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CHAPTER 1
INTRODUCTION

Welcome to BERNINA® Embroidery Software, the 
leading embroidery design application for home users. 
This is an MS Windows®-based product incorporating 
many of the conventions with which most PC users are 
already familiar.

BERNINA® Embroidery Software is unique in providing 
seamless integration with CorelDRAW® Essentials 4 by 
the Corel Corporation, the most popular vector-based 
drawing package for home users. This combination 
offers a more efficient, user-friendly approach to 
embroidery design by combining the embroidery 
capabilities of BERNINA Embroidery Software with graphical capabilities of 
CorelDRAW®. It also allows users to create not just embroidery, but true, 
multi-medium designs.

Note  CorelDRAW® Essentials 4 and its sister product, Corel 
PHOTO-PAINT® Essentials 4 can also be run as standalone applications. For a full 
description of the CorelDRAW® Essentials 4 tools, refer to the electronic User 
Guide available via the Windows Start > Programs group. Alternatively, use the 
onscreen help available from the Graphics mode Help menu.

First-time users

If you are new to BERNINA® Embroidery Software, 
you’ll be pleased with its flexible digitizing 
capabilities, the ease with which you can create and 
edit designs, and how simple it is to add or create 
your own lettering. However, before you begin 
working with the product, read the Introduction to 
Embroidery Digitizing in the Onscreen Manual. This 
chapter presents an overview of the basic concepts of 
digitizing with BERNINA Embroidery Software and 
provides you with important guidelines on how to use 
this software to achieve the best results.

You should also familiarize yourself with Basic 
Procedures. Here you will learn how to start the 
application, create or open a design, print designs, 
and how to use some of the essential tools and 
features that BERNINA Embroidery Software 
provides. The chapter Viewing Designs in the 
Onscreen Manual also provides an overview of the 
design viewing modes in BERNINA Embroidery 
Software.

Update users

BERNINA Embroidery Software is an enhanced 
version of our earlier products. It has many new and 
expanded features. Read the chapter Introduction to 
Embroidery Digitizing in the Onscreen Manual to 
familiarize yourself quickly with the scope of these 
improvements.

BERNINA® Embroidery Software 
product levels

There are two BERNINA® Embroidery Software 
product levels:

BERNINA EditorPlus

BERNINA DesignerPlus.

Caution  The product levels are controlled by the 
security device. This device is the most important and 
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valuable part of your system and should be treated 
with care.

Note  BERNINA Embroidery Software users can 
purchase software upgrades directly from the 
Internet. 

BERNINA EditorPlus

With BERNINA EditorPlus, you can edit existing 
designs and add lettering. You can also create 
attractive designs with a minimum of fuss from 
scanned artwork. Use powerful automatic digitizing 
features such as Auto Digitizer, Magic Wand and 
PhotoSnap. In addition you can:

Change color sequence for better stitchouts

Edit individual stitches to fine-tune your designs to 
a perfect finish

Use Auto Digitizer to create attractive embroidery 
automatically from scanned artwork

For greater control, use Magic Wand to convert 
shapes in pictures to stitches

Use PhotoSnap to turn photographs into line 
stitching.

BERNINA DesignerPlus

BERNINA DesignerPlus offers powerful features for 
digitizing, editing and lettering, combining both 
automatic and manual digitizing tools and methods 
for maximum control and quality. Specifically, with 
this system you can:

Use scanned or imported artwork to digitize 
designs on-screen

In addition to the automatic digitizing tools, use 
specialized digitizing tools, plus a wide range of 
artistic, decorative fill patterns

Create appliqué with Auto Appliqué

Convert any Windows TrueType font to an 
embroidery alphabet

Save all your favorite settings to templates.

Note  To identify features relevant to your specific 
model, see the BERNINA Embroidery Software 
Product Feature List in the Onscreen Manual.

BERNINA® Embroidery Software 
documentation

BERNINA Embroidery Software provides you with a 
number of ways to access information about your 
software and how to use it, both in printed form and 
onscreen via the Help menu.

Caution  Screen illustrations in the user 
documentation are intended to be representations, 
not exact duplicates of the screen layouts generated 
by the software. Procedural descriptions may be at 
slight variance from particular installations depending 
on which default system settings are activated.

Printed documentation
Depending on your product level, together with your 
BERNINA Embroidery Software installation DVD you 
will have received the following printed 
documentation:

Quick Start Guide

The BERNINA Embroidery Software Quick Start Guide 
contains installation instructions as well as an 
introduction to your BERNINA Embroidery Software. 
There is also a Quick Reference section which lists all 
the commands and shortcut keys used in the 
software. In addition, the guide provides a fully 
worked sample project. Additional tutorials are 
provided in the onscreen Quick Start Guide.

Tip  For detailed procedures covering all features of 
the BERNINA Embroidery Software (all product levels) 
and BERNINA Portfolio applications, refer to the 
Onscreen Manual which can be accessed via the Help 
menu. To identify sources of information relevant to 
your specific model, see the BERNINA Embroidery 
Software Product Feature List in the Onscreen 
Manual.

Onscreen documentation
Onscreen documentation is provided in two formats – 
HTML Help and Adobe Acrobat. Depending on your 
product level, documentation components will include 
some or all of the following:

Release Notes

A set of Release Notes is included with the software 
installation. These provide detailed information about 
new and improved features as well as direct links to 
the relevant sections of the Onscreen Manual.

Quick Start Guide

The BERNINA Embroidery Software Quick Start Guide 
is also provided in onscreen form. This provides 
additional information about product upgrades and 
updates. Additional tutorials are also provided in the 
onscreen Quick Start Guide. While the tutorials do not 
cover all product features, they provide a useful 
introduction for all product levels.
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Onscreen Manual

The Onscreen Manual provides detailed procedures 
covering all features of the BERNINA Embroidery 
Software and BERNINA Portfolio applications. It 
contains hundreds of step-by-step instructions 
together with samples and screen images. The 
BERNINA Cross Stitch and BERNINA Quilter 
applications are documented in separate 
supplementary manuals described below.

Onscreen Help

Onscreen Help provides quick access to general 
information on BERNINA Embroidery Software 
features and step-by-step instructions.

Supplementary user manuals
With your BERNINA Embroidery Software installation 
DVD you will have also received the following 
supplementary onscreen user manuals:

BERNINA Cross Stitch Onscreen Manual

This manual supplement documents the capabilities 
of the special BERNINA Cross Stitch application. Cross 
stitching is a popular technique for filling large areas 
with low stitch counts. It can also be used for outlines 
and borders. It is suitable for homeware, tablecloths, 
children’s clothes and folk designs. Cross stitch is 
sometimes combined with appliqué.

BERNINA Quilter Onscreen Manual

This manual supplement documents the capabilities 
of the special BERNINA Quilter application. Patchwork 
is a popular technique for designing and sewing 
patches into blocks. BERNINA Quilter can be used to 
design patchwork quilts, either from existing designs 
or patterns, or from designs of your own making. Use 
BERNINA Quilter to experiment with patches and 
colors enabling you create beautiful, personalized 
quilts.

Conventions used in the manual

The following conventions are adopted and used 
throughout the manual.

Commands

In this manual, commands on a menu or submenu are 
referred to by both the menu and command names. 
For example the ‘Show All’ command in the ‘View’ 
menu is referred to as View > Show All.

Dialog boxes

Dialog boxes are referred to as ‘dialogs’ and are 
shown in the manual only if they provide important 

information on using BERNINA® Embroidery 
Software. The screen images provided are intended to 
be representations, not exact duplicates of the 
layouts generated by the software.

Keyboard conventions

Viewing information onscreen

Onscreen user documentation is provided in the form 
of an Onscreen Manual and Onscreen Help.

Viewing Onscreen Help
Onscreen Help provides quick access to general 
information on BERNINA Embroidery Software 
features and step-by-step instructions.

Instruction Symbol Action

Click [ Click the left mouse button.

Right-click ] Click the right mouse but-
ton.

Double-click . Click the mouse button 
twice without moving the 
mouse.

Click OK [or j Click OK with the mouse or 
press the Enter key on the 
keyboard to complete the 
action.

Shortcut Description

C + S While holding down the Control key 
(Ctrl), press the lowercase letter S 
key.

C + V + H While holding down the Control key 
(Ctrl), press Shift and the H key.

For a complete list of keyboard shortcuts, refer to the 
Quick Reference Guide.

Select Help Topics (Help menu) to view onscreen 
help.

Select Onscreen Manual (Help menu) to view the 
onscreen manual.

Select Bernina International Home Page (Help menu) 
to view the Bernina International Web Page.

Select Bernina of America Home Page (Help menu) 
to view the Bernina of America Web Page.

Select Embroidery Online (Help menu) to view the 
Embroidery Online Web Page.
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To view Onscreen Help

1 Select Help > Help Topics to open the main Help 
window.

2 Click Contents to display the main list of topics.

Topics are grouped under high-level headings with 
‘book’ icons.

3 Double-click a book to view the list of topics, then 
double-click a topic. 

Tip  Alternatively, click Find and enter keywords 
to search on a specific subject.

Viewing the Onscreen Manual
You can read the Onscreen Manual using Adobe 
Acrobat™ Reader. This application is not supplied with 
your BERNINA Embroidery Software but it is freely 
available from the Adobe web site. Using the 
Onscreen Manual you can quickly search for the 
information you need, using standard Adobe 
Acrobat™ Reader features. 

To view the Onscreen Manual

Select Help > Onscreen Manual.

Note  If BERNINA Embroidery Software is not 
running, you can open the Onscreen Manual 
directly from Windows Explorer. To do this, 
navigate to the ..\Program 
Files\BERNINA\Embroidery Software 6\bin folder, 
and double-click UserManual.pdf.

Linking to the BERNINA® websites
You can access sales and support information about 
the products easily from within the software.

Note  You must have a correctly configured web 
browser on your system together with web access.

To link to the BERNINA® website

Connect to your Internet Service Provider (ISP).

Select Help > BERNINA Web Page.

You are directly connected to the BERNINA® 
homepage at: 

Bernina International - 
http://www.bernina.com/

Bernina of America - 
http://www.berninausa.com/

Embroidery Online - 
http://www.embroideryonline.com

http://www.bernina.com/
http://www.berninausa.com/
http://www.embroideryonline.com
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CHAPTER 2
INTRODUCTION TO EMBROIDERY

DIGITIZING

BERNINA Embroidery Software provides embroiderers with a fast, flexible way of 
creating and editing embroidery designs. This section provides an overview of the 
embroidery digitizing process as it applies to BERNINA Embroidery Software. 

The embroidery digitizing process will consist of some 
or all of the following stages:

Planning designs

Digitizing designs

Modifying designs

Improving design quality

Adding lettering

Stitching out designs

Managing designs.

Note  The Onscreen Manual provides detailed 
procedures covering all features of the BERNINA 
Embroidery Software and BERNINA Portfolio 
applications. To identify sources of information 
relevant to your specific model and any options you 
may have selected, see the BERNINA Embroidery 
Software Product Feature List.

Planning designs

To create good quality embroidery, you need to 
choose suitable artwork for use as a digitizing 
backdrop. Unless you are an experienced digitizer, do 
not use artwork which is complicated. Artwork that is 
not in digital format needs to be scanned. Possible 
sources for good embroidery design artwork include:

books

internet or CD clipart

original artwork.

Good embroidery quality
Good embroidery quality starts with the design. You 
then need a good quality machine to stitch it out. But 
even that is not enough if you do not use the correct 
fabric, threads, backings, tension, and so on. Keep 
the following points in mind when planning your 
design:

design looks good – shapes, colors, balance

stitches are neat, smooth and even

shapes are filled with correct fill and outline 
stitches

stitches are angled to match shapes

shapes are stitched correctly – no unwanted gaps

details are clearly defined

Image scanned in RGB 
color mode

Image scanned in 256 
color mode
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lettering is clear and easy to read.

The stitched-out design should also have the following 
characteristics:

The design stitches out efficiently on the machine.

The fabric has not puckered around the stitched 
areas.

The design is free of loose ends.

See also Tips & Tricks.

Preparing to digitize
Before digitizing, you need to analyze and plan design 
shapes and stitching sequence carefully. Design 
shapes need to be clearly defined to make them easy 
to embroider. The easiest shapes to embroider have a 
relatively constant width, with smooth edges, no 
sharp turns and no small, protruding details.

Design sequence
The design sequence is the order in which objects are 
created and therefore the order in which they are 
stitched out. You can change the sequence of objects 
in the design to improve sewing – for example, to 

minimize color changes. Details should be stitched 
last. See Sequencing objects for details.

Stitch types
Decide which stitch types you will use for each design 
shape. While you normally set stitch type before 
digitizing each shape, BERNINA Embroidery Software 
lets you change them at any stage. See Outline & Fill 
Stitches for details.

Digitizing designs

Digitizing allows you to build designs from basic 
shapes using the various tools available. Digitize 
shapes manually by marking reference points along 
an outline or use the automatic digitizing tools to 
create ‘embroidery objects’ automatically. All designs 
created in BERNINA Embroidery Software are 
composed of ‘objects’ which have their own unique 
sets of ‘properties’. The most important property of an 
embroidery object is its stitch type.

Details are clearly 
defined

Stitches are neat, 
smooth and even

Shapes are filled with
correct fill and outline

stitches

Stitches are angled to
match shapes

Design looks good –
shapes, colors, balance

Shapes are stitched 
correctly – no 
unwanted gaps

Lettering is clear and
easy to read

Simplify edges in artwork 
before or during digitizing

1

2

3
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Viewing designs

While digitizing, different viewing modes are available 
for different purposes. Depending on your product 
level, BERNINA Embroidery Software provides a 
number of viewing modes which are accessed via the 
View Mode toolbar.

The application has one workspace or ‘Design 
Window’ but you interact with it in separate modes. 
See Viewing modes for details.

Use grid lines and hoop to help accurately place, align 
or size embroidery objects. You can show or hide the 
grid and hoop. There are many hoop sizes available to 
suit the size of your design. See Displaying the grid 
and Displaying the hoop.

Use the Overview Window and Zoom functions to 
quickly examine your design at different degrees of 
magnification. See Zooming and panning for details.

When working with embroidery designs, you need to 
understand the stitching sequence. You can check a 
design’s stitching sequence by ‘traveling’ through it 
by stitches, colors or objects. You can also check the 
sequence by slowly redrawing your design on screen. 
See Viewing the stitching sequence for details.

In BERNINA Embroidery Software, you can change 
the background color of the Design Window to match 
the color of your fabric. Or you can select a 

background fabric for more realistic previews and 
presentations. See Changing backgrounds for details.

Selecting objects
BERNINA Embroidery 
Software provides various 
means for selecting the 
objects comprising an 
embroidery design. These 
include techniques such as 
point and click, bounding 
box selection, and multiple 
object selection. You can 
select all objects in a design 
or individual ones for precise modification. BERNINA 
Embroidery Software allows selection of object 
outlines or fill stitches. See Selecting Objects for 
details.

Hooping designs
Fabrics must be hooped before 
stitching out on the machine. 
BERNINA Embroidery Software 
allows you to select from a wide 
range of standard 
factory-supplied hoops. If your 
project contains a large design or 
a number of smaller designs, you 
may need to use multiple 
hoopings. If you have a hoop 
which does not appear in the list, 
you can define a custom hoop 
from scratch or based on a 
standard hoop. See Hooping 
Designs for details.

Digitizing methods
In BERNINA Embroidery 
Software, you build designs 
from basic shapes or 
‘embroidery objects’. The 
process of creating embroidery 
objects on-screen is called 
‘digitizing’. Like creating designs 
in graphics applications, this 
involves the use of different 
digitizing tools or methods. 
These are used in conjunction 
with stitch types to create 
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embroidery objects. Digitizing tools in BERNINA 
Embroidery Software are similar to drawing tools 
except that the end result is an embroidery object 
rather than a drawing object. See Digitizing Methods 
for details.

Outline and fill stitches
All embroidery objects in 
BERNINA Embroidery Software 
have defining settings or 
‘properties’, the most important 
of which is the stitch type. 
Whenever you create or modify 
an object, stitches are 
generated according to the 
associated stitch type. Stitch 
settings such as spacing and 
length can be adjusted before or 
after digitizing.

Stitch types divide broadly into 
two categories – ‘outline’ and 
‘fill’. Outlines are used, as the 
name suggests, for outlines or borders of shapes and 
for details. Fill stitches are used cover to large areas 
or ‘color blocks’ in a design. Outline and fill stitches 
are generated whenever you create embroidery 
shapes, but they can be changed at any stage. See 
Outline & Fill Stitches for details.

Thread colors and charts
When you digitize, you 
select thread colors for 
each object you create from 
the Color Palette in the 
Design Window. The palette 
contains a selection of 
thread colors tailored to 
each design. This color 
scheme represents the 
actual threads in which the 
design will be stitched. You 
can select colors from commercial thread charts 
containing a range of colors from different 
manufacturers. To save time when setting up new 
color schemes, you can create and print your own 
thread chart using your favorite or most frequently 
used colors. In BERNINA Embroidery Software you 
can search for particular threads by various criteria. 
Even match threads automatically from selected 
charts to colors in your design. See Thread Colors & 
Charts for details.

Object properties and templates
The properties of embroidery 
objects define general 
characteristics such as size and 
position, as well as 
embroidery-specific 
characteristics such as stitch 
type and density. The particular 
stitch settings determine how 
stitches will be regenerated when 
you reshape, transform or scale 
an object.

When you create an embroidery 
object, you can accept default 
settings for the particular 
digitizing method, or apply new 
ones. Default settings are stored 
in the design template. You can also define ‘current’ 
properties to influence all the objects you create in 
the current design. See Object Properties & Templates 
for details.

Improving stitch quality
BERNINA Embroidery Software 
provides many settings to help 
improve the quality and efficiency 
of your final stitchout. Use fabric 
settings so that the machine will 
take into account the type of 
fabric you are stitching on. Use 
Auto Underlay to help stabilize 
fabric and reduce distortion due 
to the pull effect. Adjust the 
amount of overstitching you need 
by varying the pull compensation 
setting. This is handy if you want 
to stitch a design on fabrics with varying degrees of 
stretch. 

By applying Auto Jump, you can preserve long 
stitches in objects by turning them into a series of 
jumps. By default, tie-in stitches are automatically 
inserted at the start of objects to prevent stitches 
from unraveling. You can control tie-in/offs settings 
for whole designs or particular objects. Use Auto 
Start and End to set the positions of first and last 
stitches in a design. All these features are object 
properties, and can be applied, removed or modified 
at any time. See Stitch Quality for details.

Digitizing with artwork

Remember, to create good quality embroidery, you 
need to choose suitable artwork for use as a digitizing 
backdrop. Possible sources include books, internet or 
CD clipart, or your own artwork. Once imported into 
BERNINA Embroidery Software, use it as a ‘backdrop’ 
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for manual digitizing or automatically convert shapes 
or whole designs into embroidery objects.

Digitizing with backdrops
Electronic artwork in both bitmap 
and vector formats can be loaded, 
pasted or scanned into BERNINA 
Embroidery Software for use as 
digitizing templates or 
‘backdrops’. Textured 
backgrounds can also be imported 
to show what a design will look 
like on real fabric. Almost any 
artwork can be used – photographs, magazine 
pictures, clipart drawings, and even fabric samples. 
See Digitizing with Backdrops for details.

Processing images for automatic digitizing
BERNINA Embroidery Software 
supports the automatic and 
semi-automatic digitizing of 
bitmap images. The quality of 
the resulting designs greatly 
depends on the type and 
quality of the original artwork. 
In order to make bitmap 
images more suitable for 
automatic digitizing, BERNINA 
Embroidery Software also provides image processing 
capabilities and links to graphics packages. See 
Image Processing for details.

Automatic digitizing
Through its integration with 
CorelDRAW®, BERNINA 
Embroidery Software 
provides powerful 
inter-conversion of vector 
and embroidery objects. The 
Convert Vectors to 
Embroidery tool converts fill 
or outline properties of 
selected vector graphics to 
fill or outline stitch types 
respectively. It can be 
applied to text as well as vector graphics.

BERNINA Embroidery Software also provides a Magic 
Wand tool for quickly creating embroidery that does 
not require particular artistic effects or 
embroidery-specific knowledge directly from 
electronic artwork. This in turn frees you to spend 
more time on the artistic or inherently complicated 
areas of your designs. The Auto Digitizer tool 
automatically converts artwork to fully digitized 
embroidery with little or no intervention. With this 
tool, novice embroiderers can create simple designs 
quickly and easily. Similarly, experienced 

embroiderers can improve productivity when working 
with simple designs. Use PhotoSnap to create 
embroidery from photographs and other images. See 
Automatic Digitizing for details.

Modifying designs

After digitizing a design, you can modify it as a whole, 
edit individual objects and even individual stitches.

Combining and sequencing objects
BERNINA Embroidery 
Software lets you easily 
combine designs and 
design elements by 
inserting the contents of 
one file into another. You 
can also add to designs 
quickly by copying or 
duplicating existing 
objects. Group selected 
objects or entire designs to 
keep them together for moving, scaling or 
transforming purposes. See Combining & Sequencing 
Objects for details.

The embroidery objects in a design form a ‘stitching 
sequence’. Initially, objects are stitched in the order 
they were created. However, you can change this by 
a variety of methods. For example, change the 
position of a selected object by cutting it, then pasting 
it somewhere else in the sequence. There are also 
techniques available to sequence objects ‘as selected’ 
or as ‘color blocks’. You can also resequence objects 
using the Color Film. See Sequencing objects for 
details.

The Stitch Sequence feature improves the quality and 
efficiency of the stitchout by minimizing the number 
of hoopings, color changes, and trims. All existing 
overlaps are preserved by the operation. See 
Auto-sequencing entire designs for details.

Arranging and transforming objects
BERNINA Embroidery 
Software allows you to 
arrange and transform 
objects by a variety of 
means, both interactive and 
numeric. Position objects by 
means of click and drag, 
arrow keys or object 
properties. Align objects 
relative to each other using 
the special tools available. 
Scale objects directly on-screen or by setting exact 
dimensions or scale percentages. Rotate, skew and 
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mirror objects by similar means. Special tools allow 
you to duplicate and transform selected embroidery 
objects, as well as create mirrored and rotated 
objects around a central axis. See Arranging & 
Transforming Objects for details.

Reshaping and editing objects
BERNINA Embroidery Software 
lets you modify object shapes, 
stitch angles and entry and exit 
points by means of control 
points. Stitch angle lines and 
entry and exit markers all 
appear around selected objects. 
Control points vary slightly with 
the object type. See Reshaping 
& Editing Objects for details.

Editing stitches
With BERNINA Embroidery 
Software designs, stitches 
are automatically generated 
from design outlines and 
properties. This means you 
can scale, transform and 
reshape designs without 
affecting stitch density or 
quality. However, BERNINA 
Embroidery Software also lets you edit individual 
stitches. You simply select and manipulate them like 
any other object. For example, you can insert stitches 
in an object to fill gaps, or move and delete individual 
or clusters of selected stitches. You may need to do 
this, for example, when working with ‘stitch files’ 
which do not contain design outline data. Where 
possible, however, edit the object properties rather 
than individual stitches. See Editing Stitches for 
details.

Advanced digitizing

BERNINA Embroidery Software provides a number of 
powerful productivity features as well as special 
effects and digitizing techniques for advanced 
embroiderers.

Specialized digitizing techniques
BERNINA Embroidery 
Software provides 
specialized digitizing 
features to create 
special effects as well 
as save time while 
you digitize. There 
are tools for creating 
designs with a 
hand-drawn 
appearance, something which is difficult to achieve 
through conventional digitizing methods. See 
Specialized Digitizing Techniques for details.

There are tools for reinforcing 
outlines, cutting holes in objects, 
removing underlying stitching, as 
well as filling holes. Quickly create 
outline stitching around selected 
objects or entire designs with 
Single, Triple or Satin Line. There 
are also specialized tools for 

quickly and easily creating buttonholes. See also 
Creating buttonholes.

Artistic stitch effects
BERNINA Embroidery Software 
provides many artistic effects and 
stitch types to create textured and 
patterned fill stitching. Fancy Fill is 
a decorative fill stitch, based on 
Step Fill, in which the needle 
penetrations form a tiled pattern. 
See Creating fancy fills for details.

Use Textured Edge to add rough 
edges to objects, create shading 
effects, or imitate fur or other fluffy 
textures in your design. See 
Creating textured edges for details.

Wave Effect 
lets you contour fill stitches along a 
digitized guideline. Stitches follow 
the line but maintain uniform 
density and needle penetration 
patterns. See Creating wave 
effects for details.

Gradient Fill varies stitch spacing 
between dense and open fill, 
producing shading effects which are 
difficult to achieve manually. See 
Creating gradient fills for details.
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Apply Travel on Edges effect to 
force underlying travel runs to the 
edges of an object so that they 
can’t be seen through open 
stitching. See Creating open fills for 
details.

Use the Color 
Blending effect to create different 
shading, perspective, 
three-dimensional and color effects 
by blending two colored layers in 
an embroidery object. See Creating 
color blending effects for details.

Pattern runs and fills
Patterns are 
pre-defined design 
elements, such as 
hearts, leaves or border 
patterns, that can be 
quickly inserted into a 
design. They generally 
consist of one or more 
simple objects, and are 
stored in a special 
pattern set.

Use the patterns 
provided with the 
software or create your own. Patterns can be scaled, 
rotated and mirrored in the same way as other 
objects. You can use patterns along a digitized line. 
You can also fill shapes with rows of repeated 
patterns, and apply special effects. See Patterned 
Stamps, Runs & Fills for details.

Craft stitch borders and fills
BERNINA Embroidery Software provides a range of 
craft stitches which you can use to mimic some 
traditional hand-worked embroidery. These include a 
large range of blackwork and candlewicking patterns 
suitable for both outlines and fills. 

Backstitch and stemstitch are two versatile outline 
stitches. Backstitch forms a continuous thin line, 
similar to machine stitching, while stemstitch 
produces rope-like lines which can vary in thickness 

depending on stitch angle. Both can be used to make 
a smooth continuous row of stitching suitable for 
outlines and for blackwork. Lacework and stipple are 
two decorative fill stitches. Lacework can be used to 
give a lacey look to objects such as flowers. Stippling, 
also known as vermicelli, is a free flowing run stitch 
that can be used for decorative effects or to produce 
quilting. See Craft Stitch Borders and Fills for details.

Digitizing for appliqué
Appliqué is an important 
craft in home sewing, and 
the Auto Appliqué 
feature provides an easy 
way to create high quality 
work. Use Auto Appliqué 
to generate all the 
stitching you require for 
closed-object appliqué. 
Up to four layers of stitching – placement line, cutting 
line, tackdown and cover stitch – are generated. 
Using the Partial Appliqué tool, you can create 
appliqué objects with partial cover stitching to create 
overlaps without doubling-up borders. See Digitizing 
for Appliqué for details.

Sometimes you require 
added flexibility to extend 
the range of designs that 
can be sewn. For 
instance, designs 
containing open-objects 
cannot be handled by 
Auto Appliqué. To this 

end the special Advanced Appliqué tool allows you 
to generate ‘open-object appliqué’ from one or more 
source or ‘primary’ objects. See Creating open-object 
appliqué for details.

Embroidery lettering

Create top-quality lettering quickly and simply. 
BERNINA Embroidery Software provides a large range 
of scalable closest-join alphabet styles and 
multi-color and fancy stitching alphabets to choose 
from. Select from the supplied alphabets or convert 
TrueType fonts for use as embroidery alphabets. See 
Alphabet Samples for details.
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Lettering essentials
Add lettering to designs 
quickly and easily, either 
on-screen using the current 
settings or via object 
properties. Place lettering 
on a straight horizontal or 
vertical baseline, curve it 
around a circle or arc, or 
digitize your own baselines. 
You can apply formatting to lettering objects in the 
same way as a word processor, including italics, 
bolding, and right/left justification. Letter, word and 
line spacings can be determined before or after 
creating lettering objects and placing them in your 
design. See Lettering Essentials for details.

Editing embroidery lettering
BERNINA Embroidery 
Software gives you both 
interactive and precise 
numeric control over many 
attributes affecting 
lettering objects. You can 
adjust lettering objects as 
a whole as well as 
individual letters. Lettering 
text can be edited directly 
on-screen or by means of 
object properties. When you first create lettering, it 
may be too big or small. Size can be adjusted 
interactively or numerically. Small, narrow letters 
may not require underlay, depending on their size and 
the fabric to be used. Use the available tools to skew 
and rotate lettering objects. Adjust individual letters 
like any other embroidery object. Reshape letters, 
adjust stitch angles, and recolor letters individually. 
Baselines can be modified after placement directly 
on-screen or via object properties. See Editing 
Embroidery Lettering for details.

Special lettering effects
All TrueType fonts installed on 
your computer are also 
available to you when placing 
lettering in your designs. 
BERNINA Embroidery 
Software lets you add special 
characters to your lettering 
which do not appear on the 
keyboard. BERNINA 
Embroidery Software also 
provides a number of special alphabets for fancy 
lettering as well as monogramming. Like all 
embroidery objects, each lettering object has its own 
properties. You can adjust these before or after 
creating lettering objects. BERNINA Embroidery 

Software also gives you precise control over the stitch 
angles of individual letters. Apply Elastic Lettering 
effects to lettering objects to make them bulge or 
arch, stretch or compress. See Special Lettering 
Features for details.

Monogramming
A ‘monogram’ is a 
design composed of 
one or more letters, 
typically the initials of 
a name, used as an 
identifying mark. The 
Monogramming 
feature offers a 
simple way to create 
personalized 
monograms using a 
selection of 
pre-defined 
monogramming styles, border shapes and 
ornaments, together with a set of tools to help you 
place these elements in creative and decorative ways. 
See Monogramming for details.

Design processing

At some stage you will actually want to output your 
designs to printer, machine, or storage device. For 
this, you will need an understanding of the different 
print options, embroidery file types and the storage 
media available.

Outputting designs
You can output embroidery 
designs in a variety of ways 
– by printing as 
worksheets, as appliqué 
patterns, color films, or as 
thread charts. BERNINA 
Embroidery Software also 
allows you to save your 
designs as images for use with fabric and garment 
applications. You can also send them directly to 
machine for stitching. When working with designs 
that are larger than the available physical hoop, you 
can split them into parts, each containing an object or 
group of objects. The software automatically 
calculates which files are to be sent and shows you 
how they will look. See Outputting Designs for details.
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Storing and retrieving designs
By default BERNINA 
Embroidery Software saves 
designs to its native ‘ART’ file 
format. This format contains 
all information necessary 
both for stitching a design 
and for later modification. 
However, BERNINA 
Embroidery Software can 
open and save designs in 
other formats as well. When 
doing so, BERNINA Embroidery Software converts 
design data so you can modify it using the full range 
of software features. When you send designs directly 
to machine, they will be lost when the machine is 
turned off. Apart from saving to hard disk, floppy disk 
or archiving to CD, you can also preserve designs by 
writing them to embroidery machine memory, design 
card, or USB memory stick. If you have a Magic Box, 
you can read from and write to other design cards as 
well. See Reading & Writing Design Files for details.

Design management

BERNINA Portfolio provides an efficient way for 
viewing and managing embroidery designs. This 
design management tool can access design files 
stored on your computer hard disk, CD-ROM, or 
floppy disk. BERNINA Portfolio even lets you view 
design files in folders which have been archived by 
means of the popular WinZip utility. It recognizes all 
design file formats used by BERNINA Embroidery 
Software. See BERNINA Portfolio Basics for details.

Designs in BERNINA Portfolio folders can be sorted in 
various ways. This is useful when you want to select 
designs for stitching out, printing, archiving, and so 
on. Once a design is selected in an BERNINA Portfolio 
folder, you can send it direct to an embroidery 
machine. You can also convert ART and other design 
files to and from other file formats. Catalogs of 

designs in a folder contain thumbnails and/or 
summary information. These can be sent to a printer 
and published in a variety of formats. BERNINA 
Portfolio lets you archive and view design files in 
folders which have been archived by means of the 
popular WinZip utility. This can be useful for sending 
or receiving multiple files via email. See BERNINA 
Portfolio Advanced for details.
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PART I
THE BASICS

Designs created in BERNINA Embroidery Software are composed of ‘embroidery 
objects’. They are called ‘objects’ because they are discrete entities which can be 
manipulated independently of each other. Each object has certain defining 
characteristics or ‘properties’ such as color, size, position, and so on. The most 
important property of an embroidery object is its stitch type.

Introduction to embroidery digitizing

BERNINA Embroidery Software provides embroiderers with a fast, flexible way of 
creating and editing embroidery designs. This section provides an overview of the 
embroidery digitizing process as it applies to BERNINA® Embroidery Software. See 
Introduction to Embroidery Digitizing for details.

Basic procedures

This section describes how to start BERNINA Embroidery Software and access the 
available commands and tools. It covers basic procedures to do with opening, creating 
and saving design files. It explains how to activate hoops and grids and it covers 
accessing object properties. See Basic Procedures for details.

Viewing designs

This section explains the design viewing modes available in BERNINA Embroidery 
Software as well as the various design viewing settings. It describes zooming and 
panning as well as how to view the stitching sequence. It covers displaying design 
backdrops and changing backgrounds. It also explains how to obtain information about 
your designs. See Viewing Designs for details.

Selecting objects

This section describes how to select objects using the selection tools and keyboard. It 
also shows how to select color blocks or individual objects using the Color Film. See 
Selecting Objects for details.

Hooping designs

This section describes how to choose and display hoops in BERNINA Embroidery 
Software. It covers creating and modifying custom hoops. It also deals with hooping 
large designs. See Hooping Designs for details.

Hardware and software setup

This section describes how to set up embroidery machines, and scanners and describes 
how to calibrate the monitor. It also deals with changing grid spacing and hoop options. 
The setting of general options – such as automatic save, pointer position display 
options, etc – is also covered. See Hardware & Software Setup for details.
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CHAPTER 3
BASIC PROCEDURES

To start using BERNINA Embroidery 
Software, you need to know the basic 
procedures, such as starting up, opening 
and creating designs, and saving. Once 
you start BERNINA Embroidery Software, 
you use commands or icons, and dialogs to 
complete your tasks. You select commands 
in the same way as other MS Windows® 
applications – from menus or toolbars. 

BERNINA Embroidery Software opens a 
range of native ART files, as well as some 
other embroidery file formats, from computer hard disk, USB stick, or CD-ROM. 
BERNINA Embroidery Software gives you a wide range of standard 
factory-supplied hoops to select from. Grid lines help you accurately align or size 
embroidery objects. The most important dialog in BERNINA Embroidery Software 
is the Object Properties dialog. This and the Effects dialog are ‘modeless’, 
meaning that they stay on the Design Window as long as you need them. 

Note  This section describes how to start BERNINA Embroidery Software and 
access the available commands and tools. It covers basic procedures to do with 
opening, creating and saving design files. It explains how to activate hoops and 
grids and it covers accessing object properties.

BERNINA Embroidery Software 
interface

BERNINA Embroidery Software integrates with 
CorelDRAW® Essentials 4 into a single application, 
allowing users to create, not just embroidery, but 
true, multi-medium designs. The application has one 
workspace or ‘Design Window’ but you interact with it 
in separate operating modes: Art Canvas and 
Embroidery Canvas. A third mode, Hoop Layout, 
is available for multi-hooping large designs. See also 
Viewing modes.

Starting BERNINA Embroidery Software

BERNINA Embroidery Software can be opened via the 
desktop icon or MS Windows® Start menu. It defaults 
to Embroidery Canvas mode. This mode allows you 
to create and edit embroidery objects using the 
embroidery digitizing toolset.

To start BERNINA Embroidery Software

Double-click the BERNINA Embroidery Software 

shortcut icon on the MS Windows® desktop or 
select it via the Windows Start > Programs 
group.

Double-click to start BERNINA® Embroidery 
Software.



Chapter 3 : Basic Procedures

BERNINA® Embroidery Software : Onscreen Manual 16

BERNINA Embroidery Software opens in 
Embroidery Canvas mode with a new, blank 
design (Design1). The screen image below 
displays an exploded view of all toolbars in the 

BERNINA DesignerPlus product. Depending on 
your product level, you will have access to some or 
all of these options.

Note  Toolbars are dockable left, right, top and 
bottom, and can be ‘floated’ anywhere in the 
Design Window. While the Stitch and Color Bar 
can be docked vertically, the Outline and Fill 
dropdown lists are not displayed. Therefore, it is 
advisable to dock the bar only horizontally. See 
also BERNINA Embroidery Software Quick 
Reference.

Customize the Design Window by showing or 
hiding the grid, changing the grid dimensions, as 
well as showing and hiding toolbars. See 
Displaying the grid for details.

Docking panes
BERNINA Embroidery Software includes ‘dockers’ for 
key functions. Embroidery Canvas has docking 
panes for Color Film, Carving Stamps, Morphing 

Effects, and an Overview Window. All panes are 
dockable at the right side of the Design Window.

Dockers can be ‘nested’ to increase available 
workspace. When nested, tab buttons for each dialog 
appear to the side. All dockers can be fixed or 
minimized. By hovering the mouse over the tab, a 
minimized docker will ‘fly out’, allowing you to access 
its functions. It automatically minimizes when not in 
use. Dockers may also be ‘floated’ by dragging the 
caption bar to the Design Window or double-clicking 
it when ‘pinned’ in place.

Menu bar

General toolbar

Title bar

Status bar

Design Window

Stitch and Color Bar

Edit toolbar

Digitize toolbar

Arrange toolbar

Craft Stitch toolbar

View Mode toolbar

Nested dockers
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Status bar
A Status Bar at the bottom of the Embroidery 
Canvas Design Window provides continuous display 
of current cursor position status as well as 
instructions for use of selected tools.

Information displayed includes:

Prompt message: guides you through use of 
selected functions

Design width and height

Coordinates of current needle position (X/Y), and 
length (L) and angle (A) of current stitch. See also 
Measuring distances onscreen.

Stitch count: total number of stitches in design

Zoom factor

File type: indicates grade of ART design – 
BERNINA Embroidery Software native ART designs 
are classified in four grades depending on how the 
file was created. See Embroidery design formats 
for details.

Working with design files

By default BERNINA Embroidery Software saves 
designs to its native ‘ART’ file format. This format 
contains all information necessary both for stitching a 
design and for later modification. BERNINA 
Embroidery Software opens a range of native ART 
files, as well as some other embroidery file formats, 
from computer hard disk, USB stick, or CD-ROM. You 
can save designs in ART as well as other file formats. 
See Reading & Writing Design Files for details.

Caution  You cannot open ART files created with a 
later version of the software to the one you are 
running. If you attempt to, you will be prompted to 
update your system to the current version.

Opening designs

BERNINA Embroidery Software opens a range of 
embroidery files in addition to its own ART format. 
Native ART designs are classified in four grades 
depending on how the file was created. See also 
Starting BERNINA Embroidery Software.

Note  By default, designs are automatically grouped 
upon opening or insertion into another design. See 
Setting other general options for details.

To open a design

1 Click the Open icon.

The Open dialog opens.

2 Select a folder from the Look In list.

Note  You can read designs stored on USB stick or 
CD-ROM, as well as computer hard disk.

3 If the design is not in ART format, select a file type 
from the Files of Type list.

4 Select a design or designs.

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

5 Select the Preview checkbox to preview the 
design (for supported file formats) together with 
design data. This includes stitch and color 
numbers, design height and width, and software 
version number.

6 Click Open.

Note  You can also read designs from your 
embroidery machine memory or BERNINA design 
card. If you have a Magic Box, you can read from 
other design cards as well. See Reading & Writing 
Design Files for details.

Use Open (General toolbar) to open an exist-
ing design.

Measurement indicators:
X, Y, L and A

Prompt message Design width and height

Stitch count File type

Zoom factor

Native ART design
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Starting new designs

When you start BERNINA Embroidery Software, a new 
file – Design1 – is automatically created, ready for 
you to start digitizing. By default, Design1 is based 
on the NORMAL template. Templates contain pre-set 
styles, defaults or objects, to make digitizing quicker 
and easier. When you create a file based on a 
template, the template’s values are copied to the new 
design. You can also select a custom template to base 
your new design on. See also Object Properties & 
Templates.

To start a new design

Click the New icon.

A blank design opens in the Design Window based 
on the NORMAL template. 

To use a custom template, select File > New.

If there are templates additional to the default, the 
New dialog will appear. 

Select a template from the list and click OK. See 
also Object Properties & Templates.

Saving designs

BERNINA Embroidery Software designs can be saved 
in pure ART format as well as a number of non-native 
formats. Saving a design records its file name, 
location and format, and updates it with any changes 
you make. When you save an existing design under a 
new name, to a different location or format, you 
create a copy of the original design. See also Reading 
& Writing Design Files.

Tip  Save your designs early and often. Do not wait 
until you finish working. To save changes to an 
existing file but preserve the original, use Save As. 
Once you have saved a design, every time you click 
Save on the toolbar the file will be updated.

To save a design

1 Click the Save icon.

If this is the first time you have saved the design, 
the Save As dialog opens.

2 Select the folder where you want to save the 
design from the Save In list.

3 Enter a name for the design in the File name field.

4 Select a file format from the Save as type list. 
See also Supported embroidery file formats.

5 Click Save.

Note  You can also write designs to your 
embroidery machine memory or BERNINA design 
card. If you have a Magic Box, you can write to 
other design cards as well. See Reading & Writing 
Design Files for details.

Sample designs and artwork
BERNINA Embroidery Software contains hundreds of 
ready-to-stitch designs including many new attractive 
ornaments, samples and digitizing backdrops. Design 
files (ART files) and images (BMP, JPG, and WMF files) 
can be found in your My Designs - Embroidery 
Software 6 folder. See also Digitizing with Backdrops 
and Viewing design information in the Onscreen 
Manual.

BERNINA Portfolio displays embroidery design 
thumbnails and limited design information. You can 

Use New (General toolbar) to start a new 
design with the NORMAL template. 

Use Save (General toolbar) to save the cur-
rent design.

Select required 
template

Format 

Design 
name

Folder 
containi
design
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filter the contents of the display window to show only 
certain embroidery file types. See Browsing designs in 
folders for details. 

CorelDRAW® Essentials 4 itself is packaged with a 
selection of clipart which can be used as digitizing 
backdrops or converted directly into embroidery. See 
also Browsing clipart.

Caution  Included artwork (clipart) and embroidery 
designs can only be used for personal use – i.e. they 
cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery 
to clipart – does not remove copyright protection.

Hoops and grids

Fabrics should be hooped before stitching out on the 
machine. BERNINA Embroidery Software gives you a 
wide range of standard factory-supplied hoops to 
select from. Grid lines help you accurately align or 
size embroidery objects.

Displaying the hoop

Whenever you create a new design, a single hoop 
representing the one you attach to your embroidery 
machine appears by default in the Design Window. As 
you position objects, the hoop position adjusts 
automatically so that it is always centered around 
objects in the window. See also Hooping Designs.

To display the hoop

Click the Show Hoop icon to turn on the hoop 
display.

Click the Show Hoop icon again to turn off the 
hoop display.

Displaying the grid

Use grid lines to help accurately align or size 
embroidery objects. You can show or hide the grid.

Tip  You can change the grid spacing, select a 
reference point and turn Snap to Grid on or off in the 
Options dialog. See Setting grid options for details.

Click Show Hoop (General toolbar) to view the 
hoop. Right-click to change settings.

Click Show Grid (General toolbar) to show or 
hide the grid. Right-click to change the Grid 
settings.
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To display the grid

Click the Show Grid icon to turn on the grid 
display.

Click the Show Grid icon again to turn off the grid 
display.

Measuring distances onscreen
Measure the distance between two points in the 
Design Window using the Measure command. This 
command displays coordinates, distance and angle of 
the mouse pointer from a point corresponding to the 
center of a hoop in an empty design. View the 
measurements in the Status Bar or in a tooltip. See 
Interpreting pointer position values for details.

Tip  For more accurate results, zoom in before you 
measure. The measurement is always the actual size, 
and is not affected by the zoom factor.

To measure a distance onscreen

1 Select View > Measure or press M.

2 Click the start point.

3 Move the pointer to the end point and hold the 
mouse still.

The following information displays in the Status 
Bar:

Position coordinates of the end point (X=, Y=).

Length of the measured line (L=).

Angle of the line relative to the horizontal 
(A=).

Measurements are shown in millimeters or inches, 
depending on the option selected in the 

MS Windows® Control Panel. See your 

MS Windows® documentation for more 
information.

Tip  If activated, length and angle measurements 
will also appear in a tooltip. See Setting other 
general options for details.

4 Press Esc to finish.

Using commands and tools

Once you start BERNINA Embroidery Software, you 
use commands or icons, and dialogs to complete your 
tasks. You select commands in BERNINA Embroidery 
Software in the same way as other MS Windows® 
applications – from menus or toolbars. Keyboard 
shortcuts are also available for the most frequently 
used commands. See Keyboard Shortcuts for details.

Selecting commands from toolbars
Toolbars provide quick and easy access to BERNINA 
Embroidery Software commands. Click a toolbar 
button to activate a command or, where applicable, 
right-click to set its properties.

To select commands from toolbars

Rest the pointer over an icon to see its name in a 
‘tooltip’.

Click the icon to activate the command.

Right-click to adjust settings or activate the 
secondary command.

If the icon has both left and right-click 
commands, the name is split with a slash (/). 
For example, the Scale by 20% Down/Up 
icon lets you scale objects down by 20% when 
you click it, or scale objects up by 20% when 
you right-click.

For many tools, right-click accesses current 
command settings. For example, left-click 
Lettering/Values selects Lettering as the 
input method, while right-click accesses the 
Object Properties dialog.

Measurements 
appear as tooltip 
or in Status bar
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Note  Object properties can be modified with or 
without objects selected. The former affects only 
selected objects. The latter affects current 
settings. See also Applying and managing object 
properties.

Undoing and redoing commands

You can undo the effects of most commands. If you 
change your mind, you can redo them again. 
BERNINA Embroidery Software remembers the last 
few commands you used.

To undo and redo a command

To undo a command, click the Undo icon.

When BERNINA Embroidery Software cannot 
remember more commands, Undo is dimmed.

Click the Redo icon to re-apply an ‘undone’ 
command.

Moving and docking toolbars
Toolbars provide quick and easy access to BERNINA 
Embroidery Software commands. Toolbars are 
‘dockable’. This means you can move them around the 
Design Window.

To move or dock a toolbar

To move a toolbar to a more convenient location, 
click and drag it:

Toolbars are dockable left, right, top and 
bottom.

They can be ‘floated’ anywhere in the Design 
Window.

To dock it in its normal position, double-click the 
toolbar title.

Accessing object properties

Designs created in BERNINA Embroidery Software are 
composed of ‘embroidery objects’. They are called 
‘objects’ because they are discrete entities which can 
be manipulated independently of each other. Each 
object has certain characteristics or ‘properties’ such 
as color, size, position, and so on. The most important 
dialog in BERNINA Embroidery Software is the Object 
Properties dialog. See also Applying and managing 
object properties.

To access object properties

Open the Object Properties dialog by any of the 
following means:

Click the Object Properties icon.

Select Settings > Object Properties.

Use Undo (General toolbar) to undo a com-
mand.

Use Redo (General toolbar) to reapply a com-
mand which has been ‘undone’.

Use Object Properties (General toolbar) to set 
current properties or properties of selected 
objects.
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Double-click or right-click any object in the 
Design Window.

Select a tab to access the object property set you 
want to adjust.

Use fields, dropdown lists, radio buttons, 
checkboxes, and slider controls to key in or adjust 
settings.

Click the Effects button to access a separate set 
of more specialized object property settings such 
as Underlay, Textured Edge, Gradient Fill, etc.

Note  This dialog, in turn, includes a Properties 
button which opens the Object Properties 
dialog. You can choose to close the Object 
Properties dialog automatically whenever the 

Effects dialog is opened, and vice versa. See 
Setting other general options for details.

Tip  Graphic tips are incorporated into the Object 
Properties dialog to give you visual feedback on 
particular settings. These are displayed whenever 
you hover the mouse over a control. For example, 
with the mouse placed over the Stitch Spacing 
control, a graphic tip appears beside it.

Apply settings by means of the Apply button at 
the bottom of the dialog or by pressing Enter.

If one or more objects are selected, changes 
are applied to all relevant objects.

If no objects are selected, changes are made to 
the current settings – these will affect any 
newly created objects.

If you have modified settings on a number of 
tabs, all changes that can be applied will be 
applied.

Click the Save to Template button to save 
settings to the current template.

These become the defaults whenever you create 
new files based on this template. See Managing 
design templates for details.

Click the Discard button or press the Esc key to 
discard any changes.

Click OK to close the dialog and apply any pending 
changes.
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CHAPTER 4
VIEWING DESIGNS

BERNINA Embroidery Software provides many viewing features to make it easier 
to work with your design. Zoom in on an area to see more detail or view the 
design at actual size. Show or hide various design elements with the available 
display settings. Preview an existing design in different colors on different fabrics.

When working with embroidery designs, you need to understand the stitching 
sequence. You can check a design’s stitching sequence in BERNINA Embroidery 
Software by ‘traveling’ through it stitch-by-stitch. You can also check the 
sequence by simulating the design stitchout onscreen.

BERNINA Embroidery Software also provides information about designs in a 
variety of ways and formats. Before even opening BERNINA Embroidery Software 
or your design, you can check some design information for ART files directly from 
MS Windows® Explorer. You can view stitching details about a design in the 
Design Properties dialog. Also the Print Preview provides essential design 
information, including a design preview, the size of the design, color sequence 
and any special instructions.

This section explains the design viewing modes available in BERNINA Embroidery 
Software as well as the various design viewing settings. It describes zooming and 
panning as well as how to view the stitching sequence. It covers displaying design 
backdrops and changing backgrounds. It also explains how to obtain information 
about your designs.

Viewing modes

While digitizing, different viewing modes are available 
for different purposes. Depending on your product 
level, BERNINA Embroidery Software provides a 
number of viewing modes which are accessed via the 
View Mode toolbar.

The application has one workspace or ‘Design 
Window’ but you interact with it in separate modes.
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Art Canvas mode

Below is a screen image of the Art Canvas workspace 
which is accessed via the View Mode toolbar. This 
mode allows you to create and edit vector graphics 
using the CorelDRAW® Essentials 4 toolset which 
offer many sophisticated techniques for drafting 
outlines and shapes onscreen.

In addition to the CorelDRAW® Essentials 4 toolset, 
Art Canvas provides capabilities to convert vectors 
and vector text directly to embroidery objects. Vector 
graphics or text created or imported into the Art 
Canvas can be converted directly to embroidery 
designs. You can use Art Canvas to insert or paste 
third-party vector graphics such as clipart for use in 
embroidery designs. Alternatively, insert, paste or 
scan bitmap artwork for use as digitizing templates or 
‘backdrops’. See Loading pictures for details.

Note  For a full description of the 
CorelDRAW® Essentials 4 tools, refer to the electronic 
User Guide available via the Windows Start > 
Programs group. Alternatively, use the onscreen 
help available from the Graphics mode Help menu.

Embroidery Canvas mode

Below is a screen image of the Embroidery Canvas 
workspace which is accessed via the View Mode 
toolbar. This mode allows you to create and edit 
embroidery objects using the embroidery digitizing 
toolset. See also BERNINA Embroidery Software 
interface.

Use this mode when you want to create embroidery 
from digitizing ‘backdrops’. Various types of image file 
can be loaded in BERNINA Embroidery Software. See 
also Digitizing with Backdrops.

Embroidery Canvas also offers a graphical 
representation of what the final embroidery will look 
like. Use Show Artistic View together with a 
background fabric to see how your design will look 
when stitched out. See also Changing backgrounds.

Hoop Layout mode

Below is a screen image of the Hoop Layout 
workspace which is accessed via the View Mode 
toolbar. If your embroidery is too large or contains a 
number of designs spaced around an article, you can 
split it into multiple hoopings. This means you can 
create embroidery designs that are larger than it is 
possible to stitch out on a single hoop. Hoop Layout 

Load, edit and save graphics as a back-
drops for embroidery digitizing. 
Includes entire suite of 
CorelDRAW® Essentials 4 drawing 
tools. In addition, it provides capabilities 
to convert vectors and vector text 
directly to embroidery objects.

In Art Canvas mode, the View Mode 
toolbar includes the Show Embroidery 
button to toggle embroidery display on 
or off.

Digitize and edit embroidery designs. 
Show embroidery shapes as well as 
graphics. View designs realistically in 
simulated 3D.

View and edit multi-hoopings. If embroi-
dery is too large or contains multiple 
designs spaced around an article, split 
into multiple hoopings. 
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allows you to set up the position and sequence of each 
hoop. See Hooping large designs for details.

Design viewing settings

You can show or hide design elements in Embroidery 
Canvas with a variety of display settings. See a 
graphical representation of the final embroidery. 
Show or hide needle penetration points and stitches 
themselves. Or show/hide selected colors.

Viewing simulated embroidery

With Artistic View, you can see a graphical 
representation of the final embroidery.

To view simulated embroidery

To view simulated embroidery (Artistic View), 
toggle the Show Artistic View icon on.

To view embroidery stitches (Stitch View), toggle 
the Show Artistic View icon off.

Viewing needle points

In Embroidery Canvas, you can show or hide needle 
points. For example, you may want to view needle 
points to select stitches for editing. See also Editing 
Stitches.

To view needle points

To show or hide needle points, select View > 
Needle Points.

Viewing stitches and outlines

You can show or hide stitches and object outlines in 
any viewing mode as you work. Hide stitches to see 
outlines more clearly when reshaping. See Reshaping 
& Editing Objects for details.

Click Show Artistic View (General toolbar) to toggle 
artistic or ‘stitchout’ view on/off.

Select Needle Points (View menu) to show or hide the nee-
dle points in a design.

Click Show Stitches (General toolbar) to toggle stitch 
view on/off.

Needle points ON
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To view stitches and outlines

Click the Show Stitches icon to turn stitches on 
or off.

Viewing objects by color

To help you isolate individual design elements for 
checking or manipulation, the View By Color 
function lets you view objects by color. This is 
particularly useful when you are resequencing objects 
by color. See also Resequencing objects by color. 

Note  You will need to ungroup the design before you 
can view object by color.

To view objects by color

1 Create or open a design.

2 Select View > By Color.

The Select By Color dialog opens.

3 Select the colors you want to view.

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

4 Click OK.

The design appears with only those colors you 
selected in view.

5 To view all colors in the design, select View > By 
Color again and click All Colors.

6 Click OK.

Tip  The Color Film provides another way to view 
design objects. See Viewing and selecting color 
blocks for details.

Zooming and panning

Use the Overview Window and Zoom functions to 
quickly examine your design at different degrees of 
magnification.

Tip  The Status Bar displays the current ‘zoom 
factor’. See Starting BERNINA Embroidery Software 
for details.

Viewing designs in overview
Use the Overview Window to view design thumbnails. 
The window updates whenever you make a change 
and can be used to zoom into or pan across the 
Design Window.

To view designs in overview

1 Select View > Overview Window.

Select By Color (View menu) to isolate design elements by 
color.

Stitches OFF Stitches ON

Two colors 
selected
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The Overview Window opens.

2 To zoom in or out, click the Zoom button on the 
Overview Window and drag a bounding box around 
the area to zoom and drop.

3 To pan across the design, move the cursor inside 
the zoom box – it changes to a four-way arrow 
cursor – and drag and drop.

Zooming in and out

Magnify your view of the design by zooming in on 
individual stitches or details, or zoom out to display 
more of the design in the window. The current zoom 
factor is shown at the lower right corner of the screen. 
See also Keyboard Shortcuts.

Note  To make sure your design is being displayed at 
the correct size, calibrate your monitor. See 
Calibrating the monitor for details.

To zoom in and out

Click the Zoom Box icon or press shortcut letter 
B.

The cursor becomes a magnifying glass.

Right-click in the Design Window to zoom out – the 
view zooms out to half the previous screen 
magnification, centered at the point you clicked.

Tip  The Status Bar displays the current ‘zoom 
factor’. See Starting BERNINA Embroidery 
Software for details.

Left-click in the Design Window to zoom in – the 
view zooms to twice the previous screen 
magnification, centered at the point you clicked.

Click to activate 
zoom box

Drag and drop a
bounding box

around area to
zoom

Drag zoom box
to area to pan

Click Zoom Box (General toolbar) to zoom in and out 
of the Design Window. Use it also to zoom in on 
bounded areas of the screen.

Click Show All (General toolbar) to show the whole 
design.

Click Show 1:1 (General toolbar) to show the design 
at the correct size.

Right-click
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Left- or right-click-and-drag a bounding box 
around the zoom area. Release the mouse to view 
the entire boxed area in the Design Window.

Note  All bitmap images, regardless of context, 
maintain the same zoom scale as embroidery. 
Bitmaps are used in a number of contexts:

As a backdrop or guide picture for digitizing: 
See Digitizing with Backdrops for details.

As a background to simulate the stitchout 
fabric: See Changing backgrounds for details.

As a fabric patch for appliqués: See Digitizing 
for Appliqué for details.

To display the whole design, click Show All. 
Alternatively, select View > Show All, or press 0.

To display the design at actual size, click Zoom 
1:1.

To display the design at a particular scale, press F 
on the keyboard. Enter a scale as a percentage of 
the actual size, and click OK.

Press Esc, Enter or Spacebar keys to exit Zoom 
mode.

Viewing the stitching sequence

When working with embroidery designs, you need to 
understand the stitching sequence. You can check a 
design’s stitching sequence by ‘traveling’ through it 
by stitches, colors or objects. You can also check the 

sequence by simulating the design stitchout 
onscreen. BERNINA Embroidery Software simulates 
stitching out by changing stitches from black to their 
allocated thread colors as they are ‘stitched’. See also 
Viewing and selecting color blocks.

Traveling by object and color block
Use the keyboard shortcuts to travel through designs 
by object or color block. This technique is useful if you 
need to locate a specific object in order to delete it or 
insert another object at that point the stitching 
sequence. See also Keyboard Shortcuts.

To travel by object or color block

To travel to the end of the design, press the End 
key.

The white cross is located at the last stitch and the 
design displayed in the selected thread colors.

To travel to the start of the design, press the 
Home key.

The white cross is located at the first stitch and the 
entire design displayed in dark gray.

Click-and-drag

Enter scale

White cross - 
current needle 
position marker

Start point

White cross - 
current needle 
position marker

End point



Chapter 4 : Viewing Designs

BERNINA® Embroidery Software : Onscreen Manual 29

To travel to the next object, press Ctrl+T.

To travel to the previous object, press Shift+T.

To travel to the next color, press the Page Down 
key.

To travel to the previous color, press the Page Up 
key.

Tip  With the Select Object tool activated, you 
can select objects while traveling through the 
stitching sequence. See Selecting objects by Tab 
key for details.

Traveling by stitches
Use the stitch travel tools or shortcut keys to travel 
through the design one or more stitches at a time. 
The current needle position is indicated by a large 
white cross or ‘needle position marker’. Initially, this 
is located at the end of the design. When you travel 
through stitches, the needle position marker moves 
accordingly. The current stitch number appears in the 
Status Bar.

To travel by stitches

1 Select Edit > Stitch Edit or press Esc.

2 Ensure that Select Object is not selected, then 
press the arrow keys to travel by 1 or 10 stitches. 

Press the left or right arrow key to travel 1 
stitch backward or forward.

Press the up or down arrow key to travel 10 
stitches backward or forward.

3 Press the + or - keys located on the keypad to 
travel by 100 stitches. The + key moves you 
forward, while the - key moves you backwards.

Tip  If you travel outside the visible area, press the 
C key to center the current stitch on the screen.

Simulating design stitchouts
The Slow Redraw function lets you simulate the 
actual embroidery design stitchout onscreen. Use it to 
view design stitching and color sequence in slow 
motion. Redrawing can be started from any stitch in 
the design. Hide previously stitched parts of the 
design as required. With larger designs, you can 
choose to scroll automatically so that the area being 
stitched remains onscreen.

Because Slow Redraw emulates the movements of 
the embroidery machine, you are able to make 
decisions about how to optimize your design in order 
to lessen the load on the machine. This is particularly 
important if you intend to make multiple stitchouts of 
the same design. It is good practice to perform Slow 
Redraw on completed designs for this reason.

Note  Slow Redraw cannot be used with Artistic 
View.

White cross - 
current needle 
position marker

White cross - 
current needle 
position marker

-1 +1

+ 10

- 10

Travel backwards 
one stitch
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To simulate the design stitchout

1 Switch to Stitch View.

2 Select View > Slow Redraw or press Shift+R.

The Slow Redraw dialog opens.

3 To redraw only a section of the design, specify the 
start and end stitch in the Stitch Range field.

4 Use the slider bar to set the redraw speed.

5 Click the Play button.

The design is redrawn onscreen according to 
stitching sequence and selected speed.

6 Adjust control buttons as required:

Backdrops and backgrounds

You can display a backdrop while you digitize. Hide it 
temporarily while you work, or dim it for easier stitch 
viewing. You can also change the background color of 
the Design Window to match the color of your fabric.

Viewing backdrops

You can display a backdrop, bitmap or vector, while 
you digitize, or hide it temporarily. Hiding backdrops 
does not delete them from the design. You can also 
dim backdrops to make it easier to view stitches. See 
also Digitizing with Backdrops.

To view backdrops

To toggle backdrop pictures on/off – both bitmap 
and vector graphics – click the Show Pictures 
icon. See also Importing images into BERNINA 
Embroidery Software.

Note  The drawing appears dimmed if Dim 
Picture is selected.

To dim a backdrop, click the Dim Artwork icon.

Note  To return to full color, click the Dim Picture 
icon again.

To toggle backdrop vector graphics on/off, click 
Show Vectors icon.

Button Function

Speed Use the slider bar to adjust the redraw speed 
in ‘real time’.

Pause Pauses the redraw, letting you resume where 
you left off.

Stop Stops the redraw and returns to the beginning 
of the design.

Back to 
Start

Redraws from the beginning of the design.

Play
Pause Stop

Back to Start

Use Show Pictures (General toolbar) to toggle back-
drops on/off.

Use Dim Artwork (General toolbar) to dim backdrops 
in order to show stitches more clearly when digitiz-
ing.

Use Show Vectors (General toolbar) to toggle on/off 
display of vector graphics.

Use Show Appliqué Fabric (General toolbar) to tog-
gle appliqué fabrics/colors on/off.

With Show Pictures OFF With Show Pictures ON

Dimmed bitmap imageOriginal bitmap image
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Click the Show Appliqué Fabric icon to show 
appliqué fabrics/colors. See also Digitizing for 
Appliqué.

To hide the fabrics/colors, click the Show 
Appliqué Fabric icon again.

Changing backgrounds

In BERNINA Embroidery Software, you can change 
the background color of the Design Window to match 
the color of your fabric. Or you can select a 
background fabric for more realistic previews and 
presentations. The background is saved with the 
design.

Tip  Use the Show Appliqué Fabric toggle to turn 
appliqué fabrics/colors display on/off. See Placing 
fabrics in Auto Appliqué designs for details.

To change backgrounds

1 Select Settings > Fabric Display.

The Display dialog opens.

Tip  You can also access this dialog using Settings 
> Thread Colors or clicking the link in the Color 
Palette dialog. Then double-click BKG in the 

Thread Colors tab. See Thread Colors & Charts 
for details.

2 Select the background type you want:

3 Select the color or fabric you want to use:

To select a background color, click Edit and 
select a color from the Color dialog.

To select a fabric, click Browse and choose 
from the Select Fabric Pattern dialog.

Tip  If you choose fabric, you can center or tile the 
image in the Design Window. If the bitmap is large 
enough to fill the entire window, select Center. 
Otherwise, select Tile.

Select Fabric Display (Settings menu) to change back-
ground color and fabrics.

Use the Show Appliqué Fabric tool (General toolbar) 
to toggle fabric display on or off.

With Show Appliqué 
Fabric OFF 

With Show Appliqué 
Fabric ON

Select
background

color or fabric

Option Purpose

Color Select a background color.

Fabric Select a background fabric.

Double-click to 
change background

Click to access 
Thread Colors

Select tiled or
centered
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4 Click OK.

Note  The background is saved with the design.

Viewing design information

BERNINA Embroidery Software provides information 
about designs in a variety of ways and formats. 
Before even opening BERNINA Embroidery Software 
or your design, you can check some design 
information for ART files directly from MS Windows® 
Explorer. You can view stitching details in the Design 
Properties dialog. The Print Preview tool provides 
essential design information, including a design 
preview, the size of the design, color sequence and 
any special instructions.

Viewing design properties

You can check software version number and other 
design information through the Design Properties 
dialog. Stitching details are also provided. Most of the 
fields cannot be modified directly.

To view design properties

1 Select File > Design Properties.

The Design Properties > Design dialog opens. 
This tab contains information about height and 

width and stitch count and colors. The data is 
extracted from the design and cannot be modified.

2 Select the Summary tab to view or enter 
summary information about the design.

3 Click a field and enter any text which will help you 
identify the design at a later date.

Note  Information from this tab is included on the 
Print Preview as well as the Summary tab of the 
Windows Properties dialog. See Viewing design 
information in Windows Explorer and Previewing 
designs for details.

4 Click OK.

Viewing design information in Windows 
Explorer
Before opening ART files, you can view design 
thumbnails and details via MS Windows® Explorer. 
The Properties dialog displays a design preview 
together with design information such as stitch count, 
number of stops and color changes. You can also view 
general file information, such as file size and 
modification dates. See also Design Management.

Note  This same dialog can be accessed from within 
the Open dialog in BERNINA Embroidery Software. 
See also Opening designs.

Use Design Properties (File menu) to view stitching details 
about a design.

Yellow background Denim background
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To view design information in Windows 
Explorer

1 In Windows Explorer, select the folder you are 
interested in.

Design thumbnails are displayed in the Windows 
Explorer window.

2 Right-click a file and select Properties from the 
popup menu. 

The Properties dialog opens.

3 Check the design information, or click the other 
tabs for general file information.

Tip  The Summary tab provides some of the same 
information entered in the Design Properties > 
Summary tab in BERNINA Embroidery Software. 
See Viewing design properties for details.

4 Click OK.

Previewing designs

The Print Preview contains a design preview and 
essential design information, including the size of the 

design, color sequence and any special instructions. 
See also Printing designs.

To preview designs

1 Click the Print Preview icon.

The design preview displays in a preview window.

2 Adjust the view as required:

To change the orientation of the paper, click 
Landscape or Portrait.

To change the information that displays, and 
set printing preferences, click Options. See 
also Setting print options for embroidery.

Click Zoom In to read the design information 
or view the design preview more closely. Large 
designs may be displayed over a number of 
pages.

To print the design, click Print.

To close the print preview, click Close.

Click Print Preview (General toolbar) to preview the 
print preview onscreen.

ART design 
details available 
in Windows 
Properties dialog

Click to set print 
options

Design Design information

Click to print 
design

Click to display 
one or two pages
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CHAPTER 5
SELECTING OBJECTS

BERNINA Embroidery Software provides 
various means for selecting the objects 
comprising an embroidery design. These 
include techniques such as point and click, 
bounding box selection, and multiple object 
selection. You can select all objects in a 
design or individual ones for precise 
modification. BERNINA Embroidery Software 
allows selection of object outlines or fill 
stitches.

Note  Designs must be ungrouped before 
objects can be selected. See Ungrouping 
objects for details.

This section describes how to select objects 
using the selection tools and keyboard. It also shows how to select color blocks 
or individual objects using the Color Film.

Selecting objects by point and click

The simplest way to select objects is by pointing and 
clicking with the mouse with the Select Object tool 
activated. Using Shift and Ctrl keys, you can select 
multiple objects. Both outlines and/or filled areas can 
be selected. Clicking an outline selects an object even 
if another is above it. Where you have a mixture of 
closed objects, you can select object outlines or fill 
stitches. 

Note  With low-density stitching and/or at high 
zooms, it is actually possible to click between stitches 
and not select the object.

To select objects by point and click

Click the Select Object icon.

Click an outline to select the object.

Click the fill behind a outline object to select the 
filled object.

Click Select Object (Edit toolbar) as necessary (gen-
erally activated by default), and click objects to 
select.
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Click the fill to select an object even if it lies within 
the bounds of a larger object.

Tip  To select an object which is behind another 
object, zoom in and click the outline. Alternatively, 
position the pointer over the object, hold down the 
2 key, and click until the object is selected. Each 
click selects the next overlapping object.

To select multiple items, hold down Ctrl as you 
click.

Select a range of objects by holding down Shift 
while you click the first and last objects in the 
range.

Selecting objects by bounding box

With the Select Object tool activated, you can select 
objects by dragging a bounding box around them.

To select objects by bounding box

1 Click the Select Object icon.

2 Drag a bounding box around the objects you want 
to select.

Objects are selected when you release the mouse 
button.

Note  Unless they have already been grouped, 
only objects completely within the bounding box 
will be selected when you release the mouse 
button. See also Grouping objects.

Selecting objects by Polygon Select

Use Polygon Select to select objects with a 
bounding box.

To select objects by Polygon Select

1 Click the Polygon Select icon.

2 Mark reference points around the object/s you 
want to select.

The objects you want to select must be completely 
within the outline.

3 Press Enter to select.

Selecting objects by Tab key

With the Select Object tool activated, you can select 
the first or last object in the design sequence using 
the Tab key. If an object is selected, you can select 

Use Select Object (Edit toolbar) and drag a bounding 
box around the object to select.

Click an object Hold down Ctrl and
click another object

Ctrl + 

Click first object Hold down Shift and
click last object

Shift + 

Use Polygon Select (Edit toolbar) to select objects 
with a bounding box.

Click Select Object (Edit toolbar) and press Tab or 
Shift + Tab to tab between objects.

Drag a bounding box 
around the objects

Objects are 
selected

Mark reference points 
around object/s to select
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the object before or after it in the stitching sequence. 
See also Reshaping next or previous objects.

To select objects by Tab key

Click the Select Object icon.

With an object selected, do one of the following:

Press Tab to select the next object in the 
stitching sequence.

Press Shift+Tab to select the previous object.

With no objects selected, do one of the following:

Press Tab to select the first object in the 
stitching sequence.

Press Shift+Tab to select the last object.

Tip  Hold down the Ctrl key to select multiple 
items as you tab between them.

Selecting all objects in a design

Select all objects to apply changes to a whole design. 
See also Keyboard Shortcuts.

To select all objects in a design

Select Edit > Select All or press Ctrl+A.

Sizing handles appear around the entire design.

To deselect, select Edit > Deselect All, press X or 
Esc.

Deselecting and deleting objects

Deselecting and deleting objects are basic operations 
which rapidly become second-nature. See also 
Combining objects.

Deselecting objects
You can cancel all selections in the design, or remove 
individual objects from a group of selected objects.

To deselect objects

Cancel a selection using any of the following 
methods.

Press Esc.

Select another object.

Click an empty area of the background.

Select Edit > Deselect All.

Remove an object from a selection by holding 
down Ctrl and clicking the object to deselect.

Deleting objects

Various methods are available for deleting objects. 
See also Sequencing objects with Color Film.

To delete objects

Select the object/s to delete, and do one of the 
following:

Press Delete.

Select Edit > Delete.

Right-click object/s in the Color Film and select 
Delete from the popup menu. See Viewing and 
selecting color blocks for details.

Viewing and selecting color blocks

The Color Film tool provides a sequential list of 
objects grouped by color. Use it to select and 
manipulate ‘color blocks’ – consecutive objects of the 
same color. In addition, you can display, select, 
modify and sequence individual objects. Color Film is 

Shift + Tab Tab

All objects selectedNo objects selected

Select Delete (Edit menu) to delete selected objects.

Click Color Film (General toolbar) to view all color 
blocks and objects in a design.

Click Show Individual Objects (Color Film toolbar) to 
view individual objects in order of stitching 
sequence.
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synchronized with the Design Window and vice versa. 
It dynamically updates whenever you select, modify 
or delete objects, or create new ones. See also 
Sequencing objects with Color Film.

To view and select color blocks

Click the Color Film icon.

The Color Film toolbar opens displaying all color 
blocks in the design in order of stitching sequence.

Click the Show Individual Objects toggle to 
view individual objects.

All objects within a color block are displayed in 
stitching order.

Click an icon to select the color block or object. 

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

Manipulate the color blocks as required. See also 
Sequencing objects with Color Film.

You can quickly access popup menu commands for 
manipulating selected color blocks or objects by 

right-clicking their icons. See also Combining 
objects.

Tip  To enlarge thumbnail images of color blocks 
or objects, click and drag the edge of the dialog.

Consecutive objects of 
same color form single 
color block 

All objects comprising
color blocks shown in

their stitching order

Select color
block or
object in

Color Film

Use popup menu to
cut, copy, paste

objects as required

Drag edge to enlarge 
thumbnails
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CHAPTER 6
HOOPING DESIGNS

Fabrics must be hooped before stitching out on the machine. BERNINA 
Embroidery Software allows you to select from a wide range of standard 
factory-supplied hoops. If your project contains a large design or a number of 
smaller designs, you may need to use multiple hoopings. If you have a hoop 
which does not appear in the list, you can define a custom hoop from scratch or 
based on a standard hoop. See also Displaying the hoop.

This section describes how to choose and display hoops in BERNINA Embroidery 
Software. It covers creating and modifying custom hoops. It also deals with 
hooping large designs.

Selecting hoops

Whenever you create a new design, a single hoop 
representing the embroidery hoop you connect to 
your embroidery machine appears by default in the 
middle of the Design Window. As you position objects, 
the hoop position adjusts automatically so that it is 
always centered around objects in the window. The 
Show Hoop tool allows you to toggle hoop display on 
or off. A range of hoop sizes is available for a wide 
variety of design types. You can change hoop 
orientation on screen for ease of digitizing. See also 
Auto-sequencing entire designs.

Changing hoops

From the range of hoop sizes available, select the 
smallest hoop which will accommodate your design. 

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to change hoop settings.
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This will hold the fabric tight while stitching. See also 
Hooping large designs.

Note  When you choose a new hoop, it becomes the 
‘current’ hoop until changed in the present or a future 
session.

To change hoops

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Select a hoop from the Hoop list.

3 If you want a significant point of the design to be 
stitched in a particular part of the hoop, select 
Manual and select Set Hoop Center.

4 Click OK.

If you selected Set Hoop Center, click where you 
want the center to be in the Design Window.

Setting hoop centers

By default, BERNINA Embroidery Software ensures 
that your design is always centered in the hoop. 
However, you can use the manual option to make the 
hoop display does not move from its original position. 
This means it won’t automatically center while you’re 
digitizing. If you are creating a single hoop design, 
however, you should always turn auto-centring back 
on to check that the design will fit within the hoop 
when it gets to the machine.

Note  These settings are digitizing functions only as 
the embroidery machine will always center the 
design. See also Setting automatic start and end 
points.

To set the hoop center

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 In the Position panel, select how to center the 
hoop.

Choose 
required 
hoop size

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to change hoop settings.

Automatic Centering Manual
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Automatic Centering: the hoop moves so 
that the design is always in the center.

Manual: the hoop remains in its original 
position.

Select Set Hoop Center to change the hoop 
position.

3 Click OK.

If you selected Set Hoop Center, click in the 
Design Window where you want the center to be.

Hooping large designs

If your embroidery is too large or contains a number 
of designs spaced around an article, you can split it 
into multiple hoopings. Each one contains an object or 
group of objects that can be stitched out in a single 
hooping. These can be stitched consecutively to form 
the whole design. They can be sent directly to 

machine or saved to file. See also Auto-sequencing 
entire designs.

Multi-hooping guidelines
When BERNINA Embroidery Software calculates 
multiple hoopings, it attempts to split whole objects 
between sequential hoopings. Where one object 
overlaps another, the overlapped object must be 
stitched before the overlapping object.

Bearing this in mind, try to ensure that:

Each successive hoop position overlaps a 
previously stitched hoop position.

Hoops are placed as near as possible to the order 
of the actual design object sequence. This will 
minimize the number of eventual hoopings.

View and edit multi-hoopings. If embroidery is 
too large or contains multiple designs spaced 
around an article, split into multiple hoopings.

Check object 
sequence prior to 
hooping

Three hoop 
positions but five 
‘hoopings’



Chapter 6 : Hooping Designs

BERNINA® Embroidery Software : Onscreen Manual 41

Note  ‘Hooping’ is not the same thing as ‘hoop 
position’ – you can have more hoopings than hoop 
positions but you can never have less. In other words, 
a single hoop position may involve more than one 
hooping in order to preserve the design sequence.

Hooping sequence

When a large design requires multiple hoopings, it is 
important to establish the stitching order so that 
objects in the foreground are sewn after those in the 
background. BERNINA Embroidery Software allows 
you to set up the position and sequence of each hoop. 
Multiple hoops are color-coded as follows, according 
to their position in the sequence:

In the unlikely event that you use more than eight 
hoopings, the color sequence is repeated, as long as 
none of the previously created hoop positions is 
deleted.

Checking the design sequence

Knowing the design object sequence helps you place 
hoops in the best possible hooping sequence. A good 
technique is to use the Color Film tool in object mode 
as shown above. As you select objects from the list, 
they are highlighted in the design. This will help you 
understand the order in which objects are sewn, and 

hence the order in which they should be hooped. See 
also Viewing and selecting color blocks.

Another useful tool is Slow Redraw. When you run 
Slow Redraw, you are checking to see if the start 
and end point of a particular object may have a 
bearing on the number of hoopings. For example, if 
you split a large object but the first half is in the 
second hoop, this may result in an additional hooping. 
With Slow Redraw, you are aiming to make sure 
that any split objects are split between adjacent 
hoops (both in terms of position and hoop placement 
sequence) and that the object starts stitching in the 
earlier hoop. See also Simulating design stitchouts.

Adjusting the design sequence

While correct hoop placements reduce the number of 
calculated hoopings, sometimes the design object 
sequence may not be ideal for multi-hooping. You 
may find that the only way to reduce the number of 
hoopings is to re-sequence the design itself. As a 
general guideline, bear in mind the following:

Stock designs which have been created for a single 
hoop are generally sequenced by color in order to 
reduce the number of color changes. This is 
important for single needle machines.

Enlarging a stock design to the point where it 
requires multiple hoopings may require the design 
sequence to be changed in order to reduce the 
number of hoopings.

Since a given stitchout can use only one size of 
hoop, choose a hoop that will cover the largest 
object in the design.

Always try to place hoops as near as possible to 
the order of the actual design object sequence.

Hooping calculations

While BERNINA Embroidery Software always 
preserves the original stitching sequence, hoop 
placements which follow the design object sequence 
reduce the number of calculated hoopings.

Hoop Color

1 Dark Green

2 Blue

3 Red

4 Brown

5 Orange

6 Purple

7 Teal

8 Aqua

Check stitching 
sequence of 
objects that 
cross hooping 
overlaps
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The time taken to calculate design hoopings is 
dependent more on the number of objects and hoop 
positions than stitch count. Designs converted from 
EXP, PES, HUS, etc, will in general result in a larger 
number of objects than a native BERNINA Embroidery 
Software design. Hence, these designs will take 
longer to calculate. However, even with pure ART 
files, if the design is complex, large, and contains 
many hoop positions, calculation can take time.

Creating multi-hoop designs

BERNINA Embroidery Software provides a dedicated 
Hoop Layout mode which allows you to create 
multiple hoopings. This means you can stitch out 
embroidery designs that are larger than can be 
accommodated within a single hoop. Hoop Layout 
mode allows you to define multiple hoop positions. 
The aim is to add hoops and move them around until 
you get the least number of hoopings necessary to 
accommodate the entire design. These are then 
stitched out consecutively. See also Outputting 
multi-hooped designs.

Tip  Knowing the design object sequence helps you 
place hoops in the best hooping sequence. A good 
technique is to use the Color Film tool in object 
mode. As you select objects from the list, they are 
highlighted in the design. Another useful tool for this 
purpose is Slow Redraw. See Viewing and selecting 
color blocks for details. See also Simulating design 
stitchouts.

To create a multi-hoop design

1 In Embroidery Canvas mode, choose the hoop 
you want to use. See Changing hoops for details.

Tip  Since a given stitchout can use only one size 
of hoop, you need to choose a hoop that will cover 
the largest object in the design.

2 Switch to Hoop Layout mode. See Viewing modes 
for details.

When you enter Hoop Layout, covered objects – 
those that fit wholly within a hoop – display as 
green stitches. Uncovered objects – those that do 
not fit – display as black stitches.

Note  No embroidery object can be selected or 
manipulated in Hoop Layout.

Use Selection On (Multi-Hooping toolbar) to select 
hoops in Design Window.

Use Reshape Splitting Guide (Multi-Hooping toolbar) 
to reshape split lines in Design Window.

Use Add Hoop (Multi-Hooping toolbar) to center new 
hoop in Design Window in upright orientation.

Use Add Hoop Right (Multi-Hooping toolbar) to place 
new hoop directly to right of selected hoop with 
10 mm overlap between sewing fields.

Use Add Hoop Up (Multi-Hooping toolbar) to place 
new hoop directly above selected hoop.

Use Add Four Adjacent Hoops (Multi-Hooping tool-
bar) to automatically add four hoopings around 
selected hoop perimeter.

Use Add Eight Adjacent Hoops (Multi-Hooping tool-
bar) to automatically add eight hoopings around 
selected hoop perimeter.

Use Splitting Guide (Multi-Hooping toolbar) to digi-
tize one or more split lines in multi-hooped design 
prior to outputting to file, machine or memory card.

Use Delete Hoop (Multi-Hooping toolbar) to remove 
selected hoops from Design Window.

Click Rotate Hoop Left / Right (Multi-Hooping tool-
bar) with left or right mouse buttons to rotate selected 
hoop 45° in either direction.

Use Calculate Hoopings (Multi-Hooping toolbar) to 
evaluate hoopings that will result from current hoop 
layout.

Artistic 
View
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3 Click the Selection On icon, click a hoop outline, 
and drag it till it covers the largest object in the 
design.

4 Use the Add Hoop tools to add more hoop 
positions.

As soon as a hoop is moved or joined by others, 
automatic centering is deactivated, meaning that 
it no longer centers itself automatically around 
objects in the design.

Click the Add Hoop icon to add a new hoop to 
the Design Window in an upright orientation.

Use the Add Hoop Right tool to place a new 
hoop directly to the right of a selected hoop 
with a 10 mm overlap between sewing fields.

Similarly, use the Add Hoop Up tool to place a 
new hoop directly above a selected hoop.

The Add Four Adjacent Hoops and Add Eight 
Hoops Around commands become available 
when a single hoop is selected in the Design 
Window. Clicking the associated icon causes four 
or eight hoopings to be added around hoop’s 
perimeter, starting from the top and continuing in 

a clockwise direction, with a 10mm overlap 
between sewing fields.

5 Click the Delete Hoop icon or press the Delete 
key to remove selected hoops from the Design 
Window as necessary.

Deleting a hoop position does not cause the colors 
of remaining hoops to change.

Note  If you remove all hoops in a design and 
create a new one, automatic centering is 
re-activated.

Tip  To select more than one hoop at a time, use 
one of the following techniques:

Click hoop outlines while holding down the Ctrl 
key to toggle selection on and off.

Click hoop outlines while holding down the 
Shift key to select a range of hoops.

Click and drag a marquee with the cursor to 
select all hoops lying wholly within the area 
described.

6 Re-position additional hoops and, if necessary, 
rotate them so that they completely cover all 
objects in the design.

Click the Rotate Hoop Left / Right  icon with 
left or right mouse buttons to rotate a selected 
hoop 45° in either direction.

Design not 
covered, more 
hoopings needed

New hoop
added

Add four adjacent hoops

Add eight adjacent hoops
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Alternatively, click the hoop again and rotate 
hoops by means of rotation handles and 
rotation center-point.

Note  Hoops in Hoop Layout can be rotated to 
any angle you choose. Note, however, that when a 
rotated hoop is viewed in Hoop Layout, the top will 
also appear, incorrectly, to be rotated.

Nudge selected hoops into position using the 
arrow keys.

Note  While a design may be entirely covered by 
separate hoop positions, some objects may remain 
uncovered, as indicated by black stitching. If you 
try to output at this stage, you will receive the 
message that some objects are still not covered. 
The Splitting Guide tool allows you to split 
objects that would not otherwise fit within a 
hooping. See Splitting objects between hoopings 
for details.

7 Finally, click the Calculate Hoopings icon to 
evaluate the hoopings that will result from the 
current hoop layout.

The file is split into at least as many files as there 
are hoopings, depending on whether you have 
split some objects between hoopings. You are now 
ready to save the design to one or more files or 
send it to machine. See Outputting multi-hooped 
designs for details.

Tip  Print a copy of the design showing the hoop 
positions to help you stitch it in the correct hooping 
order. See Printing multi-hooped designs for 
details.

Splitting objects between hoopings

The Splitting Guide tool allows you to split objects 
that would not otherwise fit within a hooping. In 
effect, it allows you to digitize one or more split lines 
in a multi-hooped design prior to outputting to file, 
machine or memory card. Although split lines are only 
visible in Hoop Layout, they are maintained when 
switching to other modes. Split lines do not affect 
object integrity and you can still reshape and 
transform split objects as before. 

Re-position 
center point

Drag rotation 
handle

All objects 
covered

Use Splitting Guide (Multi-Hooping toolbar) to digi-
tize one or more split lines in multi-hooped design 
prior to outputting to file, machine or memory card.

Use Reshape Splitting Guide (Multi-Hooping toolbar) 
to reshape split lines in Design Window.
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To split objects between hoopings

1 Select Hoop Layout mode.

A design already exists in the Design Window with 
multiple hoopings and uncovered objects.

2 Select the Splitting Guide tool.

You are prompted to enter the starting point of the 
split line within sewing field overlaps.

3 Digitize split lines just as you would open curve 
objects, using right-clicks for curves and left-clicks 
for corner points.

As long as splits occur within the sewing field of 
overlapping hoopings, the resultant ‘split objects’ 
become covered and are displayed in green.

Lines that completely cross over objects that are 
not already covered will be split on output. The 
split will not necessarily be along the digitized line. 
Instead, it will be made as inconspicuous as 
possible. The resulting objects will preserve their 
original object type, stitch angle, parameters and 
color.

4 Repeat as necessary or press Enter to complete.

Note  Split lines can be reshaped once created by 
selecting the line using the Reshape Splitting 

Digitize split lines 
as open curve 
objects
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Guide tool. Control points for the split line are 
highlighted and can be manipulated as required.

Note  Split lines that do not cross an object 
completely, or cross an object which is already 
covered, are ignored.

Creating sliding-hoop designs

Sliding hoops are special hoops with adjustable 
frames to accommodate larger designs. You can 
adjust the position of the sewing field according to 
objects in the design. You can even define multiple 
sewing field positions as required. The entire design, 
however, must fit within the overall hoop.

Note  You can define your own sliding hoop to suit the 
one you are working with. See Defining sliding hoops 
for details.

To create a sliding-hoop design

1 In Embroidery Canvas mode, choose the sliding 
hoop you want to use. See Changing hoops for 
details.

The overall outline is displayed in solid black.

Note  The design can only use a single sliding 
hoop, so you need to choose one that will 
accommodate the entire design. The sewing field 
must also be able to accommodate the largest 
object in the design.

2 Switch to Hoop Layout mode. See Viewing modes 
for details.

When you enter Hoop Layout, covered objects – 
those that fit wholly within the sewing field – 
display as green stitches. Uncovered objects – 
those that do not fit – display as black stitches.

Use Selection On (Multi-Hooping toolbar) to select 
hoops in Design Window.

Use Add Hoop (Multi-Hooping toolbar) to center new 
hoop in Design Window in upright orientation.

Use Delete Hoop (Multi-Hooping toolbar) to remove 
selected hoops from Design Window.

Corner point

Selected point

Curve point

Total 
Height

Sewing
Field

Width

Sliding hoop

Sliding hoop

Sewing field 
position
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Note  No embroidery object can be selected or 
manipulated in Hoop Layout.

3 Click the Selection On icon, and click and drag 
the dotted outline till it covers the largest object in 
the design.

4 Click the Add Hoop icon.

A new sewing field position – shown as a dotted 
outline in a different color – is added to the center 
of the hoop.

Note  The Add Hoop Right and Add Hoop Up 
tools are not available.

5 Click and drag the new sewing field position and 
add more as required.

6 Click the outline of the overall hoop to select it and 
all positions within it, and reposition or rotate as 
required. See Creating multi-hoop designs for 
details.

7 Remove a sewing field position as required by 
clicking the dotted outline and clicking the Delete 
Hoop icon.

Tip  The height of the sewing field and size of the 
overall hoop can be adjusted at any time to match 
the actual hoop you are working with. See 
Modifying custom hoops for details.

Creating 3-position-hoop designs

3-position hoops allow large designs to be split 
manually and stitched without the usual registration 
problems. Unlike sliding hoops, the sewing fields are 
in fixed positions with known dimensions, making it 
easy to register objects stitched in each position. The 
three sewing areas are presented in turn to the 
sewing machine without any need to detach the fabric 
from the hoop. In the software, they are displayed as 
three dotted rectangles. The top rectangle is green, 
the middle, blue and the bottom, red.

Note  You can define your own 3-position hoop to suit 
the one you are working with. See Defining 3-position 
hoops for details.

To create a 3-position-hoop design

1 In Embroidery Canvas mode, choose the 
3-position hoop you want to use. See Changing 
hoops for details.

Use Selection On (Multi-Hooping toolbar) to select 
hoops in Design Window.

Use Add Hoop (Multi-Hooping toolbar) to center new 
hoop in Design Window in upright orientation.

Second sewing 
field position

Use Add Hoop Right (Multi-Hooping toolbar) to place 
new hoop directly to right of selected hoop with 
10 mm overlap between sewing fields.

Use Add Hoop Up (Multi-Hooping toolbar) to place 
new hoop directly above selected hoop.

Use Delete Hoop (Multi-Hooping toolbar) to remove 
selected hoops from Design Window.

Total 
Height

Position 1
Height

Width

Position 2
Height

Position 3
Height
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The overall outline is displayed in solid black, with 
a dotted outline for each sewing field.

Note  Very large designs can use multiple 
3-position hoopings if required. The sewing field, 
however, must be able to accommodate the 
largest object in the design.

2 Switch to Hoop Layout mode. See Viewing modes 
for details.

When you enter Hoop Layout, covered objects – 
those that fit wholly within a hoop – display as 
green stitches. Uncovered objects – those that do 
not fit within the hoop – display as black stitches.

Note  No embroidery object can be selected or 
manipulated in Hoop Layout.

3 Click the Selection On icon, click and drag the 
hoop outline till it covers the largest object in the 
design.

Note  With a 3-Position Hoop, you can select the 
overall hoop but no individual hoop positions 
within it.

4 Use the Add Hoop tools to add more hoops as 
required. See Creating multi-hoop designs for 
details.

5 Re-position or rotate the hoops as required. See 
Creating multi-hoop designs for details.

Note  Moving or rotating affects the whole hoop 
and all positions within it.

6 Remove a hoop as required as required. See 
Creating multi-hoop designs for details.

Tip  The height of the sewing fields and the size of 
the overall hoop can be modified at any time. See 
Modifying custom hoops for details.

Defining custom hoops

If you are using a hoop size that is not in the hoop list, 
you can define your own hoops and save them for 
later use. You can create or edit four types of hoop – 
rectangular, oval, sliding and 3-position.

Defining rectangle hoops

Rectangle hoops are displayed as dotted black lines. 
You can set the height and the width of the rectangle 

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to create hoops.
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according to the dimensions of the hoop you are 
using.

To define a rectangle hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Click New Hoop.

The Create/Edit Hoop dialog opens.

3 In the Format panel, select Rectangle.

4 In the Dimensions panel, enter the Height and 
the Width of the rectangle hoop.

5 Click the Save Hoop As button.

The Save Hoop As dialog opens.

6 Enter a hoop name.

7 Click Save and Save Hoop.

Defining oval hoops

Oval hoops are displayed as black dotted outlines. You 
can set the height and the width of the oval according 
to the dimensions of the hoop you are using.

To define an oval hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Click New Hoop.

Height

Width

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to create hoops.

My rectangle hoop

Total 
Height

Rectangle
Height

Width
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The Create/Edit Hoop dialog opens.

3 In the Format panel, select Oval.

4 In the Dimensions panel, enter the Rectangle 
Height, Total Height and the Width of the oval 
hoop.

5 Click the Save Hoop As button.

The Save Hoop As dialog opens.

6 Enter a hoop name.

7 Click Save and Save Hoop.

Defining sliding hoops

Sliding hoops are special hoops with adjustable 
frames to accommodate unusual size designs. You 
can set the height and the width of the hoop as well 

as the sewing field within according to the dimensions 
of the hoop you are using.

To define a sliding hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Click New Hoop.

The Create/Edit Hoop dialog opens.

3 In the Format panel, select Sliding.

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to create hoops.

My oval hoop

Total 
Height

Sewing
Field

Width
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4 In the Dimensions panel, enter the Sewing 
Field, Total Height and Width of the hoop.

Note  It is best to enter the total height of the 
hoop first. If the sewing field is larger than the 
default total height, the size will go back to a 
smaller size.

5 Click the Save Hoop As button.

The Save Hoop As dialog opens.

6 Enter a hoop name.

7 Click Save and Save Hoop.

Defining 3-position hoops

3-position hoops allow large designs to be split 
manually and stitched without the usual registration 
problems. Unlike sliding hoops, the sewing fields are 
in fixed positions with known dimensions, making it 
easy to register objects stitched in each position. In 
the software, they are displayed as three dotted 
rectangles. The top rectangle is green, the middle, 
blue and the bottom, red. You can define your own 
3-position hoop according to the dimensions of the 
hoop you are using. 

To define a 3-position hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Click New Hoop.

The Create/Edit Hoop dialog opens.

3 In the Format panel, select 3-Position.

4 In the Dimensions panel, enter the Total 
Height, the heights for Position 1, 2 and 3, 
followed by the hoop Width.

Note  It is best to enter the total height of the 
hoop first. If the sewing field is larger than the 
default total height, the size will default to a 
smaller size.

5 Click the Save Hoop As button.

The Save Hoop As dialog opens.

6 Enter a hoop name.

7 Click Save and Save Hoop.

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to create hoops.

My sliding hoop

Total 
Height

Position 1
Height

Width

Position 2
Height

Position 3
Height

My 3 position hoop
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Modifying custom hoops

You can edit and delete custom hoops as required. 
Only custom hoops can be modified.

Editing hoops

Change the height and width of the new hoops as 
required.

To edit a hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 In the Hoop list, select the hoop.

3 Click Edit Hoop.

The Create/Edit Hoop dialog opens.

4 Enter the new dimensions.

5 Click the Save Hoop button.

Deleting hoops

When you delete a hoop type, it is removed 
permanently. Only custom hoops can be deleted.

To delete a hoop

1 Right-click the Show Hoop icon or select 
View > Hoop.

The Options > Hoop dialog opens.

2 Select a customized hoop to be deleted.

3 Click Delete Hoop then click OK to confirm.

The hoop is removed permanently.

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to edit hoops.

Click Show Hoop (General toolbar) to turn hoop dis-
play on or off. Right-click to delete hoops.



Chapter 7 : Hardware & Software Setup

BERNINA® Embroidery Software : Onscreen Manual 53

CHAPTER 7
HARDWARE & SOFTWARE SETUP

You will need to connect peripheral devices for use with 
BERNINA Embroidery Software. These may include 
printers, scanners and embroidery machines. BERNINA 
Embroidery Software lets you adjust various system 
settings controlling the appearance of designs on screen, 
display of design information, the behavior of the Design 
Window, and other settings.

This section describes how to set up embroidery machines, 
and scanners and describes how to calibrate the monitor. It 
also deals with changing grid spacing and hoop options. The 
setting of general options – such as automatic save, pointer 
position display options, etc – is also covered.

Setting up hardware

Different devices are set up in different ways – some 
in MS Windows®, via the Control Panel, others within 
BERNINA Embroidery Software itself. For instructions 
on connecting devices to your computer and setting 
up in MS Windows®, see the documentation for the 
device as well as your MS Windows® documentation.

Peripheral device connection settings
Peripheral devices such as printers are connected to 
an available ‘port’ at the front or back of your 
computer. These may be of either ‘serial’, ‘parallel’ or 
USB type. The software settings need to be 
configured within the MS Windows® Control Panel.

Serial port settings

PC serial COM ports are male connectors, and can be 
either 9-pin or 25-pin. They are named COM1, COM2, 
etc. The number of available ports limits the number 
of devices you can connect. If additional ports are 
required, you can add them. BERNINA Embroidery 
Software allows up to 4 serial ports.

Note  You must be able to identify the ports on your 
computer. If in doubt, consult a PC technician.

Parallel port settings

Parallel ports may be used to connect your printer and 
scanner. They are named LPT1, LPT2, etc. 

USB port settings

USB – Universal Serial Bus – ports are used to 
connect your dongle. They can also be used to 
connect your printer or scanner. Additional USB ports 
can use a powered USB hub.

Setting up embroidery machines
Your BERNINA embroidery machine should be 
connected to the COM1, COM2, COM3, COM4 or USB 
port of your computer. See your BERNINA embroidery 
machine manual for details on connecting the 
machine to your computer.

Setting up printers
Your printer is connected to a USB or parallel port. 
Some printers can be connected to either port type. 
BERNINA Embroidery Software will use the default 
printer that you have specified through the Printer 
icon in the Windows Control Panel.

See your printer manual for directions on setting it up 
properly. See Windows Help (select Windows 
Start > Help > Index, then type ‘default printer’) 
for directions on how to set up a default printer.
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Setting up scanners

BERNINA Embroidery Software supports 
TWAIN-compatible scanners.

Note  Some scanners will not work with BERNINA 
Embroidery Software because they require their own 
scanner software. If this is the case with your scanner, 
use your scanner software for scanning, save the 
image to your hard drive, then load the image into 
BERNINA Embroidery Software.

To set up scanners

1 Connect the scanner using the accompanying 
instructions.

2 Set it up in MS Windows® using the accompanying 

instructions and/or the Microsoft MS Windows® 
documentation.

3 Start BERNINA Embroidery Software.

4 Select Settings > Scanner Setup.

The Select Source dialog opens displaying a list 
of scanner drivers loaded on your computer.

5 Select the scanning driver to use, then click 
Select.

Note  If you have trouble with scanning after 
re-starting BERNINA Embroidery Software, there 
may be a conflict with previously installed scanner 
drivers. Re-install BERNINA Embroidery Software 
and test the scanner. If the selected scanner driver 
does not work in BERNINA Embroidery Software, 
select another scanner driver from the list. There 
are usually two installed for each scanner.

Calibrating the monitor

You need to calibrate your monitor so that designs at 
1:1 scale appear at real size. Do this when you first 

install BERNINA Embroidery Software or whenever 
you change your monitor.

To calibrate the monitor

1 Select Settings > Display Setup.

The Screen Calibration dialog opens.

2 Measure the height and width of the dialog box.

3 Enter the measurement in the Width and Height 
fields.

4 Click OK.

Setting grid options

You can turn the grid on or off, change the grid 
spacing, or set a reference point. You can also turn 
Snap to Grid on or off in the Options dialog.

Align the grid with a specific point in the design by 
setting a reference point – for example, when you 
want grid lines to intersect the center point of the 
design, or a horizontal grid line to sit under a 
particular object.

Use Snap to Grid to align objects in your design to 
the nearest grid lines. You can align objects to the 
horizontal (X) or vertical (Y) axis, or both. New 
reference points will ‘snap’ to the nearest grid line as 
you digitize. Existing objects will snap to grid when 
you select and move them.

Use Scanner Setup (Settings menu) to setup scanners.

Use Display Setup (Settings menu) to calibrate the monitor.

Select
scanning

driver

Right-click Show Grid (General toolbar) to set grid 
reference point and spacing.

Measure width

Measure 
height
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To set grid options

1 Right-click the Show Grid icon.

The Options > Grid dialog opens.

2 Select the Show Grid checkbox to display the 
grid.

3 Select the Set Reference Point checkbox to align 
a significant point of the design with a grid line or 
grid point.

For example, you can set the grid reference point 
to the design center. This is easier and faster than 
moving the whole design.

4 Enter Grid Spacing values for horizontal and 
vertical grid lines.

5 Select the Snap to Grid checkbox.

Tip  To temporarily disable Snap to Grid as you 
digitize, hold down Alt.

6 Click OK.

If you selected Set Reference Point, mark the 
reference point on your design. The grid aligns so 
that horizontal and vertical grid lines intersect at 
this point.

Setting auto scroll options

Use Auto Scroll to scroll the design automatically 
while you are digitizing. This can be more convenient 
than using panning or the scroll bars.

To set auto scroll options

1 Select Settings > Options and select the Auto 
Scroll tab.

2 Select the Auto Scroll checkbox to apply 
automatic scrolling.

3 Select the Move Pointer After Scroll checkbox 
to move the position of the pointer after each 
scroll.

4 Adjust the Autoscroll Response field as 
required.

Enter smaller values to increase scrolling speed.

5 Select the pointer position after scrolling from the 
Move Input Point To list:

6 Click OK.

The effect of this setting only becomes apparent 
when you start to digitize. The Design Window 
automatically scrolls to follow the current cursor 
position. 

Tip  Hold down the Shift key to temporarily 
deactivate Auto Scroll.

Setting hoop options

Select to display grid

Select to align grid
to a point

Enter horizontal and
vertical spacing

Select snap to grid

Option Purpose

Center Center of the window. Use this setting for 
large movements.

Midway Halfway between the original pointer position 
and the center of the window. Use this setting 
for smaller movements – e.g. when zooming 
into a small area of the design.

Corner The edge of the screen. Use this setting for 
slow scrolling.

Right-click Show Hoop (General toolbar) to change 
the hoop settings.
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A range of sizes is available to suit the size of your 
design as well as a number of embroidery machines. 
Select the smallest hoop which fits the design from 
the range of hoop sizes available. This will hold the 
fabric tight while stitching.

To set hoop options

1 Select View > Hoop or right-click the Show 
Hoop icon.

The Options > Hoop dialog opens.

Tip  Hide the hoop by clearing the Display Hoops 
checkbox. 

2 Select a hoop from the Hoop list. 

3 Select a position in the Position panel to center 
your hoop. See Setting hoop centers for details.

4 Click New Hoop to create customized hoops. See 
Defining custom hoops for details.

5 Click Edit Hoop to edit existing hoops. See Editing 
hoops for details.

6 Click Delete Hoop to delete existing hoops. See 
Deleting hoops for details.

7 Click OK.

Setting Auto Appliqué options

Use Auto Appliqué to produce all the stitching you 
require for closed-object appliqué. Options 
determining single or multiple boundaries as well as 
frame-out position are set in the Options dialog. See 
also Creating closed-object appliqué.

To set Auto Appliqué options

1 Select Settings > Options and select the 
Applique tab.

This tab contains two panels – Boundaries and 
Frame Out.

2 Select the required Boundaries option:

3 Select the required Frame Out method:

Automatic: If selected, the frame-out position 
is determined automatically.

Manual: If selected, the frame-out position is 
marked as part of the digitizing process.

Place Under Cover Stitches: If selected, the 
frame-out position is placed at the location of 
the last needle penetration before the 
frame-out would occur.

4 Click OK.

Setting Remove Overlaps options

Use Remove Overlaps to remove underlying layers 
of stitching. This helps to reduce the stitch count and 

Select Options (Settings menu) to set Auto Appliqué 
options.

Option Purpose

Single Use when creating a single closed-object 
appliqué object.

Multiple Use when creating multiple closed-object 
appliqué objects. See Creating closed-object 
appliqué for details.

Select Options (Settings menu) to set Remove Overlaps 
options.
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prevent a build-up of stitches where they are not 
needed. See also Removing underlying stitching.

To set Remove Overlaps options

1 Select Settings > Options and select the 
Remove Overlaps tab.

The Options > Remove Overlaps dialog opens.

2 Enter the amount of overlap required in the 
Cutting Overlap field.

3 Click OK.

Setting general options

BERNINA Embroidery Software lets you adjust 
various general settings controlling the automatic 
saving of designs, the position of the pointer 
on-screen, as well the display of measurements.

Setting automatic save

Save your work automatically at regular intervals 
using Auto Save to protect you from losing work in 
the event of hardware or software failure. A backup 
file is created every time you save a design. The 
design will be saved in the BACKUP folder of your 
BERNINA Embroidery Software installation. It will 
have the same name as the original file with the 
extension ‘BAK’.

Caution  Backup files remain in the BACKUP folder 
until you delete them. To prevent the folder from 
using too much hard disk space, delete unwanted files 
regularly.

To set automatic save

1 Select Settings > Options > General tab.

2 Select the Save Design checkbox.

3 Enter the auto-save frequency in the Auto Save 
Period field.

4 Click OK.

Interpreting pointer position values
The X and Y values show the horizontal and vertical 
distance of the pointer from the relative or absolute 
point. The L value is the length of the line connecting 
the pointer with the start point, while A is the angle 
of that line, relative to the horizontal.

A negative X value indicates that the second point 
was placed to the left of the first point, while a 
negative Y value displays when the second point is 
below the first. Negative angles indicate angles of 

Select Options (Settings menu) to set automatic save and 
backup options.

Cutting Overlap: 0.5 mm Cutting Overlap: 1.5 mm

L: length
A: angle

Status
bar

X = 61.4 mm

Y = -42.7 mm

length = 75.4 mm

X: horizontal
Y: vertical

end point

start point
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more than 180º – for example, an angle of -60º is 
equal to 300º.

Tip  You can measure on-screen distances using the 
values in the Status Bar. See Measuring distances 
onscreen for details.

Setting pointer position display options

When you move the mouse, the pointer position is 
displayed in the Status Bar at the bottom of the 
screen. You can optionally display the pointer position 
relative to the last digitized point or stitch point, or as 
an absolute value from the first needle point of the 
design.

To set pointer position display options

1 Select Settings > Options > General tab.

2 Select a Relative or Absolute setting for the 
pointer.

Relative: shows pointer position relative to the 
last digitized point or stitch point. Useful while 
digitizing or editing stitches.

Absolute: shows pointer position as an 
absolute value from the first needle point of the 
design. Useful for checking that the design fits 
a given area.

3 Click OK.

Setting other general options
The Special > Options > General provides options 
for activating the following functions:

Applying Closest Join while digitizing

Displaying a measure tooltip when using the 
Measure command

Hiding object properties

Grouping designs when opening and inserting.

To set other general options

1 Select Settings > Options > General tab.

2 Select one or more of these options:

Apply Closest Join while digitizing: The 
Closest Join method (the default) 
automatically calculates the closest join 
between objects while digitizing. When 
deactivated, all newly digitized objects are 
joined by the As Digitized method. See 
Digitizing closed shapes for details.

Show Measure Tooltip: shows length and 
angle in a tooltip when measuring distances on 
screen. See Measuring distances onscreen for 
details.

Hide object properties: When selected, the 
Object Properties dialog automatically closes 
when the Effects dialog is opened, and vice 
versa. See Accessing object properties for 
details.

Group Designs on Open and Insert: When 
selected, a design is automatically grouped 
when first opened or inserted into another 
design. This makes it easier to drag into 
position without accidentally deselecting it. This 
is particularly useful when working with designs 
which have been placed right on top of existing 
design elements. See Working with design files 
for details.

3 Click OK to confirm.

Select Options (Settings menu) to set pointer position dis-
play options.

90º

0º

135º

180º

-135º

45º

-45º

-90º

A = 30º

2

1

 Set other
general options

Show Measure 
Tooltip ON
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PART II
DIGITIZING TECHNIQUES

In BERNINA Embroidery Software, you build designs from basic shapes or ‘embroidery 
objects’. These are like ordinary drawing objects in that they have certain defining 
characteristics or ‘properties’ such as color, size, position, and so on. They also have 
properties unique to embroidery such as stitch type and density.

Outline and fill stitches

This section explains how to select basic outline and fill stitch types, as well as change 
stitch settings to obtain the best results. Basic outlines dealt with here include Single 
and Triple stitch, Satin stitch, and Blanket stitch. Basic fills discussed include Satin fill 
and Step fill. See Outline & Fill Stitches for details.

Digitizing methods

This section describes how to digitize shapes with the main digitizing methods. It also 
explains how to adjust digitizing settings to obtain the best results. See Digitizing 
Methods for details.

Thread colors and charts

This section describes how to select colors from the Color Palette as well as how to 
assign threads to the colors in your design. How to modify thread charts is also covered, 
as well as creating custom thread charts. See Thread Colors & Charts for details.

Object properties and templates

This section explains how to change the object properties in your design, as well as how 
to apply, create and maintain templates in BERNINA Embroidery Software. See Object 
Properties & Templates for details.

Improving stitch quality

This section covers adjusting fabric settings, stabilizing with underlays, and 
compensating for fabric stretch. It also describes how to preserve long stitches, adjust 
tie-in/off settings, and set automatic start and end points. See Stitch Quality for details.
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CHAPTER 8
OUTLINE & FILL STITCHES

All embroidery objects in BERNINA Embroidery Software 
have defining settings or ‘properties’, the most important of 
which is the stitch type. Whenever you create or modify an 
object, stitches are generated according to the associated 
stitch type. Stitch settings such as spacing and length can 
be adjusted before or after digitizing.

Stitch types divide broadly into two categories – ‘outline’ 
and ‘fill’. Outlines are used, as the name suggests, for 
outlines or borders of shapes and for details. Fill stitches 
are used to cover large areas or ‘color blocks’ in a design. 
Outline and fill stitches are generated whenever you create 
embroidery shapes, but they can be changed at any time. 
BERNINA Embroidery Software provides a variety of 
digitizing methods or ‘tools’ for creating embroidery 
objects. These tools are used in conjunction with stitch 
types to create embroidery ‘objects’.

This section explains how to select basic outline and fill stitch types, as well as 
change stitch settings to obtain the best results. Basic outlines dealt with here 
include Single and Triple, Satin, and Blanket. Basic fills discussed include Satin 
and Step. See also Advanced Digitizing.

Selecting or changing stitches

BERNINA Embroidery Software provides a number of 
basic outline and fill stitch types as well as those of a 
more artistic or decorative kind. Different stitch types 
suit different shapes. Whenever you create an object, 
it always takes the currently selected stitch type. You 
can change this at any stage.

Tip  Preset stitch values by changing the current 
properties in the Object Properties dialog before 
you digitize. See also Object Properties & Templates.

Selecting outline stitches

BERNINA Embroidery Software provides basic Single, 
Triple, Satin and Blanket outline stitches, as well as 
more decorative stitch types. You can interchange 
these at any stage.

Click Outline (Stitch and Color Bar) to access 
outline stitches.

Use Single for thin outlines. 

Use Triple for thicker outlines. 

Use Satin outline for adding 
thicker borders. 

Use Blanket for long, narrow bor-
ders with a ‘comb’ effect.
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To select an outline stitch

1 With or without an object selected, click the 
Outline icon to access a dropdown menu.

2 Select a stitch type from the list.

The selected stitch type is applied to the selected 
object or any newly created outline objects. 
Current settings apply.

Tip  Use Stemstitch and Backstitch for 
decorative outlines. Pattern Run is also available. 
See Craft Stitch Borders and Fills and Patterned 
Stamps, Runs & Fills for details.

Selecting fill stitches

BERNINA Embroidery Software provides basic Satin 
and Step fills, as well as more decorative stitch types. 
You can interchange these at any stage.

To select a fill stitch

1 With or without an object selected, click the Fill 
icon to access a dropdown menu.

2 Select a stitch type from the list.

The selected stitch type is applied to the selected 
object or any newly created filled objects. Current 
settings apply.

Tip  Use Fancy, Pattern, and Craft Stitch fills for 
more artistic effects. See Artistic Stitch Effects, 
Patterned Stamps, Runs & Fills, and Craft Stitch 
Borders and Fills for details.

Creating outlines with Single and Triple 
stitch

Use the Single and Triple tools to digitize lines of 
single or triple outline stitching. Single places a 
single row of stitches along a digitized line. Triple 
repeats each stitch three times for a thicker line. 
These tools are typically used to add borders to 
designs.

Note  You cannot see a big difference between Single 
and Triple stitches on screen as the extra stitches in 
Triple cover each other. To check that an object is 
stitched with Triple, travel through the stitches. See 
Traveling by stitches for details.

Click Fill (Stitch and Color Bar) to access fill 
stitches.

Use Satin fill for narrow shapes. 

Use Step for larger, irregular 
shapes.

Select outline 
stitch

Select a fill 
stitch

Stitch length

Single

Triple

1 2 3 4 5 6 7

1
2

3

4
5

6
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Creating Single and Triple outlines

Use Single or Triple stitch to create lines of single or 
triple stitches. Left and right mouse clicks create 
reference points – corner points and curve points 
respectively.

To create a Single or Triple outline

1 Click the Outline icon and choose Single or 
Triple from the dropdown menu.

Note  The outline is created with default Single or 
Triple stitch settings. Stitch length can be adjusted 
before or after digitizing. See Adjusting Single or 
Triple stitch length for details.

2 Select a digitizing tool and digitize a shape, open 
or closed. See Digitizing Methods for details.

Note  The Block Digitizing tool cannot be used 
for outlines.

Adjusting Single or Triple stitch length

You can change stitch length in the Object 
Properties dialog either before or after digitizing. For 
both Single and Triple stitches, set a stitch length to 
suit the digitized shape. Where the object has tight 
curves, select a shorter stitch length. To reduce the 

stitch count for flatter curves, increase the stitch 
length.

To adjust Single or Triple stitch length

1 Double-click or right-click a Single or Triple outline 
object.

The Object Properties > Outline Stitch dialog 
opens.

Tip  You can preset stitch settings before 
digitizing. Click the Object Properties icon to 
access the dialog at any time.

2 Select Single or Triple from the Stitch Type list 
to change stitch types as necessary.

3 Enter the stitch length in the Stitch Length box.

If a line has tight, sharp curves, reduce the length, 
for example to 1.8 mm, so that the stitches follow 
the line.

Tip  You can mimic handmade embroidery with 
Single or Triple stitches by setting the length to 
4.0 mm. See also Craft Stitch Borders and Fills.

4 Click Apply.

Creating outlines with Satin stitch

Satin stitch can be used for outlines or fills. It is 
well-suited to thicker borders. Adjust stitch density by 
setting a fixed spacing value, or let Auto Spacing 
calculate it for you.

Click Outline (Stitch and Color Bar) to access 
outline stitches.

Click Object Properties (General toolbar) to adjust 
stitch settings.

Select Triple or 
Single stitch

Too few stitches to 
follow tight curve

Stitches follow curve 
more closely

Stitch 
length

Stitch 
length

Enter stitch
length

Select Single
or Triple
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Creating Satin outlines

Use Satin outline type to create thicker borders. 

To create a Satin outline

1 Click the Outline icon and choose Satin from the 
dropdown menu.

Note  The outline is created with default Satin 
stitch settings. Stitch spacing and width can be 
adjusted before or after digitizing. See Adjusting 
Satin outline stitch spacing and width for details.

2 Select a digitizing tool and digitize a shape, open 
or closed. See Digitizing Methods for details.

Note  The Block Digitizing tool cannot be used 
for outlines.

Adjusting Satin outline stitch spacing and 
width

Stitch spacing is the distance in millimeters between 
two needle penetrations on the same side of a shape. 
Change the stitch density in Satin outlines by 
adjusting the Stitch Spacing setting. The larger the 
spacing between stitches, the lower the density. The 
smaller the value, the higher the density. Adjust Satin 

Width to change the thickness of the outline. See also 
Applying automatic spacing to Satin outline.

To adjust Satin outline stitch spacing and 
width

1 Double-click or right-click a Satin outline object.

The Object Properties > Outline Stitch > 
Satin dialog opens.

Tip  You can preset stitch settings before 
digitizing. Click the Object Properties icon to 
access the dialog at any time.

2 Select the Manual option.

The Stitch Spacing field becomes activated.

Note  If Automatic spacing is selected, the 
Stitch Spacing field is deactivated. See Applying 
automatic spacing to Satin outline for details.

3 In the Stitch Spacing field, enter a value.

To increase stitch density, enter a smaller 
value.

To reduce the density for more open stitching, 
enter a larger value.

4 Enter the satin width in the Satin Width field.

5 Click Apply.

Tip  If a Satin border is wide, some stitches may 
exceed the maximum stitch the particular 

Click Outline (Stitch and Color Bar) to access 
outline stitches.

Click Object Properties (General toolbar) to adjust 
stitch spacing and width.

Select Satin 
stitch

Satin spacingSatin width

Select Manual to
change stitch spacing

Adjust spacing
and width

Stitch Spacing 0.6mm Stitch Spacing 1.0mm



Chapter 8 : Outline & Fill Stitches

BERNINA® Embroidery Software : Onscreen Manual 64

embroidery machine can produce. When Special 
Satin is applied, BERNINA Embroidery Software 
breaks any long Satin stitches into shorter ones. 
See also Splitting long stitches in Satin fills.

Applying automatic spacing to Satin 
outline

Where a border narrows, stitches are tight, thus 
requiring fewer stitches to cover the fabric. Where it 
is very narrow, stitches need to be less dense because 
too many needle penetrations can damage the fabric. 
The Automatic Spacing setting adjusts stitch spacing 
for Satin stitches according to outline width. For 
varying width objects, Automatic Spacing changes 
spacing to the best density for the width. See also 
Adjusting Satin outline stitch spacing and width.

To apply automatic spacing to Satin outline

1 Double-click or right-click a Satin outline object.

The Object Properties > Outline Stitch > 
Satin dialog opens.

2 Select the Automatic checkbox.

3 Click Apply.

Tip  If a Satin border is wide, some stitches may 
exceed the maximum stitch the particular 
embroidery machine can produce. When Special 
Satin is applied, BERNINA Embroidery Software 
breaks any long Satin stitches into shorter ones. 
See also Splitting long stitches in Satin fills.

Adjusting Satin outline stitch offsets

By default, stitches are positioned around the center 
of a digitized line. You can, however, offset them to 
one side.

To adjust Satin outline stitch offsets

1 Double-click or right-click a Satin outline object.

The Object Properties > Outline Stitch > 
Satin dialog opens.

2 Select an offset option – Center or Offset.

Tip  See the offset by selecting the object then 
clicking the Reshape Object tool.

3 Click Apply.

Creating outlines with Blanket stitch

Blanket stitch is used to create long, narrow borders 
with a ‘comb’ effect. It is often used to stitch borders 
around appliqués. The needle penetrates both sides of 
the border, and then penetrates the second side 
again, laying the thread along the side. Blanket 
stitches are usually more open than Satin stitches.

Creating Blanket outlines

Use Blanket outline type to create long, narrow 
borders with a ‘comb’ effect. 

Click Object Properties (General toolbar) to apply 
Automatic Spacing.

Click Object Properties (General toolbar) to set stitch 
offsets.

Select
Automatic

Auto Spacing ON Auto Spacing OFF

Click Outline (Stitch and Color Bar) to access 
outline stitches.

Select center 
or offset

Satin outline 
stitches centered

Satin outline 
stitches offset

Reference 
points
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To create a Blanket outline

1 Click the Outline icon and choose Blanket from 
the dropdown menu.

Note  The outline uses default Blanket stitch 
settings. Stitch spacing and width can be adjusted 
before or after digitizing. See Adjusting Blanket 
stitch spacing and width for details.

2 Select a digitizing tool and digitize a shape, open 
or closed. See Digitizing Methods for details.

Note  When an open shape is digitized 
left-to-right, blanket stitch is oriented downwards. 
When digitized right-to-left, it is oriented upwards.

Adjusting Blanket stitch spacing and width

You can adjust the length of the stitches and the 
spacing between them.

To adjust Blanket stitch spacing and width

1 Double-click or right-click a Blanket outline object.

The Object Properties > Outline Stitch > 
Blanket dialog opens.

Tip  You can preset stitch settings before 
digitizing. Click the Object Properties icon to 
access the dialog at any time.

2 In the Stitch Spacing field, enter the spacing 
value. 

This value is the distance in millimeters between 
each perpendicular stitch. 

3 In the Blanket Width field, enter the width of 
each blanket stitch.

4 Click Apply.

Adjusting Blanket stitch offsets

By default, stitches are positioned around the center 
of a digitized line. You can, however, offset them to 
one side.

To adjust Blanket stitch offsets

1 Double-click or right-click a Blanket outline object.

The Object Properties > Outline Stitch dialog 
opens.

2 Select an offset option:

Center

Click Object Properties (General toolbar) to adjust 
stitch spacing and width.

Select Blanket 
stitch

Stitch width

Blanket 
width

Click Object Properties (General toolbar) to set Blan-
ket stitch offsets.

Adjust spacing
and width

 Spacing: 1.0 mm Spacing: 3.5 mmSpacing: 2.0 mm

Blanket width: 
2.5 mm Blanket width: 5 mm 

Select Center
or Offset
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Offset

Tip  See the offset by selecting the object then 
clicking the Reshape Object tool.

3 Click Apply.

Creating fills with Satin fill

Satin fill is well-suited to stitching narrow borders and 
shapes, where the length of each stitch forms the 
width of the border. Satin stitches are almost parallel, 
with every second stitch slightly slanted. Because 
there are generally no needle penetrations breaking 
up the fill, Satin fill creates a glossy, high-quality 
effect. 

Tip  If a border is too wide, stitches may be loose and 
not cover the fabric properly. If you intend to increase 
the design size, use Special Satin. This adjusts the 
stitch length automatically as you scale your design.

Creating Satin fills

Use Satin fill stitch when creating narrow borders and 
shapes.

To create a Satin fill

1 Click the Fill icon and choose Satin from the 
dropdown menu.

Note  The filled object is created with default Satin 
fill settings. Stitch spacing can be adjusted before 
or after digitizing. See Adjusting Satin fill spacing 
for details.

2 Select a digitizing tool and digitize a closed shape. 
See Digitizing Methods for details.

Note  The Open Object tool cannot be used for 
fills. See Digitizing tools for details.

Adjusting Satin fill spacing

Stitch spacing is the distance in millimeters between 
two needle penetrations on the same side of a shape. 
Where a shape is narrow, stitches are tight, thus 
requiring fewer stitches to cover the fabric. Where it 
is very narrow, stitches need to be less dense because 

Click Fill (Stitch and Color Bar) to access fill 
stitches.

Blanket stitches offsetBlanket stitches centered

Reference 
points

Click Object Properties (General toolbar) to adjust 
Satin fill spacing.

Select Satin 
stitch
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too many needle penetrations can damage the fabric. 
See also Preserving long stitches.

Change the stitch density in Satin fills at any stage. 
The larger the spacing, the lower the density. The 
smaller the spacing, the higher the density.

To adjust Satin fill spacing

1 Double-click or right-click a satin fill object.

The Object Properties > Fill Stitch > Satin 
dialog opens.

Tip  You can preset stitch settings before 
digitizing. Click the Object Properties icon to 
access the dialog at any time.

2 Select the Manual checkbox.

3 Enter the spacing in the Stitch Spacing field.

To increase stitch density, enter a smaller 
value.

To reduce the density for more open stitching, 
enter a larger value.

4 Click Apply.

Applying automatic spacing to Satin fill

You can set a fixed spacing value for Satin fill or let 
Auto Spacing calculate it for you. Auto Spacing 
automatically adjusts the stitch spacing wherever the 
border changes width. See also Preserving long 
stitches.

To apply automatic spacing to Satin fill

1 Double-click or right-click a satin fill object.

The Object Properties > Fill Stitch > Satin 
dialog opens.

2 Select the Automatic checkbox.

3 Click Apply.

Splitting long stitches in Satin fills
If a Satin shape is wide, some stitches may exceed 
the maximum stitch the particular embroidery 
machine can produce. When Special Satin is applied, 
BERNINA Embroidery Software breaks any long Satin 
stitches into shorter ones. It also distributes needle 
penetrations in a random pattern so that they do not 
form a line in the middle of the shape.

While Special Satin is used primarily to prevent long 
stitches in wide shapes, it can also be used as an 
alternative to Step fill. Special Satin looks more 
Satin-like and works well with turning stitches, 
creating soft lines and a little more depth. By 
contrast, Step fill is flat and can show unwanted 
patterns with tight curves. See also Preserving long 
stitches.

To split long stitches in Satin fills

1 Double-click or right-click a satin fill object.

Click Object Properties (General toolbar) to set auto-
matic spacing to Satin fill.

Satin spacing

Width

Select manual

Stitch Spacing 1.0mm Stitch Spacing 1.8mm

Select
Automatic

Different spacing 
depending on object shape

Automatic stitch spacing Manual stitch spacing

Stitch spacing remains 
same for whole object
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The Object Properties > Fill Stitch > Satin 
dialog opens.

2 Select the Special Satin checkbox.

3 Click Apply.

Creating fills with Step fill

Different stitch types suit different shapes. BERNINA 
Embroidery Software provides normal Satin and Step 
fills, as well as Fancy and Craft Stitch fills. These can 
all be accessed from the Stitch and Color Bar. There 
is also a dedicated Craft Stitch toolbar. 

Step fill consists of rows of straight stitches and is 
suitable for filling large, irregular shapes. Stitches are 
laid in rows going back and forth across the shape. 
These can be uniform or patterned. You can choose 
from a number of preset patterns. You can also 
control stitch spacing and length.

Note  With Step fills you can select patterns formed 
by needle penetrations. The default Step pattern (No. 
1) is designed to create a uniformly flat and smooth 
texture similar to a woven mat. See also Applying 
Step patterns.

Creating Step fills

Use Step fill type when creating large and/or irregular 
shapes. 

To create Step fill

1 Click the Fill icon and choose Step from the 
dropdown menu.

Note  The filled object is created with default Step 
fill settings. Stitch spacing and length can be 
adjusted before or after digitizing. See Adjusting 
Step fill spacing and length for details.

2 Select a digitizing tool and digitize a closed shape. 
See Digitizing Methods for details.

Note  The Open Object tool cannot be used for 
fills. See Digitizing tools for details.

Adjusting Step fill spacing and length

For Step, stitch density is determined by the distance 
between each row of stitches. The spacing setting is 
the distance between two forward rows.

You can also specify Step fill stitch length. This varies 
slightly to ensure that small stitches are not 
generated at the edges.

Click Fill (Stitch and Color Bar) to access fill 
stitches.

Select
Special Satin

Special Satin On Special Satin Off

Click Object Properties (General toolbar) to set step 
fill stitch spacing.

Select Step 
stitch

Stitch spacing

Stitch 
length

Forward

Backward
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To adjust Step fill spacing and length

1 Double-click or right-click a step fill object.

The Object Properties > Fill Stitch > Step 
dialog opens.

Tip  You can preset stitch settings before 
digitizing. Click the Object Properties icon to 
access the dialog at any time.

2 In the Stitch Spacing field, enter the new spacing 
value.

This value is the distance between each forward 
row of stitching.

To increase the density, enter a smaller value.

To decrease the density, enter a larger value.

3 In the Stitch Length field, enter the stitch length 
you require.

4 Click Apply.

Applying Step patterns

With Step fills you can select patterns formed by 
needle penetrations. The default Step pattern (No. 1) 
is designed to create a uniformly flat and smooth 

texture similar to a woven mat. See also Creating 
fancy fills.

There are other preset patterns to choose from. 
Experiment to find the best pattern for your purpose. 
See Step Fill Samples for details.

To apply a Step pattern

1 Double-click or right-click a step fill object.

The Object Properties > Fill Stitch > Step 
dialog opens.

2 Select a pattern.

A preview of the pattern appears.

3 Click Apply.

Click Object Properties (General toolbar) to set step 
patterns.

Adjust stitch
spacing and

length

Stitch spacing: 1.2 mm Stitch spacing: 0.7 mm

Stitch length: 5.0 mm Stitch length: 2.0 mm

Select Step
fill pattern
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CHAPTER 9
DIGITIZING METHODS

In BERNINA Embroidery Software, you build designs 
from basic shapes or ‘embroidery objects’. The 
process of creating embroidery objects on-screen is 
called ‘digitizing’. Like creating designs in graphics 
applications, this involves the use of different 
digitizing tools or methods. These are used in 
conjunction with stitch types to create embroidery 
objects. Digitizing tools in BERNINA Embroidery 
Software are similar to drawing tools except that the 
end result is an embroidery object rather than a 
drawing object.

Like drawing objects, embroidery objects have 
certain defining characteristics or ‘properties’ such as 
color, size, position, and so on. They also have 
properties unique to embroidery such as stitch type 
and density. The most important property for an 
embroidery object is its stitch type. Different stitch 
types are suited to different shapes. See Outline & Fill Stitches for details.

Object properties are defined as you digitize, but they can be changed at any 
stage. When you create an embroidery object, you can accept the default settings 
for the particular digitizing method, or apply new ones. Default settings are 
stored in the design template. You can also define ‘current’ properties to influence 
all the objects you create in the current design. See Object Properties & 
Templates for details.

This section describes how to digitize shapes with the main digitizing methods. It 
also explains how to adjust digitizing settings to obtain the best results.

Digitizing tools

Different digitizing methods or ‘tools’ are suited to 
creating different shapes or design elements. 
Digitizing methods divide broadly into two categories 
– outline and fill.

Tip  Drawing objects themselves can be converted to 
embroidery objects using Magic Wand. See Digitizing 
with Magic Wand for details.

Selecting digitizing tools

Digitizing methods divide broadly into two categories 
– outline and fill. BERNINA Embroidery Software 

Use Open Object (Digitize toolbar) to digitize a line.

Use Closed Object (Digitize toolbar) to digitize an 
irregular shape.

Use Circle/Oval (Digitize toolbar) to digitize a circle 
or oval.

Use Rectangle (Digitize toolbar) to digitize a square 
or rectangle.

Use Block Digitizing (Digitize toolbar) to digitize col-
umns.



Chapter 9 : Digitizing Methods

BERNINA® Embroidery Software : Onscreen Manual 71

provides various tools with which to digitize shapes – 
Open Object, Closed Object, Block Digitizing, 
Circle/Oval, and Rectangle. The Open Object tool 
is used to create outline shapes. The Block 
Digitizing tool is used to create columns of varying 
width and stitch angle. The Closed Object, 
Circle/Oval, and Rectangle tools are used to create 
filled or outlined shapes.

Reference points and reshape nodes
Once you have selected a digitizing tool, you digitize 
shapes by marking ‘reference points’ along an outline 
using the following conventions:

Click to enter corner points.

Right-click to enter curve points.

In general, you mark a reference point where:

a curved outline changes curvature

the outline has corners

the outline changes from a straight line to curve.

The reference points you mark when digitizing 
become ‘reshape nodes’ during reshaping operations. 
Other control points associated with objects allow you 
to transform objects (rotate, skew, etc), scale 
(resize), adjust letter spacing, and change entry and 
exit points.

Reshape nodes are color-coded, corner points 
appearing as yellow squares, curve points as 
turquoise circles, and stitch angle points as orange 
squares. Object entry points are shown as green 
diamonds, exit points as red crosses. The start and 
end points of an entire design are indicated by a small 
green circle and small red cross respectively. 

Note  Most reshape nodes can be added, deleted, 
moved or changed to either corner or curve points. 
Some reshape nodes have a specific function and 
cannot be deleted – for example, the entry point 
marker. See also Reshaping & Editing Objects.

Join methods

The Closest Join setting automatically calculates the 
closest join between objects while digitizing saving 
you having to think about entry and exit points. When 
activated (the default), all newly digitized objects are 
joined by this method. When deactivated, all newly 
digitized objects are joined by the As Digitized 
method. This means they are joined from the exit 
point of the last digitized object to the entry point of 
the new object. When Closest Join is off, you are able 
to specify entry and exit points when digitizing closed 
objects. See Setting general options for details.

Switching between fill and outline 
digitizing methods 

You can quickly switch from fill stitch to outline stitch 
using the Fill and Outline tools. See also Outline & 
Fill Stitches.

To switch between fill and outline digitizing 
methods

Select a digitizing tool then click either the Fill or 
Outline icon before digitizing a shape.

Digitizing open shapes

Use the Open Object tool to digitize open shapes of 
single/triple run, satin, blanket, patterned or craft 

Use Outline (Stitch and Color Bar) to digitize a 
line.

Use Fill to digitize a shape.

Use Open Object (Digitize toolbar) to digitize open 
shapes. 

Closest 
Join on

Closest 
Join off
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stitching. Open Object places a row of stitches along 
a digitized line. This tool is typically used to add 
borders to designs.

To digitize an open shape

1 Select an Outline stitch type. See Selecting 
outline stitches for details.

2 Click the Open Object icon.

3 Digitize the shape, by marking reference points 
around its outline.

Click to enter corner points.

Right-click to enter curve points.

Tip  Follow the prompts in the Status Bar to help 
you digitize. If you make a mistake, press 
Backspace to delete the last reference point, then 
continue adding reference points or press Esc to 
delete all the points so you can start again.

4 Press Enter to complete the shape.

Note  If you decide to close the object, use the 
Arrange > Close Object > ... command with the 
option of using straight or curved points.

Digitizing closed shapes

Digitize complex shapes with the Closed Object tool. 
Create objects using left and right clicks to mark 
reference points to form the boundary outlines.

To digitize closed shapes

1 Select an Outline or Fill stitch type. See Selecting 
or changing stitches for details.

2 Select the Closed Object tool and digitize the 
boundary of the shape by marking reference 
points around its outline:

Click to enter corner points.

Right-click to enter curve points.

Tip  Follow the prompts in the Status Bar to help 
you digitize. If you make a mistake, press 
Backspace to delete the last reference point, then 
continue adding reference points or press Esc to 
delete all the points so you can start again.

3 Close the shape.

To close the shape with the same type of 
reference point as the last you digitized – i.e. 
corner or curve – simply press Enter.

To close the shape using a different type of 
reference point, mark the last on top of the first 
and press Enter.

4 Repeat as many times as necessary to create more 
objects.

Note  By default, objects are joined by the 
Closest Join method. If deactivated, all newly 
digitized objects are joined by the As Digitized 
method. This means you need to specify entry and 
exit points, following prompts in the Status Bar. 

Use Closed Object (Digitize toolbar) to digitize irreg-
ular closed shapes.

Open objects

1

2

3
4

5
6 1

2

o3
4

5
6

Open object Close Object used

Outlined closed object Filled closed object

1

2

3
4

5
6

1

2

3
4

5
6

Objects are closed automatically 
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See Setting general options for details. See also 
Adjusting entry and exit points.

5 Press Esc to deselect the tool.

Digitizing columns of varying width

Use the Block Digitizing tool to digitize columns of 
varying width and stitch angle. Digitized pairs of 
reference points define the outline, while lines 
connecting the pairs define the stitch angles.

To digitize a column of varying width 

1 Select a Fill stitch type. See Selecting fill stitches 
for details.

2 Click the Block Digitizing icon.

3 Digitize the column by marking reference points on 
alternate sides of the column.

Click to enter corner points.

Right-click to enter curve points.

Mark a pair of points wherever the outline 
changes, and wherever you want the stitch angle 
to change.

Tip  The reshape nodes in a pair do not have to be 
the same type. For example, one can be a corner 
point, the other a curve.

Tip  If you make a mistake, press Backspace to 
delete the last reference point, then continue 
digitizing.

4 Press Enter to complete.

5 Repeat as many times as necessary to create more 
objects.

By default, objects are joined by the Closest Join 
method. If deactivated, all newly digitized objects 
are joined by the As Digitized method. This 
means you need to specify entry and exit points, 
following prompts in the Status Bar. See Setting 
other general options for details. See also 
Adjusting entry and exit points.

Tip  If you are using the As Digitized method, 
you can choose whether to omit or include the last 
stitch. For example, if joining two objects, keep or 
omit the last stitch so that the exit point is close to 
where you begin the next object.

Press Enter to keep the last stitch and place 
the exit point at the last reference point you 
marked.

Use Block Digitizing (Digitize toolbar) to create col-
umns of varying width and stitch angle.

As digitized Closest join

Stitches change their 
angle gradually

Stitches remain parallel 
between parallel stitch angles

Different types of reshape node in same pair

Start

Finish

Start
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Press Spacebar to omit the last stitch and 
place the exit point on the opposite the last 
reference point you marked.

6 Press Esc to deselect the tool.

Digitizing circles and ovals

Digitize circles and ovals with a few clicks. You can use 
any fill or outline stitch type with circles and ovals.

To digitize a circle or oval

1 Select an Outline or Fill stitch type. See Selecting 
or changing stitches for details.

2 Click the Circle/Oval icon.

3 Digitize the circle or oval.

Click to mark the center of the circle or oval. A 
circle outline attaches to the pointer.

Move the pointer until the outline is the 
required size, then click to mark the radius 
reference point.

To create a circle, press Enter.

To create an oval, click again to mark a second 
radius point, and press Enter.

Digitizing squares and rectangles

Digitize squares and rectangles with a few clicks. You 
can use any fill or outline stitch type with squares and 
rectangles.

To digitize a square or rectangle

1 Select an Outline or Fill stitch type. See Selecting 
or changing stitches for details.

2 Click the Rectangle icon.

3 Digitize the square and rectangle.

Click to mark one corner of the rectangle. 

Drag the pointer until the outline is the required 
size. 

Click again to define the opposite corner of the 
rectangle/square.

Use Circle/Oval (Digitize toolbar) to digitize circles 
and ovals.

Start Finish Start

BlanketSatinSingle

Fancy Pattern RunStep 

Use Rectangle (Digitize toolbar) to digitize squares 
and rectangles.

Press Enter Press Enter

center

center

1

2

1

2

3

BlanketSatinSingle

FancyPattern RunStep

1

2



Chapter 9 : Digitizing Methods

BERNINA® Embroidery Software : Onscreen Manual 75

To create a square, hold the Ctrl key down 
whilst dragging the pointer.
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CHAPTER 10
THREAD COLORS & CHARTS

When you digitize, you select thread colors for each 
object you create from the Color Palette in the Design 
Window. The palette contains a selection of thread 
colors tailored to each design. This color scheme 
represents the actual threads in which the design will 
be stitched. You can select colors from commercial 
thread charts containing a range of colors from 
different manufacturers. To save time when setting up 
new color schemes, you can create your own thread 
chart using your favorite or most frequently used 
colors. In BERNINA Embroidery Software you can 
search for particular threads by criteria. Even match 
threads automatically from selected charts to colors in your design.

This section describes how to select colors from the Color Palette as well as how 
to assign threads to the colors in your design. How to modify thread charts is also 
covered, as well as creating custom thread charts.

Changing thread colors

New objects are digitized using the selected color on 
the Stitch and Color Bar. You can change the color 
before or after digitizing. If the color you want is not 
available, you may need to add it to the palette.

Note  Due to the differences in computer monitors 
and computer video cards, the approximate colors 
displayed should be used only as guides. Threads 
should always be matched to the appropriate physical 
color card. 

Changing current colors

When you digitize a new object, it automatically takes 
the color selected in the Color Palette. This is the 
‘current’ color.

To change the current color

1 Deselect all objects. The currently selected 
(default) color is shown on the toolbar with a 
dropdown arrow beside it.

Note  The Color Palette expands to accommodate 
numbers of colors.

2 Click the arrow beside the Color icon in the Stitch 
and Color Bar.

3 Select a color from the Color Palette.

This color becomes current for newly digitized 
objects.

Use Color (Stitch and Color Bar) to set current 
color.

Current color

Click to open 
Color Palette
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Recoloring selected objects
Change the color of one or more selected objects in 
your design at any time.

To recolor a selected object

1 Select the object/s you want to recolor.

2 Click the arrow beside the Color icon in the Stitch 
and Color Bar.

The Color Palette opens.

3 Select a color from the Color Palette.

The selected objects change color immediately. 

Assigning thread colors

In BERNINA Embroidery Software you can search for 
particular threads manually by various criteria and 
assign them to your design. Thread color matching 
lets you to find and change a thread color based on 
closest match in one or several thread charts. The 
Color Wheel function allows you to change colors in 
an entire design and match them automatically to 
colors in the chart.

Tip  The Thread Chart > Print option allows you to 
print the thread list in the current thread chart as a 
shopping reference when purchasing threads. See 
Printing thread charts for details.

Searching and assigning threads

You can search for a thread by code or description and 
assign it to a selected design color slot. The supplied 
charts represent the brands of threads that BERNINA 
Embroidery Software supports. Each chart has a 
range of colors associated with it. The code, brand 
and description of each color is displayed so that you 
can easily find them in a craft or sewing shop. You can 
select colors by shade or by number. Select the thread 
chart for the brand of thread you have at home or just 
select a chart which has colors you like.

Note  You can also create your own thread charts, 
even charts which include threads from different 
makers. See also Creating custom thread charts.

To search and assign a thread

1 Select Settings > Thread Colors or click the link 
in the Color Palette dialog.

The Design Properties > Thread Colors dialog 
opens.

Select color 
from Color 

Palette

Click to open 
Color Palette

Select Thread Colors (Settings menu) to search for a 
thread.

Click to access 
Thread Colors

Select thread criterion

Select
thread chart

Enter search
string

Code or
description

matched

Click to change
background

color



Chapter 10 : Thread Colors & Charts

BERNINA® Embroidery Software : Onscreen Manual 78

Tip  Change backgrounds via the BKG button at 
the top of the Threads in Design panel. See 
Changing backgrounds for details.

2 Select a thread chart from the Thread Chart list. 

3 Select the thread criterion to search on – Code or 
Description.

Code is the identification number of a thread color 
in a brand.

4 In the Search field, enter the first few characters 
of the required code or description.

The system searches for the closest match and 
displays them in the thread color list.

5 Select a color in the Threads in Design panel and 
click Assign or double-click the thread.

6 Click Apply to preview any changes directly in the 
Design Window.

7 Click OK to close.

Note  Selected color settings only apply to the 
current design and are part of the ‘design 
properties’. As such they are saved with the 
design.

Matching and assigning threads

Use the Match command to match a selected design 
color to a color in the current thread chart. Optionally, 
the Match & Assign All option matches all design 
colors with their nearest threads and replaces them 
automatically.

Tip  You can also use this method to change all 
objects of one color to another color. For example, 
change all light green objects to dark green.

To match and assign threads

1 Select Settings > Thread Colors or click the link 
in the Color Palette dialog.

The Design Properties > Thread Colors dialog 
opens. All colors in the current design are 
displayed in the Threads in Design panel.

2 Select a design color from Threads in Design list.

3 Select a thread chart from the Thread Chart list. 

The Match button is enabled.

4 Click Match.

The closest available thread is highlighted at the 
top of the Thread Color list. 

5 Click the Assign button or double-click the thread.

The selected color in the Threads in Design list 
is replaced by the closest matching thread. 

6 Repeat until all the colors you intend to use in the 
design have been matched.

Tip  Alternatively, simply click the Match & 
Assign All button. The closest matching thread in 
the selected thread chart is found for each color 
and replaced automatically.

7 Click Apply to preview any changes directly in the 
Design Window.

Select Thread Colors (Settings menu) to match threads 
from different charts.

Select color
to match

Select
thread chart

Click to match 
color to thread

Click to assign 
matching thread

Orange assigned 
to yellow

Another green 
color assigned

Original design 
colors
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8 Click OK to close.

Changing entire design colors
The Color Wheel function allows you to change 
colors in an entire design and match them 
automatically to colors in the chart (if sufficiently 
defined). If BERNINA Embroidery Software cannot 
find a useful match, it adds colors to the palette 
instead. You then need to manually match them to 
threads (or use Match & Assign All). The main 
purpose of the tool is to create a new ‘colorway’ 
quickly and easily in order to ‘spice up’ old designs or 
place them on a different fabric.

To change entire design colors

1 Select the objects you want to modify or the entire 
design.

2 Select Color Palette from the Stitch and Color 
Bar via the Color button.

3 Select Color Wheel from the palette.

The Color Wheel dialog opens.

4 Use the Hue and Brightness controls to create 
the desired colorway and click OK.

The design changes to reflect the new color 
scheme. If you have sufficient colors already 
defined in the color chart, they will be 
automatically matched. Otherwise, BERNINA 
Embroidery Software will add the colors to the 
palette instead.

5 If you need to match and assign thread colors, you 
can do so manually or use the Match & Assign All 
function. See Matching and assigning threads for 
details.

Modifying thread charts

Update existing thread charts by modifying thread 
details or removing threads. You can also rename or 
delete thread charts.

Note  The thread charts contained in BERNINA 
Embroidery Software represent the many different 
brands and colors of thread available. Unfortunately, 
these charts may not always be accurate because 
thread manufacturers often change, delete, and add 
new colors to their lines. For this reason, you can 
modify charts to update your own personal palette of 
threads.

Modifying thread details
Change the code, brand or description for an existing 
thread.

To modify thread details

1 Select Settings > Thread Colors or click the link 
in the Color Palette dialog.

Select Color Wheel
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The Design Properties > Thread Colors dialog 
opens.

2 Click Create/Modify.

The Modify Thread Chart dialog opens.

3 From the Name list, select the chart to modify.

4 In the Threads list, select the thread to modify.

5 Click Edit.

The Edit Thread dialog opens.

6 Edit the code, brand, and description details for 
the thread color as required.

Code is the identification number of a thread color 
in a brand.

7 Click Mix to select the thread display color. See 
Mixing your own thread colors for details.

8 Click OK.

The edited color appears in the Threads list.

Mixing your own thread colors
You can change the color that displays for a particular 
thread, or create new thread colors using the Color 
dialog. 

To mix your own thread colors

1 In the Add Thread or Edit Thread dialog, click 
Mix. 

See Modifying thread details for details.

See Adding your own colors to thread charts for 
details.

The Color dialog opens.

2 From the Basic colors table, select a color that 
closely matches the color you require.

3 Click and drag the cross hairs on the color 
spectrum to get the exact color you require. 

4 Drag the slider on the right of the color spectrum 
to adjust color brightness.

The HLS and RGB values appear in the bottom 
right-hand corner of the Color dialog. Enter these 
values directly to define exact colors.

5 When you have mixed the required color, click Add 
to Custom Colors.

6 Click OK.

The new color appears in the Color preview box. 

Removing threads from charts

You can remove obsolete thread colors from thread 
chart easily, using the Modify Charts dialog.

Click to modify 
thread chart

Select thread chart

Select thread to modify Click to edit thread color

Edit code, 
brand and 
description

Mix color

Select Thread Colors (Settings menu) to remove threads 
from charts.
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To remove threads from charts

1 Open the Modify Thread Chart dialog. See 
Modifying thread details for details.

2 From the Name list, select the chart to modify.

3 In the Threads list, select the thread (or threads) 
to remove:

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

4 Click Remove. 

You are prompted to confirm.

5 Click Yes.

Tip  To delete all the threads from a thread chart, 
click Clear All.

Renaming thread charts

Rename thread charts from the Modify Thread 
Chart dialog. 

Tip  Select names that will help you remember the 
charts you need, or that sort frequently used charts 
to the top of the list.

To rename thread charts

1 Open the Modify Thread Chart dialog. See 
Modifying thread details for details.

2 From the Name list, select the chart to modify.

3 Click Rename.

The Rename Thread Chart dialog opens.

4 Enter the new name for the thread chart, then click 
OK.

Deleting thread charts

Delete obsolete thread charts from the Modify 
Thread Chart dialog.

Note  Be careful when deleting thread charts. If you 
delete the wrong chart you will need to reinstall 
BERNINA Embroidery Software to restore it.

To delete thread charts

1 Open the Modify Thread Chart dialog. See 
Modifying thread details for details.

2 From the Name list, select the chart to delete.

3 Click Delete.

You are prompted to confirm the deletion. 

4 Click Yes.

Creating custom thread charts

Thread charts are lists of pre-defined thread colors. 
They may be based on commercially available thread 
charts, or charts you define yourself.

Tip  The Thread Chart > Print option allows you to 
print the thread list in the current thread chart as a 
shopping reference when purchasing threads. See 
Printing thread charts for details.

Select Thread Colors (Settings menu) to rename thread 
charts.

Click to remove 
selected color 
from chart

Click to remove 
ALL colors from 
chart

Select thread chart Click to rename chart

Select Thread Colors (Settings menu) to delete thread 
charts.

Select Thread Colors (Settings menu) to create new thread 
charts.

Rename chartMy Madeira 40

Select thread chart Click to delete chart
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Creating new thread charts
When you create a thread chart, you are creating a 
store of colors to use in your designs. For instance, 
you may want to create a chart consisting of threads 
you already have in your collection. This may include 
multiple brands of threads. Having a pre-sorted list in 
your own custom thread chart makes it easier to 
match and replace design colors with your available 
threads.

To create a new thread chart

1 Select Settings > Thread Colors or click the link 
in the Color Palette dialog.

The Design Properties > Thread Colors dialog 
opens.

2 Click Create/Modify.

The Modify Thread Chart dialog opens.

3 Click New.

The New Thread Chart dialog opens.

4 Enter a name for the chart and click OK.

Note  Do not use symbols or punctuation, such as 
commas, when creating your own color charts or 
editing existing color charts.

You return to the Modify Thread Chart dialog. 
The new chart is created, ready for you to add 
thread colors.

5 Click Add to open the Add Thread box. See 
Adding your own colors to thread charts for 
details.

6 Click Copy From to add colors from an existing 
chart. See Copying colors between charts for 
details.

7 Click Close.

The new chart is created and ready for use.

Copying colors between charts
You can copy colors between different thread charts 
to create your own charts from existing colors. 

To copy colors between charts

1 Open the Modify Thread Chart dialog. See 
Creating new thread charts for details.

2 Select a chart from the Thread Chart > Name 
list.

3 Click Copy From. 

Click to create 
thread chart

Click New

Enter chart 
name

My Thread Chart

New chart 
created

Select thread chart

Click to copy from other chart
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The Copy From dialog opens.

4 From the Name list, select the thread chart 
containing the color you want to copy.

5 Select the colors you want to copy:

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

6 Click OK.

The colors are copied to the thread chart, and 
appear at the bottom of the list.

Adding your own colors to thread charts
You can add colors to thread charts using colors from 
other charts or colors you mix yourself.

To add your own colors to a thread chart

1 Open the Modify Thread Chart dialog. See 
Creating custom thread charts for details.

2 Click Add to add your own colors.

The Add Thread dialog opens.

3 Click Mix to select the thread display color. See 
Mixing your own thread colors for details.

4 Enter code, brand, and description details for the 
new thread color.

Code is the identification number of a thread color 
in a brand.

5 Click OK. 

The new color appears in the Threads list.

Select thread chart to copy from

Select thread 
colors

Mix color

Enter code, 
brand and 
description

1234
My Brand
Purple
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CHAPTER 11
OBJECT PROPERTIES & TEMPLATES

The properties of embroidery objects define general 
characteristics such as size and position, as well as 
embroidery-specific characteristics such as stitch type and 
density. The particular stitch settings determine how stitches 
will be regenerated when you reshape, transform or scale an 
object.

When you create an embroidery object, you can accept default 
settings for the particular digitizing method, or apply new 
ones. Default settings are stored in the design template. You 
can also define ‘current’ properties to influence all the objects 
you create in the current design.

This section explains how to change the object properties in 
your design, as well as how to apply, create and maintain 
templates in BERNINA Embroidery Software.

Applying and managing object 
properties

BERNINA Embroidery Software stores three sets of 
object properties: default, current and existing.

Note  Some object properties can be modified 
on-screen; for example, you can change the size 
properties by scaling the object with the selection 
handles. Other properties, such as stitch spacing or 
length, are modified in the Object Properties dialog.

Default object properties

Default object properties are the properties stored in 
a design template and become the starting settings 
used when creating a new design based on that 
template.

Current object properties

Current object properties are the settings used to 
create new objects. Unless you change these settings, 
they remain the same as the template defaults. You 
generally change them to save time when digitizing. 
For example, you may preset the Step stitch spacing 
setting to use a specific density for all new Step 
objects you create. 

Note  The change affects new objects in the design, 
not the template itself. To apply changes to all new 
designs based on the current template, you need to 
change the default – not the current – properties. 

Properties of existing objects

Properties of existing objects are the settings stored 
with each object in the design.

Setting current object properties

When you change current object properties, the new 
settings automatically apply to any new objects 
created in the current design. 

To set current object properties

1 Click the Object Properties icon with no object 
selected. 

Use Object Properties (General toolbar) to set cur-
rent properties.
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The Object Properties dialog opens.

Tabs display at the top of the Object Properties 
dialog. These provide access to all the possible 
object properties settings.

2 Click a tab to view the current settings and change 
as required.

3 Click Apply.

Changing properties of selected objects
You can change the properties of selected object/s. 
For example, if you make a design bigger, you may 
want to stitch some objects with Step fill instead of 
Satin fill for better coverage. If you select more than 
one object, the Object Properties dialog will only 
display tabs that include relevant settings for all 
selected objects. 

If selected objects have different current values for 
the same setting, the field will be blank. If you enter 
a new value, it will apply to all objects.

Note  Changing the properties of existing objects 
does not affect the current or default settings, nor the 
properties of any objects not currently selected.

To change properties of selected objects

1 Select the object/s whose properties you want to 
change.

2 Double-click or right-click the object/s.

The Object Properties dialog opens.

3 Select the tab you want and change the settings as 
required.

4 Click Apply.

Changing default object properties
You can change default object properties at any time 
by saving the properties of the object you are working 
with to the current template. Only settings relevant to 
that object are saved. Other properties retain their 
current settings. For example, if you make the 
properties of a selected Satin object the default, the 
default Fancy Fill settings will not change. While 
saving changes to the template, you can choose 
whether settings will relate to lettering objects only, 
other types of objects, or both.

Note  The change affects all new designs created 
using this template. If you only want the changes to 
apply to the design you are working in, change the 
current – not the default – properties. See Setting 
current object properties for details.

To change default object properties

1 Select the object/s on which you want to base the 
defaults.

2 Double-click or right-click the object/s.

The Object Properties dialog opens.

3 Select the tab you want and change the settings as 
required.

4 Click Save To Template.

Select
tab

Adjust
settings

Default Satin Spacing 
values applied

New Satin Spacing 
values applied

Change settings
as required

Click to save to
template
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The Save To Template dialog opens.

5 Select the required option:

Lettering: only new lettering objects will be 
affected by changed settings.

Other Objects: only new objects other than 
lettering will be affected.

All objects: all new objects will be affected by 
changed settings.

A confirmation message appears.

6 Click OK to update the template.

The object properties are saved to the current 
template and will apply to any new objects of the 
specified type based on this template.

Note  You can also create a new template using 
modified object properties as defaults. See 
Managing design templates for details.

Managing design templates

Templates are special files used to store default 
settings. Use templates when digitizing 
frequently-used design types so that you do not have 
to set the current properties every time. For example, 
a template may include standard objects and sample 
lettering. It may simply have preferred stitch settings, 
lettering font and size, and colors set as current 
properties. Or it may have special density, pull 
compensation or underlay settings set up to suit 
different fabrics.

The NORMAL template is the default template 
supplied with BERNINA Embroidery Software. It 
contains current object properties. If necessary, you 
can revert to the original NORMAL template after 
modifying it. See Reverting to the NORMAL template 
for details.

Creating design templates
You create templates from designs containing the 
required objects and object properties. Simply save 
the design, or elements of it, as a template. 
Templates look the same as design files, but use the 
file extension AMT. Make sure that you select a name 
for your new template before saving changes. If you 
make changes to your Object Properties settings – 
and click Save To Template – the changes will be 
saved to the template you are now using. See also 
Changing default object properties.

Note  You cannot overwrite templates by accident. 
Each time you create a new design from a template, 
BERNINA Embroidery Software opens a duplicate. 
When you save the design the first time, the Save As 
dialog opens so you can save the template under a 
new name.

To create a design template

1 Start a new design or open an existing one.

2 Adjust the object properties as required.

3 Add any objects and lettering to be included in the 
template.

For instance, you may want to include sample 
lettering using different baselines. Simply 
overtype the sample text when using the 
template. See Applying lettering baselines for 
details.

4 Select File > Save As. 

Frequently used 
Background color 
can be saved in the 
template
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The Save As dialog opens.

5 Select BERNINA Embroidery Software 
Templates from Save as Type dropdown list.

BERNINA Embroidery Software automatically 
opens the ..\Program 
Files\BERNINA\Embroidery 
Software 6\template folder. Design templates 
must be saved here or they will not appear in the 
template list when you start a new design. 

6 Enter a name for the template in the File Name 
field.

7 Click Save.

Modifying design templates
You can modify templates in the same way as a 
normal design. Changes apply only to future uses of 
the template. Existing designs based on the template 
are not affected.

Note  Delete templates in the same way as you would 
any other file using MS Windows® Explorer. 
Templates are located in the ..\Program 
Files\BERNINA\Embroidery 
Software 6\template folder.

To modify design templates

1 Select File > Open.

The Open dialog opens. 

2 Navigate to the ..\Program 
Files\BERNINA\Embroidery 
Software 6\template folder.

3 Select BERNINA Embroidery Software 
Templates from the Files of Type dropdown list.

The available template files display.

4 Select the template you want to modify and click 
Open.

5 Modify object properties, styles and other settings 
as required.

6 Select File > Save As.

The Save As dialog opens.

7 Select the ..\Program 
Files\BERNINA\Embroidery 
Software 6\template folder.

8 From the Save as Type dropdown list, select 
BERNINA Embroidery Software Templates.

9 Select the template file and click Save.

A confirmation message appears.

Tip  To create a new template based on the 
modified one, type a new file name and click Save.

10 Click Yes to confirm.

The modified template is ready for use.

Saving current properties to a template
You can easily save current object properties to the 
current template. See also Applying and managing 
object properties.

Select BERNINA
templates

Enter template
name

Lettering added to 
template for display 
with every design

Design 1 Design 2 
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To save current properties to a template

1 Access the Object Properties dialog. 

To use the current object properties, deselect 
all objects, then click the Object Properties 
icon. 

To use the properties for a particular object, 
select the object, then double-click or 
right-click it.

2 Change object properties settings as required.

3 Click Save To Template.

A confirmation message appears.

Note  Only the current object properties – not the 
objects or other settings in the design – are saved 
to the template.

4 Click OK to update the template.

5 Click Close to return to the Design Window. 

The new settings are saved in the template from 
which the design was created and are available for 
use.

Reverting to the NORMAL template
If you modify the NORMAL template supplied with 
BERNINA Embroidery Software, you can revert to the 
original version. A factory copy is always maintained 
so that the NORMAL template can be restored.

To revert to the NORMAL template

1 Close BERNINA Embroidery Software.

2 Click the MS Windows® Start button and select 
All Programs > BERNINA Embroidery 
Software > Revert.

The Revert to Factory Template dialog opens.

Note  It may take up to 1 or 2 minutes for the 
dialog to open.

3 Select the Templates checkbox and click OK.

The original settings for the NORMAL template are 
restored.

Select
Templates

Click OK
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CHAPTER 12
STITCH QUALITY

BERNINA Embroidery Software provides many settings 
to help improve the quality and efficiency of your final 
stitchout. Use fabric settings so that the machine will 
take into account the type of fabric you are stitching 
on. Use Auto Underlay to help stabilize fabric and 
reduce distortion due to the pull effect. Adjust the 
amount of overstitching you need by varying the pull 
compensation setting. This is handy if you want to 
stitch a design on fabrics with varying degrees of 
stretch.

By applying Auto Jump, you can preserve long stitches 
in objects by turning them into a series of jumps. By 
default, tie-in stitches are automatically inserted at the 
start of objects to prevent stitches from unraveling. 
You can control tie-in/offs settings for whole designs or 
particular objects. Use Auto Start and End to set the 
positions of first and last stitches in a design. All these 
features are object properties, and can be applied, removed or modified at any 
time.

This section covers adjusting fabric settings, stabilizing with underlays, and 
compensating for fabric stretch. It also describes how to preserve long stitches, 
adjust tie-in/off settings, and set automatic start and end points.

Adjusting fabric settings

BERNINA Embroidery Software allows you to change 
fabric settings so that the machine will take into 
account the type of fabric you are stitching on. For 
example, the fabric setting you choose will set the pull 
compensation to suit the fabric you will be 
embroidering on. Pull compensation keeps your 

design from having gaps between objects. See also 
Compensating for fabric stretch.



Chapter 12 : Stitch Quality

BERNINA® Embroidery Software : Onscreen Manual 90

Stitch settings for different fabric types are 
summarized in the table below.

Note  By default, the new settings will be applied to 
all objects in the design except for lettering. See also 
Compensating for fabric stretch.

To adjust fabric settings

1 Select Edit > Select All.

Your entire design is selected.

2 Select Settings > Fabric Settings.

The Fabric Settings dialog opens.

3 Select a fabric type from the Fabric Type list.

4 Select to use standard settings or fine tune the 
settings using your own values.

Use Standard Settings: Changes are made 
according to the type of fabric you selected.

Adjust Spacing: Enter a value to fine tune the 
setting. A number greater than 100 will 
increase the stitch spacing. A number less than 
100 will decrease stitch spacing. In some 

cases, the pull compensation will also be 
adjusted.

5 Click OK.

The selected fabric settings are applied to all 
objects in the design.

Stabilizing with underlays

To improve the quality of the stitchout, you need to 
add underlay. Underlay helps stabilize fabric and 
reduce distortion due to the pull effect. It also 
provides ‘loft’, raising cover stitches and preventing 
them from sinking into soft fabrics. When no underlay 
is applied, the embroidery lays flat on the fabric. It 
not only looks flat, but the underlying fabric often 
shows through. New digitizers might be tempted to 

Pull Comp 
(mm)

Spacings (mm)

Weight Fabrics Satin 
(Manual)

Satin 
(Auto) Step Zigzag 

Underlay
Step 

Underlay

Factory defaults N/A 0.200 0.4 0.01 0.45 3.0 3.0

Knit Light T-shirts 0.250 0.37 0.02 0.40 3.0 2.5

Knit Medium Polo shirts / Pique 0.250 0.37 0.02 0.40 3.0 2.5

Knit Heavy Fleece / Sweatshirts 0.350 0.36 -0.02 0.38 2.5 2.5

Terry Medium Towels 0.250 0.36 0.02 0.38 1.5 1.8

Terry Heavy Towels / Bath Robes 0.250 0.36 -0.02 0.38 1.5 1.8

Woven Light Batiste / Cotton / Satin 0.200 0.38 0.03 0.40 3.0 2.8

Woven Medium Cotton / Muslin / Polyester 0.200 0.38 0.0 0.40 2.5 2.5

Woven Heavy Denim / Canvas / Twill 0.200 0.38 -0.01 0.40 2.5 2.5

Knit Heavy Weight 
setting adjusted to 150%

Knit Heavy Weight 
setting adjusted to 75%
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increase stitch density but it is more effective to apply 
a proper underlay.

Applying automatic underlays

The Auto Underlay tool generates underlay stitching 
for objects based on current settings in the Effects 
dialog. You can preset Auto Underlay to generate 
automatic underlay stitching for all newly created 
objects in your design. Underlay settings are stored 
with each object in the same way as other object 
properties. Thus they are regenerated whenever the 
object is scaled or transformed.

To apply automatic underlays

1 Right-click the Auto Underlay icon.

The Effects > Underlay dialog opens.

2 Select Use automatic underlay settings for 
new objects if already not selected.

Caution  When this option is set, BERNINA 
Embroidery Software always calculates automatic 
settings even if you have saved custom settings to 
the template. See also Applying custom underlays.

3 Click Apply.

All newly digitized objects will include an underlay 
determined automatically by the system.

Applying custom underlays

The Auto Underlay tool generates underlay stitching 
for objects based on current settings in the Effects 
dialog. You can preset custom underlay settings for all 
newly created objects in your design, or apply them 
to selected objects. 

To apply custom underlays

1 Click the Auto Underlay icon to activate the 
feature.

Tip  To adjust settings prior to digitizing, right-click 
the Auto Underlay icon to access the Effects > 
Underlay dialog.

2 Create a closed-object – circle or square. See 
Digitizing Methods for details.

The object is digitized using current Auto 
Underlay settings.

3 If you want to change underlay settings, select the 
object and right-click the Auto Underlay icon.

Use Auto Underlay (General toolbar) to strengthen 
and stabilize embroidery designs with automatic 
underlay. 

Automatically
generate
underlay

stitching for new
objects

Use Auto Underlay (General toolbar) to strengthen 
and stabilize embroidery designs with automatic 
underlay. 

Step Stitch Block 
Digitizing - Step 
Underlay

Satin Stitch Block 
Digitizing - Zigzag 
Underlay

Satin Stitch Closed 
Curve - Step 
Underlay

Step Stitch Closed 
Curve - Step 
Underlay
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The Effects > Underlay dialog opens. This tab 
gives you the option of a single underlay or 
combined first and second underlays.

4 Select Apply Underlay 1 and select an underlay 
type from the dropdown list.

The type of underlay you choose is determined by 
the purpose it is to serve.

Note  Not all underlay types are applicable to all 
selected objects.

5 Adjust stitch length and margin settings as 
required. See Adjusting Edge Walk underlay 
spacing, Adjusting zigzag underlay spacing, and 
Setting underlay margins for details.

When you select the Apply Underlay 1 option, 
the Apply Underlay 2 checkbox becomes active. 
All underlay types available for Underlay 1 are also 
available for Underlay 2.

6 For extra stability, select a second underlay.

Any combination of underlay types can be used.

Caution  You should, however, use only one Step 
underlay at a time – i.e. it is not good practice to 
combine Step stitch for both Underlay 1 and 
Underlay 2.

7 Click Apply.

New or selected objects use the new settings.

8 To keep a permanent record of your custom 
settings, click Save To Template. See Saving 
current properties to a template for details.

9 Select Use automatic underlay settings for 
new objects if already not selected.

Caution  When the Use automatic underlay 
settings for new objects option is set, BERNINA 
Embroidery Software always calculates automatic 
settings even if you have saved custom settings to 
the template. See Applying automatic underlays 
for details.

Adjusting Edge Walk underlay spacing

Edge Walk places stitches around the edge of an 
object. Adjust the stitch length for Edge Walk 
underlays to ensure the underlay stitches follow the 
shape of curves and are not visible in the final 
embroidery. Apply settings before or after digitizing.

Note  Stitch settings for Edge Walk underlays are 
stored separately from, and do not affect, cover stitch 
settings.

Select 1st
underlay and

stitch type

Zigzag 
underlay

Step 
underlay

Double Zigzag 
underlay

Edge Walk 
underlay

Select 2nd
underlay and

stitch type

Right-click Auto Underlay (General toolbar) to 
change automatic underlay settings.

Zigzag 
underlay

Edge Walk 
underlay

Step underlay

Edge Walk 
underlay
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To adjust Edge Walk underlay spacing

1 Choose whether to make settings current or apply 
them to selected objects:

Press Esc to make sure all objects are 
deselected.

Alternatively, select an object or objects to 
adjust their particular settings.

2 Right-click the Auto Underlay icon.

The Effects > Underlay dialog opens.

3 Select the Apply Underlay 1 checkbox and select 
Edge Walk as the underlay type.

4 Enter the required stitch length.

5 Click Apply.

New or selected objects use the adjusted settings.

Adjusting zigzag underlay spacing

Use zigzag and double-zigzag underlay stitching to 
support wide columns. you can set stitch length for 
zigzag and double-zigzag underlay. Double-zigzag 
underlay only works with satin outline or lettering. 
Apply settings before or after digitizing.

Note  Zigzag underlay stitch settings are stored 
separately from, and do not affect, zigzag cover stitch 
settings.

To adjust zigzag underlay spacing

1 Choose whether to make settings current or apply 
them to selected objects:

Press Esc to make sure all objects are 
deselected.

Alternatively, select an object or objects to 
adjust their particular settings.

2 Right-click the Auto Underlay icon.

The Effects > Underlay dialog opens.

3 Select the Apply Underlay 1 checkbox and select 
Zigzag or Double Zigzag as the underlay type.

4 Enter the required stitch length.

5 Click Apply.

Selected objects are updated with the adjusted 
settings.

Setting underlay margins

The underlay margin is the distance between an 
object outline and the edge of the underlay. Increase 
this margin to prevent underlay stitches from 
extending outside the cover stitches. 

To set underlay margins

1 Choose whether to make settings current or apply 
them to selected objects:

Right-click Auto Underlay (General toolbar) to 
change automatic underlay settings.

Select Edge
Walk

Edge Walk Stitch Length: 
1.5mm

Edge Walk Stitch Length: 
3.5mm

Right-click Auto Underlay (General toolbar) to 
change automatic underlay settings.

Select Zigzag
or Double

Zigzag

Zigzag Stitch Length: 5 mmZigzag Stitch Length: 2.5 mm

Double Zigzag Stitch 
Length: 7 mm

Double Zigzag Stitch 
Length: 3.5 mm

Underlay 
margin
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Press Esc to make sure all objects are 
deselected.

Alternatively, select an object or objects to 
adjust their particular settings.

2 Right-click the Auto Underlay icon.

The Effects > Underlay dialog opens.

3 Select a Margin type from the dropdown list.

4 Click Apply.

New or selected objects use the adjusted settings.

Compensating for fabric stretch

Embroidery stitches pull fabric inwards where the 
needle penetrates. This can cause fabric to pucker 
and gaps to appear in the embroidery. Shapes are 
slightly narrower and longer in the final embroidery 
than they look on the screen. Pull compensation 
counters this effect by ‘overstitching’ outlines of filled 
shapes on the sides where the needle penetrates. 

Apply automatic pull compensation to objects in your 
design, either before or after digitizing.

The amount pull compensation required depends on 
the stitchout fabric. Experiment with the fabrics you 
are going to use and see if the set amount is suitable 
before changing it. Use the following table as a 
guideline.

You can also adjust pull compensation to suit the 
fabric you are embroidering on by selecting Settings 
> Fabric Settings. See Adjusting fabric settings for 
details.

Tip  Applying underlay stitching, and using 
appropriate backing and topping when stitching out, 
can also reduce pull effect. See also Stabilizing with 
underlays.

To apply automatic pull compensation

1 Choose whether to make settings current or apply 
them to selected objects:

Press Esc to make sure all objects are 
deselected.

Alternatively, select an object or objects to 
adjust their particular settings.

2 Click the Object Properties icon.

The Object Properties dialog opens.

3 Click the Effects button and select the Others 
tab.

4 Select the Pull Compensation checkbox.

5 Click Apply.

Use Object Properties (General toolbar) to adjust 
pull compensation settings.

Select margin
type

Normal

Medium

Wide

Fabric Pull compensation (mm)

drills, cotton 0.1

T-shirt 0.2

fleece, knit 0.25 - 0.3

lettering 0.2 - 0.3

Pull compensation

Digitized outline Calculated outline

Select Pull
Compensation
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New or selected objects use the new settings.

Tip  Pull compensation is automatically set at 
0.2 mm. This is suitable for most designs. 
However, 0.4 mm is recommended for use with 
automatic digitizing.

6 Enter an overstitch allowance (in mm) as required.

7 Click Apply.

New or selected objects use the adjusted settings.

Tip  Click Save To Template before closing this 
dialog to save settings permanently. Saved 
settings will be applied to all new designs based on 
the current template. See Object Properties & 
Templates for details.

Preserving long stitches

Embroidery machines have a maximum possible 
stitch length which is determined by the frame 
movement limitations of the machine itself. If a stitch 
exceeds this, it is broken into smaller stitches. This 
can affect the embroidery appearance, especially in 
Satin fills. By applying Auto Jump, you can preserve 

long stitches in an object by turning them into a series 
of jumps. See also Splitting long stitches in Satin fills.

To create a narrow column with more ‘loft’ than 
normal Satin, apply Auto Jump, in conjunction with a 
suitable underlay, with the maximum stitch length set 
to a small value, e.g. 6 mm. If the cover stitches are 
short, splitting them with a jump makes them looser 
and thus more effectively raised off the fabric. See 
also Stabilizing with underlays.

Auto Jump can also be used, for example, with 
manually digitized underlays. It can even be used to 
create quilted effects, for example, by applying it to 
Satin areas that are over-stitched with Run stitch or 
Pattern Fill. Auto Jump is stored as an object property 
and is activated by default. You can change its values 
at any time for selected or newly created objects. 
Auto Jump values can be adjusted for Fill stitch, 
Outline Satin and Outline Blanket stitch.

To apply Auto Jump

1 Choose whether to make settings current or apply 
them to selected objects:

Press Esc to make sure all objects are 
deselected.

Alternatively, select an object or objects to 
adjust their particular settings.

2 Click the Object Properties icon.

The Object Properties dialog opens.

3 Click the Effects button and select the Others 
tab.

4 Select Auto Jump if not already selected and click 
Apply.

Use Object Properties (General toolbar) to adjust 
Auto Jump settings.

Pull Compensation OFFPull Compensation ON

Pull Compensation: 0.2 mm Pull Compensation: 0.5 mm

Long stitch is broken into smaller 
needle arm movements or ‘jumps’

Maximum stitch

Select Auto
Jump

Adjust max stitch and
jump length values

Long jump 
stitches

No jumps
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5 In the Maximum Stitch field, adjust the 
maximum stitch length as required.

Stitches exceeding this value will have Auto Jump 
applied.

Tip  Set the maximum stitch larger than the 
longest Satin fill stitch you want to allow in the 
design, otherwise some Satin stitches will be split 
into two or more stitches.

6 In the Jump Length field, enter the length of each 
jump.

Tip  Smaller jumps increase the time required to 
stitch out but move the frame more smoothly 
across the design.

7 Click Apply.

New or selected objects use the adjusted settings.

Tip  Click Save To Template before closing this 
dialog to save settings permanently. Saved 
settings will be applied to all new designs based on 
the current template. See Object Properties & 
Templates for details.

Connecting embroidery objects

‘Connectors’ link objects in a design. They take the 
form of ‘travel runs’ or ‘jumps’ and are displayed in 
Stitch View but hidden in Artistic View. Ideally, you 
will plan your embroidery so that connecting stitches 
will be covered later by other elements of the design. 

If a connecting stitch is not covered, it will need to be 
trimmed after stitchout.

Connecting stitches are generated automatically but 
you can resequence objects in order to minimize 
trims. You can even change entry and exit points, but 
the Closest Join setting (the default) automatically 
calculates the closest join between objects while 
digitizing. See Setting other general options for 
details.

Travel runs
Travel runs are automatically added when the needle 
has to travel between segments within an object. 
They are always covered by the overlying stitches but 
may sometimes show through.

Travel runs are kept to a minimum by adjusting entry 
and exit points of consecutive objects. You can 
manually adjust entry and exit points using the As 
Digitized method, but the Closest Join setting (the 
default) automatically calculates the closest join 
between objects while digitizing. See Setting other 
general options for details.

Max stitch length: 
12.1 mm

Max stitch length: 
10 mm

Jump Length: 4 mmJump Length: 7 mm

Connectors not 
displayed in Artistic 
View

‘As Digitized’ 
connectors

‘Closest Join’ 
connectors

Travel run Entry point changed 
– no travel run

Travel run visible in 
Artistic View
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Jumps
Jump connectors move the frame from one part of the 
design to another without needle penetrations. You 
generally need to trim the connecting thread. Jump 
connectors are displayed in Stitch View either as a 
dotted or solid line – solid lines for short connectors, 
dotted lines for long connectors (more than 
12.1 mm). Dash-dotted lines indicate color changes.

Long jump connectors have needle jumps of up to 
7 mm along their length. This usually causes the 
machine to slow down while moving the hoop to the 
next needle penetration point.

Note  The default connector jump length is the same 
as that set for Auto Jump.

Tie-ins and tie-offs
Tie-ins and tie-offs are extra stitches that are added 
before and after jumps and color changes so that 
threads can be trimmed without stitches unraveling.

Tie-in stitches are automatically inserted at the start 
of objects after any connector longer than 2 mm or 
after a color change. With Satin objects, they are 
inserted inside the shape on the second stitch. 

Likewise, tie-offs are automatically added before 
connectors or before a color change.

Tip  Travel through the design by one stitch to check 
for tie-ins and tie-offs. See Traveling by stitches for 
details.

Adjusting tie-in/off settings

By default, tie-in stitches are inserted at the start of 
objects to prevent stitches from unraveling. There are 
instances, however, where whole designs may not 
include tie-ins, or where selected objects, such as 
lettering, may not include them. BERNINA 
Embroidery Software gives you control over 
tie-in/offs settings. This is necessary for specialized 
purposes such as ‘reverse embroidery’ which involves 
using thick threads in the bobbin. There can be no 
tie-offs for this. You may want to make embroidery 
with creative threads where tie-offs can’t be used. In 
these cases, you can turn off tie-ins and/or tie-offs 
and keep threads from unraveling by cutting them 
long and pulling them through. See also Adjusting 
entry and exit points.

To adjust tie-in/off settings

1 Access the Tie-In/Off controls in one of the 
following ways:

To adjust current design settings, click the 
Object Properties icon or select 
Settings > Object Properties to access the 
Object Properties dialog.

To adjust a particular object or objects, 
double-click or right-click the object(s) to 
access the Object Properties dialog.

2 Select the Tie-In/Off tab.

Long connector: dotted line

Color change: dash-dotted line (no thread to trim)

Short connector: solid line

Tie-off

Tie-in

Use Object Properties (General toolbar) to set cur-
rent properties.

Tie-in at the start of 
the object
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The tab contains two panels – Tie In Before 
Object and Tie Off After Object – which allow 
you to turn the respective option on or off.

Note  Existing designs created in previous 
versions of BERNINA Embroidery Software or 
other applications may have a connector length 
setting that differs from the 2 mm default setting.

3 Adjust the Tie In Before Object setting as 
required:

When turned off, no tie-ins are inserted for 
either external or internal connectors.

When turned on, tie-ins are inserted if the 
connecting stitch before an object is greater 
than 2 mm.

4 Adjust the Tie Off After Object setting as 
required:

When turned off, no tie-offs are inserted for 
either external or internal connectors.

When turned on, tie-offs are inserted if the 
connecting stitch following an object is greater 
than 2 mm.

5 Select a tie-off method:

The first method inserts tie-off stitches along 
the last stitch.

The second inserts tie-off stitches between the 
last two stitches.

The first method is better suited to non-lettering 
objects while the second method is better for 
lettering objects.

6 Click Apply.

Settings are applied to selected objects or, if no 
objects are selected, current properties.

Setting automatic start and end points

Before stitching, some embroidery machines require 
you to position the starting needle exactly above the 
first needle penetration point. Use automatic Start 
and End to set the positions of first and last stitches 
in a design.

To set automatic start and end points

1 Select Arrange > Start and End.

The Start and End dialog opens.

2 Select a Start Needle Position method:

First Stitch of Design: The start point is set 
to the first stitch in the design.

Auto Start at: The start point is automatically 
maintained at a specified point in the design. 
Choose from the available options:

Tie-in with two 
stitches

Select tie-off 
method

Select a start 
needle position 
method

Select an end 
needle position 
method

Select a start 
needle position
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Digitize Start Needle Position: You are 
prompted to manually mark the start and end 
points.

3 Select an End Needle Position method:

Last Stitch of Design: The end point is set to 
the last stitch in the design.

Auto End at: The end point is automatically 
maintained at a specified point in the design.

Digitize End Needle Position: You are 
prompted to manually mark the end point.

4 Select the Maintain Automatically checkbox 
(the default) to automatically maintain start 
and/or end needle positions.

5 Click OK.

Connecting stitches will be inserted as required 
before the first and after the last stitches in the 
design.

Start Point: First Stitch
End Point: Last Stitch of the 

design

Start Point: Auto Start
End Point: Auto End, Center 

of the design
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PART III
DIGITIZING WITH ARTWORK

There are two broad categories of artwork file, both of which can be imported into 
BERNINA Embroidery Software for use as digitizing backdrops – vector and bitmap. To 
create good quality embroidery, you need to choose or create suitable artwork of either 
format.

Digitizing with backdrops

This section describes how to choose suitable artwork for digitizing purposes as well as 
how to scan it into BERNINA Embroidery Software. It also describes how to digitize with 
images as backdrops, as well as how to show and hide them as you digitize. See 
Digitizing with Backdrops for details.

Processing images for automatic digitizing

This section describes how to prepare images for automatic digitizing. It explains how 
to prepare both outlined and non-outlined images. See Image Processing for details.

Automatic digitizing

This section describes how to automatically convert vector graphics as well as bitmap 
images to embroidery designs with the available techniques. It also covers how to 
create embroidery from photographs. See Automatic Digitizing for details.
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CHAPTER 13
DIGITIZING WITH BACKDROPS

Electronic artwork in both bitmap and vector formats 
can be loaded, pasted or scanned into BERNINA 
Embroidery Software for use as digitizing templates or 
‘backdrops’. Textured backgrounds can also be 
imported to show what a design will look like on real 
fabric. Almost any artwork can be used – photographs, 
magazine pictures, clipart drawings, and even fabric 
samples.

From within BERNINA Embroidery Software you can 
open images into MS Paint, Corel 
PHOTO-PAINT® Essentials 4, or Paint Shop Pro™. 
Images updated in this way are automatically 
re-imported into BERNINA Embroidery Software.

This section describes how to choose suitable artwork for digitizing purposes as 
well as how to scan it into BERNINA Embroidery Software. It also describes how 
to digitize with images as backdrops, as well as how to show and hide them as 
you digitize.

Using design backdrops

Backdrops can be used as a guide to manual 
digitizing. Alternatively, BERNINA Embroidery 
Software semi-automatic and automatic digitizing can 
convert bitmaps to embroidery designs. In summary, 
backdrops can help you to:

Digitize objects manually.

You trace shapes and lines over the artwork using 
the appropriate digitizing tools. See Digitizing 
Methods for details.

Digitize shapes automatically with Magic Wand.

You select a shape and Magic Wand 
automatically determines the required stitches. 

Digitize complete images automatically with Auto 
Digitizer.

You select the image and Auto Digitizer 
automatically determines the shapes and stitches 
needed to digitize the design. See Digitizing with 
Auto Digitizer for details.

Digitize photographs with PhotoSnap.

Again you select the image and PhotoSnap 
automatically determines the shapes and 

stitches needed to digitize the design. See 
Digitizing with PhotoSnap for details.

Artwork can be imported into BERNINA Embroidery 
Software in both vector and bitmap formats:

Vector graphics: These consist of outlines which 
may be colored and may have colored fills. Vector 
outlines remain thin and clear even at large zoom 
factors, so you can digitize them accurately.

Bitmap images: These consist of colored dots or 
pixels. When you zoom in on a small area, the 
outlines become jagged and are displayed as a 
series of colored squares or pixels. 

To create good quality embroidery, you need to 
choose suitable artwork. Once in BERNINA® 
Embroidery Software, you can set general properties 
such as size and position. You can also arrange and 
transform artwork in the same way as embroidery 
designs.

Caution  Included artwork (clipart) and embroidery 
designs can only be used for personal use – i.e. they 
cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery 
to clipart – does not remove copyright protection.
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Vector graphics
Vector graphics can be loaded into BERNINA® 
Embroidery Software for use as digitizing backdrops. 
They are automatically converted to bitmap images.

Bitmap images
Bitmap images can be loaded or scanned into 
BERNINA® Embroidery Software for use as digitizing 
backdrops. For both manual and automatic digitizing 
purposes, ‘clean’ images, sometimes referred to as 
‘cartoons’, work best. Such images have a limited 
number of solid colors which in turn have well-defined 
outlines. Ideally, they are:

well defined, where each shape is made up of 
pixels of the same color

clearly ‘blocked’, where each shape is a stitchable 
size, at least 1 sq mm

saved at a color depth of at least 256 colors (8 bit), 
or preferably millions of colors (16 bit). (Images 
are automatically reduced to 256 colors or less 
when loaded into BERNINA® Embroidery 
Software.)

Tip  You can scale and transform bitmap images once 
they are loaded into BERNINA® Embroidery Software. 
However, if an image needs to be resized or rotated, 
it is best to do so during scanning. Scaling afterwards 
may distort the image.

Supported graphic formats

BERNINA Embroidery Software supports a wide 
variety of vector and bitmap graphic formats:

Note  For a full discussion of graphics formats, refer 
to the CorelDRAW® Essentials 4 User Guide available 
via the Windows Start > Programs group. 
Alternatively, use the onscreen help available from 
the Graphics mode Help menu.

Automatic digitizing

BERNINA® Embroidery Software automatic digitizing 
techniques – Auto Digitizer and Magic Wand – 
produce best results with images of the type found in 
clipart libraries or created from scratch in a graphics 
application. See Digitizing with Magic Wand and 
Digitizing with Auto Digitizer for details.

Automatic digitizing can work with images from other 
sources but they require greater or lesser amounts of 
preparation. This is because most commonly available 
images are not made up of solid colors. Scanners 
introduce noise, while graphics applications perform 
‘dithering’ and ‘anti-aliasing’ to improve image print 
quality.

Automatic digitizing works least effectively with 
photographic images which may contain many 
dithered colors and complex forms. With 
photographs, however, you can pick out shapes that 
you want to embroider, leaving out unnecessary 
detail. Alternatively, PhotoSnap is available to create 
embroidery designs from scanned photographs.

Scanned images

Images scanned from 
hardcopy drawings or 
existing embroidery typically 
contain a lot of introduced 
‘noise’. While they can be 
used as input to automatic 
digitizing, once again, best 
results are achieved with 
relatively clean images 
consisting of solid color 
blocks. Typically, logos and simple drawings scanned 

Digitized with Magic WandDrawing 

Supported
graphic formats

Image containing a lot of 
scanner ‘noise’
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from business cards, letterheads, books, magazines, 
cards fall into this category.

Noisy images typically need to be prepared by 
reducing the color count and sharpening the outlines. 
See Image Processing for details.

Dithered images

Dithering is a software technique which combines 
existing colors in a checkerboard arrangement of 
pixels. It is typically used to simulate colors that are 
missing from an image palette.

Like noisy images, dithered images need to be 
color-reduced before use. Be aware, however, that 
while the software is excellent at processing dithered 
colors within a defined outline, it does not work so 
well with non-outlined images. See Image Processing 
for details.

Anti-aliased images

Anti-aliasing is a software 
technique similar to dithering 
which is used to soften hard 
outlines where color blocks 
intersect. It produces 
smoother outlines by 
‘blurring’ the pixels where 
colors join.

Where anti-aliasing is 
deliberately used to blur 
outlines, these need to be 
‘sharpened’ before use with automatic digitizing. See 
Image Processing for details.

Scanning artwork into BERNINA 
Embroidery Software

If you have existing artwork, you can scan it with a 
TWAIN-compatible scanner using the BERNINA 
Embroidery Software scanning function. It is 
important to scan your artwork properly if you intend 
to use one of the automatic digitizing techniques; the 

scanned image quality will affect the quality of the 
final embroidered design.

Preparing artwork for scanning
With embroidery design, less is more. You do not 
need every detail in an image to create a design. You 
use the ‘structure’ of the image rather than the fine 
details of texture and color.

To simplify artwork, you can cover it with tracing 
paper and draw only the essential shapes and lines 
which will be filled with stitches. When scanning, take 
away the original artwork and put white paper behind 
the tracing paper. 

Shiny surfaces, such as glossy photographs, may not 
scan well. Cover them with tracing paper. If the 
artwork has very light colors, highlight outlines with a 
fine black felt-tip pen.

Scanning resolution
Most scanners require you to enter scanning 
resolution information. Resolution determines the 
number of dots per inch (dpi) used to create a 
drawing. The higher the value, the clearer the image 
but larger the file. For digitizing purposes, use a 
maximum resolution of 300 dpi (dots per inch). A 
resolution of 72dpi (screen resolution) will usually be 
sufficient. Generally speaking, the smaller the source 
image and/or more detail it contains, the higher the 
resolution needs to be. Use the following table as a 
guide.

Dithered color 
blocks

Anti-aliased outlines

Type of artwork Scanning resolution

Business cards, letter heads 150 - 300 dpi

Good image: good 
stitch quality 

Poor image: poor 
stitch quality

Original artwork Required parts traced
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Color mode
Most scanners also require you to enter color mode 
information. First decide whether your image is line 
art (black and white drawing), sketch, color picture, 

or black and white or color photograph, then choose 
an appropriate mode. Black and white mode produces 
the smallest files. Color photograph and grayscale 
modes generate 256 color images and produce similar 
sized files. ‘RGB’, ‘True Color’ or ‘millions of colors’ 
modes generate 16.7 million colors and produce the 
biggest files. Use the table below to decide which 
mode is suitable for use with your image.

Note  Note that scanners may use different terms for 
the same mode, some of these terms are included.

Scanning tips
Do not scan line art images in grayscale mode; 
grayscale scanning produces fuzzy edges.

Scan color images in RGB mode (millions of colors) 
rather than 256 color mode. You may not notice 
any difference on screen. In fact the 256 color 
image may look better than the RGB image. 
However, BERNINA Embroidery Software converts 

all images to 256 colors or less upon loading. It 
uses the extra information to produce a better 

Hand sketches 150 - 300 dpi

Photos and images 150 - 300 dpi

Commercial art, line drawing 72 - 150 dpi

Type of artwork Scanning resolution

Source image Example Description Recommended 
color mode *

No. of colors in 
scanned image

Line art Two colors – usually black 
and white

Black/white drawing
Line art

2
2

Drawing/sketch Sketch or drawing with 
shades of gray

Grayscale 
Line art

256
2

Black & white pho-
tograph

Shades of gray Black/white photo
Grayscale

256
256

Color photograph Many colors Color RGB 
Color photo

16 million
256

Color picture Two colors or more Color RGB
Millions of colors
Color drawing

16 million
16 million
2 - 256

* Different scanning software uses different terms for the same mode.
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image than if it was originally scanned at 256 
colors.

Do not scan color images in CMYK mode as this is 
only used for images that will be printed and the 
colors may be different from RGB colors.

If the image needs to be resized, scale it when you 
scan it. Scaling afterwards may distort the image.

Sharpening
Some scanning software lets you apply what is called 
‘sharpening’ as you scan. Sharpening compensates 
for the slight blurring in a scanned image by looking 
for any differences between colors in the image. 
Sharpening accentuates these differences which 
makes the image edges more defined. It does not 
increase the image details; it just makes them more 
obvious. In general, use sharpening with images that 
have well-defined outlines. Do not use it with 
non-outlined images.

Importing images into BERNINA 
Embroidery Software

Bitmap images and vector graphics of different 
formats can be scanned or ‘loaded’ into BERNINA 
Embroidery Software for use as digitizing backdrops. 
You can scale and transform them after importing but 

it is generally better to do so during scanning. Scaling 
afterwards may distort the image.

Caution  Included artwork (clipart) and embroidery 
designs can only be used for personal use – i.e. they 
cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery 
to clipart – does not remove copyright protection.

Scanning artwork

You can scan images directly into BERNINA 
Embroidery Software for use as digitizing backdrops. 
The scanning feature in BERNINA Embroidery 
Software allows you to use most TWAIN-compatible 
scanners. You can use any scanning software 
provided that it can save the image in one of the 
compatible formats.

Tip  You can also scan in your own textured 
backgrounds to see what a design will look like on real 
fabric. Fabrics can be scanned to provide full, 
centered, backgrounds to your design, or as small 
samples which can be tiled to fill the screen. See also 
Changing backgrounds.

To scan artwork

1 Set up your scanner. See Setting up scanners for 
details.

2 Prepare the artwork for scanning. See Preparing 
artwork for scanning for details.

3 Create a new file or open a design you want to load 
the image into.

4 Switch to Art Canvas mode.

5 Click the Scan Picture icon.

Your scanning program will open.

Scanned in 256 
color mode

Scanned in RGB color 
mode (millions of colors)

Scanned with 
sharpening

Scanned without 
sharpening

Use Art Canvas to load, edit and save pic-
tures as a backdrop for embroidery digitiz-
ing.

Use Scan Picture (Image toolbar) to scan an image 
into BERNINA Embroidery Software.

Traced image scanned Auto-digitized
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6 Choose a scanning mode and resolution. See 
Scanning resolution and Color mode for details.

Tip  If you are scanning a fabric background, set 
the scan to 256 colors, 100% and 72 dpi (dots per 
inch). These settings will give a small file which will 
display well on your screen without taking up too 
much disk space or memory.

7 Preview the image in the scanning program.

8 Select the area to be scanned and scan the image.

9 Save the scanned picture in a compatible format 
picture file to your My Designs folder. See also 
Digitizing with Backdrops.

Note  Scanned drawings are bitmaps and must be 
saved separately from the design file or they will 
be lost when you close the design. See Saving 
backdrops as separate files for details.

Loading pictures

You can load bitmap images of various formats for use 
as digitizing backdrops. See also Digitizing with 
Backdrops.

Note  Vector graphics are converted to bitmap 
images when loaded into BERNINA Embroidery 
Software.

To load a picture

1 Switch to Art Canvas mode and click the Load 
Picture icon.

The Import dialog opens.

2 Select a folder and select a file type from the Files 
of Type list – e.g. BMP.

3 Select the file you want to load and click Import.

4 Position the picture in the Design Window as 
necessary.

5 Use any of the automatic conversion options 
available or use the image as a digitizing 
backdrop:

Convert vectors to embroidery: See Digitizing 
with vector graphics for details.

Convert bitmaps to embroidery: See Automatic 
Digitizing for details.

Switch to Embroidery Canvas and use the 
imported image as a digitizing backdrop: See 
Digitizing Methods for details.

Note  If you cannot see the image you loaded, 
make sure Show Picture icon is toggled on. See 
Viewing backdrops for details. 

Use Art Canvas to load, edit and save pic-
tures as a backdrop for embroidery digitiz-
ing.

Use Load Picture (Image toolbar) to load an image 
for use as a digitizing backdrop. 

Select folder

Select required format

Select required
format
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Browsing clipart
CorelDRAW® Essentials 4 itself is packaged with a 
selection of clipart which can be used as digitizing 
backdrops or converted directly into embroidery. See 
also Converting vectors to embroidery.

To browse clipart

1 Access the CorelDRAW® Essentials 4 folder via the 
Windows Start > Programs group.

2 Select the Clipart folder.

3 Browse the folders for the clipart you are 
interested in.

Note  To open the clipart in BERNINA Embroidery 
Software, you will need to do so via Art Canvas. 
See also Loading pictures.

Tip  It may be more convenient to take a copy of 

the entire CorelDRAW® Clipart folder and copy it 
to My Designs - Embroidery Software 6 folder 
for easy reference.

Editing imported images

For both manual and automatic digitizing purposes, 
you may want to crop an image before digitizing. You 
can do this within BERNINA Embroidery Software or 
using a third-party graphics application. Sometimes, 
you may want to save backdrops as separate files 
after scanning or cropping.

Tip  For both manual and automatic digitizing 
purposes, ‘clean’ images, sometimes referred to as 
‘cartoons’, work best. Scanners introduce noise, while 
graphics applications perform ‘dithering’ and 
‘anti-aliasing’ to improve print quality. See also 
Preparing images for automatic digitizing.

Cropping images for digitizing
BERNINA Embroidery Software allows you to crop 
images prior to use. Before using bitmap images for 
design purposes, crop them to remove unnecessary 
detail and save processing time. 

To crop images for digitizing

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

2 Select the image and a cropping tool:

Select Edit > Crop Image > Rectangle to 
crop the image in rectangular form.

Select Edit > Crop Image > Oval to crop the 
image in oval form.

Select Edit > Crop Image > Heart to crop the 
image in heart form.
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Select Edit > Crop Image > Star <n> point 
to crop the image in star form. 

Select Edit > Crop Image > Curve to crop 
the image in free form.

Digitize points to create a cropping shape around 
the part of the image you require and press Enter.

Tip  Use the prompt line to guide you.

BERNINA Embroidery Software crops the area 
inside the cropping selection. This process may 
take some time.

Reshaping cropped images

After an image has been cropped, you can reshape 
and transform the cropping outlines in the same way 
as you reshape and transform lettering. You can also 
use the tool to reposition cropping outlines. See also 
Reshaping letters on screen.

To reshape cropped images

1 Crop an image. See Cropping images for digitizing 
for details.

2 Select the image.

3 Click the Reshape Object icon.

The image displays the cropping outline with 
reshape nodes.

4 Adjust reshape nodes to change the shape and 
press Enter.

5 Press Esc to finish.

Editing images in graphics applications

From within BERNINA Embroidery Software you can 
open images into third-party graphics applications 
which can help you improve your scanned images. 
Eliminate backgrounds, flood-fill solid areas with 
color, or add outlines, close gaps, or reinforce 
outlines. Images updated in this way are 
automatically re-imported into BERNINA Embroidery 
Software. 

Click Reshape Object (Edit toolbar) to crop a free 
form image.

Star 8 points Star 10 points

Load, edit and save graphics as a back-
drops for embroidery digitizing. Includes 
entire suite of CorelDRAW® Essentials 4 
drawing tools. In addition, provides capabil-
ities to convert vectors and vector text 
directly to embroidery objects.

Use Touch Up Picture (Image toolbar) to 
edit images in a graphics application.
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Many graphics applications are available. At one end 
of the spectrum you have the simple MS Paint 
application. This comes free with MS Windows® but 
can handle few formats or color conversions. At the 
other end there are professional tools such as Corel 
PHOTO-PAINT® Essentials 4. An excellent 
compromise is Paint Shop Pro™ which has many of 
the features of high-end applications but at a much 
lower cost.

To edit images in a graphics application

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

2 Still in Art Canvas mode, select the image.

3 Click the Touch Up Picture icon.

The image opens into the Corel 
PHOTO-PAINT® Essentials 4 application.

4 Edit the image as required.

5 Select File > Update Design1.

The image displays in BERNINA Embroidery 
Software overlaid with stripes. This means that it 
is still open in the graphics application.

6 Select File > Exit & Return <Filename> to exit 
the graphics application.

The updated image displays in BERNINA 
Embroidery Software and the stripes disappear.

Tip  If you want to keep the graphics application 
open, select File > Close when finished updating 
the image.

Saving backdrops as separate files

All images placed in the Design Window, whether by 
scanning, pasting or inserting from hard disk, are 
saved together with the embroidery design in the ART 
file. After editing in BERNINA Embroidery Software or 
third-party graphics application, you may want to 
save the image out as a separate file.

To save a backdrop as a separate file

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

2 Still in Art Canvas mode, select the image.

Use a graphics 
application, for 
example, to cut out the 
part to be embroidered

 Image cropped

Background removed

Outlines added

Load, edit and save graphics as a back-
drops for embroidery digitizing. Includes 
entire suite of CorelDRAW® Essentials 4 
drawing tools. In addition, provides capabil-
ities to convert vectors and vector text 
directly to embroidery objects.

Use Save Picture (Image toolbar) to save a 
backdrop as a separate file.

Image still open in 
graphics 
application
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3 Click the Save Picture icon.

The Export dialog opens.

4 In the Save In field, select a folder, then select a 
format from the Save as type dropdown list.

5 Enter a new file name and click Export.

When you save the design, the reference is 
updated to use the new image file.

Note  This file is not referenced by the ART file. 
Any further changes to it are not reflected in the 
embedded image.

Enter file name

Select folder

Select required format
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CHAPTER 14
IMAGE PROCESSING

BERNINA Embroidery Software supports the automatic and 
semi-automatic digitizing of bitmap images. The quality of 
the resulting designs greatly depends on the type and quality 
of the original artwork. In order to make bitmap images 
more suitable for automatic digitizing, BERNINA Embroidery 
Software also provides image processing capabilities and 
links to graphics packages.

This section describes how to prepare images for automatic 
digitizing. It explains how to prepare both outlined and 
non-outlined images. 

Preparing images for automatic 
digitizing

Before applying automatic digitizing, you frequently 
need to improve or ‘clean up’ artwork. To work 
effectively, both Auto Digitizer and Magic Wand 
require solid color images as input. You can improve 
artwork both with bitmap editing tools in graphics 
packages and/or the image processing tools provided 
in BERNINA® Embroidery Software. In fact, the 
software will not let you apply Auto Digitizer until 
the image has been suitably processed.

Outlined vs non-outlined images

Before preparing your image you need to know what 
type you are using. For the purposes of automatic 
digitizing, there are two categories – outlined and 
non-outlined. Outlined images ideally have a solid 
black outline around each colored area. Non-outlined 
images ideally consist of solid areas of color. Outlined 
and non-outlined images require different methods of 
preparation.

Image clean up

In practice, cleaning up scanned images may involve 
any one or a combination of the following techniques:

reducing the number of colors

adding or emphasizing outlines

removing noise, dithering or anti-aliasing

eliminating unnecessary detail

cropping sections

eliminating backgrounds.

Color reduction

Sometimes an image looks clean but extra colors 
have been introduced during scanning or in a graphics 
package. Color reduction means reducing the actual 
number of image colors in order to eliminate 
unnecessary detail and reduce each block to a single 
color. Color reduction also cleans the image, removing 
noise and anti-aliasing if present. This in turn helps 
minimize the number of trims and color changes 
required in the resulting embroidery design. Reduce 
colors in a non-outlined and outlined images using the 
Image Preparation tool.

Color reduction should only be applied if the loss of 
detail does not affect the image shapes. Before color 
reduction, the colored areas in the image below 

Image with outlines Image without outlines
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include many colors. After reduction, each area is 
reduced to a single color. The detail is preserved.

If you are scanning images, make sure you scan them 
correctly for best results. See Scanning artwork into 
BERNINA Embroidery Software for details.

Outline sharpening

Outline sharpening means more clearly defining the 
outlines bordering distinct color blocks or shapes in 
the artwork. These may have been indistinct in the 
original or made so by the scanning process. Outline 
sharpening is important for automatic digitizing 
because it makes it easier for the software to identify 
the distinct areas which become embroidery objects 
in the resulting design.

Note  Outline sharpening only works on images with 
black or dark outlines. 

Some images have solid outlines but they may be 
indistinct or incomplete. These need to be rectified 
with the BERNINA® Embroidery Software image 
preparation tools or a graphics package. See Editing 
images in graphics applications for details.

Noise filtering

Noise filtering means restoring the solid color blocks 
of the original artwork in scanned images. This is 
achieved by merging different shades into one solid 
color. Noise filtering is important for automatic 
digitizing because it makes it easier for the software 
to identify solid color blocks which become 
embroidery objects in the resulting design. It also 
cleans up blurred or mottled areas of color.

Image preparation summary

Even if your artwork looks ready to stitch when 
inserted into the software, it will need to be 
image-processed before conversion. The software will 
not let you apply automatic digitizing techniques 
without preliminary image-processing.

Image before color 
reduction

Image after color 
reduction

Image scanned in RGB 
color mode

Image scanned in 256 
color mode

Image before outline 
sharpening 

Image after outline 
sharpening

Image of mottled colors 
before noise removal

Image single colors 
after noise removal

Action Outlined image Non-outlined image Photo

Scan artwork • Scans in RGB mode
• Uses sharpening

• Scans in RGB mode
• No sharpening

Scans in RGB mode

Scan line drawing Scans in two color mode - -
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Preparing non-outlined images

Use the Image Preparation > Reduce Colors 
option to prepare non-outlined images for automatic 
digitizing. The tool automatically reduces color blocks 
in bitmap images to a single color, removing 
anti-aliasing and noise. You can let the software 
reduce the color count automatically or specify a 
precise number. The latter is useful if you want to 
match design colors to an exact number of threads.

Tip  Depending on the quality of the scanned image, 
you may need to touch it up manually before 
processing in BERNINA Embroidery Software. You 
would normally do this in order to eliminate 

backgrounds, flood-fill solid areas with color, or add 
outlines, close gaps, or reinforce outlines. See Editing 
images in graphics applications for details.

To prepare a non-outlined image

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

2 Still in Art Canvas mode, select the image and 
crop or edit it as required. See Editing imported 
images for details.

3 Switch to Embroidery Canvas mode, and select 
the image.

4 Click the Image Preparation icon.

Touch up in graphics 
package

• Crops
• Adds or edits outlines
• Edits colors
• Removes noise

• Crops
• Edits image shapes
• Edits colors
• Removes noise

• Crops
• Converts to grayscale
• Removes background
• Lightens or darkens
• Adjusts contrast

Use Image Preparation 
tool in BERNINA Embroi-
dery Software

Adjusts lightness or dark-
ness of outlines. Automat-
ically:
• blends each outlined 

block into a single color
• removes anti-aliasing, 

noise and dithering
• sharpens outlines.

Reduces colors to a spec-
ified number. Automati-
cally:
• reduces each block to a 

single color
• removes anti-aliasing, 

noise and dithering
• removes colors less 

than specified area.

-

Digitize • Manual
• Magic Wand
• Auto Digitizer

• Manual
• Magic Wand
• Auto Digitizer

PhotoSnap

Action Outlined image Non-outlined image Photo

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Use Image Preparation (Edit toolbar) to 
reduce number of colors and remove image 
‘noise’ in non-outlined images.

Prepared image Digitized image
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The Image Preparation dialog opens with the 
image in the preview panel.

5 Check how many colors are in the image.

This is indicated by the Available colors. If there 
appear to be too many, the image probably 
contains ‘noise’. See Preparing images for 
automatic digitizing for details.

6 Enter the number of colors you require:

You can accept the number suggested by BERNINA 
Embroidery Software or change it.

7 Click OK to apply the changes.

The image is ready for automatic digitizing. See 
Automatic Digitizing for details.

Preparing outlined images

Use the Image Preparation > Outline 
Appearance option to prepare outlined images for 
automatic digitizing. The tool automatically sharpens 
outlines and reduces noise. Areas enclosed by a black 
outline are reduced to a single color. Outline 
sharpening makes it easier for the software to 
recognize distinct areas in the artwork. These areas 
then become the embroidery objects of the finished 
design. Use it particularly if the outlines are blurry, 
fuzzy or indistinct.

Tip  Depending on the quality of the scanned image, 
you may need to touch it up manually before 
processing in BERNINA Embroidery Software. You 
would normally do this in order to crop an image, 
eliminate backgrounds, flood-fill solid areas with 
color, or add borders, close gaps, or reinforce borders. 
See Editing images in graphics applications for 
details.

To prepare an outlined image

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

2 Still in Art Canvas mode, select the image and 
crop or edit it as required. See Editing imported 
images for details.

3 Switch to Embroidery Canvas mode, and select 
the image.

4 Click the Image Preparation icon.

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Enter number of
colors required

Reduced to 3 colors Reduced to 2 colors

Use Image Preparation (Edit toolbar) to 
sharpen outlines and reduce noise in out-
lined images.

Image with single, 
solid colors

Digitized image

Zoomed area
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The Image Preparation dialog opens.

The image appears in the preview panel. The 
Available colors field shows the number of image 
colors.

5 Set the outline contrast tolerance by dragging the 
slider control.

This produces a black and white preview of the 
detected outlines.

Tip  Move the slider to the right until there is too 
much black, then move it slowly back to the left. 
Stop when the image shows all the outlines you 
need.

6 Click Show Color Areas to see the updated image.

7 Click OK to apply the changes.

The image is ready for automatic digitizing. See 
Automatic Digitizing for details.

Set outline
appearance

Slider moved to the left, 
outlines lightened

Slider moved to the right, 
outlines darkened
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CHAPTER 15
AUTOMATIC DIGITIZING

Through its integration with CorelDRAW®, BERNINA 
Embroidery Software provides powerful 
inter-conversion of vector and embroidery objects. The 
Convert Vectors to Embroidery tool converts fill or 
outline properties of selected vector graphics to fill or 
outline stitch types respectively. It can be applied to 
text as well as vector graphics.

BERNINA Embroidery Software also provides a Magic 
Wand tool for quickly creating embroidery that does 
not require particular artistic effects or 
embroidery-specific knowledge directly from electronic 
artwork. This in turn frees you to spend more time on 
the artistic or inherently complicated areas of your 
designs. The Auto Digitizer tool automatically converts artwork to fully digitized 
embroidery with little or no intervention. With this tool, novice embroiderers can 
create simple designs quickly and easily. Similarly, experienced embroiderers can 
improve productivity when working with simple designs. Use PhotoSnap to 
create embroidery from photographs and other images. 

This section describes how to automatically convert vector graphics as well as 
bitmap images to embroidery designs with the available techniques. It also covers 
how to create embroidery from photographs.

Digitizing with vector graphics

Special conversion tools in BERNINA Embroidery 
Software automatically convert vector objects and 
text to embroidery or lettering objects. In fact, entire 
vector drawings can be quickly and easily converted 
to embroidery designs. When creating embroidery 
objects, the software determines optimum object and 
stitch type for given shapes. These can be modified as 

required. You can also convert embroidery designs or 
objects to vector objects.

Caution  Included artwork (clipart) and embroidery 
designs can only be used for personal use – i.e. they 
cannot be commercially sold in any form. Changing 
the medium – i.e. clipart to embroidery or embroidery 
to clipart – does not remove copyright protection.
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Conversion tools

The conversion feature provides three tools:

Convert Vectors to Embroidery

Convert Vector Text to Embroidery: See 
Converting text to embroidery for details.

Convert Selected Embroidery to Art Vectors. 

The Convert Vectors to Embroidery and Convert 
Text to Embroidery tools are accessed via buttons 
on the Art Toolbox in Art Canvas. The Convert 
Selected Embroidery to Art Vectors tool is 
accessed via the Edit toolbar in Embroidery 
Canvas.

Conversion limitations

There are some limitations when converting some 
CorelDRAW® vectors to embroidery. Vector special 
effects, such as drop shadow, contour, and 
transparency, do not convert well as there is no 
equivalent embroidery effect. Enveloped text and 
Fountain or Mesh fills do not always give the 
expected result either.

Also Artistic Media is not always converted to 
embroidery as you might expect. Unless you first 
break the object into its constituent parts, the result 
is sometimes just a single line of run stitches.

However, as long as the vector object has a fill and/or 
an outline, BERNINA Embroidery Software will 

attempt to convert it. But if there is no embroidery 
equivalent, the object is converted with solid colors 
only. Enveloped text is converted to embroidery 
objects rather than embroidery text.

Tip  A workaround is to break any ‘special’ vector 
objects apart using the Arrange > Break Apart 
command in Art Canvas. In most cases, you will get 
a result, but it may not be exactly the one you want. 

Converting vectors to embroidery

The Convert Vectors to Embroidery tool converts 
fill or outline properties of selected vector graphics to 
fill or outline stitch types respectively. It can be 
applied to text as well as vector graphics. See also 
Converting text to embroidery.

Note  Bitmaps cannot be converted to embroidery via 
the Convert to Embroidery tool as images still need 
to be processed prior to conversion. See Image 
Processing for details.

To convert vectors to embroidery

1 Switch to Art Canvas mode.

2 Scan, load, or create the artwork and/or text you 
want to use. See also Importing images into 
BERNINA Embroidery Software.

3 Click the Convert to Embroidery tool.

Drop shadow unable 
to be converted

Artistic Media broken 
apart prior to conversion

Use Convert to Embroidery (Art Toolbox) to convert 
selected vectors to fill or outline stitches.
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BERNINA Embroidery Software automatically 
switches to Embroidery Canvas mode. The 
source objects are removed from the design.

Converting embroidery to vectors

The new Convert Selected Embroidery to Art 
Vectors tool converts selected embroidery objects to 
vector.

To convert embroidery to vectors

1 Switch to Embroidery Canvas mode. 

2 Select one or more embroidery and/or lettering 
objects and click the Convert Selected 
Embroidery to Art Vectors tool.

BERNINA Embroidery Software automatically 
switches to Art Canvas mode. The source objects 
are removed from the design.

Digitizing with Magic Wand

The Magic Wand tool provides everything necessary 
to digitize shapes in bitmap images automatically.

Note  Even if your artwork looks ready to stitch when 
inserted into the software, it will need to be 
image-processed before conversion. The software will 
not let you apply automatic digitizing techniques 
without preliminary image-processing. See Image 
Processing for details.

Digitizing fills automatically

If you want to fill an object, select a fill stitch from the 
Stitch and Color Bar before using the Magic Wand. 
You may need to add underlay to your embroidery. 
See Stabilizing with underlays for details.

To digitize fills automatically

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

Tip  If you cannot see the image you loaded make 
sure Show Pictures icon is toggled on. See 
Viewing backdrops for details.

Use Convert Selected Embroidery to Art Vectors 
(Edit toolbar) to convert selected embroidery objects 
to vectors.

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Use Magic Wand (Digitize toolbar) to digi-
tize filled shapes in your artwork.
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2 Select Embroidery Canvas and click Magic 
Wand.

The tool is only enabled if at least one bitmap 
exists in the Design Window.

3 Click an area of the image as prompted.

The software checks whether the bitmap has been 
processed and displays the Image Preparation 
dialog as necessary. See Preparing images for 
automatic digitizing for details.

4 Change thread color and stitch type as desired in 
the Stitch and Color Bar. See Assigning thread 
colors for details.

5 Hover the mouse pointer over an area of the 
image, and click.

Fill stitches are generated accordingly.

Tip  If you want to both fill and outline a shape, 
you need to create two objects – one with fill stitch 
and one with outline stitch. See also Digitizing 
outlines automatically.

6 Digitize the other filled shapes in the same way, 
changing thread color and stitch type as required.

7 To finish, select another input tool or press the Esc 
button.

8 Check the results in Artistic View.

Note  Stitches are generated according to current 
stitch settings. You may have jumps if the stitch 
length exceeds the default setting.

Digitizing outlines automatically

If you want to outline an object, select an outline 
stitch before using the Magic Wand. 

To digitize outlines automatically

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

Tip  If you cannot see the image you loaded make 
sure Show Pictures icon is toggled on. See 
Viewing backdrops for details.

2 Select Embroidery Canvas and click Magic 
Wand.

The tool is only enabled if at least one bitmap 
exists in the Design Window.

3 Click an area of the image as prompted.

Image processed

Click in area Area filled with 
stitches

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Use Magic Wand (Digitize toolbar) to digi-
tize filled shapes in your artwork.

All areas 
digitized

Image processed
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The software checks whether the bitmap has been 
processed and displays the Image Preparation 
dialog as necessary. See Preparing images for 
automatic digitizing for details.

4 Change thread color and stitch type as desired in 
the Stitch and Color Bar. See Assigning thread 
colors for details.

5 Hover the mouse pointer over an area of the 
image, and right-click.

Outline stitches are generated accordingly.

Tip  If you want to both fill and outline a shape, 
you need to create two objects – one with fill stitch 
and one with outline stitch. See also Digitizing fills 
automatically.

6 Digitize the other filled shapes in the design in the 
same way changing thread color and stitch type as 
required.

7 To finish, select another input tool or press the Esc 
button.

8 Check the results in Artistic View.

Note  Stitches are generated according to current 
stitch settings. You may have jumps if the stitch 
length exceeds the default setting.

Digitizing with Auto Digitizer

An extension of Magic Wand technology, Auto 
Digitizer recognizes shapes in artwork and makes 
decisions about the most suitable stitch types to use. 
It also determines the stitching sequence based on 
closest join. Artwork is effectively ‘batch processed’ to 
create the many embroidery objects that make up a 
design.

Auto Digitizer allows you some control over how an 
image is interpreted during conversion. You can 
choose to omit selected colors and you can specify 
stitch types. Once created, you can always edit the 
final result using the available digitizing techniques. 
See also Digitizing Methods. Always remember to 
apply underlays and you may need to reshape some 
objects. See Applying automatic underlays for details.

Note  Even if your artwork looks ready to stitch when 
inserted into the software, it will need to be 
image-processed before conversion. The software will 
not let you apply automatic digitizing techniques 
without preliminary image-processing. See Image 
Processing for details.

Digitizing whole images automatically

Click outline Filled with Satin 
outline stitches

Press 
Enter

Border color 
changed

Border stitch type 
changed

Completed design Only outlines digitized

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Use Auto Digitizer (Digitize toolbar) to cre-
ate embroidery designs directly from 
imported images.

Satin Stitch width: 
2.5mm some jumps

Satin Stitch width: 
1.0mm NO jumps
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In essence, creating an embroidery design with Auto 
Digitizer is simply a matter of selecting the image 
you want to convert, and clicking the Auto Digitizer 
tool. There are, however, some settings you can 
adjust to optimize the conversion process for a 
particular image. Only one image may be selected at 
a time. The command is disabled if the selection 
contains anything other than an image.

Tip  Change the pull compensation to 0.4 mm when 
using Auto Digitizer.

To digitize a whole image automatically

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

Tip  If you cannot see the image you loaded make 
sure Show Pictures icon is toggled on. See 
Viewing backdrops for details.

2 Select Embroidery Canvas and click Auto 
Digitizer.

The tool is only enabled if at least one bitmap 
exists in the Design Window.

3 Click the image as prompted.

The software checks whether the bitmap has been 
processed and displays the Image Preparation 
dialog as necessary. See Preparing images for 
automatic digitizing for details.

4 Click the image again as prompted.

The Auto Digitizer dialog opens. Image 
information is given in the top panel, including 

width and height values as well as the number of 
image colors.

5 Select the stitch types for fills and outlines. See 
Adjusting automatic stitch settings and Digitizing 
outlines automatically.

6 Click Omitted Colors.

A list of image colors is displayed in the dialog. You 
can choose to omit selected colors from the 
operation:

To select multiple items, hold down Ctrl as you 
click.

To select a range, hold down Shift as you click.

7 Set outline or border options as required. See 
Creating automatic outlines and borders for 
details.

8 Click OK.

Auto Digitizer converts the artwork to 
embroidery objects and generates stitches.

9 Click the Show Artistic View icon on the 
General toolbar or press the ‘T’ shortcut key.

Image processed

Click colors 
to omit

Select stitching 
options

Number of 
thread colors

Design size

Select to 
omit

Some colors 
omitted

White background 
omitted
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The software matches colors from the existing 
palette. If the design does not seem to convert 
colors properly, check that your monitor is set to 
16 Bit color depth and check that you have 
selected an appropriate thread chart. 

Adjusting automatic stitch settings
Auto Digitizer lets you adjust fill and detail stitch 
settings.

To adjust automatic stitch settings

Scan or load the image you want to use and run 
Auto Digitizer to digitize a whole design 
automatically. See Digitizing whole images 
automatically for details.

Click the image as prompted.

The Auto Digitizer dialog opens.

Select a stitching style for fills from the list.

Note  Do not use Satin fill for areas where the 
stitch length exceeds 7 mm. See Preserving long 
stitches for details.

Select a stitching style for Details from the list.

Click OK.

Auto Digitizer converts the artwork to 
embroidery objects and generates stitches.

Creating automatic outlines and borders

The Auto Digitizer tool allows you to automatically 
generate outlines during image conversion. These 
may be in the form of outlines between objects and/or 
borders around the design itself. Automatic outlining 
can also be used to provide an open filled background 
for stitching on difficult fabrics or simulating a 
shadow, etc. You can select the outline colors to use 
at the time of converting the image. Colors and object 
details of generated objects can be changed at any 
time.

Style Description

Auto The software works out the best stitch type.

Step Suited for most areas.

Satin Suited for use in small and narrow areas.

Select stitching
style for fills

Select stitching
style for details

Style Description

Satin Most suited for use with thicker lines or 
small shapes of varying width.

Double Run Most suited for use with thin lines.

Satin Line Suited for use with thicker lines.

Use Auto Digitizer (Digitize toolbar) to create auto-
matic outlines and borders from imported bitmap 
images.

Satin fill not suitable Jump stitches created

Outline: Satin Outline: Double Run



Chapter 15 : Automatic Digitizing

BERNINA® Embroidery Software : Onscreen Manual 123

Note  If the image already contains outlines, the use 
of Add Outlines is not recommended as you will get 
double outlines. See Creating outlines and borders for 
details.

To create automatic outlines and borders

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

Tip  If you cannot see the image you loaded make 
sure Show Pictures icon is toggled on. See 
Viewing backdrops for details.

2 Select Embroidery Canvas and click Auto 
Digitizer.

The tool is only enabled if at least one bitmap 
exists in the Design Window.

3 Click the image as prompted.

The software checks whether the bitmap has been 
processed and displays the Image Preparation 
dialog as necessary. See Preparing images for 
automatic digitizing for details.

4 Click the image again as prompted.

The Auto Digitizer dialog opens.

5 Check the Add Outlines and/or Add Border 
options as required.

Generated outline stitching uses Run stitching 
to surround separate color blocks in the source 
image. The Run stitching has the same stitch 
properties as any details generated during 
conversion.

Generated border outlines are created as Satin 
objects with the current design settings for 
width and other properties. The border is 
oriented clockwise for consistent stitching with 
objects such as appliqué.

6 Select thread colors for outlines from the 
dropdown lists and click OK.

Auto Digitizer converts artwork to embroidery 
objects and generates stitches.

Set conversion 
options as 
required

Add outlines 
and/or borders as 
required and set 
colors

Outlines added Border added
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Tip  You may, if you wish, omit all image colors 
from the selection criteria and choose to generate 
only outlines and/or borders.

Digitizing with PhotoSnap

Use PhotoSnap to create embroidery from 
photographs and other images. Use color or 
grayscale. Grayscale images are made up of different 
shades of gray pixels. Color images are automatically 
converted to grayscale when you apply PhotoSnap.

PhotoSnap designs consist of rows of Satin stitches 
of varying spacing settings. The effect resembles the 
output of a line printer.

Tip  For best results, use images with well-defined 
subjects or constantly varying shades.

To create a design using PhotoSnap

1 Scan or load the image you want to use. See 
Importing images into BERNINA Embroidery 
Software for details.

Tip  If you cannot see the image you loaded make 
sure Show Pictures icon is toggled on. See 
Viewing backdrops for details.

2 In Embroidery Canvas mode, click the 
PhotoSnap icon and click the image as prompted.

BERNINA Embroidery Software generates stitches. 
This process may take some time.

3 Right-click or double-click the resulting 
PhotoSnap design.

The Object Properties > PhotoSnap dialog 
opens.

Use Art Canvas mode to load, edit and save 
pictures as a backdrop for embroidery digi-
tizing.

Use Embroidery Canvas mode to prepare 
pictures for automatic digitizing.

Use PhotoSnap (Digitize toolbar) create 
embroidery designs directly from photo-
graphs.

All image colors 
omitted

All image colors omitted, 
border added

With border and 
lettering added

Select resolution
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4 In the Resolution panel, select a resolution – 
Coarse, Medium, or Fine – and click Apply.

5 In the Background Fabric panel, select a 
background option – Light or Dark – and click 
Apply.

Tip  Usually the option you select depends on 
whether the fabric is light or dark.

6 In the Fill Angle panel, adjust the stitching angle, 
if required, and click Apply.

7 Select Fill Stitch tab and adjust PhotoSatin 
stitch values as desired.

Stitch Spacing: adjusts stitch density – to 
increase stitch density, enter a smaller value.

Skew Angle: determines the angle of the 
stitches themselves (as distinct from the fill 
angle).

8 Click Apply to apply changes and OK to close.

Coarse Fine

Light Background Dark Background

Fill Angle 45°Fill Angle 0°

Adjust stitching 
values

Fill Angle 45°
Skew Angle: 0°

Fill Angle 45°
Skew Angle: 45°
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PART IV
MODIFYING DESIGNS

After digitizing a design, you can modify it as a whole, edit individual objects or even 
individual stitches.

Combining and sequencing objects

This section describes how to combine objects and designs by copying and pasting, 
duplicating, and inserting whole designs and design elements. It also covers grouping 
and splitting objects, as well as sequencing objects using various techniques including 
Color Film. It also discusses auto-sequencing entire designs. See Combining & 
Sequencing Objects for details.

Arranging and transforming objects

This section describes how to position and align objects by both interactive and numeric 
methods. It also covers scaling, rotating and skewing objects. A variety of methods for 
mirroring objects are also described. See Arranging & Transforming Objects for details.

Reshaping and editing objects

This section describes how to reshape objects – including circle and pattern run objects 
– with reshape nodes. It also covers adjusting stitch angles – including multiple stitch 
angles – as well as changing entry and exit points. See Reshaping & Editing Objects for 
details.

Editing stitches

This section deals with selecting and editing stitches. See Editing Stitches for details.
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CHAPTER 16
COMBINING & SEQUENCING OBJECTS

BERNINA Embroidery Software lets you easily combine 
designs and design elements by inserting the contents of 
one file into another. You can also add to designs quickly 
by copying or duplicating existing objects. Group selected 
objects or entire designs to keep them together for 
moving, scaling or transforming purposes.

The embroidery objects in a design form a ‘stitching 
sequence’. Initially, objects are stitched in the order they 
were created. However, you can change this by a variety 
of methods. For example, change the position of a 
selected object by cutting it, then pasting it somewhere else in the sequence. 
There are also techniques available to sequence objects ‘as selected’ or as ‘color 
blocks’. You can also resequence objects using the Color Film.

The Stitch Sequence feature improves the quality and efficiency of the stitchout 
by minimizing the number of hoopings, color changes, and trims. All existing 
overlaps are preserved by the operation.

This section describes how to combine objects and designs by copying and 
pasting, duplicating, and inserting whole designs and design elements. It also 
covers grouping and splitting objects, as well as sequencing objects using various 
techniques including Color Film. It also discusses auto-sequencing entire designs.

Combining objects

A design or design objects can be copied or cut and 
placed on the MS Windows® Clipboard for temporary 
storage. It can then be pasted any number of times, 
either within the same or another design, until 
replaced on the Clipboard. Objects also can be cloned 
or duplicated without copying to the Clipboard. See 
also Selecting Objects.

Inserting designs

BERNINA Embroidery Software lets you insert one 
design into another. The two (or more) designs can 
then be saved as a combined design. When you insert 
a design in another, the two color palettes are 
combined. Colors with the same RGB values are 
automatically identified as having the same thread 
color. If you want to preserve these as separate 

colors, you need to change one or other before 
merging.

To insert designs

1 Open the first design.

2 Travel to the position in the stitching sequence 
where you want to insert the design. See Traveling 
by stitches for details.

3 Select File > Insert Design.

The Open dialog opens.

Select Insert Design (File menu) to combine designs.
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4 From the Look In dropdown list, select the folder 
where the design you want to insert is stored, and 
select the required format from the Files of type 
dropdown list.

5 Select the design file to insert, and click Open.

The design is inserted at the current needle 
position.

6 Move the second design into the required position. 
See Positioning objects using click and drag for 
details.

Tip  To ensure that all the objects in the inserted 
design stay together, group the design while 
working with it. See Grouping objects for details.

7 Save the combined design under the original or 
different name.

The designs you have inserted are now combined 
into one design.

Copying and pasting objects

You can copy objects to create multiple, identical 
objects, or to insert objects from other designs. See 
also Sequencing objects with Color Film.

Note  You can also remove objects from a design 
using the Cut command and paste them back in 
again. Cut and Paste changes the stitching sequence 
in the design. See Resequencing objects with cut and 
paste for details.

To copy and paste objects

1 Select the object(s) to copy.

2 Click the Copy icon.

The selected object is copied to the clipboard.

3 Travel to the position in the stitching sequence at 
which you want to paste the object. See Traveling 
by stitches for details.

You can paste between other objects in the 
sequence. 

4 Click the Paste icon.

Note  The object will be pasted exactly on top of 
the original object. Click and drag it off the object 
before deselecting.

The object remains on the clipboard and can be 
pasted repeatedly until the next Copy or Cut 
command.

Caution  Make sure that there is only one copy of 
an object at any one position. If an object is pasted 
twice into the same position, it will be stitched 
twice.

Duplicating objects

Objects can be duplicated rather than copied. When 
an object is duplicated, it is not copied to the 
clipboard. This leaves the clipboard free for you to cut 
or copy other objects. See also Sequencing objects 
with Color Film.

Click Copy (General toolbar) to copy selected 
objects to the clipboard.

Click Paste (General toolbar) to paste copied objects 
in the design.

Select Duplicate (Edit menu) to duplicate selected objects.

Petals copied
and pasted
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To duplicate objects

1 Travel to the point in the stitching sequence where 
you want to place the object(s). See Traveling by 
stitches for details.

You can place the duplicate(s) between other 
objects in the sequence.

2 Select the object(s) to duplicate.

3 Select Edit > Duplicate.

The duplicate object is placed directly on top of the 
original object, in the specified position in the 
stitching sequence. Be sure to click and drag it off 
the object before deselecting.

Cloning objects

The Quick Clone feature lets you quickly duplicate 
selected objects by right-clicking, dragging and 
releasing at a new position.

To clone objects

1 Select the object(s).

2 Holding down the right mouse button, drag the 
object(s) to a new position.

A black outline of the object(s) appears. The 
cursor icon includes a plus symbol.

Tip  For precise positioning, hold down the Ctrl key 
while dragging – movement is constrained to X or 
Y axes.

3 Release the mouse.

A duplicate object(s) is created at the release 
point.

Tip  Clone objects to another window by the same 
method. An identical copy of the selection is 
created at the same coordinates as the first 
window, no matter where the mouse is released.

Grouping and splitting objects

You can group selected objects or an entire design to 
keep them together for moving, scaling or 
transforming purposes. BERNINA Embroidery 
Software makes a distinction between ‘ungrouping’ 
objects and ‘breaking apart’ objects. Generally 
speaking, objects which have been explicitly grouped 
by you, the digitizer, need to be ‘ungrouped’ in order 
to access their component objects. If you want to 
access objects which have been grouped during 
system operations – e.g. when generating 
open-object appliqué – you need to break them apart.

Note  By default, designs are automatically grouped 
upon opening or insertion into another design. See 
Setting other general options for details.

Grouping objects

When you group objects, you can apply a change to 
all of them at once, saving time, and ensuring that 
any changes are consistently applied. Group selected 
objects or the whole design to keep them together for 
moving, scaling or transforming operations.

To group objects

1 Select the objects to group.

2 Click the Group icon or press Ctrl+G.

Selected objects are combined into a group. This 
can be selected, moved, resized and transformed 
as a single object. See also Arranging & 
Transforming Objects and Reshaping & Editing 
Objects.

Ungrouping objects

When you have finished making changes to a group, 
you can ungroup it and work with the objects 
individually.

Use Select Object (Edit toolbar) to select and clone 
objects.

Right-click 
object

Drag-and-drop

Click Group (Arrange toolbar) to group selected 
objects.

Click Ungroup (Arrange toolbar) to ungroup selected 
objects.

Select, move, resize 
or transform grouped 
objects as a single 
object
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Note  You need to ungroup before you can set 
embroidery properties for any individual object in the 
group.

To ungroup objects

1 Select the grouped object.

2 Click the Ungroup icon.

The object is ungrouped and the component 
objects can be individually selected.

Splitting into component objects

A Break Apart tool allows you to split Advanced 
Appliqué objects into their component objects. The 
command can also be used with monograms, Auto 
Appliqué, lettering and Blackwork runs. The effect on 
these objects is similar to the ungrouping operation.

Note  When saved into earlier versions of the 
software, monograms, appliqués, lettering, and 
Blackwork runs may be subjected to the Break Apart 
procedure by default.

To split into component objects

1 Select the object you want to split – open-object 
appliqué, auto-appliqué, monogram, or lettering.

The Break Apart command is activated.

2 Click the Break Apart icon or select Arrange > 
Break Apart.

The object is split into its component source 
(primary) and any generated (secondary) objects.

The operation ungroups open-object appliqué into 
its component groups – source (primary) objects, 
generated (secondary) objects. It also creates an 
auto-appliqué object from each piece of fabric in 
the design. These will have no stitching. See also 
Digitizing for Appliqué.

The operation ungroups monogram objects into 
their component groups – one lettering object, 
ornaments (each ornament set remaining as a 
group) and borders (also grouped). See also 
Monogramming.

Tip  To modify individual objects – e.g. to change 
the stitching sequence of monogram borders – use 
the Color Film to ungroup objects and resequence.

Sequencing objects

The embroidery objects in a design form a ‘stitching 
sequence’. Initially, objects are stitched in the order 
they were created. However, you can change this by 
a variety of methods. For example, change the 
position of a selected object by cutting it, then pasting 
it somewhere else in the sequence. There are also 
techniques available to sequence objects ‘as selected’ 
or as ‘color blocks’. You can also resequence objects 

Use Break Apart (Edit toolbar) to split monograms, 
appliqués, lettering, and Blackwork runs into compo-
nent objects.

Ungrouped objects 
can be individually 
selected
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using the Color Film. See also Sequencing objects 
with Color Film.

Note  When working with embroidery designs, you 
need to understand the stitching sequence. You can 
check this by ‘traveling’ through the design 
stitch-by-stitch or by slowly redrawing it on screen. 
See Viewing the stitching sequence for details.

Resequencing objects with cut and paste

You can resequence objects by cutting an object from 
the design and pasting it back at a different point in 
the sequence. This does not change the physical 
location of the object.

To resequence objects with cut and paste

1 Select the object(s) to resequence.

2 Click the Cut icon.

The selected object is removed from the design 
and moved to the clipboard.

3 Travel to the position in the stitching sequence 
where you want to paste the object. See Traveling 
by stitches for details.

You can paste between other objects in the 
sequence, or ‘nest’ the cut object within another 
object. 

If your current needle position marker is at the end 
of the design, it will be pasted at the end of the 
sequence.

4 Click the Paste icon.

The object is pasted back in the design. 

Note  The object remains on the clipboard and can 
be pasted repeatedly until the next Copy or Cut 
command.

Resequencing objects as selected

You can resequence objects by selecting them in the 
required stitching order. 

To resequence objects as selected

1 Select the first object in the range you want to 
resequence.

2 Holding down Ctrl, select the subsequent objects 
to resequence.

Note  Select each object in the order you want it 
to stitch out in.

3 With the objects still selected, select 
Arrange > Sequence As Selected.

The objects are resequenced in the order they 
were selected right after the first selected object. 
See also Sequencing objects with Color Film.

Resequencing objects by color

You can resequence objects by color. This reduces the 
number of color changes in a design. See also 
Sequencing objects with Color Film.

To resequence objects by color

1 Select the objects to resequence. 

2 Select Arrange > Sequence By Color.

Click Cut (General toolbar) to cut a selected object or 
objects and place them on the clipboard.

Click Paste (General toolbar) to paste copied objects 
in the design.

Wrong sequence Select and cut object 
to be changed

Paste the object
Travel to the end of 

the design

Select Sequence As Selected (Arrange menu) to rese-
quence selected objects.

Select Sequence By Color (Arrange menu) to resequence 
objects by color.

Wrong sequence Correct sequence
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The Sequence By Color dialog opens listing the 
colors used in the selected objects.

3 Select a color and click Move Up or Move Down to 
change its position in the sequence.

4 Click OK.

Resequencing objects to start or end

You can resequence objects by selecting them and 
placing them at the start or end of the stitching 
sequence. See also Sequencing objects with Color 
Film.

To resequence objects to start or end

Select the object(s).

Select Arrange > Sequence to Start.

The design is resequenced with the selected 
object(s) placed first in the stitching sequence.

Select Arrange > Sequence to End.

The design is resequenced with the selected 
object(s) placed last in the stitching sequence.

Sequencing objects with Color Film

Designs are made up of individual embroidery 
‘objects’ grouped by ‘color block’. These are listed in 
stitch order in the Color Film. Use it to optimize your 
design by cutting, copying, pasting, duplicating, 
deleting, and resequencing selected color blocks. 
Generally, you should aim to keep objects of the same 
color together in the stitching sequence to minimize 
the number of color changes, trims, and frame 
movements. Once you have optimized the color 
sequence, you can optimize your design further by 
checking the order in which individual objects are 
stitched out. See also Viewing and selecting color 
blocks.

Note  There are instances where colors have to be 
split, particularly when one object is an outline, since 
outlines are necessarily stitched above fills.

To sequence objects with Color Film

Click the Color Film icon on the General toolbar.

The Color Film dialog opens displaying all color 
blocks in the design in order of stitching sequence.

Drag and drop color blocks to change their position 
in the stitching sequence.

Note  The Color Film is synchronized with the 
Design Window and vice versa. It dynamically 
updates whenever you select, modify or delete 
objects, or create new ones. 

Select Sequence to Start (Arrange menu) to place selected 
object at start of stitching sequence.

Select Sequence to End (Arrange menu) to place selected 
object at end of stitching sequence.

o

Click Color Film (General toolbar) to open the Color 
Film. Resequence by dragging and dropping objects 
in the list.

Click Show Individual Objects (Color Film toolbar) to 
view individual objects in order of stitching 
sequence. Drag and drop object icons to rese-
quence.

Black first Black last

Select Sequence As Selected (Color Film toolbar) to 
resequence selected objects.

Select Sequence By Color (Color Film toolbar) to 
resequence objects by color.

Select Sequence to Start (Color Film toolbar) to 
place selected object at start of stitching sequence.

Select Sequence to End (Color Film toolbar) to place 
selected object at end of stitching sequence.

Click and 
drag color 
block 

Drop color 
block in new 
position
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Click the Show Individual Objects toggle to 
view individual objects.

All objects within each color block are displayed in 
their stitching order.

Use the list to drag and drop object icons and 
resequence as required.

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

Right-click any object in the list to invoke the 
popup menu. Use it to cut, copy, paste, or delete 
objects as required.

Use the Sequence command buttons to reposition 
selected color blocks or individual objects in the 
stitching sequence.

Each Sequence command has the same 
functionality as its identical menu item in the 
Arrange menu – e.g. clicking the Sequence By 
Color icon while it is enabled causes the 
Sequence By Color dialog to open. See also 
Sequencing objects.

Auto-sequencing entire designs

The Stitch Sequence feature improves the quality 
and efficiency of the stitchout by minimizing the 
number of hoopings, color changes, and trims. All 
existing overlaps are preserved by the operation. The 
system analyzes the design and calculates:

hoopings (if there are more than one)

color changes (the total number in the current 
Design Window), and

uncovered objects (if any) – i.e. any stitched 
objects not covered within a hooping.

Grouped objects are not ungrouped by the Stitch 
Sequence operation, but differently colored objects 
are optimally sequenced regardless of grouping. 
Monogramming and open-object appliqué, however, 
are treated as single objects. In other words, they are 
not internally resequenced unless you break them up 
with the Break Apart command. See also Splitting 
into component objects.

To auto-sequence an entire design

1 Open or create a design.

2 Select Arrange > Stitch Sequence.

The system analyzes all selected objects and 
calculates optimal hoopings, color changes and 
trims.

Consecutive objects of 
same color form single 
color block 

All objects comprising
color blocks shown in

their stitching order

Use popup menu to
cut, copy, paste

objects as required

Select Stitch Sequence (Arrange menu) to automatically 
arrange the stitch sequence to minimize hoopings, color 
changes and trims.

6 color 
changes



Chapter 16 : Combining & Sequencing Objects

BERNINA® Embroidery Software : Onscreen Manual 134

Note  If your design does not fit in the current 
hoop, you will be alerted that there are uncovered 
objects. You can fix this by selecting a larger hoop 
or adding more hoopings. See also Hooping large 
designs.

3 Confirm whether you want to proceed with stitch 
sequence optimization by clicking Yes.

Note  The Undo command will reverse the effect 
of any sequencing changes.

4 color 
changes
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CHAPTER 17
ARRANGING & TRANSFORMING OBJECTS

BERNINA Embroidery Software allows you to 
arrange and transform objects by a variety of 
means, both interactive and numeric. Position 
objects by means of click and drag, arrow keys or 
object properties. Align objects relative to each 
other using the special tools available.

Scale objects directly on-screen or by setting 
exact dimensions or scale percentages. Rotate, 
skew and mirror objects by similar means.

Special tools allow you to duplicate and 
transform selected embroidery objects, as well 
as create mirrored and rotated objects around a 
central axis.

This section describes how to position and align objects by both interactive and 
numeric methods. It also covers scaling, rotating and skewing objects. A variety 
of methods for mirroring objects are also described.

Positioning objects

You can position objects in the Design Window by a 
variety of standard MS Windows® techniques 
including click and drag, as well as arrow keys to 
nudge them into position. You also have precise 
numeric control over object positioning by means of 
object properties.

Positioning objects using click and drag
The simplest way to move an object in your design is 
to click and drag it to a new position. Use the arrow 
keys to ‘nudge’ objects into position.

To position objects using click and drag

1 Select the object/s to move.

2 Click and drag the object to a new position.

3 For more accurate positioning, press the arrow 
keys to ‘nudge’ the object into the required 
position.

Tip  Zoom in to make it easier to make small 
adjustments. The distance the object moves 
depends on the current zoom factor. The greater 
the zoom factor, the smaller the distance moved.

Positioning objects using object properties
You can position selected objects relative to the 
center of a design by means of its object properties.

Cross-hair cursor 
centers objects
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To position objects using object properties

1 Select the object/s to move.

2 Double-click or right-click the object/s to open the 
Object Properties dialog, and select the 
General tab.

3 In the Position fields, enter the new coordinates 
for the object.

4 Click Apply.

The object is centered over the coordinates you 
set.

Aligning objects

BERNINA Embroidery Software provides tools to 
precisely align objects relative to each other. You can 
align to the left, right, top, bottom or center of a 
‘reference object’.

To align objects

1 Select the objects you want to align.

2 Select the object you want to align with.

Note  Objects are aligned with the last object 
selected. When we select all the objects in the 
design by using Ctrl+A or a marquee all the 
objects are aligned with the last object in the 
sequence.

3 Click one of the alignment icons on the Arrange 
toolbar.

Scaling objects

You can scale objects directly on-screen or by setting 
exact dimensions or scale percentage. As an object is 
scaled, the stitch count changes to preserve current 
stitch spacing.

Note  The scalability and stitching quality of a design 
ultimately depends on its original source – ART Grade 
A, ART Grade B, ART Grade C, or ART Grade D. Only 
native ART Grade A designs contain the complete set 
of design information required for 100% perfect 
scaling and transformation. See Embroidery design 
formats for details.

Scaling objects using Scale by 20% 
Down/Up

Use Select Object (Edit toolbar) to select an object.

Click Align Left Vertical (Arrange toolbar) to align 
selected objects along their left sides.

Click Align Centers Vertical (Arrange toolbar) to align 
selected objects vertically around centers.

Click Align Right Vertical (Arrange toolbar) to align 
selected objects along their right sides.

Click Align Top Horizontal (Arrange toolbar) to align 
selected objects along their top sides.

Click Align Centers Horizontal (Arrange toolbar) to 
align selected objects horizontally around centers.

Click Align Bottom (Arrange toolbar) to align selected 
objects along their bottom sides.

Click Align Centers (Arrange toolbar) to align 
selected objects centers.

Click Space Horizontally (Arrange toolbar) to evenly 
distribute three or more selected objects horizontally.

Click Space Vertically (Arrange toolbar) to evenly 
distribute three or more selected objects vertically.

Enter new coordinates

Click Scale by 20% Down/Up (Edit toolbar) to reduce 
selected objects by 20%. Right-click to increase 
selected objects by 20%.

Align Centers

Align LeftAlign Bottom

1

2

3
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Use this technique when you need to make very quick 
changes that do not need to be precise.

To scale objects using Scale by 20% 
Down/Up

1 Select the object/s.

Tip  See Selecting objects by point and click for 
the methods used to quickly select more than one 
object or all objects in a design.

2 Click the Scale by 20% Down/Up icon.

Click to make the object 20% smaller.

Right-click to make the object 20% bigger.

Scaling objects using click and drag
You can change the height and width of an object, or 
scale it proportionally using the selection handles. 
Scale objects individually, or select multiple objects 
and scale them together.

To scale objects using click and drag

1 Select the object/s to scale.

Eight selection handles display around the object.

2 Click and drag a selection handle to resize the 
object.

To scale height and width proportionally, use a 
corner handle.

Tip  By default, objects scale proportionally. To 
scale freely in vertical and horizontal planes, hold 
down Ctrl as you drag.

To change the height, use the handles at the 
center-top or center-bottom.

To change the width, use the handles at the 
center-sides.

Tip  To resize around a center anchor, hold down 
Shift while you resize.

Scaling objects using object properties
You can scale the height and width of selected objects 
or a whole design using object properties.

Caution  If you scale a stitch or ‘expanded’ design by 
more than 5%, changes to stitch density will affect 
the design quality. See also Embroidery design 
formats.

To scale objects using object properties

1 Select the object/s to scale.

2 Double-click or right-click the object/s to open the 
Object Properties dialog, and select the 
General tab.

3 In the Dimensions panel, scale the object as 
required. Either:

Enter exact height and width values, or

Enter the new height and width as a percentage 
of the current dimensions.

Scale proportionally Scale proportionally 
about center

Shift+dragDrag

Scale vertically

Drag

Drag

Scale horizontally

Drag
Drag

Shift+drag

Scale 
vertically in 
both directions

Scale horizontally in 
both directions

Shift+drag

Enter dimensions as
absolute values or as

percentage
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Tip  Use the Proportional Scaling checkbox to 
maintain proportional scaling of original object.

4 Click Apply.

Note  After scaling, the new object size is reset to 
100%.

Rotating objects

You can rotate objects directly on-screen or by setting 
an exact rotation angle.

Rotating objects using click and drag
When you select an object, selection handles display 
at its extremities. When you click the object again, 
the handles change to rotation handles.

To rotate objects using click and drag

1 Select the object/s to rotate.

Eight selection handles display around the object.

2 Click the object/s a second time.

Rotation handles appear at the corners and an 
anchor point at the center of the object.

Caution  If you click too quickly, the Object 
Properties dialog opens.

3 If required, drag the rotation anchor from the 
center to a new position.

4 Click a rotation handle, and drag it clockwise or 
counter-clockwise. An outline and cross-hairs 
display as you rotate.

Rotating objects using Rotate CCW/CW

Use the Rotate CCW / CW by 45° tool to rotate 
objects by 45° rotations in either direction.

To rotate objects using Rotate CCW / CW 
by 45°

1 Select the object/s to rotate.

2 Click Rotate CCW / CW by 45° on the toolbar. 

Click to rotate 45° counter-clockwise.

Right-click to rotate 45° clockwise.

Rotating objects using object properties
You can rotate selected objects by specifying an exact 
rotation angle.

To rotate objects using object properties

1 Select the object/s to rotate.

2 Double-click or right-click the object/s to open the 
Object Properties dialog, and select the 
General tab.

3 In the Rotate By field, enter the rotation angle 
you require.

4 Click Apply.

Skewing objects

You can skew objects directly on-screen or by setting 
an exact skew angle.

Original object

Height scaled by 150%

Height scaled by 80% 
Width scaled by 140%

First click displays 
selection handles

Second click displays 
rotation handles

Anchor point

Skew handle
Rotation handle

Use left/right-click Rotate CCW / CW by 45° (Edit 
toolbar) to rotate an object or design by 45° in either 
direction.

Drag a corner to 
rotate about the 

anchor point

Drag the anchor 
point

Drag a corner to 
rotate about the 

anchor point

Enter rotation 
angle
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Skewing objects using click and drag
You can skew objects along the horizontal plane by 
clicking skew handles and dragging to the required 
angle.

To skew objects using click and drag

1 Select the object/s to skew.

Eight selection handles display around the object.

2 Click the object/s a second time.

Rotation handles appear at the corners and skew 
handles at center-top and bottom of the object.

Caution  If you click too quickly, the Object 
Properties dialog opens.

3 Drag the skew handles left or right. 

The object skews along the horizontal plane. An 
outline and cross-hairs show the change to the 
object’s shape.

Skewing objects using object properties
You can skew selected objects by entering an exact 
angle in the Object Properties dialog.

To skew objects using object properties

1 Select the object/s to skew.

2 Double-click or right-click the object/s to open the 
Object Properties dialog, and select the 
General tab.

3 In the Skew By field, enter the skew angle you 
require. 

4 Click OK.

Mirroring objects

You can mirror objects horizontally or vertically using 
the mirroring tools or via object properties. Special 
tools allow you to duplicate and transform selected 
embroidery objects, as well as create mirrored and 
rotated objects around a central axis.

Mirroring objects horizontally or vertically

You can mirror selected objects horizontally or 
vertically using Mirror Horizontal or Mirror 
Vertical.

First click displays 
selection handles

Second click displays 
rotation handles

Anchor point

Skew handle
Rotation handle

Drag skew handle 
left or right

Skewed 30° using
Object Properties

Click Mirror Horizontal (Edit toolbar) to flip an object 
or design horizontally.

Click Mirror Vertical (Edit toolbar) to flip an object or 
design vertically.

Enter skew angle
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To mirror objects horizontally or vertically

1 Select the object/s to mirror.

2 Click the Mirror Horizontal icon to flip 
horizontally or Mirror Vertical to flip vertically.

Mirroring objects using object properties
You can mirror selected objects horizontally or 
vertically using the Object Properties dialog.

To mirror objects using object properties

1 Select the object/s to mirror.

2 Double-click the object to open the Object 
Properties dialog, and select the General tab.

3 In the Mirror panel, select the In X or In Y 
checkbox.

In X mirrors the object in the horizontal plane.

In Y mirrors the object vertically.

Tip  Select both checkboxes to mirror horizontally 
and vertically at the same time.

4 Click OK.

Mirror-merging objects

The Mirror-Merge tools allow you to duplicate and 
transform selected embroidery objects, and merge 
them into a single object.

To mirror-merge objects

1 Select the object/s.

Note  Make sure the source object/s are 
ungrouped otherwise colors will not be 
automatically resequenced during the 
mirror-merge operation.

2 Select a Mirror-Merge tool.

Mirror-Merge Horizontal:

Mirror-Merge Vertical:

Mirror-Merge Horizontal/Vertical:

Use Mirror-Merge Horizontal (Arrange toolbar) to 
mirror-merge horizontally.

Use Mirror-Merge Vertical (Arrange toolbar) to mir-
ror-merge vertically.

Use Mirror-Merge Horizontal/Vertical (Arrange tool-
bar) to mirror-merge both horizontally and vertically.

Mirror horizontal 
and vertical (X 
and Y)

Mirror
vertical (Y)

Original
object

Mirror 
horizontal (X)

Flip horizontally
Flip vertically
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3 Move the reference line to the position you want to 
add the mirrored object and click to mark the 
anchor point.

The pointer attaches to the reference line. As you 
move the pointer around the object, the mirrored 
object moves also. A copy of the object is placed 
as a mirror image of the original.

Note  If the mirrored copy overlaps the original 
object, you are asked if you want to merge the 
objects.

Creating wreaths

The Wreath tool duplicates objects around a central 
point. The Kaleidoscope tool works with Wreath to 
create mirrored objects around the central axis. 
Because the object is mirrored, Kaleidoscope only 
works with an even number.

Tip  Use the Wreath tool with alphabets and 
numbers to create fun designs.

To create a wreath

1 Select the object/s.

Note  Make sure the source object/s are 
ungrouped otherwise colors will not be 
automatically resequenced during the 
mirror-merge operation.

2 Click the Wreath icon.

3 Enter the number of Wreath points.

Note  Enter an even number to activate the 
Kaleidoscope icon.

4 Click the Kaleidoscope icon if required.

5 Move the reference line to the center of the wreath 
and click to mark the anchor point.

Tip  Hold down Ctrl to constrain the line to 45° 
angles.

The pointer attaches to the center point. As you 
move the pointer around the object, the mirrored 
objects also move. The objects are copied and 
placed around this center point.

Note  If the mirrored copy overlaps the original 
object, you are prompted to merge the objects.

Use Wreath (Arrange toolbar) to duplicate objects 
around a central point.

Use Kaleidoscope (Arrange toolbar) to mirror objects 
around a central axis.

Six-point wreath with 
Kaleidoscope OFF

Six-point wreath with 
Kaleidoscope ON

Move pointer to set 
the center point

Eight point wreath with center 
marked below original object

Eight point wreath with center
marked above original object
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CHAPTER 18
RESHAPING & EDITING OBJECTS

BERNINA Embroidery Software lets you modify object 
shapes, stitch angles and entry and exit points by means of 
reshape nodes. Stitch angle lines and entry and exit markers 
all appear around selected objects. Reshape nodes vary 
slightly with the object type. 

Before modifying any design, a good practice is to save a 
copy under a new name and keep the original in case you 
want to discard your changes and start again.

This section describes how to reshape objects – including 
circle and pattern run objects – with reshape nodes. It also 
covers adjusting stitch angles – including multiple stitch 
angles – as well as changing entry and exit points. See also 
Editing Embroidery Lettering.

Reshaping objects

In BERNINA Embroidery Software you reshape 
objects by selecting them with the Reshape Object 
tool and moving, adding or deleting reshape nodes on 
the outline. With some objects, you can also change 
reshape nodes from corner points to curves. 
Reshaping operations do not affect stitch angles.

Note  Stitches of all objects are now regenerated 
whenever a reshaping change is made.

Viewing and selecting reshape nodes

Reshape nodes can be selected individually or 
together, for repositioning or modification.

To view and select reshape nodes

Select an object and click the Reshape Object 
icon.

Reshape nodes appear around the object.

Click to select a single reshape node.

Holding down Ctrl, click to select multiple reshape 
nodes.

Click Reshape Object (Edit toolbar) to view the 
reshape nodes of a selected object.

Corner reshape 
node

Exit point

Curve reshape 
node

Entry point
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Holding down Shift key, click to select a range of 
reshape nodes. 

Tip  Left-clicking or right-clicking in closed shapes 
reverses the direction of the selection.

Click and drag a bounding box around a group of 
reshape nodes to select.

Reshaping objects using reshape nodes

Change object shapes with the Reshape Object tool. 
Use it to add, delete, or move reshape nodes on the 
object outline. For some objects, you can also change 
between corner and curve points.

To reshape objects using reshape nodes

1 Select the object to reshape.

2 Click the Reshape Object icon.

Reshape nodes appear around the object.

3 To add extra reshape nodes on the outline:

Left-click to add a corner point.

Right-click to add a curve point.

4 Select reshape nodes as required. See Viewing and 
selecting reshape nodes for details.

5 Adjust the position of selected reshape nodes by 
dragging them along the outline as required and 
press Enter.

Tip  Use the arrow keys to ‘nudge’ selected 
reshape nodes.

6 Press Delete to delete unwanted reshape nodes 
and press Enter.

7 Press Spacebar to toggle between selected corner 
and curve reshape nodes and press Enter.

Tip  If you make a mistake, press Esc to remove 
the changes, press Esc again to exit Reshape 
Object tool.

Click Reshape Object (Edit toolbar) to reshape 
selected objects.

Right-click

Left-click

Drag and press 
Enter

Select, delete 
and press Enter

Select, press 
spacebar and 
press Enter



Chapter 18 : Reshaping & Editing Objects

BERNINA® Embroidery Software : Onscreen Manual 144

Note  You can also adjust stitch angles as 
required, as well as change entry and exit points. 
See Adjusting stitch angles and Adjusting entry 
and exit points for details.

8 Press Esc to finish.

Reshaping next or previous objects
When editing an object in Reshape mode, use the 
Tab key to quickly jump between objects. See also 
Deselecting objects.

To reshape next or previous objects

Press the Tab key to accept all changes to an 
object and jump to the next object in the stitching 
sequence.

Pressing Shift + Tab causes all changes to the 
object to be accepted and the previous object in 
the stitching sequence to be selected for 
reshaping.

Smoothing curves

Like vector objects, embroidery objects contain 
reshape nodes on their outlines. On shapes where the 
angle changes constantly, the software may insert 
hundreds of reshape nodes, making reshaping 
difficult. The Smooth Curves command lets you 
apply curve ‘smoothing’ to embroidery objects. 

To smooth curves

1 Select the object (or objects) to smooth.

Note  You can only smooth objects that have been 
ungrouped and selected. However, you can select 
multiple objects.

2 Click the Reshape Object icon.

Reshape nodes display around the outline.

3 Select Edit > Smooth Curves.

The Smooth Curves dialog opens.

4 In the Precision field, enter the smoothing 
precision value.

This value controls how closely the smoothed 
outline follows the original. The larger the 
precision value, the fewer the reshape nodes.

5 Click OK.

Reshaping circle objects

For objects created with 
the Circle tool, you 
reshape using the 
existing reshape nodes 
only. You cannot add, 
change or delete reshape 
nodes in these objects. 
You can change Circle 
objects from circles to ovals using the Reshape 
Object tool. Circle objects have two reshape nodes 
(used to change the radius and orientation of the 
object), a center point (used to reposition it), and a 
stitch entry point.

Use Reshape Object in combination with Edit > 
Smooth Curves to remove unnecessary reshape 
nodes from embroidery objects.

Shift + Tab Tab

Click Reshape Object (Edit toolbar) to reshape circle 
objects

Entry
point

Reshape node

Center point

Stitch angle

90°

Reshape node
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To reshape circle objects

1 Select a Circle object and click the Reshape 
Object icon.

Reshape nodes appear around the object.

2 To move a circle, click the reshape node in the 
circle’s center, and drag it to a new position.

3 Click a reshape node on the circumference of the 
circle, and drag it to reshape the outline.

To reshape without changing the orientation, 
use the reshape node at the top of the object.

To reshape and spin the object around its 
center point, use the reshape node at the side.

4 Press Enter to apply the changes, then Esc to 
finish.

Tip  To scale a circle without changing it to an oval, 
select it with the Select Object tool, and use the 
corner selection handles to scale it.

Reshaping pattern runs

Reshape pattern runs with the Reshape tool in the 
same way as you reshape lettering objects. You can 
make pattern runs taller or narrower, rotate pattern 
runs, move individual patterns along the baseline or 
reshape the baseline. You can rotate, skew and mirror 
pattern runs just like other objects.

To reshape pattern runs

1 Select a pattern run and click the Reshape icon.

Reshape nodes appear around the object.

2 Drag the reshape nodes to change the appearance 
of the pattern run.

3 Press Esc to finish.

Adjusting stitch angles

Stitch angle adjustments depend on the type of object 
you are working with. With filled objects you can set 
a stitch angle for the entire object. Alternatively, you 
can add multiple stitch angles with the Add Stitch 
Angles tool. You can also adjust the stitch angle 
using the Reshape Object tool.

Scale using corner 
selection handles

Click Reshape Object (Edit toolbar) to view the 
reshape nodes of a selected object.

Drag to scale patterns 
proportionally

Drag to change baseline 
length and orientation

Drag to scale patterns 
horizontally

Drag to scale pattern heightDrag to move 
individual patterns

Default patterns

Individual 
pattern moved

Pattern size increased 
proportionally

Pattern width 
decreased

Pattern height 
increased

Baseline length and 
orientation changed
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Note  You can change the stitch angle of Circle 
objects by moving the stitch entry point.

Setting nominal stitch angles

You can change the nominal stitch angles of filled 
objects using object properties.

Note  Whenever Remove Stitch Angles is applied 
to selected objects with turning stitch angles, the 
resultant object takes a single, nominal stitch angle.

To set the nominal stitch angle

1 Select an closed object with or without turning 
stitches.

2 If necessary, click the Remove Stitch Angles tool 
to return it to the current nominal stitch angle.

3 Right-click the Add Stitch Angles icon.

Alternatively, double-click or right-click the object 
itself.

The Object Properties dialog opens.

4 Select the Stitch Angle tab if not already 
selected.

5 In the Angle field, enter the required stitch angle.

6 Click Apply.

Adding stitch angles

The stitch angles of filled objects are all modified in 
the same way. Multiple stitch angles can be added or 
subtracted with the Stitch Angles tools.

In BERNINA Embroidery Software, the Add Stitch 
Angles tool can be applied to closed objects with:

turning stitch angles

a single stitch angle, with or without hole(s).

Use Stitch and Color Bar > Add Stitch Angles to set 
the nominal stitch angles for closed objects with or 
without holes.

Use Stitch and Color Bar > Remove Stitch Angles to 
remove stitch angles from closed objects with turning 
stitches.

Object with 
turning stitch 
angles

Nominal 
angle: 45°

Use Stitch and Color Bar > Add Stitch Angles to add 
stitch angles to closed objects with or without holes.

Use Stitch and Color Bar > Remove Stitch Angles to 
remove stitch angles from closed objects with turning 
stitches.

Enter required stitch angle

Nominal angle: 90°Nominal angle: 0°

Multiple stitch anglesSingle stitch angle
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Tip  With the Reshape tool, you can add individual 
reshape nodes, modifying the shape without 
affecting the stitch angles. See Reshaping objects 
using reshape nodes for details.

To add stitch angles

1 Select an closed object with or without turning 
stitches.

Note  If a Stitch Angles tool is applied to an 
object with a Star Fill or Wave Fill effect, the 
effect is removed.

2 If necessary, click the Remove Stitch Angles tool 
to return it to the current nominal stitch angle.

3 Click the Add Stitch Angles icon.

You are prompted to enter stitch angles.

Tip  If you press Enter without entering stitch 
angle lines after the Add Stitch Angles tool is 
activated, stitch angle line/s are automatically 
created. You either press Enter again to accept 
the angle lines or Spacebar to discard them so a 
single stitch angle is applied.

4 Digitize stitch angles – Points 1 and 2 – so that 
they intersect two sides of the object. Make sure 
that they do not intersect each other.

Caution  New stitch lines should not intersect 
existing stitch lines or an error message displays. 
Press Backspace to delete.

5 Enter as many stitch angles as required to create 
a turning fill effect.

6 Press Enter to apply changes, then Esc to finish.

The object is re-stitched with the new angles.

Tip  Use the Reshape Object tool to adjust 
reshape nodes as required. See Adjusting stitch 
angles on-screen for details.

Adjusting stitch angles on-screen

Click Reshape Object (Edit toolbar) to adjust the 
multiple stitch angles of a selected object.

Turning stitch 
angles applied
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You can change stitch angles of filled objects using the 
Reshape Object tool.

To adjust stitch angles on-screen

1 Select the filled object.

2 Click the Reshape Object icon.

Reshape nodes appear including stitch angle lines.

3 Select stitch angle nodes and press Delete to 
remove stitch angles.

Tip  When you move the mouse pointer over the 
stitch angle point, a tooltip displays the stitch 
angle of the selected object.

4 Click and drag lines as required.

5 Press Enter to apply the changes, then Esc to 
finish.

The object is re-stitched with the new angles.

Tip  To set a precise stitch angle, use object 
properties. See Setting nominal stitch angles for 
details.

Adjusting entry and exit points

The default Closest Join method automatically 
calculates the closest join between objects while 
digitizing – no need to think about object entry and 
exit points. The Settings > Options > General tab 
lets you deactivate the setting if so required. When 
deactivated, all newly digitized objects are joined by 
the As Digitized method. This means you are 
prompted to enter entry and exit points as you 
digitize. You can change these at any time with the 
Reshape Object tool. See also Setting other general 
options.

To adjust entry and exit points

1 Select the object.

2 Click the Reshape Object icon.

Reshape nodes appear, including entry and exit 
points.

Note  In Circle objects, only the entry point 
appears.

3 Select the entry or exit point as required, and drag 
it to a different position on the object outline.

Click Reshape Object (Edit toolbar) to adjust the 
entry and exit points of a selected object.

Long
travel runs

Exit point

Entry point
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4 Press Enter to apply the changes, then Esc to 
finish.

Note  In Circle objects, the stitch angle is 
perpendicular to the line connecting the entry 
point to the circle center. Thus, changing the stitch 
entry point in a Circle object changes its stitch 
angle.

Exit point

Entry point
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CHAPTER 19
EDITING STITCHES

With BERNINA Embroidery Software 
designs, stitches are automatically 
generated from design outlines and 
properties. This means you can scale, 
transform and reshape designs without 
affecting stitch density or quality. 
However, BERNINA Embroidery 
Software also lets you edit individual 
stitches. You simply select and 
manipulate them like any other object. 
For example, you can insert stitches in 
an object to fill gaps, or move and 
delete individual or clusters of selected stitches. You may need to do this, for 
example, when working with ‘stitch files’ which do not contain design outline data. 
Where possible, however, edit the object properties rather than individual 
stitches. See also Embroidery design formats.

This section deals with selecting and editing stitches.

Selecting stitches

The Stitch Edit feature lets you select single stitches, 
several stitches, or a range of stitches by selecting 
their needle points, or dragging a bounding box 
around them. Selected stitches are highlighted in a 
different color. 

Selecting stitches by needle point

You can select individual stitches in Stitch Edit mode 
by selecting their needle points.

To select stitches by needle point

1 Select Edit > Stitch Edit. Alternatively press E.

Tip  Zoom in and display the needle points for 
easier selection. See Zooming in and out and 
Viewing needle points.

2 Click a needle point.

The needle point and stitch colors change and the 
needle position marker moves to the selected 
stitch. All stitches after the needle position marker 
in the stitching sequence appear in black.

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

Use Stitch Edit (Edit menu) to select individual stitches for 
editing.

Selected stitch
Hold down Shift to select a 
range of stitches
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Selecting stitches with a bounding box

You can quickly select all stitches in a group by 
dragging a bounding box around them.

To select stitches with a bounding box

1 Select Edit > Stitch Edit. Alternatively press E.

Tip  Zoom in and display the needle points for 
easier selection. See Zooming in and out and 
Viewing needle points.

2 Drag a bounding box around the stitches you want 
to select.

Stitches are selected when you release the mouse 
button.

Inserting stitches

You can insert stitches in an object to fill gaps. 
Inserted stitches are considered part of the object 
rather than independent objects. They will, however, 
be lost if the object’s stitches are regenerated. Where 
possible, edit the object properties rather than 
individual stitches. For example, to increase stitch 
density, reduce spacing rather than insert stitches.

To insert stitches

1 Select Edit > Stitch Edit. Alternatively press E.

Tip  Zoom in and display the needle points for 
easier selection. See Zooming in and out and 
Viewing needle points.

2 Select a needlepoint.

The needle point and stitch colors change and the 
needle position marker moves to the selected 
stitch. All stitches after the needle position marker 
in the stitching sequence appear in black.

3 Move the mouse pointer where you want to insert 
the new stitch, and right-click.

4 Move the mouse to where you want to insert the 
next stitch, and right-click. 

5 Continue right-clicking as required.

Moving stitches

You can move individual or groups of selected 
stitches.

Caution  If an object’s stitches are regenerated for 
any reason, all stitch editing functions are lost. Where 
possible, reshape the object rather than move 
individual stitches. See Reshaping & Editing Objects 
for details.

Use Stitch Edit (Edit menu) to select stitches with a bound-
ing box.

Use Stitch Edit (Edit menu) to insert stitches in an object.

Bounding box Stitches selected

Use Stitch Edit (Edit menu) to select individual stitches for 
moving.

Right-click to insert new stitch

New stitch 
inserted and 
selected

Right-click to insert new stitch

New stitch 
inserted and 
selected
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To move stitches

1 Select Edit > Stitch Edit. Alternatively press E.

Tip  Zoom in and display the needle points for 
easier selection. See Zooming in and out and 
Viewing needle points.

2 Select stitches and drag them to a new position.

The stitch shadow outline shows the new position.

3 Press Enter.

Deleting stitches

You can delete individual or groups of selected 
stitches.

Caution  If an object’s stitches are regenerated for 
any reason, all stitch editing functions are lost. Where 
possible, edit the object properties rather than 
individual stitches. See Adjusting Satin fill spacing 
and Preserving long stitches for details.

To delete stitches

1 Select Edit > Stitch Edit. Alternatively press E.

Tip  Zoom in and display the needle points for 
easier selection. See Zooming in and out and 
Viewing needle points.

2 Select a stitch or stitches.

3 Press Delete.

Use Stitch Edit (Edit menu) to select individual stitches for 
deletion.

Drag stitch to
new position

Selected stitches

Shadow outline

Stitches deletedStitches selected
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PART V
ADVANCED DIGITIZING

BERNINA Embroidery Software provides specialized productivity features as well as 
special effects and digitizing techniques.

Specialized digitizing techniques

This section covers creating freehand embroidery as well as reinforcing outlines with 
Double Run and Blackwork Run techniques. It also discusses cutting holes and 
removing overlaps, as well as filling holes in objects and creating automatic outlines 
and borders. It also describes how to create buttonholes simply and quickly. See 
Specialized Digitizing Techniques for details.

Artistic stitch effects

This section describes how to apply artistic stitch types and effects to embroidery 
objects, and how to adjust their settings to get the results you want. See Artistic Stitch 
Effects for details.

Pattern runs and fills

This section describes how to insert patterns into your design, and how to adjust their 
settings to get the results you want. It also explains how to create your own patterns 
and pattern sets as well as how to create stitch patterns with carving stamps. See 
Patterned Stamps, Runs & Fills for details.

Craft stitch borders and fills

This section explains how to apply the various craft stitch types to outlines and fills, as 
well as change stitch settings to obtain the best results. See Craft Stitch Borders and 
Fills for details.

Digitizing for appliqué

This section covers creating closed-object appliqué as well as partial cover appliqué. It 
also discusses creating open-object appliqué. See Digitizing for Appliqué for details.
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CHAPTER 20
SPECIALIZED DIGITIZING TECHNIQUES

BERNINA Embroidery Software provides specialized 
digitizing features to create special effects as well 
as save time while you digitize. There are tools for 
creating designs with a hand-drawn appearance, 
something which is difficult to achieve through 
conventional digitizing methods. There are tools for 
reinforcing outlines, cutting holes in objects, 
removing underlying stitching, as well as filling 
holes. Quickly create outline stitching around selected objects or entire designs 
with Single, Triple or Satin Line. There are also specialized tools for quickly and 
easily creating buttonholes. 

This section covers creating freehand embroidery as well as reinforcing outlines 
with Double Run and Blackwork Run techniques. It also discusses cutting holes 
and removing overlaps, as well as filling holes in objects and creating automatic 
outlines and borders. It also describes how to create buttonholes simply and 
quickly.

Creating freehand embroidery

The Freehand Embroidery feature provides 
functionality similar to CorelDRAW® Freehand and 
Polyline tools. Freehand Embroidery has many 
benefits. It lets you easily and fluidly create designs 
with a hand-drawn appearance, something which is 
difficult to achieve through conventional digitizing 
methods. The aim is to mimic designs formed on an 
embroidery machine by freehand motion with the 
fabric secured in an embroidery hoop, allowing the 
needle to ‘draw’ on the fabric surface.

Other techniques include stitching on top of 
photographic images or detailed line drawings. For 
example, use the tools to manually trace a color 
photo-stitch design. This technique requires accuracy 
and control of corners, similar to the CorelDRAW® 
Polyline tool.

Alternatively, designs resembling pencil or charcoal 
sketches can be quickly digitized. Use the tools to 
create ‘doodle’ type drawing effects without following 
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detailed artwork – for example, adding to a basic 
clipart design or decorative text and so on.

Creating freehand lines

Accessed from the Digitize toolbar, the freehand 
feature is deployed in two forms: ‘Open Object’ and 
‘Closed Object’. As with other digitizing tools, 
freehand tools can be used in conjunction with all 
stitch types currently available. With these tools, 
however, you draw objects directly on screen and, in 
the case of outline objects, view a stitch simulation as 
you draw. It is thus possible to produce artistic effects 
similar to free-motion machine embroidery or ‘thread 
painting’. Use the feature to preview designs you have 
in mind before attempting to sew them out manually. 
Alternatively, once designed on screen, sew them out 
automatically.

Note  The Freehand Embroidery tools can be 
operated with a mouse or WACOM pen.

To create freehand lines

To create open objects, select the Freehand 
Embroidery - Open Object tool.

The current outline stitch type is selected. 
BERNINA Embroidery Software prompts you as 
follows:

Click and drag to draw; and release to finish

BERNINA Embroidery Software displays the 
stitches as the mouse drags.

To create closed objects, select the Freehand 
Embroidery - Closed Object tool.

If Outline is selected in the Stitch and Color 
Bar, BERNINA Embroidery Software displays 
the stitches after each click or as the mouse 
drags.

If Fill is selected, a wireframe outline is 
displayed after each click or as the mouse 
drags.

Release the mouse button.

The last point of the curve is joined to the mouse 
position. BERNINA Embroidery Software closes 
and smooths the object outline and, in the case of 
a fill object, immediately displays the fill stitches.

Adjusting freehand line smoothness

The Freehand Embroidery tools have a special 
cursor. This is designed to provide a spacing guide as 
you use the tools. The number and spacing of the 
concentric circles is controlled by the Freehand 

Use Digitize > Freehand Embroidery - Open Object 
to draw embroidery outlines directly on screen and 
view a stitch simulation as they are drawn.

Use Digitize > Freehand Embroidery - Closed Object 
to draw freehand filled embroidery objects on 
screen.

Use Digitize > Freehand Embroidery - Open Object 
to draw embroidery outlines directly on screen and 
view a stitch simulation as they are drawn.

Use Digitize > Freehand Embroidery - Closed Object 
to draw freehand filled embroidery objects on 
screen.
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Embroidery Smoothing toolbar. This toolbar can be 
docked or floating.

To adjust freehand line smoothness

Create a freehand design using outline and/or 
filled objects. See Creating freehand lines for 
details.

Adjust the ‘smoothness’ of your freehand lines by 
means of the Smoothing controls.

The toolbar contains a Smoothing control which 
lets you specify, as a percentage, how closely the 
smoothed outline follows the original. By adjusting 
the percentage, you increase or decrease the 
number of control points BERNINA Embroidery 
Software uses to define an embroidery shape.

Toggle display of the freehand cursor guide as 
reuqired:

You can view and edit the control points generated 
by Freehand Embroidery tools in Reshape 
mode.

If you want to erase a portion of a line, press and 
hold the Shift key while dragging backward over 
the line before releasing the mouse. On releasing 
the Shift key, the edited path is joined with a 
straight line to the mouse position.

Alternatively, press the Backspace key. The last 
point digitized is removed.

Release the mouse to finish the outline at the last 
point digitized. Or press Esc to cancel input of the 
object.

Note  Objects created using the Freehand 
Embroidery tools can be reshaped in the same 
way as objects created via conventional methods 
by selecting the object and clicking the Reshape 
Object tool in the Edit toolbar.

Reinforcing outlines

Use the Double Run feature to reinforce outlines. 
Use Blackwork Run to join selected outlines to form 
a single grouped, reinforced outline, correctly 
sequenced for efficient stitchout.

Tool Note

Use Show Guide to toggle use of the free-
hand digitizing guide cursor. This tool pro-
vides more precise control over ‘freehand’ 
onscreen drawing than the default pointer 
cursor.

Use the Guide Inner Circle Radius control 
to define the size of the center circle of the 
freehand digitizing guide.

Use the Number of Guide Circles control to 
define how many offset circles, as multi-
ples of the inner circle radius, comprise the 
freehand cursor – e.g. if the inner circle 
radius is 2mm, each additional guide circle 
is offset by 2mm.

No smoothing

With smoothing

No smoothing

With smoothing

Hold the Shift key 
and drag back
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Reinforcing outlines with Double Run

Use the Double Run feature to 
reinforce outlines. Double Run 
stitches in reverse direction to 
the original. It is typically used 
to make run stitch outlines 
thicker without creating 
unwanted connecting stitches. 

To reinforce outlines with Double Run

1 Select the object/s to reinforce an outline.

2 Click the Double Run icon, or press Ctrl+B.

The object is duplicated with the stitching 
reversed, and placed on top of the original. It is 
the same color as the original and is positioned 
after it in the stitching sequence.

3 Check that the object has been duplicated by using 
one of the following methods:

Check the stitch count in the Status Bar.

Use Slow Redraw. See Simulating design 
stitchouts for details.

Travel through the stitches. See Viewing the 
stitching sequence for details.

Reinforcing outlines with Blackwork Run

Use Blackwork Run to join selected outlines to form 
a single grouped, reinforced outline, correctly 
sequenced for efficient stitchout. The resulting 
Blackwork Run object always follows the color of the 
first object in the sequence. See also Creating 
backstitch outlines.

Blackwork Run works with embroidery outlines 
consisting of one or a combination of Open Object, 
Closed Object, Circle/Oval, or Rectangle object types. 

All outline stitches can be used except for Pattern 
Run, Blackwork Border or Candlewicking 
Border.

Note  The Ungroup command is not available when 
a Blackwork Run object is selected. If you wish to 
access component objects, use the Break Apart tool. 
See Splitting into component objects for details.

To reinforce outlines with Blackwork Run

1 Select outline objects.

Note  The function is only available if more than 
one object of suitable type is selected. Any which 
cannot be automatically sequenced are excluded 
from the operation.

2 Click the Blackwork Run icon.

3 Digitize the entry point or press Enter to accept 
the default.

Stitches are regenerated. Component objects are 
grouped and take the color of the first object.

Use Double Run (Edit toolbar) to reinforce outlines, 
stitching it in the opposite direction.

Use Blackwork Run (Craft Stitch toolbar) to automat-
ically sequence selected embroidery objects.

Use any of these 
outline stitches

Long connectors 
between separate 
objects

Objects resequenced, 
connectors minimized
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Tip  Travel through the sequenced object to check 
stitching. See Viewing the stitching sequence for 
details.

4 Change the thread color of the entire sequenced 
object as required. See Changing thread colors for 
details.

5 Reshape the sequenced object as required.

Sequenced objects can be reshaped as a whole. 
There is only one entry and one exit point, but all 
component objects have individual reshape points. 
See Reshaping objects using reshape nodes for 
details.

Note  You cannot see a big difference on screen 
after applying Blackwork Run as the reinforced 
outlines cover each other. To check that a 
Blackwork Run object, travel through the stitches. 
See Traveling by stitches for details.

Cutting holes and removing overlaps

When two objects overlap each other, two layers of 
stitching will be applied to the same area. The 
Remove Overlay Stitching feature allows you to 
maintain the shapes but remove one layer of 
stitching. Alternatively you can use fill or lettering 
objects as cutters to cut holes.

Cutting holes in objects

With BERNINA Embroidery Software you can cut holes 
in selected closed objects with a single stitch angle 
using the Add Holes tool.

Note  Add Holes is not designed to work with the 
block digitizing feature or the Stitch Angle tool. It 
must be used with objects created with the Closed 
Object tool.

To cut holes in objects

1 Select the Closed Object or Rectangle object to 
modify.

2 Click the Add Holes icon.

Reference points display around the object outline.

Tip  Follow the instructions in the prompt bar to 
help digitize additional boundaries.

3 Digitize additional boundaries for the object. Press 
Enter after each boundary.

4 Press Enter.

Note  To remove boundaries from a closed object, 
click the Reshape Object icon to display the 
object’s reshape nodes. Select the reshape nodes 
on the unwanted boundary, and press Delete.

Removing underlying stitching

Use the Remove Overlaps tool to remove underlying 
layers of stitching. This helps to reduce the stitch 
count and prevent a build-up of stitches where they 
are not needed. A cutting overlap is preserved 
between ‘cut’ objects and their ‘cutters’ in order to 

Use Add Holes (Edit toolbar) to cut holes in objects.

Use Remove Overlaps (Edit toolbar) to remove 
underlying layers of stitching in overlapping objects.
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prevent gaps forming. This can be adjusted for 
different fabric types.

Valid cutters

Various embroidery objects can be used as cutters if 
not too small and with a stitch spacing of 1.00 mm or 
less. Examples include:

Objects with Satin, Step or Fancy Fill fills

Satin outlines

Auto Appliqué objects with Satin cover stitching

Lettering objects.

‘Cuttable’ objects

‘Cuttable’ objects include:

Filled objects

Auto Appliqué objects

Outline objects.

Lettering and Buttonhole objects cannot be cut in 
Remove Overlaps operations although they can 
both be used as cutters. See also Creating 
buttonholes.

Stitches underlying see-through fills are not removed. 
These include fills such as Pattern Fill, Blackwork Fill, 
Candlewicking Fill, Lacework Fill, Gradient Fill, or 
stitches with more than 1.00 mm stitch spacing. Also 
any stitches underlying narrow sections of objects are 
not removed.

To remove underlying stitching

1 Select one or more ‘cutters’.

2 Click the Remove Overlaps icon or select 
Arrange > Remove Overlaps.

Stitching overlaps are removed according to the 
current setting. To change the setting, see Setting 
Remove Overlaps options.

Note  Multiple cutters can be simultaneously 
selected as part of a single cutting operation.

Overlaps
removed
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In the example above, note that:

The sky object has been broken in two.

The door and path have caused the removal of 
stitches in the house and hill objects.

The tree stem and sky underlying the leaf 
object are preserved since Pattern Fill is not a 
valid cutter.

The section of sky where the orange moon 
overlaps remains unchanged since the moon is 
not selected at the start of the operation.

Filling holes in objects

The Fill Holes tool fills holes in single Closed Object 
or Rectangular objects containing holes. These can be 
removed altogether or new objects created.

To fill holes in objects

1 Select a source object.

2 To use the default settings, simply click the Fill 
Holes icon.

3 To control overlaps or remove holes altogether, 
select Arrange > Fill Holes.

The Fill Holes dialog opens.

4 Choose to remove holes altogether or create new 
objects.

5 If you choose to create new objects, adjust the 
Underlap value as required.

To cover holes exactly, accept the default value 
of 0.00.

To overlap the filled holes and the original 
object, enter a positive offset – e.g. 1.00. 
Overlapping the objects prevents gaps 
appearing.

To leave a gap between the filled holes and the 
original object, enter a negative offset – e.g. 
-1.00.

6 Click OK.

All newly created objects are filled with the current 
fill stitch settings, stitch angle and thread color. 
Each new object is an independent object and is 
placed immediately before the source object in the 
stitch sequence.

Use Fill Holes (Edit toolbar) to fill holes in single 
objects.

Adjust 
underlap value 
as required

Underlap: -1.00
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Creating outlines and borders

Outline Design allows you to quickly create outline 
stitching around selected objects or entire designs 
with Single, Triple or Satin Line. See also Creating 
automatic outlines and borders.

To create outlines and borders

1 Select the embroidery object/s or design to 
outline.

2 Click the Outline Design icon.

The Outline Design dialog is displayed.

3 Adjust the settings as required:

4 Click OK to apply settings.

The design outline is stitched in the current palette 
color using current properties. The outline is put 
last if the whole design is selected, or after a 
design part, in cases where the selected part of the 
design is separated by ‘whitespace’ from the rest 
of the design.

Creating buttonholes

BERNINA Embroidery Software allows you to insert 
preset buttonholes. You can specify their size and 
merge them into a design. Buttonholes are usually 
formed with Satin column stitches bordering a slit 
that is approximately the length of the button 
diameter. The satin stitch border protects the slit from 

Use Digitize > Outline Design to stitch around groups 
of objects with Single, Triple or Satin Line.

Set number of 
outlines

Field Description

Offset Set an outline offset in mm. This may be 
zero or even a negative value.

Outline Count Specify multiple outlines – up to 99.

Outline Holes Option to exclude or include outlines for 
any holes in the selected object.

Outline Type Choice of outline object types: Single, 
Triple or Satin Line.

Select Add Buttonhole (Arrange menu) to add buttonholes 
to your design.
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fraying. The buttonhole consists of a bead of satin 
stitches with a bar tack.

Adding buttonholes
Add buttonholes to a design.

To add buttonholes

1 Open or create a design requiring buttonholes.

2 Select Arrange > Add Buttonhole.

The current buttonhole outline appears attached 
to the mouse pointer.

3 Click to place the buttonhole.

4 Repeat to add more buttonholes.

5 Press Esc to finish.

It is good practice to remove areas of stitching 
which underlie the buttonhole object. See 
Removing underlying stitching for details.

Tip  If a buttonhole has been placed over other 
objects, some of the underlying stitches could 
unravel after the slit has been cut. To prevent this, 
objects under the buttonhole can be reshaped so 
that their boundaries line up along buttonhole slit. 
See Reshaping & Editing Objects for details.

Creating a line of buttonholes
Add a line of evenly spaced buttonholes to a design 
with the Add Buttonholes command.

To create a line of buttonholes

1 Open or create a design requiring buttonholes.

2 Select Arrange > Add Buttonholes.

The Buttonholes Settings dialog opens.

3 Enter the number of the buttonholes your design 
requires and click OK.

4 Click where you want to put the first buttonhole in 
your design. 

Bead Buttonhole

Bar tack top

Bar tack end

Underlying 
stitching removed

Enter number of 
buttonholes 
required
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5 Drag the line to where you want to put the last 
buttonhole. 

6 Use the measure tooltip as a guide and click to 
complete.

Changing buttonhole types

Select the buttonhole type before or after digitizing. 
If you use buttonholes without selecting a buttonhole 
type, the default will be used.

To change a buttonhole type

1 Click the Object Properties icon and select the 
Buttonhole tab.

2 Select a buttonhole type.

3 Click Apply.

Tip  Double-click or right-click the buttonhole 
object to change the buttonhole type for that 
object only.

Adjusting buttonhole length and density

Change the buttonhole length by changing the length 
of the slit. Use the Object Properties dialog to enter 
an exact length or use the Reshape Object tool.

Tip  You can also adjust the buttonhole length using 
the Reshape Object tool.

Increase or decrease the bead stitch density by 
decreasing or increasing the Bead Stitch Spacing.

To adjust buttonhole length and density

1 Click the Object Properties icon and select the 
Buttonhole tab.

Tip  Double-click or right-click the buttonhole 
object to change the stitch values for that object 
only.

2 In the Slit Length field, enter a new value.

3 In the Bead Stitch Spacing field, enter a new 
value.

4 Click Apply.

Adjusting buttonhole orientation
You can rotate buttonhole objects just like any other 
embroidery objects by manipulating control points 
on-screen or via their object properties. Any of the 
following techniques will work:

Use Object Properties (General toolbar) to change 
buttonhole types.

Use Object Properties (General toolbar) to change 
buttonhole length and density.

Measure tooltip

Drag 
buttonhole 
line

Select button
hole type

Adjust
button hole

values

Slit length: 
20mm

Slit length: 
15mm

Slit length:
10mm

Bead Stitch 
Spacing: 0.3mm

Bead Stitch 
Spacing: 0.4mm

Bead Stitch 
Spacing: 1.0mm
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Select Object tool to rotate one or more 
buttonholes together. See Rotating objects for 
details.

Reshape Object tool to rotate single buttonholes. 
See Reshaping objects for details.

Rotate 45° CCW/CW tool to rotate one or more 
buttonholes. See Rotating objects using Rotate 
CCW/CW for details.

Mirror Vertical and Mirror Horizontal tools. 
See Mirroring objects for details.

Object Properties dialog to rotate one or more 
buttonholes individually. See Rotating objects 
using object properties for details.

Multiple 
buttonholes 
rotated

Buttonhole 
rotated and 
resized
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CHAPTER 21
ARTISTIC STITCH EFFECTS

BERNINA Embroidery Software provides many 
artistic effects and stitch types to create textured 
and patterned fill stitching.

Contour stitch provides back and forth stitching 
with a fixed number of lines with variable spacing 
depending on the object outline. Fancy Fill is a 
decorative fill stitch, based on Step Fill, in which 
the needle penetrations form a tiled pattern. Cross 
Stitch fill is something like Pattern Fill but it is 
generated differently and uses travel runs under 
and along the cross stitching. 

Use Textured Edge to add rough edges to objects, 
create shading effects, or imitate fur or other fluffy 
textures in your design.

Wave Effect lets you contour fill stitches along a digitized guideline. Stitches 
follow the line but maintain uniform density and needle penetration patterns. Star 
Fill generates radial turning stitching in several stitch types such as Satin and 
Tatami stitch. Gradient Fill varies stitch spacing between dense and open fill, 
producing shading effects which are difficult to achieve manually. Apply Travel on 
Edges effect to force underlying travel runs to the edges of an object so that they 
can’t be seen through open stitching. 

Use the Color Blending effect to create different shading, perspective, 
three-dimensional and color effects by blending two colored layers in an 
embroidery object. The Morphing feature allows you to transform object outlines 
and stitches in a variety of novel and interesting ways. 

This section describes how to apply artistic stitch types and effects to embroidery 
objects, and how to adjust their settings to get the results you want.

Creating contour fills

Contour stitch provides back and forth stitching with 
a fixed number of lines with variable spacing 
depending on the object outline. It can only be 
applied to block digitizing objects, including Circle 
objects. Closed objects modified with the Add Stitch 

Angles tool cannot be used with Contour stitch. See 
also Creating ripple fills.

Use Fill (Stitch and Color Bar) to select a fill stitch 
type before or after digitizing.
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Contour stitch is accessed from the stitch list in the 
Stitch and Color Bar and the Fill Stitch object 
properties tab.

To create a contour fill

1 Click the Fill icon and choose Contour from the 
dropdown menu.

Tip  You can digitize the shape before or after 
selecting the fill.

2 Create a block digitizing object and select. See 
Digitizing Methods for details.

The current Contour settings are applied to the 
selected object.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 Adjust contour Stitch Values as desired:

Adjust Stitch Length for smoother or sharper 
curves.

Adjust Stitch Spacing for denser or more 
open stitching.

5 Click Apply to preview the effect or OK to finish 
and close.

The selected settings are applied to the object.

Creating fancy fills

Fancy Fill is a decorative fill stitch, based on Step Fill, 
in which the needle penetrations form a tiled pattern. 
Use Fancy Fill to fill wide and large areas with unique 
artistic effects while keeping the appearance of a solid 
field of stitching. You can select patterns, adjust 
settings, or change layouts at any time before or after 
digitizing. See also Applying Step patterns.

Select Contour

Adjust stitch 
settings as desired

Use Fill (Stitch and Color Bar) to select a fill stitch 
type before or after digitizing.

Stitch length: smaller Stitch length: larger

Stitch spacing: smaller Stitch spacing: larger
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Tip  You can also create artistic stitch effects with 
craft stitch and pattern fills. See Creating craft stitch 
fills and Creating pattern fills.

Tip  The Carving Stamp feature allows you to define 
a pattern of needle penetrations using a ‘carving 
stamp’ as a template. See Creating stitch patterns 
with carving stamps for details.

To create a fancy fill

1 Click the Fill icon and choose Fancy from the 
dropdown menu.

Tip  You can digitize the shape before or after 
selecting the fill.

2 Create closed-object/s – circle or square – and 
select. See Digitizing Methods for details.

The current Fancy Fill settings are applied to the 
selected object.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object/s.

The Object Properties > Fill Stitch dialog 
opens.

4 Select a pattern from the dropdown list. See also 
Fancy Fill Samples.

The selected pattern is displayed in the preview 
panel.

5 Change pattern layout by adjusting settings in the 
dialog or on-screen via the Layout button.

By default, Grid is selected. Techniques for 
adjusting pattern layout are the same as for 
pattern fills. See Laying out pattern fills 
on-screen for details.

For turning patterns, choose Sculpture. See 
also Creating Sculptured Fancy fills.

6 Click Apply to preview the effect or OK to finish 
and close.

The stitch is regenerated with the adjusted 
settings.

Tip  Wave Effect lets you contour fill stitches 
along a digitized guideline. Wave Effect can be 

Select Fancy

Click to select 
pattern

Preview 
displayed

Choose 
layout 
option

Grid layout Sculpture layout
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applied to Fancy Fill objects. However, you need to 
first apply the effect to a Step fill before converting 
to a Fancy Fill. See also Creating wave effects.

Creating cross stitch fills

Cross Stitch fill is a stitch type in its own right but 
does not replace the BERNINA Cross Stitch 
application available from the Digitize toolbar. It is 
something like Pattern Fill but it is generated 
differently and uses travel runs under and along the 
cross stitching. Crosses are horizontal to suit a global 
or standard grid for the whole design. See also 
Creating pattern fills.

Tip  You can also create artistic stitch effects with 
craft stitch and pattern fills. See Creating craft stitch 
fills and Creating pattern fills.

To create a cross stitch fill

1 Click the Fill icon and choose Cross Stitch from 
the dropdown menu.

Tip  You can digitize the shape before or after 
selecting the fill.

2 Create closed-object/s – circle or square – and 
select. See Digitizing Methods for details.

The current Cross Stitch settings are applied to 
the selected object.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object/s.

The Object Properties > Fill Stitch dialog 
opens.

Use Fill (Stitch and Color Bar) to select a fill stitch 
type before or after digitizing.

Wave Effect 
applied

Fancy Fill 
selected

Step stitch used

Select Cross 
Stitch

Cross Stitch 
settings
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4 Adjust cross stitch settings as desired:

5 Click Apply to preview the effect or OK to finish 
and close.

Tip  The cross stitch grid is not displayed but you 
can set the background grid to the cross size to get 
a better idea of how the grid is used to generate 
the crosses. Use Snap to Grid to ensure that your 
object outlines line up with the cross stitch grid. 
See Setting grid options for details.

Creating textured edges

Use Textured Edge to 
add rough edges to 
objects, create shading 
effects, or imitate fur or 
other fluffy textures in 
your design. Textured 
Edge is applied based 
on current settings in 
the Effects dialog. 
Adjust settings to 

change the degree of roughness, the side of the 
object to which the effect is applied and the textured 
edge margin. You can change these settings before or 
after digitizing.

To create a textured edge

1 Click the Textured Edge icon.

The effect will be applied to new or selected 
objects based on current settings.

Tip  To modify current settings, right-click the 
Textured Edge icon to access Effects dialog with 
no objects selected. Adjust the settings as 
described below.

2 Create closed-object/s – circle or square – and 
select. See Digitizing Methods for details.

The current Textured Edge settings are applied to 
the selected object.

3 To change settings, right-click the Textured Edge 
icon with the object selected.

The Effects > Textured Edge dialog opens.

4 Use the buttons to choose the side of the object 
you want to apply the effect to.

Field Description

Fabric Count Controls the size of cross specified as a 
counted fabric rather than an actual 
cross size.

Threads Number of times – 2, 4 or 6 – thread 
passes over the same cross in order to 
make it bulkier.

Stitch Style Full cross (X), diagonal, or upright (+).

Floss Direction Controls which way top leg of the cross 
– i.e. full length stitch – is directed – for-
ward or backward for diagonal full 
crosses and horizontal or vertical for 
upright full crosses.

Use Textured Edge (General toolbar) to create rough 
edges and shading effects, or to imitate fluffy tex-
tures. 

Stitch Style: Upright Cross Stitch Style: Full Cross

Adjust values

Select settings

Left side 
textured

Both sides 
textured

Right side 
textured
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5 Use the Texture slider to select the degree of 
texture – left for a rougher texture and right for a 
smoother texture.

6 Use the Span slider to select a stitch range in 
which you want the stitches to fall.

Move the slider to the left for a short range and to 
the right for a longer range.

7 Click Apply to preview the effect or OK to finish 
and close.

The stitch is regenerated with the adjusted 
settings.

Tip  To better view the Textured Edge effect, 
press the . key to display needle points or use 
Artistic View.

Creating wave effects

Wave Effect lets you contour fill stitches along a 
digitized guideline. Stitches follow the line but 
maintain uniform density and needle penetration 
patterns.

Wave Effect can be applied to closed-objects using 
Step, Fancy Fill, Pattern Fill or some of the craft stitch 
types.

Tip  Use smaller stitch lengths – e.g. 4.00 mm or less 
– for best results.

To create Wave Effect

1 Double-click or right-click a selected 
closed-object.

The Object Properties > Fill Stitch dialog 
opens.

2 Click the Effects button and select the Star & 
Wave Fill tab.

3 Select the Wave Effect checkbox and click Apply.

The effect is applied to the selected object.

4 To modify the effect, select the object and click the 
Reshape Object icon.

5 Click and drag the curve into the required shape 
and press Enter. See Reshaping objects for 
details.

6 Press Esc to finish.

More variation 
in stitch length 
gives a rougher 
texture

Less variation in
stitch length

gives a smoother
texture

Shorter 
range

Longer
range

Select Wave 
Effect
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Tip  Wave Effect can be applied together with 
Fancy Fill, Pattern Fill and some of the craft 
stitch types. See also Creating fancy fills, Creating 
pattern fills, and Creating craft stitch fills.

Tip  Don’t alter stitch angles after applying Wave 
Effect as it can displace Fancy Fill patterns.

Creating star fill effects

Star Fill generates radial turning stitching in several 
stitch types such as Satin and Tatami stitch. Stitches 
are generated from the outside edge to the geometric 
center. 

Star Fill is applicable to several object shapes – 
closed, circle and rectangle – with optional holes. The 
effect may be on or off while digitizing. All 
transformations, excepting morphing effects, 
preserve the Star Fill radial stitching but transform 
the hole shape. Shaping operations such as Mirror 
Merge or Remove Overlaps preserve Star Fill 
effect.

Tips for use

Not all patterns and stitch settings or objects (size 
specific) are suitable for Star Fill. In particular, if you 
are using it with larger objects, use one or a 
combination of the following to avoid bunching at the 
center:

Increase the size of the hole, move the center into 
an existing hole in the object, or move it outside 
the object altogether.

Add Textured Edge to the inside.

Use larger stitch spacing – increase by about 20%.

Avoid patterns which add needle penetrations 
close to the center of the object.

Use Edge Walk underlay with smaller objects, to 
help reduce the number of stitches at the object 
center.

For fewer problems and a better embroidery 
result, use an SUK or H/E embroidery needle.

Tip  For best effect, use Star Fill with ring shapes. 
The size of ring should be about 20% of the outer 
diameter.

To create star fill effects

1 Double-click or right-click a selected 
closed-object.

The Object Properties > Fill Stitch dialog 
opens.

2 Click the Effects button and select the Star & 
Wave Fill tab.

3 Select the Star Fill checkbox and click Apply.

The effect is applied to the selected object.

4 To modify the effect, select the object and click the 
Reshape Object icon. In Reshape mode, you 
can:

Move the center point of the radial stitching.

Set the size of the center hole.

Wave Effect with 
Candlewicking Fill

Wave Effect with 
Blackwork Fill

Select Star 
Fill effect
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Edit the center hole shape as for a circle/ellipse 
object.

Tip  Unlike Ripple stitch, the center of Star Fill 
effect can be moved outside the shape or into an 
included hole to achieve a different effect, without 
loosing the original object shape. When you move 
the center marker outside the shape, the center 
hole is removed but the radial stitching is 
preserved around the new center position.

5 Press Enter to apply, Esc to finish.

Tip  Star Fill can be applied together with Satin 
Fill, Step Fill, and Fancy Fill. See also Creating 
fancy fills.

Tip  You are not able to directly edit the stitch 
angles automatically generated by Star Fill effect. 
However, you can apply Break Apart to an object 
with Star Fill effect and edit the resulting turning 
angle closed object. See also Splitting into 
component objects.

Creating gradient fills

Gradient Fill varies 
stitch spacing between 
dense and open fill, 
producing perspective 
and shading effects 
which are difficult to 
achieve manually. A 
number of different 
Gradient Fill effects 
are available. When you 
use Gradient Fill, the 
current stitch spacing 
settings are ignored. 
However, other stitch 
effects will still apply.

Tip  You can use Gradient Fill with Step fill to create 
interesting shading effects.

To create a gradient fill

1 Double-click or right-click a filled object.

The Object Properties > Fill Stitch dialog 
opens.

2 Click the Effects button and select the Gradient 
Fill tab.

3 Select the Gradient Fill checkbox and choose a 
profile.

4 Click Apply to preview the effect.

5 Move the slider to adjust the values or enter new 
spacing values as required.

Star Fill with Fancy FillStar Fill with Satin Fill

Select
Gradient Fill

Adjust spacing
values
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6 Click Apply to preview the effect or OK to finish 
and close.

Tip  To prevent underlay stitching from showing 
through, deselect the Underlay checkbox. See 
also Stabilizing with underlays. See also Creating 
open fills.

Creating open fills

Apply Travel on Edges effect to force underlying 
travel runs to the edges of an object so that they can’t 
be seen through open stitching. This is often used for 
backgrounds.

Tip  Use Travel on Edges effect with the Gradient 
Fill or Color Blending effect to eliminate travel 
stitches inside graded embroidery objects. See also 
Creating gradient fills and Creating color blending 
effects.

To create an open fill

1 Double-click or right-click a filled object.

The Object Properties > Fill Stitch dialog 
opens.

2 Click the Effects button and select the Others 
tab.

3 Select the Travel on Edges checkbox.

Travel runs and overlapping rows are removed, 
and consistent row spacing is applied.

4 Click Apply to preview the effect or OK to finish 
and close.

Travel on Edges is applied to the selected object.

Tip  Click Save To Template before closing this 
dialog to save settings permanently. Saved 
settings will be applied to all new designs based on 
the current template. See Object Properties & 
Templates for details.

Creating color blending effects

Use the Color Blending effect to create different 
shading, perspective, three-dimensional and color 
effects by blending two colored layers in an 
embroidery object. The effect is created by 
duplicating the object, then applying Gradient Fill and 

Max spacing: 2 mm Max spacing: 4 mm

Use Color Blending (Edit toolbar) to create shading 
and perspective effects.

Select Travel
on Edges
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Travel on Edges to both layers, which are then 
grouped. 

There are two different Color Blending effects: 

linear stitch spacing

curved stitch spacing.

Color Blending can be applied to objects filled with 
Satin, Step, or Fancy Fill stitch, or objects outlined 
with Satin or Blanket stitch.

Applying Color Blending

Use the Color Blending effect to create color blends, 
perspective effects and shading.

To apply Color Blending

1 Select a filled object.

2 Click the Color Blending icon.

The Color Blending dialog opens.

3 In the Profiles panel, select a spacing profile for 
top and bottom layers.

4 In the Bottom Layer panel:

Select the color of the first layer.

Adjust the maximum spacing value for the first 
layer as required.

5 In the Top Layer panel:

Select the color of the second layer.

Adjust the maximum spacing value for the 
second layer as required.

6 Click OK.

Tip  To prevent underlay stitching from showing 
through, deselect the Underlay checkbox. See 
also Stabilizing with underlays.

Editing color-blended objects

Use Color Blending (Edit toolbar) to apply the effect 
to new or selected objects.

Maximum 
spacing

Minimum
spacing

s

Click Ungroup (Arrange toolbar) to ungroup selected 
objects.

Select spacing
effect

Select first color

Select second
color

Bottom Layer: Profile1
Top Layer: Profile1

Bottom Layer: Profile3
Top Layer: Profile3

Bottom Layer: Red
Top Layer: Yellow

Bottom Layer: Yellow
Top Layer: Red
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Editing a Color Blending object is limited. The two 
objects must first be ungrouped and the separate 
objects edited according to Gradient Fill settings. 
See Creating gradient fills for details.

Note  If you edit a grouped object the Color Blending 
effect will be lost as both layers will have the same 
settings.

To edit color-blended objects

1 Select the blended object and ungroup it. See 
Grouping and splitting objects for details.

Tip  Use the Color Film to view all color blocks and 
objects in the design. See Viewing and selecting 
color blocks for details.

2 Select one of the objects and change the color as 
required.

3 Double-click or right-click it to open the Object 
Properties dialog, click the Effects button, and 
select the Gradient Fill tab.

4 Select a profile.

5 Adjust spacing settings as required. See Creating 
gradient fills for details.

6 Click Apply to preview the effect or OK to finish 
and close.

7 Repeat the process for the second object and 
re-group the objects.

Creating morphing effects

The Morphing feature allows you to transform object 
outlines and stitches in a variety of novel and 
interesting ways. They are additive in the sense that 
more than one effect can be applied to a given 
selection.

Tip  Morphing is a powerful feature but don’t overdo 
it. Keep in mind the following points when morphing 
objects/designs:

To avoid poor quality embroidery, don’t use too 
much of the effect. Less is more when it comes to 
morphing.

Use larger stitch spacing – increase it by about 
20%.

Avoid morphing Satin stitches – in some objects 
they become too long.

Increase the underlay margin to avoid it projecting 
outside the cover stitch.

To create morphing effects

1 Select one or more objects.

Click Color Film (General toolbar) to view all color 
blocks and objects in a design.

Select
Gradient Fill

Adjust maximum
spacing

Use General > Morphing to create transformed 
object outlines and stitches.
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Any object/s can have morphing effects applied.

2 Click the Morphing icon on the General toolbar.

The Morphing Effect docker opens with all 
morphing effect buttons enabled.

3 Choose a morphing effect:

The selected morphing effect is applied to the 
current selection with the morphing center (if any) 
defaulting to the center of the current selection.

BERNINA Embroidery Software also does the 
following:

Groups selected objects if they were not 
already grouped.

Applies the morphing effect to selected objects 
as a whole, using the default morphing center 
and current parameters.

Activates the Reshape Object tool for the 
resultant objects.

Displays the available morphing graphical 
controls for the selected morphing effect.

4 Optionally, click the Undo button to undo the 
morphing transformation, or click and drag the 
available morphing controls to adjust the effect.

If you drag one of sliders, the resultant object 
outlines display dynamically in black until the 
mouse button is released.

5 Optionally, if available, adjust the morphing center 
using the Reshape Object tool. (Not all morphing 
effects have a moveable center.)

The Center Morphing button in the Morphing 
Effect docker is enabled when the morphing 

Use Pinch to pinch the object outlines and stitches 
together in the morphing center, while pulling outer 
stitches away from each other.
Use Punch to punch the object outlines and stitches 
away from the morphing center, while stretching the 
object outlines and stitches around an imaginary 
sphere.
Use Ripple to apply a wave pattern radiating from the 
morphing center, like dropping a stone into a pond.
Use Twirl to twist the object outlines and stitches 
around the morphing center, creating a swirling effect 
like a whirlpool.
Use Skew Horizontal to slant the object outlines and 
stitches horizontally to the left or right.

Use Skew Vertical to slant the object outlines and 
stitches vertically up or down.

Punch

Twirl

Skew Vertical

Wave Vertical

Pinch

Ripple

Skew
Horizontal

Wave
Horizontal

Use Wave Horizontal to move the object outlines and 
stitches to follow a horizontal wave pattern

Use Wave Vertical to move the object outlines and 
stitches to follow a vertical wave pattern.
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center is moved away from the center of the 
current selection. Clicking it causes the morphing 
center to be moved back to the center of the 
current selection.

6 Apply as many effects to the current selection as 
desired.

7 Optionally, remove one or more morphing effect/s 
by the following means:

The Remove button is enabled if the current 
selection has one or more morphing effects 
applying. Clicking it causes the last-applied 
morphing effect to be deleted. The previous 
morphing effect (if any) becomes immediately 
available for reshape or removal.

Clicking the enabled Remove All button 
causes all morphing effects to be removed from 
the current selection and the Reshape process 
to be stopped.

Center moved to 
the left
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CHAPTER 22
PATTERNED STAMPS, RUNS & FILLS

Patterns are pre-defined design elements, 
such as hearts, leaves or border patterns, 
that can be quickly inserted into a design. 
They generally consist of one or more 
simple objects, and are stored in a special 
pattern set.

Use the patterns provided with the 
software or create your own. Patterns can 
be scaled, rotated and mirrored in the 
same way as other objects. You can use 
patterns along a digitized line. You can 
also fill shapes with rows of repeated 
patterns, and apply special effects.

You can also define a pattern of needle 
penetrations using a ‘carving stamp’ as a 
template. A carving stamp can be any 
vector and/or embroidery shape or 
shapes.

This section describes how to insert patterns into your design, and how to adjust 
their settings to get the results you want. It also explains how to create your own 
patterns and pattern sets as well as how to create stitch patterns with carving 
stamps.

Adding pattern stamps

The Pattern Stamp feature allows you to place 
single patterns anywhere in the Design Window. You 
can access any pattern in any ‘pattern set’. These 
include purpose-made Pattern Fill patterns as well as 
craft stitch patterns and monogramming ornaments.

To add a pattern stamp

1 Select Arrange > Pattern Stamp.

The Select Pattern dialog opens.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

Select Pattern Stamp (Arrange menu) to place single pat-
terns in designs.

Select
pattern set

Select
pattern

Select viewing mode
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2 Select a pattern set from the dropdown list and 
select a pattern from the display panel.

This becomes the current pattern. See also Pattern 
Stamp, Run & Fill Samples.

3 Click OK.

The dialog closes and the pattern appears 
attached to the mouse pointer.

4 Move the pointer to the desired position and click 
to mark the guide point.

This becomes the rotating anchor point. You are 
prompted to place the second guide point. 

5 Move the pointer until the pattern is orientated 
correctly, then click again for a guide point.

Tip  You can resize the pattern on screen by 
holding down the Shift key before marking the 
second guide point.

6 Press Enter.

Stitches generate.

7 Repeat the step to insert another pattern.

You can rotate and scale patterns as you insert 
them.

Tip  Right-click to mirror the pattern.

8 Press Esc to finish.

Note  Each pattern is treated as a single grouped 
object. To edit only a section of a pattern, ungroup 
it first. See Grouping and splitting objects for 
details.

Creating pattern outlines

Pattern Run is a stitch type that creates pattern 
repeats along a digitized line. You can create 
decorative outlines using any pattern from the 
selection list. You can modify the rotation angle, 
orientation and scale, and vary the space between 
patterns.

Applying pattern runs

Select the pattern to use in the pattern run before or 
after digitizing.

Insert anchor point Insert guide point
(resized and rotated)

o

Use Outline (Stitch and Color Bar) to digitize 
an outline of Pattern Run stitching.
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To apply a pattern run

1 Click the Outline icon on the Stitch and Color 
Bar and choose Pattern Run from the dropdown 
menu. See also Selecting or changing stitches.

Tip  You can digitize the shape before or after 
selecting Pattern Run.

2 Digitize an outline for the run to follow. See 
Digitizing Methods for details.

Note  The outline is created with default stitch 
settings. These can be adjusted before or after 
digitizing via Object Properties.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Outline Stitch dialog 
opens.

4 If not already selected, select Pattern Run from 
the Stitch Type list and click Select.

The Select Pattern dialog opens showing all 
available patterns in the current set.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

5 Select a pattern set from the dropdown list and 
select a pattern from the display panel. See also 
Pattern Stamp, Run & Fill Samples.

6 Click OK.

7 Adjust pattern run settings. See Adjusting pattern 
run settings for details.

8 Click Apply.

The digitized object is outlined with the selected 
pattern run. See also Reshaping pattern runs.

Tip  If the pattern run does not pick up the color 
you have selected in the color palette when first 
digitized, select the outline after digitizing, then 
select a color.

Adjusting pattern run settings
You can insert a pattern run at its original size and 
orientation, and then adjust settings later. You can 
also set the exact size and spacing before you insert 
the pattern run. Spacing is the distance between each 
pattern repetition. See Applying pattern runs for 
details.

Select Pattern Run

Select Pattern 
Run
Click to select 
pattern

Select
pattern set

Select
pattern

Select viewing mode

Adjust pattern
run settings

Spacing increased

Initial spacing
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If they do not fit the baseline exactly, BERNINA 
Embroidery Software adjusts the spacing to make 
them fit:

If the space remaining at the end of the baseline is 
less than half a pattern, the extra space is spread 
evenly between the patterns. 

If the space is larger than half a pattern, BERNINA 
Embroidery Software inserts an extra pattern, and 
slightly overlaps the patterns to distribute them 
evenly along the baseline.

Tip  You can reshape the baseline to achieve the exact 
spacing you require. See Reshaping pattern runs for 
details.

To adjust pattern run settings

1 Select the pattern run object. 

2 Double-click or right-click the object.

The Object Properties > Outline Stitch dialog 
displays.

3 Enter the pattern size in the Size field.

4 Adjust the Spacing.

5 Click Apply.

Tip  You can also resize pattern runs using the 
selection handles. See Scaling objects for details.

Creating pattern fills

Pattern Fill is a decorative stitch used for filling closed 
objects. Patterns are repeated in parallel rows to fill a 
shape. You can design the pattern layout on-screen or 
by adjusting object properties.

Note  You can also create artistic stitch effects with 
craft stitches and fancy fills. See Creating craft stitch 
fills and Creating fancy fills.

Adding pattern fills

Use Pattern Fill with filled objects to create 
decorative fill stitching. Current values are set in the 
Fill Stitch tab of the Object Properties dialog. You 
can select patterns, adjust settings, or change layouts 
at any time before or after digitizing.

To add a pattern fill

1 Click the Fill icon and choose Pattern Fill from 
the dropdown menu.

Adjust
pattern size
and spacing

Default sizeSize increased Size decreased

Default spacingSpacing decreased Spacing increased

Use Fill (Stitch and Color Bar) to select a fill stitch 
type before or after digitizing.

Select Pattern Fill
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Tip  You can digitize the shape before or after 
selecting Pattern Fill.

2 Create a closed shape and select. See Digitizing 
Methods for details.

Tip  If the pattern fill does not pick up the color 
you have selected in the color palette when first 
digitized, select the outline after digitizing, then 
select a color.

3 To change settings, double-click or right-click the 
object/s.

The Object Properties > Fill Stitch dialog 
opens.

4 If not already applied, select Pattern Fill from the 
Stitch Type list and click Select.

The Select Pattern dialog opens showing all 
available patterns in the current set.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

5 Select a pattern set from the dropdown list and 
select a pattern from the display panel. See also 
Pattern Stamp, Run & Fill Samples.

6 Click OK.

The selected pattern is displayed in the preview 
panel.

7 Adjust pattern layout by changing settings or 
on-screen. See Adjusting pattern fill settings or 
Laying out pattern fills on-screen.

Note  Stitch angle has no effect on the pattern 
layout.

8 Click Apply.

The digitized object is filled with the selected 
Pattern Fill.

Tip  Wave Effect lets you contour fill stitches along 
a digitized guideline. Wave Effect can be applied to 
Pattern Fill objects. However, you need to first 
apply the effect to a Step fill before converting to 
a Pattern Fill. See also Creating wave effects.

Adjusting pattern fill settings
You can insert a pattern fill at its original size and 
orientation, and then adjust settings later. You can 
also set the exact size and spacing as you insert the 
pattern fill. Spacing is the distance between each 
pattern repetition. See also Adding pattern fills.

Click to select 
pattern

Select
pattern set

Select
pattern

Select viewing mode

Preview 
displayed

Wave Effect 
applied

Pattern Fill 
selected

Step stitch used
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To adjust pattern fill settings

1 Double-click or right-click a pattern fill object.

The Object Properties > Fill Stitch dialog opens 
with the current pattern in the preview panel.

2 Change the current fill pattern as required. See 
Adding pattern fills for details.

3 Adjust Size X, Size Y, Column Spacing, Row 
Spacing settings as required.

4 Adjust Row Offset as required (from -99.99mm 
to 99.99mm).

5 Adjust Rotation Angle as required (from -180° to 
+180°).

This field sets the current rotation angle of the fill 
pattern (default is zero), and defines the 
orientation of the entire pattern fill.

6 Click Apply.

The digitized object is filled with the selected 
pattern fill, current settings applying.

Note  If more than half a pattern is outside the 
boundary, it will be clipped along the boundary.

Laying out pattern fills on-screen

You lay out pattern fills on-screen by using 
‘guide-patterns’ to scale, space, transform and offset 
the entire pattern fill. There are three blue 
guide-patterns. Other sample patterns appear in 
yellow. Each guide-pattern lets you change different 
elements of the layout. When you change a 
guide-pattern, all patterns in the fill change 
accordingly. 

Tip  You can also use this method to adjust the layout 
of Blackwork Fill, Candlewicking Fill and 
Lacework.

Tip  Generally you define the layout of the fill before 
digitizing the object. If it is important to align the 
patterns with the object boundary, digitize the object 
using the current settings, and change the layout 
afterwards.

To lay out pattern fills on-screen

1 Double-click or right-click a pattern fill object.

The Object Properties > Fill Stitch dialog 
opens.

2 Click Layout.

The Object Properties dialog temporarily closes 
allowing you to see and edit the layout guides. 

Preview 
displayed

X: 12, Col Sp: 12
Y: 12, Rw Sp: 12

X: 9, Col Sp: 12
Y: 9, Rw Sp: 12

X: 9, Col Sp: 9
Y: 9, Rw Sp: 9

Row offset: 0.00 Row offset: 2.00 Row offset: 5.00

Rotation angle: 0° Rotation angle: 15° Rotation angle: 45°

Use top guide-pattern to change row spacing, 
row offset, and to scale all patterns

Use side guide-pattern to change column 
spacing, and to scale all patterns

Use middle guide-pattern to move, 
rotate, skew, and scale all patterns

Click to adjust pattern layout



Chapter 22 : Patterned Stamps, Runs & Fills

BERNINA® Embroidery Software : Onscreen Manual 184

Yellow sample and blue guide-patterns appear in 
the Design Window. When you change a 
guide-pattern, all patterns in the fill change 
accordingly.

Tip  Zoom in to select the correct guide-pattern.

3 Adjust the guide-patterns to achieve the effect you 
require.

Move patterns by selecting the middle 
guide-pattern and dragging it to a new position.

Scale patterns by selecting a guide-pattern 
and resizing it using the selection handles.

Rotate patterns by clicking the middle guide 
twice to display the rotation handles. Click a 
corner handle and drag to rotate. 

Skew patterns by clicking the middle guide 
twice, then dragging the skew handles. 

Change column spacing by selecting the side 
guide and dragging it left or right.

Change row spacing by selecting the top 
guide and dragging it up or down. 

Change row offset by selecting the top guide 
and dragging it left or right. Changing the offset 
distorts the rows.

4 Press Enter to finish.

The Object Properties dialog re-opens allowing 
you to apply any other settings. The adjusted size 
and layout are applied to the selected object and 
become the current Pattern Fill settings.

Managing patterns

BERNINA Embroidery Software provides various ways 
to manage your patterns including making pattern 
sets, saving patterns, and deleting patterns.

Saving your own patterns
The Create Pattern function lets you save your own 
patterns for future use. Store them in your own or an 
existing pattern set. They can be used in pattern fills 
or runs, or even as pattern stamps.

To save a pattern

1 Select the embroidery object/s you want to save.

Tip  To create objects with holes, see Cutting holes 
and removing overlaps for details.

2 Select Settings > Create Pattern.

The Make Pattern dialog opens.

3 Select a pattern set from the dropdown list.

Scale 
proportionally

Scale 
horizontally

Scale 
vertically

Rotate

Skew

Anchor

Change 
column 
spacing

Change 
row 
spacing
Change 
offset

Enter name for
new pattern

Select pattern
set

My Pattern Set

Smiley



Chapter 22 : Patterned Stamps, Runs & Fills

BERNINA® Embroidery Software : Onscreen Manual 185

Note  Choose the pattern set carefully so you 
remember where you have stored your patterns. 
See also Creating your own pattern sets.

4 Enter a name for your new pattern.

5 Click OK.

You are prompted to digitize reference points.

6 Click to mark two reference points for the pattern.

These determine the default pattern orientation.

Reference points also determine default pattern 
spacing.

7 A confirmation message appears.

8 Click OK.

Tip  Test your new pattern. See Adding pattern 
stamps, Creating pattern outlines, and Creating 
pattern fills.

Creating your own pattern sets

The Create Pattern function lets you create your 
own pattern sets to organize and classify your 
patterns.

To create your own pattern set

1 Select the object/s you want to save as a pattern. 
See Saving your own patterns for details.

2 Select Settings > Create Pattern.

The Make Pattern dialog opens.

3 Click New Set.

The New Pattern Set dialog opens.

4 Enter a name for the new pattern set and click OK.

The Pattern Set is ready for use.

Note  Pattern sets are stored in the 
C:\..\Program Files\BERNINA\Embroidery 
Software 6\Userletw folder. 

Deleting patterns

Delete any patterns you no longer want from a 
pattern set. You can only delete your own patterns.

To delete a pattern

1 Click Object Properties icon.

2 Select Pattern Run from Outline Stitch tab or 
Pattern Fill from the Fill Stitch tab.

3 Click Select.Use Create Pattern (Settings menu) to create your own pat-
tern set.

1 2

1

2

1

2

1 2

1 2

Click Object Properties (General toolbar) to delete 
patterns.

Click New Set to create 
new pattern set

Enter name for
pattern set

My pattern set

Select Pattern 
Run
Click to delete 
pattern
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The Select Pattern dialog opens showing all 
available patterns in the current set.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

4 Select the pattern set you saved your pattern/s to.

5 Select the pattern you want to remove and click 
Delete.

A confirmation message appears.

6 Click OK.

Creating stitch patterns with carving 
stamps

The Carving Stamp feature allows you to define a 
pattern of needle penetrations using a ‘carving stamp’ 
as a template. A carving stamp can be any vector 
and/or embroidery shape or shapes. A needle 
penetration is placed wherever a stitch intersects with 
the vector or embroidery shape.

With the Carving Stamp feature, you can:

Apply pre-defined or temporarily-selected or 
-digitized carving stamps to applicable objects.

Move/rotate/scale/reshape/delete carving stamps 
associated with an applicable object while in 
Reshape mode.

Create and manage your own user-defined carving 
stamps in a pattern library for future reference.

Selected carving stamps can be applied to outline 
objects with Satin stitch type, and closed objects with 
Satin/Step/Fancy stitch type.

Applying pre-defined patterns

The Carving Stamp docker contains four tabs: Use 
Pattern, Use Object, Digitize, and Appearance. The 
Use Pattern tab lets you select and apply 
pre-defined stamp patterns to selected applicable 
objects only or to any applicable objects if nothing is 
selected.

To apply pre-defined patterns

1 Select an embroidery object or not as required.

Note  You can start with or without embroidery 
objects selected. If one or more objects is 
selected, stamps are only applied to selected 
objects. If no object is pre-selected, stamps can be 
applied to any objects.

2 Click the Carving Stamp icon.

My pattern set

Select pattern
to delete

Select
pattern set

Click to delete

Use General > Carving Stamp to define a pattern of 
needle penetrations using a ‘carving stamp’ as a tem-
plate.
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the Carving Stamp dialog opens. The Use 
Pattern tab is open by default.

3 Select a pattern set from the Set list – e.g. 
‘Nature’.

The Set dropdown list contains pre-defined 
pattern sets as well as user-defined stamp pattern 
sets. See Pattern set: Carving Stamps for details.

4 Select a pre-defined stamp pattern.

A thumbnail appears in the preview panel and the 
Use Stamp button is enabled.

5 Click the enabled Use Stamp button and move 
the mouse pointer to the Design Window. 

The pre-defined stamp is attached to the mouse 
pointer. You are prompted in the Status Bar to 
enter an anchor point.

6 Move the mouse pointer to the desired position 
over the target object/s.

Right-click to mirror the stamp.

Press Shift to prevent Auto Scroll.

7 Click the mouse button to fix the anchor point.

You are prompted to enter the guide point.

8 Swivel the pattern about the anchor point to the 
desired guide point position, optionally with the 
Shift key pressed.

BERNINA Embroidery Software resizes the stamp 
if the Shift key is pressed while moving the mouse 
pointer. 

9 Click the mouse button.

If you have pre-selected an object or objects, 
the stamp pattern is only applied to those 
objects, whether or not the pattern extends 
beyond the object borders.

If no objects are pre-selected, the stamp 
pattern is applied to any applicable underlying 
objects.

Note  If there are multiple overlapping objects in 
the area in which the stamp is applied, the stamp 
is applied to every overlapping applicable object.

10 Repeat as many times as necessary. Press Esc to 
proceed.

Note  The Rename and Delete buttons are 
enabled whenever a user-defined stamp pattern is 
selected. When the Rename button is clicked, the 
Rename Stamp Pattern dialog opens. Use it to 

Select a pattern 
set

Select a stamp 
to use



Chapter 22 : Patterned Stamps, Runs & Fills

BERNINA® Embroidery Software : Onscreen Manual 188

rename user-defined stamp patterns. See also 
Adding stamps to a library.

Tip  Use the Softened Stamp and Raised Stamp 
options on the Appearance tab to soften or 
accentuate the effect. See Changing carving 
stamp appearance for details.

Using objects as carving stamps
The Carving Stamp docker contains four tabs: Use 
Pattern, Use Object, Digitize, and Appearance. The 
Use Object tab allows you to select object outlines 
from the Design Window and apply them directly as 
stamps or save them to a library for future reference.

To use an object as a carving stamp

1 Select an embroidery object or not as required.

You can start with or without embroidery objects 
selected to be used as stamps.

2 Click the Carving Stamp icon and select the Use 
Object tab.

3 Click the Start Selecting button.

Any pre-selected objects remain selected.

4 Hover the mouse over any object in the Design 
Window.

The object outline is highlighted.

Select object outlines to include in the stamp 
using any existing selection methods. The 
selected outlines appear in the preview panel.

Deselect at any time by pressing the Esc key.

Tip  Selectable objects can include vectors from 
Art Canvas. This is the only time vectors can be 
selected in the Embroidery Canvas. 

5 Click the Use Stamp button to apply the selection 
as a carving stamp. See Applying pre-defined 
patterns for details.

6 Optionally, click the Add to Library button to add 
the selection to the library for future reference. 
See Adding stamps to a library for details.

Tip  Use the Softened Stamp and Raised Stamp 
options on the Appearance tab to soften or 
accentuate the effect. See Changing carving 
stamp appearance for details.

Digitizing carving stamps
The Carving Stamp docker contains four tabs: Use 
Pattern, Use Object, Digitize, and Appearance. The 
Digitize tab allows you to digitize stamp outlines and 
either directly apply the digitized stamp where it was 

Select Use 
Object tab



Chapter 22 : Patterned Stamps, Runs & Fills

BERNINA® Embroidery Software : Onscreen Manual 189

digitized, or apply it to applicable objects in the 
Design Window.

To digitize carving stamps

1 Select an embroidery object or not as required.

If embroidery objects are pre-selected, digitized 
stamps will apply only to these objects.

2 Click the Carving Stamp icon and select the 
Digitize tab of the dialog.

3 Click the Start Digitizing button.

You are prompted to enter a starting point for the 
stamp outline.

4 Digitize stamp outlines:

Press Enter once to complete a boundary.

Press Enter again to finish stamp digitizing.

5 Click the enabled Stamp button.

Click the Stamp button to apply the stamp to 
selected applicable objects only.

Alternatively, use Stamp to apply the stamp to 
applicable objects with no object/s selected.

Click the Use Stamp button to position the 
stamp. You are prompted to enter an anchor 

Click to start 
digitizing

Stamp applied with object/s selected

Stamp applied with no object/s selected
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point as with pre-defined patterns. See 
Applying pre-defined patterns for details.

6 Optionally, click the Add to Library button to add 
the selection to the library for future reference. 
See Adding stamps to a library for details.

Changing carving stamp appearance
The Carving Stamp docker contains four tabs: Use 
Pattern, Use Object, Digitize, and Appearance. The 
Softened Stamp and Raised Stamp checkboxes 
and Clear All Stamps button in the Appearance tab 
are enabled when one or more objects with stamps 
are selected. 

To change carving stamp appearance

1 Select an embroidery object with stamps already 
applying.

2 Click the Carving Stamp icon and select the 
Appearance tab of the dialog.

3 Choose an option to modify stamp appearance as 
desired:

Checking the Softened Stamp checkbox 
causes any existing stamp/s to be softened.

Checking the Raised Stamp checkbox cause 
any splits within the combined closed 
boundaries of a carving stamp to be removed. 
Self-intersecting boundaries and overlapping 
boundaries are combined.

Note  Clicking the Clear All Stamps button will 
cause all existing stamps to be removed from 
selected objects.

Reshaping carving stamps
Carving stamps can be moved, rotated, scaled, 
reshaped, and deleted individually in Reshape mode. 
As you transform carving stamps, needle 
penetrations in the underlying object are 
automatically updated.

To reshape a carving stamp

In Reshape mode, select an embroidery object 
with carving stamps applied.Choose an 

option
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A diamond selection handle is displayed at the 
center of each stamp.

Select the diamond selection handle.

Another set of sizing, stretching and rotation 
handles appears around the stamp as shown.

Drag the diamond to move the stamp.

Tip  Holding down the Ctrl key will constrain the 
movement to the horizontal or vertical axis.

Drag one of the corner sizing handles to scale the 
stamp.

Holding down the Shift key will scale the stamp 
from the center.

Holding down the Ctrl key will scale the stamp 
proportionally. 

Holding down both Ctrl and Shift keys while 
dragging a corner sizing handle will scale the 
stamp proportionally about the center.

Drag one of the stretching handles to stretch the 
stamp.

Top and bottom stretching handles stretch the 
object vertically.

Left and right stretching handles will stretch the 
stamp horizontally. 

Holding down the Shift key will stretch the 
stamp from the center.

Drag the rotation handle to rotate the stamp.

Click the blue diamond handle to change it back 
into a green diamond handle with no nodes 
displayed.

Click the curve of the stamp to display control 
points. Use these to reshape or delete the stamp 
in the same way as for other objects.

Click a diamond 
selection handle

Drag diamond

Drag corner 
sizing handle

Drag stretching 
handle

Drag rotation 
handle
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Note  When an embroidery object with carving 
stamps is itself transformed, carving stamps are 
transformed accordingly.

Adding stamps to a library
This procedure starts when you click the enabled Add 
to Library button either on the Use Object tab or 
Digitize tab in the Carving Stamp docker.

To add a stamp to a library

1 Select an object which you want to add to the 
library as a user-defined carving stamp.

Define your own carving stamps using the 
Carving Stamp > Use Object tab. See Using 
objects as carving stamps for details.

Digitize carving stamps on the spot using the 
Carving Stamp > Digitize tab. See Digitizing 
carving stamps for details.

2 On either of these tabs, click the enabled Add to 
Library button.

The Create Stamp Pattern dialog opens.

3 Select a set from the dropdown list or click the 
New Set button to create a new library.

If you chose to create a new library set, use the 
New Stamp Set dialog to create a new stamp set. 

The newly created stamp set is displayed in the 
Set list when the Use Pattern tab is selected. 

4 Enter a new stamp name and click OK.

You are prompted to digitize the first reference 
point in the Design Window.

5 Enter the first reference point:

Press Enter to have the reference point created 
automatically.

Move the mouse pointer to the position you 
want to use as the anchor point during 
manual stamp placement, and left-click.

6 Enter the second reference point:

Press Enter to have the reference point created 
automatically.

Move the mouse pointer to the position you 
want to use as the guide point during manual 
stamp placement and left-click.

BERNINA Embroidery Software:

creates the stamp

registers the reference points either 
automatically or manually entered

replaces any same name stamp with the newly 
created stamp

displays a confirmation message.

7 Click OK.

Click to add
to library

Select library set
from dropdown list

Enter name for
new stamp

Enter name for
new library set

Enter first 
reference point

Enter second 
reference point
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The newly created stamp is displayed in the stamp 
list when the Use Pattern tab is selected.

Note  The Rename and Delete buttons are 
enabled in the Use Patterns tab whenever a 
user-defined stamp pattern is selected. When the 
Rename button is clicked, the Rename Stamp 
Pattern dialog opens. Use it to rename 
user-defined stamp patterns. See also Applying 
pre-defined patterns.
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CHAPTER 23
CRAFT STITCH BORDERS AND FILLS

BERNINA Embroidery 
Software provides a range of 
craft stitches which you can 
use to mimic some traditional 
hand-worked embroidery. 
These include a large range 
of blackwork and 
candlewicking patterns 
suitable for both outlines and 
fills. See also Craft Stitch 
Pattern Samples.

Backstitch and stemstitch are 
two versatile outline stitches. 
Backstitch forms a 
continuous thin line, similar to machine stitching, while stemstitch produces 
rope-like lines which can vary in thickness depending on stitch angle. Both can be 
used to make a smooth continuous row of stitching suitable for outlines and for 
blackwork.

Lacework and stipple are two decorative fill stitches. Lacework can be used to give 
a lacey look to objects such as flowers. Stippling, also known as vermicelli, is a 
free flowing run stitch that can be used for decorative effects or to produce 
quilting.

This section explains how to apply the various craft stitch types to outlines and 
fills, as well as change stitch settings to obtain the best results.

Creating craft stitch outlines

BERNINA Embroidery Software provides a range of 
craft stitches for use as borders. Available stitch types 
include blackwork, backstitch, stemstitch, and 
candlewicking. See also Craft Stitch Pattern Samples.

Tip  You can also create decorative stitch effects with 
pattern runs. See Creating pattern outlines for 
details.

Creating craft stitch borders

Click Outline (Stitch and Color Bar) to access 
outline stitches.

Use Blackwork Border (Craft Stitch toolbar) to digitize 
blackstitch borders.

Use Candlewicking Border (Craft Stitch toolbar) for 
candlewick borders. 

Use Backstitch (Craft Stitch toolbar) for backstitch 
borders. 
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Different stitch types suit different shapes. When you 
digitize an object, it uses the current stitch type for 
the selected digitizing method. However, you can 
change stitch types at any stage. See also Setting 
current object properties.

To create a craft stitch border

1 Select a craft stitch outline you want to use from 
the Craft Stitch toolbar.

Alternatively, click the Outline icon on the Stitch 
and Color Bar and choose a craft stitch outline 
from the dropdown menu. See also Selecting or 
changing stitches.

2 Use the Open Object, Closed Object, Circle or 
Rectangle tools to create a line for the outline to 
follow. See Digitizing Methods for details.

Note  The outline is created with default stitch 
settings. These can be adjusted before or after 
digitizing via Object Properties.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Outline Stitch dialog 
opens.

4 Adjust settings as required:

Blackwork Border: See Creating blackwork 
outlines for details.

Backstitch: See Creating backstitch outlines for 
details.

Stemstitch: See Creating stemstitch outlines 
for details.

Candlewicking Border: See Creating stemstitch 
outlines for details.

Tip  You can change between craft stitch fills and 
outlines quickly using the buttons on the Craft 
Stitch toolbar or the Outline dropdown menu. 
See also Creating craft stitch fills.

Creating blackwork outlines

Blackwork gets its name from the black silk thread 
traditionally used in this form of embroidery. Early 
designs tend to be angular, whereas later designs use 
more diagonal stitches. Blackwork employs just a few 
simple stitches to create complex designs. It can be 
used to decorate articles of dress or furnishings such 
as hankies, table napkins, tablecloths, and doilies. 
See also Creating blackwork fills.

To create a blackwork outline

1 Select Blackwork Border from the Outline 
menu or Craft Stitch toolbar. See Creating craft 
stitch borders for details.

2 Digitize a line for the outline to follow. See 
Digitizing Methods for details.

3 To change settings, double-click or right-click the 
object.

Use Stemstitch (Craft Stitch toolbar) for stemstitch 
borders. 

Select a craft 
stitch outline

Use Blackwork Border (Craft Stitch toolbar) to digitize 
blackstitch borders.
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The Object Properties > Outline Stitch dialog 
opens.

4 If not already applied, select Blackwork Border 
from the Stitch Type list.

5 Click the Select button.

The Select Pattern dialog opens.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

6 Select a pattern from the display panel.

This becomes the current pattern. See also Craft 
Stitch Pattern Samples.

7 Click Apply to preview the effect.

The selected pattern is applied to the object.

8 Adjust the pattern Size as required and click 
Apply.

9 Adjust the pattern Spacing as required and click 
Apply.

To increase stitch density, enter a smaller 
value.

To reduce density for more open stitching, 
enter a larger value.

Tip  If the border does not automatically pick up 
the color you have selected in the color palette, 
select it and re-select the color.

Creating backstitch outlines

Backstitch is an old, adaptable stitch which can be 
used as a delicate outline. This small, even stitch 
follows intricate curves well. Backstitch can be used 
for blackwork and redwork designs. You can specify 
the exact stitch length, thickness and overlap values 
as well as the number of strokes.

To create a backstitch outline

1 Select Backstitch from the Outline menu or 
Craft Stitch toolbar. See Creating craft stitch 
borders for details.

Click to change pattern

Select
pattern

Select viewing mode

Use Backstitch (Craft Stitch toolbar) to digitize back-
stitch borders. 

Size
reduced

Spacing
reduced
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2 Digitize a line for the outline to follow. See 
Digitizing Methods for details.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Outline Stitch dialog 
opens.

4 If not already applied, select Backstitch from the 
Stitch Type list.

5 Adjust the Stitch Length as required and click 
Apply.

6 Adjust the Stitch Thickness as required and click 
Apply.

7 Adjust the Overlap as required and click Apply.

8 Adjust the number of strokes as required.

Creating stemstitch outlines

Stemstitch is a detail stitch that can be used to outline 
items or fill in areas. It is used for stems and vines 
with other decorative stitches, or as an outline for 
stitches such as Satin fill or Pattern Fill. You can 
specify various settings including line thickness, 
spacing, angle, single or triple, and stitch thickness.

To create a stemstitch outline

1 Select Stemstitch from the Outline menu or 
Craft Stitch toolbar. See Creating craft stitch 
borders for details.

2 Digitize a line for the outline to follow. See 
Digitizing Methods for details.

Adjust settings

Stitch Length:
1.5 mm

Stitch Length:
3.0 mm

Stitch
Thickness:

0.15 mm

Stitch
Thickness:

0.2 5mm

Use Stemstitch (Craft Stitch toolbar) to digitize stem-
stitch borders. 

Overlap: 30% Overlap: 70%

Strokes: 3 Strokes: 5
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3 To change settings, double-click or right-click the 
object.

The Object Properties > Outline Stitch dialog 
opens.

4 If not already applied, select Stemstitch from the 
Stitch Type list. 

5 Adjust the Line Thickness as required and click 
Apply.

6 Adjust the Spacing as required and click Apply.

7 Adjust the Angle as required and click Apply.

8 Select either Single or Triple and click Apply.

9 For Triple only, enter a Stitch Thickness.

Creating candlewicking outlines

Candlewicking is a traditional white-on-white 
embroidery technique, usually done on white linen or 
cotton fabric with heavy cotton threads. Stitches used 
are mostly knots, both Colonial and French, as well as 
stemstitch. Candlewicking Border can be used for 
ornate borders. You can specify the exact size of each 
pattern as well as spacing between them. See also 
Creating candlewicking fills.

To create a candlewicking outline

1 Select Candlewicking Border from the Outline 
menu or Craft Stitch toolbar. See Creating craft 
stitch borders for details.

2 Digitize a line for the outline to follow. See 
Digitizing Methods for details.

Adjust settings

Line
Thickness:

2.0 mm

Line
Thickness:

1.0 mm

Spacing:
0.8 mm

Spacing:
1.5 mm

Angle: 90° Angle: 45°

Use Candlewicking Border (Craft Stitch toolbar) to 
digitize candlewicking outlines. 

Type: Triple Type: Single

Triple Stitch
Thickness:

0.15 mm

Triple Stitch
Thickness:

0.25 mm
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3 To change settings, double-click or right-click the 
object.

The Object Properties > Outline Stitch dialog 
opens.

4 If not already applied, select Candlewicking 
Border from the Stitch Type list. 

5 Click the Select button.

The Select Pattern dialog opens.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

6 Select a pattern from the display panel.

This becomes the current pattern. See also Craft 
Stitch Pattern Samples.

7 Click Apply to preview the effect.

The selected pattern is applied to the object.

8 Adjust the Size as required and click Apply.

9 Adjust the Spacing as required and click Apply.

Tip  If the border does not automatically pick up 
the color you have selected in the color palette, 
select it and re-select the color.

Creating craft stitch fills

BERNINA Embroidery Software provides a range of 
craft stitches for use as fills. Available stitch types 
include blackwork, candlewicking, lacework, and 
stippling. See also Craft Stitch Pattern Samples.

Tip  You can also create decorative stitch effects with 
fancy and pattern fills. See Creating fancy fills and 
Creating pattern fills.

Creating craft stitch fills

Click to change pattern

Select
pattern

Select viewing mode

Click Fill (Stitch and Color Bar) to access fill 
stitches.

Use Blackwork Fill (Craft Stitch toolbar) to fill 
blackwork designs. 

Use Candlewicking Fill (Craft Stitch toolbar) for 
special candlewick effects.

Size
reduced

Spacing
reduced
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BERNINA Embroidery Software provides four craft 
stitch fills – Blackwork Fill, Candlewicking Fill, 
Lacework and Stipple. Different stitch types are 
suited to different objects. You can select craft stitch 
fills by means of the Stitch and Color Bar or the 
dedicated Craft Stitch toolbar. See Craft Stitch 
Pattern Samples for details.

Note  Stippling is a method of creating a fill made of 
run stitches which meander around within a border. It 
works a little differently to the other craft stitch fills. 
See Creating stippling fills for details.

To create a craft stitch fill

1 Select the craft stitch fill you want to use from the 
Craft Stitch toolbar.

Alternatively, click the Fill icon on the Stitch and 
Color Bar and choose a craft stitch fill from the 
dropdown menu. See also Selecting or changing 
stitches.

Tip  You can digitize the shape before or after 
selecting the fill.

2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  The fill is created with default stitch 
settings. These can be adjusted before or after 
digitizing via Object Properties.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

Tip  You can change between craft stitch fills and 
outlines quickly using the buttons on the Craft 
Stitch toolbar or the Fill dropdown menu. See 
also Creating craft stitch borders.

4 Adjust settings as required:

Blackwork Fill: See Creating blackwork fills for 
details.

Candlewicking Fill: See Creating candlewicking 
fills for details.

Lacework: See Creating lacework fills for 
details.

Tip  Wave Effect lets you contour fill stitches along 
a digitized guideline. Wave Effect can be applied to 
some craft stitches. However, you need to first 
apply the effect to a Step fill before converting to 
a craft stitch fill. See also Creating wave effects.

Creating blackwork fills

Blackwork gets its name from the black silk thread 
traditionally used in this form of embroidery. The 
most common blackwork fills employ simple stitches 
to create complex scrolling or geometric patterns. By 
using different blackwork fill patterns, you can create 

Use Lacework (Craft Stitch toolbar) for special 
lacey effects.

Use Sculptured Fancy (Craft Stitch toolbar) to cre-
ate turning tiled patterns using pre-defined needle 
penetrations.

Use Craft Stitch (Craft Stitch toolbar) to create spi-
ral stitching from the center of any filled object.

Use Stipple Run (Craft Stitch toolbar) for special 
stippled effects.

Select a fill 
type

Use Blackwork Fill (Craft Stitch toolbar) to fill black-
work designs.

Step stitch used Wave Effect 
applied

Craft stitch 
selected
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light and dark tones in a design. See also Creating 
blackwork outlines.

To create a blackwork fill

1 Click the Blackwork Fill icon or click the Fill icon 
and choose Blackwork Fill from the dropdown 
menu. See Creating craft stitch fills for details.

2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 If not already applied, select Blackwork Fill from 
the Stitch Type list and click Select.

The Select Pattern dialog opens showing all 
available fill types.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

5 Select the desired pattern from the display panel. 
See also Craft Stitch Pattern Samples.

6 Click Apply to preview the effect.

The selected pattern is applied to the object.

7 Change pattern layout by adjusting settings in the 
dialog or on-screen via the Layout button.

Techniques for adjusting pattern layout are the 
same as for pattern fills. See Creating pattern fills 
for details.

8 Click Apply to preview the effect or OK to finish 
and close.

Note  If more than half a pattern is outside the 
boundary, it will be clipped along the boundary.

Creating candlewicking fills

Click to change 
pattern

Use Candlewicking Fill (Craft Stitch toolbar) for spe-
cial candlewick effects. 

Select
pattern

Select viewing mode
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Candlewicking is a traditional white-on-white 
embroidery technique, usually done on white linen or 
cotton fabric with heavy cotton threads. More use of 
color is becoming popular today. Stitches used are 
mostly knots, both Colonial and French, as well as 
stemstitch. Candlewicking can be used to embroider 
white bedspreads, pillows and clothing. See also 
Creating candlewicking outlines.

To create a candlewicking fill

1 Click the Candlewicking Fill icon or click the Fill 
icon and choose Candlewicking Fill from the 
dropdown menu. See Creating craft stitch fills for 
details.

2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 If not already applied, select Candlewicking Fill 
from the Stitch Type list and click Select.

The Select Pattern dialog opens showing all 
available fill types.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

5 Select the desired pattern from the display panel. 
See also Craft Stitch Pattern Samples.

6 Click Apply to preview the effect.

The selected pattern is applied to the object.

7 Change pattern layout by adjusting settings in the 
dialog or on-screen via the Layout button.

Techniques for adjusting pattern layout are the 
same as for pattern fills. See Creating pattern fills 
for details.

8 Click Apply to preview the effect or OK to finish 
and close.

Note  If more than half a pattern is outside the 
boundary, it will be clipped along the boundary.

Creating lacework fills

Lacework stitch consists of an open square trellis-like 
pattern which gives objects a lacey look. With 

Click to change 
pattern

Use Lacework (Craft Stitch toolbar) for special lacey 
effects.

Select
pattern

Select viewing mode
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Lacework fills you can adjust the layout of the preset 
patterns.

To create a lacework fill

1 Click the Lacework icon or click the Fill icon and 
choose Lacework from the dropdown menu. See 
Creating craft stitch fills for details.

2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  Stitch angle has no effect on the pattern 
layout.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 If not already applied, select Lacework from the 
Stitch Type list and click Select.

The Select Pattern dialog opens showing all 
available fill types.

Tip  Select a viewing mode – you can list patterns 
by picture, name, or both.

5 Select the desired pattern from the display panel. 
See also Craft Stitch Pattern Samples.

6 Click Apply to preview the effect.

The selected pattern is applied to the object.

7 Change pattern layout by adjusting settings in the 
dialog or on-screen via the Layout button.

Techniques for adjusting pattern layout are the 
same as for pattern fills. See Creating pattern fills 
for details.

8 Click Apply to preview the effect or OK to finish 
and close.

Note  If more than half a pattern is outside the 
boundary, it will be clipped along the boundary.

Creating Sculptured Fancy fills

Sculptured Fancy stitch is related to Fancy Fill 
stitch using needle penetrations to form a tiled 
pattern. The difference is that Sculptured Fancy 

Click to change 
pattern

Use Craft Stitch > Sculptured Fancy to create turning 
tiled patterns using pre-defined needle penetrations.

Select
pattern

Select viewing mode
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stitch can be applied to objects with turning stitches 
creating three dimensional, turning pattern effects 
which can’t be achieved by Fancy Fill alone. See also 
Creating fancy fills.

Tip  If the object you are working with does not 
contain turning stitches, you can generally add them 
with the Add Stitch Angles tool. See Adjusting stitch 
angles for details.

To create a Sculptured Fancy fill

1 Create or select a closed shape with turning 
stitching. See Digitizing Methods for details.

2 Click the Sculptured Fancy icon. See Creating 
craft stitch fills for details.

The Sculptured Fancy effect is applied using the 
current Fancy Fill pattern. See also Creating 
fancy fills.

Creating ripple fills

Ripple stitch is related to Contour stitch, providing 
a similar look (with a fixed number of lines and 
variable spacing) but spiralling out from the center of 
a filled object. This stitch type works best for ‘blobby’ 
shapes but can be applied to longer shapes. With 
longer shapes it may generate stitches that go 
outside the perimeter of the object, but this can 
provide for some interesting visual effects. See also 
Creating contour fills.

Ripple stitch can be applied to any filled object and is 
accessed from the stitch list in the Stitch and Color 
Bar and the Fill Stitch object properties tab as well 
as from the Craft Stitch toolbar. The center of the 
Ripple stitch can be moved with the Reshape 
Object tool.

To create a ripple fill

1 Click the Ripple icon or click the Fill icon and 
choose Ripple from the dropdown menu. See 
Creating craft stitch fills for details.

2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  Stitch angle has no effect on the pattern 
layout.

Use Craft Stitch > Ripple to create spiral stitching 
from the center of any filled object.
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3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 Adjust ripple Stitch Values as desired:

Adjust Stitch Length for smoother or sharper 
curves.

Adjust Stitch Spacing for denser or more 
open stitching.

5 Click Apply to preview the effect or OK to finish 
and close.

The selected settings are applied to the object.

Note  If the object has a hole, this is ignored when 
ripple is applied but still exists when other stitch 
types are applied.

Tip  Some interesting visual effects can be 
achieved by reshaping and moving the centre of 
the Ripple stitch outside the object outline.

Creating stippling fills

Stippling creates a fill made up of run stitches which 
meander within a border. There are three types: 
Stipple Run, Stipple Backstitch, and Stipple 
Stemstitch. Stippling can be applied to the same 
objects as Pattern Fill – i.e. closed objects with or 
without stitch angles. It can’t be applied to lettering, 
auto appliqué or composite objects.

You can control stitch density in stippling objects by 
adjusting stitch length and loop spacing. You can 
reshape and scale stipple fill object outlines while 
preserving settings.

To create a stippling fill

1 Click the Stipple Run icon or click the Fill icon 
and choose Stipple Run from the dropdown 
menu. See Creating craft stitch fills for details.

Adjust stitch 
settings as desired

Stitch length: 3.0 mm Stitch Length: 1.0 mm

Stitch spacing: 3mm Stitch spacing: 5mm

Use Stipple Run (Craft Stitch toolbar) for special stip-
pled effects.
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2 Create or select a closed shape. See Digitizing 
Methods for details.

Note  Stitch angle has no effect on the stipple run 
pattern.

3 To change settings, double-click or right-click the 
object.

The Object Properties > Fill Stitch dialog 
opens.

4 Adjust run Stitch Values as desired:

Adjust Stitch Length for smoother or sharper 
curves.

Adjust Run Count defines the number of stitch 
repetitions – e.g. 1, 3, 5, 7, 9 – and hence the 
stitch bulk.

5 Adjust Stipple Values as desired:

Adjust Loop Spacing for tighter or more open 
stitching.

Adjust Inset Step to offset stippling inwards 
from the object outline. To leave a larger gap 
between the stippling and the outline, enter a 
larger value. Note that the stipple fill cannot 
extend beyond the object outline.

6 Change stipple Stitch Type as desired. Stipple 
Stemstitch and Stipple Backstitch work the 
same way as Stipple Run except that they create 
a more ornate fill effect.

Stipple Stemstitch settings are also 
controlled via Object Properties. See also 
Creating stemstitch outlines.

Adjust stitch values 
as required

Adjust stipple 
settings

Stitch length: 1.0 mm Stitch Length: 3.0 mm

Loop Spacing: 1.5 mm Loop Spacing: 2.5 mm

Stipple BackstitchStipple Stemstitch
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Stipple Backstitch settings are also 
controlled via Object Properties. See also 
Creating backstitch outlines.

7 Click Apply to preview the effect or OK to finish 
and close.

Once a stipple fill is generated, you can adjust 
object properties of the generated stipple run at 
any time. You can also reshape and scale stipple fill 
object outlines while preserving settings. See 
Reshaping objects using reshape nodes for details.

Tip  The Break Apart command can be applied to 
stipple fill objects. As a result, you can edit the 
stipple run line directly. Apply Pattern Run, Satin 
and other outline stitch types as desired. See 
Splitting into component objects for details.

Stipple with Candlewicking Stipple with Blanket
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CHAPTER 24
DIGITIZING FOR APPLIQUÉ

Appliqué is an important craft in home 
sewing, and the Auto Appliqué feature 
provides an easy way to create high quality 
work. Use Auto Appliqué to generate the 
stitching you require for closed-object 
appliqué. Up to four layers of stitching – 
placement lines, cutting lines, tackdown and 
cover stitches – are generated. Using the 
Partial Appliqué tool, you can create appliqué 
objects with partial cover stitching to create 
overlaps without doubling-up borders. 
Sometimes you require added flexibility to extend the range of designs that can 
be sewn. For instance, designs containing open objects cannot be handled by 
Auto Appliqué. In such cases, the special Advanced Appliqué tool allows you to 
generate ‘open-object appliqué’ from one or more source objects.

This section covers creating closed-object appliqué as well as partial cover 
appliqué. It also discusses creating open-object appliqué.

Creating closed-object appliqué

Use Auto Appliqué to produce the stitching you 
require for closed-object appliqué. You digitize the 
border around an appliqué shape in much the same 
way as an closed-object embroidery object. You can 
control various settings including cover stitch type – 
Satin or Blanket – width, stitch spacing, as well as 
offset. Up to three types of ‘secondary object’ can be 
automatically generated:

Placement lines: Optionally, placement lines are 
used to position applique fabrics or pre-cut 
patches on the background fabric.

Cutting lines: Optionally, cutting lines form a 
guide when trimming the fabric of an appliqué 
patch ‘in situ’.

Tackdown: This is a zigzag or run stitch placed 
after placement and cutting lines, and used to fix 
appliqué patches to the background fabric before 
cover stitching is applied.

Tip  You can also create appliqué objects with partial 
cover stitching to create overlaps without doubling-up 
borders. See also Creating partial cover appliqué.

Creating appliqué with Auto Appliqué

Use Auto Appliqué to generate the stitching you 
require for closed-object appliqué. Up to four layers of 
stitching – placement line, cutting line, tackdown and 
cover stitch – are generated. Options determining 
single or multiple boundaries as well as frame-out 
position are set in the Options dialog. See Setting 
Auto Appliqué options for details.

Use Auto Appliqué (Digitize toolbar) to digitize 
closed-object appliqué objects.
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Tip  When you stitch out an appliqué object, the 
machine stops between layers. Before you begin to 
stitch the appliqué, lay the fabric over the design and 
start the machine. When the guideline has been 
stitched, trim the excess appliqué material and start 
the machine again for the tackdown and cover stitch.

To create appliqué using Auto Appliqué

1 Load a picture. See Loading pictures for details.

Tip  By default, the tool allows you to digitize 
multiple appliqué objects. If you only want to 
digitize a single object, activate the Single option 
in the Options dialog. See Setting Auto Appliqué 
options for details.

2 Click the Auto Appliqué icon in Design or 
Artistic View.

3 Digitize the appliqué outline by marking reference 
points around the shape.

Click to create a corner point.

Right-click to create a curve point.

Tip  Follow the prompts in the Status Bar to help 
you digitize. If you make a mistake, press 
Backspace to delete the last reference point, then 
continue digitizing.

4 Press Enter to close the shape.

5 Click the outline to set the stitch entry and exit 
points or press Enter to accept the defaults.

6 Depending on the selected frame-out method, you 
may be prompted to mark the frame-out position. 
See Setting Auto Appliqué options for details.

Automatic: If activated, the frame-out 
position is determined automatically.

Manual: If activated, click the point where the 
frame-out position is to be.

Place Under Cover Stitches: If activated, the 
frame-out position is placed at the location of 
the last needle penetration before the 
frame-out would occur.

7 Press Enter.

The shape is closed and up to four layers of 
stitching generated – placement line, cutting line, 
tackdown and cover stitch – depending on current 
settings. See Adjusting Auto Appliqué settings for 
details.

Note  The Ungroup command is not available 
when an Auto Appliqué object is selected. If you 
wish to access component objects, use the Break 
Apart tool. See Splitting into component objects 
for details.

Adjusting Auto Appliqué settings

The cover stitch is the border around the appliqué 
shape. You can control various settings including 
cover stitch type, width, stitch spacing, as well as the 
offset in relation to the digitized outline.

To adjust Auto Appliqué settings

1 Double-click or right-click an Auto Appliqué object.

Use Object Properties (General toolbar) to set cur-
rent properties.

Frame out 
position

Satin cover
stitch

Placement
line (pink)

Zigzag
tackdown

(green)

Cutting line
(purple)
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The Object Properties > Appliqué dialog opens.

Tip  To adjust settings prior to digitizing, with no 
objects selected, access the Object Properties > 
Appliqué dialog.

2 In the Cover Stitch panel, select the required 
cover stitch type – Satin or Blanket.

Note  By default cover stitching is activated. This 
control allows compatibility between appliqués 
created in Explorations which has a ‘No Border’ 
option, and those created in BERNINA Embroidery 
Software.

3 Adjust cover stitch width and spacing as required:

Width: Enter the width of the Satin or Blanket 
column.

Spacing: Enter the stitch spacing of the Satin 
or Blanket column.

4 If using Satin cover stitch, select the Use 
Tackdown checkbox as required and adjust width 

and spacing settings. Tackdown width cannot be 
greater than the cover stitch width.

Note  Tackdown stitching is not available for 
Blanket cover stitch.

5 Select required appliqué styles.

Two options are available – Placement Line and 
Cutting Line. Use placement lines as a guide to 
place pre-cut fabric patches. Use cutting lines to 
hold down uncut patches so that they can be cut in 
place.

6 Click Choose to choose a fabric or plain color in 
the Fabric panel to assign to your appliqué patch. 
See Placing fabrics in Auto Appliqué designs for 
details.

7 Use the slider to offset the cover stitch relative to 
– inside or outside – the placement line.

Satin Width: 1.0 mmSatin Width: 2.5 mm

Blanket Spacing: 2.0 mmBlanket Spacing: 1.3 mm

Tackdown stitch 
width: decreased

spacing: increased

Tackdown stitch 
width: default

spacing: default

Tackdown stitch 
width: increased

spacing: decreased

Select placement
and/or cutting lines

Click to choose
fabric or color

Adjust cover
stitch and

tackdown offset
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Satin defaults to none while Blanket defaults to 
100% inside.

8 Click Apply.

Current settings are applied to selected objects.

Placing fabrics in Auto Appliqué designs

The Object Properties > Appliqué dialog contains 
a Fabric panel which allows you to choose a fabric or 
plain color to assign to your appliqué patch.

To place fabric in an Auto Appliqué design

1 Double-click or right-click an Auto Appliqué object.

The Object Properties > Appliqué dialog opens.

2 Click Choose to choose a fabric or plain color in 
the Fabric panel to assign to your appliqué patch.

The Appliqué Fabric dialog opens. The 
Fabric/Color/None options allow you to select 

between fabrics or plain colors. By default the 
Fabrics option is selected.

3 Scroll down the display panel to find a suitable 
category and click a node on the fabrics tree to 
view the available range – e.g. ‘Anniversary 
Florals’.

4 Click OK to apply it to the selected appliqué object.

Note  The Benartex range is displayed as in Patch 
Properties dialog. See Creating open-object 
appliqué for details.

5 If you prefer to assign a color to your appliqué 
patch, select the Color option.

Use Show Appliqué Fabric (General toolbar) to tog-
gle appliqué fabrics/colors on/off.

Offset: inside Offset: none Offset: outside

Swatch showing 
current fabric used 
for appliqué
Click to choose 
fabric or color

Select
between

fabrics or
plain colors

Click node to
view available

range
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The Appliqué Fabric dialog updates to display a 
range of colors.

6 Select a tonal range – Light, Mid or Dark – and 
choose a color.

7 Click OK to close the dialog and put the fabric into 
the Object Properties > Appliqué dialog.

8 Click Apply to apply it to the selected appliqué 
object.

Tip  Use the Show Appliqué Fabric toggle to 
turn appliqué fabrics/colors display on/off.

Creating partial cover appliqué

Using the Partial Appliqué tool, you can create 
overlapping appliqué objects with partial cover 

stitching without doubling-up borders. The lower 
layers will have partial appliqué applied to them.

To create partial cover appliqué

1 Create appliqué shapes with Auto Appliqué. See 
Creating appliqué with Auto Appliqué for details.

2 Select the appliqué objects.

3 Click the Partial Appliqué icon.

Cover stitches are removed where objects overlap, 
leaving only the secondary objects – tackdown, 
placement and cutting lines.

Click Partial Appliqué (Digitize toolbar) to create 
appliqué objects with partial cover stitching.

Click to
choose color

Swatch showing 
current fabric or 
color

Unstitched part 
of boundary

Partial cover
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Creating open-object appliqué

Appliqué is an important craft in home sewing, and 
the Auto Appliqué feature provides an easy way to 
create high quality work. However, sometimes you 
require added flexibility to extend the range of 
designs that can be sewn. For instance, designs 
containing open objects cannot be handled by Auto 
Appliqué.

In this design, the stem in the center of the leaf must 
be sewn after the placement and cutting lines around 
the leaf outline but before the cover stitches. There 
may be one or two fabric areas. If there is only one 
patch, the stem will not require placement or tacking 
stitches. If there are two patches, the stem, as well as 
the outline, must have placement and tacking 
stitches.

Another problem is illustrated by the rabbit design 
below. The entire shape is composed of open curves 
whose stitching order is crucial – e.g. the left ear must 
be on top. The interior of the rabbit needs to be filled 
with fabric, even though none of its component 
curves is closed.

In both cases, you want to be able to enter the curves 
in as natural an order as possible and have the 
software correctly interpret where the enclosed areas 

are to be. To this end the special Advanced Appliqué 
tool allows you to generate ‘open-object appliqué’ 
from one or more source or ‘primary’ objects. 
Boundaries can be defined by a mixture of objects as 
shown here:

Primary objects

Source or ‘primary’ objects used in the creation of 
open-object appliqué must be created and sequenced 
before the feature is applied. These objects are not 
affected in any way by their incorporation into 
open-object appliqué. Several types of source object 
can be used:

Any outline stitch type – Single Run, Satin Outline, 
etc,

Any closed-object filled object, or 

Any block-digitized object.

Some other object types can be used as input in 
combination with the above objects. These include 
lettering objects, auto-appliqués and even other 
open-object appliqués.

Note  If BERNINA Embroidery Software detects more 
than one area, you have the option of joining them 
into one patch. See Merging and unmerging patches 
for details.

Secondary objects

Up to three types of ‘secondary object’ can be 
automatically generated:

Placement lines: These are, optionally, the first 
appliqué layer to be stitched. Placement lines are 
used to position pre-cut appliqué patches on the 
background material.

Cutting lines: Again optionally, cutting lines form 
a guide when trimming the fabric of an appliqué 
patch ‘in situ’.

Tackdown: This is a zigzag or run stitch placed 
after placement and cutting lines, and used to fix 

Block Digitized 
Object (Block 
Digitizing)

Patch

Satin outline

Blanket stitch
outline
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appliqué patches to the background fabric before 
cover stitching is applied.

Each ‘boundary segment’ will generate a placement 
line, cutting line and/or tackdown depending on 
current settings.

Note  Secondary objects are stitched before primary 
objects and are therefore shown beneath. You can 
assign thread colors to each secondary object or let 
BERNINA Embroidery Software decide.

Creating open-object appliqué design

Several types of ‘primary object’ can be used in the 
creation of open-object appliqué, including any 
outline stitch type – Single Run, Satin Outline, etc – 
any filled object, or any block-digitized object. 
Additionally, some other objects can be used as input, 
including lettering objects, auto-appliqués or even 
other open-object appliqués.

Note  By default, designs are automatically grouped 
upon opening or insertion into another design. When 
you open an appliqué design after saving, you will 
need to ungroup it before you can access appliqué 
properties. See Setting other general options for 
details.

To create an open-object appliqué design

1 Create the objects you want to include in your 
cover stitching of the appliqué design. See 
Digitizing open shapes for details.

2 Set the stitching properties and sewing sequence 
of these objects.

3 Select all objects to be included in the open-object 
appliqué and click the Advanced Appliqué icon.

BERNINA Embroidery Software determines 
whether a selection contains at least one allowable 
boundary object and whether an area has been 
properly enclosed. If these conditions are met, an 
open-object appliqué object is created and the 
Appliqué Properties dialog opens.

Note  Shapes are ‘corrected’ when an open-object 
appliqué is first created. This may have the effect 
of removing small detail segments. However, 
primary objects are unaffected.

Use Advanced Appliqué (Digitize toolbar) to gener-
ate open-object appliqué from one or more source 
objects.

Areas enclosed by
allowable boundary
objects marked with

hashing in white
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4 Click Place Fabric and Color in Patches option 
to add fabric or color. See Placing fabric in patches 
and Placing color in patches below for details.

5 Click Back when complete.

6 Click Close to close the dialog.

Tip  Open-object appliqué objects can be selected 
and manipulated in the same way as a grouped 
object – i.e. they can be moved, resized, skewed 
or rotated, using the same click and drag method 
applying to all objects. Reshaping of open-object 
appliqué objects, however, is not possible. Nor is 
there any way to select individual objects, primary 
or secondary, within open-object appliqué unless 
the object is first ‘broken apart’. See Splitting into 
component objects for details.

Placing fabric in patches

You can add fabric swatches to open-object appliqué 
when it is first created or at any later stage.

To place fabric in patches

1 If editing an existing open-object appliqué object, 
double-click or right-click the object.

The Appliqué Properties dialog opens (or will 
already be open if you have just created the 
object).

2 Click the Place Fabric and Color in Patches 
option.

The dialog changes to display the Place Fabric in 
Patches panel.

Note  There may already be pre-selected entries 
in the Used Fabrics and Colors palette.

3 Select a fabric from the fabrics tree – e.g. ‘Vintage 
Shirtings’ – or from the Used Fabrics and Colors 
palette.

4 Move the cursor over the design area.

A white outline appears around any closed area 
over which the cursor passes.

5 Click an area which is currently hashed or filled.

Use Show Appliqué Fabric (General toolbar) to tog-
gle appliqué fabrics/colors on/off.

A white outline appears
around any closed area

where the cursor passes.
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The area is filled with the chosen fabric and a 
swatch added to the Used Fabrics and Colors 
palette.

Note  For any new patches created, secondary 
stitching objects are created using default stitch 
types and automatic stitch colors. See Setting 
stitch colors and Setting stitch types for details.

6 Select other areas as required to add more 
patches.

7 Click Back when complete.

8 Click Close to close the dialog.

Alternatively, click Place Color in Patches or 
Remove Fabric from Patches for more options. 
See Placing color in patches and Removing fabric 
or color from patches below for details.

Tip  Use the Show Appliqué Fabric toggle to 
turn appliqué fabrics/colors display on/off.

Placing color in patches

You can add color, in place of fabric swatches, to 
open-object appliqué when it is first created or at any 
later stage.

To place color in patches

1 If editing an existing open-object appliqué object, 
double-click or right-click the object.

The Appliqué Properties dialog opens (or will 
already be open if you have just created the 
object).

2 Click the Place Fabric and Color in Patches 
option.

The dialog changes to display the Place Fabric in 
Patches panel. There may already be 
pre-selected entries in the Used Fabrics and 
Colors palette.

Note  There may already be pre-selected entries 
in the Used Fabrics and Colors palette.

3 Select a tonal range – Light, Mid or Dark – using 
one of the three switches at the top of the palette.

4 Select a color from the palette.

5 Move the cursor over the design area.

A white outline appears around any closed area 
over which the cursor passes.

6 Click an outlined area which is currently hashed or 
filled.

Use Show Appliqué Fabric (General toolbar) to tog-
gle appliqué fabrics/colors on/off.

A white outline appears
around any closed area

where the cursor passes.
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The area is filled with the chosen color and a color 
sample added to the Used Fabrics and Colors 
palette.

Note  For any new patches created, secondary 
stitching objects are created using the default 
stitch types and automatic stitch colors. See 
Setting stitch colors and Setting stitch types for 
details.

7 Select other areas as required to add more colors.

8 Click Back when complete.

9 Click Close to close the dialog.

Alternatively, click Place Fabric in Patches or 
Remove Fabric from Patches for more options. 
See Placing fabric in patches and Removing fabric 
or color from patches below for details.

Tip  Use the Show Appliqué Fabric toggle to 
turn appliqué fabrics/colors display on/off.

Removing fabric or color from patches
You can remove colors or fabrics from open-object 
appliqué at any stage.

To remove fabric or color from patches

1 Double-click or right-click the open-object 
appliqué object.

The Appliqué Properties dialog opens.

2 Click the Remove Fabric from Patches option.

The dialog changes to display the Remove Fabric 
from Patches panel.

3 Move the cursor over the design area.

A white outline appears around any closed area 
over which the cursor passes.

4 Click an outlined area which is currently filled.

The patch fabric or color is replaced with white 
hashing and all associated secondary objects 
removed.

Note  The fabric or color is also removed from the 
Used Fabrics and Colors palette if this was the 
only instance of that fabric or color.

5 Select other areas as required to remove more 
patches.

6 Click Back when complete.

7 Click Close to close the dialog.

Alternatively, click Place Fabric in Patches or 
Place Color in Patches for more options. See 
Placing fabric in patches and Placing color in 
patches below for details.

Merging and unmerging patches
In the sample below, there may be one or two fabric 
areas. If there are two patches, the stem, as well as 
the outline, must have placement and tacking 
stitches. If there is only one patch, the stem will not 
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require placement or tacking stitches. In this case, 
the two fabric areas need to be merged into one.

To merge and unmerge patches

1 Double-click or right-click the Advanced Appliqué 
object.

The Appliqué Properties dialog opens.

2 Select the Merge Patches Together option.

The Merge Patches Together panel is displayed.

3 Select the patch to merge.

A red line appears around its border.

4 Hover the cursor over the second patch.

This patch may or may not be filled with fabric or 
color. A white line appears around its border.

5 Click the patch.

The two patches are merged into a single patch 
taking the fabric or color of the first one. All 
secondary stitching is removed from the boundary 
segments previously shared by the patches.

Note  Two patches are said to be adjoining when 
they share a boundary which is either a section of 
outline object – Run, Satin Outline, etc – or a 
section of filled object which collapses in the 
middle, forming a section of common boundary.

6 Repeat as many times as required.

Patches 3 and 4 
can be merged, 
because they are 
adjoining

Patches 1 and 2 
cannot be merged, 
because they are 
not adjoining
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Tip  To unmerge a merged patch, click the 
Unmerge Patches option at any stage and click 
a merged patch.

The merged patch is broken into its original 
individual patches, each with their current fabric or 
color (not the original fabric or color). New 
secondary objects are created for the shared 
boundaries between the newly unmerged patches. 
The stitch properties of these secondary objects 
are as they were before the areas were merged.

7 Click Back to complete.

8 Click Close to close the dialog.

Tip  Use the Show Appliqué Fabric toggle to 
turn appliqué fabrics/colors display on/off.

Setting stitch colors
You can either set colors automatically or manually. 
For any newly created open-object appliqué, 
secondary objects are created using the automatic 
stitch colors. Two options are available: Special 
colors for each layer and Match color of cover 
stitching. See also Setting stitch types.

To set stitch colors

1 Double-click or right-click the Advanced Appliqué 
object.

The Appliqué Properties dialog opens.

2 Select the Set Colors Automatically option.

The Automatic Stitch Colors dialog opens.

3 Choose an automatic color scheme from the 
available options:

Match color of cover stitching: If selected, 
all secondary objects are shown in the color of 
their associated primary objects.

Special colors for each layer: If selected, all 
secondary objects are shown and stitched in 
the colors displayed here (chosen for visual 
clarity on screen).

Note  You would not normally use actual threads 
in the display colors but a single thread color for all 
secondary objects closely matching the fabric on 
which the appliqué is to be stitched.

4 Click OK to complete.

5 Click Close to close the dialog.

Setting stitch types
You have two options when it comes to setting stitch 
types to use for secondary objects: automatic or 
manual. To set stitch types automatically, you simply 
click the Set Stitch Types Automatically option in 
the Applique Properties dialog. Stitch types for all 
tackdowns are set according to the cover stitch type 
as follows:

If the cover stitches are Satin Outline, Satin Fill, 
Step fill or Fancy Fill, the tackdown is set to Zigzag.

If the cover stitches are anything else, the 
tackdown is set to Run stitch.

If you require greater control over stitch types used 
for placement lines, cutting lines, and tackdowns, use 
the following procedure. When you set colors 
manually, any change you make overrides 
automatically chosen colors.

To set stitch types

1 Double-click or right-click the Advanced Appliqué 
object.
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The Appliqué Properties dialog opens.

2 Select the Set Stitch Types Manually option.

The Set Properties Manually panel is displayed.

3 To make the Set Properties Manually panel 
activated, select boundary segments as follows:

By placing the mouse cursor over an individual 
boundary segment, it is highlighted in white. If 
you place it over a filled patch, the entire 
boundary of the patch is highlighted in white. If 
you then click the mouse, the highlighted 
section is selected. Selected boundary 
segments appear in magenta. 

By holding down the Ctrl key while a boundary 
or boundary segment is highlighted, the 
highlighted section is added to the selection, if 
not already selected, or subtracted from the 
selection if already selected.

4 Select the secondary objects you want included in 
your open-object appliqué:

Placement lines: These are, optionally, the 
first appliqué layer to be stitched. Placement 
lines are used to position pre-cut appliqué 
patches on the background material.

Cutting lines: Again optionally, cutting lines 
form a guide when trimming the fabric of an 
appliqué patch ‘in situ’.

Tackdown: This is a zigzag or run stitch placed 
after placement and cutting lines, and used to 
fix appliqué patches to the background fabric 
before cover stitching is applied.

5 Set the display color for each of the secondary 
objects – placement lines, cutting lines, and/or 
tackdown – you have selected.

Note  When you set colors manually, any change 
you make overrides automatically chosen colors. 
See Setting stitch colors for details.

6 If you have chosen to include tackdown stitches, 
select the required type:

Zigzag: This gives you control over:

Stitch width: sets the column width for the 
Zigzag stitch.

Spacing: sets the stitch spacing.

Color: sets the stitch color.

Offset: sets the cover stitching in relation to 
the secondary objects as shown:

Run Stitch: This gives you control over:

Stitch length: set the stitch length to suit the 
digitized shape – where the object has tight 
curves, select a shorter stitch length; to reduce 
the stitch count for flatter curves, increase the 
stitch length.

Color: sets the stitch color.

7 Click Back to return.

8 Click Close to close the dialog.

Recovering the original embroidery objects
Primary objects can be recovered at any time. 
BERNINA Embroidery Software will remove all 

Choose tackdown 
stitch type

Tackdown stitch 
offset: outside

spacing: decreased

Tackdown stitch 
offset: none

spacing: default

Tackdown stitch 
offset: inside

spacing: increased
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secondary objects, ungroup the primary objects and 
return them as individual objects. See also Splitting 
into component objects.

To recover the original embroidery objects

1 Double-click or right-click the Advanced Appliqué 
object.

The Appliqué Properties dialog opens.

2 Click the Recover your original embroidery 
objects option.

All secondary objects are removed and all primary 
objects ungrouped.

3 Click Close to close the dialog.

Note  If the whole open-object appliqué had been 
resized, moved, or skewed, the primary objects 
are returned in this transformed state.
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PART VI
EMBROIDERY LETTERING

Create top-quality lettering quickly and simply. BERNINA Embroidery Software provides 
a large range of scalable closest-join alphabet styles and multi-color and fancy stitching 
alphabets to choose from. 

Lettering essentials

This section describes how to add lettering to embroidery designs. It also covers 
applying lettering baselines, formatting lettering and adjusting letter spacing. See 
Lettering Essentials for details.

Editing embroidery lettering

This section describes how to edit lettering text. It also covers scaling lettering and 
removing underlay from small lettering. It also deals with transforming lettering 
objects, adjusting individual letters, as well as reshaping baselines. See Editing 
Embroidery Lettering for details.

Special lettering effects

This section describes how to convert TrueType fonts to embroidery fonts. It also 
explains how to add special characters as well as fancy and monogram lettering to your 
designs. It also covers applying different stitch types to lettering objects as well as 
creating special effects with Elastic Lettering. See Special Lettering Features for details.

Monogramming

This section details the creation of monogram lettering with initials or with a name, how 
to add ornaments to monograms, and how to create ornament layouts. It also covers 
adding and creating your own borders. See Monogramming for details.
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CHAPTER 25
LETTERING ESSENTIALS

Add lettering to designs quickly and easily, either 
on-screen using the current settings or via object 
properties. Place lettering on a straight horizontal 
or vertical baseline, curve it around a circle or arc, 
or digitize your own baselines. You can apply 
formatting to lettering objects in the same way as 
a word processor, including italics, bolding, and 
right/left justification. Letter, word and line 
spacings can be determined before or after 
creating lettering objects and placing them in your 
design. See also Alphabet Samples.

This section describes how to add lettering to embroidery designs. It also covers 
applying lettering baselines, formatting lettering and adjusting letter spacing.

Adding lettering to embroidery designs

You can add lettering to a design by typing it directly 
on-screen. Adjust object properties to specify letter 
formatting before or after adding it to a design. 
BERNINA Embroidery Software provides an alphabet 
range suitable for many applications. Select from the 
supplied alphabets or convert TrueType fonts.

Creating lettering on-screen

If it is not essential to fit letters precisely to a certain 
area, you can type them directly on-screen. You can 
also modify lettering objects directly on-screen to 
achieve various artistic effects. Appearance and 
layout depend on current settings. You can change 
them at any time. See Editing Embroidery Lettering 
for details.

To create lettering on-screen

1 Click the Lettering icon.

2 Select a color from the color palette. See Changing 
current colors for details.

3 Click where you want to start typing.

An I-beam appears where you clicked.

4 Type the letters you want to embroider.

Tip  To start a new line, press Shift+Enter.

5 Press Enter to complete.

Stitches are generated immediately.

Note  Appearance and layout depend on current 
settings in the Object Properties > Lettering 
dialog. You can change them at any time. See 
Editing Embroidery Lettering for details.

Use Lettering (Digitize toolbar) to add lettering 
directly on-screen.

I-beam
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Creating lettering with the Object 
Properties dialog

You can specify letter formatting before adding it to 
the design. This is the more traditional method and is 
useful with more complex designs.

To create lettering with the Object 
Properties dialog

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Enter the text you want to embroider in the text 
entry panel.

To start a new line of lettering, press Shift+Enter. 

Tip  You can insert a color change between two 
letters by keying a caret (^) symbol. Subsequent 
letters default to the next color in the palette.

3 Select alphabet and adjust formatting and 
baseline settings for the lettering as required. See 
Selecting alphabets and Formatting lettering for 
details.

4 Click Apply.

5 Click where you want to place the lettering, or 
mark reference points for the baseline you 

selected. See Applying lettering baselines for 
details.

Note  Letters are filled with stitches according to 
current stitch settings in the Object Properties 
dialog. You can change these at any time. See 
Applying different stitch types and effects to 
lettering for details.

Selecting alphabets

BERNINA Embroidery Software provides an alphabet 
range suitable for many applications. Select from the 
supplied alphabets or convert TrueType fonts. The 
alphabet you select depends on where and on what 
your lettering is going to appear. If you are 
embroidering on a child’s outfit you might use a 
simple alphabet like Childs Play. If you are 
embroidering on a ladies nightdress you might use an 
elegant script alphabet like Anniversary.

Note  Be sure to check the minimum/maximum 
recommendations for each alphabet and stay within 
those recommendations for best results. See also 
Alphabet Samples.

To select an alphabet

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select an alphabet from the Alphabet list. See 
also Converting fonts to alphabets.

A sample character of the chosen alphabet 
appears in the preview window. See also Alphabet 
Samples.

Tip  Consider letter size before you change 
alphabets. Some alphabets look best in a smaller 

Right-click Lettering (Digitize toolbar) to enter text in 
the dialog and adjust settings for embroidery letter-
ing.

Enter text

Adjust settings

Right-click Lettering (Digitize toolbar) to select an 
alphabet for new or selected lettering objects.

Select an alphabet

Preview 
window
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size. Others can be stitched at a larger size. See 
also Adjusting letter height and width.

3 Click Apply.

The lettering alphabet is set.

Applying lettering baselines

Baselines determine the shape of lettering objects in 
a design. You can place lettering on a straight 
horizontal or vertical line, curve lettering around a 
circle or arc, or digitize your own baseline. Different 
reference points are needed depending on the 
baseline you use. You can digitize baselines 
on-screen.

Baselines use default settings to determine their size, 
spacing and angles. BERNINA Embroidery Software 
gives you both interactive and precise numerical 
control over many baseline settings. Techniques are 
available to modify baseline type, length, radius and 
angle, as well as baseline position.

Note  BERNINA Embroidery Software will remember 
which baseline you used last and use this one if you 
type letters directly on-screen.

Selecting baselines

Different baselines are available for use with new or 
selected lettering objects. Adjust baseline settings 
interactively or via properties.

To select baselines

1 Double-click or right-click a lettering object or 
right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select a baseline.

The baseline you choose depends on the effect you 
want to achieve. You need to digitize different 
reference points depending on the type of baseline 
you select. Options include:

Straight Horizontal: See Creating horizontal 
baselines for details.

Circle CW: See Creating circular baselines for 
details.

Circle CCW: See Creating circular baselines for 
details.

Any Shape: See Creating custom baselines for 
details.

Vertical: See Creating vertical baselines for 
details.

Multiple: See Creating custom baselines for 
details.

3 Click Apply.

The selected baseline is applied to any selected 
lettering object or newly created lettering objects.

Tip  Create identical baselines by duplicating or 
copying them in your design.

Creating horizontal baselines

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Free Line (Lettering tab) to create straight hori-
zontal baselines of no fixed or pre-determined 
length.

Use Circle CW (Lettering tab) to create clockwise 
baselines.

Use Circle CCW (Lettering tab) to create 
counter-clockwise baselines.

Use Any Shape (Lettering tab) to shape lettering 
around elements in a design. 

Use Free Line Vertical (Lettering tab) to create 
straight vertical baselines of no fixed or pre-deter-
mined length.

Use Predefined (Lettering tab) to create multiple 
arching baselines.

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Free Line (Lettering tab) to create straight hori-
zontal baselines of no fixed or pre-determined 
length.

Select 
baseline
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Free Line baselines do not have a fixed or 
pre-determined length. They extend as long as you 
keep adding letters.

To create horizontal baselines

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens. See Creating lettering with the Object 
Properties dialog for details.

2 Enter your text in the text entry panel. See 
Creating lettering with the Object Properties dialog 
for details.

3 Select the Free Line icon.

4 Click Apply.

5 Click where you want to place the letters.

Creating vertical baselines

Free Line Vertical baselines are straight, 
vertical baselines. Free Line Vertical 
baselines do not have a fixed length, and 
extend to fit the letters you enter. Line 
spacing is calculated horizontally while letter 
spacing is calculated vertically. Letters, by 
default, are centered along vertical lines. 
New lines are placed by default from right to 
left to suit Asian languages. Vertical 
baselines are effective for embroidering on 
sleeves, as a decorative effect, and for Asian 
text.

Tip  Vertical lettering best suited to uppercase for 
Western languages because descenders in lowercase 
letters are not accommodated in the letter spacing.

To create vertical baselines

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens. See Creating lettering with the Object 
Properties dialog for details.

2 Enter your text in the text entry panel. See 
Creating lettering with the Object Properties dialog 
for details.

3 Select the Free Line Vertical icon.

4 Click Apply.

5 Click where you want to place the letters.

Creating circular baselines

Use Circle CW and Circle CCW baselines to place 
letters around a full circle or ellipse in clockwise or 
counter-clockwise directions. By default, letters are 
positioned above Circle CW baselines and below 
Circle CCW baselines. They are also centered by 
default.

To create circular baselines

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens. See Creating lettering with the Object 
Properties dialog for details.

2 Enter your text in the text entry panel. See 
Creating lettering with the Object Properties dialog 
for details.

3 Select the Circle CW or Circle CCW icon and click 
Apply.

The Status Bar will prompt you.

4 Mark the center of the circle.

5 Mark a point to define the radius.

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Free Line Vertical (Lettering tab) to create 
straight vertical baselines of no fixed or pre-deter-
mined length.

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Circle CW (Lettering tab) to create clockwise 
baselines.

Use Circle CCW (Lettering tab) to create 
counter-clockwise baselines.

Click to mark 
center of circle

Click to set 
radius

Press Enter to 
complete circle

1 2



Chapter 25 : Lettering Essentials

BERNINA® Embroidery Software : Onscreen Manual 227

6 Press Enter to complete the circle.

7 Alternatively, if you want to create an oval 
baseline, mark a third reference point.

8 Press Enter to complete the oval.

Tip  Make a circle large enough for your lettering. 
If it is too small, or the lettering too big, the letters 
will be crowded. You can, however, adjust the 
baseline radius in the dialog. See also Reshaping 
baselines.

Tip  Different effects can be achieved by changing 
the justification setting – left, right, center, full. 
See Setting letter justification for details.

Creating predefined baselines

Use Predefined baselines to arch lettering clockwise 
across the top, straight through the middle, and 
counterclockwise around the bottom of a circle, all in 
one action.

To create a predefined baseline

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens. See Creating lettering with the Object 
Properties dialog for details.

2 Type the text for the line around the top of the 
circle in the text entry panel.

3 Press Enter.

4 On the next line type the text for the line across 
the middle of the circle and press Enter.

5 On the third line type the text for the line around 
the bottom of the circle.

6 Select the Predefined icon.

7 Click Apply.

8 Mark the center of the circle. See Creating circular 
baselines for details.

9 Mark a point to define the radius.

10 Press Enter for a perfect circle, or click again to 
form an oval and press Enter.

Circle CW Circle CCW 

Press Enter to 
complete circleClick to set

oval radius

1
2

3

Circle CW Circle CCW 

Baseline Radius: 
10 mm

Baseline Radius: 
20 mm

Adjust baseline radius

Left-justified 
CCW oval 
baseline

Fully justified 
CW circle 
baseline

Right-justified
CW circle
baseline

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Predefined (Lettering dialog) to create multiple 
arching baselines.

Type in texts for 
each line



Chapter 25 : Lettering Essentials

BERNINA® Embroidery Software : Onscreen Manual 228

Creating custom baselines

Use Any Shape baselines to shape lettering around 
elements in your design. Digitize Any Shape baselines 
by marking reference points to form the required line. 
The number of reference points and length of baseline 
are practically unlimited.

If the baseline has tight curves, or sharp corners, the 
letters may overlap. For best results, only mark curve 
points, and digitize lines which have shallow, gentle 
curves.

To create custom baselines

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens. See Creating lettering with the Object 
Properties dialog for details.

2 Enter your text in the text entry panel. See 
Creating lettering with the Object Properties dialog 
for details.

3 Select the Any Shape icon and click Apply.

The Status Bar will prompt you.

4 Click to mark the baseline reference points.

Right-click for curve points.

Left-click for corner points.

5 Press Enter to complete.

Formatting lettering

You can control the appearance of lettering by 
changing object properties before or after adding 
lettering, in the same way as other objects. 

Making italic lettering

You can slant letters to the left or right for an italic 
effect. The default italic angle is 0° which is equivalent 
to no italics. The largest angle lettering can be 
inclined is 45°.

To make italic lettering

1 Double-click or right-click a lettering object or 
right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Enter an angle in the Italic field.

You can enter an angle anywhere between 45° and 
-45°.

3 Click Apply.

The setting is applied to any selected lettering 
object or to newly created lettering objects.

Making bold lettering

You can create the effect of bold lettering by 
increasing the pull compensation settings for selected 
lettering objects.

To make bold lettering

1 Double-click or right-click a lettering object or 
right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

Right-click Lettering (Digitize toolbar) to select base-
lines and adjust baseline settings.

Use Any Shape (Lettering tab) to shape lettering 
around elements in a design. 

1 2
3

4

Right-click Lettering (Digitize toolbar) to adjust italic 
settings.

Right-click Lettering (Digitize toolbar) to adjust bold-
ing settings.

Enter angle 
value

Italic angle: 45°

Italic angle: 0°

Italic angle: -45°
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2 Click the Effects button.

The Effects dialog opens.

3 Select the Others tab.

4 Select the Pull Compensation checkbox and 
increase the setting to 0.4–0.6 mm.

Caution  Do not use a value of more that 0.6 mm 
or letters may distort.

5 Click Apply.

The setting is applied to any selected lettering 
object or to newly created lettering objects.

Setting letter justification

Justification is the way that lettering aligns itself on a 
baseline. You can justify lettering left or right, center 
it, or fully justify it. Full justification spreads the 
letters out to fill the length of the baseline.

To set letter justification

1 Double-click or right-click a lettering object or 
right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select a justification setting – Left, Right, 
Center, or Full Justification.

3 Click Apply.

The setting is applied to any selected lettering 
object or to newly created lettering objects.

Adjusting spacings

Letter, word and line spacings can be determined 
before or after creating lettering objects and placing 
them in your design. You can edit spacing directly 
on-screen or via object properties. Letter spacing is 
calculated automatically according to justification – 
Left Justification, Right Justification, Center 
Justification, or Full Justification. See also Setting 
letter justification.

Adjusting overall letter spacing on-screen

The spacing between letters is calculated 
automatically as a percentage of the letter height. In 
most cases the default spacing is adequate. 
Sometimes, however, you may want to change the 
overall letter spacing.

To adjust overall letter spacing on-screen

1 Select the lettering object and click the Reshape 
Object icon.

2 Drag the triangular letter spacing handle left or 
right.

Letters are redistributed proportionately along the 
baseline.

3 Release the mouse button to complete and press 
Esc.

Tip  When a lettering is set to Full Justification, the 
letters are evenly distributed along the baseline. 
To change the spacing for fully justified lettering, 
simply change the length of the baseline.

Right-click Lettering (Digitize toolbar) to adjust letter 
justification.

Increase pull comp

Pull comp: 0.2 mm Pull comp: 0.6 mm

Click Reshape Object (Edit toolbar) to adjust letter 
spacing.

Drag letter spacing handle
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Adjusting individual letter spacing 
on-screen

Spacing between letters is calculated automatically as 
a percentage of letter height. In most cases the 
default spacing is adequate. Sometimes, however, 
spacing between certain letters may appear too large 
or too small, depending on the shape of neighboring 
letters. To compensate for this visual effect, you can 
move one or several selected letters closer or further 
apart along the baseline to improve spacing.

To adjust individual letter spacing 
on-screen

1 Select the lettering object and click the Reshape 
Object icon.

2 Click the diamond handle at the center of a letter.

Tip  To select multiple letters, hold down Ctrl as 
you select.

3 Drag selected letter/s along the baseline or use 
arrow keys to adjust the spacing.

Tip  Alternatively, to move multiple letters, 
right-click the diamond handle of the first letter 
and drag. All letters to the end of the line move as 
one.

4 Release the mouse button to complete and press 
Esc.

Adjusting line spacing on-screen

Change the space between lines in a multiple-line 
lettering object using the Reshape tool.

To adjust line spacing on-screen

1 Select the lettering object and click the Reshape 
Object icon.

2 Drag the triangular line spacing handle up or down 
to change line spacing.

3 Release the mouse button to complete and press 
Esc.

Click Reshape Object (Edit toolbar) to adjust individ-
ual letter spacing.

Click and drag 
diamond handle

Click Reshape Object (Edit toolbar) to adjust line 
spacing.

Drag line spacing 
handle down to 
increase spacing



Chapter 26 : Editing Embroidery Lettering

BERNINA® Embroidery Software : Onscreen Manual 231

CHAPTER 26
EDITING EMBROIDERY LETTERING

BERNINA Embroidery Software gives you both 
interactive and precise numeric control over 
many attributes affecting lettering objects. You 
can adjust lettering objects as a whole as well as 
individual letters. Lettering text can be edited 
directly on-screen or by means of object 
properties. When you first create lettering, it may 
be too big or small. Size can be adjusted 
interactively or numerically. Small, narrow letters 
may not require underlay, depending on their size 
and the fabric to be used. Use the available tools 
to skew and rotate lettering objects. Adjust 
individual letters like any other embroidery 
object. Reshape letters, adjust stitch angles, and recolor letters individually. 
Baselines can be modified after placement directly on-screen or via object 
properties.

This section describes how to edit lettering text. It also covers scaling lettering 
and removing underlay from small lettering. It also deals with transforming 
lettering objects, adjusting individual letters, as well as reshaping baselines.

Editing lettering text

When you have created a lettering object, you can 
select it and make changes to the text directly 
on-screen or via object properties.

Editing lettering text on-screen

The easiest way to edit lettering is to change it 
directly on-screen.

To edit lettering text on-screen

1 Click the Lettering icon and then click inside the 
lettering object. 

An I-beam appears.

2 Edit the text as required.

Tip  Press Shift+Enter to start a new line.

3 Press Enter to complete.

Click Lettering (Digitize toolbar) to edit lettering 
on-screen. 

Click here to edit

Letter deleted
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Editing lettering text with the Object 
Properties dialog
When you have created a lettering object, you can 
select it and make changes to it via object properties. 

To edit lettering with the Object Properties 
dialog

1 Double-click or right-click a lettering object.

The Object Properties > Lettering dialog 
opens.

2 Edit the text in the text entry panel as required.

3 Adjust settings as required. See Formatting 
lettering for details.

4 Click Apply.

Note  Letters are filled with stitches according to 
current stitch settings in the Object Properties > 
Fill Stitch dialog. You can change these at any 
time. See Applying different stitch types and 
effects to lettering for details.

Scaling lettering

When you first create lettering, it may be too big or 
too small. Size can be adjusted in three ways:

by scaling on-screen with Select Object or 
Reshape Object tools

by adjusting width and height settings in the 
Object Properties > Lettering dialog

by adjusting width and height settings in the 
Object Properties > General dialog.

Scaling lettering with Select Object

You can scale your lettering objects vertically, 
horizontally and proportionally with the Select 
Object tool. See also Transforming lettering with 
Select Object.

To scale lettering with Select Object

1 Click Select Object and select the lettering 
object.

2 Click and drag a handle to resize the object 
horizontally, vertically or proportionally.

3 Release the mouse to complete.

Scaling lettering with Reshape Object

You can scale your lettering objects vertically, 
horizontally and proportionally with the Reshape 
Object tool. See also Rotating lettering with Reshape 
Object.

To scale lettering with Reshape Object

1 Select the lettering object and click the Reshape 
Object icon.

Edit text

Adjust
settings

Use Select Object (Edit toolbar) to scale lettering 
objects on-screen.

Use Reshape Object (Edit toolbar) to scale lettering 
objects on-screen.

Resize 
horizontally

Resize 
proportionally

Resize vertically

Drag
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2 Click and drag a dark triangular handle to scale the 
object horizontally, vertically or proportionally.

3 Release the mouse button to complete and press 
Esc.

Adjusting letter height and width

You can scale your lettering objects vertically, 
horizontally and proportionally via the Object 
Properties > Lettering dialog.

Tip  Change the appearance of an alphabet by 
changing the letter width in proportion to the height. 
The original width value is 100%. 

To adjust letter height and width

1 Double-click or right-click a lettering object or 
right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Enter the height in the Height field.

Note  Letter height can be between 1 mm and 
200 mm. See Alphabet Samples for details.

3 Enter the width as a percentage of height in the 
Width field.

4 Click Apply.

The setting is applied to any selected lettering 
objects or to newly created lettering objects.

Adjusting lettering dimensions

You can scale your lettering objects vertically, 
horizontally and proportionally via the Object 
Properties > General dialog.

Tip  Change the appearance of an alphabet by 
changing the letter width in proportion to the height. 
The original width value is 100%. 

To adjust lettering dimensions

1 Double-click or right-click a lettering object.

The Object Properties > Lettering dialog 
opens.

2 Select the General tab.

3 Adjust the width and height settings either as 
absolute values (mm) or as a percentage of the 
current settings.

Use Lettering (Digitize toolbar) to adjust letter height 
and width.

Resize 
horizontally

Resize 
vertically

Drag

Drag

Resize 
proportionally

Drag

Resized 
vertically

Resized 
horizontally

Resized 
proportionally

Use Lettering (Digitize toolbar) to adjust lettering 
dimensions.

Adjust width percentage

Enter height

Width 100%

Width 140%

Width 70%

Adjust width and 
height settings



Chapter 26 : Editing Embroidery Lettering

BERNINA® Embroidery Software : Onscreen Manual 234

4 Click Apply.

The setting is applied to any selected lettering 
objects.

Removing underlay from small lettering

The quality of most lettering can be improved with an 
underlay using the same methods as for other 
embroidery objects. Small, narrow letters, however, 
may not require underlay, depending on their size and 
the fabric to be used. See also Stabilizing with 
underlays.

To remove underlay from small lettering

1 Select the lettering object.

2 Click the Auto Underlay icon.

The underlay is removed.

Transforming lettering objects

Use the available tools to skew and rotate lettering 
objects. See also Scaling lettering.

Transforming lettering with Select Object

You can transform lettering objects by manipulating 
control points on-screen with the Select Object tool. 
See also Scaling lettering with Select Object.

To transform lettering with Select Object

1 Click Select Object and select the lettering 
object.

Selection handles appear – these let you scale the 
object. See Scaling lettering with Select Object for 
details.

2 Click the lettering object again.

Another set of selection handles appears – these 
let you rotate and skew the object.

3 Click and drag one of the diamond-shaped handles 
to skew the lettering object horizontally.

Use Auto Underlay (General toolbar) to strengthen 
and stabilize embroidery designs with automatic 
underlay. 

Original Height 140%

Width 140%

Use Select Object (Edit toolbar) to transform lettering 
objects on-screen.

Rotation 
handles

Skew handle

Rotation point

Drag



Chapter 26 : Editing Embroidery Lettering

BERNINA® Embroidery Software : Onscreen Manual 235

4 Click and drag one of the hollow square handles to 
rotate the object.

Tip  Drag the rotation point itself to a new location 
as required.

5 Release the mouse to complete.

Rotating lettering with Reshape Object

You can rotate lettering objects by manipulating 
control points on-screen. See also Scaling lettering 
with Select Object.

To rotate lettering with Reshape Object

1 Select the lettering object and click the Reshape 
Object icon.

Control points appear around the lettering object.

2 Click and drag a solid square handle to rotate the 
lettering object.

3 Release the mouse button to complete and press 
Esc.

Adjusting individual letters

As well as scaling and rotating lettering objects, the 
Reshape Object tool is used to manipulate individual 
letters. You can reposition letters in relation to each 
other, scale, rotate and skew them. You can also 
reshape individual letters, adjust stitch angles, and 
recolor them individually.

Repositioning letters on screen

You can reposition individual letters in a lettering 
object using the Reshape Object tool. 

To reposition letters on screen

1 Select the lettering object.

2 Click Reshape Object.

3 Click the diamond control point in the centre of the 
letter.

Tip  To select multiple or a range of letters, hold 
down Ctrl or Shift as you select.

4 Click-and-drag the letter to the new position:

Use Reshape Object (Edit toolbar) to rotate lettering 
objects on-screen.

Drag

Rotation 
point

New rotation point

Rotate baseline selection handle

Drag

Use Reshape Object (Edit toolbar) to reposition indi-
vidual letters on screen.

Click diamond control points
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To move the letter horizontally, drag it along 
the baseline.

To move the letter vertically, hold down Shift 
as you drag.

To move the letter freely, hold down Ctrl as you 
drag.

5 Release the mouse to complete and press Esc.

Transforming letters on screen

You can transform individual letters by manipulating 
control points on screen with the Reshape Object 
tool.

To transform letters on screen

1 Select the lettering object.

2 Click Reshape Object.

Control points appear.

3 Click the diamond control point of a letter.

Another set of reshape nodes appear around the 
letter.

4 Click-and-drag a reshape node around the letter to 
transform it.

5 Press Esc to finish.

Reshaping letters on screen

Create special lettering effects by reshaping letter 
outlines with the Reshape Object tool.

To reshape letters on screen

1 Select the lettering object and click the Reshape 
Object icon.

Selection handles appear around the lettering 
object.

2 Click the letter outline.

Use Reshape Object (Edit toolbar) to transform indi-
vidual letters on screen.

Use Reshape Object (Edit toolbar) to reshape indi-
vidual letters.

Drag to scale 
letter width

Drag to scale letter 
proportionally

Drag to scale
letter height

Drag to rotate 

Drag to skew

Click letter outline
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Reshape nodes appear around it.

Tip  Zoom in the letter for precise reshaping. See 
Zooming in and out for details.

3 Reshape the letter by adding, deleting, changing 
or moving reshape nodes. See Reshaping objects 
using reshape nodes for details.

4 Turn on Artistic View to view the results.

Adding stitch angles to letters

Set different stitch angles within letters with the 
Stitch Angle icon. Each segment of the letter can 
have a different stitch angle.

To add stitch angles to letters

1 Select a lettering object.

2 Click the Add Stitch Angles icon.

You are prompted to enter angle point 1.

3 Digitize stitch angles so that they intersect two 
sides of the object. 

Note  Make sure that the stitch angles do not 
intersect each other.

4 Press Enter.

Stitches are regenerated with the new angles.

Deleting stitch angles of letters

Delete individual stitch angles in lettering objects with 
the Reshape Object icon. 

To delete stitch angles of letters

1 Select the lettering object and click the Reshape 
Object icon.

2 Click the diamond handle at the center of a letter.

3 Click the letter outline.

Reshape nodes appear around it.

4 Select and delete reshape nodes as required.

Note  Lettering outlines are preserved after any 
angle deletion.

Recoloring letters

Use Add Stitch Angles (Stitch and Color Bar) to set 
different stitch angles for selected letters.

Use Reshape Object (Edit toolbar) to delete individ-
ual stitch angles in lettering objects.

Use Lettering (Digitize toolbar) to recolor letters. 
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BERNINA Embroidery Software lets you change the 
color of individual letters within a lettering object.

Tip  You can also insert a color change between two 
letters by keying a caret (^) symbol. Subsequent 
letters default to the next color in the palette. See 
Creating lettering with the Object Properties dialog for 
details.

To recolor letters

1 Click the Lettering icon and then click inside the 
lettering object. 

An I-beam appears.

2 Select a letter(s) by dragging the cursor over the 
letter(s).

3 Click a color on the color palette.

4 Press Enter.

Reshaping baselines

Baselines can be adjusted on-screen after they have 
been placed in your design. Reshape straight 
baselines to place them on an angle. For Vertical 
baselines, you can also change baseline length and 
letter spacing. Reshape Circle and baselines to 
change curve depth, justification point and baseline 
length. Reshape Any Shape baselines by moving, 
changing, adding or deleting reshape nodes along the 
baseline. See also Applying lettering baselines.

To reshape a baseline

Select the lettering object and click the Reshape 
Object icon.

Different control points display for different types 
of baseline.

Tip  The large diamond and cross represent start 
and end points. You may need to move them to 
access baseline selection handles. They will 
reposition themselves automatically based on 
changes you make.

To change the angle of a straight or vertical 
baseline, click and drag one of the large solid 
squares. 

To adjust the baseline length, click and drag the 
open triangle handle.

Letter spacing adjusts accordingly.

Use Reshape Object (Edit toolbar) to reshape letter-
ing baselines.

I-beam 

Drag the cursor over the letter

Baseline selection
handles

Drag up or 
down 

Drag triangle 
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To reshape lettering with a circular baseline, drag 
the handle at the circle center to adjust the radius.

On a circular baseline, there are actually two 
selection handles at the circumference of the 
circle, one on top of the other. Drag them apart to 
create an arc.

To change letter spacing evenly around a circular 
baseline, click and drag the triangle.

Tip  The exact letter positions depend on the 
justification – Left Justification, Right Justification, 
Center Justification, or Full Justification. If the 
baseline becomes too short, letter spacing is 
reduced, and letters may overlap. See Setting 
letter justification for details.

To adjust Any Shape baselines, add, delete, 
change or move reshape nodes on the base line 

like any embroidery object. See Reshaping objects 
using reshape nodes for details.

Press Esc to finish.

Drag up or down to change 
radius of circle

Drag to change circle baseline to arc

Drag triangle to 
change spacing evenly 

Click baseline to bend, then 
drag up or down

Press spacebar to
change between

corners and curves
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CHAPTER 27
SPECIAL LETTERING FEATURES

All TrueType fonts installed on your computer are also 
available to you when placing lettering in your designs. 
BERNINA Embroidery Software lets you add special 
characters to your lettering which do not appear on the 
keyboard. BERNINA Embroidery Software also provides 
a number of special alphabets for fancy lettering as well 
as monogramming. Like all embroidery objects, each 
lettering object has its own properties. You can adjust 
these before or after creating lettering objects. BERNINA 
Embroidery Software also gives you precise control over 
the stitch angles of individual letters. Apply Elastic Lettering effects to lettering 
objects to make them bulge or arch, stretch or compress.

This section describes how to convert TrueType fonts to embroidery fonts. It also 
explains how to add special characters as well as fancy and monogram lettering 
to your designs. It also covers applying different stitch types to lettering objects 
as well as creating special effects with Elastic Lettering.

Converting fonts to alphabets

In addition to the professional embroidery alphabets 
included with the software, BERNINA Embroidery 
Software provides various techniques for converting 
any installed TrueType and OpenType font on your 
system to embroidery.

Note  Not all TrueType fonts are suitable for including 
in embroidery designs. Experiment with the ones you 
like and try different stitch settings.

Converting text to embroidery

The Convert Text to Embroidery tool converts 
selected CorelDRAW® text objects to:

Satin embroidery lettering with turning stitching if 
the text is not enveloped and does not have an 
outline, or

Non-lettering if the text is enveloped and has an 
outline.

To convert text to embroidery

1 Select Art Canvas mode.

2 Select one or more text objects and click the 
Convert Text to Embroidery tool.

Use Art Toolbox > Convert Text to Embroidery to 
convert text objects to Satin embroidery lettering with 
turning stitching.
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BERNINA Embroidery Software automatically 
switches to Embroidery Canvas mode. Source 
objects are removed from the design.

Once converted to an embroidery alphabet, you 
can apply whatever font you prefer.

Tip  You can also use the Convert Text to 
Embroidery tool with ordinary vector objects with 
different results to the Convert to Embroidery 
tool.

Converting fonts to embroidery

MS Windows® comes with a collection of TrueType 
and OpenType fonts installed and there are others 
available from various sources, including 
CorelDRAW® Essentials 4. All these fonts are 
available to you when placing lettering in your 
designs.

Tip  Install new fonts using My Computer > Control 
Panel. Double-click the Fonts folder then select File 
> Install New Font. Before you can use the new 
fonts, you need to restart your computer and then 
BERNINA Embroidery Software will display the new 
fonts in the Alphabet list.

To convert a font to embroidery

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select a TrueType font from the Alphabet list.

Any TrueType fonts installed on your computer are 
listed.

3 Enter the text you want to embroider in the text 
entry panel.

4 Click Apply.

5 Click on-screen where you want to place the 
letters.

The text is stitched using the selected font. 

Tip  Not all TrueType fonts are suitable for 
including in embroidery designs. Experiment with 
the ones you like and try different stitch settings.

Adding special characters

In BERNINA Embroidery Software, you can add 
special characters and symbols directly through the 
Select Symbols dialog or by means of the 
MS Windows® Character Map.

Selecting special characters

Use Lettering (Digitize toolbar) to convert TrueType 
fonts to embroidery fonts. Right-click to select letter-
ing options.

Use Lettering (Digitize toolbar) to add special char-
acters and symbols. Right-click to select lettering 
options.

Select 
TrueType font
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You can quickly add special 
characters and symbols to 
your lettering designs. If you 
know the keyboard shortcut 
for a symbol, add it to your 
lettering by entering the 
combination on-screen or in 
the Object Properties > 
Lettering dialog.

To select special 
characters

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

Tip  If you know the Alt key code for the special 
character you require, you can key it directly into 
the text entry field. The Character Map gives you 
codes for all characters. See Using the Character 
Map for details.

2 Click Select Character.

The Select Character dialog opens.

Tip  Select a viewing mode – you can list alphabets 
by picture, character, or both.

3 Select an alphabet from the Alphabet Set list.

4 Select the character(s) you want to use. 

Tip  When you select a character, a keystroke 
appears in the Selection field. This indicates the 

key combination required to type the character 
directly on-screen. For example, ‘m’ means press 
the m key while ‘M’ means press Shift+M.

5 Click OK.

The selected characters are displayed in the text 
entry panel.

6 Click Apply.

Using the Character Map
Use the MS Windows® Character Map to provide 
quick access to common symbols and letters. The 
Character Map is usually installed as part of the 
MS Windows® setup. See your MS Windows® 
documentation for more details.

Tip  You can create special characters in each 
alphabet by holding down the Alt key on your 
keyboard and typing 0 (zero), its code, using the 
numbers on the keypad. For example, to type è with 
the code 232, type Alt+0232. The character will 
appear when you release the Alt key. The Character 
Map gives you codes for all characters.

To use the Character Map

1 Open the MS Windows® Character Map. 

By default, you will find it under Start > 
Programs > Accessories > System Tools > 
Character Map.

2 Double-click a character, or select it and press 
Select.

The character appears in the Characters to copy 
box.

Click to select 
special characters

Select
alphabet

Select
character

Corresponding
keystrokes

Select viewing mode

Alt key combination
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Note  The equivalent Alt key combination is 
shown at the bottom of the dialog. This can be 
used to key the character directly on screen.

3 Click Copy to copy the character to the clipboard.

4 Paste it into the text entry panel by pressing 
Ctrl+V.

5 Click Apply.

Continue creating the lettering object in the 
normal way.

Using special alphabets

BERNINA Embroidery Software provides a number of 
special alphabets for fancy lettering as well as 
monogramming. See also Alphabet Samples.

Adding fancy lettering

BERNINA Embroidery Software provides fancy 
alphabets such as Creative Cross and Secret 
Garden-Caps. Use these alphabets to add lettering 
objects to your design, each letter comes with a 
design or use the small design on its own.

Note  If you edit the letters, you may lose the current 
object properties.

To add fancy lettering

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select Creative Cross or Secret Garden-Caps 
from the Alphabet list.

A sample character appears in the preview 
window.

3 Click Select Character.

The Select Character dialog opens.

Tip  Select a viewing mode – you can list alphabets 
by picture, character, or both.

4 Select the character(s) you want to use. 

Tip  When you select a character, a keystroke 
appears in the Selection field. This indicates the 
key combination required to type the character 
directly on-screen. For example, ‘m’ means press 
the m key while ‘M’ means press Shift+M.

5 Click OK.

The selected characters are displayed in the text 
entry panel.

6 Click Apply.

Use Lettering (Digitize toolbar) to add fancy lettering. 
Right-click to select lettering options.

Creative Cross 

Secret
Garden-Caps

Select Creative 
Cross or Secret 
Garden-Caps

Click to select 
fancy lettering 
characters

Select
character

Corresponding
keystrokes

Select viewing mode



Chapter 27 : Special Lettering Features

BERNINA® Embroidery Software : Onscreen Manual 244

Tip  To change the colors of the letters assign the 
required colors See Matching and assigning 
threads for details.

Adding flair script lettering

Flair script is a special font which allows you to add 
decorative flairs to the end of text objects, mimicking 
flamboyant handwriting flourishes.

To add flair script lettering

1 Click the Lettering icon.

The Object Details > Lettering dialog opens.

2 Select Flair Script from the Font list.

3 Enter the text you want to embroider in the text 
entry panel.

4 Click Select Character.

The Select Character dialog opens.

5 Select the flare character(s) you want to use. 

Scroll down for more options. See also Selecting 
special characters.

6 Click Make Current to close the dialog.

The selected characters are displayed in the text 
entry panel.

7 Adjust lettering as required. See Adding lettering 
to embroidery designs for details.

8 Click OK.

9 Click where you want to place the lettering, or 
mark reference points for the selected baseline.

Use Lettering (Digitize toolbar) to add embroidery 
lettering to designs or edit selected lettering.

Small design 
only

Letters only

Letters and 
small designs

Enter text

Select Flair
Script font

Click to
select special

characters

Select flare

Corresponding
keystrokes
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10 Press Enter.

Tip  Experiment with different flare characters to 
obtain the look you want.

Adding monogram lettering
In addition to the dedicated Monogramming feature, 
BERNINA Embroidery Software allows you to create 
monogramming designs using special monogram 
alphabets. Use Diamond2 for 2-letter monograms and 
Diamond3 for 3-letter monograms. See also 
Monogramming.

To add monogram lettering

1 Right-click the Lettering icon.

The Object Properties > Lettering dialog 
opens.

2 Select the desired monogram alphabet:

Diamond2 for a two-letter monogram: 
Diamond2 is a special alphabet which includes 
two versions of each letter for left and right 
positions, plus a border and flourish for 
two-letter designs. See Diamond2 for details.

Use Diamond3 for a three-letter monogram: 
Diamond3 is a special alphabet which includes 
three versions of each letter for left, center and 
right positions, plus a border and flourish for 
3-letter designs. See Diamond3 for details.

3 Click Select Character.

The Select Character dialog opens.

Tip  Select a viewing mode – you can list alphabets 
by picture, character, or both.

Tip  When you select a character, a keystroke 
appears in the Selection field. This indicates the 
key combination required to type the character 
directly on-screen. For example, ‘m’ means press 
the m key while ‘M’ means press Shift+M.

4 Select a left letter.

Note  When selecting letters, make sure the letter 
orientation is correct. For example, Diamond3 has 
three sets of each letter, one for the left side, one 
for the middle and one for the right side.

5 Select the middle letter, if using Diamond3.

6 Select the right letter.

7 Select a border if required.

8 Click OK.

The selected characters are displayed in the text 
entry panel.

Select Diamond2 
or Diamond3

Click to select 
fancy lettering 
characters

Select
character

Corresponding
keystrokes

Select viewing mode

Select 
border
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9 Click Apply.

Tip  If you want the letters in your monogram to 
be different styles, create each letter separately.

Applying different stitch types and 
effects to lettering

By default, lettering objects are filled with Satin 
stitch. You can also apply other basic fill stitch types, 
such as Step or Fancy, as with other embroidery 
objects. See Selecting outline stitches for details.

Adjusting Satin stitch settings for lettering 
objects
By default, lettering objects are filled with Satin 
stitch. Where a letter is narrow, stitches are tight, 
thus requiring fewer stitches to cover the fabric. 
Where a column is very narrow, stitches need to be 
less dense because too many needle penetrations can 
damage the fabric. You can fill lettering shapes with 
Special Satin stitching as well as the regular satin 
stitch. It is particularly suitable for filling large, 

irregular lettering shapes that are too large for satin 
stitch. See also Creating fills with Satin fill.

To adjust Satin stitch settings for lettering 
objects

1 Double-click or right-click a lettering object. 

The Object Properties > Lettering dialog 
opens.

2 Select the Fill Stitch tab.

3 Select the type of satin spacing. See Adjusting 
Satin fill spacing and Applying automatic spacing 
to Satin fill.

4 If you chose Manual spacing, adjust the setting.

5 Click Apply.

Note  For larger lettering objects, various 
techniques are available for controlling long 
stitches. See Preserving long stitches for details. 
See also Splitting long stitches in Satin fills.

Diamond2
monogram

Diamond3 
monogram

Adjust stitch
spacing

Select Fill
Stitch tab

Automatic Spacing

Manual Spacing 
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Adjusting Step stitch settings for lettering 
objects
You can fill lettering shapes with Step stitch. It is 
particularly suitable for filling large, irregular lettering 
shapes.

To adjust Step stitch settings for lettering 
objects

1 Double-click or right-click a lettering object. 

The Object Properties > Lettering dialog 
opens.

2 Select the Fill Stitch tab and Step from the 
Stitch Type list.

3 Adjust stitch spacing to increase or decrease 
density. See Adjusting Step fill spacing and length 
for details.

4 Adjust stitch length. See Adjusting Step fill spacing 
and length for details.

5 Select a Step pattern. See Creating fills with Step 
fill for details.

6 Click Apply.

Adjusting Fancy stitch settings for lettering 
objects
You can fill lettering shapes with Fancy stitching as 
well as the regular satin stitch. It is particularly 
suitable for filling large, irregular lettering shapes that 
are too large for satin stitch. The density is 

determined by the stitch spacing setting. See also 
Creating fancy fills.

To adjust Fancy stitch settings for lettering 
objects

1 Double-click or right-click a lettering object. 

The Object Properties > Lettering dialog 
opens.

2 Select the Fill Stitch tab and Fancy from the 
Stitch Type list.

3 Select a pattern from the Pattern list and adjust 
the settings. See also Creating fancy fills and 
Laying out pattern fills on-screen.

4 Click Apply.

Creating special effects with Elastic 
Lettering

Apply Elastic Lettering effects to lettering objects to 
make them bulge or arch, stretch or compress. You 
can create slant or pennant lettering with straight 
Elastic Lettering. You can create bulges and arches 
with curved elastic lettering. Elastic Lettering can be 
used with any baseline.

Adjust stitch
spacing and length

Select Fill Stitch tab

Select pattern

Select Step

Select Fancy

Adjust pattern settings

Select Fill Stitch tab
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Caution  If you get an ‘Out of Memory’ error on your 
A200 or A730 embroidery machine, there are two 
possible workarounds:

Select the lettering object and click the Break 
Apart tool before sending the design. This will 
turn lettering into embroidery patches – i.e. no 
longer a lettering object. See Splitting into 
component objects for details.

Save as EXP and send to the machine as an EXP 
file.

Distorting lettering objects

Four types of Elastic Lettering effect are available – 
Straight, Curved, Perspective and Diamond.

To distort lettering objects

1 Select the lettering object you want to distort.

2 Select Edit > Elastic Lettering.

3 Select an elastic type from among the following 
alternatives:

Different handles display around the object outline 
depending on the Elastic Lettering type.

4 Drag a handle to reshape the object:

To move two handles in opposite directions, 
hold the Shift key down while dragging a 
handle.

To move the handles in the same direction, hold 
down the Ctrl key while dragging a handle.

5 Press Enter to complete.

Editing lettering in Elastic Lettering

You can edit lettering in Elastic Lettering on-screen in 
the same way as normal lettering. When you click 
inside the lettering, a duplicate displays below the 
envelope.

To edit lettering in Elastic Lettering

1 Click the Lettering icon then click inside the 
lettering object. 

Duplicate letters appear below the selected shape 
in their original form. The cursor changes to an 
I-beam and appears after the last letter.

2 Click inside the duplicate lettering object and edit 
text as required.

3 Press Enter to complete.

The lettering in the Elastic Lettering is updated.

Use Elastic Lettering (Edit menu) to create special effects 
with letters.

Perspective

Straight

Diamond

Curved

Curved 
reshape 
handles

o

Click Lettering (Digitize toolbar) to edit letters in 
envelopes on-screen.

Shift+drag

Ctrl+drag



Chapter 27 : Special Lettering Features

BERNINA® Embroidery Software : Onscreen Manual 249

Removing Elastic Lettering

Return an object to its original shape by removing the 
Elastic Lettering. 

To remove Elastic Lettering

Select the lettering object.

Select Edit > Elastic Lettering > None.

The Elastic Lettering is removed and the letters 
return to their original shape.

Use Elastic Lettering (Edit menu) return an object to its orig-
inal shape.
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CHAPTER 28
MONOGRAMMING

A monogram is a design composed of one 
or more letters, typically the initials of a 
name, used as an identifying mark. The 
Monogramming feature offers a simple way 
to create personalized monograms using a 
selection of pre-defined monogramming 
styles, border shapes and ornaments, 
together with a set of tools to help you 
place these elements in creative and 
decorative ways.

This section details the creation of 
monogram lettering with initials or with a 
name, how to add ornaments to 
monograms, and how to create ornament 
layouts. It also covers adding and creating 
your own borders.

Creating monogramming designs

The Monogramming feature offers a simple way to 
create personalized monograms with minimal manual 
digitizing, using a selection of pre-defined 
monogramming styles, border shapes and 
ornaments, together with a set of tools to help you 
place these elements. The Monogramming feature 
creates a single ‘monogramming object’ comprising 
some or all of the following elements:

Lettering: a single lettering object (initials or 
name)

Ornaments: up to ten ornament sets (each of 
which may comprise multiple copies of an 
ornament or embroidery design)

Borders: up to four concentric borders.

Assuming that all elements are present, the 
monogram is stitched in the following order: borders 
(1, 2, 3, and 4), ornament sets, and lettering 
object(s).

To create a monogramming design

1 Click the Monogramming icon.

Use Monogramming (Digitize toolbar) to create per-
sonalized monograms using a selection of 
pre-defined monogramming styles, border shapes 
and ornaments.

Borders stitched 
first – 1, 2, 3, etc

Ornaments 
stitched next

Lettering 
stitched last
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The Monogramming dialog opens with the 
Lettering tab selected. This tab allows you to 
specify the characters in the lettering component 
of a monogram. Two options are available: 
Initials and Name.

The Monogramming dialog is ‘modal’ meaning 
that you are not able to select objects or operate 
any controls outside the dialog while it is open. 
However, elements specified in the dialog are 
displayed instantly in the Design Window, and any 
changes made to settings inside the dialog are 
immediately visible. The dialog also contains 
Undo, Redo and Zoom buttons. Undo reverses 
any changes made since the dialog was opened. 
The normal shortcut keys – Ctrl+Z, Ctrl+Y, Z, 
Shift+Z – can also be used while the dialog is 
open.

2 Select the type of lettering object you want to 
make:

Initials: Up to three initials can be entered, 
including special characters and symbols. See 
Creating monogram lettering with initials for 
details.

Name: This option allows unlimited lines of 
characters to be entered. See Creating 
monogram lettering with names for details.

3 Click the Ornaments tab and specify the type of 
ornamentation you want by clicking Add.

You can add up to ten ornament sets around a 
monogram. See Adding ornaments to monograms 
for details.

4 Click the Borders tab and specify the type of 
border you want by clicking Add.

You can add up to four borders of the same shape 
to a monogram design. See Adding borders to 
monograms for details.

5 Click OK to close.

Tip  You can modify selected monograms at any 
time by adjusting their settings in the 
Monogramming dialog. The dialog can be 
opened with a single monogram, and no other 
object, selected. Any modifications to the settings 
are applied directly to the selected monogram.

Note  The Ungroup command is not available 
when a Monogramming object is selected. If you 
wish to access component objects, use the Break 
Apart tool. See Splitting into component objects 
for details.

Zoom and 
Undo/Redo buttons
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Creating monogram lettering

The Monogramming tool allows you to create 
personalized monograms with up to three initials, 
including special characters and symbols, or unlimited 
lines of characters.

Creating monogram lettering with initials

Up to three initials can be entered into your 
monogramming design, including special characters 
and symbols. Change settings for each one or all 
together, or apply pre-defined layout styles.

To create monogram lettering with initials

1 Click the Monogramming icon.

The Monogramming dialog opens with the 
Lettering tab selected. The Initials option is 
selected by default.

Note  The All Letters option is selected by 
default. This means that any changes to lettering 
properties will affect all initials in the monogram. 
If you want to specify different settings for each 
one, select the button corresponding to the letter 
you want to modify before proceeding. This step is 
repeated for each letter.

2 Enter the first initial for the monogram in the 
Letter #1 field.

The letter simultaneously appears in the Design 
Window.

Note  When using a single letter, it should be 
placed in the Letter #1 field.

3 Tab to the next fields and enter second and third 
initials as required.

These letters appear in the Design Window.

4 Optionally, click the Style button and select the 
style you want from the flyout menu – scroll to the 
desired item and release the mouse button.

The current height of Letter #1 is used as the ‘base 
setting’ for the style.

Note  The Style button is only applicable to 
initials. (Style 1 is applied by default.) When the 
Name option is selected, this button is disabled. 
See also Creating monogram lettering with names.

5 Select a thread color from the Color palette.

6 Use the Alphabet dropdown list to change 
alphabets.

Note  The default values for monogram lettering 
Alphabet and Height are distinct from those for 
conventional lettering. All settings can, however, 

Use Monogramming (Digitize toolbar) to create per-
sonalized monograms using a selection of 
pre-defined monogramming styles, border shapes 
and ornaments.

Enter initials in 
each field

Enter initials in 
each field

Select layout 
style from flyout 
menu

Style 1

Style 15

Style 7

Select thread color

Select alphabet

Adjust lettering
settings

Adjust letter height
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be controlled via the Object Properties > 
Lettering tab.

7 Adjust available lettering settings as desired:

Adjust Letter Height and Color as desired. 
This height setting overrides the one in the 
Object Properties > Lettering tab.

Adjust letter rotation via the Rotate By and 
Rotate Baseline controls. These allow you 
rotate individual letters or the entire baseline.

8 Click View Properties to make any further 
adjustments to your lettering stitch properties. 
See Applying different stitch types and effects to 
lettering for details.

9 Define any ornaments and/or borders you want:

Click the Ornaments tab to specify monogram 
ornamentation. See Adding ornaments to 
monograms for details.

Click the Borders tab to specify a monogram 
border or borders. See Adding borders to 
monograms for details.

10 Click OK to complete.

Note  The zoom factor is automatically adjusted to 
show the whole monogram.

Creating monogram lettering with names

The monogram Name option allows unlimited lines of 
characters to be entered.

To create monogram lettering with a name

1 Click the Monogramming icon.

The Monogramming dialog opens with the 
Lettering tab selected. The Initials option is 
selected by default.

2 Click the Name option.

The Initials option is disabled.

3 Enter your text in the Name field.

Pressing Enter starts a new line. When more than 
one line is created, the default baseline type is 
used.

4 Click the Select Character button if you want to 
add special characters and symbols. See Adding 
special characters for details.

5 Select a thread color from the Color palette.

Color changed Height changed

Rotate by 90°

Rotate baseline by 90°

Style 1 with default 
properties

Italic 35%

Width 130%
Vertical baseline

Use Monogramming (Digitize toolbar) to create per-
sonalized monograms using a selection of 
pre-defined monogramming styles, border shapes 
and ornaments.

Select Name
option

Initials option
disabled

Select
alphabet

Click to adjust
lettering settings

Click to add
special character

Click to create
lettering
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Tip  You can edit the name using Backspace or 
Delete keys, using left and right arrow keys, or 
Home and End keys to move the insertion point.

6 Use the Alphabet dropdown list to change 
alphabets and adjust the Letter Height setting as 
required.

Note  The default values for monogram lettering 
Alphabet and Height are distinct from those for 
conventional lettering. All settings can be 
controlled via the Object Properties > Lettering 
tab.

7 Click View Properties to make any further 
adjustments to your lettering stitch properties. 
See Applying different stitch types and effects to 
lettering for details.

8 Click Create Lettering.

The monogram lettering object is added to the 
Design Window, replacing any that might already 
be there. 

9 Define any ornaments and/or borders you want:

Click the Ornaments tab to specify monogram 
ornamentation. See Adding ornaments to 
monograms for details.

Click the Borders tab to specify a monogram 
border or borders. See Adding borders to 
monograms for details.

10 Click OK to complete.

Adding ornaments to monograms

Ornaments can be added to a monogram either from 
pre-defined patterns or from any design file.

Adding ornament patterns or designs
You can add up to ten ornament sets to a monogram 
design and change them at any time. There is a 
dedicated monogram ornaments pattern set although 
any available pattern set can be used. A set of 
ornamental designs is also available. These are stored 
in their own Ornaments folder.

Tip  You can create your own ornament patterns as 
you would any other pattern using the Create 
Pattern tool. See Creating your own pattern sets for 
details.

To add ornament patterns or designs

1 Create the lettering object you want to use in your 
monogram:

Initials: Up to three initials can be entered, 
including special characters and symbols. See 
Creating monogram lettering with initials for 
details.

Name: This option allows unlimited lines of 
characters to be entered. See Creating 
monogram lettering with names for details.

2 Click the Ornaments tab.

Italic -35%

Circle CW baseline Tiffany font

Childs Play font with 
default settings

Click to add an 
ornament set
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3 Click the Add button.

The Select Source dialog opens.

Note  Up to ten ornaments can be added to the 
selection list. Any combination of positions can be 
used.

4 Choose an ornament source:

If you choose Patterns, Blackwork, 
Lacework, or Candlewicking, the Select 
Pattern dialog opens offering a library of 
pre-defined ornamental patterns.

Note  All pattern sets are available for selection as 
ornaments. You can even create your own pattern 
designs and save them to the ornament collection. 
See Creating your own pattern sets for details.

If you choose the From Design option, an 
Open dialog opens onto the Ornaments 

folder. Designs here are specifically intended 
for use as ornaments.

5 Select a pattern or design and click OK.

A new ornament set is created using the selected 
pattern and a new entry added to the list box. 

6 Select an ornament set from the list box.

Note  If you choose a pattern for the ornament 
set, the Pattern Set and Pattern fields give you 
the pattern identity. If you choose a design as the 
ornament set, a Design Name field appears.

7 Use the Positions checkboxes to add up to eight 
instances of a selected ornament.

The checkboxes are arranged to illustrate 
ornament placements relative to the lettering. 
Excluding Position #5, any combination of 
checkboxes can be used.

Note  The first position selected serves as the 
‘anchor’ position (highlighted in bold). All settings 
in the dialog relate to this ornament and all other 
ornaments are sized, rotated and mirrored in 
relation to it. See also Creating single ornament 
layouts and Creating multi-ornament layouts.

Add a design 
ornament

Add a pre-defined 
pattern

Anchor 
position

1
2

3

4 6

7 8 9
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8 Use the Width and Height fields to change 
ornament dimensions.

Tip  A Resize Proportionally checkbox (selected 
by default), forces width and height settings to 
resize in proportion to each other.

9 Use the Rotate By field to specify a rotation angle 
for the anchor object.

All other ornaments are sized, rotated and 
mirrored in relation to this object. See also 
Creating multi-ornament layouts.

10 Use the Color Blocks palette to change ornament 
colors.

The colors in the palette are shown in the 
sequence they occur in the ornaments. To change 
colors, select a slot in the Color Blocks list and 
select a color from the Color palette.

Note  The Sequence this Set by Color checkbox 
is enabled if you include two or more repetitions of 
the selected ornament. When this option is 
checked, an ornament set containing two or more 
colors is resequenced so that all like colors are 

stitched together. When unchecked, each 
ornament is stitched out individually. This may 
result unnecessary thread color changes.

11 Click the Borders tab if you want to specify a 
border or borders for your monogram. See Adding 
borders to monograms for details.

12 Click OK to complete.

Creating single ornament layouts
You can insert an ornament as a standalone element 
within an ornament set. This single ornament can be 
used on its own or combined with other ornaments or 
patterns. See also Creating multi-ornament layouts.

To create a single ornament layout

1 Create the lettering object you want to use in your 
monogram. See Creating monogram lettering with 
initials and Creating monogram lettering with 
names for details.

2 Add the ornament you want to use.

Tip  Usually for a single ornament layout, you will 
want to use one of the ornamental designs 
included in the dedicated Ornaments folder. This 
is accessed via the From Design option. See 
Adding ornaments to monograms for details.

3 Select Position #5 to insert an ornament as a 
standalone element within a set.
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All other checkboxes are unchecked automatically. 
Width, Height, and Rotate By fields remain 
available and an Offset panel appears.

4 Size and rotate the ornament as required. See 
Adding ornaments to monograms for details.

5 Use the X and Y fields in the Offset panel to 
position the ornament horizontally or vertically 
relative to the lettering object.

These settings specify the position of the 
ornament center relative to the center of the 
lettering object.

6 Click the Borders tab if you want to specify a 
border or borders for your monogram. See Adding 
borders to monograms for details.

7 Click OK to complete.

Creating multi-ornament layouts
You can add up to eight instances of a selected 
ornament to your monogram. Any combination of 
ornaments and ornament positions can be used.

Choose from a range of pre-defined layout styles, 
including Mirrors, Duplicates, and Cycle. You also 
have the option of flipping the anchor ornament 
horizontally or vertically.

To create a multi-ornament layout

1 Create the lettering object you want to use in your 
monogram. See Creating monogram lettering with 
initials and Creating monogram lettering with 
names for details.

2 Add the ornaments you want to use. See Adding 
ornaments to monograms for details.

3 Use the Positions checkboxes to add up to eight 
instances of a selected ornament.

The checkboxes are arranged to illustrate 
ornament placements relative to the lettering. 
Excluding Position #5, any combination of 
checkboxes can be used.

Note  The first position selected serves as the 
‘anchor’ position (highlighted in bold). All settings 
in the dialog relate to this ornament and all other 
ornaments are sized, rotated and mirrored in 
relation to it.

4 Size and rotate the anchor ornament as required. 
See Adding ornaments to monograms for details.

5 Use the Distance From Lettering field to specify 
the distance ornaments are offset from the 
lettering object.

Tip  The software allows you to enter a negative 
offset.

6 Use the Layout Style dropdown list to select a 
style for the ornament arrangement – Mirrors, 
Duplicates, or Cycle.

Positions are laid out for each layout style in 
relation to the anchor object, regardless of any 
positions omitted from the set.

Specify ornament offset
from lettering object

Distance from lettering

Anchor
position

1 2 3

4 6

7 8 9
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Mirrors:

Duplicates:

Cycle:

7 Flip the entire configuration horizontally and/or 
vertically as required.

Horizontal:

Vertical:

Horizontal and Vertical:

8 Click the Borders tab if you want to specify a 
border or borders for your monogram. See Adding 
borders to monograms for details.

9 Click OK to complete.

Adding borders to monograms

You can add up to four borders of the same shape to 
a monogram design.

Creating multiple borders
The Select Border dialog offers a list of pre-defined 
border shapes. You can also create your own to add 

Flip horizontally
or vertically
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to the built-in collection. See Creating custom borders 
for details.

To create multiple borders

1 Create the lettering object you want to use in your 
monogram:

Initials: Up to three initials can be entered, 
including special characters and symbols. See 
Creating monogram lettering with initials for 
details.

Name: This option allows unlimited lines of 
characters to be entered. See Creating 
monogram lettering with names for details.

2 Add any ornaments you want. See Adding 
ornaments to monograms for details.

3 Click the Borders tab.

4 Click the Add button.

The Select Border dialog opens offering a library 
of pre-defined border shapes.

Tip  You can create you own border shapes using 
the Closed Object tool and save them to the 
border collection. See Creating custom borders for 
details.

5 Choose a border from the dialog and click OK.

A new entry is added to the border list box and the 
selected border appears in the Design Window.

6 Use the Offset field to adjust space between 
lettering and border.

Tip  The software allows you to enter a negative 
offset. This allows you to create multiple 
overlapping borders.

7 Click the Add button again to add up to four more 
borders.

Each time you click, a new entry is added to the list 
box and another border of the same shape is 
added to your design.

Tip  If you want to change the border shape, click 
the Change button and select a different border 
from the Select Border dialog. Any change 
affects all borders in the design.Select 

border

Offset from 
lettering object

Adjust border 
offset 

Click to add
more borders

Click to change
border shapes

Adjust Offset
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8 Use the Offset field to adjust spacing between 
borders.

9 Use the Color palette to adjust the colors of 
selected borders.

10 Use the Outline and Fill tool buttons to change 
outline or fill stitch type for selected borders.

By default, Satin Outline is the default stitch type. 
When Fill is selected, Step is selected as the 
default fill stitch. All outline and fill stitch types 
available in the software can be used as borders.

11 Use the Aspect Ratio field to change the ratio of 
height to width for all borders.

By adjusting this value, you adjust height and 
width in relation to one another and thereby make 
the border fatter or taller. The default is 1.00 which 

means that the border height and width are as per 
the original.

12 Click View Properties to make any further 
adjustments to your border stitch properties. See 
Outline & Fill Stitches for details.

13 Click OK to complete.

Creating custom borders
The Select Border dialog offers a list of pre-defined 
border shapes. You can also create your own to add 
to the library. These can be saved to the default 
‘Borders’ set or one of your own creation. Borders 
must be closed and, by default, Satin is always used 
as the default border stitch type. This can be changed 
once the border is selected in the Monogramming 
dialog.

Tip  Like borders, you can create your own ornament 
patterns for use in monograms using the Create 
Pattern tool. See Creating your own pattern sets for 
details.

To create your own border

1 Select the closed embroidery object you want to 
save as a border.

2 Select Settings > Create Border.

2nd border offset: 4 mm
3rd border offset: 2 mm

2nd border offset: 4 mm
3rd border offset: 6 mm

Change colors

Change
outline or fill
stitch types

First border: Pattern FillFourth border: Pattern Run

Aspect Ratio: 0.70

Aspect Ratio: 1.30
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The Make Border dialog opens.

3 Select a border set from the list.

Optionally, click New Set to define a new border 
set. Enter a name and click OK.

4 Enter a name for your new border and click OK.

You are prompted to digitize the start and end 
points of the border.

5 Click to mark two reference points on the border.

Reference points set the standard orientation of 
the border.

6 Click OK.

The new border is saved to the border set and a 
confirmation message displayed.

Enter name for
new border

Select border set

Cloud

My Borders

Mark reference 
points

1 2
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PART VII
DESIGN PROCESSING & OUTPUT

At some stage you will actually want to output your designs to printer, machine, or 
storage device. For this, you will need an understanding of the different print options, 
embroidery file types and the storage media available.

Outputting designs

This section describes how to print worksheets, appliqué patterns, color films, and 
thread charts. It also covers stitching out designs, both singly and as multi-hooped 
designs. See Outputting Designs for details.

Reading and writing design files

This section describes how to select conversion options for opening and saving different 
stitch and outline design formats. It also deals with storing designs to design card. It 
also discusses storing designs with Magic Box. See Reading & Writing Design Files for 
details.
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CHAPTER 29
OUTPUTTING DESIGNS

You can output embroidery designs in a 
variety of ways – by printing as worksheets, 
as appliqué patterns, color films, or as thread 
charts. BERNINA Embroidery Software also 
allows you to save your designs as images for 
use with fabric and garment applications. You 
can also send them directly to machine for 
stitching. When working with designs that are 
larger than the available physical hoop, you 
can split them into parts, each containing an 
object or group of objects. The software 
automatically calculates which files are to be sent and shows you how they will 
look.

This section describes how to print worksheets, appliqué patterns, color films, and 
thread charts. It also covers stitching out designs, both singly and as 
multi-hooped designs.

Printing designs

You can create a hard copy of your designs using 
default or custom printer options. Preview designs 
before printing. Set print options to display the 
information you require. If you are using a color 
printer, you can print in Artistic View. Even print 
thread charts as a shopping reference when 
purchasing threads. See also Printing and publishing 
designs with BERNINA Portfolio.

Previewing and printing worksheets

Use Print Preview to view stitching information. Use 
it to check the sewing sequence before you stitch out 
your design. You can create a hard copy of your 
designs using default or custom printer options.

To preview and print a worksheet

1 Click the Print Preview icon.

Your design displays as it will be printed. Large 
designs may be displayed over a number of pages 
if printed at actual size. 

2 Use the Preview buttons as required:

Use Print Preview (General toolbar) to preview a 
design before printing.

Use Print (General toolbar) to print a design.

Field Description

Next Page View the next page.

Prev Page View the previous page.
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3 Click Options to set any Print Options. See 
Setting print options for embroidery for details.

4 Click Print Now to proceed with printing.

The MS Windows® Print dialog opens allowing 
you to choose a printer and adjust any other print 
settings you require. See also Setting print options 
for embroidery.

5 Click Close to return to the Design Window.

Setting print options for embroidery
Print options provide precise control over your design 
printout. You can include information about design 
size, color sequence, and stitch count, together with 
a picture of the design. There are options to include 
or exclude start/end point crosshairs, connectors, 
background color/fabric and the current hoop in 
Artistic View. Design information includes author, 
estimated length of upper thread per color and total 
bobbin usage.

Note  You have the option of printing the whole 
design or selected objects only. If the latter, you need 
to select the objects before accessing the Print 
Options dialog.

To set print options for embroidery

1 Select File > Print.

The Print dialog opens.

2 Select a printer from the Name list.

3 Type the number of copies you want to print and 
other printing information.

4 Click Options to change the size of the picture, 
the type of view or the items to be included.

The Print Options dialog opens.

5 Choose whether to print the whole design or 
selected objects only.

Note  The Selected Objects option is only 
available if you have already selected the objects 
you want to print.

6 Select the Embroidery option in the Elements 
panel if not already selected.

All embroidery stitches are shown by default in 
normal (Stitch View) display mode.

7 Select Artistic View to print the design in Artistic 
View.

8 Include other options as required:

Two Page Display two pages in the Preview Win-
dow. 

Portrait / 
Landscape

Toggle design display between land-
scape and portrait views.

Zoom In / Out Use to examine portions of the design or 
to read production information.

Field Description

Select
embroidery

elements to print

Print whole
design or

selected objects
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Hoop: The hoop is included in the printout.

Picture: The design is printed with the picture 
behind it.

Connectors: All connecting stitches in the 
design are displayed even if the current 
Selection option is Selected Objects.

Tip  Connectors may be used as a guide when you 
save an ART design into multiple files to be output 
for multi-hooped positioning.

Note  In Artistic View the Connectors option is 
disabled – i.e. you cannot view connecting stitches 
in Artistic View.

Start/End Crosshairs: The start/end needle 
position is included in the printout.

Background Color/Fabric: The background 
page is filed with a color or a fabric image 

according to the current Fabric Display 
setting. See Changing backgrounds for details.

9 Select a size option from the Size panel:

Actual Size: the design is printed at the same 
size it will be stitched.

Fit to Page: large designs will be reduced to fit 
the printing paper, small designs will be 
enlarged.

% of Actual: The design view is resized 
according to this setting.

10 Click OK.

Printing appliqué patterns
Print a copy of the appliqué pattern to use to cut out 
the fabric pieces. Each appliqué pattern piece is 
numbered according to the stitching sequence.

To print an appliqué pattern

1 Select File > Print Preview.

2 Click Options icon.

Print Options dialog opens.

70 % of 
actual size

150 % of 
actual size
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3 Select the Appliqué Pattern checkbox.

4 Click OK.

Each appliqué pattern piece is numbered 
according to the stitching sequence.

Note  If the Actual Size option is selected, both 
an assembled appliqué layout and individual 
patterns in the actual size are created on separate 
pages. If the Fit to Page or % of Actual options 
are selected, the assembled appliqué layout is 
created in the selected size, but individual patterns 
are still printed in the actual size on separate 
pages.

5 Click Print.

Printing Color Film
The Color Film option lets you include a list of color 
layers in the current design, together with color and 
stitch information for each layer.

To print a Color Film

1 Select File > Print Preview.

2 Click Options icon.

The Print Options dialog opens.

3 Select the Color Film checkbox.

4 Click OK.

The following information is included:

Select to print
appliqué pattern

Appliqué 
Assembly 
page

Appliqué 
Patterns page

Field Description

Number Number in the stitching sequence.

Color Color name listed in the associated thread 
chart.

Code Thread code for ease of ordering.

Brand Thread brand – e.g. Isacord 40.

Stitches Total stitch count for individual color layer.

Thread 
Used

Total stitch length of the individual color 
layer in the measurement unit currently set 
for the system – e.g. ‘meters’.

Check to print
color film

#: 3.
Color: Black
Code: 0020
Brand: Isacord 40
Stitches: 1214
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Note  The information displayed here is the same 
as the information displayed in the Thread Colors 
dialog. See Assigning thread colors for details.

5 Click Print.

Printing multi-hooped designs
If there is more than one hooping in the design, you 
have the option of printing hoops in multi-hooping 
view in their correct color sequence. The Hooping 
Sequence option allows you to print a Color Film 
type printout showing the objects in each hooping. 
See also Creating multi-hoop designs.

To print a multi-hooped design

1 Select File > Print Preview.

2 Click Options icon.

The Print Options dialog opens.

3 Select the Hooping Sequence checkbox.

4 Click OK.

The following information is included showing the 
objects in each hooping.

Note  The information displayed here is the same 
as the information displayed in the Hooping 
Sequence dialog. See Saving multi-hooped 
designs for details.

5 Click Print.

Printing thread charts

Thread color
details

Check to print
hooping sequence Select Thread Colors (Settings menu) to print thread charts.
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The Thread Chart > Print option allows you to print 
the thread list in the current thread chart as a 
shopping reference when purchasing threads.

To print a thread chart

1 Select Settings > Thread Colors.

The Design Properties > Thread Colors dialog 
opens.

2 Select a thread chart from the Thread Chart list. 

3 Click the Print button.

A Print Preview page opens displaying a printed 
form of the selected thread chart in the current 
sorting order.

This printable thread chart includes the Thread 
Chart name, Code, Brand, and Description.

4 Click Print Now to proceed with printing.

The MS Windows® Print dialog opens allowing 
you to choose a printer and adjust any other print 
settings you require.

5 Use the tick boxes in the printed document to 
mark off any threads you want to purchase. There 
is also a Memo field for notes.

6 Click Print.

Saving designs as images

The Save Design as Image command allows you to 
save design images for use with your fabric and 
garment application. The resulting image is exactly as 
it appears on screen, including connectors, stitch 
cursor, grid, as well as any backdrop. The hoop, 
however, does not appear in the image file even if it 
intersects objects within the design.

To save a design as an image

1 Switch to Embroidery Canvas mode.

2 With the design still open in the Design Window, 
select File > Save Design as Image.

The Save Design as Image dialog opens. By 
default, PNG is the selected file type.

3 Deselect the Make Background Transparent 
option as required.

This option is only available when PNG is the 
selected file type. When checked (the default), the 
grid and background are excluded from the saved 
image and only design objects appear.

4 Click Save.

The current design is saved as an image file.

Note  If the Design Window is zoomed at the time 
of saving, the saved file still includes the whole 
design even if larger than the Design Window.

Stitching out designs

Select thread
chart to print

Click to print chart

Use Write to Machine (General toolbar) to send a 
design to machine.

Stitch View with grid Artistic View with fabric
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Use Write to Machine to send a design directly to 
your BERNINA embroidery machine ready to stitch. 
See also Writing designs to machine.

Tip  Check the sewing sequence before you stitch a 
design as you need to know the color sequence. Use 
Print Preview to view stitching information. See 
Previewing and printing worksheets for details.

To stitch out a design

1 Switch to Embroidery Canvas mode.

2 Check that the design fits the hoop. Use the 
smallest hoop possible. See Changing hoops for 
details.

3 Click the Write to Machine icon.

If this is the first time you have downloaded a 
design after turning on the machine or Reader box, 
the Bernina Device Selection dialog opens.

4 Select an embroidery machine type and COM port 
if prompted to do so.

5 Click OK.

If the machine connection is working, the Write to 
Embroidery System dialog opens. The name and 
the thumbnail of your design are displayed.

6 Click Stitch out Selected Design.

The Writing file(s) to device dialog displays, 
followed by a confirmation message. The design is 
sent to your embroidery machine ready for 
stitching.

Note  When you send designs directly to machine, 
they will be lost when the machine is turned off. 
Apart from saving to hard disk, floppy disk or 
archiving to CD, you can also preserve designs by 
writing them to a variety of storage devices. Saved 
designs can then be retrieved for editing. See also 
Reading & Writing Design Files.

Outputting multi-hooped designs

When working with designs that are larger than the 
available physical hoop, you can split them into parts 
in Hoop Layout mode, each containing an object or 
group of objects. When a multi-hooped design is 

Select embroidery 
machine type

Click to stitch out
selected design
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output, each part is stitched separately after the 
fabric has been re-hooped. See also Hooping large 
designs.

The following commands are all available in Hoop 
Layout mode:

Save As

Write to Machine

Card/Machine Write

Write to Magic Box

When any of these commands is invoked, 
multi-hoopings and split lines are applied. Hooping 
Sequence mode is activated, showing the separate 
hoopings. In the case of the Save As command, 
however, Hooping Sequence mode is only activated 
if you choose to export split files. See also Printing 
multi-hooped designs.

Sending multi-hooped designs to machine

With a multi-hooped design, you can send one or 
more stitch files to sewing machine or memory card. 
The software automatically calculates which files are 
to be sent and shows you how they will look. See also 
Hooping large designs.

To send a multi-hooped design to machine

1 Switch to Hoop Layout mode and create your 
multi-hooped design. See Hooping large designs 
for details.

2 Ensure that the embroidery machine or reader box 
have been correctly attached.

3 Click the Write to Machine icon.

The system checks whether there is only one hoop 
in the design and if all objects are covered.

If some objects are uncovered, you are asked 
whether you want to continue or otherwise.

If there is more than one hoop, the system 
checks that all objects are covered. All Use Write to Machine (General toolbar) to send a 

design to machine.
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hoopings needed to stitch the design are 
displayed in Hooping Sequence mode.

Once in Hooping Sequence mode, all toolbars 
are hidden, leaving only the Hooping Sequence 
dialog. This displays a list of all hoopings required 
to stitch the design.

Note  Fabric in covered appliqués is hidden, 
leaving stitchable items only. 

4 Select any hooping in the list.

The newly selected hooping is shown as a dotted 
line surrounded by a solid line, while the other 
hoop positions are shown as dotted lines only. 
Objects within the selected hooping are shown in 
their actual stitch colors. Objects to be stitched 
before or after are shown as mid- and light-grey 
outlines respectively.

5 Click the Send Now button.

The system outputs a file containing everything to 
be stitched within the current hooping.

6 Repeat this process as many times as necessary to 
send all hoopings.

7 Click Close to end.

Note  Registration marks are red for the first file 
and green for any additional files.

Saving multi-hooped designs
If more than one hooping is needed to cover your 
design, you may split it into separate files for each 
one. See also Hooping large designs.

To save a multi-hooped design

1 Switch to Hoop Layout mode and create your 
multi-hooped design. See Hooping large designs 
for details.

2 Select File > Save As.

A standard MS Windows® Save As dialog appears 
allowing you to browse to any folder, choose any 

Objects to be sewn 
after this hooping 
shown as light grey 
outlines

Objects already 
sewn shown as 
dark grey outlines

Objects to be sewn 
in this hooping 
shown in actual 
stitch colors

List of
hoopings in

current
design

Hoop
position

colors match
display

colors of
hoops
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name for the exported file, and choose a file 
format from a dropdown list.

3 Change the file name as required, and choose a 
destination folder and/or file format, and click 
Save.

If more than one hoop position is detected, you 
are prompted to split the design into multiple 
files, or export everything to a single file.

If the system detects that not all objects in the 
design are covered by hoop positions, you are 
asked whether you want to continue.

4 If you decide to export a file for every hooping, 
click Yes.

The system checks that all embroidery objects are 
covered. You will be warned if they are not. 
Otherwise, all hoopings needed to stitch the 
design are calculated and displayed in the 

Hooping Sequence dialog. Hoopings are named 
as files with the chosen file extension.

5 Select a hooping and click Save.

All embroidery objects associated with the chosen 
hooping are saved to file as named in the list. 
Alternatively, click Save All. All files in the list, 
named as shown, are saved.

Outputting designs with split lines
The Splitting Guide tool allows you to digitize one or 
more split lines in a multi-hooped design prior to 
outputting to file, machine or memory card. Although 
split lines are only visible in Hoop Layout, they are 
maintained when switching to other modes. Split lines 
do not have any permanent effect on objects prior to 
output. See also Splitting objects between hoopings.

Save, Save
All and
Cancel
buttons

displayed

Hoopings
shown as file

names with
extensions
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To output designs with split lines

1 Select the Save As, Write to Machine, or Write 
to Magic Box command.

If you select the Save As command, the Multiple 
Hoopings dialog is displayed.

2 Click Yes to export one file for every hooping or 
No to export everything to a single file.

BERNINA Embroidery Software applies the split 
lines and activates the Hooping Sequence 
dialog, showing the objects in their split state in 
their respective hoops.

3 If you selected Save As, you can Save each split 
design individually or Save All at once.

BERNINA Embroidery Software outputs the split 
designs to their individual files.

4 Click Close.

BERNINA Embroidery Software exits Hooping 
Sequence mode and displays the design in the 
Design Window in its original state - with split lines 
but with objects un-split.
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CHAPTER 30
READING & WRITING DESIGN FILES

By default BERNINA Embroidery Software saves 
designs to its native ‘ART’ file format. This format 
contains all information necessary both for 
stitching a design and for later modification. 
However, BERNINA Embroidery Software can open 
and save designs in other formats as well. When 
doing so, BERNINA Embroidery Software converts 
design data so you can modify it using the full 
range of software features.

When you send designs directly to machine, they 
will be lost when the machine is turned off. Apart 
from saving to hard disk, floppy disk or archiving to 
CD, you can also preserve designs by writing them 
to embroidery machine memory, design card, or USB memory stick. If you have 
a Magic Box, you can read from and write to other design cards as well.

Note  If you intend to stitch a design immediately, send it directly to the machine. 
See Stitching out designs for details.

This section describes how to select conversion options for opening and saving 
different stitch and outline design formats. It also deals with storing designs to 
design card. It also discusses storing designs with Magic Box.

Embroidery design formats

BERNINA Embroidery Software opens and saves pure 
ART format designs as well as a number of non-native 
formats. Other format designs which can be read into 
BERNINA Embroidery Software are generally 
‘stitch-based’. This means they were not created 
object-by-object but stitch-by-stitch. When you open 
other formats into BERNINA Embroidery Software, 
the software reads the data and, depending on your 
settings, attempts to determine object outlines and 
properties so that you can modify the designs like 
native ones.

ART files
Native ART designs, called ‘ART Grade A’, contain a 
complete set of design information in a single file – 
object outlines and properties, actual stitches, thread 
colors, a picture icon and comments. There are three 

other grades of ART file, depending on how the ART 
file was created – Grade B is more reliable than Grade 
C, but not as good as Grade A format, and Grade D is 
the least reliable. It goes without saying that only ART 
Grade A files provide 100% perfect scaling and 
transformation. 

File source Description

Art Grade A Pure ART file created in BERNINA Embroi-
dery Software-based software. These files 
contain pure ART objects, outlines and 
stitches.

Art Grade B Designs read from outline format such as 
GNC and saved in ART format. Such 
designs cannot be read directly in BERN-
INA Embroidery Software but once con-
verted to ART in other software, BERNINA 
Embroidery Software reads them as Grade 
B designs.
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All files saved in ART format are automatically 
compressed when saved, and decompressed when 
re-opened. This reduces the storage space required, 
and makes it possible to save large files to floppy disk, 
or send them as email attachments.

Tip  For information about the source of a design file, 
refer to the Open dialog or the Design Properties 
dialog. See Viewing design information for details. 
See also Opening designs.

Stitch files
Different embroidery machines understand different 
languages. Each has its own control commands for 
the various machine functions. Before you can stitch 
a design, it must be in a format which can be 
interpreted by the machine. Stitch or ‘expanded’ 
designs are low-level formats for direct use by 
embroidery machines. They contain only stitch 
coordinates and machine functions. They are 
generally created ‘on the fly’ when sending designs to 
machine. They can also be output to embroidery disk 
or design card.

When read into BERNINA Embroidery Software, stitch 
files do not contain object information such as 
outlines or stitch types, but present the design as a 
collection of ‘stitch blocks’. Stitch blocks are created 
wherever colors change or trims are detected in the 
design. Stitch designs are generally not suited to 
modification because stitches are not regenerated. 
You will be warned if the design you are opening 
should not be scaled.

Tip  You can make this warning display when opening 
designs by selecting Help > Show Design Warning.

Comparison of outline and stitch file 
formats
BERNINA Embroidery Software uses the native ART 
embroidery file format which combines the 
advantages of both outlines and calculated stitches. 

The table below shows the type of data found in ART 
files compared with stitch files.

Converting stitch files

When you scale a pure ART design, you change the 
number of stitches needed to fill the shape. BERNINA 
Embroidery Software recalculates and redraws all 
stitches automatically. This is called ‘stitch 
processing’ and it ensures that the design you see 
on-screen appears as it will be stitched. While stitch 
designs are generally not suited to modification, 
BERNINA Embroidery Software can interpret object 
outlines, stitch types and spacing from stitch data 
with some success. When you open a stitch file, it is 
converted by default to a Grade C ART file. Converted 
designs can be scaled and stitches recalculated.

Opening without conversion

You can choose to open stitch files without 
conversion. Designs opened in this way can be output 
for stitching in other formats. Or you can edit stitches 
and add new elements. There is nothing to stop you 
scaling stitch format designs which have been opened 
without object conversion. However, because the 
stitch count does not change, the density increases or 
decreases with the design size. Thus you should not 
scale stitch designs by more than ±5% or some areas 
may be too thickly or too thinly covered.

Note  With or without object conversion, stitch files 
can be still saved in ART format once they are opened 
in BERNINA Embroidery Software.

Art Grade C Designs read from stitch files – SEW, PCS, 
PES, etc – where stitches have been con-
verted to objects. See Opening files with 
conversion for details.

Art Grade D Designs read from stitch files – SEW, PCS, 
PES, etc – where stitches have NOT been 
converted to objects. See Opening files 
without conversion for details.

File source Description

Included in file Stitch files ART files

Object properties No Yes

Stitch data No Yes

Stitch types No Yes

Includes stitch coordinates Yes Yes

Thread colors Some Yes

Comments No Yes

Pull compensation settings No Yes

Auto spacing settings No Yes

Original stitch design

Scaled stitch design
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Recalculating converted stitch files
When an ART design is created by opening a stitch file 
with stitch processing, the original stitches are 
maintained until you change them. You can guarantee 
that the design will stitch as originally made. 
However, if you scale the design or do anything which 
forces stitches to be recalculated from new estimated 
outlines, there may be significant differences from the 
original stitches.

Supported embroidery file formats
BERNINA Embroidery Software supports the following 
specific file formats:

Note  BERNINA Embroidery Software will convert 
designs to non-native home formats which are 
current at the time of development. Later releases of 
other-brand software may not produce compatible 
formats of the same file types.

Opening design files

BERNINA Embroidery Software can open supported 
design files stored on your PC from a variety of 
sources – hard disk, floppy disk, USB memory stick, 
or CD ROM. Once opened, they can be checked or 
edited before sending to machine for stitchout or 
storage. See also Supported embroidery file formats.

Opening files with conversion

Stitch files are converted to outlines and objects by 
default upon opening. BERNINA Embroidery Software 
interprets object outlines, stitch types and spacing 
from stitch data with some success. When you open a 
stitch file with object conversion, the design is 
converted to a Grade C ART file. Converted designs 
can be scaled and stitches recalculated. While 
processing is effective for most stitch designs, it 
cannot produce the same level of quality as original 
outlines and may not handle some fancy stitches.

Grade Source Open method Contains

A ART Open normally Outlines and 
stitches

B non-native out-
line file saved 
as ART

Open normally Converted out-
lines and 
stitches

C EXP or DST file 
saved as ART

Open with object 
conversion on

Estimated out-
lines and con-
verted stitches

D EXP or DST file 
saved as ART

Open with object 
conversion off

No outlines and 
individual 
stitches

Format File Grade Read Write

V6.0 BERNINA 
Embroidery Software

ART60 A

V5.0 BERNINA 
Embroidery Software

ART50 A

BERNINA A730/A200 
designs

ART A

BERNINA USB Stick EXP

V1.x Explorations Projects ART42 A

V4.0 artista Designs ART ^

artista Cross Stitch ARX D ‡

Deco, Brother, Babylock PEC C

Deco, Brother, Babylock PES C

Elna Xpressive EMD C

Husqvarna / Viking HUS C

Husqvarna / Viking SHV C *

Husqvarna Viking / Pfaff VP3 C

Husqvarna Viking / Pfaff VIP C

Janome / Elna / Kenmore SEW C

Melco EXP C

^ V1, V2 and V3 ART no longer supported for write ‡ Cross 
Stitch program only † Quilter program only * Save back as 
SHV but not convert to SHV

Pfaff PCS C

Pfaff PCD C

Pfaff PCQ C

Pfaff PCM C

Poem, Huskygram, 
Singer EU

CSD C

Singer XXX C

Tajima DST C

artista Templates AMT A

V6.0 BERNINA Embroi-
dery Software templates

AMT60 A

artista Quilter ARQ D † †

Use Open (General toolbar) to open an existing 
design.

Format File Grade Read Write

^ V1, V2 and V3 ART no longer supported for write ‡ Cross 
Stitch program only † Quilter program only * Save back as 
SHV but not convert to SHV
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Tip  To ensure object outlines, stitch types, stitch 
density and colors are correct, it is always a good idea 
to check and edit designs after conversion.

To open a file with conversion

1 Click the Open icon to open from your hard disk, 
or read from disk or design card.

The Open dialog opens.

2 Select a folder from the Look In list.

3 Select a stitch format from the Files of Type list 
and select a file to open. See Supported 
embroidery file formats for details.

4 Click Options.

The Open Options dialog opens.

5 Select the Convert Stitches Into Object 
Shapes checkbox.

6 Click OK and then Open.

The selected design is processed and converted to 
objects with fill or outline stitch properties as well 
as general properties. If an object is not 
recognized, it has general properties only.

Opening files without conversion

Occasionally you may want to turn off stitch 
processing. For example, you may have used special 
effects or made manual edits to stitches, which will be 
lost when stitch processing occurs as you scale the 
design. You can switch off stitch processing for each 
design as you open it. By opening a stitch file without 
object conversion, you can output the design without 
change, edit individual stitches, and perform minor 
scaling and transforming actions without losing the 
original stitch information. When you open stitch files 
without object conversion, the design is converted to 
a Grade D ART file.

To open a file without conversion

1 Click the Open icon to open from your hard disk, 
or read from disk or design card.

The Open dialog opens.

2 Select a folder from the Look In list.

3 Select a stitch format from the Files of Type list 
and select a file to open. See Supported 
embroidery file formats for details.

4 Click Options.

Select stitch format

Select to convert
stitches into

object shapes

Use Open (General toolbar) to open an existing 
design.

Stitches processed
(ART Grade C)
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The Open Options dialog opens.

5 Select Leave Stitches As Individual Stitches to 
switch off stitch processing.

6 Click OK and click Open.

The design opens as a collection of stitches with 
only general properties.

Reading designs from machine

You can read designs into BERNINA Embroidery 
Software from a variety of sources, both on your 
computer and embroidery machine. Once opened, 
they can be checked or edited before saving to hard 
disk, or sending to machine for stitchout or storage. 
When reading designs from machine, three options 
are available:

Embroidery machine: Most machines allow 
designs to be stored to and read from machine 
memory. This is like having a built-in design card.

Design card: Designs can also be stored on a 
design card attached to your embroidery machine 

(or Embroidery Card Reader/Writer Box). See also 
Storing designs with Magic Box.

USB memory stick: Designs can also be read 
from a USB memory stick attached to your 
machine. See also Writing designs to machine.

Note  USB memory sticks can also be attached 
directly to your PC and designs read into BERNINA 
Embroidery Software. See Opening design files for 
details.

To read designs from machine

1 Open a new, blank file.

2 If you intend to read designs from card or USB 
stick, insert the storage device in the machine (or 
Embroidery Card Reader/Writer Box).

Note  For connection details, see the instructions 
which came with your Embroidery Card 
Reader/Writer Box.

3 Select File > Card/Machine Read.

Select to leave
stitches as

individual

Stitches processed
(ART Grade D)
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If this is the first time you have downloaded a 
design after turning on the machine or reader box, 
the Bernina Device Selection dialog opens.

4 Select an embroidery machine or reader box, as 
well as COM port if prompted to do so.

5 Click OK.

If the machine connection is working, the Write to 
Embroidery System dialog opens. The name and 
thumbnail image are displayed.

The Read from Embroidery System and 
Design Manager dialog opens.

6 Select the required storage source by clicking the 
corresponding button – embroidery machine, 
design card, or USB memory stick.

When you select a button, all folders and designs 
currently stored on the device are displayed.

Tip  Right-click the design icon to access a popup 
menu – use it to rename, delete, or view design 
properties.

7 Click a folder tab (if more than one) and/or folder 
to locate the design.

Tip  Use the icons on the right of the display panel 
to create new folders or navigate the folder 
structure.

8 Select the design.

A preview image is displayed in the Selected 
Design panel.

9 Use the display panel buttons as required to:

Open the design directly into BERNINA 
Embroidery Software for editing.

Rename the design.

Delete the design.

Access design properties.

10 Select a destination folder on the hard disk where 
the design is to be stored.

11 Click the Download arrow button to read the 
design and save to hard disk.

Select device 
type

Select
storage
device
Select
design

Select hard
drive

destination
Click to

download

Select folder
tab

Create new
folders

Right-click to
access popup

menu

Click to open design in 
BERNINA Embroidery Software

Click to access 
design properties

Use folder buttons to
navigate folders and

create new ones

Select
destination

folder
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Note  You can write designs of the appropriate 
format from hard disk to the storage device using 
the Upload arrow button.

Tip  You can also open designs from design cards 
using the Magic Box. See Storing designs with 
Magic Box for details.

Writing designs to machine

If you intend to stitch designs only when the machine 
is connected to your computer, store them on your PC 
hard disk. However, you can also use the Write to 
Machine command to save designs for later use, 
independent of your PC. Designs from any storage 
device – embroidery machine, design card, or USB 
memory stick – can then be stitched out as many 
times as you like. This eliminates the need for the PC 
to be connected to the machine during stitchout. See 
your BERNINA embroidery machine documentation 
for details.

Note  You can also store designs permanently using 
the Magic Box. See Storing designs with Magic Box for 
details.

To write designs to machine

1 Open the design and select Stitch View. See 
Opening designs for details.

Note  The machine (or external Embroidery Card 
Reader/Writer Box) must be switched on before 
you insert the card, otherwise designs will not 
display or be loaded to the machine.

2 If you intend to write the design to card or to USB 
stick, insert the storage device in the machine (or 
Embroidery Card Reader/Writer Box).

For connection details, see the instructions which 
came with your Embroidery Card Reader/Writer 
Box.

3 Click the Write to Machine icon.

If this is the first time you have downloaded a 
design after turning on the machine or reader box, 
the Bernina Device Selection dialog opens.

4 Select an embroidery machine or reader box, as 
well as COM port if prompted to do so.

5 Click OK.

Use Write to Machine (General toolbar) to write 
(save) a design to machine embroidery machine, 
design card, or USB memory stick.

Click Show Stitches (General toolbar) to toggle stitch 
view on/off.

Use Upload arrow button 
to write selected designs 
from hard disk to storage 
device

Select device 
type
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If the machine connection is working, the Write to 
Embroidery System dialog opens. The name and 
thumbnail image are displayed.

6 Select the required storage device by clicking the 
corresponding button – embroidery machine, 
design card, or USB memory stick. 

When you select a button, all folders and designs 
currently stored on the device are displayed.

7 Click a folder tab (if more than one) and/or folder 
to select where the design is to be saved.

Tip  Use the icons on the right of the display panel 
to create new folders or navigate the folder 
structure. Right-click the design icon to access a 
popup menu – use it to rename, delete, or view 
design properties.

Caution  Make sure the needle arm on your 
machine is up before downloading designs.

8 Click the Download arrow button to write the 
design.

The machine touch screen goes blank while the 
download takes place. Once the design is saved to 
the selected device, you can stitch it at any time 

without a PC connected to your machine. See your 
BERNINA embroidery machine documentation for 
details.

Writing designs directly to USB stick

Designs can be saved to a dedicated BERNINA or 
OESD USB memory stick attached directly to your PC. 
While you can copy designs directly from your hard 
disk to memory stick via MS Windows® Explorer, you 
should do so via BERNINA Embroidery Software. 
While saving the design, BERNINA Embroidery 
Software automatically converts it to the correct 
format for stitchout.

Note  Other types of memory stick can be used but 
they are not recognized automatically by the 
software.

To write a design directly to USB stick

1 Open the design and select Stitch View. See 
Opening designs for details.

2 Insert a BERNINA or OESD USB memory stick 
directly into a USB port on your PC.

3 Click the Write to Machine icon.

Write to 
design card

Select
folder tab

Click to download
selected design

Design to be
stored

Write to 
USB stick

Write to memory
module

Indicates
current
storage

device usage

Select folder
tab

Select folder

Create new foldersRight-click to access
popup menu

Use Write to Machine (General toolbar) to write 
(save) a design directly to a memory stick.

Click Show Stitches (General toolbar) to toggle stitch 
view on/off.
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If this is the first time you have downloaded a 
design after turning on the machine or reader box, 
the Bernina Device Selection dialog opens.

Tip  If you are already connected to a embroidery 
system, click the Connected Device button in the 
Write to Embroidery System dialog in order to 
access the Bernina Device Selection dialog. See 
also Writing designs to machine.

4 Select the appropriate BERNINA USB Stick 
option for the embroidery system that will be used 
to stitch out the design and click OK.

If you have inserted a memory stick other than 
BERNINA or OESD, the Enter Drive Letter and 
Path dialog opens prompting you for the device 
location.

5 Browse for the device location on your PC as 
required.

If the machine connection is working, the Write to 
Embroidery System dialog opens. The name and 
the preview of your design are displayed. Folders 

and designs currently saved on the device are also 
displayed.

6 Select the location the design is to be stored.

Tip  Use the icons on the right of the display panel 
to create new folders or move up a level in the 
folder structure. Right-click design files already 
stored to access a popup menu – use it to rename, 
delete, or view design properties.

7 Click the Download arrow button to write the 
design to the memory stick.

While saving the design, BERNINA Embroidery 
Software automatically converts it to the correct 
format for stitchout. See the relevant BERNINA 
Embroidery Software documentation for details of 
how to stitch out from a USB memory stick.

Storing designs with Magic Box

Magic Box lets you convert between designs saved in 
a variety of ‘non-native’ formats. You can read a 
design from any supported design card into BERNINA 
Embroidery Software, edit it then write it to a Magic 
Card of any of four types each of which can support 
different file formats. You can also save designs read 
from Magic Card to your computer or write them to a 
design card other than Magic Card.

Note  The Magic Box software is installed 
automatically when you install BERNINA Embroidery 
Software and only works with BERNINA Embroidery 
Software.

Select Bernina 
USB Stick

Click to access the 
Bernina Device 
Selection dialog

Click to browse 
for the USB 
device

Click to download
selected design

Design to be
stored

Select folder
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There are up to four color-coded card slots on the 
front of a Magic Box, corresponding to each of the 
available card types. (The mini Magic Box only has 
Slots 1 and 2.) Use Magic Box in conjunction with 
BERNINA Embroidery Software in order to:

Read an ART file from CD, hard disk or floppy, 
make desired changes, and write to a Magic Card. 

Read a stitch file from one of the supported design 
card formats (including Magic Card), make desired 
changes, and write it to a Magic Card.

Read a stitch file from a Magic Card, make desired 
changes, and write it to the storage media of your 
choice.

Once a design is in BERNINA Embroidery Software, 
you can add lettering, insert other designs stored on 
your computer, CD-ROM, or disk, and use all of 
BERNINA Embroidery Software editing features.

Note  The procedures here only apply to the 
operation of the Magic Box with BERNINA Embroidery 
Software. Refer to the Magic Box User Manual for 
installation, setup and operating instructions.

Reading designs from design cards

You can read a design from any supported design 
card, edit it, and then write it to one of the four types 
of Magic Card – Red, Blue, Yellow, or Green. You can 
select multiple designs to write to a Magic Card. 
However, you can only read and edit one design at a 
time into BERNINA Embroidery Software.

To read designs from a design card

1 Insert a design card in the Magic Box.

The slot you choose will depend on the card 
format.

Note  Magic Box allows you to read many design 
formats. See the Magic Box documentation for 
details.

2 Click the Read from Magic Box icon.

The Magic Box About dialog opens.

3 Click OK to proceed.

Refer to the Magic Box User Manual for operating 
instructions.

Tip  You can write designs read from Magic Box to 
your computer floppy disk or hard drive. 
Alternatively, write them to any supported design 
card, including of course Magic Cards.

Writing designs to Magic Card

From BERNINA Embroidery Software you can write 
designs to Magic Box using Magic Cards of any of four 
types. Use the Magic Card which supports the format 
you need. See the Magic Box documentation for 
details.

To write designs to Magic Card

1 Load an existing design from a design card or your 
computer. See Reading designs from design cards 
and Reading designs from machine.

The Magic Box About dialog opens.

2 Click OK to proceed.

Refer to the Magic Box User Manual for operating 
instructions.

Use Read from Magic Box (General toolbar) to read 
designs of other formats with Magic Box.

Use Write to Magic Box (General toolbar) to write 
designs to Magic Cards with Magic Box.
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Saving designs in PES format

PES is a Brother stitch file format which involves 
different combinations of hoop size and file version. 
Use the following procedure when saving PES 
designs.

To save a design in PES format

1 Select File > Save As. 

2 Choose PES as the file type and click Save.

The PES Save Options dialog opens.

3 Select the PES version you want to save to from 
the dropdown list.

The hoop list updates according to the selected 
version – different hoops are available in different 
versions of PES.

Tip  If the Remember hoop option is checked, 
the last hoop used is automatically selected next 
time around.

4 Select the required hoop type from the Hoop 
dropdown list.

Height and Width fields update automatically 
depending on the chosen hoop type.

Alternatively, select User Defined from the Hoop 
list. The Height and Width fields are enabled and 
you can set the values as required.

Note  You will be warned if the design does not fit 
in the hoop.

Select PES

Adjust height and 
width for 
user-defined hoops
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PART VIII
DESIGN MANAGEMENT

BERNINA Portfolio provides an efficient way for viewing and managing embroidery 
designs. This design management tool can access design files stored on your computer 
hard disk, CD-ROM, or floppy disk. BERNINA Portfolio even lets you view design files in 
folders which have been archived by means of the popular WinZip utility. It recognizes 
all design file formats used by BERNINA Embroidery Software. See Converting design 
files for details.

BERNINA Portfolio Basics

This section describes how to open and view designs in BERNINA Portfolio as well as 
adjusting viewing settings. It also covers browsing for and accessing designs in folders. 
See BERNINA Portfolio Basics for details.

BERNINA Portfolio Advanced

This section describes the more advanced workings of BERNINA Portfolio including 
sorting files in folders, printing designs, and publishing design catalogs. It also covers 
stitching and converting designs. It describes how to archive dormant or unused 
designs as well as how to organize designs in folders. See BERNINA Portfolio Advanced 
for details.
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CHAPTER 31
BERNINA PORTFOLIO BASICS

BERNINA Portfolio provides an 
efficient way for viewing and 
managing embroidery designs. This 
design management tool can access 
design files stored on your 
computer hard disk, CD-ROM, or 
floppy disk. BERNINA Portfolio even 
lets you view design files in folders 
which have been archived by means 
of the popular WinZip utility. It 
recognizes all design file formats 
used by BERNINA Embroidery 
Software.

This section describes how to open 
and view designs in BERNINA 
Portfolio as well as adjusting viewing settings. It also covers browsing for and 
accessing designs in folders.

Opening BERNINA Portfolio and 
viewing designs

BERNINA Portfolio does not require a separate 
installation. It works as an integral part of BERNINA 
Embroidery Software. BERNINA Portfolio displays 
thumbnails and limited design information whenever 
a design folder is accessed. You can filter the contents 
of the Display Panel to show only certain file types. 
You can also rename folders, add sub-folders and 
delete folders without leaving BERNINA Portfolio.

Opening BERNINA Portfolio

BERNINA Portfolio can only be opened from within 
BERNINA Embroidery Software.

To open BERNINA Portfolio

Select File > Portfolio to open BERNINA 
Portfolio.

Use the folder tree to direct BERNINA Portfolio to 
the My Designs - Embroidery Software 6 
folder.

Select Portfolio (File menu) to open BERNINA Portfolio.
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All your ART designs are displayed as thumbnail 
images.

Tip  If BERNINA Embroidery Software is hiding 
BERNINA Portfolio from view, switch between 

them using the MS Windows® Alt+Tab function.

Viewing designs in the Display Panel 

The designs in BERNINA Portfolio can be listed as 
thumbnails only (the default), thumbnails and 
summary information, or design information only.

Tip  Designs can also be displayed full screen using 
BERNINA Embroidery Software. See Opening designs 
in BERNINA Embroidery Software for details.

To view designs in the display panel

1 Open BERNINA Portfolio and select a folder. See 
Browsing designs in folders for details.

The BERNINA Portfolio Display Panel updates to 
show the contents of the selected folder. See also 
Refreshing the display.

2 Use the viewing options to view the designs in the 
database in the display format you require:

To display the designs as thumbnails only, click 
the Change Design View icon and select 
Thumbnails from the dropdown menu. Or, 
select View > Design Thumbnails.

To display the designs as thumbnails with 
stitching details, click the Change Design 
View icon and select Summary from the 
dropdown menu. Or, select View > Design 
Thumbnails and Summary.

To display the designs in a detailed list, click the 
Change Design View icon and select List 
from the dropdown menu. Or, select View > 

Change Design View

Folders

Design thumbnails
contained in

selected folder

Status bar

Menu bar
Toolbar

Split bar

Click Change Design View to select thumbnails 
only, thumbnails with stitching details, or summary 
information only.
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Design List. By default, designs are listed 
showing design name, file size, file type, 
version, etc.

Note  The number of selected designs is displayed 
in the Status Bar at the bottom of the BERNINA 
Portfolio window.

Viewing designs in the whole window

It is often more convenient to view designs in folders 
and databases in the whole window. When doing so, 
you can always browse for designs using the Look In 
list or Browse Location option.

To view designs in the whole window

1 Click the Hide/Show folders icon.

Designs are now viewable across the window.

2 Select View > Browse Location to view designs 
in another folder.

The Browse for Folder dialog opens.

3 Search the folder tree for the folder or database 
you require and click OK.

The display area updates accordingly.

Tip  Alternatively, select from the Look in 
dropdown list.

Viewing archived designs
BERNINA Portfolio lets you archive and view design 
files in folders which have been archived by means of 
the popular WinZip utility. This is a software program 
which bundles files into a single compressed file with 
the extension *.ZIP. This can be useful for sending or 
receiving multiple files via email. See also Archiving 
design files.

To view archived designs

1 Open BERNINA Portfolio and browse to the folder 
containing the zipped design files.

If the folder contains individually zipped 
designs, these will appear in the Display Panel 
along with any other design files in the folder. 
The names of any zipped files are displayed in 
italics.

If the folder contains zipped files containing 
multiple designs, the entire contents of the file 

Click Hide/Show Folders to toggle the folder tree on 
and off.

Folder containing 
individual zipped files

Zipped design – name 
appears in italics
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will appear in the Display Panel. The names of 
any zipped files are displayed in italics.

2 Select the zipped file to view its contents.

Locating missing files
If users incorrectly move files, the normal design 
thumbnail is usually replaced by a ‘missing design’ 
thumbnail when BERNINA Portfolio is next opened. 
Each color indicates the likely cause:

Adjusting view settings

BERNINA Portfolio allows you to customize window 
settings. It lets you customize the toolbar layout. You 
can switch between ‘locales’ – English, German, etc – 
at any time. Occasionally you may need to refresh the 
display. You can also change the way selected designs 
are highlighted, whether thumbnail files are created, 
and so on. BERNINA Portfolio even lets you customize 
design lists to display only the fields you require in 
any order you prefer.

Changing locale

During installation of the BERNINA Portfolio software, 
optional languages (locales) can be selected for 
dialogs and messages – e.g. German. You can switch 
between these locales at any time after installation.

Caution  If the default locale is not the same as the 
language of the Operating System, then this option 
will not work properly. See also ‘locale’ in 
MS Windows® Help for information about changing 
MS Windows® to suit different locales.

To change locale

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select View > Change Locale to open the locale 
required.

The Choose Locale dialog opens.

Note  Only those locales selected when BERNINA 
Portfolio was installed will be listed.

3 Select the locale required, and click OK to make 
the change.

Tip  See also ‘locale’ in MS Windows® Help for 
information about changing keyboards, fonts and 
so on to suit different locales.

Refreshing the display
Occasionally, your screen will not show changes you 
have made until you refresh the display. Changes to 
folders may not display either until you refresh the 
folder tree. If graphics and thumbnails still do not 
appear correctly, or if you have updated your 
BERNINA Embroidery Software installation, you may 
need to ‘validate and refresh’.

To refresh the display

To refresh the Display Panel, select View > 
Refresh, or press F5.

To refresh folders in the folder tree, select View > 
Refresh Folder. Alternatively, select the node or 
folder you want to refresh, right-click and select 
Refresh from the popup menu.

To validate and refresh files in folders, click the 
folder and select View > Validate and Refresh.

Tip  Occasionally, BERNINA Portfolio displays red, 
blue or green question marks and a short 

Icon Description

BERNINA Portfolio recognizes a pre-deter-
mined set of file types as per the file type drop-
down list. If it sees a design that has the 
required file suffix – ART, BMP, etc – but it is 
unable to read the file, it will display the green 
question mark. Locate the file and delete it.

Select Change Locale (View menu) to open BERNINA Port-
folio.

Zipped file appears 
in folder tree

Zipped design – name 
appears in italics
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description instead of a graphic thumbnail. See 
Locating missing files for details.

Modifying user preferences

You can change several default settings in BERNINA 
Portfolio, including the size of the design thumbnails. 
You can also change the way that selected designs are 
highlighted.

To modify user preferences

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select View > User Preferences.

The User Preferences dialog opens.

3 Select Highlight in Full to fully highlight each 
thumbnail as it is selected.

If you only require selected thumbnail borders to 
be highlighted, clear Highlight in Full.

Tip  The color and intensity of highlights can be 

changed in the MS Windows® Control Panel to suit 

each user. See MS Windows® Help for details 
about ‘Display Settings’.

4 Select Open Design in the Double-click 
Options panel to open designs when you double 
click on the selected design.

5 Select Show Properties in the Double-click 
Options panel to open Design Properties dialog 
when you double click on the selected design.

6 Click OK to apply the settings.

Tip  If you need more space in the Display Panel 
for viewing thumbnails, click the Hide/Show 
Folder Tree button.

Customizing design lists

BERNINA Portfolio lets you customize design lists to 
display only the fields you require in any order you 
prefer.

To customize design lists

1 To display the designs in a detailed list, click the 
Change Design View icon and select List from 
the dropdown menu. Or, select View > Design 
List.

By default, designs are listed showing design 
name, file size, file type, version, etc.

2 Right-click the column header and select the 
Customize Column from the popup menu. 
Alternatively, select View > Customize Columns 
> Design List.

The Design List Columns dialog opens.

3 Exclude a field from the listing by deselecting the 
associated checkbox.

Alternatively, highlight the field and select Hide.

4 Adjust the order of selected fields with the Move 
Up and Move Down buttons.

Alternatively, select the column header in list view 
and drag-and-drop to a new location.

Browsing designs in folders

Information about designs in folders can be viewed in 
BERNINA Portfolio. Designs can be browsed using 
navigation buttons and slide show buttons. You can 

Select User Preferences (View menu) to set design view 
user preferences.

Select Customize Columns (View menu) to customize 
design lists.

Select Customize Column

Select / deselect fields to 
include / exclude in listing

Click to reorder 
selected fields
Click to hide 
selected fields

Drag-and-drop header to new location
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do this to both the whole folder or to selected designs. 
You can also filter the contents of any design folder to 
show only certain file types – e.g. only ART files. See 
Sorting files in folders and Limiting file types 
displayed for details.

Viewing design properties

Information about designs in folders can be viewed in 
the Properties dialog. The data is extracted directly 
from design files created in BERNINA Embroidery 
Software. You cannot add, delete and edit these 
fields.

Tip  Designs in folders can be browsed using 
navigation buttons and slide show buttons on the 
Properties dialog. See Sorting files in folders for 
details.

To view design properties

1 Open BERNINA Portfolio and select a design folder. 
See Opening BERNINA Portfolio and viewing 
designs for details.

2 Right-click a design and select Properties from 
the popup menu, or click the Design Properties 
icon.

The Properties dialog opens.

Stitch information from the design file appears 
grayed out and cannot be edited. The Design, 
Description, and Selected fields are ranged 
across the top of the dialog. Use the Selected field 
at the top of the dialog to select or deselect 
designs in the main window as you move between 
designs. See Sorting files in folders for details.

Tip  If not all text is visible in a field, select the 
field and use the Arrow, Home and End keys to 
scroll. Alternatively, resize the dialog.

3 Click OK to close.

Browsing designs in folders
Navigation buttons on the Properties dialog allow 
you to move forwards, backwards, as well as to the 
start and end of all designs in the selected folder. 
Similarly, you can move forward and back through 
selected designs. As you browse, the Properties 
dialog displays a thumbnail together with relevant 
design information.

To browse designs in a folder

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Select or sort the designs as required. See Sorting 
files in folders for details.

3 Open the Properties dialog. See also Viewing 
design properties.

4 Browse through the entire folder or a selection of 
designs as required.

If you want to browse the entire folder, use the 
red navigation buttons. 

These allow you to move to the first design, last 
design, previous design and next design in the 
folder.

If you want to browse through selected 
designs, use the blue navigation buttons.

These too allow you to move to the first design, 
last design, previous design and next design in 
the folder.

5 Click OK to close.

o

Click Design Properties to view information about 
selected designs.

Navigation buttons

Navigation of 
designs

Navigation of 
selected designs

Start End Start End
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Browsing designs using slide show buttons
All designs in folder can be displayed as a slide show. 
The slide show is run from the Properties dialog 
which displays each design’s thumbnail together with 
relevant information. You can control the speed and 
direction of the slide show.

To browse designs using slide show 
buttons

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Select or sort the designs as required. See Sorting 
files in folders for details.

3 Open the Properties dialog. See also Viewing 
design properties.

4 Click the Forwards or Backwards button to start 
the slide show.

The slide show automatically scrolls through every 
design in the folder, looping back to the beginning 
when it reaches the end.

5 Click + or - to increase or decrease the speed.

6 Click the Stop button to stop.

7 Click OK to close.

Accessing designs and artwork

BERNINA Portfolio lets you select designs and 
electronic artwork residing in folders. Once selected, 
you can manipulate them in a variety of ways – e.g. 
cutting, copying, pasting, editing the record, and 
converting designs to other formats. You can also 
open them in BERNINA Embroidery Software directly 
from BERNINA Portfolio for viewing or editing.

Tip  With the file selected, right-click to open a popup 
menu which includes frequently used commands.

Selecting designs in folders
Designs and images must be selected before an 
action can be performed – e.g. view, open or copy a 
design. A group of designs, a range, or all the designs 
in a database can be selected. A group is made up of 
any selected designs. A range is a series of 
consecutive designs.

To select designs in a folder

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Display designs as thumbnails or as a details list. 
See Adjusting view settings for details.

Tip  The thumbnail image generation process can 
be very slow on older machines or if there are a lot 
of designs in the database. Holding down the Alt 
key will abort the redraw. The thumbnail will be 
drawn using a default yellow exclamation mark.

3 Sort designs by required category. See Sorting 
files in folders for details.

4 Select a design or designs:

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

To select all designs in the current folder, select 
Edit > Select All or click Ctrl+A.

5 To deselect all selected designs, select Edit > 
Deselect All, or click any unselected design.

Tip  To deselect a single design amongst a group 
of selected design, click it again while holding 
down the Ctrl key.

Opening designs in BERNINA Embroidery 
Software

Any designs selected in the BERNINA Portfolio 
Display Panel can be opened in BERNINA Embroidery 
Software for viewing or editing. Similarly, any artwork 
file can be opened in a third-party graphics package 
for viewing or editing.

Caution  Occasionally BERNINA Portfolio may fail to 
connect with BERNINA Embroidery Software. See 
Reconnecting BERNINA Portfolio to BERNINA 
Embroidery Software for details.

To open designs in BERNINA Embroidery 
Software

1 Open BERNINA Portfolio and select a design folder. 
See Opening BERNINA Portfolio and viewing 
designs for details.

Slide show buttons

Stop
Backwards

Fast/Slow
Forwards

Click Open Design to open a selected design or 
designs into BERNINA Embroidery Software.
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2 Select a design or designs. See Selecting designs 
in folders for details.

Tip  If you want to open several designs at once, 
select the details list view. See Adjusting view 
settings for details.

3 Click the Open Design icon or select File > Open 
with BERNINA Embroidery Software.

All selected files are opened.

Note  If you wish to open selected artwork in a 
third-party graphics package for viewing or 
editing, select File > Open.

Tip  Alternatively, double-click a design thumbnail.

Make sure Open Design in the Double-click 
Options panel is selected in the User 
Preferences dialog. See Modifying user 
preferences for details.

The selected design or designs are displayed in the 
BERNINA Embroidery Software window ready for 
editing.

4 To switch between BERNINA Embroidery Software 
and BERNINA Portfolio:

Hold down the Alt key, then tap the Tab key 
until the BERNINA Embroidery Software icon is 
highlighted. Release the Alt key.

Alternatively, click the BERNINA Embroidery 

Software icon on the MS Windows® taskbar.

Creating designs with custom templates
You can open a new design in BERNINA Embroidery 
Software from within BERNINA Portfolio.

To create designs with a custom template

1 Select File > New.

BERNINA Embroidery Software opens with a blank 
design.
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CHAPTER 32
BERNINA PORTFOLIO ADVANCED

Designs in BERNINA Portfolio folders 
can be sorted in various ways. This 
is useful when you want to select 
designs for stitching out, printing, 
archiving, and so on. Once a design 
is selected in an BERNINA Portfolio 
folder, you can send it direct to an 
embroidery machine. You can also 
convert ART and other design files 
to and from other file formats. 

Catalogs of designs in a folder 
contain thumbnails and/or 
summary information. These can be 
sent to a printer and published in a 
variety of formats.

BERNINA Portfolio lets you archive and view design files in folders which have 
been archived by means of the popular WinZip utility. This can be useful for 
sending or receiving multiple files via email.

This section describes the more advanced workings of BERNINA Portfolio 
including sorting files in folders, printing designs, and publishing design catalogs. 
It also covers stitching and converting designs. It describes how to archive 
dormant or unused designs as well as how to organize designs in folders.

Sorting files in folders

The simplest way to sort files in BERNINA Portfolio 
folders is by file type – e.g. ART files only. Designs 
can be further sorted in the following ways:

As simple sorts using View > Sort by (Design 
Name, File Type, File Size, or Last Changed). 
The designs are arranged according to the sort 
selection. The designs can be sorted whether they 
are displayed as thumbnails or as a details list.

As simple sorts using details list headings: by 
Design Name, File Size, File Type, Version, 
Last Changed, Stitches, or Description. 
Designs are arranged according to the heading 
selected, and repeating the sort reverses the 
order. Designs must be displayed as a details list.

As a complex sort in up to two levels in ascending 
or descending order: by File Type, First 
Designed, Height, Last Changed, Stitches, 

Version, Width or None. Designs can be 
displayed as thumbnails, thumbnails with stitching 
details, or details lists.

Limiting file types displayed
With BERNINA Portfolio you can filter the contents of 
any design folder to show only certain types of file – 
e.g. All Embroidery files.

To limit file types displayed

1 Open BERNINA Portfolio and select a design folder. 
See Opening BERNINA Portfolio and viewing 
designs for details.
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2 Click the Files dropdown on the toolbar.

3 Select:

All Files to show every file type in the folder.

All Artwork Files to all supported artwork file 
types. See Digitizing with Backdrops for details.

Any other option to display only files of that 
type – e.g. templates (AMT). See Supported 
embroidery file formats for details.

Running simple sorts using the View menu
You can sort your thumbnails or details lists by 
selecting any of four types of sort from the View 
menu.

To run a simple sort using the View menu

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Display the designs in list or thumbnail fashion as 
preferred. See Viewing designs in the Display 
Panel for details.

3 Select View > Sort by Design Name, Sort by 
File Type, Sort by File Size, or Sort by Last 
Changed.

The designs will be sorted according to the option 
selected.

Running simple sorts using details lists
You can sort details lists by clicking the column 
headings.

To run a simple sort using details lists

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 List the designs as a details list. See Viewing 
designs in the Display Panel for details.

3 Click the heading at a column to be sorted – e.g. 
Design Name.

The designs will be sorted in the order of the 
selection.

4 Click the heading again to reverse the order.

Running complex sorts using Sort

You can sort designs by various criteria such as 
Colors, Design Date, Design Name, File Type, etc. 
BERNINA Portfolio lets you sort them by up to two 
levels, in ascending or descending order.

To run a complex sort using Sort

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 List the designs as a details list. See Viewing 
designs in the Display Panel for details.

3 Click the Sort icon or select Sort > View menu.

The Sort dialog opens.

4 Select the first sort criterion:

Select the main category you want from the 
Sort By list – e.g. First Designed.

Select Ascending to sort letters from A to Z 
and numbers from lowest to highest, or 
Descending to sort in the reverse order.

5 Select the second level sort criterion:

Select a different category from the And Then 
By dropdown – e.g. Stitches.

Select Ascending or Descending.

Use Sort to run a complex sort using the Sort dialog.

Click column heading to sort

Select Level 1 
criterion

Select Level 2 
criterion
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6 Click OK.

In the above example, the details list will display 
all designs by first designed, together with 
stitches.

Printing and publishing designs with 
BERNINA Portfolio

Catalogs of designs in a folder contain thumbnails 
and/or summary information. These can be sent to a 
printer, published on your website or intranet, and 
exported in formats suitable for spreadsheet and 
database programs.

Tip  Before printing, publishing or exporting, sort the 
designs into useful groups. See Sorting files in folders 
for details. 

Printing designs with BERNINA Portfolio

You can print a copy of designs for selected groups of 
designs in folders, and include thumbnails of each 
design. See also Setting print options for embroidery.

Note  Unlike Print Designs, this option can provide 
all of the design and sewing information available, but 
it uses far more paper to do so. See also Printing 
design catalogs.

To print a design with BERNINA Portfolio

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio for details.

2 Filter the file types to display as required. See 
Limiting file types displayed for details.

3 Sort the designs to be printed using Sort. See 
Sorting files in folders for details.

4 Select the design(s) and click the Print Selected 
Designs icon.

The Print Options dialog opens.

5 Select a size option:

Actual Size: the design is printed at the same 
size it will be stitched.

Fit to Page: large designs will be reduced to fit 
the printing paper, small designs will be 
enlarged.

6 Select Artistic View to print the design in Artistic 
View.

7 Include other options as required:

Hoop: The hoop is included in the printout.

Picture: The design is printed with the picture 
behind it.

8 Click OK.

The Print Setup dialog opens.

Note  The dialog and the settings available will 
vary from printer to printer. See your printer 
manual for details.

9 Ensure that your printer settings are correct and 
click OK to print.

Printing design catalogs
Printed catalogs of your designs contain thumbnails of 
the designs plus limited text details. You can prepare 
catalogs of all your designs, and others to suit your 
needs.

To print a design catalog

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio for details.

Use Print Selected Designs to print selected 
design(s).



Chapter 32 : BERNINA Portfolio Advanced

BERNINA® Embroidery Software : Onscreen Manual 297

2 Filter the file types to display as required. See 
Limiting file types displayed for details.

3 Sort the designs to be printed in the catalog using 
Sort. See Sorting files in folders for details.

4 Select File > Print Catalog.

The Print Catalog Options dialog opens.

5 Change the Scale (%) amount if you want your 
thumbnails bigger or smaller.

6 Select Summary if you want design details to be 
printed.

7 Click Preview as required.

8 Click Printer to select a printer, paper size and 

other options in the MS Windows® Print Setup 
dialog for the printer attached to your PC.

9 Click OK to print the catalog.

Tip  If the catalog requires more than one page, 
you can select which page to print in the 

MS Windows® Print Setup dialog.

Publishing design catalogs for browser 
viewing
You can convert your designs to the HTML and PNG 
formats suitable for viewing by any browser, such as 
Microsoft Internet Explorer. This allows you to publish 
designs throughout the world via the internet.

To publish a design catalog for browser 
viewing

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio for details.

2 Filter the file types to display as required. See 
Limiting file types displayed for details.

3 Sort the designs to be published in the catalog 
using Sort. See Sorting files in folders for details.

4 Select File > HTML Catalog.

The HTML Catalog Options dialog opens.

5 Change the Scale (%) amount if you want your 
thumbnails bigger or smaller.

6 Adjust the numbers of rows and columns for the 
final output, which will appear as a table. 

7 Deselect Summary if you don’t want design 
details to appear.

8 Enter a filename and location in the File Name 
field – e.g. C:\Designs\Catalogs\Crests.htm – or 
accept the default settings.

Tip  Make a separate folder for each catalog – the 
catalog conversion will generate a PNG file for a 
thumbnail of each design, another PNG file for a 
Artistic View of each design, and an HTML file for 
each page.

9 Click OK to start converting the designs.
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Your browser – e.g. MS Windows® Internet 
Explorer – will open automatically at the first page 
of designs when the conversion is finished.

If your browser does not open automatically:

Open your browser – e.g. MS Windows® 

Internet Explorer – via the MS Windows® Start 
button.

Click the Address field, browse to the selected 
folder, and double-click the first HTM file 
containing thumbnails – e.g. Crests1.htm.

There will be at least two HTM files with similar 
names – e.g. Crests.htm, Crests1.htm, etc. The 
filename without a number is the index to all 
of the HTM files.

Your browser will display one or more design 
thumbnails in the window. 

10 Examine the contents of the page. 

Click Next Page to view the next screen of 
thumbnails.

Tip  Click a thumbnail to view its Artistic View 
image in real size.

11 Repeat the procedure to adjust thumbnail size and 
table layout as required.

Exporting design catalogs
Design details can be converted to the Tab and CSV 
(Comma Separated Value files) formats suitable for 
use by most spreadsheets. See your spreadsheet 
program for details.

To export a design catalog

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio for details.

2 Filter the file types to display as required. See 
Limiting file types displayed for details.

3 Sort the designs to convert the design details to 
different formats using Sort. See Sorting files in 
folders for details.

4 Select File > Export Designs List.

The Export to File Options dialog opens.

5 Click either Comma Separated Value File or 
TAB Delimited Text File, depending on your 
spreadsheet program’s recommended format.

The Save As dialog opens.

6 Select a folder and enter a filename to store the 
CSV or TXT file.

7 Click Save.

The designs will be generated and saved in the 
selected format.

Stitching out designs

Once a design is selected in a folder, you can send it 
direct to any embroidery machine connected to the 
BERNINA Embroidery Software system.

Tip  When a file is selected, right-click to open a 
popup menu which includes the commands Open, 
Print, Convert, Write to Card/Machine, Rename, 
and Delete.

Stitching directly from BERNINA Portfolio

Use Stitch Selected Designs to stitch a design 
directly to machine.
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Select one or more designs in a folder using BERNINA 
Portfolio. You can then stitch to any embroidery 
machine connected to your BERNINA Embroidery 
Software system.

To stitch directly from BERNINA Portfolio

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Sort and select the design(s) to be stitched using 
Sort or Search. See Sorting files in folders and 
Selecting designs in folders for details.

3 Click the Stitch Selected Designs icon.

The Stitch Options dialog opens.

4 Select a machine type and format from the lists.

5 Click OK.

The Bernina Device Selection dialog opens. See 
Stitching out designs for details.

Converting design files

You can convert your ART and other design files to 
and from other file formats directly from BERNINA 
Portfolio.

Note  You cannot convert design files to PES format 
in BERNINA Portfolio as the PES file type requires the 
hoop size be set.

To convert design files

1 Open BERNINA Portfolio and select a design 
folder. See Opening BERNINA Portfolio and viewing 
designs for details.

2 Select the file(s) to be converted. See Selecting 
designs in folders for details.

3 Click the Convert Selected Designs icon.

The Convert Options dialog opens.

4 Select the file types you want to convert to.

5 Browse to the folder where you want to store the 
converted designs, using the Browse button and 
the Browse for Folder dialog.

6 Click OK to start the conversion.

The converted designs will be stored in the 
nominated folder. You are prompted to record the 
results in a log file.

7 Click OK.

Archiving design files

BERNINA Portfolio lets you archive and view design 
files in folders which have been archived by means of 
the popular WinZip utility. This is a software program 
which bundles designs into compressed or ‘zipped’ 
files. This can be useful for saving on storage space or 
receiving multiple files via email. See also Viewing 
archived designs.

Saving designs to an archive file

BERNINA Portfolio provides a shortcut to the WinZip 
utility via the toolbar. Use it to bundle designs into 
compressed or ‘zipped’ files. See also Viewing 
archived designs.

Use Convert Selected Designs to convert from one 
design file type to another.

Select 
machine type 
and format

Use WinZip to archive selected designs to a single 
compressed file.
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To save designs to an archive file

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select a folder and select the design or designs 
you want to archive. 

3 Click the WinZip icon.

4 If you have selected one design file, the system 
will create a ZIP file. Enter a name for the file and 
choose a location.

5 If you have selected more than one design file, 
choose whether to archive the selected files 
individually or as a single file.

Create one archive containing multiple 
designs: creates a single ZIP file for all 
designs. Enter a name for the file and choose a 
location.

Create individual archives for each 
design: opens the Browse for Folder dialog. 

Choose a location and click OK. The ZIP files 
automatically take the name of the design.

Tip  You can view zipped files in the specified 
folder. See Viewing archived designs for details.

Extracting designs from an archive file
BERNINA Portfolio allows you to extract design files 
from a zipped archive directly to a folder. This is 
useful, for example, if you are receiving zipped 
designs via email. See also Viewing archived designs.

To extract designs from an archive file

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select the folder which contains the design or 
designs you want to extract.

3 Select the individual design to extract in the 
Display Panel or the zipped file in the folder tree.

Folder containing 
individual zipped files

Zipped design – name 
appears in italics
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4 Within the zipped file, select the design(s) you 
want. 

To select a range, hold down Shift as you click.

To select multiple items, hold down Ctrl as you 
click.

Tip  If you leave designs unselected, all zipped 
files in the folder will be extracted.

5 Select File > Extract Zip Archive.

The Browse for Folder dialog opens.

6 Choose a location and click OK.

The designs are extracted to the selected location. 
See also Viewing designs in the Display Panel.

Organizing designs in folders

You can rename and copy and paste designs in 
folders. You can also rename folders, add or delete 
folders without leaving BERNINA Portfolio.

Renaming, adding or deleting folders
You can rename, add and delete folders without 
leaving BERNINA Portfolio.

To rename, add or delete folders

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Browse to the folders you want to rename, delete 
or add sub-folders to. See Browsing designs in 
folders for details.

3 Add, rename, or delete folders as required:

To add a sub-folder to another, select the folder 
and right-click. Select Add Folder and type in 
the name when the new sub-folder appears.

To rename a folder, select it and right-click. 
Select Rename and type in the new name.

To delete a folder, select and right-click it, and 
select Delete. You are prompted to confirm the 
deletion.

Copying and pasting designs
Once a selected design is copied, it can then be 
pasted to another location using Paste. A copied 
design can be pasted any number of times.

To copy and paste designs

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details.

2 Select any number of designs. See Selecting 
designs in folders for details.

3 Select Edit > Copy.

4 Change to another folder using the folder tree as 
required. 

A design can be pasted to the same folder as the 
original design.

5 Select Edit > Paste.

If the selected design – e.g. Bear.ART – is pasted 
into the current folder, and the current folder 
contains the original design, or a file of the same 
name, the new design is automatically named 
Copy of Bear.ART. You can then change the 
name of the new file by right-clicking its name, 
selecting Rename and typing the new name. 
Press Enter to complete the name change.

Note  If you rename the file, ensure that the three 
letter extension – e.g. ART – is not altered.

Cutting and pasting designs
When a selected design is cut, the design is removed 
from the current folder. The design can then be pasted 
at another location using the Paste command.

Zipped file appears 
in folder tree

Zipped design – name 
appears in italics
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To cut and paste designs

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select any number of designs. See Selecting 
designs in folders for details.

3 Select Edit > Cut.

A confirmation dialog opens.

4 Click Yes to cut the design.

5 Browse to the folder where you want to paste the 
file or files.

6 Select Edit > Paste to paste the selected design 
into the new folder.

If a design of the same name already exists, you 
are prompted to overwrite the existing one with 
the new one.

Renaming designs in folders
Duplicate designs, designs with misleading names, 
and designs with misspelled names can be quickly 
renamed without opening them.

To rename a design in a database or folder

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio and viewing designs for details. 

2 Ensure that the design you select is not currently 
open in BERNINA Embroidery Software.

3 Right-click and select Rename from the popup 
menu.

4 The Rename Design dialog opens.

5 Enter the new name and click OK.

The original design name is overwritten.

Deleting designs
Delete designs to remove them permanently from 
your PC.

To delete designs from BERNINA Portfolio

1 Open BERNINA Portfolio. See Opening BERNINA 
Portfolio for details. 

2 Select any number of designs. See Selecting 
designs in folders for details.

3 Select Edit > Delete or right-click and select 
Delete from the popup menu.

A confirmation dialog opens.

4 Click Yes to delete the design.

Caution  The file is removed permanently from 
the folder.

Rename 
selected 
design

Bear Enter new 
design name
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BERNINA EMBROIDERY SOFTWARE
QUICK REFERENCE

BERNINA Embroidery Software integrates with 
CorelDRAW® Essentials 4 into a single application. 
The application has one workspace or ‘Design 
Window’ but you interact with it in separate operating 
modes: Art Canvas and Embroidery Canvas. A 
third mode is available for multi-hooping large 
designs. This Quick Reference Guide details all menu 
options and toolbars available in Embroidery 
Canvas mode. Not all options described here are 
relevant to all product levels. See also Product 
Feature List.

Embroidery Canvas Design Window

The screen image below displays an exploded view of 
all toolbars in the BERNINA DesignerPlus 
Embroidery Canvas Design Window.

Art Canvas

Below is a screen image of the Art Canvas 
workspace. This replaces the old ‘Picture Mode’ and 
includes the entire suite of CorelDRAW® drawing tools 

Digitize and edit embroidery designs. Show 
embroidery shapes as well as graphics. 
View designs realistically in simulated 3D.

Menu bar

General toolbar

Title bar

Status bar

Design Window

Stitch and Color Bar

Edit toolbar

Digitize toolbar

Arrange toolbar

Craft Stitch toolbar

View Mode toolbar

Load, edit and save graphics as a back-
drops for embroidery digitizing. Includes 
entire suite of CorelDRAW® Essentials 4 
drawing tools. In addition, provides capabil-
ities to convert vectors and vector text 
directly to embroidery objects.
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which offer many sophisticated techniques for 
drafting outlines and shapes onscreen.

In addition to the CorelDRAW® Essentials 4 toolset, 
Art Canvas provides capabilities to convert vectors 
and vector text directly to embroidery objects. Vector 
graphics or text created or imported into the Art 
Canvas can be converted directly to embroidery 
designs. You can use Art Canvas to insert or paste 
third-party vector graphics such as clipart for use in 
embroidery designs. Alternatively, insert, paste or 
scan bitmap artwork for use as digitizing templates or 
‘backdrops’.

Note  For a full description of the CorelDRAW® tools, 
refer to the electronic User Guide available via the 
Windows Start > Programs group. Alternatively, use 
the onscreen help available from the Graphics mode 
Help menu.

Hoop Layout

Below is a screen image of the Hoop Layout 
workspace, previously known as Multi-Hooping 
View. If your embroidery is too large or contains a 
number of designs spaced around an article, you can 
split it into multiple hoopings. Hoop Layout allows 

View and edit multi-hoopings. If embroidery 
is too large or contains multiple designs 
spaced around an article, split into multiple 
hoopings.
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you to set up the position and sequence of each hoop. 
See Hooping large designs for details.

Embroidery Canvas menu bar
The Embroidery Canvas menu bar contains the 
pulldown menus described below. Not all commands 
are relevant to all product levels. Some are also 
available as toolbar buttons.

Note  Standard MS Windows® Alt key shortcuts 
apply. Use the Alt key with the letter underlined in the 
menu. To cancel an operation, press Esc twice.

File menu

Edit menu

New Open new empty design.

Open Open design. 

Close Close current Design Window.

Portfolio Start BERNINA Portfolio and select 
design.

Cross Stitch Start cross stitch program.

Quilter Start Quilter program.

Insert Design Insert existing design. 

Save Save current design.

Save As Save current design with a different 
name, location or format.

Save Design 
As Image

Save design images in Stitch View 
or Artistic View. The resulting image 
is exactly as it appears in the Design 
Window.

Design Proper-
ties

Show information about a design 
such as size or number of stitches, 
and add comments about design for 
printing on worksheet.

Print Print design.

Print Preview Show design worksheet. Print work-
sheet from this window.

Card / Machine 
Read

Read (open) design from BERNINA 
Embroidery Software Design Card 
or BERNINA embroidery machine.

Card / Machine 
Write

Write (save) design to BERNINA 
Embroidery Software Design Card 
or BERNINA embroidery machine.

Write to Magic 
Box

Write (save) design to Design Card 
in Magic Box.

Read from 
Magic Box

Read (open) design from Design 
Card in Magic Box.

Recent File List List most recently used files. Select 
to open a file.

Exit Close all open designs and exit 
BERNINA Embroidery Software 
program.

Undo Cancel last command.

Redo Re-apply cancelled commands.
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View menu

Arrange menu

Cut Deletes selection and places it on 
clipboard.

Copy Copy selection to clipboard. 

Paste Paste contents of clipboard to Design 
Window.

Duplicate Duplicate selection and place it on 
current selection.

Delete Delete selection without placing it on 
clipboard.

Select All Select all objects in design.

Deselect All Deselect all selected objects in 
design.

Stitch Edit Move insert point to selected point in 
design.

Smooth 
Curves

Apply curve ‘smoothing’ to embroi-
dery objects. Selecting it opens the 
Smooth Curves dialog.

Lettering Change lettering settings.

Elastic Letter-
ing

Apply special effects to lettering 
objects to make them bulge or arch, 
stretch or compress.

Monogram-
ming

Create personalized monograms 
with a selection of pre-defined mono-
gramming styles, border shapes and 
ornaments.

Touch Up 
Picture

Open a third-party paint program to 
edit a selected bitmap graphic.

Crop Image Crop a bitmap graphic for use with 
PhotoSnap.

By Color Show only selected colors in design.

Needle Points Show/hide needle points.

Picture Show/hide background picture.

Artistic View Toggle artistic view on/off.

Overview Win-
dow

Show/hide design thumbnails.

Show 1:1 Show design at actual size.

Show All Show whole design.

Center Current 
Stitch

Center currently selected stitch in 
Design Window. Shortcuts C and F6 
also available.

Previous View Return to previous view. Shortcuts V 
and F5 also available.

Zoom Out 2X Display design at 50% of current 
view. Shortcuts Shift+Z and F10 also 
available.

Zoom In 2X Display design at 200% of current 
view. Shortcut Z also available.

Zoom Zoom in and out of the Design Win-
dow and zoom in on bounded areas 
to full window size. Shortcut F8 also 
available.

Zoom Factor Display design to scale as percent-
age of actual size. Shortcuts F and 
F3 also available.

Redraw Redraw design.

Slow Redraw Redraw design slowly to show stitch-
ing sequence.

Hoop Show/hide hoop and set hoop size 
and position.

Grid Show/hide grid and set grid size and 
spacing.

Measure Measure design size.

Start and End Set start and end points in design.

Stitch 
Sequence

Automatically arrange the stitch 
sequence to minimize hoopings, 
color changes and trims.

Sequence as 
Selected

Set stitching sequence for selected 
objects in order of selection.

Sequence to 
Start

Place selected object at start of 
stitching sequence.

Sequence to 
End

Place selected object at end of 
stitching sequence.

Sequence by 
Color

Set stitching sequence of objects in 
selected color order. 

Color Film Open Color Film dialog.

Mirror Hori-
zontal

Mirror selected object/s horizontally 
about center. 

Mirror Vertical Mirror selected object/s vertically 
about center.

Group Group selected objects into one 
object.

Ungroup Separate grouped object into com-
ponent objects.

Break Apart Split monograms, appliqués, letter-
ing, and Blackwork runs into compo-
nent objects.

Lock / Unlock 
All

Lock and unlock objects to protect 
them during digitizing or editing. 
Shortcut keys K and Shift+K also 
available.

Remove Over-
laps

Remove underlying layers of stitch-
ing in overlapping objects.

Add Holes Remove stitching from shape (leav-
ing hole).

Fill Holes Fill holes in single objects.
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Settings menu

Window menu

Help menu

Viewing modes
There are three View Mode buttons in BERNINA 
Embroidery Software. The different modes display 
different toolbars.

BERNINA Embroidery Software window 
toolbars
The Design Window contains the toolbars described 
below. Not all tools are relevant to all levels of 
product. Some are shortcuts to the pulldown menu 
commands.

Add Button-
hole

Add buttonhole to design.

Pattern Stamp Place single patterns in the design.

Close Object Close any open object with the 
option of using straight or curved 
points.

Thread Colors Assign thread colors for use in 
design.

Fabric Set-
tings

Adjust fabric types and settings.

Fabric Display Select background fabrics and col-
ors.

Object Proper-
ties

Adjust properties for selected 
shapes.

Options Adjust settings for display window.

Security Enter codes when upgrading or add-
ing optional features.

Display Setup Calibrate screen.

Scanner Setup Set scanner options.

Create Pattern Create and name patterns.

Create Border Create and name borders.

Cascade Display any open windows in a ‘cas-
caded’ or stair-stepped fashion.

Tile Horizon-
tally

Display any open windows in a hori-
zontally ‘tiled’ (non-overlapping) 
fashion.

Tile Vertically Display any open windows in a verti-
cally ‘tiled’ (non-overlapping) fash-
ion.

(Title of Open 
Window)

Choose from a list of open windows 
titles in the order in which they are 
stacked.

Help Topics List onscreen help topics.

Onscreen 
Manual

Onscreen documentation in Adobe 
Acrobat PDF format.
Note: depending on your product 
level, documentation components 
may vary.

Quick Start 
Guide

Release Notes

About Show BERNINA Embroidery Soft-
ware version information.

Show Design 
Warning

Displays a warning when opening a 
design that should not be scaled.

BERNINA® 
International 
Home Page

Open BERNINA® International web 
site.

BERNINA® of 
America Home 
Page

Open BERNINA® of America web 
site.

Embroidery 
Online

Open Embroidery Online web site.

Access Code 
Order Form

Open Access Code online order 
form.

Purchase 
Upgrade on 
the Internet

Purchase software upgrades directly 
from the internet.

Install 
Upgrade

Downloads access codes to your 
dongle after email notification of suc-
cessfully processed online upgrade 
purchase.

Load, edit and save graphics as a 
backdrops for embroidery digitiz-
ing. Includes entire suite of 
CorelDRAW® Essentials 4 draw-
ing tools. In addition, provides 
capabilities to convert vectors 
and vector text directly to embroi-
dery objects.

Digitize and edit embroidery 
designs. Show embroidery 
shapes as well as graphics. View 
designs realistically in simulated 
3D.

View and edit multi-hoopings. If 
embroidery is too large or con-
tains multiple designs spaced 
around an article, split into multi-
ple hoopings. 

In Art Canvas mode, the View 
Mode toolbar includes the Show 
Embroidery button.
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General toolbar

This toolbar is available in Embroidery Canvas 
mode.

Image toolbar

This toolbar is available in Art Canvas mode.

Art toolbox

This toolbar is available in Art Canvas mode.

Note  For a full description of the 
CorelDRAW® Essentials 4 tools, refer to the electronic 
User Guide available via the Windows Start > 
Programs group. Alternatively, use the onscreen 
help available from the Graphics mode Help menu.

Edit toolbar

This toolbar is available in Embroidery Canvas 
mode.

New Same as File > New.

Open Same as File > Open.

Save Same as File > Save.

Print Prints design using current print 
settings.

Print Preview Same as File > Print Preview.

Write to 
Machine

Same as File > Card / Machine 
Write.

Read from 
Magic Box

Read designs from design 
cards using Magic Box.

Write to Magic 
Box

Save designs to design cards 
using Magic Box.

Cut Same as Edit > Cut.

Copy Same as Edit > Copy.

Paste Same as Edit > Paste.

Undo Same as Edit > Undo.

Redo Same as Edit > Redo.

Show Grid Same as View > Grid.

Show Hoop Same as View > Hoop.

Show Pic-
tures

Same as View > Picture.

Dim Artwork Dim backdrops to show stitches 
more clearly when digitizing.

Show Vectors Toggle on/off display of vector 
graphics.

Show Stitches Toggle stitch view on/off.

Show Artistic 
View

Toggle artistic view on/off.

Show Appli-
qué Fabric

Toggle appliqué fabrics/colors 
on/off.

Object Prop-
erties

Same as Settings > Object 
Properties.

Auto Underlay Add automatic underlay.

Textured 
Edge

Add textured edge to object.

Color Film Same as Arrange > Color Film.

Carving 
Stamp

Define a pattern of needle pen-
etrations using a ‘carving 
stamp’ as a template.

Morphing 
Effect

Create transformed object out-
lines and stitches.

Zoom Box Same as View > Zoom Box.

Show 1:1 Same as View > Show 1:1.

Show All Same as View > Show All.

Load Picture Load graphics – bitmap and 
vector – into BERNINA Embroi-
dery Software for use as a digi-
tizing backdrop or other.

Scan Picture Scan images into BERNINA 
Embroidery Software.

Touch Picture Touch up bitmap images in 
Corel 
PHOTO-PAINT® Essentials 4.

Save Picture Save backdrop as graphics file 
– bitmap or vector.

Convert Vec-
tors to 
Embroidery

Convert selected vectors to fill 
or outline stitches.

Convert Text 
to Embroidery

Convert text objects to Satin 
embroidery lettering with turn-
ing stitching.

Select Object Select embroidery object for 
sizing, moving, mirroring or 
rotating.

Polygon 
Select

Select irregular areas or 
shapes.
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Digitize toolbar

This toolbar is available in Embroidery Canvas 
mode.

Craft Stitch toolbar

This toolbar is available in Embroidery Canvas 
mode.

Reshape 
Object

Reshape selected embroidery 
and lettering objects.

Mirror Hori-
zontal

Same as Arrange > Mirror Hor-
izontal.

Mirror Vertical Same as Arrange > Mirror Ver-
tical.

Rotate CCW / 
CW by 45° 

Rotate selected objects in 45° 
increments. Click to rotate 
counter clockwise. Right-click 
to rotate clockwise.

Scale by 20% 
Down / Up

Scale selected object in 20% 
increments. Click to reduce 
object/s. Right-click to increase 
object/s.

Double Run Repeat stitches in selected 
objects.

Remove 
Overlaps

Same as Arrange > Remove 
Overlaps.

Add Holes Same as Arrange > Add Holes.

Fill Holes Same as Arrange > Fill Holes.

Break Apart Same as Arrange > Break 
Apart.

Color Blend-
ing

Digitize blended objects.

Image Prepa-
ration

Prepare bitmap artwork for 
automatic digitizing.

Convert 
Selected 
Embroidery to 
Art Vectors

Convert selected embroidery 
objects to vectors.

Auto Digitizer Digitize prepared bitmap 
images automatically.

Magic Wand Digitize single shape in design.

PhotoSnap Turn grayscale or color photo-
graph into embroidery.

Open Object Draw and digitize open shapes.

Closed Object Draw and digitize closed 
shapes.

Free Hand 
Embroidery - 
Open Object

Draw embroidery outlines 
directly onscreen and view a 
stitch simulation as you draw.

Free Hand 
Embroidery - 
Closed Object

Draw freehand filled embroi-
dery objects onscreen.

Block Digitiz-
ing

Digitize columns with turning 
stitches.

Circle / Oval Draw and digitize ovals or cir-
cles.

Rectangle Draw and digitize rectangles or 
squares.

Lettering / Fill 
Values

Create lettering and change let-
tering properties.

Monogram-
ming

Create personalized mono-
grams using a selection of 
pre-defined styles, border 
shapes and ornaments.

Auto Appliqué Digitize closed-object appliqué.

Partial Appli-
qué

Create appliqué objects with 
partial cover stitching.

Advanced 
Appliqué

Generate open-object appliqué 
from one or more source 
objects.

Outline 
Design

Stitch around groups of objects 
with Single, Triple or Satin Line.

Cross Stitch Same as File > Cross Stitch.

Quilter Same as File > Quilter.

Blackwork 
Run

Automatically sequence 
selected embroidery objects.

Blackwork 
Border

Digitize blackstitch borders.

Blackwork Fill Digitize fill blackwork designs. 

Candlewick-
ing Border

Digitize candlewick borders.

Candlewick-
ing Fill

Digitize special candlewick 
effects.

Lacework Digitize special lacey effects.

Stipple Run Digitize special stippled effects.

Backstitch Digitize backstitch borders.

Stemstitch Digitize stemstitch borders.

Sculptured 
Fancy

Create turning tiled patterns. 

Ripple Create spiral stitching from the 
center of any filled object.
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Stitch and Color Bar

This toolbar is available in Embroidery Canvas 
mode.

Arrange toolbar

This toolbar is available in Embroidery Canvas 
mode.

Color Film

This toolbar is available in Embroidery Canvas 
mode.

Multi-Hooping toolbar

This toolbar is available in Hoop Layout mode.

Outline Select outline stitch for 
new and selected 
objects.

Show outline stitch types 
for selection.

Fill Select fill stitch for new 
and selected objects.

Show fill stitch types for 
selection.

 

Stitch 
Angles / Val-
ues

Add stitch angles to 
closed objects with or 
without holes.

 

Remove 
Stitch 
Angles

Remove stitch angles 
from closed objects with 
turning stitches.

 

Star Fill Generate radial turning 
stitching in several stitch 
types such as Satin and 
Tatami stitch.

 

Wave Fill Contour fill stitches along 
a digitized guideline 
maintaining uniform den-
sity and needle penetra-
tion patterns.

Color list List available thread col-
ors.

Group Same as Arrange > Group.

Ungroup Same as Arrange > Ungroup.

Lock Lock selected object/s into 
position for protection.

Unlock Unlock selected locked object/s 
to remove protection.

Align Left 
(Vertical) 

Left-align selected objects.

Align Centers
(Vertical)

Vertically align centers of 
selected objects.

Align Right 
(Vertical) 

Right-align selected objects.

Align Top 
(Horizontal)

Aligns top of selected objects.

Align Centers 
(Horizontal)

Horizontally align centers of 
selected objects.

Align Bottom 
(Horizontal)

Align bottoms of selected 
objects.

Align Centers Align centers of selected 
objects to design center.

Space Hori-
zontally

Evenly distributes three or more 
selected objects horizontally.

Space Verti-
cally

Evenly distributes three or more 
selected objects vertically.

Mirror- Merge 
Horizontal

Mirror-merge horizontally.

Mirror- Merge 
Vertical

Mirror-merge vertically.

Mirror- Merge 
Horizontal & 
Vertical

Mirror-merge horizontally & ver-
tically.

Wreath Duplicate objects around a cen-
tral point.

Kaleidoscope Mirror objects around a central 
axis.

Show Individ-
ual Objects

View individual objects in order 
of stitching sequence. Drag 
and drop object icons to rese-
quence.

Sequence As 
Selected

Resequence selected objects.

Sequence By 
Color

Resequence objects by color.

Sequence to 
Start

Place selected object at start of 
stitching sequence.

Sequence to 
End

Place selected object at end of 
stitching sequence.

Selection On Select hoops in the Design 
Window.

Reshape 
Splitting 
Guide

Reshape split lines in the 
Design Window.

Add Hoop Center a new hoop in the 
Design Window in an upright 
orientation.

Add Hoop 
Right

Place a new hoop directly to the 
right of a selected hoop with a 
10 mm overlap between sew-
ing fields.
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Add Hoop Up Place a new hoop directly 
above a selected hoop.

Add Four 
Adjacent 
Hoops

Automatically add four hoop-
ings around a selected hoop’s 
perimeter.

Add Eight 
Adjacent 
Hoops

Automatically add eight hoop-
ings around a selected hoop’s 
perimeter.

Splitting 
Guide

Digitize one or more split lines 
in a multi-hooped design prior 
to outputting to file, machine or 
memory card.

Delete Hoop Remove selected hoops from 
the Design Window.

Rotate Hoop 
Left / Right

Click left or right mouse buttons 
to rotate selected hoop 45° in 
either direction.

Calculate 
Hoopings

Evaluate hoopings that will 
result from current hoop layout.
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BERNINA Portfolio Quick Reference 
Guide

This Quick Reference Guide describes all menu options and toolbars available in 
BERNINA Portfolio.

BERNINA Portfolio Display Window

Portfolio menu bar
The Portfolio display window menu bar contains the 
pulldown menus described below. Some commands 
are reproduced as toolbar buttons. Underlined letters 
in a menu item allow you to select it without using the 
mouse, by first pressing the Alt key and then the 
underlined letter. To cancel the operation, press Esc 
twice.

File menu

Change Design View

Folders

Design thumbnails
contained in

selected folder

Status bar

Menu bar
Toolbar

Split bar

New Open new template in BERNINA Embroi-
dery Software.

Open with 
BERNINA 
Embroidery 
Software

Open design with BERNINA Embroidery 
Software.

Open Open design in BERNINA Embroidery 
Software or pictures in graphic programs.

Print Catalog Print designs as thumbnails with or with-
out descriptions.

HTML Catalog Output design catalog as HTML file suit-
able for publishing on the Web.

Export Design 
List

Output design information as text file suit-
able for import to database or spread-
sheet.

Create Zip 
Archive

Output design information as zipped file 
suitable for emailing or storing on disk.

Extract Zip 
Archive

Open design information as zipped file 
from for email or storage on disk.

Print Worksheet Print selected designs.

Write to Card/
Machine

Write selected designs to Bernina design 
card.

Convert Convert designs to selected formats.

Properties Open Properties dialog of the selected 
design.

Exit Close all open designs and exit Portfolio 
program.
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Edit menu

View menu

Portfolio General toolbar
The BERNINA Portfolio window contains only one 
toolbar described below. Some buttons are shortcuts 
to the pulldown menu commands.

General toolbar

Cut Delete selected files and place on clipboard.

Copy Copy selected files to clipboard. 

Paste Paste contents of clipboard to a folder.

Delete Delete selected files without placing on clip-
board.

Select All Select all designs in folder.

Deselect All Deselect all designs in folder.

Design Thumbnails Show files in folder as thumbnails.

Design Thumbnails 
and Summary

Show thumbnails and summaries of 
files in folder.

Design List Show file details such as design 
name, file size, file type and date.

Sort Select method to sort designs.

Sort by Design Name Sort designs by name. *

Sort by File Type Sort designs by file type. *

Sort by File Size Sort designs by file size. *

Sort by Last 
Changed

Sort designs by creation date. *

Refresh Update design file display.

Refresh Folder Update folder display.

Validate and Refresh Validate and refresh folders.

Browse Location Select folders from folder tree.

Folders Toggle folder tree on/off.

Change Locale Switch to other installed languages.

User Preferences Adjust default settings.

Customize Columns Customize design lists.

* Repeat to switch between ascending and descending order.

Open Same as File > Open

Print Selected Designs Same as File > Print

Stitch Selected 
Designs

Same as File > Write to 
Card/Machine

Convert Selected 
Designs Same as File > Convert

Hide/Show Folders Same as View > Folder

Sort Same as View > Sort

Change Design View Change design views 
(thumbnail, thumbnail and 
summary, and design list)

WinZip Same as File > Create Zip 
Archive

Design Properties Same as File > Properties
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Keyboard Shortcuts

You select commands in BERNINA Embroidery 
Software in the same way as other MS Windows® 
applications – from menus or toolbars. Keyboard 
shortcuts are also available for the most frequently 
used commands.

General functions

Select objects

View designs

View stitching sequence

Digitizing & lettering

To Press

Cancel command E 

Exit the program A+4 

Open existing design C+o 

Print design C+p 

Redo command C+y 

Save design C+s 

Start new design C+n 

Undo command C+z 

To Press

Activate Select Object tool o 

Add next object to selection C+T 

Add previous object to selection C+V+T 

Deselect all objects E or x 

Select a range of objects V+[

Select all objects C+a 

Select multiple objects C+[

Select next object T 

Select object underneath 2+[

Select previous object V+T 

To Press Or

Center current stitch c 6 

Measure M

Redraw the screen r 4 

Return to previous view v 5 

Show needle points . (period or full 
stop)

Show outlines (BERNINA Quilter only) V+L

Show previous view V 5

Show selected objects only V+S

Show whole design 0 (zero) 2 

Show/hide connectors V+C

Show/hide picture d 

Show/hide vectors V+d

Specify zoom factor f 3 

Turn on/off Artistic View T

Zoom (box) b then 
[

8 

Zoom factor f 3

Zoom in 2x z

Zoom out 2x V+z 0 

Zoom to 1:1 scale (100%) 1 

To travel
Press

Keyb’rd Keypad*

1 segment backward C+l 

1 segment forward C+r 

1 stitch backward † l 4

1 stitch forward † r 6

10 stitches backward † t 8

10 stitches forward † b 2

100 stitches backward - 

100 stitches forward + 

Activate Slow Redraw V+r

To next color d 9

To next object C+t 

To next selected object T

To previous color u 3

To previous object V+t 

To previous selected object V+
T

To the end of a design e 1

To the start of a design h 7

* Num Lock OFF † Select Object tool OFF

To Press

Activate Double Run V+b

Delete the last input point * B 

Finish digitizing an object * R or s

Turn underlay on/off u 

* BERNINA DesignerPlus only

To Press Or
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Manipulate objects and stitches

Cut & paste objects

Display the lettering dialog a 

To Press or click

Nudge selected designs t b l r 

Move an object horizontally or verti-
cally

:+C
Drag the object

Maintain an object’s proportions 
while resizing 

† VL+:
Drag corner handle

Reshape selected object h

Change reshape node type [+M 
Select reshape 
node and press 
spacebar

Group selected objects C+g 

Ungroup selected objects C+u 

Regroup ungrouped objects * C+R

Lock selected objects K

Unlock selected objects V+K

Bring object to front * V+u

Bring object forward * u

Send object to back * V+d

Send object backward * d

Activate Stitch edit e 

† Use Alt+Drag with BERNINA Quilter * BERNINA Quilter only

To Press

Cut object C+x 

Copy object C+c 

Paste object C+v 

Duplicate object C+d 

Clone object ]+:

Reinforce an outline C+b

Delete selected object(s) or the last 
object

D 

To Press

* BERNINA DesignerPlus only
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PART X
PRODUCT FEATURE LIST
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BERNINA Embroidery Software Product Feature List

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

View designs Viewing Designs
View designs in Art Canvas mode Art Canvas Art Canvas mode
View designs in Embroidery Canvas mode Embroidery Canvas Embroidery Canvas mode
View designs in Hoop Layout mode Hoop Layout Hoop Layout mode
Working with hoops Hooping Designs
Create multi-hooped designs Hoop Layout Creating multi-hoop designs
Split objects between hoopings Splitting Guide Splitting objects between hoopings
System setup Hardware & Software Setup
Set automatic scrolling Setting auto scroll options
Thread colors and thread charts Thread Colors & Charts
Change colors in entire design Changing entire design colors
Digitizing with backdrops Digitizing with Backdrops
Scan bitmap images Scanning artwork
Load bitmap and vector pictures Loading pictures
Edit images in a graphics application Touch Up Picture Editing images in graphics applications
Prepare non-outlined images Image Preparation Preparing non-outlined images
Prepare outlined images Outlined Image Prepa-

ration
Preparing outlined images

Automatic digitizing Automatic Digitizing
Convert vectors to embroidery Convert to Embroidery Converting vectors to embroidery
Convert embroidery to vectors Convert Selected 

Embroidery to Art Vec-
tors

Converting embroidery to vectors

Create automatic outlines and borders Auto Digitizer Creating automatic outlines and borders
Combining and sequencing objects Combining & Sequencing Objects
Manipulate color blocks and objects Color Film Sequencing objects with Color Film
Reshaping and editing objects Reshaping & Editing Objects
Adjust stitch angles Adjusting stitch angles
Specialized digitizing techniques Specialized Digitizing Techniques
Create freehand embroidery Freehand Draw 

Embroidery
Creating freehand embroidery

Create outlines and borders Outline Design Creating outlines and borders
Included as standard  New/improved feature/option
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Artistic stitch effects Artistic Stitch Effects
Create contour fills Contour Creating contour fills
Create cross stitch fills Cross Stitch Creating cross stitch fills
Creating star fills Star Fill Creating star fill effects
Pattern runs and fills Patterned Stamps, Runs & Fills
Create stitch patterns with carving stamps Carving Stamp Creating stitch patterns with carving stamps
Craft stitch borders and fills Craft Stitch Borders and Fills
Create ripple fills Ripple Creating ripple fills
Create stippling fills Stipple Creating stippling fills
Embroidery lettering Embroidery Lettering
Adjusting individual letters (reposition, transform, 
reshape)

Adjusting individual letters

Embroidery lettering – special Embroidery Lettering
Convert text to embroidery Converting text to embroidery
Monogramming Monogramming
Create monogram lettering with initials Monogramming Creating monogram lettering with initials
Create monogram lettering with names Creating monogram lettering with names
Design processing Design Processing & Output
Print multi-hooped designs Printing multi-hooped designs
Output multi-hooped designs Outputting multi-hooped designs

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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APPENDIX A
TROUBLESHOOTING

This appendix provides help for solving problems in BERNINA 
Embroidery Software. It includes procedures for checking 
your system’s requirements and settings, reverting to 
original values, and testing disks and connections. It also 
describes how to log errors, and lists causes for common 
error messages and problems.

Solving problems in BERNINA 
Embroidery Software

If you encounter a problem, refer to the following 
sources for help:

BERNINA Embroidery Software Onscreen Manual – 
select Help > Onscreen Manual (or printed version)

BERNINA Embroidery Software Online Help – 
select Help > Help Topics
MS Windows® Online Help – select Start > Help
MS Windows® manual

Documentation supplied with your hardware.

Getting help

If you are unable to solve a problem, you should 
contact your dealer. Before seeking help, check that 
your PC meets the system requirements, and check 
the Security device messages and General problems 
sections in this chapter.

Reverting to factory settings

If you have made changes to the default settings in 
your software and you want to revert back to the 
factory settings, use the Revert utility.

To revert to factory settings

1 Exit BERNINA Embroidery Software.

2 On the MS Windows® Taskbar, click the Start 
button and select Programs > BERNINA Embroidery 
Software > Revert.
The Revert to Factory Settings dialog opens.

3 Select the items you want restored to factory 
defaults.

Note  Reverting to the original settings removes 
any changes you have made to styles, templates 
and hardware settings. New styles, templates and 
hardware settings are unaffected as they are 
saved separately.

4 Click OK. 

The selected items are restored to factory settings. 

Note  There is no confirmation message.
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PC specifications
Check that your PC meets the system requirements. 
Check CPU/RAM as well as hard disk space. The table 
below provides minimum system requirements.

Checking CPU/RAM specifications
Check your CPU and RAM specifications, and the 
version of MS Windows® you are running to ensure 
they meet the BERNINA Embroidery Software 
requirements. See PC specifications for details.

To check CPU/RAM specifications

1 On the MS Windows® desktop, right-click the My 
Computer icon and select Properties.

The System Properties > General dialog opens.

2 Check the MS Windows® version, the CPU and the 
amount of RAM. 

Checking your hard disk space
Check that your hard disk has enough space to run 
BERNINA Embroidery Software effectively. See PC 
specifications for details.

To check your hard disk space

1 Double-click the My Computer icon on your 

MS Windows® Desktop.

The My Computer window opens.

2 Right-click the hard-disk drive icon (usually C:) 
and select Properties.

The Properties > General dialog opens.

This tab shows the hard-disk capacity as well as 
any free space. This must be greater than 100 Mb 
or 10% of your total hard drive space, whichever 
is the greater amount.

Reconnecting BERNINA Portfolio to 
BERNINA Embroidery Software

Occasionally BERNINA Portfolio may fail to connect 
with BERNINA Embroidery Software. Follow the steps 
below to track down the problem.

To reconnect BERNINA Portfolio to 
BERNINA Embroidery Software

1 Check that your dongle security device is 
connected.

2 Close down BERNINA Embroidery Software, 
reopen it, then open BERNINA Portfolio.

3 If the problem persists, re-install BERNINA 
Embroidery Software.

Recovering from hardware or software 
failure

If your software crashes due to a hardware or 
software failure, recovery files are usually created. 
When you restart BERNINA Embroidery Software 
after such a failure, the design you were last working 
on is opened automatically or, if Auto Save was on, 
the backup file is retrieved. If a recovery file is 
opened, save the file to a new name with the ART 
extension.

Note  Do not save to the Backup folder or it will be 
deleted.

Item Minimum Requirements

CPU Single Core 1GHz or greater proces-
sor

Operating System Windows XP® SP2 (Home or Profes-
sional)

Internet Connection Optional: Internet connection for 
access to regular product information

Internet Browser Internet Explorer 6.x

System Memory 1GB for running multiple applications

Hard Disk Size 30GB available before installation

Free Disk Space 2GB or more than 10% of the Hard 
Drive Size, whichever is greater

Data Drives DVD-ROM drive for software installa-
tion

Graphics Card Support for High Color (16 bit) and 
high resolution (1024 x 768)

Monitor 15” or larger for on-screen digitizing

USB Ports Dedicated USB port for security 
device. Additional USB ports for 
Bernina Reader/Writer Box or direct 
machine connection.

Serial Ports Additional serial port for artista 
Reader/Writer Serial Box connection 
(optional)

Scanner MS Windows® XP compatible

Printer MS Windows® XP compatible

Mouse MS Windows® XP compatible

Sound cards Not required
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Once your recovery file has been saved and re-named 
with the ART extension, delete the recovery files.

To recover from hardware or software 
failure

1 Open MS Windows® Explorer.

2 Open the ..\Program Files\BERNINA\Embroidery 
Software 6 folder.

3 Open the Backup folder.

4 Select a BAK file and right-click.

5 Select Rename from the pop-up menu.

6 Change the BAK extension to ART.

7 Start BERNINA Embroidery Software.

8 Open the new file in BERNINA Embroidery 
Software.

9 Save As to a different location, not the Backup 
folder.

Unrecoverable errors

Deleting files with Delete Recovery
You can delete corrupt files using the Delete Recovery 
utility. Delete Recovery deletes files in the 
C:..\Program Files\BERNINA\Embroidery 
Software 6\Recover and C:..\Program 
Files\BERNINA\Embroidery Software 6\Backup 
folders. You should also periodically delete the backup 
files created by Auto Save.

Note  Some files such as MLG and DMP files can build 
up over time and take up disk space. You can delete 
them manually from MS Windows® Explorer.

To delete files with Delete Recovery

1 Exit BERNINA Embroidery Software.

BERNINA Embroidery Software must be closed 
before deleting recovery or backup files or it will 
NOT delete these files.

2 On the MS Windows® Taskbar, click the Start 
button, and select Programs > BERNINA 
Embroidery Software > Delete Recovery Files.

The Purge Recover and Backup Directories dialog 
opens.

3 Select Delete Backup Files if you want to delete 
back up files.

4 Click OK. 

If some files cannot be deleted, a message will 
display. Delete these files from the C:..\Program 
Files\BERNINA\Embroidery Software 6\Recover 
and C:..\Program Files\BERNINA\Embroidery 
Software 6\Backup folders manually, from 

MS Windows® Explorer. 

Tip  If the errors persist, try reverting to factory 
settings. See Reverting to factory settings for 
details.

Security device messages

This section describes the messages related to the 
security device. Most security device messages are 
caused by incorrect connection, access codes, 
interference or conflict from another hardware device 
on the PC.

Problem The system fails and displays ‘unrecoverable’ 
error. 

Cause The design you tried to open is corrupt.

Suggestion Delete any files in the C:..\Program 
Files\BERNINA\Embroidery 
Software 6\Recover folder using the Purge 
Recovery utility, or manually via 
MS Windows® Explorer, then restart BERN-
INA Embroidery Software. You can also 
delete files using MS Windows® Explorer. 
See Deleting files with Delete Recovery for 
details.
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To prevent security device errors, enter all access 
codes as soon as you receive them. If you skip any 
access codes, features may become unavailable, or 
BERNINA Embroidery Software may stop working 
altogether. See Installation Notes for details.

Invalid Access Code

Installing the dongle driver
If your system cannot locate the dongle connection, 
you may need to reinstall the dongle driver.

To install the dongle driver

1 From the MS Windows® Taskbar, click the Start 
button and select Run.

The Run dialog opens.

2 In the Open field, enter:

C:..\Program Files\BERNINA\Embroidery 
Software 6\BIN\haspdinst.exe -i -kp -av

3 Click OK. 

A message informs you that the dongle driver was 
installed successfully.

4 Restart your PC.

Invalid product

Security Error

General problems

The following section refers to general problems you 
may experience with your designs.

Design dimensions

Inconsistent output results

Missing toolbar buttons

Message Invalid Access Code

Cause • The access codes you are trying to enter 
are incorrect for your security device.

• You are missing a set of codes.

Suggestion Check the ID code on the access code sheet 
to see whether it matches the ID code in the 
Security Dialog. If they do not match, note 
your security device Serial Number and cur-
rent ID code and contact your distributor.

Message Invalid product

Cause The security device cannot be found, or is 
damaged.

Suggestion Check the installation of the security device to 
ensure it is fitted correctly. Contact your dis-
tributor with your Dongle Serial Number.

Message Security Device Not Found (-3)

Cause The hardware or security device is faulty, or 
the security device is not correctly plugged in.

Suggestion Check the installation of the security device to 
ensure it is fitted correctly.
Try using another port and restarting the soft-
ware. If this does not work contact your dis-
tributor with your Dongle Serial Number.

Problem Dimensions of design are incorrect.

Cause If the design’s dimensions are too large or too 
small, the system units of measurement may 
be set incorrectly. The units of measurement 
are set in MS Windows® Regional settings.

Suggestion Change the units of measurement in 
MS Windows®. Select Start > Settings > Con-
trol Panel > Regional and Language Options.

Problem Problems when sending designs to embroi-
dery machines for stitching. Inconsistent 
reading and writing.

Cause Serial or USB communications problems. 
Inconsistent reading and writing may be 
caused by wrong port settings in the operat-
ing system. 
Other possible causes are that machine and 
software versions may not be compatible. In 
this case, contact your dealer.

Suggestion Change the port settings. 

Problem Buttons missing from toolbars or bottom of 
toolbars.

Cause Screen resolution is set too low.
Virus in computer.

Suggestion Change the screen resolution to 800x600 or 
higher.
Run your virus checker.
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Resolving Exception Access Violation 
errors

The error message ‘Exception Access Violation’ can 
appear when zooming, using lettering, printing or 
scanning, saving designs, or viewing the Color Film. 
This problem generally relates to the display adapter 
driver and/or the display adapter itself. Try each of 
the following solutions in sequence.

Exception access violation at startup

Other exception setting violations

Check the display adapter

Use the following procedure to determine which 
display adapter make and model you have, and what 
drivers are installed for the display adapter.

To check the display adapter

1 From the MS Windows® Start menu, open the 
Control Panel.

2 Double-click the System icon.

The System Properties dialog opens.

3 Select the Device Manager option.

The Device Manager dialog opens.

4 Click the Display Adapters node to open.

5 Note down the display adapter listed.

6 Right-click the adapter and select Properties.

7 Select the Driver tab and note the date of the 
driver.

8 Click Driver Details option.

Problem An ‘Exception Access Violation’ error mes-
sage appears when starting BERNINA 
Embroidery Software.

Cause A corrupt design file in the RECOVER folder 
or a corrupt ..\Program Files\BERN-
INA\Embroidery Software 6\RES\defaults.dfl 
file.

Suggestion Delete any files in the .....\Program 
Files\BERNINA\Embroidery 
Software 6\RECOVER folder. If BERNINA 
Embroidery Software still will not start, use 
MS Windows® Explorer to copy the default 
...\BIN\defaults.dfl file to the ...\RES folder, 
overriding the corrupt defaults.dfl file. This will 
reset BERNINA Embroidery Software to ‘new 
installation’.

Problem An ‘Exception Access Violation’ error mes-
sage appears when zooming, using lettering, 
printing or scanning, saving designs, or view-
ing the Color Film.

Cause This problem generally relates to the display 
adapter driver and/or the display adapter itself.

Suggestion Try each of the listed solutions in sequence. 
See Check the display adapter for details. See 
also Resolving Exception Access Violation 
errors.

Use the System utility in the Control Panel to check 
your display adapter and drivers.

Double-click System 
icon

Note down 
display 
adapter

Click to see
the driver

details
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9 Note down Provider and File Version details.

10 Cancel out of the dialogs and close the Control 
Panel window.

11 Check the display adapter manufacturer’s website 
for a more recent version of the driver. See Locate 
the latest display adapters for details.

Locate the latest display adapters
Some common problems are related to your PC’s 
display adapter. These occur more frequently with 
on-board graphics chipsets. Check the display 
adapter manufacturer’s website or a software driver 
download site for the latest display adapter driver. If 
there is a more recent driver available, download and 
install it. These are normally free from the provider. 
Some popular display adapter websites are:

www.ati.com

www.nvidia.com

www.matrox.com

www.diamondmm.com

www.download.com

www.intel.com

www.helpdrivers.com

www.neomagic.com

www.oaktech.com

www.s3graphics.com

www.sis.com

www.tridentmicro.com

www.tucows.com

www.windrivers.com

If your video card is integrated to your system board, 
please check the system board manufacturers 
website.

Reduce graphics acceleration
If you already have the latest driver installed, or if 
installing a newer driver does not solve the problem, 
you can reduce the MS Windows® graphics 
acceleration.

To reduce graphics acceleration

1 Access the Hardware Acceleration option in your 
system settings for Win 2000/XP:

Right-click the Desktop and select Properties. 

Select the Settings tab and click Advanced.

Select the Troubleshoot tab.

2 Reduce the hardware acceleration a ‘notch’.

3 Click OK.

You will be prompted to restart your computer.

4 When MS Windows® has restarted, see how the 
software runs. If it has not improved, try dropping 
the acceleration another notch.

Usually you should not need to reduce the 
acceleration by more than two notches to correct 
the problem. However, in extreme cases, you may 
need to reduce it to ‘None’.

Install a different model display adapter
In a very few cases updating the display adapter 
driver and/or reducing graphics acceleration will not 
solve the problem. The only solution is to install a 
different brand/model of display adapter. BERNINA 
International AG can advise on the type of display 
adapter to use. If you have another computer with a 
different display adapter, we recommended swapping 
the two. Often a ‘problem’ display adapter will work 
fine in another computer. 

Note down 
provider and file 
version

Reduce 
hardware 
acceleration
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APPENDIX B
TIPS & TRICKS

This appendix provides tips and tricks for getting the 
most out of your BERNINA Embroidery Software in 
combination with your BERNINA embroidery 
machine. It includes tips for stabilizing designs, 
hooping, thread and needle recommendations, 
lettering and appliqué, stitch quality, design 
management, and many others.

Tips and tricks

Add fabrics to appliqué designs created in the 
software.

Add hoops to your software by specifying new 
sizes in Hoop options and saving them for later 
use.

Adjust stitch width and spacing of blanket stitching 
on your appliqué designs.

Remember to save while working. Start off with a 
‘Save As’ as soon as you open a design so that you 
don’t mistakenly save over the original.

Always do a test sew-out on a similar fabric, 
stabilizer, and thread, before embroidering of your 
final design.

Always print your design template using a hoop 
that includes the x-y axis. This provides reference 
points - start and center point – to verify the 
design position on the machine.

Appliqué can be done as a trim-in-place or pre-cut.

Ball Point needles should be used on knit fabrics. 
The slightly rounded needle tip will slip between 
the knit fibers and keep it from making runs or 
holes.

Bernina artista machines and the 830 allow you to 
wind extra bobbins while embroidering.

Click an object to select it, or hold down the #2 key 
while clicking to cycle through layered objects.

Create advanced appliqués with the advanced 
open-object Advanced Appliqué function.

Digitize reference lines to help position designs. 
Use lines saved with the template to position 
designs accurately on the project. 

Don’t stretch fabric when placing in the hoop. 

Don’t forget the underlay. Underlay attaches the 
fabric to the stabilizer to further stabilize the 
design. BERNINA Embroidery Software V6.0 
automatically adds underlay to both automatically 
digitized and manually digitized designs.

You can preset underlay settings before you 
digitize. 

Quickly send designs to your Bernina embroidery 
machines using File/Card Machine Write or the 
Write to Machine tool.

For proper placement of a left chest design, lay 
your garment on a flat surface. Draw imaginary 
lines down from the top of the shoulder, then 
across through the middle of the sleeve. The 
center should be where the two lines intersect.

Grade ‘A’ art files will retain their integrity when 
resizing and give more editing possibilities.

If the start point is in the design center, select 
Arrange > Start and End to move it to the best 
reference point for perfect placement on the 
machine.

If positioning manually, digitize a boundary line 
around the inside of the hoop. As the embroidery 
machine auto-centers, the boundary line will keep 
your arrangement in position. Simply skip the 
boundary line when stitching out. 

Press the (.) key to see all needle points in a 
design.



Appendix B : Tips & Tricks

BERNINA® Embroidery Software : Onscreen Manual 328

It’s easy to convert a Satin appliqué to a Blanket 
stitch. 

Large letters work better if the density is a little 
higher, whereas small letters work better at lower 
density.

Lettering doesn’t have to be Satin stitching. If it is 
to be stitched onto a gym bag or similar high-use 
item, consider changing the stitch type to, say, 
Tatami. 

Make sure the inner hoop is all the way into the 
outer one. The inner should be flat on the machine 
bed in order to form a proper stitch.

Marking placement lines on your fabric or project 
is important. Make sure your project is always 
hooped straight. 

Once you have created your appliqué shape(s), 
the software will automatically create placement 
line, tack down, and cover stitching with color 
stops. 

Polyester embroidery thread is stronger than 
rayon thread and is colorfast, chlorine bleach 
resistant, UV resistant and will not take on other 
colors or bleed onto your project.

Portfolio is a great tool for organizing designs in 
many formats. 

Portfolio allows you to view your designs several 
ways: design only, design with details, and list. 

Portfolio allows you to sort designs by name, size 
and date. 

Portfolio allows you to print a design catalog 
showing all designs on your computer. 

Portfolio allows you to zip and unzip designs. 

Portfolio allows you to batch convert your designs.

You can send multiple designs from Portfolio to 
your embroidery machine.

You can insert multiple designs directly from 
Portfolio.

Print out the appliqué pattern when using the tools 
in artista for cutting appliqué fabric shapes.

Scan pictures into the software and create 
decorative embroidery frames around them. 

Press the Escape key to deselect any current 
selection in the software.

Slow Redraw simulates the actual design stitchout. 
With BERNINA Embroidery Software V6.0, you can 
set the stitch number to begin from.

Stabilizing is the most important issue with 
embroidery. Your dealer has lots of information 
about choosing the right type of stabilizer for your 
embroidery projects.

The Onscreen Manual has a list of shortcut keys to 
make using the software faster.

The Blackwork Run tool makes outlining your 
design a snap. It automatically eliminates jump 
stitches by resequencing the stitching.

BERNINA Embroidery Software V6.0 will 
automatically digitize TrueType fonts.

The Partial Appliqué tool will remove overlapping 
appliqué stitches. 

The Polygon Select tool lets you easily select a 
portion of a design. 

The Remove Overlaps tool works to remove excess 
stitching under objects or lettering.

The Stitch Resequence feature will give you the 
best sewing sequence, fewer color changes, and 
fewer hoopings.

There are 30 Step Fill types.

There are 55 fonts in EditorPlus and 70 fonts in 
DesignerPlus.

There are several ways to get designs from 
computer to your machine: direct connection, via 
BERNINA USB stick, or using a Personal Design 
Card.

To check if you have the right needle, pierce the 
fabric with the needle. It should go in easily and 
shouldn’t leave a hole. A smaller rather than larger 
needle may be needed for denser designs.

To keep your embroidery machine running 
smoothly, always keep it clean. Follow the 
manufacturer’s instructions for cleaning and oiling. 
Take your machine in for service when needed. If 
you take care of it, it will take care of you.

To place a design on the center front of a garment, 
use the sleeves as your guide. Fold the shirt down 
the middle to get the vertical placement, then use 
the center of the sleeves as your horizontal 
placement. 

To select a design color, select the color chip in the 
Color Film dialog. To view just that color, select 
View > By Color.

Try a new colorway to perk up an old design. Do a 
design in a single color, or scale it back from many 
to only two or three colors. You’ll get a totally 
different look. Use the new Color Wheel tool to test 
new colors. New thread colors will automatically be 
assigned to the design.

Turn the hoop off when positioning multiple 
designs to avoid the distraction of watching it 
‘move’ as you add to the composition. When 
satisfied with the design arrangement, turn the 
hoop on to verify that the design fits within the 
embroidery field.
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Undo is your friend – you can undo up to 256 times 
or to the last save.

Use the ‘hoop relocator’ for easier threading on the 
embroidery machine.

Use the Alignment tools to align selected objects to 
left, right, top, bottom, or center of the last object 
selected.

Use the Multiple Spool Holder to ensure optimal 
threading of various brands of embroidery thread. 
The Multiple Spool Holder also allows you to view 
the colors you will use for the design.

When using the Wreath tool, you can merge any 
overlapping objects, making the two objects into 
one. 

Use the Wreath tool with alphabets and numbers 
to create fun designs.

When copying and pasting a design be sure to 
group it first. Check the Color Film for duplicate 
copies and eliminate them by pressing the Delete 
key.

When stitching embroidery on stretchy fabric, 
always use cut-away stabilizer to stabilize the 
fabric. 

When embroidering on towels or anything with a 
nap, a topping should be used - generally a 
water-soluble one. This will keep the ‘pokies’ from 
coming through the embroidery as well as keep 
stitches on top of the fabric.

When embroidering small lettering, use the 
smallest needle possible for smoother edges and 
easier reading.

When the embroidery is finished, cut or tear away 
excess stabilizer by holding the project in your lap 
toward you. This will help you avoid those ‘V’ 
slashes in the project when you can’t see it while 
removing the tear-away.

When removing the excess tear-away, hold onto 
the stitches and don’t tear into them. Remember 
it’s tear ‘away’ not tear ‘into’.

When trimming the bobbin thread, don’t trim it too 
close. Leave a little tail. This will keep stitches in 
front from coming loose. If they are close together, 
leave them alone – don’t trim at all.

Whenever possible, always hoop the project and 
stabilizer together in the hoop. 

With Color Film you can change the stitch order of 
your design. 

With Color Film you can easily change design 
colors. 

With Color Film you can view the design 
color-by-color. 

With Elastic Lettering you can create unique 
lettering styles.

With Arc Baselines you can set the lettering radius. 

You can adjust letter kerning, creating more or less 
space between letters – helpful especially when 
using a lower arc baseline.

You can apply pull compensation to an object.

You can change entry and exit points of an object 
simply by moving the green diamond (entry) and 
the red plus (exit) icons when using the Reshape 
tool.

You can make a quick quilt label using the 
Rectangle tool and selecting from the many 
pattern outlines, then adding your message. The 
monogram program is also great for making 
labels.

You can manually set Blanket stitch width and 
spacing through Object Properties.

You can set or change the stitch angle of a fill 
through Object Properties.

You can view what each font looks like together 
with recommended min and max sizes in your 
Onscreen Manual. Print these pages out for quick 
reference.

Your Onscreen Manual is found under the ‘Help’ 
menu.

Stitch count is displayed in the bottom right corner 
of the screen along with the height and width of 
design.
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APPENDIX C
ALPHABET SAMPLES

The embroidery alphabets shown in this appendix are a part of your BERNINA 
Embroidery Software although not all alphabets are included in all product 
levels.

For the best results when stitching, do not exceed the maximum or minimum 
recommended sizes. Note, however, that recommended heights refer to UPPER 
CASE letters. Most embroidery alphabets are digitized from an original 
TrueType Font (TTF), some of which have lower-case letters – e.g. a and c – 
which are about 70% the height of a capital letter. As a result, these letters 
may be too small to embroider neatly at minimum sizes. You may need to 
increase the size of the lower-case characters to suit the embroidery. See also 
Adding lettering to embroidery designs.

For best results, always check that the correct type of underlay is selected. 
Apart from stabilizing, underlay helps give ‘loft’ or to raise your lettering off 
the fabric. The size of your lettering will determine the type of underlay you 
need to apply. Small, narrow letters may not require automatic underlay, 
depending on their size and the fabric to be stitched on. If auto underlay is 
used, it will show outside the stitched columns. Lettering with heights under 5 
mm should not have underlay. Letters 6 mm to 10 mm can have a center-run 
underlay applied. Lettering larger than 10 mm is large enough for edge-run 
underlay. See Stabilizing with underlays for details. See also Removing 
underlay from small lettering.

Note  You can create special characters in each alphabet by holding down the 
Alt key on your keyboard and typing 0 (zero), its code, using the numbers on 
the keypad. For example, to type ê with the code 234, type Alt+0234. The 
accented letter will appear when you release the Alt key. See also Adding 
special characters.
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Abby Script

Abby Script is a traditional one-color script alphabet. It is great for names. Use 
extra pull compensation at smaller sizes.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.50 in 13 mm
Maximum 2.8 in 70 mm
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Alice

Alice is a traditional decorative style suitable for initials/monograms and 
personalization.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Anniversary

Anniversary is a stylish script with fine curves and flourishes. It is popular for 
personalizing garments. Use extra pull compensation at smaller sizes.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.50 in 13 mm
Maximum 3.0 in 75 mm
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Bamboo

Bamboo is an oriental style alphabet. It can be used as a decorative alphabet 
by restaurants or martial arts clubs to convey an Asian influence.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 1.6 in 40 mm
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Blackboard

Blackboard is a classic serif-style alphabet. It has been popular for many years 
and is common in logos and educational designs.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Bodoni

Bodoni is a classic, high-contrast alphabet best suited to larger sizes or with 
very stable fabric.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 7 mm
Maximum 2.0 in 50 mm
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Border-CAPS

Border-CAPS is a two-color block alphabet. It is used on sporting, school or 
college wear.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 2 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13mm
Maximum 1.5in 38mm
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Broadsheet

Broadsheet has a Satin outline around the outside edge of the letter shapes. 
The letters have solid, heavy appearance, with a serif-effect. This alphabet 
should be used in larger sizes.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching CAPS - Satin

Recommended letter height
Minimum 1.2 in 30 mm
Maximum 3.0 in 75 mm
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Castle

Castle is a classic romantic alphabet suitable for monograms or to convey a 
medieval or old world feel to restaurants or advertising material.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.75 in 10 mm
Maximum 1.6 in 40 mm
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Centurion

Centurion is a compact alphabet with strokes curving into serifs perpendicular 
to the letter strokes. It is more suited to medium-larger sizes. 

Alphabet contains Characters A - Z, a - z, 0 - 9, Punctuation and symbols, 
European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13 mm
Maximum 2.4 in 60 mm
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Chicago

Chicago is a modern very squarish athletic-style alphabet, with half-serifs. Its 
solidity makes it well suited to large lettering on heavier fabrics, such as 
athletic wear and jeans.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 3.0 in 75 mm
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Childs Play

Childs Play is a fun alphabet, based on children’s handwriting.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13 mm
Maximum 1.2 in 30 mm
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Christopher

Christopher is a very rounded style. It suits children's wear, sportswear and 
modern designs.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 1.2 in 30 mm
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Craft

Craft is a modern narrow upright block, more suited for use on stable fabrics.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.4 in 10 mm
Maximum 2.0 in 50 mm
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Creative Cross

Creative Cross is decorative alphabet which can be used to embellish children’s 
wear. Capital letters include a design whereas the lower case letters are plain.

Alphabet contains Letters A - Z are letters with designs, a - z are letters only
Designs only on keys ! " # $ % & ' ( ) * + , - . / 01234567890

Colors Multi-color

Stitching Manual/cross stitches

Recommended letter height
Minimum 1.2 in 30 mm
Maximum 4.0 in 100 mm
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Croissant

Croissant is a specialist fancy style, giving a completely different look from 
most other alphabets. It is suitable for restaurants, homewear and other 
people-oriented designs.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 2.0 in 50 mm
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Cursive

Cursive is a basic script-style alphabet, with simply-formed capital letters. The 
thickness of the strokes is reasonably uniform, making this style usable across 
a wide range of sizes.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.28 in 7 mm
Maximum 2.4 in 60 mm
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Detex Normal

Detex Normal is a distinctive style. It has squarish letters in upper-case, with 
the effect of an open bar on the left size. It makes an attractive monogram.

Alphabet contains Characters A - Z, 0 - 9, Punctuation and symbols, Euro-
pean/special characters

Colors 1 color

Stitching CAPS - Satin

Recommended letter height
Minimum 0.35 in 9 mm
Maximum 2 in 50 mm
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Diamond2

Diamond2 is a special alphabet which includes two versions of each letter for 
left and right positions, plus a border and flourish for two-letter designs.

Alphabet contains

Left and Right letters for 2-letter monogram, 2 Borders as 
shown. To create a monogram, use upper case for the left 
letter, and lower case for the right letter, and either left 
square bracket [ or right square bracket ] for the border. 
For example, to create the first monogram shown above 
type Ab[.

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.7 in 18 mm
Maximum 4.0 in 100 mm

For left-hand letters, type uppercase For right-hand letters, type lowercase
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Diamond3

Diamond3 is a special alphabet which includes three versions of each letter for 
left, center and right positions, plus a border and flourish for 3-letter designs.

Alphabet contains

Left, Center and Right letters for 3-letter monogram, plus 
2 borders as shown. To create a monogram, use upper 
case for the left letter, the symbol key shown above for 
center letter, and lower case for the right letter, with either 
left square bracket [ or right square bracket ] for the bor-
der. For example, to create the first monogram shown 
above type A"c[.

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.7 in 18 mm
Maximum 4.0 in 100 mm

For left-hand letters, type uppercase

For right-hand letters, type lowercase
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Drifter

Drifter is a bold, relaxed style, with curves throughout. It has an Art Deco feel, 
and can be used in most situations.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 1.6 in 40 mm
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Easy Appliqué

Easy Appliqué makes appliqué letters which have uneven stroke width and 
rounded serifs. Each letter includes three stitching layers – first a placement 
line, then a zigzag tackdown, and finally a Satin cover stitch.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color (cover stitch)

Stitching Appliqué

Recommended letter height
Minimum 1.2 in 30 mm
Maximum 2.8 in 70 mm
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Eliza

Eliza is a one-color script alphabet designed for monogramming.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.8 in 20 mm
Maximum 3.2 in 80 mm
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Empress

Empress is an elegant calligraphic script style with a rich, classical look and 
small lower-case letters. It is reminiscent of wedding and similar invitations, 
and is suitable for gifts and special occasions.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13 mm
Maximum 2.4 in 60 mm
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Energy

Energy is a fun, fast-paced style, which looks like quickly-written, hand-printed 
notes. It is suitable for larger lettering in youth-oriented designs.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 2.4 in 60 mm
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Erica

Erica is a graceful script alphabet based on Espania font and designed for 
monogramming.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.6 in 15 mm
Maximum 2.3 in 55 mm
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Felt Tip

Felt Tip is a Gothic alphabet in the style of historic English fonts. It can be 
applied to gifts and personalised items.

Alphabet contains
Characters A - Z, 0 - 9
Punctuation and symbols
European/special characters

Colors 1 color

Stitching Normal - Satin

Recommended letter height
Minimum 0.4 in 10 mm
Maximum 2 in 50 mm
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Flair Script

Flair Script is a graceful script with added flairs underneath. Flairs either fit 
snugly under the letters or are lowered to accommodate descenders. For Flair 
characters type keys as shown. Flairs can be for letters with or without 
descenders. For example, for the first example, type 4 abc[. See Adding flair 
script lettering for details.

Alphabet contains Characters A - Z, a - z, 0 - 9, Punctuation and symbols, 
Flair characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.75 in 10 mm
Maximum 3.2 in 80 mm
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Fortress

Fortress is solid block-style alphabet with simple clean lines. It is suitable for 
use on heavier fabrics.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 1.6 in 40 mm
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Greek

Greek is a classic serif-style. It is suited for educational institutions, 
restaurants, and events such as marriages and births in Greek communities.

Alphabet contains Greek letters, 0 - 9, and some punctuation and symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 2.0 in 50 mm
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Greek Ionic

Greek Ionic is a san-serif style alphabet. As it is an easy to read alphabet, it 
can be applied to a wide range of personal and corporate uses in Greek 
communities.

Alphabet contains Greek letters, 0 - 9, and some punctuation and symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.4 in 10 mm
Maximum 2.0 in 50 mm



Appendix C : Alphabet Samples

BERNINA® Embroidery Software : Onscreen Manual 362

Guinevere

Guinevere is based on the old writing styles of Welsh and Irish texts. It is 
decorative and suited for a wide range of uses such as souvenirs, linen, 
restaurants, some ethnic designs, etc.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13 mm
Maximum 2.0 in 50 mm
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Hebrew 2

Hebrew 2 is a modern square Hebrew alphabet. It is a compact alphabet which 
can be applied to a wide range of uses in Hebrew communities.

Alphabet contains Hebrew letters, 0 - 9, and some punctuation and symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 1.6 in 40 mm
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Hebrew David

Hebrew David is a modern Hebrew alphabet with rounded letters. As it is an 
easy to read alphabet, it can be applied to a wide range of uses in Hebrew 
communities.

Alphabet contains Hebrew letters, 0 - 9, and some punctuation and symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.28 in 7 mm
Maximum 1.6 in 40 mm
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Hiragana

This is a special alphabet with Japanese Hiragana symbols for each letter.

Alphabet contains Japanese Hiragana characters. See print manual Alpha-
bets appendix for details of input keys.

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.50 in 13 mm
Maximum 2.0 in 50 mm
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Impact 3D

Impact 3D is a raised 3D alphabet to be stitch out with 3 mm thick foam only. 
It looks good if you follow the recommended lettering heights. It can be 
applied to items that don’t require frequent washing as this will tend to 
damage the foam.

Alphabet contains Characters A - Z, 0 - 9

Colors 1 color

Stitching Normal - Satin, additional underlay not required

Recommended letter height
Minimum 0.8 in 20 mm
Maximum 1.4 in 35 mm

Special
Foam 3 mm
Thread tension 
setting -2
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Island

Island is a bold script-style alphabet, with connecting lower-case letters. The 
thickness of the strokes is even throughout. It is popular and versatile. 

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Jikharev

Jikharev is based on the Russian Cyrillic alphabet. It is easy to read and can 
be used for many purposes, both personal and corporate.

Alphabet contains Russian/Cyrillic letters, 0 - 9, and some punctuation and 
symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 2.0 in 50 mm
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Katakana

This is a special alphabet with Japanese Katakana symbols for each letter.

Alphabet contains Japanese Katakana characters. See print manual Alpha-
bets appendix for details of input keys.

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.50 in 13 mm
Maximum 2.0 in 50 mm
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Ketchikan

Ketchikan is an ornate all caps alphabet which is commonly used for 
restaurant, clothing and other business names where style and fashion are 
important.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 1.2 in 30 mm
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Kindergarten Block

Kindergarten Block is a fun alphabet which has many applications for children’s 
wear. 

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching CAPS - Satin

Recommended letter height
Minimum 0.4 in 10 mm
Maximum 3.6 in 90 mm
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King Charles

King Charles is a fancy alphabet style with proportionally large lower-case and 
long ascenders. It creates an old-style formal and elegant impression.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Lazer

Lazer is a modern techno-style alphabet with rounded corners consisting only 
of upper case letters, small and large. It looks good when applied to modern, 
clean designs, particularly with a techno theme.

Alphabet contains Characters A - Z, a - z, 0 - 9, Punctuation and symbols, 
European/special characters

Colors 1 color

Stitching Normal - Satin

Recommended letter height
Minimum 0.24 in 6 mm
Maximum 2 in 50 mm



Appendix C : Alphabet Samples

BERNINA® Embroidery Software : Onscreen Manual 374

Lisa

Lisa is a hand-writing style where lower-case letters join together. It is popular 
for monograms, but is not suitable for use with many capital letters together.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.50 in 13 mm
Maximum 3.0 in 75 mm
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London

London is an easy-to-read sans-serif style alphabet with large lower-case 
letters. The stylish look suits both corporate and personal text.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Mandarin

Mandarin is an alphabet consisting of upper-case characters, with an Asian 
influence. It is used for Asian restaurants, martial arts clubs, etc.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 2.0 in 50 mm
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Medley

Medley has a hint of serif created by the flared ends of the strokes. It is very 
stylish, and suitable for masculine monograms. 

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.28 in 7 mm
Maximum 1.6 in 40 mm
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Meegan

Meegan is a one-color script alphabet designed for monogramming.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.6 in 15 mm
Maximum 2.2 in 55 mm
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Microgramma

Microgramma is a slightly boxy, wide, sans-serif alphabet.

Alphabet contains Characters A - Z, a - z, 0 - 9, Punctuation and symbols, 
European/special characters

Colors 1 color

Stitching Satin

Default Letter Spacing 10%

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 2.4 in 60 mm
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Neon-CAPS

Neon-CAPS is an alphabet which mimics the effect of neon lights. It can be 
used to give a modern hi-tech look in a wide variety of applications.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.7 in 18 mm
Maximum 3.0 in 75 mm
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Nightowl

Nightowl is a modern sans-serif alphabet with a noticeable italic slant and 
rounded ends. It is a popular style for advertising and designs with a carefree 
feeling.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 2.0 in 50 mm
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Olde English

Olde English is based on traditional medieval English calligraphy script. It is 
used for specialist lettering, and is especially popular for school, college and 
university badges.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.5 in 13 mm
Maximum 2 in 50 mm
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Phoebe Curls

Phoebe Curls is an ornamental capital-serif alphabet with floral background 
designed for monogramming.

Alphabet contains Characters A - Z (caps only)

Colors 1 colors

Stitching Satin

Recommended letter height
Minimum 0.6 in 15 mm
Maximum 1.4 in 35 mm
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Prestige

Prestige is a traditional block-style alphabet, popular for corporate logo work. 
It is quite bold and usually does not require additional pull compensation. It 
also works well with Elastic Lettering effects. See Creating special effects 
with Elastic Lettering for details.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.2 in 5 mm
Maximum 2.0 in 50 mm
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Quilting Text

Quilting Text gives a feel of hand stitching and is used to personalize blocks in 
quilts. It is a very small alphabet made of simple running stitches, as it is 
required to be subtle and blend into the quilt.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Run stitching

Recommended letter height
Minimum 0.16 in 4 mm
Maximum 0.25 in 6 mm
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Racer

Racer is a streamlined script alphabet with emphasized balled top ends. It 
recalls the chrome-strip lettering used on industrial goods of the 1930s and 
40s, such as enamelled refrigerators and automobile trunks. It looks good 
when applied to racing and sporting uniforms.

Alphabet contains Characters A - Z, a - z, 0 - 9, Punctuation and symbols, 
European/special characters

Colors 1 color

Stitching Normal - Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 1.4 in 35 mm
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Roman-Small

Roman-Small is a variant of Times Roman, specifically designed for use in 
smaller sizes.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.2 in 4 mm
Maximum 0.25 in 6 mm
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Rounded Block

Arial Rounded is based on the widespread 20th century realist sans-serif.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 1.8 in 45 mm
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Russian Textbook

As the name suggests, Russian Textbook is a standard textbook font based on 
Russian/Cyrillic letters, suitable for general use in logos, etc.

Alphabet contains Russian/Cyrillic letters, 0 - 9, and some punctuation and 
symbols

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 1.8 in 45 mm
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Scanner

Scanner has a modern, ‘hi-tech’ look. It is suitable for a wide variety of 
applications.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.28 in 7 mm
Maximum 1.6 in 40 mm
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Secret Garden-CAPS

Secret Garden-CAPS is a floral alphabet which can be used to decorate many 
items of clothing. Only the capital letters are embellished with flowers, the 
lower case letters are a plain sans serif.

Alphabet contains Letters A - Z (caps only), dash, and brackets

Colors Multi-color

Stitching Satin

Recommended letter height
Minimum 1.5 in 38 mm
Maximum 3.6 in 90 mm
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Speedy

Speedy is a bold, fast-paced modern alphabet.

Alphabet contains Characters A - Z, 0 - 9

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.3 in 8 mm
Maximum 1.2 in 30 mm
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Swiss Block

Swiss Block is based on Helvetica, the great all-purpose sans-serif alphabet. It 
is clean and simple, and suitable for any fabric.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 2.4 in 60 mm
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Tabloid

Tabloid has a Satin outline around the outside edge of the letter shapes. The 
letters have solid, heavy appearance, with a serif-effect. This alphabet should 
be used in larger sizes.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 1.2 in 30 mm
Maximum 3.0 in 75 mm
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Technical Block

Technical Block is a medium weight alphabet with squared serifs which stitch 
cross-ways. It is suitable for lettering in logos at a variety of sizes.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.32 in 8 mm
Maximum 2.0 in 50 mm
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Tiffany

Tiffany is an upright calligraphy script style where the letters do not join. The 
style is bold and extended, and suited for monograms, homewares, etc.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.28 in 7 mm
Maximum 1.4 in 35 mm
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Varsity Appliqué-CAPS

Varsity Appliqué-CAPS is a large alphabet suitable for making appliqué letters 
for college, school and university wear. Each letter includes three stitching 
layers – first a placement line, then a zigzag tackdown, and finally a Satin 
cover stitch.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Appliqué

Recommended letter height
Minimum 1.2 in 30 mm
Maximum 3.0 in 75 mm
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Varsity Block-CAPS

Varsity Block-CAPS is a bold serif block alphabet. It is suitable for athletic-style 
lettering on garments, and for general use in logos, etc.

Alphabet contains Characters A - Z (caps only), 0 - 9, punctuation and sym-
bols, and European/special characters

Colors 1 color

Stitching Satin 

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 1.4 in 35 mm
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Verdana

Verdana is a modern sans-serif alphabet that is very popular with web designs 
but lends itself to embroidery as a substitute, for example for Swiss Block.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum 2.4 in 60 mm
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Victoria

Victoria is an opulent alphabet reminiscent of late 19th century stylings.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.4 in 10 mm
Maximum 2.0 in 50 mm
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Zurich

Zurich is based on one of the most popular calligraphy hand-written styles. It 
is often used in logos and is very popular for personalization.

Alphabet contains Characters A - Z, a - z, 0 - 9, punctuation and symbols, 
and European/special characters

Colors 1 color

Stitching Satin

Recommended letter height
Minimum 0.25 in 6 mm
Maximum Letters 60 mm
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APPENDIX D
STEP FILL SAMPLES

The Step fill patterns shown in this appendix are a sample of those included with 
your BERNINA® Embroidery Software program. For actual Step fills and 
instructions on how to use them, see Creating fills with Step fill.

Note  Make sure you apply the correct stitch angle to each Step fill. The following 
samples have been digitized with a stitch angle of 0°. Experiment with different 
stitch angles to get new effects.

No. Stitch sample Preview

1

2

3

4

5

6

7

8

9

10

11

12

13

14

No. Stitch sample Preview
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15

16

17

18

19

20

21

22

23

24

25

No. Stitch sample Preview

26

27

28

29

30

No. Stitch sample Preview
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APPENDIX E
FANCY FILL SAMPLES

The Fancy fill patterns shown in this appendix are a sample of those included with 
your BERNINA Embroidery Software program. For actual Fancy fill patterns and 
instructions on how to use them, see Creating fancy fills.

ID & Angle Fancy Fill

001 Diamond 
(90)

002 Emerald 
(90)

003 Ruby (90)

004 Sapphire 
(90)

005 Topaz (90)

006 Jewel (90)

007 Brilliant 
(90)

008 Square (45)

009 Squarecut 
(45)

010 Brick1 (45)

011 Brick2 (45)

012 Brick3 (45)

013 BabyBlock 
(120)

014 3DBlock (0)

015 Roman (90)

016 Capri (45)

017 Frame (45)

018 Quilt1 (45)

019 Quilt2 (45)

020 Quilt3 (45)

021 Circle (90)

022 Wattle (90)

ID & Angle Fancy Fill
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023 Oval (90)

024 Whirlpool 
(90)

025 Dance (90)

026 Heart (90)

027 Heart2 (90)

028 Valentine 
(90)

029 Scallop 
(90)

030 Shell (90)

031 Smile (90)

032 Flower (90)

033 Ribbon (30)

034 Sunny (90)

035 Shine (90)

036 Star (90)

037 Stardust 
(90)

ID & Angle Fancy Fill

038 Honey-
comb (90)

039 Beeswax 
(30)

040 Wave (90)

041 Dunes (0)

042 Chevron 
(90)

043 Chevron2 
(90)

044 Chevron3 
(90)

045 Wedge (90)

046 Crazy (90)

047 Arrow (20)

048 Weave (48)

049 Weave2 
(90)

050 Stream (90)

051 Bowtie (0)

052 Chain (90)

ID & Angle Fancy Fill
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053 Glitter (90)

054 Cross (45)

055 Double-
cross (90)

056 Galaxy (90)

057 Ring (90)

058 Ramble 
(90)

059 Florastar 
(90)

060 Stripes (90)

061 Letter A 
(90)

062 Letter B 
(45)

063 Letter C 
(90)

064 Letter D 
(45)

065 Letter E 
(45)

066 Letter F 
(45)

067 Letter G 
(45)

ID & Angle Fancy Fill

068 Letter H 
(45)

069 Letter I (45)

070 Letter J 
(45)

071 Letter K 
(30)

072 Letter L 
(45)

073 Letter M 
(45)

074 Letter N 
(45)

075 Letter O 
(30)

076 Letter P 
(45)

077 Letter Q 
(30)

078 Letter R 
(45)

079 Letter S 
(45)

080 Letter T 
(45)

081 Letter U 
(45)

082 Letter V 
(45)

ID & Angle Fancy Fill
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083 Letter W 
(45)

084 Letter X 
(90)

085 Letter Y 
(30)

086 Letter Z 
(30)

087 Paver (90)

088 Picasso 
(135)

089 Ziggy (0)

090 Spirali (90)

091 Manchu 
(45)

092 Grilles (45)

093 Wooden 
Lattice (82)

094 Han Line 
(45)

095 Dart (10)

096 T-frame 
(45)

097 Dou-
ble-arm (87)

ID & Angle Fancy Fill

098 Knuckled 
frame (45)

099 Tile (0)

100 Alarm Tile 
(83)

101 Turtle-back 
(79)

102 Stepped 
Wave (45)

103 Crayon (0)

104 Diamond 
Inlay (0)

105 Corduroy 
(0)

106 Diamond 
Punch (0)

107 Inlay Print 
(0)

108 Snowflake 
(0)

109 Inlay Maze 
(45)

110 Quilt Dia-
mond 1 (0)

111 Quilt Dia-
mond 2 (0)

112 Quilt Dia-
mond 3 (0)

ID & Angle Fancy Fill
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113 Zig-Zag 
Inlay (0)

114 Shell Inlay 
(0)

115 Music 1 (0)

116 Music 2 (0)

117 Four 
Square (45)

118 Symbol 1 
(45)

119 Symbol 2 
(50)

120 Symbol 3 
(82)

121 Wave 2 (0)

122 Wave 3 (0)

123 Honey-
comb 2 (45)

124 Rope (0)

125 Tree (142)

126 Wings 
(135)

127 Leaf (0)

ID & Angle Fancy Fill

128 Star (18)

129 Web (0)

130 Tear Drop 
(0)

131 2-way 
zig-zag (87)

132 Quilt 
Square 1 (45)

133 Quilt 
Square 2 (0)

134 Quilt 
Square 3 (0)

135 Quilt 
Square 4 (0)

136 Quilt 
Square 5 (45)

137 Quilt 
Square 6 (18)

138 Cloud Band 
1 (25)

139 Cloud 
Bands 2 (0)

140 Cloud 
Bands 3 (0)

141 Arrow 2 (0)

142 Rusty Ice 
(0)

ID & Angle Fancy Fill
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143 Ice Rays 
(0)

144 Dynasty (0)

145 Windwheel 
(0)

146 Tea Tray 
(0)

147 Cash Bars 
(45)

148 Chengtu (0)

149 Chihli (86)

150 Ming (135)

151 Arrowhead 
(89)

152 Basket2 
(40)

153 Bird (90)

154 Blocks2 (0)

155 Chain (90)

157 Circle (0)

158 Cube (48)

ID & Angle Fancy Fill

159 Ellipse (0)

160 Flame (90)

161 Jem (90)

162 Leaf (0)

163 Melody (0)

164 Metal (0)

165 Passage 
(0)

166 Piccolo (0)

167 Roma (0)

168 Rope (10)

169 Seville (0)

170 Star5 (10)

172 Tick (0)

173 Tile1 (135)

174 Tile3 (0)

ID & Angle Fancy Fill
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175 Vine (0)

176 Wave2 (90)

177 Wave3 (90)

178 Whirl (90)

179 Wild (48)

180 Xmastree 
(48)

ID & Angle Fancy Fill
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APPENDIX F
PATTERN STAMP, RUN & FILL SAMPLES

Below are samples of the Pattern Stamps, Runs and Fills included with your 
BERNINA Embroidery Software. See also Patterned Stamps, Runs & Fills.

Pattern set: BerninaV5

Name Pattern

NP005-01

NP005-02

NP005-03

NP005-04

NP005-05

NP005-06

NP005-07

NP005-08

NP005-09

NP005-10

NP005-11

NP005-12

NP005-13

NP005-14

NP005-15

NP005-16

NP005-17

NP005-18

NP005-19

Name Pattern
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NP005-20

NP005-21

NP005-22

NP005-23

NP005-24

NP005-25

NP005-26

NP005-27

NP005-28

NP005-29

NP005-30

NP005-31

NP005-32

NP005-33

NP005-34

Name Pattern

NP005-35

NP005-36

NP005-37

NP005-38

NP005-39

NP005-40

NP005-41

NP005-42

NP005-43

NP005-44

NP005-45

Name Pattern
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Pattern set: Children

Pattern set: Corners

NP005-46

NP005-47

NP005-48

NP005-49

NP005-50

Name Pattern

901

905

907

909

910

911

914

Name Pattern

929

Name Pattern

Cnr001

Cnr002

Cnr003

Cnr004

Cnr005

Cnr006

Cnr007

Name Pattern
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Pattern set: Cross

Cnr008

Cnr009

Cnr010

Cnr011

Cnr012

Cnr013

Cnr014

Cnr015

Cnr016

Cnr017

Name Pattern

Cnr018

Cnr019

Cnr020

Name Pattern

301

302

303

305

309

311

313

b301

b302

Name Pattern
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Pattern set: Embellishment 
Pattern set: Heirloom

b303

b304

b305

b306

b307

 b308

b309

b310

Name Pattern

601

605

608

610

612

Name Pattern

614

618

623

629

637

641

644

648

653

Name Pattern

705

706

709

710

711

717

Name Pattern
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Pattern set: Home Dec

718

719

724

726

728

732

733

738

a701

a702

a703

a704

a705

a706

Name Pattern

Name Pattern

401

402

403

405

406

407

409

411

412

413

414

415

416

417

422
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Pattern set: Misc

424

425

426

427

429

430

431

a401

a402

a403

a404

a405

a406

a407

Name Pattern

a408

a409

Name Pattern

10

11

12

13

21

29

Star

3wave

Heart

Wedge

Blanket

Feather

Name Pattern
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Pattern set: Monogram Ornaments

Pinstit

Name Pattern

M001a

M001b M001a pattern oriented horizontally 
and mirrored

M002a

M002b M02a pattern oriented horizontally

M003a

M004a

M004b M004a pattern oriented horizontally

M005a

M005b M005a pattern oriented horizontally 
and mirrored

Name Pattern

M006a

M006b M006a pattern oriented horizontally

M007a

M008a

M008b M008a pattern oriented vertically

M009a

M009b M009a pattern oriented horizontally

M010a

M010b M010a pattern oriented horizontally

M011a

M011b M011a pattern oriented horizontally

M012a

M012b M012a pattern oriented horizontally

Name Pattern
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M013a

M013b M013a pattern oriented horizontally

M014a

M014b M014a pattern oriented vertically and 
mirrored

M015a

M015b M015a pattern oriented horizontally

M016a

M016b M016a pattern oriented horizontally

M017a

M018a

M018b M018a pattern oriented vertically

M019a

M019b M019a pattern oriented horizontally

Name Pattern

M020a

M020b M020a pattern oriented horizontally

M021a

M021b M021a pattern oriented horizontally

M022a

M022b M022a pattern oriented diagonally

M023a

M023b M023a pattern oriented horizontally

M024a

M024b M024a pattern oriented diagonally

M024c M024a pattern oriented horizontally

M025a

M025b M025a pattern oriented horizontally

Name Pattern
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M026a

M026b M026a pattern oriented horizontally

M027a

M027b M027a pattern oriented vertically

M028a

M028b M028a pattern oriented diagonally

M029a

M029b M029a pattern oriented horizontally

M030a

M030b M030a pattern oriented horizontally

M031a

M031b M031a pattern oriented horizontally

M032a

M032b M032a pattern oriented horizontally

Name Pattern

M033a

M033b M033a pattern oriented horizontally

M034a

M034b M034a pattern oriented vertically

M035a

M035b M035a pattern oriented horizontally

M036a

M036b M036a pattern oriented horizontally

M037a

M037b M037a pattern oriented horizontally

M038a

M038b M038a pattern oriented horizontally

Name Pattern
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M039a

M039b M039a pattern oriented horizontally

M040a

M040b M040a pattern oriented horizontally

M041a

M041b M041a pattern oriented horizontally

M042a

M042b M042a pattern oriented vertically

M042c M042a pattern oriented diagonally

M043a

M043b

M043c M043a pattern oriented horizontally

M044a

M044b M044a pattern oriented vertically

Name Pattern

M045a

M045b M045a pattern oriented horizontally

M046a

M046b M046a pattern oriented horizontally

M047a

M047b M047a pattern oriented horizontally

M048a

M048b M048a pattern oriented horizontally

M049a

M049b M049a pattern oriented horizontally

M050a

M050b M050a pattern oriented horizontally

M051a

M051b M051a pattern oriented diagonally

Name Pattern
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M052a

M053a

M054a

M055a

M055b M055a pattern oriented vertically

M056a

M057a

M057b M057a pattern oriented diagonally 
and mirrored

M058a

M059a

M059b M059a pattern oriented horizontally

M060a

M061a

M061b M061a pattern oriented horizontally

M062a

M062b M062a pattern oriented horizontally

Name Pattern

M063a

M064a

M064b M064a pattern oriented horizontally

M065a

M066a

M066b M066a pattern oriented horizontally

M067a

M067b M067a pattern oriented vertically

M068a

M069a

M069b M069a pattern oriented vertically

M070a

M071a

M071b M071a pattern oriented vertically

Name Pattern
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M072a

M072b M072a pattern oriented horizontally

M072c M072a pattern oriented diagonally

M073a

M073b M073a pattern oriented vertically

M073c M073a pattern bigger sized

M073d

M073e M073d pattern oriented vertically

M073f

M073g M073f pattern oriented horizontally

M073h

M073i M073h pattern oriented horizontally

M073j

M073k M073j pattern oriented diagonally

M073l M073j pattern oriented vertically

M074a

M074b
M074a pattern oriented hori-

zontally

M074a
M074a pattern oriented verti-

cally

Name Pattern

M074g

M075a

M075b

M075c M075b pattern mirrored

M075d M075b pattern oriented vertically

M076a

M076b M076a pattern oriented vertically

M077a

M077b M077a pattern oriented vertically

M078a

M078b M078a pattern smaller sized

M078c M078b pattern oriented vertically

M079a

M079b M079a pattern smaller sized

M079c M079b pattern oriented vertically

M080a

M080b M080a pattern smaller sized

M080c M080b pattern oriented vertically

M081a

M081b M081a pattern smaller sized

M081c M081b pattern oriented vertically

M082a

M082b M082a pattern oriented vertically

Name Pattern
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M083a

M083b M083a pattern oriented vertically

M084a

M084b M084a pattern oriented vertically

M085a

M085b M085a pattern smaller sized

M085c M085b pattern oriented vertically

M086a

M086b M086a pattern oriented vertically

M087a

M087b M087a pattern smaller sized

M087c M087b pattern oriented vertically

M088a

M088b M088a pattern oriented horizontally

M088c M088a pattern oriented diagonally

M089a

M089b M088a pattern oriented vertically

M089c

Name Pattern

M090a

M090b M090a pattern oriented horizontally

M090c M090a pattern oriented diagonally

M090d

M090e M090d pattern oriented vertically

M091a

M091b M091a pattern oriented vertically

M091c M091a pattern oriented diagonally

M092a

M092b M092a pattern oriented vertically

M092c

M092d M092e pattern mirrored vertically and 
horizontally

M092e M092e pattern mirrored horizontally

M093a

M093b M093a pattern oriented vertically

M093c

M093d M093c pattern oriented diagonally

M093e M093c pattern oriented vertically

M093f

M094a

M094b M094a pattern oriented vertically

M094c M094a pattern oriented diagonally

Name Pattern
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Pattern set: NP004a

M095a

M095b

M096a

M096b M096a pattern oriented vertically

M096c

M096d

M097a

M097b M097a pattern oriented vertically

M097c

M097d M097c pattern oriented horizontally

M097e M097c pattern oriented diagonally

M098a

M098b M098a pattern oriented vertically

M098c

M098d M098c pattern oriented vertically

M099a

M099b M099a pattern oriented right

M099c M099a pattern oriented downwards

M099d M099a pattern oriented left

M099e M099a pattern oriented diagonally

Name Pattern

M0100a

M0100b M0100a pattern bigger sized

Name Pattern

K0001a

K0002a

K0003a

K0004a

K0005a

K0006a

K0007a

K0008a

K0009a

K0010a

K0011a

K0012a

Name Pattern
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Pattern set: NP005a

K0013a

K0014a

K0015a

K0016a

K0017a

K0018a

K0019a

K0020a

K0021a

K0022a

K0023a

K0024a

K0025a

K0026a

K0027a

A200026

A200150

A200446

A200602

Name Pattern

A200606

A200609

A200615

A200749

Name Pattern

151a

151b

152a

437a

660a

663a

701a

1023a

1024a

1026a

Name Pattern
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Pattern set: Nature

Pattern set: Quilting

1027a

Name Pattern

101

102

103

106

111

112

113

114

115

117

118

119

124

Name Pattern

129

135

136

Name Pattern

327

328

330

332

333

334

336

337

338

339

340

342

Name Pattern
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Pattern set: Satin-Quilt

343

a301

a302

a303

a304

a305

a306

a307

a308

a309

a310

a311

a312

a313

a314

a315

a316

Name Pattern

Name Pattern

501

503

506

507

508

509

511

512

513

514

515
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Pattern set: Carving Stamps

Name Pattern

0

 

1

2

3

4

5

6

7

8

9

A

B

C

D

E

F

G

H

I

J

K

Name Pattern
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L

M

N

O

P

Q

R

S

T

U

Name Pattern

V

W

X

Y

Z

Cylinder

Triangle

Ring_Half

Trapezoid

Arrow_3_Way

Arrow_4_Way

Name Pattern
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Arrow_Block

Ring_Ellipse

Parallelogram

Page

Tear

Arrow_4_Way_
Block

Arrow_Right_
Angle

Arrow_Double
_Block

Arrow

Cross

Flash

Name Pattern

Flame

Heart

Banned

Smiley

Arrow_Double
_Right_Angle

Polygon

Name Pattern
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APPENDIX G
CRAFT STITCH PATTERN SAMPLES

The Craft Stitch patterns shown in this appendix are a sample of those included 
with your BERNINA Embroidery Software program. For actual Craft Stitches and 
instructions on how to use them, see Craft Stitch Borders and Fills.

Blackwork patterns

Blackwork gets its name from the black silk thread 
traditionally used in this form of embroidery. 
Blackwork patterns can be used either as borders, as 
fills, or even pattern stamps. The most common 
blackwork fills employ simple stitches to create 
complex scrolling or geometric patterns. See Creating 
blackwork outlines and Creating blackwork fills.

ID Sample

B0001a

B0002a

B0003a

B0004a

B0005a

B0005b

B0006a

B0007a

B0008a

B0009a

B0010a

ID Sample
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B0011a

B0012a

B0013a

B0013b

B0014a

B0015a

B0016a

B0017a

B0018a

B0019a

B0020a

B0021a

ID Sample

B0022a

B0023a

B0024a

B0025a

B0026a

B0027a

B0028a

B0029a

B0030a

ID Sample
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B0031a

B0032a

B0033a

B0034a

B0035a

B0036a

B0037a

B0038a

B0039a

B0040a

ID Sample

B0041a

B0042a

B0043a

B0044a

B0045a

B0046a

B0047a

B0048a

B0048b

B0049a

B0050a

ID Sample
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B0051a

B0052a

B0053a

B0054a

B0055a

B0056a

B0057a

B0058a

B0059a

B0060a

B0061a

ID Sample

B0062a

B0063a

B0064a

B0065a

B0066a

B0067a

B0068a

B0069a

B0070a

B0071a

ID Sample
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Candlewicking patterns

Candlewicking is a traditional white-on-white 
embroidery technique, usually done on white linen or 
cotton fabric with heavy cotton threads. 
Candlewicking patterns can be used either as borders, 
as fills, or even pattern stamps. See Creating 
candlewicking outlines and Creating candlewicking 
fills.

Lacework patterns

Lacework stitch consists of an open square trellis-like 
pattern which gives objects a lacey look. Lacework 

B0072a

B0073a

B0074a

B0075a

B0075a

B0075a

B0075a

B0075a

ID Sample

B0075a

ID Pattern

Knot-3mm

Colonial-
4mm

Colonial-
4.5mm

Half Knot

ID Sample
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can only be applied to filled objects with a single stitch 
angle. See Creating lacework fills for details.

ID Pattern

L0001a

L0002a

L0003a

L0004a

L0005a
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Glossary

Active window:  The active window is 
one to which the next command or action 
will apply. If a window is ‘active’, its title 
bar changes color to differentiate it 
visually from other open windows.

Alphabet:  A set of characters of the 
same design or style including letters, 
numbers and typographical symbols.

Anchor point:  A fixed point used when 
rotating, scaling, skewing or mirroring a 
design.

Anti-aliasing:  A software technique 
similar to dithering which is used to 
soften hard outlines where color blocks 
intersect. It produces smoother outlines 
by ‘blurring’ the pixels where colors join.

Appliqué:  Decoration or trimming cut 
from one piece of fabric and stitched to 
another to add dimension and texture. 
Designs with appliqué can be more 
economical than embroidery alone, if 
appliqué occupies a significant amount of 
the design, thereby lowering stitch count.

Appliqué cutter:  A device that can cut 
fabric along a line, somewhat like old pen 
plotters. It requires a vector file as input. 
In MS Windows they can be set up as a 
type of printer device.

ARQ:  BERNINA Quilter format.

ART:  BERNINA Embroidery Software 
format.

Artistic View:  A realistic, ‘three 
dimensional’ preview of a stitched 
embroidery design.

Artwork:  Bitmap or vector graphic used 
as a backdrop for digitizing. See also 
Bitmap image and Vector graphic.

Image Preparetion:  See Image 
preparation.

ARX:  BERNINA Embroidery Software 
Cross Stitch format.

Auto Appliqué:  Auto Appliqué is an 
embroidery object associated with an 

appliqué which provides automatic 
stitching to place it, tack it down, and 
cover its edges.

Auto Center:  Auto Center 
automatically centers the start and end 
points of a design.

Automatic digitizing:  Digitize 
complete images automatically. Auto 
Digitizer automatically converts artwork 
to embroidery objects and generates 
stitches.

Auto Jump:  Preserves long stitches in an 
object by splitting them into a series of 
jumps. This prevents the machine from 
inserting unwanted needle penetrations 
when the maximum frame movement is 
exceeded.

Auto Scroll:  The Auto Scroll feature 
automatically scrolls the screen while you 
are digitizing.

Auto-sequencing:  The 
Auto-sequencing feature lets you digitize 
like objects – e.g. the fingers of a hand – 
without having to think about the most 
efficient stitching sequence and joins. 

Auto Spacing:  Auto Spacing only 
affects Satin stitch. It adjusts stitch 
spacing according to column width.

Automatic color change:  Ability of 
multi-needle embroidery machine to 
follow a command to change to a 
specified needle with a different thread 
color.

Automatic pull compensation:  

Embroidery stitches pull the fabric 
inwards where the needle penetrates. 
This can cause the fabric to pucker, and 
gaps to appear in the embroidery. 
Automatic pull compensation counters 
this effect by ‘overstitching’ outlines of 
filled shapes on the sides where the 
needle penetrates. This means the design 
can be optimized for different fabrics. See 
Pull compensation.

Back appliqué:  A fabric piece used 
behind a design where the front fabric 

will be cut away to reveal the fabric 
beneath it.

Backdrop:  An electronic image used as 
a guide for digitizing designs on-screen. 
Two types are used – vector or bitmap. 
Insert them from various file sources, or 
copy and paste them via the Windows 
clipboard.

Background:  BERNINA Embroidery 
Software lets you change the background 
color of the Design Window to match the 
color of your fabric. Or you can select a 
background fabric for more realistic 
previews and presentations. The 
background is saved with the colorway.

Backing:  Also known as ‘stabilizers’, 
backings are woven or non-woven 
materials placed beneath the item or 
fabric being embroidered for stability and 
support. The more stitches a design has, 
the heavier the backing required. 
Backings are available in various weights 
and types such as cut-away, tear-away 
and wash-away (soluble). Professional 
embroiderers use tear-away stabilizers for 
woven fabrics and cut-away stabilizers for 
knits. See Topping.

Backstitch:  Backstitch is an input 
method which can be used for delicate 
outlines. This stitch follows intricate 
curves well. It is also is the term used for 
every second row of stitches in a Tatami 
fill. See also Standard backstitch, 
Borderline backstitch, and Diagonal 
backstitch.

Backup:  The copying of files onto floppy 
disk or other storage media in order to 
duplicate and secure data. Usually two 
copies are made and kept separately.

Baseline:  The notional line on which the 
letters of an alphabet sit. Only descenders 
extend below it. Baselines determine the 
shape of lettering objects in a design. 
Place it on straight horizontal or vertical 
lines, curve it around a circle or arc, or 
digitize your own baselines.

Baseline Angle:  The baseline angle 
determines the absolute angle of the 
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baseline relative to the horizontal axis. 
You use it to align letters to a significant 
part of the design.

Batting:  A layer of padded material 
between the front and back fabric to add 
thickness and substance.

Bitmap:  An electronic image made up of 
dots or ‘pixels’, in contrast to vector 
‘outlines’. Typically created in paint 
programs, bitmaps have file extensions 
such as BMP, JPG, GIF, TIF and PCX. When 
enlarged or scaled down, vector graphics 
preserve image quality while bitmap 
images generally cause problems of 
pixilation and image degradation. See 
also Pixel.

Blackwork:  Blackwork gets its name 
from the black silk thread traditionally 
used in this form of embroidery. It can be 
used to decorate articles such as hankies, 
table napkins, table clothes, and doilies.

Blanket stitch:  Widely used for tacking 
down appliqués as a decorative border. 
The stitches form a comb pattern.

Block:  The basic unit of a quilt top.

BMP:  Windows bitmap image format. 
See also Bitmap.

Bobbin:  Spool or reel that holds the 
bobbin thread, which helps form stitches 
on the underside of the fabric.

Bobbin embroidery:  Designs worked 
with the fabric hooped facedown and the 
specialty thread or ribbon wound onto 
the bobbin. Most effective for simple 
designs such as leaves and vines, or 
special effects with threads too heavy to 
be threaded through the needle.

Bonding:  Permanently joining two 
fabrics together with a bonding agent. 
Heat sealing.

Border:  Single closed-curve object 
which can be optionally added to a 
monogram. Also, a strip of fabric that is 
joined to an inner quilt to enhance it.

Bounding box:  The dotted rectangle 
that appears when you select a range of 
items.

Candlewicking:  A traditional 
white-on-white embroidery technique, 
usually done on white linen or cotton 
fabric with heavy cotton threads.

Cascade:  A way of arranging open 
windows on the desktop so that they 
overlap each other, with the title bar of 
each window remaining visible.

Checkbox:  A small square box that 
appears in a dialog box and that can be 
selected or cleared. When selected, a tick 
or a cross appears. A checkbox represents 
an option that you can set.

Click:  Press and release the left mouse 
button. See also Right-click.

Click-and-drag:  Click to select, hold 
down the left mouse button, move the 
cursor and release.

Clipboard:  A temporary storage area in 
PC memory for what was last cut or 
copied. Images on the clipboard can be 
pasted into designs any number of times.

Close button:  Used to close a window 
or an application. In MS Windows, it 
appears as a small box with an ‘X’ in it at 
the top-right of the title bar.

Color depth:  Color depth, also called 
‘pixel depth’, refers to the amount of 
color information available to each pixel 
in an image. An image with a color depth 
of 1-bit can display only two colors. As 
the color depth increases, more colors are 
available – 16 Colors (4 bit), 256 Colors (8 
bit), High Color (16 bit), True Color (24 
bit).

Color palette:  The color palette 
contains a selection of thread colors 
tailored for each design. This color 
scheme, or ‘colorway’, represents the 
actual thread colors in which a design will 
be stitched. See also Thread chart.

Color Reduction:  See Image 
preparation for details.

Colorways:  Colorways are multiple 
color schemes for the same design. They 
are made up of colors defined in ‘color 
books’ which may be created in Wilcom 
BERNINA Embroidery Software or similar 
design program, or may be selected from 

a patent color system such as 
Chromatone or Pantone.

Column:  Narrow, long, curving shape.

COM port:  A standard serial port used 
as a connection point for peripherals. 
Other ports may be present if the 
appropriate internal option cards have 
been installed. The computer must be 
informed which port is being used by 
which peripheral – e.g. COM1, COM2, 
etc.

Command:  An instruction issued to the 
software in order to carry out an action. It 
may be as simple as ‘paste an object’ or as 
complex as ‘regenerate stitches’. It is 
usually activated via a menu item, toolbar 
icon, or command button in a dialog.

Command button:  A button in a dialog 
which executes or cancels the selected 
action. Two common command buttons 
are Cancel and OK.

Closed Curve:  Input method, used to 
digitize large and complex shapes. Allows 
holes to be designated at the same time 
the object outline is digitized. The object 
is thus digitized as one fill area, instead of 
being broken down into multiple 
sections. Objects so created are known as 
Closed Curve objects.

Condensed file:  See Outline file for 
details.

Configuration:  The size and type of 
computer hardware. Can also be used to 
mean the options provided with your 
software.

Confirmation message:  A message 
displayed by the software asking you if 
you are sure you want to proceed – e.g. 
when you want to delete a design.

Connector stitches:  Connector stitches 
link objects in a design. They can be run 
stitches or jumps. You can use automatic 
settings to generate connectors, trims 
and tie-offs, or add them manually.

Connectors:  Hardware devices to 
connect cables to ports. If the connection 
is male, the port is female, and vice versa. 
The wiring configuration of each device is 
determined by its function.
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Copy:  To place a copy of a selection onto 
the clipboard. See also Duplicate.

Control points:  Control points are used 
to modify object shapes, stitch angles and 
entry and exit points. You can change the 
shape of an object by moving, adding or 
deleting control points on the outline. For 
most objects, you can also change control 
points from corner points to curves.

Contour stitch:  Contour is a curved fill 
stitch type – stitches follow the contours 
of a shape, creating a curved, light and 
shade effect. It only works on columnar 
shapes. There are two types – Standard 
and Spiral – both of which can be applied 
to Input A, Input B, Input C or Ring 
objects. Standard Contour can also be 
applied to Circle objects.

Copyright:  A right granted by the 
government or by international 
agreement giving the owner the exclusive 
privilege to publish and sell artistic work 
during the life of the creator plus 50 
years.

Corner points:  In standard digitizing, 
corner points indicate where a curve 
changes direction. The user digitizes a line 
segment with two consecutive corner 
points. The run and turning fill stitch 
generation algorithms interpret corner 
points as subdividing the curve, and so 
always generate a stitch penetration at 
corner points.

Cover stitch:  Cover stitch is the border 
around an appliqué shape. You can 
control various settings including cover 
stitch type – Satin or Blanket – width, 
stitch spacing, as well as the offset.

Conversion software:  Programs that 
read information, other than from a card, 
and translate it from one sewing machine 
format to another. 

Converter box:  A converter box acts 
like a translator from one memory card 
format to another, via computer. Various 
companies offer this technology under 
names like the Magic Box™ from 
Oklahoma Embroidery. They translate 
designs from memory cards in other 
formats or from a hard drive, disk, or CD 
and write the design to a blank card. 

CPU:  Central Processing Unit.

Cross stitch:  Two stitches that cross at 
the center to form an X. Laid in rows or 
within a box shape to form geometric 
designs. Creates a handmade 
appearance.

Current property settings:  Current 
property settings override the template 
defaults. Unless you deliberately change 
them, these take the default values. You 
generally change them to save time when 
digitizing. For example, you may preset 
Tatami stitch spacing to use a specific 
density for all new Tatami objects you 
create. See also Object properties.

Curve smoothing:  Curve smoothing is 
used to filter out ‘mouse jaggies’ 
generated by freehand techniques and to 
convert the generated path into a 
relatively smooth curve. Advanced curve 
smoothing typically works on an entire 
outline, and includes corner detection to 
better approximate the intended curve.

Custom designs:  Designs created by 
digitizing artwork or manipulating 
existing patterns.

Cut:  An editing function. To remove a 
selection from a design. The cut selection 
is stored in memory (on the ‘clipboard’) 
and can be pasted into the same or 
different design.

Cutting line:  A second line of run 
stitches that forms a guide when 
trimming the fabric of an appliqué patch.

Default object properties:  See Default 
values for details.

Default values:  Pre-defined settings 
which determine object properties such 
as stitch spacing, as well as certain system 
settings. These are stored in the design 
template. They are automatically applied 
to any newly created objects. They remain 
‘current’ unless you override them with 
new settings. See also Current property 
settings.

Defects:  See Stitching defects for 
details.

Density:  See Stitch density or Thread 
density.

Design:  A ‘design’ is a file in the native 
embroidery format – e.g. EMB, JAN, ART 

– of embroidery digitizing software. The 
design source may be a stitch format 
design. The design contains stitching 
information such as fabric type in 
addition to stitched shapes.

Design card:  Disk containing 
computerized embroidery designs read by 
the embroidery machine’s computer.

Design elements:  The decorative 
design components that make up a 
monogram (including ornaments and 
borders).

Design file:  See File for details.

Design object:  See Object for details.

Design properties:  Designs themselves 
have properties, some of which can be 
modified, others not. The most important 
design property is its source – Native 
Design, Imported Outlines, Processed 
Stitches, or Imported Stitches. Other 
properties include the software version 
number, stitch count, and so on. 
Colorways too are properties of the 
whole design.

Design sequence:  See Stitching 
sequence for details.

Design source:  While embroidery files 
are broadly classified as ‘outline’ 
(condensed) or ‘stitch’ (expanded), 
BERNINA Embroidery Software internally 
tags files as belonging to one of four 
types–Native Design, Imported Outlines, 
Processed Stitches, or Imported Stitches. 
See also Design properties.

Design template:  See Template for 
details.

Design Window:  The Design Window 
is where designs are displayed for viewing 
and modification.

Desktop:  MS Windows terminology for 
the screen background on which 
program icons are displayed.

Destination folder:  The folder 
(directory) where you intend to copy or 
move one or more files.

Detail:  An outline, a border, a pickout 
run, or a small area of the design you 
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want to be stitched out last when using 
Auto Digitizer.

Dialog:  An on-screen box that either 
requests or provides information. Many 
dialogs present options to choose among 
before a command is carried out. Some 
dialogs present warnings or explain why a 
command cannot be completed.

Digitizing:  Process of encoding a 
design. Artwork is converted into a series 
of ‘embroidery objects’ to be read and 
manipulated by a specialist CAD/CAM 
application. Before outputting to 
embroidery machine, it is converted into 
‘stitch data’.

Digitizing tool:  Digitizing tools, 
sometimes referred to as ‘input methods’, 
are similar to drawing tools except that 
the end result is an embroidery object 
rather than a vector object. Different 
digitizing tools are suited to creating 
different shapes or design elements. 

Disk:  See Floppy disk for details.

Disk drive:  Computers usually have 
three types of disk drive: a hard disk (or 
fixed disk) which usually supports the 
mass storage of information and 
applications, a floppy disk drive, and a CD 
ROM drive.

Display:  A screen used to display the 
output of a computer. Also known as the 
monitor.

Dithering:  A software technique which 
combines existing colors in a 
checkerboard arrangement of pixels. It is 
typically used to simulate colors that are 
missing from an image palette. A type of 
optical illusion created by placing two 
pixels of different color next to each 
other. The human eye automatically 
resolves the two colors into a third color.

Dongle:  A security hardware device 
required to run protected software. Some 
are attached to a parallel port, others to a 
USB port.

Dots Per Inch (DPI):  A measurement of 
screen or printer resolution; the number 
of dots in a line of 1".

Double-click:  Click the left mouse 
button twice without moving the mouse. 

Double-clicking carries out actions such 
as opening a program from an icon.

Download:  The process of transferring 
a copy of a file from a remote computer 
or the internet to a computer or other 
device such as an embroidery machine.

Drag:  An operation of the mouse. 
Holding the (left) mouse button while 
moving the mouse. Typically used for 
moving something on the screen.

Dropdown list :  A single-line dialog 
box control that opens to display a list of 
choices.

Duplicate:  When an object is 
duplicated, it is not copied to the 
clipboard. This leaves the clipboard free 
for you to cut or copy other objects.

Editing:  Changing aspects of a design 
via a computerized editing program. 
Most programs allow you to scale designs 
up or down, edit stitch-by-stitch or 
block-by-block, merge lettering with the 
design, move aspects of the design 
around, combine designs and insert or 
edit machine commands.

Elastic Lettering:  Special effects 
applied to lettering objects to make them 
bulge, stretch or compress. 

Emblem:  Embroidered design with a 
finished edge, applied to a garment after 
stitching, commonly an insignia of 
identification. Also known as a ‘crest’ or 
‘patch’.

Embroidery:  Decorative stitching on 
fabric. Generally involves non-lettering 
designs, but can also include lettering 
and/or monograms. Evidence of 
embroidery exists during the reign on 
Egyptian pharaohs, in the writings of 
Homer and from the Crusaders of the 
12th century. Has evolved from 
hand-work to manual sewing machines 
and from hand-looms and Schiffli 
machines with hundreds of needles to 
high-speed, computerized multihead 
machines.

Embroidery object:  See Object for 
details.

Embroidery thread:  See Thread for 
details.

EMF:  Enhanced Metafile vector graphic 
format.

Entry point:  The entry point is the point 
where the thread enters the embroidery 
object. This should coincide with the exit 
point of the preceding object.

Exit:  To leave a current window or 
application.

Exit point:  The exit point is the point 
where thread leaves the embroidery 
object. This should coincide with the 
entry point of the next object.

EXP:  Stitch or ‘expanded’ file format 
native to Melco machines.

Extension:  See File extension for details.

Fabric:  Fabrics have many properties, 
the main one being elasticity or ‘fabric 
stretch’. Surface texture, if present, is 
another property that requires different 
underlay types. The system can 
automatically compensate for the 
pull-push effect of different fabrics. Push, 
warping, and shearing are reduced by 
suitable underlay for the stitch type and 
fabric.

Fabric stretch:  Embroidery stitches pull 
the fabric inwards where the needle 
penetrates. This can cause the fabric to 
pucker, and gaps to appear in the 
embroidery. Use automatic pull 
compensation to counter this effect by 
‘overstitching’ outlines of filled shapes.

Facing:  See Topping for details.

Factory settings:  These are the initial 
system settings as installed. They are a 
standard known setting that you can 
return to. Some customers want to create 
custom settings tailored to the exact 
fabric they are using most frequently. The 
‘My Fabric’ settings are those retained in 
the design and can be saved to the 
template file.

Fancy Fill:  A decorative fill stitch which 
can be applied to various object types 
where needle penetrations form a tiled 
pattern. Different preset patterns are 
available for use.

File:  A named collection of specifically 
related information stored on a disk. 
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Designs that have been saved are stored 
as files.

File extension:  The dot and three 
letters at the end of a filename such as 
‘.BMP’. The extension identifies the file as 
a certain type, readable by certain 
applications.

Filename:  The name of a file, including 
the extension, e.g. Cat.BMP.

Fill stitch:  Series of running stitches 
commonly used to cover large areas. 
Different fill patterns can be created by 
altering the angle, length and repeat 
sequence of the stitches. Also known as 
Geflect stitch.

Finishing:  Processes done after 
embroidery is completed. Includes 
trimming loose threads, cutting or tearing 
away excess backing, removing facing or 
topping, cleaning any stains, pressing or 
steaming to remove wrinkles or hoop 
marks and packaging for sale or 
shipment.

Flagging:  Up and down motion of fabric 
under action of the needle, so named 
because of its resemblance to a waving 
flag. Often caused by improper framing 
of goods. Flagging may result in poor 
registration, unsatisfactory stitch 
formation and birdnesting.

Floppy disk:  A flexible disk permanently 
sealed in a square plastic jacket – e.g. 
HD/DD 3.5" floppy disk. Used for 
information storage ‘off-line’ for security 
and/or infrequently used data. Also used 
for transferring punched embroidery 
design (stitch file) data from computer to 
embroidery machine.

Folder:  A collection of files and 
subfolders that are stored together on a 
disk. Part of structure for organizing files 
on a disk.

Font:  A set of characters, including 
letters, numbers and other typographic 
symbols, of the same design and style. 
Also called Alphabet, even if it includes 
non-letter characters. See also Alphabet 
and Lettering.

Free motion machine embroidery:  

See Thread painting for details.

French knot:  A stitch featuring a raised 
knotted center.

Fringe:  Threads that are cut and hang 
loosely from the edge of a design.

Gradient Fill:  artistic stitch effect that 
gradually varies stitch spacing between 
dense and open fill along an embroidery 
object, producing shading and color 
effects which are difficult to achieve 
manually.

Graphics application:  Software 
application that creates or allows you to 
edit bitmap images and/or vector 
graphics. Vector graphics can be scaled 
with no loss of sharpness. Examples of 
vector editing programs are Adobe 
Illustrator, MacroMedia Freehand and 

CorelDRAW®. See also Paint package 
and Drawing package.

Grayscale:  A grayscale picture is made 
up of 254 different shades of gray, plus 
solid black and solid white for a total of 
256 different tones. Black and white 
photographs are grayscale.

Grid:  Grid lines provide visual cues to 
help you accurately place a design. When 
you start the software for the first time, 
grid lines appear by default.

Guide run:  Series of stitches used to 
align embroideries in multi-hooping 
situations or to assist in fabric placement 
for appliqué. It is the first appliqué layer 
stitched and is used to position the 
appliqué fabric on the background 
material. See also Appliqué.

Handle:  See Selection Handle.

Hard disk:  A device for mass 
information storage. Usually the disk is 
fixed inside the system unit, and a second 
hard disk can be added. When you store 
information on the hard disk it will remain 
there until you delete it. As it has a finite 
capacity, file management is required.

Hardware:  Computer componentry, 
including monitor, keyboard, digitizing 
tablet, printer, scanner, sewing machine, 
etc.

Heirloom embroidery:  Embroidered 
goods designed to be passed down from 
generation to generation.

I-beam:  One shape taken by the PC 
pointer, it indicates that text can be input 
at the point selected. The shape is like the 
capital letter ‘I’.

Icon:  Miniature picture used in the 
screen display instead of, or as well as, 
text. The file list can be displayed as icons 
with the filenames underneath; the 
toolboxes which appear in the left of the 
screen are composed of icons.

Image preparation:  Cleaning up 
scanned images as input to embroidery 
digitizing. This may involve any one or a 
combination of the following techniques: 
reducing the number of colors, adding or 
emphasizing outlines, removing noise, 
dithering or anti-aliasing, eliminating 
unnecessary detail, cropping sections or 
eliminating backgrounds.

Input method:  See Digitizing tool for 
details.

JPG:  JPEG file interchange bitmap image 
format.

Jump:  A frame or hoop movement 
without a needle penetration, commonly 
used to get from one point in a design to 
another.

Justification:  The position of lettering 
on the embroidery baseline.

Lacework:  Lacework involves the use of 
threads to produce overall embroidery of 
full-length fabrics. Most often used to 
embellish women's apparel and home 
fashions. It is the most widely used 
application for Schiffli machines.

Letters:  Initials or name making up a 
monogram. Letters of an alphabet or 
font.

Lettering:  Embroidery using letters or 
words. Lettering commonly called 
‘keyboard lettering’ may be created from 
pre-defined alphabet styles or fonts, 
allowing variance of size, height, spacing, 
density and other characteristics.

Line art:  A drawing with only two colors 
– usually black and white.

List box:  A single-line dialog that opens 
to display a list of choices.
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Lockstitch:  Commonly referred to as a 
lock-down or tack-down stitch, a 
lockstitch is formed by three or four 
consecutive stitches of at least a 10-point 
movement. It should be used at the end 
of all columns, fills and at the end of any 
element in your design where jump 
stitches will follow, such as color changes 
or the end of a design. May be stitched in 
a triangle, star or in a straight line. Lock 
stitch is also the name of the type of stitch 
formed by the hook and needle of home 
sewing machines, as well as 
computerized embroidery machines.

Logo:  Name, symbol or trademark of a 
company or organization. Short for 
logotype.

Looping:  Loops on the surface of 
embroidery generally caused by poor top 
tension or tension problems. Typically 
occurs when polyester top thread has 
been improperly tensioned.

Magic Wand:  Technique for creating 
embroidery designs by automatically 
digitizing color blocks in electronic 
images.

Max/Min stitch length:  The minimum 
and maximum stitch lengths allowable in 
a design determine the outside limits as 
measured between needle penetration 
points. They are governed by the 
minimum and maximum frame 
movements that the machine can make.

Maximize button:  For Windows, the 
small box in the center of the group of 
three at the right of the title bar. Click the 
Maximize button to enlarge a window to 
its maximum size.

Memory:  The place in the computer’s 
system unit that stores information while 
you are working with it. If you exit 
without saving information in memory, it 
will be lost.

Menu bar:  The menu bar contains 
dropdown menus of commands. Some of 
the same commands are available on the 
toolbar.

Menu chart:  The menu chart provided 
with the software lets you select 
commands directly from the digitizing 
tablet using the puck. You need to 
‘register’ it before use.

Minimize button:  For Windows, the 
small box to the left of the group of three 
at the right of the title bar. Click the 
Minimize button to reduce a window to 
its minimum size.

Modal dialog:  A dialog which, while 
open, prevents the user from selecting 
any control or object outside it. Changes 
made to settings inside the dialog are not 
effective until it is closed.

Modeless dialog:  A dialog which, while 
open, allows the user to select objects 
freely. Controls in the dialog change to 
conform to the values of selected objects, 
or show relevant system information 
when no object is selected. Changes 
made to settings in the dialog may be 
applied while it remains open. Other 
dialogs and commands may be opened 
and used while the modeless dialog 
remains open.

Modem:  Unit to telegraphically send 
computer information from one 
computer to another.

Monogram:  Embroidered design 
composed of one or more letters, usually 
the initials of a name. Can also consist of 
borders or designs to mark ownership of 
items such as clothing, caps, 
handkerchiefs, etc.

Multi-appliqué:  A type of appliqué 
object composed of more than one piece 
of fabric and bordered by various types of 
embroidery objects.

Native file format:  A design saved in 
the original format of the application you 
are working with is said to be the ‘native’ 
file format. It can also refer to the stitch 
file format required by a specific 
embroidery machine. When saved to 
another format, it is known as a 
non-native format.

Needle:  Small, slender piece of steel 
with a hole for thread and a point for 
piercing fabric. A machine needle differs 
from a handwork needle; the machine 
needle’s eye is found at its pointed end. 
Machine embroidery needles come with 
sharp points for piercing heavy, tightly 
woven fabric; ball points which glide 
between fibers of knit; and variety of 
specialty points, such as wedge points, 
which are used for leather.

Needle points:  You can view needle 
points in a design to check density or, for 
instance, to select stitches for editing.

Noise filtering:  Noise filtering means 
restoring the solid color blocks of original 
artwork in scanned images. This is 
achieved by merging different shades into 
one solid color. Noise filtering is 
important for automatic digitizing 
because it makes it easier for the software 
to identify solid color blocks which 
become embroidery objects in the 
resulting design. It also cleans up blurred 
or mottled areas of color.

NORMAL template:  Default template. 
See also Template.

Object:  In embroidery design terms, an 
object is an individual ‘element’ of a 
design. An object has many properties, 
such as its size, color, sequence in the 
design, stitch type and values, including 
the rules for stitching. See also Vector 
object.

Object outline:  See Outline file for 
details.

Object properties:  All embroidery 
objects in BERNINA Embroidery Software 
contain defining settings or ‘values’. The 
values stored with an object become its 
‘properties’. All objects have certain 
properties in common such as size and 
position. There are other, more specific 
properties of objects which depend on 
the object type.

Object type:  An object has a type, 
shape, thread type and color, stitching 
settings and a position in the stitching 
order. The object type may or may not 
determine the intended final appearance 
of the stitching.

Ornament:  A grouped embroidery 
design which may consist of one or more 
objects of any type and one or more 
colors. Ornaments may be placed in up to 
eight positions around letters, or centered 
behind letters.

Outline file:  Outline or ‘condensed’ 
files are high-level formats which contain 
object outlines, object properties and 
stitch data. When you open an outline file 
in BERNINA Embroidery Software, 
corresponding stitch types, input 
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methods and effects are applied. Outline 
files can be scaled, transformed and 
reshaped without affecting stitch density 
or quality. See also Stitch file.

Outline stitch:  Stitch such as Run or 
Satin used to outline an embroidery 
object.

Overview window:  Use the Overview 
window to view a thumbnail of the 
design. The window is updated whenever 
you make a change, and can be used to 
zoom in or pan across the Design 
Window. 

Paint package:  Software application 
that creates or allows you to edit image 
files. You can create lines and filled areas 
as well as edit the image pixel-by-pixel 
using paintbrushes, erasers and 
spraypaint tools. Examples of image 
editing programs are Adobe Photoshop, 
Jasc PaintShop Pro and Corel 

PHOTO-PAINT® Essentials 4. See also 
Graphics application.

Pan:  Use Pan to view parts of a design 
which are not currently visible in the 
Design Window. 

Parallel port:  A connection on a 
computer, usually LPT1, where you plug 
in the cable for a parallel printer and/or a 
dongle. Parallel ports are used to connect 
some embroidery machines. They are 
named LPT1, LPT2, etc. When you set up 
a parallel machine connection, select the 
parallel port and the required protocol, 
and complete the machine setup 
procedure.

Paste:  To insert an object, which has 
previously been placed on the clipboard 
by cutting or copying selected objects, 
into a design. You can paste from the 
clipboard as many times as you like.

Patch:  The fabric piece use in appliqué.

Patchwork:  The composite of pieces 
sewn together to form a large piece, such 
as a quilt.

Patchwork block:  A collection of 
patches sewn together, usually forming a 
regular shape such as a rectangle. These 
are then sewn together to make a quilt.

Pattern Fill:  Pattern Fill is a decorative 
fill stitch with which you can fill Closed 
Curve objects. You can also create special 
or three dimensional effects.

Pattern Run:  Patterns which are linked 
together along a digitized line. You can 
create decorative outlines using any 
pattern from the list. 

PCX:  PC Paintbrush bitmap image 
format.

PDF:  Portable Document Format. Used 
to view the Online Manual in Acrobat 
Reader.

Pencil rub:  Low-cost way of producing 
an embroidery design sample. Consists 
literally of a piece of tracing paper placed 
over a stitchout and rubbed lightly with a 
pencil to produce an impression of the 
embroidery.

Peripheral:  Any device connected to a 
computer which is to some degree 
controlled by the computer – e.g. an 
embroidery machine or printer.

PhotoSnap:  Technique for creating 
embroidery designs directly from 
photographs and other grayscale bitmap 
images. PhotoSnap designs consist of 
rows of Satin or Contour stitches of 
varying spacing. The effect resembles the 
output of a line printer.

Pixel:  A dot. For example, dots of light 
that make up the picture on a computer 
screen. The more pixels there are in a 
given area – that is, the smaller and closer 
together they are – the higher the 
resolution.

Pixilation:  An effect which occurs when 
a bitmap image is enlarged so that the 
individual pixels are obvious to the eye.

Placement line:  The first appliqué layer 
stitched – placment lines are used to 
position appliqué fabric on background 
material. See also Appliqué.

PNG:  Portable Network Graphics vector 
graphic format.

Pointer:  A part of the screen display, the 
pointer can take various shapes. It is 
moved by moving the mouse and can be 
used to point to anything on the screen to 

make selections and indicate points for 
input. It also indicates when the 
computer is working and no input is 
possible.

Point:  Unit of measurement, with 
10 points equal to 1 mm.

Port:  A connection on a computer 
where you plug in the cable that carries 
data to another device. Ports which are 
used to attach peripherals have names 
like COM1 or LPT1 so that you can specify 
where the peripherals are attached.

Position:  The Position indicator shows 
position of the design (X, Y) in the Design 
Window.

Print Preview:  Use to preview design 
and design information before printing a 
Production Worksheet. The design is 
displayed as it will be printed.

Production worksheet:  The 
production worksheet is the link between 
the designer and the embroidery machine 
operator. It contains a design preview as 
well as essential production information, 
including the design size, the color 
sequence and any special instructions.

Program:  A computer program or 
‘application’ is generally used for a 
particular kind of work, such as word 
processing or database management.

Properties:  See Object properties for 
details.

Protocol:  The communications protocol 
depends on the connection type between 
the computer and the embroidery 
machine. This will be one of: standard 
serial, parallel, serial to parallel converted 
(DCi), or interface card.

Puckering:  Result of the fabric being 
gathered by the stitches. Many possible 
causes include incorrect density, loose 
hooping, lack of backing, incorrect 
tension or dull needle.

Pull compensation:  Digitizing 
technique that takes into account the 
distortion of a design that will occur 
because of the interaction of thread with 
fabric. ‘Push and pull’ will cause a circle 
digitized perfectly round to sew with the 
sides pushed out, resulting in an egg 
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shape. Generally, it is necessary to extend 
horizontal elements and reduce vertical 
elements. See also Automatic pull 
compensation.

Push-Pull:  When any stitch is sewn into 
fabric, the tension in the thread between 
needle penetrations can build up and 
result in a ‘push-pull’ effect. This can 
cause distortions in your sewn designs, 
poor stitch registration and even the 
bunching of the fabric. The degree of 
distortion can be affected by the 
following factors: stitch density, fabric 
type, underlay, backing type, thread type 
and garment orientation. See also 
Stitch-Pull.

Quilting:  In general, the process of 
making a quilt; in specific, the stitching of 
patterns into the quilt layers to add 
strength and decoration to the quilt - top, 
batting and backing -- to form decorative 
patterns on the surface of the quilt and to 
hold the layers together. 

RAM:  Random Access Memory, 
computer chip maintaining memory.

Read:  To open a design which has been 
written on a design card or to an 
embroidery machine.

Redraw:  The screen display is refreshed. 
This is useful when parts of the display 
have become obscured in the course of 
editing. See also Slow Redraw.

Refresh:  See Redraw for details.

Resequence:  You can change the 
position of a selected object by cutting it, 
then pasting it somewhere else in the 
stitching sequence, or by using the 
Resequence command. You can also 
resequence objects by color or using the 
Color Film. 

Resizing:  See Scaling for details.

Resolution:  Resolution determines the 
number of dots per inch (dpi) used to 
create an image. The higher the value, 
the clearer the image, but the more 
storage space required. A resolution of 75 
dpi generally produces good results.

RGB:  RGB stands for red, green, and 
blue. It is the system used by computer 
monitors to create color.

Right-click:  To press and release the 
right mouse button. See also Click.

Rotation handles:  When you select an 
object, selection handles display at its 
extremities. If you click the object again, 
rotation and skew handles appear around 
the object. Rotation handles appear at 
the corners of the object and an anchor 
point displays at the object’s center. Skew 
handles are diamond-shaped and appear 
at the center-top and bottom of the 
object. See also Selection handles.

Run stitch:  Run stitch (also called Walk 
stitch) places a single row of stitches 
along a digitized line. The needle 
penetrations are placed in consecutive 
order. Run is generally used for stitching 
outlines and connector stitches. Run 
stitch length can be set to automatically 
vary in order to follow tight curves.

Satin Special:  Satin Special only affects 
Satin stitch. When applied, it breaks any 
long Satin stitches into shorter ones. It 
also distributes needle penetrations in a 
random pattern so that they do not form 
a line in the middle of the shape. Used 
primarily to prevent long stitches in wide 
columns, it can also be used as an 
alternative to Tatami fill. Auto Split looks 
more Satin-like and works well with 
turning stitches, creating soft lines and a 
little more depth.

Satin stitch:  Type of fill stitch. Formed 
by closely arranged zigzag stitches, it can 
be stitched at any angle and with varying 
lengths. The thread is laid across a shape 
with a zigzag sewing action where two 
stitches form a column. Hence it is only 
suitable for small or narrow shapes. As 
the stitches are almost parallel, Satin 
provides good coverage. It is often used 
for lettering, outlining, and details. 
Because there are generally no needle 
penetrations breaking up the fill, Satin 
stitch creates a glossy effect.

Save:  To store (design) information in a 
file. Each time you save a design, you 
replace the previous version using the 
filename. You should save your design 
frequently.

Scalability:  Ability to enlarge or reduce 
a design. In expanded format, most 
scaling is limited to 10 to 20%, because 
the stitch count remains constant despite 

final design size. In condensed formats, 
on the other hand, scale changes may be 
more dramatic, because stitch count and 
density may be varied.

Scaling:  Ability to enlarge or reduce a 
design in size. In stitch or ‘expanded’ 
format, most scaling is limited to ±5% 
because the stitch count remains 
constant despite final design size. In 
outline or ‘condensed’ formats, scale 
changes may be more dramatic because 
stitch count and density are recalculated.

Scanner:  A device that converts physical 
images into digital form so that they can 
be stored and manipulated by computer. 
Scanning allows you to take scanned 
images as a basis for embroidery design.

Screen calibration:  You need to 
calibrate your monitor so that designs at 
1:1 scale appear at real size. Do this when 
you first install BERNINA Embroidery 
Software, whenever you change your 
monitor, or adjust your monitor’s 
horizontal or vertical controls.

Screen resolution:  See Pixel for details.

Scroll bar:  The bar at the bottom and 
right edge of a window whose contents 
are not entirely visible. Each scroll bar 
contains a small box, called a scroll box, 
and two scroll arrows to allow different 
types of scrolling.

Security code:  Options in BERNINA 
Embroidery Software are controlled by a 
security device installed on the computer. 
Security access codes entered into the 
software are sent to this security device. 
Each security device has a unique serial 
number and identity code.

Security Device:  See Dongle for details.

Select:  To highlight an object or group 
of objects for the purpose of editing. Only 
selected items can be edited.

Selection handles:  Eight small squares 
that appear symmetrically at the corners 
and edges of a selected object. Use them 
to position and resize objects. See also 
Rotation handles.

Sequence:  See Stitching sequence for 
details.
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Serial port:  A connection point on a 
computer where you plug a serial 
communications device such as a 
modem. PC serial COM ports are male 
connectors, and can be either 9-pin or 
25-pin. They are named COM1, COM2, 
COM3, etc. The number of available ports 
limits the number of devices you can 
connect. If additional ports are required, 
you can add them. Multi-port serial cards 
can also be used.

Serial Port Setup:  Here you can adjust 
Baud, Data Bits, Stop Bits, Parity values. 
These settings must be identical to those 
of the embroidery machine. The type of 
handshaking must match the type of 
cable you are using.

Short stitch:  Digitizing technique that 
places shorter stitches in curves and 
corners to avoid an unnecessarily bulky 
build-up or stitches.

Shortcut key:  A key stroke or a series of 
keystrokes you can use to perform a task 
instead of using the mouse. For example, 
Ctrl+C actions the Copy command.

Sizing handles:  See Selection handles 
for details.

Skew handles:  See Rotation handles 
for details.

Slow Redraw:  Use to redraw your 
design slowly. Slow Redraw lets you view 
the stitching and color sequence of a 
design in slow motion.

Software:  Programs, such as MS 
Windows and BERNINA Embroidery 
Software, which run your computer.

Specialty fill:  A fill stitch capability that 
produces a fill with a ‘relief’ or ornament 
within the fill-stitch area – e.g. Pattern Fill.

Specialty threads:  Threads designed 
for effects such as shine, glitter, 
iridescence or thickness. The threads 
often are made from synthetic materials 
including rayon, mercerized cotton, 
metallics and textured nylon.

Status bar:  Provides information about 
the whole design: number of stitches, 
position of the design (X, Y), number of 
colors (C), number of stops (S), etc.

Stemstitch:  A detail stitch that can be 
used to outline items or fill in areas. It is 
used for stems and vines with other 
decorative stitches, or as an outline for 
Satin or Stipple fills.

Step stitch:  Series of parallel stitches 
commonly used to cover large areas. 
Different step patterns can be created by 
altering the angle, the length and repeat 
sequence of the stitches.

Stippling:  A method of creating a fill 
made of run stitches which meander 
around within a border. Often used in 
quilting.

Stitch:  A stitch is one needle 
penetration; also used to refer to the 
thread laid down from one needle 
penetration to the next.

Stitch angle:  The stitch angle is the 
angle the overall stitching follows within 
a shape. The shape may have a fixed 
stitch angle – e.g. 45° to the horizontal – 
or multiple stitch angles.

Stitch bunching:  Standard stitch 
spacing is calculated at the outside edge 
of a shape. With sharp curves, spacing 
which provides adequate coverage on the 
outside edge may cause bunching along 
the inside edge. This may cause thread 
breakage when stitching out.

Stitch count:  Stitch count refers to the 
number of stitches in a design. In 
BERNINA Embroidery Software one stitch 
is considered one machine revolution. See 
also Design properties.

Stitch density:  The number of stitches 
per given area (or stitch lines per distance 
in a fill).

Stitch editing:  Digitizing feature that 
allows one or more stitches in a pattern to 
be deleted or altered.

Stitch file:  Stitch or ‘expanded’ designs 
are low-level formats for direct use by 
embroidery machines. They contain only 
stitch coordinates and machine functions. 
Stitch designs are generally not suited to 
scaling because stitches are not 
regenerated during rescaling. See also 
Outline file.

Stitch length:  The distance between 
two needle penetration points. For 
maximum stitch length, the length is 
measured according to the X and Y 
co-ordinates, whichever is greater. Run 
stitch length can be set to automatically 
vary in order to follow tight curves. See 
also Max/Min stitch length.

Stitch-Pull:  When any stitch is sewn into 
fabric the tension in the thread between 
needle penetrations can build up and 
result in Stitch-Pull. Stitch-Pull can cause 
distortions in your sewn designs, poor 
stitch registration and even the bunching 
up of fabric. The amount of Stitch-Pull 
that results in your design can be affected 
by the following factors: Stitch Density, 
Fabric Type, Underlay, Backing Type, 
Thread Type and Garment Orientation. 
See also Push-Pull.

Stitch type:  Three basic stitch types are 
available with lockstitch machines – Run, 
Satin and Tatami (Weave). BERNINA 
Embroidery Software provides many 
variants of these.

Stitch spacing:  Spacing between two 
consecutive needle penetrations on the 
same side of a column. The smaller the 
value, the greater the stitch density. For 
more open stitching, use larger values.

Stitching defects:  Stitching defects 
may appear in the form of gaps between 
filled areas, fabric show-through and 
thread breaks. These are often caused by 
incorrect stitching settings – e.g. setting 
pull compensation too small for the fabric 
stretchiness.

Stitching sequence:  The embroidery 
objects in a design form a stitching 
sequence. Initially, objects are stitched in 
the order in which they were created. You 
can change the position of a selected 
object by cutting it, then pasting it 
somewhere else in the sequence, or by 
using the Resequence command. You can 
also resequence objects by color or with 
the Color Film.

Stock designs:  Embroidery designs 
readily available on disk or proprietary 
embroidery card. Digitized embroidery 
designs that are commercially available 
for general use by embroiderers.
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System requirements:  What your 
computer’s hardware and software, 
operating together, can support. System 
requirements are printed on software 
packages, design disk cards and packs, 
CDs and other computer accessories. You 
need to know what your system can and 
cannot support, as sometimes a system is 
not capable of handling new software 
without adding memory or disk space. 

Tackdown:  Zigzag stitch, placed after 
placement and cutting lines, and used to 
fix appliqué patches to the background 
fabric before cover stitching is applied.

Tatami stitch:  Series of run stitches, 
commonly used to cover large, irregular 
shapes. Stitches are laid in rows traversing 
back and forth across the shape. These 
can be parallel or slightly turning. 
Different fill patterns can be created by 
varying the stitch length, angle or 
sequence. Also known as Weave stitch.

Template:  Special files used to store 
styles and default property settings. Use 
templates when digitizing 
frequently-used design types to save time 
re-adjusting the current property settings. 

Tension:  Tautness of thread when 
forming stitches. Top thread tension, as 
well as bobbin thread tension, need to be 
correctly set. Proper thread tension is 
achieved when about one third of the 
thread showing on the underside of the 
fabric on a column stitch is bobbin 
thread.

Textured Edge:  Use Textured Edge to 
create rough edges, to create shading 
effects, or to imitate fur or other fluffy 
textures in your design.

Thread:  Fine cord or natural or synthetic 
material made from two or more 
filaments twisted together and used for 
stitching. Machine embroidery threads 
come in rayon (high sheen), cotton (duller 
finish), polyester (strong and colorfast), 
metallics (synthetic core wrapped with 
metal foil or thin slivers of metal foil) and 
acrylic (sheen similar to rayon).

Thread chart:  Thread charts are lists of 
pre-defined thread colors. They may be 
based on commercially available thread 
charts, or charts you define yourself. You 
can copy colors between different thread 

charts to create your own charts from 
existing colors. See also Color palette.

Thread code:  Code is the identification 
number of a thread color in a brand.

Thread painting:  The technique of 
forming designs on an embroidery 
machine by simultaneously running the 
machine and using a freehand motion 
with the fabric secured in an embroidery 
hoop, allowing the needle to ‘draw’ on 
the fabric surface.

Thread density:  Different thread 
density systems are used by different 
thread manufacturers. Density A is 
normal embroidery thread (density 120/2, 
or 40). Density B is thicker, Density C is 
finer, and Density D is very fine.

Thread thickness:  See Thread density 
for details.

Thread type:  Embroidery thread varies 
in thickness. Types are A, B, C and D. 
Stitch density should be set according to 
the thread type. See also Thread 
thickness.

Tie-ins:  Tie-in stitches are inserted at the 
start of objects to prevent stitches from 
unraveling. They are inserted inside the 
shape on the second stitch. You generally 
use them when the previous connector is 
trimmed.

Tie-offs:  Tie-offs are generally placed 
before trims to prevent stitches from 
unraveling. You can adjust connector 
settings to automatically add tie-offs 
under certain conditions, or add them 
manually. You can also include trim 
functions so machines with trimmers cut 
the thread automatically.

Title bar:  The horizontal bar located at 
the top of a window and containing the 
title of the window. On many windows, 
the title bar also contains the Control 
menu box and Maximize and Minimize 
buttons.

Toolbar:  Toolbars provide quick and 
easy access to BERNINA Embroidery 
Software commands. Click a toolbar 
button to activate a command or, where 
applicable, right-click to view and adjust 
its settings.

Topping:  Material hooped or placed on 
top of fabrics that have definable nap or 
surface texture, such as corduroy and 
terry cloth, prior to embroidery. The 
topping compacts the wale or nap and 
holds the stitches above it. It includes a 
variety of substances, such as plastic 
wrap, water-soluble plastic ‘foil’ and 
open-weave fabric that has been 
chemically treated to disintegrate with 
the application of heat. Also known as 
‘facing’.

Travel on Edges:  In BERNINA 
Embroidery Software, Travel on Edges 
effect forces travel runs to the edges of 
objects so they do not show through 
open or loose stitching.

Travel run:  Travel runs are typically used 
to connect segments of complex shapes. 
They can also connect adjacent objects. 
Because runs are not trimmed, they may 
be visible in the final embroidery. For this 
reason, they are less commonly used as 
connectors between objects than jumps. 
If objects are adjacent and connectors will 
be hidden, they can be used.

Traveling:  You generally check a 
design’s stitching sequence by ‘traveling’ 
through it by stitches, segments, 
functions or objects.

Trims functions:  If you are using a 
machine with an automatic trimmer, the 
trim code causes the thread to be cut 
after a tie-off. In the software, trims are 
represented by a triangle with a small 
circle at the point where stitching starts 
again. The trimmed connector appears as 
a dotted line. You can adjust connector 
settings to automatically add trims, or 
add them yourself.

Trimmers:  Devices built into an 
embroidery machine to automatically trim 
or cut remaining thread when the design 
jumps from one area to another or 
performs a color change.

Trimming:  Action of cutting loose 
thread, removing backing, etc, from the 
final embroidered product.

TrueType Font:  Digital font technology 
designed by Apple Computer and now 
used by both Apple and Microsoft in their 
operating systems.
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TWAIN:  Industry standard which allows 
devices (such as scanners) to 
communicate directly with design and 
layout programs. Both device and 
program must be TWAIN-compliant. This 
lets you use any TWAIN-compliant 
scanner with your software.

Underlay:  Stitches sewn before other 
design elements to help stabilize fabrics. 
The stitching action that will attach the 
backing to the fabric being embroidered. 
It also supports the top embroidery for a 
more lofty, dimensional look. Underlay 
stitches are made up of a series of single 
run stitches, usually with a very short 
stitch length, and are digitized manually 
or placed automatically under the column 
(satin) or fill stitch areas of your 
embroidery design.

Underlay margin:  The distance 
between an object outline and the edge 
of the underlay. Increase this margin to 
prevent underlay stitches from extending 
outside the cover stitches.

USB port:  Universal Serial Bus 
Connector, a connection on a computer 
where you plug in the dongle. 

Values:  The actual settings – letters and 
numbers – that you enter into dialogs. 
See also Object properties.

Variable sizing:  Ability to scale a design 
to different sizes.

Vector graphic:  Any image displayed 
and stored mathematically as lines. Vector 
‘objects’ include rectangles, ellipses, 
curves, polygon stars, complex stars and 
perfect-shape objects created in graphics 

applications such as CorelDRAW®. Unlike 
raster images, vector graphics contain 
geometric shapes and lines that combine 
to form the image. Vector graphics are 
scalable without distortion, and usually 
form small files. See also Bitmap image.

Vector object:  Vector objects are 
derived from vector graphics and can be 
created in BERNINA Embroidery Software 
or imported. In BERNINA Embroidery 
Software they can be converted to and 
from embroidery objects. You can set 
general properties such as size and 
position, and arrange and transform 
them in the same way as other objects. 
See also Bitmap.

Wave Effect:  With Wave Effect you can 
curve Closed Fill stitches along a digitized 
line to create flowing stitch effects. The 
stitches follow the digitized line but 
maintain uniform density and needle 
penetration patterns.

Weave stitch:  See Tatami stitch for 
details.

Weight:  When referring to T-shirts, the 
three standard weight divisions are 
mid-weight/value, 
heavyweight/premium, and super 
heavyweight.

WMF:  Windows Metafile vector format.

Write:  To send design information to an 
embroidery disk, design card or 
embroidery machine for immediate 
stitchout or storage.

X/Y coordinates:  The horizontal (X) 
and vertical (Y) distances on a graph or 
computer screen. Use X values to 
measure width, and Y values to measure 
height.

Zigzag stitch:  Zigzag stitch is similar to 
Satin but is generally used where fewer 
stitches are required. The needle 
penetrates each side of the column, 
laying the thread across in an open zigzag 
pattern. The density is determined by the 
stitch spacing setting. The settings for 
Zigzag fill stitches are stored separately 
from Zigzag and Double Zigzag underlay 
settings.

Zigzag underlay:  Zigzag and Double 
Zigzag underlay stitching is used to 
support wide columns.

Zoom factor:  The scale at which the 
design is currently displayed.
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INDEX

Numerics

3-position-hoop designs, creating 47

A

accessing designs, databases and 
folders 292

Add Eight Adjacent Hoops tool 42
Add Four Adjacent Hoops tool 42
Add Holes tool 158
Add Hoop
Right tool 42, 47
tool 42, 46, 47
Up tool 42, 47

Add Stitch Angles tool 146
Add Thread dialog 83
adding
folders 301
lettering to designs 223

adjusting
baselines 238
Blanket stitch offsets 65
letter dimensions 233
letter height and width 233
letter spacing 229
pattern fill settings 182
Step stitch spacing 68

Advanced Appliqué tool 214
Align
Bottom tool 136
Centers Horizontal tool 136
Centers tool 136
Centers Vertical tool 136
Left Vertical tool 136
Right Vertical tool 136
Top Horizontal tool 136

aligning objects 136
alphabets
Abby Script 331
Alice 332
Anniversary 333
Bamboo 334
Blackboard 335
Bodoni 336
Castle 339
Chicago 341
Childs Play 342
Christopher 343
Craft 344
creating special characters 401

Creative Cross 345
Croissant 346
Cursive 347
Diamond2 349
Diamond3 350
Drifter 351
Easy Appliqué 352
Eliza 353
Empress 354
Energy 355
Erica 356
Fortress 359
Greek 2 360
Greek Ionic 361
Guinevere 362
Hebrew 2 363
Hebrew David 364
Hiragana 365
illustrated descriptions 330
Island 367
Jikharev 368
Katakana 369
Ketchikan 370
King Charles 372
Lisa 374
London 375
Mandarin 376
Medley 377
Meegan 378
Neon-CAPS 380
Nightowl 381
Olde English 382
Phoebe Curls 383
Prestige 384
Quilting Text 385
Roman-Small 387
Rounded Block 388
Russian Textbook 389
Scanner 390
Secret Garden-CAPS 391
selecting 224
Swiss Block 393
Tabloid 394
Technical Block 395
Tiffany 396
Varsity Applique-CAPS 397
Varsity Block-CAPS 398
Verdana 399
Victoria 400
Zurich 401
See also lettering

AMT templates 86
anchor points, rotation 138
angles
adjusting stitches 145
rotating by exact angle 138
skewing by exact angle 139
See also stitch angle

anti-aliasing 103
Any Shape option 225, 228
appliqué
adjusting cover stitch settings 209, 
265

closed-objects 208
cover stitch values 209, 265
offsetting cover stitches 209
open-object 213
partial cover 212
splitting 130

Applique Fabric dialog 211
Appliqué Properties dialog
Merge Patches Together 218
Place Fabric and Color in 
Patches 216

Place Fabric in Patches 215
Recover your original embroidery 
objects 221

Remove Fabric from Patches 217
Set Colors Automatically 219
Set Stitch Types Manually 219

archived design files, handling 299
Arrange menu
Buttonhole 161
Pattern Stamp 178
Sequence As Selected 131
Sequence By Color 131
Sequence to End 132
Sequence to Start 132
Stitch Sequence 133

Arrange toolbar
Align Bottom 136
Align Centers 136
Align Centers Horizontal 136
Align Centers Vertical 136
Align Left Vertical 136
Align Right Vertical 136
Align Top Horizontal 136
Group 129
Kaleidoscope 141
Mirror-Merge Horizontal 140
Mirror-Merge 
Horizontal/Vertical 140

Mirror-Merge Vertical 140
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Ungroup 129, 174
Wreath 141

arranging objects, grouping 129
Art Canvas mode 24, 105–109, 
113–114, 118–124

Art Toolbox
Convert Text to Embroidery 240
Convert to Embroidery 117

artwork
anti-aliased images 103
bitmap images 102
dithered images 103
loading 106
preparing for automatic 
digitizing 111, 113, 114

scanned images 102
scanning 103
vector drawings 102

Artwork Preparation tool 113, 114
As Digitized method 71
Auto Applique
tool 208

Auto Appliqué
cover stitch values 209, 265

Auto Applique options,setting 56
Auto Digitizer
dialog 121–123
tool 120–122

Auto Jump, applying 95
auto scroll options 55
Auto Spacing, setting values 64
Auto Underlay tool 91–93, 234
automatic spacing, see Auto Spacing
automatic backup 57
automatic digitizing 120
cleaning up images 111
color reduction 111
cropping images 107
image preparation tools 112
noise filtering 112
outline sharpening 112
preparing images 111
preparing non-outlined images 113
preparing outlined images 114

automatic outlines and borders 122
automatic pull compensation 94
automatic save 57
automatic sequencing 133
automatic spacing
satin fill stitch 67

automatic start and end, setting 98
Automatic Stitch Colors dialog 219
automatic stitch splitting 67
automatic stitching 118, 120
adjusting fill stitch settings 122
creating embroidery designs 120, 
122

automatic underlay, applying 91

B

backdrops
inserting bitmap images 106
loading 106
saving as separate files 109
scanning 105
using as template 101

backgrounds, scanning 105
Backstitch
outlines 196
stitch length 196
tool 194, 196

backup files 323
baselines
circular lettering 226
custom baseline lettering 228
horizontal lettering 225
lettering 225
multiple baseline lettering 227
reshaping 238
selecting 225
vertical lettering 226

basics
saving designs 18
starting 15
using commands 20

Bernina Device Selection dialog 269, 
278, 280, 281

BERNINA Embroidery Software, 
starting 15

Bernina International Web Page 3
Bernina of America Web Page 3
bitmap images
anti-aliasing 103
automatic digitizing 102
dithered 103
file types 106
inserting 106
saving separately 109
scanned 102
scanning 105
supported file formats 102

Blackwork Border
changing pattern 195
selecting patterns 195
tool 194, 195

Blackwork Fill tool 199, 200
blackwork fills 200
Blackwork Run tool 157
Blackwork runs, splitting 130
Blanket stitch 60
adjusting offsets 65
adjusting spacing 65
creating 64
offsets 65
spacing 65

block digitizing 73
with Block Digitizing tool 73
with multiple angles 73

Block Digitizing tool 70, 73

bold lettering, making 228
borders
automatic 122
creating 161
creating your own 260
multiple 258
with monograms 250, 258

bounding box, selecting objects 35
Break Apart tool 130
Browse for Folder dialog 288, 299, 
300

browsing
designs, slide show 292

buttonhole
add 161
adjusting angles 163
command 161
length and density 163
objects, transforming 163
orientation 163
types 163

buttonholes
creating a line 162

Buttonholes Settings dialog 162

C

Calculate Hoopings
dialog 42
tool 42

calibrate monitor 54
Candlewicking Border 198
selecting patterns 198
stitch spacing 198
tool 194, 198

Candlewicking Fill tool 199, 201
candlewicking fills 201
Carving Stamp dialog
Appearance 190
Digitize 189, 192
Use Object 188
Use Pattern 186

carving stamps
adding to library 192
changing appearance 190
creating stitch patterns 186
digitizing 188
pre-defined 186
reshaping 190
using objects 188

catalogs
exporting in CSV format 298
exporting in Tab delimited 
format 298

printing 296
publishing 297

Change Design View tool 287
Change Locale command 289
changing
entry and exit points 148
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entry point 144
exit point 144
locale (language) 289
stitches 60

Character Map 242
dialog 242

checking
sequence 130
stitching sequence 130

Choose Locale dialog 289
circle baselines
creating 226

Circle CCW option 225, 226
Circle CW option 225, 226
circle objects
changing stitch angle 145
digitizing 74
reshaping 144

Circle/Oval tool 70, 74
cloning objects 129
Closed Object tool 70, 72
closed-object appliqué, creating 208
Closest Join method 71
color
matching 77
place in patches 216
reduction 111
remove from patches 217

Color Blending
applying 174
dialog 174
selecting types 174
setting values 174
spacing values 174
tool 173, 174

Color dialog 31, 80
Color Film
dialog 37, 132
printing 266
resequencing objects 132
selecting color blocks 36
tool 36, 132, 175

Color Film toolbar
Sequence As Selected 132
Sequence By Color 132
Sequence to End 132
Sequence to Start 132
Show Individual Objects 36, 132

Color tool 76
Color Wheel dialog 79
colors
adding to thread charts 83
changing for an object 77
changing thread color 76
changing thread colors 76
copying across thread charts 82
deleting thread charts 81
modifying thread charts 79
modifying thread values 79
removing from thread charts 80
resequencing by 131

selecting for an object 76
selecting new current color 76
traveling by 28

colors, changing 79
columns of varying width
digitizing 73

columns, sorting 290
combining
designs 130
objects 127

Comma Separated Value files, see 
CSV files

commands
selecting 20
toolbars 20

Complex Fill
filling holes 160

component objects, splitting 130
composite objects, splitting 130
connection settings
parallel ports 53
peripheral devices 53
serial ports 53
USB ports 53

connectors
Auto Jump 95
jumps 97
stitches used to move between 
objects 96

tie-ins 97
travel runs 96

contour fills 165
control points 71
selecting 142
using to reshape objects 143

conversion tools 117
Convert Options dialog 299
Convert Selected Designs tool 299
Convert Selected Embroidery to Art 
Vectors tool 118

Convert Text to Embroidery tool 240
Convert to Embroidery tool 117
converting
file types 299
photos to designs 124
stitch designs 276

coordinates, setting for objects 135
Copy From dialog 82
Copy tool 128
copying
and pasting designs 301
cloning objects 129
colors across thread charts 82
duplicating objects 128
objects 128

cover stitches
offsetting 209
setting values 209, 265

Craft Stitch
Ripple 200, 204
Sculptured Fancy 200, 203

Craft Stitch toolbar
Backstitch 194, 196
Blackwork Border 194, 195
Blackwork Fill 199, 200
Blackwork Run 157
Candlewicking Border 194, 198
Candlewicking Fill 199, 201
Lacework 200, 202
Stemstitch 195, 197
Stipple Run 200, 205

craft stitches 11
blackwork fills 200
candlewicking fills 201
lacework fills 202
ripple fills 204

Create Pattern 185
command 185

Create Stamp Pattern dialog 192
Create/Edit Hoop dialog 49–52
creating
lettering on-screen 223
monograms 245
own thread charts 81
textured edges 169
textures with Fancy fill 166

cross stitch fills 168
CSV files
Comma Separated Value files 298
exporting catalogs as 298

current
color changing 76
needle position marker 29
object properties 84
object properties, changing 84

curved lines, making 71
curves
smoothing 144

custom baselines, creating 228
custom borders, creating 260
custom hoops
creating 48
creating sliding hoops 50
editing 52
oval 49
rectangular 48

custom templates
selecting 18, 293

Customize Columns command 290
cut and paste
designs 302
objects 128
resequencing 131

cut holes in objects 158
Cut tool 131
cutters, remove overlaps 159
cutting lines
appliqué 208
open-object appliqué 213
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D

default
design view 290
object properties 84

Delete command 36
Delete Hoop tool 42, 46, 47
delete recovery 323
deleting
colors from thread charts 80
custom hoops 52
designs 302
folders 301
objects 128
patterns 185
templates 88
thread charts 81

deselecting objects 36
design
stabilizing with underlay 90

design colors, changing 79
design dimensions, problems 324
design information
viewing 28, 32
viewing in Windows Explorer 32

Design List Columns dialog 290
design lists, customizing 290
Design Properties command 32
Design Properties dialog
Design 32
Summary 32
Thread Color 31
Thread Colors 77–82, 268

Design Properties tool 291
Design toolbar
Block Digitizing 73
Circle/Oval 74

designs
accessing 292
adding lettering 223
archiving 299
browsing with slide show 
buttons 292

combining 130
converting to other file types 299
creating new 17
downloading 280
opening 17, 292
opening multiple 17
opening stitch designs 276
planning 5
previewing 33, 263
print preview 263
printing 263
reading design from machine 278
resequencing 131
saving 18
saving as images 268
saving multi-hooped 271
selecting 292
sending to machine 268

sorting 294
sorting using Navigation buttons 
and Slide Show buttons 290

starting 17
stitching 268
stitching and punching 298
storing 280
viewing 290
viewing in databases 290
viewing records 291
writing to design cards 280

details lists, sorting 295
Device Manager dialog 325
dialogs
Add Thread 83
Applique Fabric 211
Appliqué Properties > Merge 
Patches Together 218

Appliqué Properties > Place Fabric 
and Color in Patches 216

Appliqué Properties > Recover your 
original embroidery objects 221

Appliqué Properties > Remove 
Fabric from Patches 217

Appliqué Properties > Set Colors 
Automatically 219

Appliqué Properties > Set Stitch 
Types Manually 219

Auto Digitizer 121–123
Automatic Stitch Colors 219
Bernina Device Selection 269, 278, 
280, 281

Browse for Folder 288, 299, 300
Buttonholes Settings 162
Calculate Hoopings 42
Carving Stamp > Appearance 190
Carving Stamp > Digitize 189, 192
Carving Stamp > Use Object 188
Carving Stamp > Use Pattern 186
Charactor Map 242
Choose Locale 289
Color 31, 80
Color Blending 174
Color Film 37, 132
Color Wheel 79
Convert Options 299
Copy From 82
Create Stamp Pattern 192
Create/Edit Hoop 49–52
Design List Columns 290
Design Properties 31, 32
Design Properties > Thread 
Colors 77–82, 268

Device Manager 325
Display 31
Edit Thread 79
Effects 21
Effects > Color Blending 175
Effects > Gradient Fill 172
Effects > Others 95, 173, 228
Effects > Star & Wave Fill 170, 171

Effects > Underlay 91–93
Effects >Textured Edge 169
Enter Drive Letter and Path 281
Export 109
Export to File Options 298
Fabric Settings 90
Fill Holes 160
Hooping Sequence 267–273
HTML Catalog Options 297
Image Preparation 113, 114
Import 106
Load Picture 31
Magic Box About 283
Make Border 260
Make Pattern 184, 185
Modify Thread Chart 79–82, 83
Monogramming > Borders 259
Monogramming > 
Lettering 250–253

Monogramming > 
Ornaments 254–257

Multiple Hoopings 271, 273
New 18, 293
New Pattern Set 185
New Set 260
New Stamp Set 192
New Thread Chart 82
Obejct Properties > Lettering 233
Object Not Covered 270, 271
Object Properites > Fill Stitch > 
Pattern Fill 185

Object Properites > Outline Stitch > 
Pattern Run 185

Object Properties 21, 84, 85
Object Properties > Appliqué 209, 
211

Object Properties > Buttonhole 163
Object Properties > Fill Stitch 246
Object Properties > Fill Stitch > 
Blackwork 201

Object Properties > Fill Stitch > 
Candlewicking Fill 202

Object Properties > Fill Stitch > 
Contour 166

Object Properties > Fill Stitch > 
Cross Stitch 168

Object Properties > Fill Stitch > 
Fancy 167

Object Properties > Fill Stitch > 
Lacework 203

Object Properties > Fill Stitch > 
Pattern Fill 181–183

Object Properties > Fill Stitch > 
PhotoSatin 124

Object Properties > Fill Stitch > 
Ripple 204

Object Properties > Fill Stitch > 
Satin 67

Object Properties > Fill Stitch > 
Step 69
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Object Properties > Fill Stitch > 
Stipple Run 205

Object Properties > Fill Stitch 
>Step 247

Object Properties > General 136, 
137, 138, 233

Object Properties > 
Lettering 224–229, 232, 241–245

Object properties > Outline Stitch > 
Backstitch 196

Object Properties > Outline Stitch > 
Blacket 65

Object Properties > Outline Stitch > 
Blackwork Border 195

Object Properties > Outline Stitch > 
Candlewicking Border 198

Object Properties > Outline Stitch > 
Pattern Run 180–181

Object Properties > Outline Stitch > 
Satin 63–64

Object Properties > Outline Stitch > 
Single 62

Object Properties > Outline Stitch > 
Stemstitch 197

Object Properties > Outline Stitch > 
Triple 62

Object Properties > PhotoSnap 124
Object Properties > Stitch 
Angle 146

Object Properties > Tie-In/Off 97
Open 17, 254, 277
Open Options 277
Options 39, 49–52, 55–58
Outline Design 161
PES Save Options 284
Print 264
Print Catalog Options 296
Print Options 264–267, 296
Print Preview 263
Print Setup 296
Properties 33, 291–292
Rename Design 302
Rename Stamp Pattern 186
Rename Thread Chart 81
Revert to Factory Template 88
Save As 86
Save Design as Image 268
Save Hoop As 49–52
Save To Template 85
Screen Calibration 54
Select Border 259
Select By Color 26
Select Character 242–245
Select Pattern 178, 180, 181, 185, 
195, 198, 201, 202, 203, 254

Select Source 54, 254
Sequence By Color 131
Slow Redraw 30
Smooth Curves 144
Sort 295
Start and End 98

Stitch Options 299
Stitch Sequence 133
User Preferences 290
Write to Embroidery System 269, 
278, 280, 281

Zip archive 300
Zoom Factor 27

Digitize toolbar
Advanced Appliqué 214
Auto Applique 208
Auto Digitizer 120–122
Block Digitizing 70
Circle/Oval 70
Closed Object 70, 72
Freehand Draw Embroidery - Closed 
Object 155

Freehand Draw Embroidery - Open 
Object 155

Lettering 223–229, 231, 233, 237, 
241–248

Magic Wand 118–119
Monogramming 250–253
Open Object 70, 71
Outline Design 161
Partial Applique 212
PhotoSnap 124
Rectangle 70, 74

digitizing
automatic 120
circles and ovals 74
closed shapes using Closed Object 
tool 72

columns 73
essentials 59
fills with Magic Wand 118, 119
lines with Open Object 71
manually 59
methods, Open Object tool 71
selecting a digitizing tool 70
squares and rectangles 74

digitizing tools 70
selecting 70

Dim Artwork tool 30
display adapters
checking 325
locating drivers 326

Display dialog 31
Display Setup command 54
displaying
hoops 19

distorting lettering, using Elastic 
Lettering 248

dithering 103
dockers
Morphing Effect 175

dongle
driver, installing 324

Double Run tool 157
Double Zigzag, setting values 93
downloading, designs to cards 280
drawings, see also backdrops

driver, dongle installing 324
Duplicate command 128
duplicating, objects 128

E

Edge Walk
adjusting settings 92
setting underlay values 92

Edit menu
Delete 36
Duplicate 128
Elastic Lettering 248, 249
Stitch Edit 150–152

Edit Thread dialog 79
Edit toolbar
Add Holes 158
Artwork Preparation 113, 114
Break Apart 130
Color Blending 173, 174
Convert Selected Embroidery to Art 
Vectors 118

Double Run 157
Fill Holes 160
Mirror Horizontal 139
Mirror Vertical 139
Polygon Select 35
Remove Overlaps 158
Reshape Object 108, 142–148, 
229–230, 232–238

Scale by 20 percent Down/Up 136
Select Object 34–35, 129, 136, 232, 
234

editing
custom hoops 52
Lettering 231

editing stitches 10, 151
deleting stitches 152
inserting stitches 151
moving stitches 152

effects
Auto Jump 95
Color Blending 173
star fill 171
Textured Edge 169
Travel on Edges 173

Effects dialog 21
Color Blending 175
Gradient Fill 172
Others 95, 173, 228
Star & Wave Fill 170, 171
Textured Edge 169
Underlay 91–93

Elastic Lettering
distorting lettering 248
editing lettering 248
removing 249

Elastic Lettering command 248, 249
Embroidery Canvas mode 24, 
113–114, 118–124
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embroidery design formats 274
embroidery lettering, converting 
font 241

embroidery lettering, converting 
text 240

embroidery machines
connections 53
setting up 53

embroidery objects, conversion to 
vectors 116

Embroidery Online Web Page 3
embroidery, converting to 
vectors 118

end point, setting automatically 98
Enter Drive Letter and Path 
dialog 281

entry point, changing 148
errors, unrecoverable 323
Exception Access Violation, resolving 
errors 325

exit point, changing 148
Export dialog 109
Export to File Options dialog 298
exporting
catalogs as CSV files 298
catalogs as Tab delimited files 298

F

Fabric Display command 31
Fabric Settings dialog 90
fabric, placing in patches 215
fabric, removing from patches 217
fabrics
stretch compensation 94

fabrics, placing in Auto Appliqué 211
File menu
Design Properties 32
Insert Design 127
Portfolio 286

file tree, refresh 289
file types
PES files 284

files
backup 323
combining designs 130

Fill Holes dialog 160
Fill Holes tool 160
fill objects, adding stitch angles 146
fill stitch settings
adjusting 122

fill stitches
Blackwork Fill 199
block digitizing 73
Candlewicking Fill 199
Satin fill 61
Step 61
switching between fill and 
outline 71

types 60, 68

Fill tool 61, 66–68, 71, 165–168, 181, 
199

filling holes, Complex Fill 160
fills
blackwork 200
candlewicking 201
contour 165
cross stitch 168
lacework 202
ripple 204
star fill 171
stippling 205
stitch types 68

find threads 77
flair script designs 244
folders
adding 301
deleting 301
masking file types 294
refreshing/validating 289
renaming 301
searching 294
viewing zipped designs 288

font, converting to embroidery 241
fonts, flair script 244
fonts, see alphabets
formats, embroidery design 274
frame movement, Auto Jump 95
Free Line option 225
Free Line Vertical option 225, 226, 
227

Freehand Draw Embroidery
Closed Object tool 155
Open Object tool 155

freehand embroidery 154
freehand lines, creating 155
freehand lines, smoothing 155

G

gaps, offsetting filled holes 160
General options, setting 57
General toolbar
Auto Underlay 91–93, 234
Color Film 36, 132, 175
Copy 128
Cut 131
Dim Artwork 30
Morphing 175
New 18
Object Properties 21, 62–69, 84, 
94–97, 163, 185, 209

Open 17, 276, 277
Paste 128, 131
Print 263
Print Preview 33, 263
Read from Magic Box 283
Redo 21
Save 18
Show 1-1 27

Show All 27
Show Appliqué Fabric 30, 31, 211, 
215, 216

Show Artistic View 25
Show Grid 19, 54
Show Hoop 19, 38, 48–52, 55
Show Pictures 30
Show Stitches 25, 280–281
Show Vectors 30
Textured Edge 169
Undo 21
Write to Machine 268–270, 
280–281

Write to Magic Box 283
Zoom Box 27

generating stitches 17
gradient fills
adjusting settings 172
applying 172
setting values 172
spacing values 172

graphics acceleration, reducing 326
graphics packages, linking to 108
graphics, digitizing with vectors 116
grid
displaying 19
setting options 54

Group tool 129
grouping objects 129
guide patterns
Pattern Fill 183

H

handles, see selection handles
hard disk space
checking 322

hardware
peripheral device settings 53
recovering from failure 322
reducing acceleration 326
setting up display monitor 54
setting up scanner 54

Help menu
Bernina International Web Page 3
Bernina of America Web Page 3
Embroidery Online Web Page 3
Help Topics 3
Online Manual 3

Help Topics command 3
help, view Onscreen Manual 4
help, viewing 3
Hide/Show Folders tool 288
hiding
stitches 25

hiding outlines 25
holes
filling holes 160

holes, create in objects 158
hoop centers,setting 39
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Hoop Layout mode 24, 40
Hoop Options,setting 55
hooped designs
outputting 269
outputting,split lines 272
sending to machine 270

hooping sequence 41
Hooping Sequence dialog 267–273
hooping sequence, printing 267
hoops
changing 38
changing display 19
creating custom hoops 48
creating oval hoops 49
creating sliding hoops 50
deleting 52
displaying 19
editing custom hoops 52
hiding on screen 19
selecting 38
showing on screen 19

horizontal baselines
creating 225

HTML Catalog Options dialog 297

I

image preparation
cropping 107
preparing non-outlined images 113

Image Preparation dialog 113, 114
Image toolbar
Load Picture 106
Save Picture 109
Scan Picture 105
Touch Up Picture 108

images
cleaning up 111
color reduction 111
cropping 107
editing 108
inserting bitmaps 106
loading 106
noise filtering 112
non-outlined 113
outline sharpening 112
outlined vs non-outlined 111
preparation tools 112
preparing for automatic 
digitizing 113, 114

saving bitmaps separately 109
saving designs as 268
scanning bitmaps 105
sharpening/scanning 105

Import dialog 106
individual letters, adjusting 235
information, viewing online 3
initials, monogram lettering 252
Insert Design command 127
inserting

bitmap images 106
one design into another 130

installing, printers 53
internet, link to website 4
invalid
access code message 324
product 324

italic lettering
making 228

J

joining, columns with underlay 93
jumps
as connectors 97
Auto Jump 95
setting Jump Length 95

justification, setting lettering 229

K

Kaleidoscope
mirroring 141
tool 141
using with wreath 141

keyboard shortcuts 315

L

lacework fills 202
Lacework tool 200, 202
large designs, hooping 40
layers
removing extra stitching layers 158

layout
Pattern Fills 183

length
Backstitch 196
Edge Walk stitches 92
jumps 95
preserving long stitches 95
Zigzag and Double Zigzag 
stitches 93

letter
adjusting spacing 229
dimensions, adjusting 233
height, adjusting 233
spacing, adjusting 229
width, adjusting 233

lettering
adding to designs 223
adjusting Fancy stitch settings 247
adjusting individual letter 
spacing 230

adjusting on-screen 230
adjusting overall spacing 229
adjusting Satin stitch settings 246
adjusting spacing 229
adjusting spacing on-screen 229

adjusting step stitch settings 247
applying baselines 225
changing line spacing 230
Character Map 242
circle baselines 226
converting font to embroidery 241
converting text to embroidery 240
creating monograms 245, 250
creating on-screen 223
creating with the Lettering 
dialog 224

custom baselines 228
deleting stitch angles 237
editing 231
entering on-screen 223
entering via dialog 224
fancy lettering 243
horizontal baselines 225
letter justification 229
making bold 228
making italic 228
moving letters along baseline 230
multiple baselines 227
reshaping baseline 238
resizing 232
rotating with Reshape Object 235
scaling 232
scaling with Reshape Object 232
scaling with Select Object 232
selecting symbols 241
special characters 241
special characters and symbols 241
switching off underlay 234
symbols 241
transforming 234
transforming with Reshape Object 
tool 236

transforming with Select 
Object 234

vertical baselines 226
See also alphabets
See also baselines

lettering objects, transforming 234
Lettering tool 223–229, 231, 233, 
237, 241–248

lettering, splitting 130
letters
adjusting 235
adjusting individually 235
changing colors 237
reshaping 236

line spacing, adjusting lettering 230
lines, digitizing with Open Object 71
Load Picture
dialog 31
tool 106

locale, changing languages 289
locate missing files 289
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M

machine, sending multi-hooped 
designs 270

machines, stitching out designs 268
Magic Box
reading from design card 283
setup 282
writing design to Magic card 283

Magic Box About dialog 283
Magic Wand
digitizing artwork 118, 119

Magic Wand tool 118–119
Make Border dialog 260
Make Pattern dialog 184, 185
manipulating designs, using the 
Color Film 36

margins, setting for underlays 93
masking files, in folders 294
measure distance on-screen 20
menu bar
General 309
options 313

Mirror Horizontal tool 139
mirror merge
creating wreaths 141
mirroring objects 140

Mirror Vertical tool 139
mirroring
with Kaleidoscope 141

mirroring objects
around X or Y axis 140
in the Object Properties dialog 140

Mirror-Merge
Horizontal tool 140
Horizontal/Vertical tool 140
Vertical tool 140

missing files, locating 289
mixing your own thread colors 80
modes
Art Canvas 24
Embroidery Canvas 24
Hoop Layout 24
viewing 23

Modify Thread Chart dialog 79–82, 
83

modifying designs 135
modifying objects
changing entry point 144
changing exit point 144
changing radius of Circle 144
grouping 129
mirroring 139
reshaping 142
reshaping circles 144
reshaping circles to ovals 144
rotating 138
scaling 136
skewing
viewing by color 26

monitor

calibrate 54
setting up 54

Monogramming dialog
Borders 259
Lettering 250–253
Ornaments 254–257

Monogramming tool 250–253
monograms
creating 245, 250
lettering with initials 252

monograms, splitting 130
morphing effects 175
Morphing Efrfect docker 175
Morphing tool 175
moving objects
nudging 135
positioning with XY 
coordinates 135

with click and drag 135
multi-hooped designs
creating 42
outputting 269
outputting with split lines 272
printing 267
saving as 271
sending to machine 270

Multi-Hooping toolbar
Add Eight Adjacent Hoops 42
Add Four Adjacent Hoops 42
Add Hoop 42, 46, 47
Add Hoop Right 42, 47
Add Hoop Up 42, 47
Calculate Hoopings 42
Delete Hoop 42, 46, 47
Reshape Splitting Guide 42, 44
Rotate Hoop Left / Right 42
Select On 47
Selection On 42, 46
Splitting Guide 42, 44

multiple baselines
creating 227

Multiple Hoopings dialog 271, 273
multiple stitch angles
adjusting 147
setting 146
with block digitizing 73

N

names, monogram lettering 253
needle points
displaying 25
hiding 25
patterns 69

Needle Points command 25
needle position marker 29
new designs, creating 17, 293
New dialog 18, 293
New Pattern Set dialog 185
New Set dialog 260

New Stamp Set dialog 192
New Thread Chart dialog 82
New tool 18
nodes
reshaping 143

noise filtering, automatic 
digitizing 112

nominal stitch angles 146
non-outlined images 113
NORMAL template
reverting 88
using 18

nudging objects 135

O

object connectors
stitches used to move between 
objects 96

Object Not Covered dialog 270, 271
object properties
applying 84
changing defaults 85
changing for an object 85
current 84
default 84
defaults 84
managing 84
saving current 84
saving to a template 87
templates 86

Object Properties dialog 21, 84, 85
Appliqué 209, 211
Buttonhole 163
Fill Stitch 246
Fill Stitch > Blackwork 201
Fill Stitch > Candlewicking Fill 202
Fill Stitch > Contour 166
Fill Stitch > Cross Stitch 168
Fill Stitch > Fancy 167
Fill Stitch > Lacework 203
Fill Stitch > Pattern Fill 181–183, 
185

Fill Stitch > PhotoSatin 124
Fill Stitch > Ripple dialog 204
Fill Stitch > Satin 67
Fill Stitch > Step 69
Fill Stitch > Stipple Run 205
Fill Stitch >Step 247
General 136, 137, 138, 233
Lettering 224–229, 232, 233, 
241–245

Outline Stitch > Backstitch 196
Outline Stitch > Blacket 65
Outline Stitch > Blackwork 
Border 195

Outline Stitch > Pattern 
Run 180–181, 185

Outline Stitch > Satin 63–64
Outline Stitch > Single 62
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Outline Stitch > Stemstitch 197
Outline Stitch > Triple 62
Outline Stitch >Candlewicking 
Border 198

PhotoSnap 124
Stitch Angle 146

Object Properties tool 21, 62–69, 84, 
94–97, 163, 185, 209

object splitting 130
objects
aligning 136
applying underlay 91
changing colors 77
changing entry and exit points 148
changing the object properties 85
cloning 129
combining 127
copying and pasting 128
deselecting 36
digitizing for appliqué 208
duplicating 128
mirror merging 140
mirroring 139
moving 135
reshaping 142
reshaping using control points 143
rotating 138
scaling 136
selecting colors 76
skewing 138
strengthening with underlay 90
traveling by 28
See also modifying objects

offsets, Satin outline 64
offsetting
appliqué cover stitches 209
filled holes (Complex Fill) 160
patterns on-screen 184

Online Manual command 3
onscreen help, viewing 3
onscreen information 3
Open Design tool 292
Open dialog 17, 254, 277
open fills, creating 173
Open Object tool 70, 71
Open Options dialog 277
open stitching, see color blending
Open tool 17, 276, 277
open-ended shapes, digitizing 71
opening designs 17, 292
converting stitch designs 276

opening Portfolio 286
open-object appliqué, creating 213
Options command 56–58
Options dialog
Applique 56
Auto Scroll 55
Genaral 57–58
Grid 55
Hoop 39, 49–52, 56
Remove Overlaps 57

options, setting pointer display 58
ornament layouts 256
multi-ornaments 257

ornaments
creating monograms 250
with monograms 254

outline
sharpening, automatic 
digitizing 112

stitches 60
Outline Design
dialog 161
tool 161

Outline Stitch Types
Backstitch 194
Blanket 60
Candlewicking 194
Lacework 200
Satin outline 60
Single 60
Stemstitch 195
Stipple 200
Triple 60

Outline tool 60–64, 71, 179, 194
outlined images
sharpening 114
vs non-outlined 111

outlines
backstitch 196
Candlewicking Border 198
creating blanket stitch 64
displaying 25
reinforce (Blackwork Run) 157
Satin 62
selecting objects with 35
single 61
stemstitch 197
stitch types 60, 194
switching between fill and 
outline 71

Triple 61
outlines and borders
automatic 122
creating 161

oval custom hoops
creating 49

ovals, reshaping circles 144
overlap stitching
remove 158

overlapping
Backstitch 196
color blending 173

overstitching
compensating for fabric stretch 94

Overview Window 26

P

parallel ports, connection 
settings 53

Partial Applique tool 212
partial cover appliqué 212
Paste tool 128, 131
pasting
designs 301
objects 128

patches
merging/unmerging 217
placing color 216
placing fabric 215

Pattern Fill
applying 181
filling shapes with 181
layout patterns 183
modifying layouts on-screen 183
settings 182

pattern runs
creating 179, 184
reshaping 145
scaling 180

pattern sets
making 184, 185

Pattern Stamp command 178
pattern stamps
adding 178

patterns
adjusting spacing on-screen 184
Blackwork Border 195
Candlewicking Border 198
deleting 185
inserting 179
laying out on-screen (Pattern 
Fill) 183

managing 184
offsetting patterns on-screen 184
outline values 180
pre-defined 186
scaling patterns on-screen 184
selecting 179
skewing patterns on-screen 184
using objects 188

peripheral devices
connection settings 53

perspective effects
Color Blending 174
gradient fills 172

PES format, saving as 284
PES Save Options dialog 284
photographs
converting to embroidery 124

PhotoSatin stitch type 124
PhotoSnap tool 124
pictures
editing 108
loading 106

placement lines
appliqué 208
open-object appliqué 213

pointer
interpreting position 57
setting options 58
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Polygon Select tool 35
Portfolio
command 286
opening 286
viewing 286

ports
parallel 53
serial 53
USB 53

preserving, long stitches 95
presetting, object properties 84
preview designs 33
previewing
designs 263
printed design 263

primary objects, open-object 
appliqué 213

Print Catalog Options dialog 296
Print dialog 264
Print Options dialog 264–267, 296
Print Preview
dialog 263
tool 33, 263

Print Selected Designs tool 296
Print Setup dialog 296
Print tool 263
printers 53
installing 53
parallel port 53
setting up 53

printing
Artistic View option 264, 296
catalogs 296
Connectors option 265
designs 263
Hoop option 265, 296
Picture option 265, 296
production worksheets 296

problems, solving 321
production worksheets, printing 296
properties
existing properties 84
of objects 21
viewing 291

Properties dialog 33, 291–292
proportional scaling, maintain 137
publishing catalogs 297
pull compensation
applying 94

punching, designs 298

R

Read from Magic Box tool 283
reading designs
from machine 278

recoloring
lettering 237
objects 77

records, viewing 291

recovering, from software/hardware 
failure 322

Rectangle tool 70, 74
rectangles, digitizing 74
rectangular hoops
creating 48

Redo tool 21
reference points 71
refreshing display/folders/tree 
node 289

reinforce outlines (Blackwork 
Run) 157

Remove Overlaps
options 56
tool 158

Remove Stitch Angles tool 146
Rename Design dialog 302
rename folders 301
Rename Stamp Pattern dialog 186
Rename Thread Chart dialog 81
renaming
thread charts 81

resequencing
by color 131
by color using Color Film 132
by selection 131
to start or end of design 132
using Color Film 132
using cut and paste 131

Reshape Object
for rescaling lettering 232

Reshape Object tool 108, 142–148, 
229–230, 232–238

Reshape Splitting Guide tool 42, 44
reshaping
circles 144
letters 236
Pattern Run 145
selecting control points 142

reshaping objects 142
circles 144
control points 142
lettering 238

resizing, lettering 232
Revert to Factory Template dialog 88
reverting
to original NORMAL template 88

ripple fills 204
Ripple tool 200, 204
Rotate Hoop Left / Right tool 42
rotating
lettering 235
objects 138
patterns on-screen 184
See also rotating objects

rotating objects
by an exact amount 138
by click and drag 138
from the Object Properties 
dialog 138

on-screen 138

run
creating pattern runs 179

S

sample patterns, Pattern Fill 183
Satin
appliqué cover stitch 209, 265
automatic spacing 64
outline 62
splitting long stitches 67

Satin fill
automatic spacing 67
overview 66
stitch 61
stitch spacing 66

Satin outline
offsets 64
stitch 60
stitch length 63

Satin Special 67
Save As dialog 86
Save Design as Image dialog 268
Save Hoop As dialog 49–52
Save Picture tool 109
Save To Template dialog 85
Save tool 18
saving
automatic 57
bitmap images as separate 
files 109

designs 18
object properties to a template 87

Scale by 20 percent Down/Up 
tool 136

scaling
lettering 232
lettering with Reshape Object 232
pattern runs 180
patterns on-screen 184
See also scaling objects

scaling objects 136
by click and drag 137
on-screen 137
to an exact size 137
using object properties 137
using Object Properties dialog 137

Scan Picture tool 105
Scanner Setup command 54
scanning
artwork 103, 105
color mode 104
resolution 103
setting up scanners 54
sharpening 105

Screen Calibration dialog 54
scrolling, automatically 55
Sculptured Fancy tool 200, 203
searching, for threads 77
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secondary objects, open-object 
appliqué 213

security
device messages 323
errors 324

Select Border dialog 259
Select By Color dialog 26
Select Character dialog 242–245
Select Object
scaling letters with Select 
Object 232

using to transform lettering 234
Select Object tool 34–35, 129, 136, 
232, 234

Select On tool 47
Select Pattern dialog 178, 180, 181, 
185, 195, 198, 201, 202, 203, 254

Select Source dialog 54, 254
selecting
alphabets 224
and inserting Pattern Runs 179
designs 292
fill stitches 68
reshape control points 142

selecting objects
bounding box 35
by color blocks 36
cancelling a selection 36
grouping 129
resequencing as selected 132
resequencing by selection 131
selecting first and last 34
selecting multiple objects 34
selecting the next or previous 
object 34

using Color Film 36
using point and click 34
with Polygon Select 35

selecting stitches 60, 150
range of stitches 150
several stitches 150
single stitch 150
using outline 151

selection handles
rotating 138
scaling 135

Selection On tool 42, 46
selection tools
Polygon Select 35
Select Object 34

sequence
checking 130
resequencing 131
to End command 132
to End tool 132
to Start command 132
to Start tool 132
traveling 130

Sequence As Selected
tool 132

Sequence As Selected command 131

Sequence By Color
command 131
dialog 131
tool 132

sequence of hoops, printing 267
sequencing, automatic 133
serial
devices, recommended settings 53
ports, connection settings 53

setting
design view defaults 290
user preferences 290

Settings menu
Create Pattern 185
Display Setup 54
Fabric Display 31
Options 56–58
Scanner Setup 54
Thread Colors 77–81, 267

sewing, stitch out designs 268
shading effects, Color Blending 174
shading effects, gradient fills 172
shapes
block digitizing 73
digitizing 72
digitizing using block digitizing 73

shortcut keys 315
Show 1-1 tool 27
Show All tool 27
Show Appliqué Fabric tool 30, 31, 
211, 215, 216

Show Artistic View tool 25
Show Embroidery tool 24
Show Grid tool 19, 54
Show Hoop tool 19, 38, 48–52, 55
Show Individual Objects tool 36, 132
Show Pictures tool 30
Show Stitches tool 25, 280–281
Show Vectors tool 30
Single stitch 60
adjusting length 61
spacing 61

skewing objects 138
by click and drag 139
by exact angle 139
in the Object Properties dialog 139
patterns on-screen 184
with rotation handles 139

slide show
browsing designs 292
running 291
thumbnails and properties 291
viewing designs 291

sliding hoops, creating 50
sliding-hoop designs, creating 46
Slow Redraw dialog 30
Smooth Curves
command 144
dialog 144

smoothing freehand lines 155
software failure

recovering 322
Sort
dialog 295
tool 295

sorting
design lists 290
designs 294
using details lists 295
using Sort 295
using View menu 295

Space
Horizontally tool 136
Vertically tool 136

space, checking hard disk 322
spacing
adjusting lettering on-screen 229
adjusting lines 230
Candlewicking Border 198
open spacing (color blending) 173
Satin outline 63
Stemstitch 197
using automatic spacing 67
Zigzag and Double Zigzag 
stitches 93

special characters
selecting 241
selecting for lettering 241

special effects
with Elastic Lettering 247

splitting
using Satin Special 67

Splitting Guide tool 42, 44
squares, digitizing 74
stabilizing designs, with underlay 90
star fill effects 171
Start and End
dialog 98

start and end points
setting automatically 98

start, resequencing to 132
Stemstitch
outlines 197
stitch thickness 197

Stemstitch tool 195, 197
Step
applying patterns 69
stitch spacing 68

Step stitch 61
Stipple Run tool 200, 205
stippling fills 205
Stitch and Color Bar
Add Stitch Angles 146
Blanket 60
Color 76
Fill 61, 66–68, 71, 165–168, 181, 
199

Outline 60–64, 71, 179
Remove Stitch Angles 146
Satin fill 61
Satin outline 60
Single 60
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Step 61
Triple 60

Stitch and Color bar
Outline 194

Stitch and Color toolbar
Stitch Angles 237

stitch angles
adding to fill objects 146
adjusting 145
adjusting for individual letters 237
adjusting multiple angles 147
changing in circle objects 145
lettering, deleting 237
setting 146

Stitch Angles tool 237
stitch designs
conversion options 276
opening 276
processing into objects 276
stitch recognition 276

Stitch Edit command 150–152
stitch length
adjusting 61
Satin outline 63
Stemstitch 197

Stitch Options dialog 299
stitch patterns, with carving 
stamps 186

stitch recognition 276
Stitch Selected Designs tool 298
Stitch Sequence
command 133
dialog 133

stitch spacing
Blanket stitch 65
Candlewicking Border 198
Satin outline 63
Stemstitch 197

stitch thickness
Backstitch 196

stitch types
fill 68
fills 68
outline 60, 194
Pattern Run 181
PhotoSatin 124
Satin 62
Satin fill 66
Satin outline 62
Single 61
Triple 61

stitch types, cross stitch 168
stitch values
Auto Spacing (Satin) 64
automatic spacing (Satin fill) 67
cover applique 209, 265
stitch type 60, 68, 194

stitches
adjusting Auto Jump length 95
appliqué cover stitches 209, 265
changing 60

digitizing run stitches 71
displaying 25
Edge Walk length 92
editing 10, 151
generating 17
selecting 60, 150
stitch types 60, 68, 194
traveling by 29
Zigzag and Double Zigzag 
length 93

See also inserting stitches
See also selecting stitches

stitching
designs 268
removing overlaps 158
selecting machine and options 298
sequence checking 130

stitchouts, simulation 29
straight lines
making 71

strengthening design with 
underlay 90

styles, monogram lettering 252
styles, see templates
switching between fill and outline 71
symbols
Character Map 242
selecting 241
selecting for lettering 241

system preferences
automatic backup 57
automatic save 57

T

Tab delimited files, exporting 
catalogs 298

tackdown, appliqué 208
tackdown, open-object appliqué 213
templates
AMT 86
creating 86
custom templates 293
deleting 88
managing 86
modifying 87
overview 86
reverting to original 88
saving object properties 87
using 18
See also styles

text, adjusting line spacing 230
text, converting to embroidery 240
Textured Edge tool 169
thread charts
adding colors 83
copying colors 82
creating your own 81
deleting 81
modifying 79

modifying thread values 79
printing 267
removing thread colors 80
renaming 81

thread colors
adding to thread charts 83
copying across thread charts 82
matching 77
mixing your own 80
modifying thread values 79
removing from thread charts 80

Thread Colors command 77–81, 267
threads
finding 77
searching for 77

tie-ins as connectors 97
toolbars
hiding 21
showing 21
using 21

tools
on Arrange toolbar 311
on Digitize toolbar 310
on Edit toolbar 309
on General toolbar 309
selecting commands 20

Touch Up Picture tool 108
transform
buttonhole objects 163
lettering objects 234

transforming objects
letters on screen 236

Travel on Edges effect 173
travel runs 96
traveling
by 1 stitch 29
by 10 stitches 29
by color 28
by stitches 29
overview 130
to end of design 28
to start of design 28

tree node, refresh 289
Triple Outline
adjusting length 61

Triple stitch 60
spacing 61

troubleshooting 321
delete recovery 323
design dimensions 324
exception access violations 325
general problems 324
hardware failure 322
inconsistent output results 324
invalid product 324
missing toolbar buttons 324
reverting to factory settings 321
security device messages 323
software failure 322

TWAIN scanners 54
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U

underlay
Double Zigzag 93
Edge Walk 92
Edge Walk margins 93
margins 93
setting automatic underlay 
margins 93

setting margins 93
Step margins 93
switching off for small lettering 234
using to strengthen design 90
Zigzag and Double Zigzag 93
Zigzag margins 93

Undo tool 21
Ungroup tool 129, 174
ungrouping objects 129
unrecoverable errors 323
USB
embroidery machine connection 53

USB ports
connection settings 53

User Preferences
command 290
dialog 290
setting 290

V

validating folders 289
values
pull compensation 94
selecting stitch types 60, 68, 194

vector drawings
automatic digitizing 102
supported file formats 102

vector graphics, digitizing 116
vectors, converting to 
embroidery 117

vertical baselines
creating 226

View
By Color command 26

View menu
By Color 26
Change Locale 289
Customize Columns 290
Needle Points 25
User Preferences 290

View Mode toolbar
Art Canvas 24, 105–109, 113–114, 
118–124

Embroidery Canvas 24, 113–114, 
118–124

Hoop Layout 24, 40
Show Embroidery 24

viewing
design properties 291
information online 2

objects by color 26
options, see user preferences
slide show 292

viewing designs
needle points 25
outlines and stitches 25
zooming 6

W

wave effect 170
website, link to 4
Windows Explorer
viewing design information 32

WinZip tool 299
Wreath tool 141
wreaths
kaleidoscope effect 141
objects as wreaths 141

Write to Embroidery System 
dialog 269, 278, 280, 281

Write to Machine tool 268–270, 
280–281

Write to Magic Box tool 283
writing designs
to design cards 280

X

X and Y coordinates
setting for objects 135

Z

Zigzag underlay, settings 93
Zip archive dialog 300
zipped designs
extracting 300
viewing in folders 288

Zoom Box tool 27
Zoom Factor dialog 27
zooming in and out 6
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