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BERNINA® EMBROIDERY
SOFTWARE RELEASE NOTES

BERNINA® Embroidery Software represents a departure from previous 
versions in providing seamless integration with CorelDRAW® Essentials 4 by 
the Corel Corporation, the most popular vector-based drawing package for 
home users. For this reason, the latest release offers a more efficient, 
user-friendly approach to embroidery design by combining the embroidery 
capabilities of BERNINA Embroidery Software with graphical capabilities of 
CorelDRAW®.

Note  These Release Notes give detailed descriptions of new and improved 
features in BERNINA Embroidery Software V6.0 and provide direct links to 
relevant sections of the Onscreen Manual. Additional information may be 
included in the Release Notes that was not available when the manual was 
sent to production.

Contents of BERNINA Embroidery Software V6.0

The BERNINA Embroidery Software V6.0 kits include some or all of the 
following components:

BERNINA® Embroidery Software Installation DVD

USB dongle with tag attached

BERNINA® Embroidery Software Quick Start Guide

Note  The BERNINA Embroidery Software installation DVD includes software 
for all products, including BERNINA DesignerPlus, BERNINA EditorPlus, 
BERNINA Portfolio, BERNINA Cross Stitch and Quilter. 

Product levels

There are now two BERNINA Embroidery Software product levels:

BERNINA EditorPlus

BERNINA DesignerPlus
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Tip  BERNINA Embroidery Software users can now purchase software 
upgrades directly from the Internet. See the Onscreen Quick Start Guide for 
details.

System requirements

You need to ensure that the following pre-requisite system requirements are 
met in order to run the BERNINA® Embroidery Software application.

PC specifications
Check that your PC meets the system requirements. Check CPU/RAM as well 
as hard disk space. The table below provides minimum system 
requirements.

Item Minimum Requirements

CPU Single Core 1GHz or greater proces-
sor

Operating 
System

Windows XP® SP2 (Home or Pro-
fessional)

Internet Con-
nection

Optional: Internet connection for 
access to regular product informa-
tion

Internet 
Browser

Internet Explorer 6.x

System Mem-
ory

1GB for running multiple applica-
tions

Hard Disk Size 30GB available before installation

Free Disk 
Space

2GB or more than 10% of the Hard 
Drive Size, whichever is greater

Data Drives DVD-ROM drive for software instal-
lation

Graphics Card Support for High Color (16 bit) and 
high resolution (1024 x 768)

Monitor 15” or larger for on-screen digitizing

USB Ports Dedicated USB port for security 
device. Additional USB ports for 
Bernina Reader/Writer Box or direct 
machine connection.
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Security device
BERNINA Embroidery Software is controlled by a 
security device or ‘dongle’ attached to the 
computer, in conjunction with security access 
codes entered into the software. Each dongle has 
a unique serial number and identity code so your 
system can be uniquely recognized.

Caution  Do not attach your dongle until 
requested on screen by the software installation. 
Otherwise the generic USB drivers will be used 
and will prevent the correct working of the security system.

All purchases of the latest software release, whether new or updates, are 
shipped with a USB type dongle. Whenever you update your software, you 
need to carry out a ‘brain transplant’ from your previous dongle to the latest 
one. Parallel port dongles are no longer provided or supported by the brain 
transplant. See Installation Notes in the Quick Start Guide for details.

Caution  If the dongle is removed or loses connection while you are working 
in BERNINA Embroidery Software, error messages will display. Cancel the 
messages, then exit BERNINA Embroidery Software. You will lose any 
unsaved changes to your design. Re-attach the dongle to your computer, 
making sure that it is firmly secured, then restart BERNINA Embroidery 
Software.

Serial Ports Additional serial port for artista 
Reader/Writer Serial Box connection 
(optional)

Scanner MS Windows® XP compatible

Printer MS Windows® XP compatible

Mouse MS Windows® XP compatible

Sound cards Not required

Item Minimum Requirements

USB Port Dongle
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BERNINA Embroidery Software interface

BERNINA® Embroidery Software has a new desktop icon as shown above. 
The BERNINA Embroidery Software interface (GUI) has been updated to 
bring it into line with the latest MS Windows® developments. It contains 
new-look icons, new-look ‘docker’ dialogs, as well as new toolbars for 
improved efficiency and ease-of-use. The aim is to minimize confusion while 
preserving easy-access for experienced users to the rich feature set. The 
main elements of the re-design are:

Updated icons and color scheme

Use of ‘dockers’

Removal of Artistic View

Integration with CorelDRAW® Essentials 4

BERNINA Embroidery Software integrates BERNINA Embroidery Software 
and CorelDRAW® Essentials 4 into a single application, allowing users to 
create, not just embroidery, but true, multi-medium designs. The 
application has one workspace or ‘design window’ but you interact with it in 
separate modes: Art Canvas and Embroidery Canvas. A third mode is 
available for multi-hooping large designs. See also Vector conversion 
capabilities.

Art Canvas: This mode allows you to create and edit vector objects 
using the CorelDRAW® Essentials 4 toolset.

Embroidery Canvas: This mode allows you to create and edit 
embroidery objects using the embroidery digitizing toolset.

Hoop Layout: This mode allows you to set up the position and sequence 
of each hoop used in a design.

Note  Artistic View mode is no longer available. This functionality is now 
available in the Embroidery Canvas mode via the Show Artistic View 
icon on the General toolbar or ‘T’ shortcut key.

Double-click to start BERNINA® Embroidery Software.
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Embroidery Canvas

Below is a screen image of the Embroidery Canvas workspace. This shows 
an exploded view of all toolbars in the BERNINA DesignerPlus product. The 
workspace has been minimized for the purposes of clearer readability here. 
Depending on your product level, you will have access to some or all of these 
options.

Note  BERNINA Embroidery Software has a ‘multiple document interface’ 
(MDI), meaning that it allows more than one design to be opened at a time. 
If multiple documents are open, the current design mode – Art Canvas or 
Embroidery Canvas – is maintained when switching between designs.

Art Canvas

Below is a screen image of the Art Canvas workspace. This replaces the old 
‘Picture Mode’ and includes the entire suite of CorelDRAW® Essentials 4 

Menu bar
General toolbar

Title bar

Stitch and
Color bar

Edit toolbar

Digitize toolbar

Arrange toolbar

Craft Stitch
toolbar

Status bar

View toolbar

Docker panel



BERNINA Embroidery Software interface

BERNINA® Embroidery Software : Release Notes 7

drawing tools which offer many sophisticated techniques for drafting 
outlines and shapes on screen.

In addition to the CorelDRAW® Essentials 4 toolset, Art Canvas provides 
capabilities to convert vectors and vector text directly to embroidery 
objects. Vector graphics or text created or imported into the Art Canvas 
can be converted directly to embroidery designs. You can use Art Canvas 
to insert or paste third-party vector graphics such as clipart for use in 
embroidery designs. Alternatively, insert, paste or scan bitmap artwork for 
use as digitizing templates or ‘backdrops’.

Note  For a full description of the CorelDRAW® Essentials 4 tools, refer to 
the electronic User Guide available via the Windows Start > Programs 
group. Alternatively, use the onscreen help available from the Graphics 
mode Help menu.

Hoop Layout

Below is a screen image of the Hoop Layout workspace, previously known 
as Multi-Hooping View. If your embroidery is too large or contains a 
number of designs spaced around an article, you can split it into multiple 
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hoopings. Hoop Layout allows you to set up the position and sequence of 
each hoop. See Multi-hooping improvements for details.

Application menus
A number of changes have been made to the menu structure in BERNINA 
Embroidery Software. Menu display varies with the selected view mode – 
Art Canvas, Embroidery Canvas, or Hoop Layout.

The changes outlined below pertain to Embroidery Canvas mode. For a 
description of the CorelDRAW® Essentials 4 menus, refer to the electronic 
User Guide available via the Windows Start > Programs group or onscreen 
help available from the Graphics mode Help menu.

Embroidery Canvas menu bar

Art Canvas menu bar
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Edit menu changes

Depending on the selected view mode, a revised Edit menu contains some 
or all of the following commands:

Note these changes:

Command Function

Smooth 
Curves

New command which lets you apply curve ‘smoothing’ to embroidery 
objects. Selecting it opens the Smooth Curves dialog. See Curve 
smoothing for details.

Delete Changed from ‘Del’.

Touch Up Pic-
ture

The Touch Up Picture menu item, previously only enabled in Picture 
View, is now enabled in Embroidery Canvas when a bitmap is 
selected. (Cannot be applied to vector objects.)

Crop Image The Crop Image menu item, previously only enabled in Picture View, 
is now enabled in Embroidery Canvas when a bitmap image is 
selected. (Cannot be applied to vector objects).
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View menu changes

Depending on the selected view mode, a revised View menu contains some 
or all of the following commands:

Note these changes:

Command Function

Show All Shortcut 0 (zero) added.

Center Current 
Stitch

New menu item – shortcuts C and F6 already available.

Previous View New menu item – shortcuts V and F5 already available. 

Zoom Out 2X Shortcut Shift+Z added.

Zoom In 2X New menu item and shortcut Z.

Zoom Changed from Zoom Box and shortcut F8 added.

Zoom Factor New menu item – shortcuts F and F3 already available.
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Arrange menu changes

A revised Arrange menu contains the following commands:

Note these changes:

Application toolbars
A number of changes have been made to the toolbars in BERNINA 
Embroidery Software. Toolbar display varies with the selected view mode – 
Art Canvas, Embroidery Canvas, or Hoop Layout.

Command Function

Lock / Unlock 
All

New menu items and shortcut keys.

Close Object Use to close any open object with the option of using straight or 
curved points. See Digitizing open shapes in the Onscreen Manual 
for details.
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View Mode toolbar

The View Mode toolbar now contains the following buttons:

By default, the toolbar is docked immediately beneath the menu bar.

Note  Artistic View mode is no longer available. This functionality is now 
available in the Embroidery Canvas mode via the Show Artistic View 
icon on the General toolbar or ‘T’ shortcut key.

General toolbar

A revised General toolbar contains the following commands:

Note these changes:

Button Function

Changed from ‘Picture View’.

Changed from ‘Design View’.

Changed from ‘Multi Hooping View’.

In Art Canvas mode, the toolbar includes an additional Show 
Embroidery button.

Tool Function

Show Pictures Tool name updated from ‘Show Picture’.

Dim Artwork Moved from Picture Toolbar in Picture View and updated from ‘Dim 
Picture’. Can be applied to both bitmaps and vectors. See Viewing 
backdrops in the Onscreen Manual for details.

Show Vectors New tool with shortcut to toggle on/off display of vector graphics.

Show Artistic 
View

New tool replacing the old Artistic View mode.

Carving Stamp New tool. See New ‘carving stamps’ for details.
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Arrange toolbar

A revised Arrange toolbar contains the following commands:

Note these changes:

Digitize toolbar

A revised Digitize toolbar contains the following icons:

This toolbar is only available in the Embroidery Canvas. Note these 
changes:

Morphing 
Effect

New tool. See Morphing effects for details.

Tool Function

Group and 
Ungroup

Tooltips include keyboard shortcuts.

Lock and 
Unlock All

New tools allowing you to lock objects into position as required.

Tool Function

Auto Digitizer Name changed from ‘AutoDigitizer’. See Auto digitizing improve-
ments for details.

Magic Wand Improved functionality:
• Clicking an area of an image will stitch the area immediately 

rather than selecting the area and pressing Enter.
• Left-clicking will stitch the area with the current fill stitch type.
• Right-clicking will stitch it with the current outline stitch type.
The prompt message is updated to reflect the changed functional-
ity. See Auto digitizing improvements for details.

PhotoSnap Moved from Picture View > Picture toolbar. 

Free Hand 
Embroidery - 
Open Object

New tool. See Freehand embroidery for details.

Tool Function
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Edit toolbar

A revised Edit toolbar contains the following icons:

This toolbar is only available in the Embroidery Canvas. Note these 
changes:

Free Hand 
Embroidery - 
Closed Object

New tool. See Freehand embroidery for details.

Lettering / Fill 
Values

Moved from Edit toolbar.

Monogramming Moved from Edit toolbar.

Outline Design New tool. See Automatic outlines and borders with Outline Design 
for details.

Cross Stitch Moved from Edit toolbar.

Quilter Moved from Edit toolbar.

Tool Function

Select Object Shortcut O added in tooltip.

Reshape Object Shortcut H added in tooltip.

Rotate 45° CCW / CW Changed from ‘Rotate 45 deg CCW / CW’.

Double Run Shortcut Ctrl+B added in tooltip.

Add Holes Moved from Digitize toolbar.

Fill Holes Moved from Digitize Toolbar.

Artwork Preparation Access new Image Preparation dialog which replaces the Art-
work Preparation dialogs previously accessed via the Artwork 
Preparation tool and Outlined Artwork Preparation tool in Pic-
ture View. See Image Preparation dialog for details.

Convert Selected 
Embroidery to Art 
Vectors

New tool. See Vector conversion capabilities for details.

Tool Function
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Craft Stitch toolbar

A revised Craft Stitch toolbar contains the following icons:

This toolbar is only available in the Embroidery Canvas. Note these 
changes:

Stitch and Color Bar

A revised Stitch and Color Bar toolbar contains the following icons:

This toolbar is only available in Embroidery Canvas mode. Note these 
changes:

Tool Function

Stipple Run Changed icon and tooltip. Selecting will cause the Stipple Run fill 
stitch type to be selected / applied. See Improved Stipple fill for 
details.

Ripple New tool. See New Ripple fill for details.

Tool Function

Add Stitch 
Angles / Val-
ues

Changed from Stitch Angles / Values. See Turning stitch angles for 
details.

Remove Stitch 
Angles

New tool. See Turning stitch angles for details.

Star Fill New tools. Left-clicking these icons toggles on/off the associated 
effect. Right-clicking causes Effects > Star & Wave Fill dialog to dis-
play. See Star Fill effects for details.

Wave Fill
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Docking panes in Embroidery Canvas
BERNINA Embroidery Software includes new ‘dockers’ for key functions. 
Embroidery Canvas has four docking panes for Color Film, Carving 
Stamps, Morphing Effects, and Overview Window. All panes are 
dockable at the right side of the design window.

Dockers can be ‘nested’ to increase available workspace. When nested, tab 
buttons for each dialog are to the right of the docking panes. All dockers can 
be fixed or minimized. By hovering the mouse over the tab, a minimized 
docker will ‘fly out’, allowing you to access its functions. It automatically 
minimizes when not in use. Dockers may also be ‘floated’ by dragging the 
caption bar to the design window or double-clicking it when ‘pinned’ in 
place.

Color Film docker

The Color Film dialog is now implemented as a docker. Color Sequence 
mode displays the color blocks and number of colors and sequence used in 
the design. In addition it displays the groups of objects to the right of the 

Fill Type list New stitch types: Ripple, Contour, Stipple Run, Stipple Stemstitch, 
and Stipple Backstitch. See New stitch types for details.

Tool Function

Nested dockers

Floating docker

Pin docker in place 
as required
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color blocks. To enlarge thumbnail images of color blocks or objects, click 
and drag the edge of the dialog.

The Color Film right-click popup menu can be invoked in both Color 
Sequence and Object modes. Note that it includes new menu items: Lock, 
Unlock, Unlock All, Hide, Hide Others, Unhide and Unhide All.

Application dialogs
BERNINA Embroidery Software includes revised dialogs.

Object Properties > Fill Stitch tab

The Object Properties > Fill Stitch dialog includes a variety of exciting 
new decorative stitch types. All are accessible from the fill stitch list on the 
Stitch and Color Bar. Some are also available from the Craft Stitch 

Toggle Color 
Sequence and 
Object modes 
on/off

Drag edge to
enlarge

thumbnails
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toolbar. New fill stitch types include: Ripple, Contour, Stipple Run, Stipple 
Stemstitch, Stipple Backstitch. See New stitch types for details.

Object Properties > General tab

The Object Properties > General tab includes a new checkbox which 
enables proportional scaling. See Scaling objects using object properties in 
the Onscreen Manual for details.

Options > Auto Scroll tab

A new Auto Scroll feature has been added to the Options dialog. Use Auto 
Scroll to scroll the design automatically while you are digitizing. This can be 
more convenient than using panning or the scroll bars. To temporarily 

New stitch 
types

Enable
proportional

scaling
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disable the Auto Scroll function, hold down the Alt key. See Setting auto 
scroll options in the Onscreen Manual for details.

Effects dialog

A new Star & Wave Fill tab has been added to the Effects dialog. New 
Star Fill is enabled via a checkbox. The Wave Effect checkbox has been 
renamed Wave Fill and moved from the Others tab. See also New stitch 
effects.

Image Preparation dialog

The Artwork Preparation dialogs, previously accessed via the Artwork 
Preparation tool and Outlined Artwork Preparation tool in Picture 
View, have been combined into a single Image Preparation dialog which 
is accessed via the Magic Wand tool or Auto Digitizer tool. There is also 
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an Artwork preparation button on the Edit toolbar which accesses the new 
Artwork Preparation tool. See Auto digitizing improvements for details.

Color Wheel dialog

The new Color Wheel function allows you to change colors in an entire 
design and match them automatically to colors in the chart (if sufficiently 
defined). If BERNINA Embroidery Software cannot find a useful match, it 
adds colors to the palette instead. You then need to manually match them 
to threads (or use Match & Assign All). The main purpose of the tool is to 
create a new ‘colorway’ quickly and easily in order to ‘spice up’ old designs 
or place them on a different fabric. See Changing entire design colors in the 
Onscreen Manual for details.

Adjust overall
design colors
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Monogramming dialog

Monogramming controls have improved. You can now enter a rotation 
angle for letters as a group, for individual letters, or the entire baseline. See 
Creating monogram lettering in the Onscreen Manual for details.

Slow Redraw dialog

Slow Redraw now allows you to select the range of stitches to redraw. See 
Simulating design stitchouts in the Onscreen Manual for details.

Enter rotation
angle for lettering

Specify range of 
stitches to redraw
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Print Options dialog

A new Hooping Sequence option has been added to the Print Options 
dialog. This allows you to print a Color Film type printout showing the 
objects in each hooping. See Multi-hooping improvements for details.

Vector conversion capabilities

Through its integration with CorelDRAW® Essentials 4, BERNINA 
Embroidery Software now provides powerful inter-conversion of vector and 
embroidery objects. New conversion tools automatically convert vector 
objects and text to embroidery or lettering objects. In fact, entire vector 
drawings can be quickly and easily converted to embroidery designs. When 
creating embroidery objects, the software determines optimum object and 
stitch type for given shapes. These can be modified as required. You can also 
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convert embroidery designs or objects to vector objects. See Converting 
vectors to embroidery in the Onscreen Manual for details.

Caution  Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart – 
does not remove copyright protection.

Conversion tools

The conversion feature provides three tools:

Convert Vectors to Embroidery: See Converting vectors to embroidery in 
the Onscreen Manual for details.

Convert Vector Text to Embroidery: See Converting text to embroidery 
in the Onscreen Manual for details.

Convert Selected Embroidery to Art Vectors: See Converting embroidery 
to vectors in the Onscreen Manual for details.

The Convert Vectors to Embroidery and Convert Text to Embroidery 
tools are accessed via buttons on the Art Toolbox in Art Canvas. The 
Convert Selected Embroidery to Art Vectors tool is accessed via the 
Edit toolbar in Embroidery Canvas.

Working with bitmaps

Bitmap artwork can be inserted via the File > Import as well as File > 
Acquire Image functions in Art Canvas. These commands replace the 
Load Picture and Scan Picture tools previously located on the Picture 
toolbar in Picture View. Bitmaps cannot be converted to embroidery via 
the Convert to Embroidery tool as these still need to be processed prior 

Convert to 
embroidery tools

Convert to vectors tool
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to conversion. The Artwork Preparation tools have been moved to the 
Embroidery Canvas and combined with Auto Digitizer and Magic Wand 
tools. See also Auto digitizing improvements.

Auto digitizing improvements

As in previous releases, Auto Digitizer and Magic Wand only work on 
bitmap images. The artwork preparation tools have moved from the old 
Picture mode (now Art Canvas) and are incorporated into the Auto 
Digitizer and Magic Wand tools. There are two types of automatic 
outlining in BERNINA Embroidery Software:

Outline Design: initiated from the Outline Design button on the 
Digitize toolbar.

Automatic Image Outline: accessed via the Automatic Digitizing 
dialog when converting bitmaps to embroidery.

These features are complementary and can be used singly or together on 
designs based on bitmap artwork. Outline Design works equally well on 
existing embroidery objects as a standalone tool.

Image preparation improvements

Use Edit > Artwork Preparation to prepare bitmap artwork for automatic dig-
itizing.
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The new Image Preparation dialog has a panel containing two options for 
image preparation: Reduce Colors and Outline Appearance. The 
controls for these are the same as those of the old Artwork Preparation 
and Outlined Artwork Preparation dialogs. An Image Properties panel 
located above the image preview contains width and height measurements. 
See Processing Images for Automatic Digitizing in the Onscreen Manual for 
details.

Note  Bitmaps can now be selected and scaled in Embroidery Canvas. 
Scaling and transforming of bitmaps can also be performed in Art Canvas.

Magic Wand improvements

Magic Wand has been improved. When an image has been processed, you 
initiate automatic digitizing by clicking the image. However, whereas you 
previously had to press Enter after clicking an area, now stitches are 
generated immediately – left-click generates fill stitches, right generates 
outline stitches. See Digitizing with Magic Wand in the Onscreen Manual for 
details.

Automatic outlines and borders with Auto Digitizer

The Auto Digitizer tool now allows you to automatically generate outlines 
during image conversion. These may be in the form of outlines around 

Use Digitize > Magic Wand to digitize filled or outlined shapes in your art-
work.

Use Digitize > Auto Digitizer to create automatic outlines and borders from 
imported bitmap images.
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objects and/or a border around the design itself. Automatic outlining can 
also provide open-filled backgrounds for stitching on difficult fabrics or 
simulating shadows, etc. You can select outline colors to use when 
converting the image. However, colors and object details of generated 
objects can be changed at any time. See Creating automatic outlines and 
borders in the Onscreen Manual for details.

Tip  You may, if you wish, omit all image colors from the selection criteria 
and generate only outlines and/or borders.

Automatic outlines and borders with Outline Design

Use Digitize > Outline Design to stitch around groups of objects with Single, 
Triple or Satin Line.

Outlines added Borders added

All image colors omitted All image colors omitted, 
borders added



New stitch types

BERNINA® Embroidery Software : Release Notes 27

Outline Design allows you to quickly create outline stitching around 
selected objects or entire designs with Single, Triple or Satin Line. See 
Creating outlines and borders in the Onscreen Manual for details.

New stitch types

BERNINA Embroidery Software includes a variety of exciting new decorative 
stitch types. All are accessible from the fill stitch list on the Stitch and 
Color Bar. Some are available from the Craft Stitch toolbar.

New fill stitch types include:
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Contour

Ripple

Stipple Run

Stipple Stemstitch

Stipple Backstitch

They are also available from the Object Properties > Fill Stitch tab. See 
Object Properties > Fill Stitch tab for details.

Some are closely related but have different names to make it easier to 
identify the objects they can be applied to. The newly added stitch types and 
effects can be applied to the following objects:

Closed objects with turning stitch angles

Closed objects with a single stitch angle

Rectangle objects with a single stitch angle

Circle/oval objects with a single stitch angle

Block digitizing objects.

New Contour fill

Contour stitch provides back and forth stitching with a fixed number of lines 
with variable spacing depending on the object outline. Contour stitch can 
only be applied to block digitizing objects, including Circle objects.

Contour stitch is accessed from the stitch list in the Stitch and Color Bar 
and the Fill Stitch object properties tab. See Creating contour fills in the 
Onscreen Manual for details.

New Ripple fill

Use Craft Stitch > Ripple to create spiral stitching from the center of any filled 
object.
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New Ripple stitch is related to Contour stitch, providing a similar look (with 
a fixed number of lines and variable spacing) but spiralling out from the 
center of a filled object. This stitch type works best for ‘blobby’ shapes but 
can be applied to longer shapes. 

Tip  Some interesting visual effects can be achieved by reshaping and 
moving the centre of the Ripple stitch outside the object outline.

Ripple stitch can be applied to any filled object and is accessed from the 
stitch list in the Stitch and Color Bar and the Fill Stitch object properties 
tab as well as from the Craft Stitch toolbar. The center of the Ripple stitch 
can be moved with the Reshape Object tool. See Creating ripple fills in the 
Onscreen Manual for details.

New Sculpture fill

New Sculpture stitch is related to Fancy Fill stitch using needle 
penetrations form a tiled pattern. The difference is that Sculpture stitch 

Use Craft Stitch > Sculpture to create turning tiled patterns using pre-defined 
needle penetrations.
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can be applied to objects with turning stitches creating three dimensional 
effects which can’t be achieved by Fancy Fill alone. See Creating 
Sculptured Fancy fills in the Onscreen Manual for details.

Improved Stipple fill

Stipple stitch has been improved in BERNINA Embroidery Software. It is 
now a stitch type with the same functionality as all other selectable stitch 
types. You can now reshape and scale stipple fill object outlines while 
preserving settings. There are now three stipple fill stitch types: Stipple 
Run, Stipple Backstitch, and Stipple Stemstitch. See Creating stippling 
fills in the Onscreen Manual for details.

The Stipple button on the Craft Stitch toolbar has been replaced by the 
Stipple Run button. Selecting this will also cause Stipple Run to be 
selected as the current fill stitch type.

Use Craft Stitch > Stipple Run to create a fill made of run stitches which 
meander around within a border.

Stipple BackstitchStipple StemstitchStipple Run

Stipple Run
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Stipple stitch types can be applied to the same objects as Pattern Fill – i.e. 
closed objects with a single stitch angle – not lettering, auto appliqué or 
composite objects. 

Tip  The Break Apart command can be applied to stipple fill objects. As a 
result, you can edit the stipple run line directly. Apply Pattern Run, Satin 
and other outline stitch types as desired. See also Splitting into component 
objects in the Onscreen Manual.

New Cross Stitch fill

The new Cross Stitch fill is a stitch type in its own right but does not replace 
the BERNINA Cross Stitch application available from the Digitize toolbar. It 
is something like Pattern Fill but it is generated differently and uses travel 
runs under and along the cross stitching. Crosses are horizontal to suit a 
global or standard grid for the whole design. See Creating cross stitch fills 
for details.

Tip  The cross stitch grid is not displayed but you can set the background 
grid to the cross size to get a better idea of how the grid is used to generate 
the crosses. Use Snap to Grid to ensure that your object outlines line up 
with the cross stitch grid.
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New stitch effects

BERNINA Embroidery Software includes a variety of exciting new decorative 
stitch effects which can be applied to several stitch types.

Star Fill effects

Star Fill generates radial turning stitching in several stitch types such as 
Satin and Tatami stitch. Stitches are generated from the outside edge to 
the geometric center. Star Fill is applicable to several object shapes – 
closed, circle and rectangle – with optional holes. The effect may be on or 

Use Stitch & Color > Star Fill to generate radial turning stitching in several 
stitch types such as Satin and Tatami stitch.
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off while digitizing. See Creating star fill effects in the Onscreen Manual for 
details.

Tip  Keep the following points in mind when using Star Fill effect:

Use a sharp needle – i.e. one that doesn’t have a ball end such as you 
would use on woollen knits.

For best effect, use with ring type shapes to avoid small areas in the 
center of the object which could cause problems. The size of the ring 
should be about 20% of the outer diameter.

Use larger stitch spacing – increase by about 20%.

Only use Edge Walk underlay with small objects, to help reduce the 
number of stitches at the object center.

Tip  Unlike Ripple stitch, the center of Star Fill effect can be moved outside 
the shape or into an included hole to achieve a different effect, without 
loosing the original object shape.

Object includes a circular hole which 
can be resized/reshaped and moved 
as needed
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Morphing effects

The new Morphing feature allows you to transform object outlines and 
stitches in a variety of novel and interesting ways. They are additive in the 
sense that more than one effect can be applied to a given selection.

The feature is accessed by means of the new Morphing icon on the 
General toolbar. This toggles on and off the Morphing Effect docker. See 
Creating morphing effects in the Onscreen Manual for details.

Use General > Morphing to create transformed object outlines and stitches.

Punch

Twirl

Skew Vertical

Wave Vertical

Pinch

Ripple

Skew Horizontal

Wave Horizontal
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Tip  Morphing is a powerful feature but don’t overdo it. Keep in mind the 
following points when morphing objects/designs:

To avoid poor quality embroidery, don’t use too much of the effect. Less 
is more when it comes to morphing.

Use larger stitch spacing – increase it by about 20%.

Avoid morphing Satin stitches – in some objects they become too long.

Increase the underlay margin to avoid it projecting outside the cover 
stitch.

Freehand embroidery

The new Freehand Draw Embroidery feature provides functionality 
similar to CorelDRAW® Freehand and Polyline tools. Freehand Draw 
Embroidery has many benefits. It lets you easily and fluidly create designs 
with a hand-drawn appearance, something which is difficult to achieve 
through conventional digitizing methods. See Creating freehand embroidery 
in the Onscreen Manual for details.

The aim is to mimic designs formed on an embroidery machine by freehand 
motion with the fabric secured in an embroidery hoop, allowing the needle 
to ‘draw’ on the fabric surface. Other techniques include stitching on top of 
photographic images or detailed line drawings. For example, use the tools 

Use Digitize > Freehand Draw Embroidery - Open Object to draw embroidery out-
lines directly on screen and view a stitch simulation as they are drawn.

Use Digitize > Freehand Draw Embroidery - Closed Object to draw freehand filled 
embroidery objects on screen.
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to manually trace a color photo-stitch design. This technique requires 
accuracy and control of corners, similar to the CorelDRAW® Polyline tool.

Alternatively, designs resembling pencil or charcoal sketches can be quickly 
digitized. Use the tools to create ‘doodle’ type drawing effects without 
following detailed artwork – for example, adding to a basic clipart design or 
decorative text and so on.

New ‘carving stamps’

The new Carving Stamp feature allows you to define a pattern of needle 
penetrations using a ‘carving stamp’ as a template. A carving stamp can be 

Use General > Carving Stamp to define a pattern of needle penetrations using 
a ‘carving stamp’ as a template.
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any vector and/or embroidery shape or shapes. A needle penetration is 
placed wherever a stitch intersects with the vector or embroidery shape.

With the Carving Stamp feature, you can:

Create and manage your own user-defined carving stamps in a pattern 
library for future reference.

Apply pre-defined or temporarily-selected or -digitized carving stamps to 
applicable objects.

Move/rotate/scale/reshape/delete carving stamps associated with an 
applicable object while in Reshape mode.

Selected carving stamps can be applied to any of the following objects:

Outline objects with Satin stitch type

Closed objects with Satin/Step/Fancy stitch type

Rectangle objects with Satin/Step/Fancy stitch type

Block objects with Satin/Step/Fancy stitch type

Circle/oval objects with Satin/Step/Fancy stitch type

Lettering and composite objects.
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Carving Stamp docker
The Carving Stamp docker contains four tabs: Use Pattern, Use Object, 
Digitize, and Appearance. See Creating stitch patterns with carving 
stamps in the Onscreen Manual for details.

The Use Pattern tab lets you select and apply pre-defined stamp patterns 
to selected applicable objects only or any applicable objects if nothing is 
selected. The Use Object tab allows you to select object outlines from the 
design window as a temporary stamp and apply to applicable objects. 
Selectable objects can include vectors from Art Canvas. This is the only 
time vectors can be selected in the Embroidery Canvas. See Applying 
pre-defined patterns in the Onscreen Manual for details.

The Digitize tab allows you to digitize stamp outlines and either directly 
apply the digitized stamp where it was digitized, or apply it to applicable 
objects in the design window. The Softened Stamp and Raised Stamp 
checkboxes and Clear All Stamps button in the Appearance tab are 

Use Pattern tab Use Object tab
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enabled when one or more objects with stamps are selected. See Digitizing 
carving stamps in the Onscreen Manual for details.

Advanced appliqué improvements

Advanced appliqué has been improved to make it easier to create closed 
areas. Previously, when using outline stitches to create an area to be used 
for appliqué, you had to ensure that the centers of the outline overlapped.

Now you only need to have part of the cover stitches overlap in order to 
create a valid closed area.

The Appliqué Properties dialog has undergone some minor changes. The 
caption in the title bar has changed from Applique Properties to Appliqué 
Properties. The caption in the Remove Applique panel has similarly 

Center lines 
overlap

Center lines do 
not overlap

Cover stitch is created
whether or not center

lines overlap
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changed to Remove Appliqué. See Creating open-object appliqué in the 
Onscreen Manual for details.

While it is not implemented as a docking pane, instead of being docked at 
the left of the design window, the Appliqué Properties dialog docks by 
default to the right. If any of the dockers are open (nested or otherwise), 
BERNINA Embroidery Software will temporarily hide them while Appliqué 
Properties is open.

Lettering enhancements

Lettering now allows you to perform full lettering reshape operations – i.e. 
move, resize, stretch, skew and rotate individual letters in a lettering 
object. You can also kern letters away from the lettering baseline by 
dragging while holding down the Shift key. See Adjusting individual letters 
in the Onscreen Manual for details.
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Multi-hooping improvements

The old Multi-Hooping View has changed to Hoop Layout mode and 
incorporates a number of enhancements. The purpose of these is to improve 
the efficiency and ease of hoop placements and give you greater choice in 
how a design is split. Four new tools have been added to the Multi-Hooping 
toolbar:

Adding multiple adjacent hoopings

The new Add Four Adjacent Hoops and Add Eight Hoops Around tools 
become available when a single hoop is selected in the design window. 
Clicking the icon causes four or eight hoopings to be added around hoop’s 
perimeter, starting from the top and continuing in a clockwise direction, with 

View and edit multi-hoopings. If embroidery is too large or contains 
multiple designs spaced around an article, split into multiple hoop-
ings.

Use Add Four Adjacent Hoops (Multi-Hooping toolbar) to automatically add 
four hoopings around a selected hoop’s perimeter.

Use Add Eight Adjacent Hoops (Multi-Hooping toolbar) to automatically add 
eight hoopings around a selected hoop’s perimeter.

Reshape Splitting Guide

Add Four Adjacent Hoops

Add Eight Hoops Around

Splitting Guide
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a 10mm overlap between sewing fields. See Creating multi-hoop designs in 
the Onscreen Manual for details.

Splitting objects between hoopings

The new Splitting Guide tool allows you to stitch out objects that would 
not otherwise fit within a hooping. In effect, it allows you to digitize one or 
more split lines in a multi-hooped design prior to outputting to file, machine 
or memory card. Although split lines are only visible in Hoop Layout, they 
are maintained when switching to other modes. Split lines do not have any 
permanent effect on objects prior to output. See Splitting objects between 
hoopings in the Onscreen Manual for details.

Saving multi-hooped designs

The following commands are now available in Hoop Layout mode:

Save As

Add Four Adjacent Hoops Add Eight Adjacent Hoops

Splitting guides allow
objects that would not

otherwise fit within a
hooping.
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Write to Machine

Card/Machine Write

Write to Magic Box

When any of these commands is invoked, multi-hoopings and split lines are 
applied. Hooping Sequence mode is activated, showing the separate 
hoopings. In the case of the Save As command, however, Hooping 
Sequence mode is only activated if you choose to export split files. See 
Outputting designs with split lines in the Onscreen Manual for details.

Multi-hoop registration marker

To reduce the number of needle penetrations and make it easier to unpick, 
the alignment cross has been modified as follows: 

It is now stitched with fewer needle penetrations.

It has been made larger to be stitched within a 4mm x 4mm cell.

Both these enhancements make the cross easier to remove after the design 
portions have been aligned. They also ensure that, if the machine is not 
threaded, there will still be a needle penetration in the middle of the 
registration point which you can use to register the design.

DEL key operation

BERNINA Embroidery Software allows you to delete all selected hoops with 
the Delete key. Behavior is identical to clicking the Delete Hoop toolbar 
button.
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New print layout for multi-hoop designs

Previous version print layouts show hoops in black and not the coded colors 
shown in Multi-Hooping View (now Hooping Layout). In the new print 
layout, if there is more than one hooping, hoops are shown with their coded 
colors. See Printing multi-hooped designs in the Onscreen Manual for 
details.

The Hooping Sequence printout has the same layout as the Color Film 
printout. The following information is included for each hooping: hooping 
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sequence number and hoop position. See Printing multi-hooped designs in 
the Onscreen Manual for details.

Other improvements

BERNINA Embroidery Software also includes the following miscellaneous 
improvements.

Curve smoothing

Like vector objects, embroidery objects contain reshape nodes on their 
outlines. On shapes where the angle changes constantly, the software may 
insert hundreds of reshape nodes, making reshaping difficult. The Smooth 

Use Reshape Object in combination with Edit > Smooth Curves to remove 
unnecessary reshape nodes from embroidery objects.
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Curves command lets you apply curve ‘smoothing’ to embroidery objects. 
See Smoothing curves in the Onscreen Manual for details.

Turning stitch angles

The Stitch Angles tool has been renamed to Add Stitch Angles on the 
revised Stitch and Color Bar toolbar. A new Remove Stitch Angles has 
been added. See Adjusting stitch angles in the Onscreen Manual for details.

In BERNINA Embroidery Software, the Add Stitch Angles tool can be 
applied to closed objects with:

turning stitch angles

a single stitch angle, with or without hole(s).

Note  When an object with Star Fill or Wave Fill effect is selected and the 
Add Stitch Angles tool activated, the effect is removed from the object. 

Automatic creation of stitch angles

If you press Enter without entering stitch angle lines after the Add Stitch 
Angles tool is activated, stitch angle line/s are automatically created. You 
either press Enter again to accept the angle lines or Spacebar to discard 
them so a single stitch angle is applied.

Use Stitch and Color Bar > Add Stitch Angles to add stitch angles to closed 
objects with or without holes.

Use Stitch and Color Bar > Remove Stitch Angles to remove stitch angles 
from closed objects with turning stitches.

Remove Stitch Angles

Add Stitch Angles 
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New Remove Stitch Angles tool

The new Remove Stitch Angles tool has been added to the Stitch and 
Color Bar. This tool is enabled when one or more of the following objects 
are selected:

Closed object (including Rectangle object) with turning stitch angles 

Block digitizing object.

Whenever Remove Stitch Angles is applied to selected objects with 
turning stitch angles, the resultant object takes a single, nominal stitch 
angle. This was previously achieved by applying the Stitch Angles tool to 
selected objects with turning stitches.

Evenly spaced buttonholes

Add a line of evenly spaced buttonholes to a design with the new Add 
Buttonholes command. See Creating a line of buttonholes in the Onscreen 
Manual for details.
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Design details available in Windows Explorer

Design thumbnails and information are now available in Windows Explorer. 
See Viewing design information in the Onscreen Manual for details.

Support for new Deco and Janome hoops

BERNINA Embroidery Software now provides support for Deco hoops (3 new 
Deco 330/340 hoops added) Hoop A/F, Hoop B and Hoop C as well as 
Janome hoops 50 x 50, 110 x 126 and 190 x 220. See Selecting hoops in 
the Onscreen Manual for details.

ART designs now 
displayed in Windows 
Explorer

ART design details 
available in Windows 
Properties dialog
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Quilter improvements

BERNINA Quilter includes the following improvements:

On Point Measurement

The On Point format measurement has been corrected. It now defaults to 
10" along the edge rather than across the middle.

New Diamond format

A new Diamond format has been added for non-square blocks.

On Point format
now 10" along the

edge
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Quilt Block Editor

BERNINA Quilter now allows you to create and edit square blocks. This 
feature is available in BERNINA DesignerPlus only.

In general the drawing tools work the same way as in BERNINA Embroidery 
Software:

Tool Purpose

Use Select Shapes to select any lines drawn in the design window. 

Use Zoom Box to zoom in on details in your design. Use in conjunction with 
Pan.

Use Reshape to modify selected lines in the block. Click and drag them as 
required. Right-click to add reshape nodes.

Use Pan to click and drag the design within the editor window when working 
at high zoom factors.

Use Color in conjunction with the color palette to color in selected areas of the 
block.

Use Line to draw lines and divide up the grid as required.

Use Curve to create curved lines.

Use Solid Rectangle to create rectangular shapes in the currently selected 
color.

Use Solid Circle to create circular shapes in the currently selected color.
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Rotary cutting instructions

You can print Rotary Cutting instructions for your own custom blocks from 
inside the Block Editor.

Use Solid Shape to create any shape in the currently selected color.

Tool Purpose

Rotary cutting 
instructions
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Supported file formats

BERNINA® Embroidery Software supports a number of new embroidery and 
image file formats. See below for a complete listing.

Supported embroidery file formats

You may need to store designs in file formats other than ART60. For 
example:

You may wish to send a design to a someone else who uses BERNINA 
Embroidery Software or some other compatible embroidery software.

You may wish to stitch the design on a sewing machine that is not directly 
connected to your PC. This may be a BERNINA A200, older BERNINA, or 
other brand of machine. In this case the file will need to be saved in ART 
or a stitch file format for delivery to that machine.

If more than one hoop is needed to cover the design, you may wish to 
split the design into separate files for each hooping.

BERNINA Embroidery Software supports the following formats. The writable 
file formats are available in BERNINA EditorPlus as well as BERNINA 
DesignerPlus.

Format File Grade Read Write Note

V6.0 BERNINA Embroi-
dery Software

ART60 A Current release

V5.0 BERNINA Embroi-
dery Software

ART50 A

BERNINA A730/A200 
designs

ART A All BERNINA Embroi-
dery Software 
Designs

BERNINA USB Stick EXP

V1.x Explorations Projects ART42 A

V4.0 artista Designs ART ^

artista Cross Stitch ARX D ‡

Deco, Brother, Babylock PEC C

Deco, Brother, Babylock PES C Includes V5.0 and 
V6.0

Elna Xpressive EMD C

Husqvarna/Viking HUS C

^ V1, V2 and V3 ART no longer supported for write ‡ Cross Stitch program 
only † Quilter program only * Save back as SHV but not convert to SHV
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Note  * In all situations where File > Open and File > Insert Design 
dialogs are invoked, the first item in the list of file types is always ‘All ART 
(*.ART*)’. The reason for this is that there are a huge number of ART files 
of versions earlier than ART60 in the market.

Supported graphic formats

With full integration with CorelDRAW® Essentials 4 by the Corel 
Corporation, graphic file formats now supported by BERNINA Embroidery 
Software include the following:

Husqvarna/Viking SHV C *

Husqvarna Viking/Pfaff VP3 C

Husqvarna Viking/Pfaff VIP C

Janome/Elna/Kenmore SEW C

Melco EXP C

Pfaff PCS C

Pfaff PCD C

Pfaff PCQ C

Pfaff PCM C

Poem, Huskygram, 
Singer EU

CSD C

Singer XXX C

Tajima DST C

artista Templates AMT A

V6.0 BERNINA Embroi-
dery Software templates

AMT60 A

artista Quilter ARQ D † †

File format Extension Import Export Note

Illustrator Vec-
tor Graphic

AI Vector file format native to Adobe 
Systems Incorporated.

Format File Grade Read Write Note

^ V1, V2 and V3 ART no longer supported for write ‡ Cross Stitch program 
only † Quilter program only * Save back as SHV but not convert to SHV
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Windows Bit-
map

BMP Device-independent bitmap (DIB) 
format that allows Windows to dis-
play the bitmap on any type of dis-
play device.

CALS com-
pressed bitmap

CAL Developed in mid-1980s to stan-
dardize graphics data interchange 
for electronic publishing.

CorelDRAW CDR Vector file format native to 
CorelDRAW and other Corel appli-
cations.

CorelDRAW 
Compressed

CDX Same as CDR file but compressed.

Computer 
Graphics Meta-
file

CGM File format for 2D vector graphics, 
raster graphics, and text.

R.A.V.E. ani-
mation file

CLK Animation file format native to 
CorelDRAW and other Corel appli-
cations.

Corel Presenta-
tion Exchange

CMX Presentation format of Corel Suite 
applications.

Corel 
PHOTO-PAINT 
Image

CPT Native file format of Corel 
PHOTO-PAINT application.

Corel CMX 
Compressed

CPX Same as CMX file but compressed.

Corel Symbol 
Library

CSL Symbol library stores reusable 
objects or ‘symbols’.

Corel 
DESIGNER

DES 3D technical illustration created with 
Corel Designer, a technical graphics 
design program.

MS Word DOC / 
DOCX

MS Word Binary File Format con-
taining text, tables, fields, pictures, 
embedded XML markup, and other 
document content.

Enhanced Win-
dows Metafile

EMF Windows Metafile (WMF and EMF) 
formats are vector formats that may 
or may not also contain a 
bit-mapped image.

File format Extension Import Export Note
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Encapsulated 
Postscript

EPS Standard file format for importing 
and exporting PostScript files. Can 
contain any combination of text, 
graphics and images.

Macromedia 
Freehand

FH Vector file format native to Macro-
media Freehand.

GEM File GEM Digital Research (GEM Paint) 
image.

CompuServe 
Bitmap

GIF Bit-mapped graphics file format 
widely used on the Internet. 
Includes data compression but is 
limited to 256 colors. 

HyperText 
Markup Lan-
guage

HTM Common webpage file type. Gener-
ally used on Internet for webpages 
with static content.

GEM Paint File IMG Digital Research (GEM Paint) 
image.

Joint Photo-
graphic Experts 
Group Bitmaps

JPG / 
JPEG

Compressed format for grayscale 
and color images.

Macintosh 
PICT

PCT Originates on Apple Macintosh – 
basically a metafile recording a 
series of Macintosh QuickDraw 
graphics commands. 

PaintBrush PCX File format created by ZSoft. Com-
presses image data with RLE type 
compression.

Adobe Type 1 
Font

PFB Adobe Type Manager Type 1 Post-
Script font file format.

Portable Net-
work Graphics

PNG Designed to replace older and sim-
pler GIF format. Features lossless 
compression and supports up to 
48-bit truecolor or 16-bit grayscale.

Picture Pub-
lisher 4

PP4 Bitmap graphics file extension used 
by version 4 of Micrografix Picture 
Publisher.

Picture Pub-
lisher 5.0

PP5 Bitmap graphics file extension used 
by version 5 of Micrografix Picture 
Publisher.

Picture Pub-
lisher

PPF Bitmap graphics file extension used 
by Micrografix Picture Publisher.

File format Extension Import Export Note
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Microsoft Pow-
erPoint

PPT Microsoft PowerPoint proprietary 
file format – also known as Binary 
Interchange File Format (BIFF). 

Adobe Photo-
Shop

PSD Native Adobe Photoshop graphic 
file format that takes up less mem-
ory than uncompressed TIF files.

Corel Paint 
Shop Pro

PSP Native graphic file format of Paint 
Shop Pro.

MS Publisher 
Document For-
mat

PUB Native file format of Microsoft Pub-
lisher.

Painter RIFF Generic meta-format introduced in 
1991 by Microsoft and IBM as 
default format for Windows 3.1 mul-
timedia files.

Rich Text For-
mat

RTF Text with some very common for-
matting stored in a plain ASCII text 
file somewhat like HTML files. Used 
to exchange text files between dif-
ferent word processors or operating 
systems.

Corel Presenta-
tions

SHW Native file format of Corel Presenta-
tions, usually packaged as part of 
Corel’s WordPerfect Office.

Macromedia 
Flash

SWF Adobe (formerly Macromedia) Flash 
movie file. ShockWave Flash, Ani-
mated Vector Format for Internet.

Targa Bitmap TGA Created by Truevision Inc. Supports 
uncompressed and RLE com-
pressed TGA file formats.

Tagged Image 
File Format Bit-
map

TIFF Tag-based file format designed to 
promote universal interchanges of 
digital image data.

True Type Font TTF A file containing typeface informa-
tion.

ANSI Text TXT Common text file associated with 
many MS-DOS, Unix, Windows 
applications and text editors. May 
vary from simple ASCII to UTF.

Corel Quatro 
Pro

WB / WQ Corel Quatro Pro spreadsheet file.

File format Extension Import Export Note
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Note  For a full description of the CorelDRAW® Essentials 4 tools, refer to 
the electronic User Guide available via the Windows Start > Programs 
group. Alternatively, use the onscreen help available from the Graphics 
mode Help menu.

Software inclusions

BERNINA Embroidery Software provides many new software inclusions for 
sample designs and artwork and embroidery alphabets. 

Sample designs and artwork

BERNINA Embroidery Software contains hundreds of ready-to-stitch designs 
including many new attractive ornaments, samples and artwork backdrops. 
Design files (ART files) and images (BMP, JPG, and WMF files) can be found 

LOTUS 1-2-3 WK Lotus 1-2-3 spreadsheet file.

Windows Meta-
file

WMF Windows Metafile (WMF and EMF) 
formats are vector formats that may 
or may not also contain a 
bit-mapped image.

Corel WordPer-
fect 4.2

WP4 Document format used by Corel 
WordPerfect word editor version 4.

Corel WordPer-
fect 5

WP5 Document format used by Corel 
WordPerfect word editor version 5.

Corel WordPer-
fect

WPD Document format used by Corel 
WordPerfect word editor.

Corel WordPer-
fect Graphic

WPG Can contain bitmaps, line art, and 
vector graphics.

WordStar WSD WordStar document file format.

Gimp Image XCF Gimp bitmap image format.

XPixMap 
Image

XPM ASCII-text-based image format 
used by the X Window System.

Microsoft Excel XSL Microsoft Excel spreadsheet file.

File format Extension Import Export Note
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in your My Designs - Embroidery Software 6 folder. See also Digitizing 
with Backdrops in the Onscreen Manual.

Tip  BERNINA Portfolio displays embroidery design thumbnails and limited 
design information. You can filter the contents of the display window to show 
only certain embroidery file types. See Browsing designs in folders in the 
Onscreen Manual for details.

CorelDRAW® Essentials 4 itself is packaged with a selection of clipart which 
can be accessed via the CorelDRAW® Essentials 4 program group. This 

Supported file
types
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clipart can be used as digitizing backdrops or converted directly into 
embroidery.

It may be more convenient to take a copy of the entire 
CorelDRAW® Essentials 4 Clipart folder and copy it to My Designs - 
Embroidery Software 6 folder for easy reference.

Caution  Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart – 
does not remove copyright protection.

Access CorelDRAW® 
clipart folders

CorelDRAW®
clipart folders
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Embroidery alphabets

BERNINA Embroidery Software provides over 50 professional quality 
embroidery alphabets including over 10 brand new ones. See Alphabet 
Samples in the Onscreen Manual for details.

Note  Not all alphabets are included in all product levels. 

CorelDRAW® Essentials 4 itself is packaged with a selection of TrueType and 
OpenType fonts which are automatically registered during installation. 
These can be automatically converted to embroidery alphabets. See also 
Converting fonts to alphabets in the Onscreen Manual.

CorelDRAW®
font folders
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Carving Stamp patterns

BERNINA Embroidery Software provides a number of attractive new 
Carving Stamp patterns. See Pattern set: Carving Stamps in the Onscreen 
Manual for details.

Known limitations in BERNINA® Embroidery Software

The following are known limitations in BERNINA Embroidery Software V6.0.

Conversion of artistic media

There are some limitations when converting some CorelDRAW® vectors to 
embroidery. Vector special effects, such as drop shadow, contour, and 
transparency, do not convert well as there is no equivalent embroidery 
effect. Enveloped text and Fountain or Mesh fills do not always give the 
expected result either.

Drop shadow unable 
to be converted
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Also Artistic Media is not always converted to embroidery as you might 
expect. Unless you first break the object into its constituent parts, the result 
is sometimes just a single line of run stitches.

However, as long as the vector object has a fill and/or an outline, BERNINA 
Embroidery Software will attempt to convert it. But if there is no embroidery 
equivalent, the object is converted with solid colors only. Enveloped text is 
converted to embroidery objects rather than embroidery text. See also 
Converting vectors to embroidery in the Onscreen Manual.

Tip  A workaround is to break apart any ‘special’ vector objects using the 
Arrange > Break Apart command in Art Canvas. In most cases, you will 
get a result, but it may not be exactly the one you want. 

PhotoSnap

The Mirror Merge feature is not intended to be used with PhotoSnap 
designs. Objects are not placed in the correct mirrored position.

Some PhotoSnap designs, when sent to a BERNINA artista 200 machine, 
may produce Out of Memory errors. It is recommended that the 
photograph or image be removed from the design before sending to the 
machine.

When opening a PhotoSnap design created in BERNINA artista V3 or V2, 
it will open correctly. However, if the design is resized, excessive stitches 
are generated. To regenerate stitches, producing a better result and 
lower stitch count:

Select and double-click the PhotoSnap object.

Select PhotoSnap tab in the Object Properties dialog.

Adjust the Resolution setting and click OK.

Artistic Media broken 
apart prior to conversion
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Note  After generating the stitches, the stitch angle of the object is 
greater than the stitch angle for a comparable V6.0 PhotoSnap object.

Gradient Fill limitations

Gradient Fill is subject to the following limitations

You cannot use Gradient Fill and Travel on Edges at the same time 
with Block Digitized objects. When applying Gradient Fill to a Block 
Digitized object, you must explicitly turn off Travel on Edges or the 
effect will not be applied. 

Adding a holes to a Block Digitized object will destroy any Gradient Fill 
effect applying.

See also Creating gradient fills in the Onscreen Manual.

Stitching out elastic lettering

When sending a design that contains a single lettering object with Elastic 
Lettering applied, an Out of Memory error is generated when selecting 
the design after sending. The workaround is to use the Break Apart tool 
which will turn the lettering into embroidery patches – i.e. it is no longer a 
lettering object. Alternatively save as EXP and send to machine as an EXP 
file. See Creating special effects with Elastic Lettering in the Onscreen 
Manual for details.

Wave Effect stitch angles

Don’t alter stitch angles after applying Wave Effect as it can displace 
Fancy Fill patterns.

Zoom factors in Art Canvas

The zoom factors in Art Canvas of To Page, To Width and To Height do 
not work the same as in standalone CorelDRAW® Essentials 4.

Design file formats

Some designs created in BERNINA Embroidery Software and saved in PES 
format may not be readable by other machines. See Writing designs to 
machine in the Onscreen Manual for details.

Multi-hooping large areas of Step fill

Large areas of Step fill with stitch spacings of 1 mm or more cannot be split 
using the Splitting Guide. Attempting to split these objects may give you 
an Out of Memory error.
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Saving split designs to earlier versions

Saving split designs to earlier versions of ART file may create a large number 
of manual stitch objects which will have scaling limitations in earlier versions 
of the software.

Saving objects with added stitch angles

Saving objects which have had stitch angles manually added to earlier ART 
file versions can cause problems when changing underlays in earlier 
versions of the software.

PCM and EMD file formats

The newly supported PCM and EMD file formats may not convert exactly as 
expected. If not, you will need to save to another format supported by your 
machine.

Monogram TrueType fonts and characters

Monogramming does not work with all TrueType fonts and characters. For 
example:

On MS Windows® XP SP2 English with East Asian language support, most 
unicode characters (including Kanji characters) are generated as ‘?’ 
characters.

On MS Windows® XP SP2 Chinese Traditional the situation is better, 
however some characters still generate outlines as ? characters.

Tip  Character outlines are generated correctly, however, when you create 
ordinary lettering or monogramming objects using the Name field instead 
of Initials fields. See Creating monogram lettering with names in the 
Onscreen Manual for details.

BERNINA Cross Stitch

If BERNINA Cross Stitch has been left open for a while without being used, 
a message displays asking if you want to save your design. Click the Cancel 
button to keep BERNINA Cross Stitch open and continue working. Click the 
Save button to save the current design and close BERNINA Cross Stitch.

BERNINA Portfolio

When viewing converted files in BERNINA Portfolio for DST and EXP, 
design connectors are displayed in thumbnail view.

In this version, it is not possible to export Tab and CSV (Comma 
Separated Value files) formats for use by spreadsheets. 

When reading a memory stick in BERNINA Portfolio, the icon appears in 
the folder tree as a floppy disk. When you select it, the contents do not 
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display immediately. Right-click the icon and select Refresh Display – 
the contents are then displayed correctly in the folder tree.

Windows Vista 64 Bit

If the error message ‘Failed to load rapi.dll’ is displayed when trying to 
connect to BERNINA home embroidery machine, update to the newest 
Windows Mobile Device Center Driver. Download and install the update from 
the Microsoft website. The current Driver Version 6.1. 

http://www.microsoft.com/downloadS/details.aspx?familyid=4F68EB56-7825-43B2-AC89-2030ED98ED95&displaylang=en


B
ER

N
IN

A
®

 Em
b

ro
id

ery So
ftw

are : R
elease N

o
tes

B
ER

N
IN

A
 Em

b
ro

id
ery So

ftw
are Pro

d
u

ct Featu
re List

66

BERNINA Embroidery Software Product Feature List

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Basics Basic Procedures
Open designs from PC Opening designs
Open multiple designs Opening designs
Create designs (templates) Starting new designs
Save designs Saving designs
Display the hoop and grid Hoops and grids
Measure distances onscreen Measuring distances onscreen
Undo/redo commands Undo/Redo Undoing and redoing commands
Move/dock toolbars Moving and docking toolbars
Access object properties Accessing object properties
View designs Viewing Designs
View designs in Art Canvas mode Art Canvas Art Canvas mode
View designs in Embroidery Canvas mode Embroidery 

Canvas
Embroidery Canvas mode

View designs in Hoop Layout mode Hoop Layout Hoop Layout mode
View simulated embroidery Artistic View Viewing simulated embroidery
View embroidery stitches Stitch View Viewing simulated embroidery
View needle points Viewing needle points
View stitches and outlines Viewing stitches and outlines
View design objects by color Viewing objects by color
View designs in overview Overview Window Viewing designs in overview
Zoom in/out Zooming in and out
Travel by object/color block Traveling by object and color block
Travel by stitches Traveling by stitches
View simulated design stitchout Slow Redraw Simulating design stitchouts
View/hide backdrops Viewing backdrops
Change background colors/fabrics Changing backgrounds
View design information Viewing design properties
Preview designs Previewing designs
Select objects Selecting Objects
Select objects by point and click Select Object Selecting objects by point and click

Included as standard  New/improved feature/option
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Select objects with bounding box Selecting objects by bounding box
Select objects with Polygon Select Polygon Select Selecting objects by Polygon Select
Select objects by Tab key Selecting objects by Tab key
Select all objects in design Selecting all objects in a design
Deselect objects Deselecting objects
View and select color blocks Color Film Viewing and selecting color blocks
Working with hoops Hooping Designs
Display hoops Selecting hoops
Create multi-hooped designs Hoop Layout Creating multi-hoop designs
Split objects between hoopings Splitting Guide Splitting objects between hoopings
Create custom hoops Defining custom hoops
Modify custom hoops Modifying custom hoops
System setup Hardware and Software Setup
Calibrate monitor Calibrating the monitor
Set grid options Setting grid options
Set automatic scrolling Setting auto scroll options
Set hoop options Setting hoop options
Set closed-object appliqué options Auto Appliqué Setting Auto Appliqué options
Set Remove Overlaps options Remove Overlaps Setting Remove Overlaps options
Set automatic save Setting automatic save
Set pointer position display options Setting pointer position display options
Set other general options Setting other general options
Digitizing methods Digitizing Methods
Switch between fill and outline methods Switching between fill and outline digitizing 

methods
Digitize open shapes Open Object Digitizing open shapes
Digitize closed shapes Closed Object Digitizing closed shapes
Digitize columns of varying width Block Digitizing Digitizing columns of varying width
Digitize circles and ovals Circle/Oval Digitizing circles and ovals
Digitize squares and rectangles Rectangle Digitizing squares and rectangles
Outline and fill stitches Outline and Fill Stitches
Select outline stitches Selecting outline stitches
Select fill stitches Selecting fill stitches

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Create Single/Triple outlines Single/Triple Creating outlines with Single and Triple 
stitch

Create Satin outlines Satin Creating outlines with Satin stitch
Create Blanket outlines Blanket Creating outlines with Blanket stitch
Create Satin fills Satin Fill Creating fills with Satin fill
Create Step fills Step Fill Creating fills with Step fill
Change Step patterns Step Pattern Applying Step patterns
Thread colors and thread charts Thread Colors and Charts
Change current colors Changing current colors
Recolor selected objects Recoloring selected objects
Search and assign threads Searching and assigning threads
Match and assign threads Matching and assigning threads
Change colors in entire design Changing entire design colors
Modify thread charts Modifying thread charts
Create custom thread charts Creating custom thread charts
Object properties and templates Object Properties and Templates
Set current object properties Setting current object properties
Change object properties Changing properties of selected objects
Change default object properties Changing default object properties
Create design templates Creating design templates
Modify design templates Modifying design templates
Save current properties to template Saving current properties to a template
Revert to NORMAL template Reverting to the NORMAL template
Improving stitch quality Improving Stitch Quality
Adjust fabric settings Adjusting fabric settings
Apply automatic underlays Stabilizing with underlays
Apply automatic pull compensation Compensating for fabric stretch
Preserve long stitches Auto Jump Preserving long stitches
Adjust tie-in/off settings Adjusting tie-in/off settings
Set automatic start and end points Auto Start/End Setting automatic start and end points
Digitizing with backdrops Digitizing with Backdrops
Scan bitmap images Scanning artwork
Load bitmap and vector pictures Loading pictures
Crop images for digitizing Cropping images for digitizing

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Reshape cropped images Reshape Object Reshaping cropped images
Edit images in a graphics application Touch Up Picture Editing images in graphics applications
Save backdrops as separate files Saving backdrops as separate files
Prepare non-outlined images Image 

Preparation
Preparing non-outlined images

Prepare outlined images Outlined Image 
Preparation

Preparing outlined images

Automatic digitizing Automatic Digitizing
Convert vectors to embroidery Convert to 

Embroidery
Converting vectors to embroidery

Convert embroidery to vectors Convert Selected 
Embroidery to Art 
Vectors

Converting embroidery to vectors

Digitize filled shapes automatically Magic Wand Digitizing fills automatically
Digitize outlines automatically Magic Wand Digitizing outlines automatically
Digitize whole images automatically Auto Digitizer Digitizing whole images automatically
Create automatic outlines and borders Auto Digitizer Creating automatic outlines and borders
Create designs from photographs PhotoSnap Digitizing with PhotoSnap
Combining and sequencing objects Combining and Sequencing Objects
Insert designs Inserting designs
Copy and paste objects Copying and pasting objects
Duplicate objects Duplicating objects
Clone objects Quick Clone Cloning objects
Group/ungroup objects Group/Ungroup Grouping and splitting objects
Break objects apart Break Apart Splitting into component objects
Resequence objects Sequencing objects
Manipulate color blocks and objects Color Film Sequencing objects with Color Film
Sequence entire designs automatically Stitch Sequence Auto-sequencing entire designs
Arranging and transforming objects Arranging and Transforming Objects
Position objects Positioning objects
Align objects Aligning objects
Scale objects Scaling objects
Rotate objects Rotating objects
Skew objects Skewing objects

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Mirror objects Mirroring objects
Mirror-merge objects Mirror-merging objects
Create wreaths Creating wreaths
Reshaping and editing objects Reshaping and Editing Objects
Reshape objects Reshape Object Reshaping objects
Adjust stitch angles Adjusting stitch angles
Change entry and exit points Adjusting entry and exit points
Stitch editing Editing Stitches
Select stitches Selecting stitches
Insert stitches Inserting stitches
Move stitches Moving stitches
Delete stitches Deleting stitches
Specialized digitizing techniques Specialized Digitizing Techniques
Create freehand embroidery Freehand Draw 

Embroidery
Creating freehand embroidery

Reinforce outlines Reinforcing outlines
Cut holes in objects Add Holes Cutting holes in objects
Remove underlying stitching Remove Overlaps Removing underlying stitching
Fill holes in objects Fill Holes Filling holes in objects
Create outlines and borders Outline Design Creating outlines and borders
Create buttonholes Add Buttonhole Creating buttonholes
Artistic stitch effects Artistic Stitch Effects
Create contour fills Contour Creating contour fills
Create fancy fills Fancy Fill Creating fancy fills
Create cross stitch fills Cross Stitch Creating cross stitch fills
Create textured edges Textured Edge Creating textured edges
Create wave effects Wave Effect Creating wave effects
Creating star fills Star Fill Creating star fill effects
Create gradient fills Gradient Fill Creating gradient fills
Create open fills Travel on Edges Creating open fills
Create color blending effects Color Blending Creating color blending effects
Create morphing effects Morphing Creating morphing effects

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Pattern runs and fills Patterned Stamps, Runs and Fills
Add pattern stamps Pattern Stamp Adding pattern stamps
Create pattern runs Pattern Run Creating pattern outlines
Create pattern fills Pattern Fill Creating pattern fills
Create your own pattern sets Managing patterns
Create stitch patterns with carving stamps Carving Stamp Creating stitch patterns with carving stamps
Craft stitch borders and fills Craft Stitch Borders and Fills
Create blackwork outlines Blackwork Border Creating blackwork outlines
Create backstitch outlines Backstitch Creating backstitch outlines
Create stemstitch outlines Stemstitch Creating stemstitch outlines
Create candlewicking outlines Candlewicking 

Border
Creating candlewicking outlines

Create blackwork fills Blackwork Fill Creating blackwork fills
Create candlewicking fills Candlewicking Fill Creating candlewicking fills
Create lacework fills Lacework Creating lacework fills
Create ripple fills Ripple Creating ripple fills
Create stippling fills Stipple Creating stippling fills
Appliqué Digitizing for Appliqué
Create appliqué Auto Appliqué Creating closed-object appliqué
Create partial cover appliqué Partial Appliqué Creating partial cover appliqué
Create open-object appliqué Advanced 

Appliqué
Creating open-object appliqué

Embroidery lettering Embroidery Lettering
Add lettering to embroidery designs Adding lettering to embroidery designs
Create horizontal baselines Creating horizontal baselines
Create vertical baselines Creating vertical baselines
Create circle baselines Creating circular baselines
Create multiple baselines Creating predefined baselines
Create custom baselines Creating custom baselines
Format lettering (italics, bolding, 
justification)

Formatting lettering

Adjust letter spacing (overall, individual, 
line)

Adjusting spacings

Edit lettering text Editing lettering text

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Scale lettering Scaling lettering
Remove underlay from small lettering Removing underlay from small lettering
Transform lettering objects (rotate, skew) Transforming lettering objects
Adjusting individual letters (reposition, 
transform, reshape)

Adjusting individual letters

Add stitch angles to letters Adding stitch angles to letters
Recolor letters Recoloring letters
Embroidery lettering – special Embroidery Lettering
Convert text to embroidery Converting text to embroidery
Convert TrueType fonts to embroidery Converting fonts to embroidery
Add special characters and symbols Adding special characters
Special alphabets Using special alphabets
Create special effects with Elastic Lettering Elastic Lettering Creating special effects with Elastic 

Lettering
Monogramming Monogramming
Create monogram lettering with initials Monogramming Creating monogram lettering with initials
Create monogram lettering with names Creating monogram lettering with names
Add ornaments to monograms Adding ornaments to monograms
Create ornament layouts Creating multi-ornament layouts
Add borders to monograms Adding borders to monograms
Create your own borders Creating custom borders
Design processing Design Processing & Output
Print designs Previewing and printing worksheets
Set print options for embroidery Setting print options for embroidery
Print appliqué patterns Printing appliqué patterns
Print Color Film Printing Color Film
Print multi-hooped designs Printing multi-hooped designs
Print thread charts Printing thread charts
Save designs as images Saving designs as images
Stitch out designs Stitching out designs
Output multi-hooped designs Outputting multi-hooped designs
Open stitch files with object conversion Opening files with conversion
Open stitch files without object conversion Opening files without conversion
Read designs from machine Reading designs from machine

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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Write designs to machine Writing designs to machine
Write designs to USB stick Writing designs directly to USB stick
Store designs with Magic Box Storing designs with Magic Box
Save designs in PES format Saving designs in PES format
Design management Design Management
Browse for designs in folders Browsing designs in folders
View zipped designs in folders Viewing archived designs
Locate missing files Locating missing files
Change locale Changing locale
Open designs in BERNINA Embroidery 
Software

Opening designs in BERNINA Embroidery 
Software

Create designs with custom templates Creating designs with custom templates
Run simple and complex sorts Sorting files in folders
Print designs Printing designs with BERNINA Portfolio
Print design catalogs Printing design catalogs
Stitch out designs Stitching out designs
Convert design files Converting design files
Archive design files Archiving design files
Organize designs in folders Organizing designs in folders

Capability Feature Name EditorPlus DesignerPlus Relevant topic in Onscreen Manual

Included as standard  New/improved feature/option
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