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CHAPTER 1
INTRODUCTION
Welcome to BERNINA® Embroidery
Software, the leading embroidery design
application for home users. This is an
MS Windows®-based product
incorporating many of the conventions
with which most PC users are already
familiar.
BERNINA Embroidery Software is unique
in providing seamless integration with
CorelDRAW® Essentials X6, the most
popular vector-based drawing package
for home users. This combination offers a
more efficient, user-friendly approach to
embroidery design by combining the
embroidery capabilities of BERNINA
Embroidery Software with graphical capabilities of CorelDRAW®. It also allows
users to create not just embroidery, but true, multi-medium designs.
First-time users
If you are new to BERNINA Embroidery Software,
you’ll be pleased with its flexible digitizing
capabilities, the ease with which you can create and
edit designs, and how simple it is to add or create
your own lettering. However, before you begin
working with the product, please read Getting
Started. This chapter presents an overview of the
basic concepts of digitizing with BERNINA Embroidery
Software and provides you with important guidelines
on how to use this software to achieve the best
results.
Update users
BERNINA Embroidery Software is an enhanced
version of our earlier products. It has many new and
expanded features. Please read the Release Notes
available from the Help menu to quickly familiarize
yourself with the scope of these improvements.

Note If you are upgrading from a previous version of
the software, you are advised not to remove any
earlier versions until after installing the new software.
This gives you the option of merging user-defined
settings, including user-defined motifs, into the new
installation.

System requirements
In order to run your software, you need to ensure that
the following pre-requisite system requirements are
met.
PC specifications

Check that your PC meets the system requirements. Check CPU/RAM as well as hard disk space. The table
below provides minimum system requirements.
Component

Minimum

Recommended

CPU

Intel® Core 2 Duo or AMD Athlon™ 64

3GHz + Latest 64-bit (x64) multi core processor
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Component
Operating system

Minimum

Recommended

‡ Windows® 7 (32-bit or 64-bit Editions) with latest Windows® 10 (64-bit Edition) or Windows®
service packs installed.
8.1 (64-bit Edition), with latest service packs.

Browser

I.E. 9.0 or Later

I.E. 11.0 or Later

Memory

4 GB

8 GB or more

Hard disk size

80 GB

256 GB or More (Solid State Drive)

Free disk space

† 40 GB

Graphics card

Monitor

60 GB or More

Support for Highest Color (32bit) and resolution
(1366 X 768)

¥ 1366 X 768 screen resolution

Support for DirectX 9 graphics with:
WDDM Driver
1GB of graphics memory (non-integrated)
Pixel Shader 2.0 in hardware bits per pixel
Dual Monitor Capable
Dual monitors capable of displaying 1920 X 1080
screen resolution

Mouse

USB mouse

USB port

Required for software installation.

Sound card

Required for online video help.

Internet
connection

Required for product activation and registration. Internet connection may also be required during
installation in order to download Windows features such as .Net Framework 3.5.

Supported operating systems ‡
Although Windows® 7 (32-bit or 64-bit edition) is
supported, we recommend updating to Windows® 10
(64-bit edition) or Windows® 8.1 (64-bit edition) with
latest service packs installed. You will, however, need
to uninstall any versions of CorelDRAW earlier than
X6.

USB mouse

the first time following installation. Please keep the
product key in a secure place.

Note Each licensed copy of the software is for a
single user. It entitles you to three (3) activations:
two (2) on different computers, and one (1) in case of
hardware failure or replacement.

Free hard disk space †
BERNINA Embroidery Software occupies up to 5GB of
hard disk space, depending on options installed.
CorelDRAW Essentials also takes up an additional
3GB.
Screen resolution ¥
Some controls may be hidden on the user interface if
you run your monitor at low resolutions. The physical
size of your monitor will have a bearing on the
optimum screen resolution. Larger fonts will
exacerbate the problem. If you experience visibility
issues, try adjusting both screen resolution and font
size. For example, a resolution of 1366 X 768 with a
font size of 100% or 125% should be acceptable.

System security
The software is shipped with a product key which can
be found inside the software kit. Each product key
allows your system to be uniquely identified. You will
be prompted to enter the product key to register and
activate the product when the software is launched

Integration with CorelDRAW®
CorelDRAW® Graphics Suite is the most popular
vector-based drawing package for the decorated
goods industry. It features ‘best-of-breed’
bitmap-to-vector tracing, enhanced illustration
capabilities, photo-editing together with a library of
professional clipart images.
BERNINA Embroidery Software comes together with
an installation of CorelDRAW® Essentials X6. The
built-in CorelDRAW Graphics window includes
CorelDRAW drawing tools which offer many
techniques for drafting outlines and shapes on screen.
Vector objects can be converted to embroidery
designs. CorelDRAW® Essentials X6 and its sister
product, Corel PHOTO-PAINT® Essentials X6 can also
be run as standalone applications.
For a full description of the tools, refer to the
electronic User Guide available via the Windows Start
> Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.
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2 Close all MS Windows® applications and
Note CorelDRAW is installed together with Windows
.NET Framework. To ensure that CorelDRAW is
correctly installed with your embroidery software with
the correct version of .NET, make sure you install it
when prompted to do so. It can take up to 20 minutes
or more to install the .NET Framework on some
computers.

temporarily disable your anti-virus software.

3 Insert the Installation USB stick. The installation
program should start within 30 seconds and a
welcome screen displayed.

4 Follow the onscreen instructions to complete the
installation. You will be prompted to choose:
 where the software will be installed on your PC
(default location recommended).
 which components will be installed – e.g.
additional languages.

Installation

 which documentation files will be installed.

5 Reboot the PC when prompted. Save any files and
®

Double-click to start BERNINA Embroidery
Software.

close all applications beforehand.

6 Double-click the icon on the desktop to start the
software for the first time.

Below are instructions for installing the software on
your PC. If you are upgrading or updating your
software from Version 5 to 7, you will need your
previous version hardware dongle and attach it to the
PC when prompted. It will no longer be working after
the update process.

Before you start...
The BERNINA® Embroidery Software kit includes a
USB Drive and Product Key to activate the software.

7 A CorelDRAW configuration message will appear.
Click OK.
Note If you are installing on Windows 10, you will
be prompted to uninstall any previously installed
versions of CorelDRAW Essentials.

8 When prompted, enter the product key (located in
your software kit) and your registration details in
the fields provided.

Before commencing, make sure you have the
following...
 Software product key which is located in the kit.

9 Click OK and the software will connect to our

 If you are upgrading, you will need your previous
version hardware dongle. Do not attach until
prompted.

10 If you have purchased an upgrade kit, attach the

 When you install the software, you will be
prompted to reboot your PC to complete the
installation. Make sure that you save any files and
close all applications beforehand.

activation server to activate the software.
old hardware dongle when prompted.

To install the software

1 Ensure your computer meets the technical
requirements for the software. See System
requirements.
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11 Once activated, you can now use the software.

up in MS Windows®, see the documentation for the
device as well as your MS Windows® documentation.

Setting up embroidery machines
Your BERNINA embroidery machine should be
connected to the USB port of your computer. See your
BERNINA embroidery machine manual for details on
connecting the machine to your computer.

12 When the new software is correctly running,
discard the old dongle if you have one.
Note If you encounter problems with the
installation, please contact your dealer.

Modify installation
Whether you are upgrading your current software or
wanting to uninstall it, you follow the same
procedure. When you run the installation program
again, it will automatically detect if there is an
existing copy of the software on your system and give
you an option to modify, repair or remove it. This will
prevent the installation of more than one release
version of the software on your computer.

Setting up scanners
BERNINA Embroidery Software supports
TWAIN-compatible scanners.

Note Some scanners will not work with BERNINA
Embroidery Software because they require their own
scanner software. If this is the case with your scanner,
use your scanner software for scanning, save the
image to your hard drive, then load the image into
BERNINA Embroidery Software.
To set up scanners

1 Connect the scanner using the accompanying
instructions.

2 Set it up in MS Windows® using the accompanying
To modify an existing installation
 Close all MS Windows® applications but leave
Windows running.
 Insert the Installation USB. If the software is
already installed on the computer, you will be
prompted to:
Option

Notes

Modify

Change selection of installed components.

Repair

Reinstall same components.

Remove

Uninstall the software.

Note Upon successful installation of the software and
any additional MS Windows® files that need
upgrading, the Maintenance Complete screen
appears. If you have selected Repair as your
installation option, currently installed components will
be reinstalled.

Hardware setup
Different devices are set up in different ways – some
in MS Windows®, via the Control Panel, others within
BERNINA Embroidery Software itself. For instructions
on connecting devices to your computer and setting

instructions and/or the Microsoft MS Windows®
documentation.

3 Start BERNINA Embroidery Software.
4 Select Settings > Scanner Setup.
The Select Source dialog opens displaying a list
of scanner drivers loaded on your computer.

Select
scanning
driver

5 Select the scanning driver to use, then click
Select.
Note If you have trouble with scanning after
re-starting BERNINA Embroidery Software, there
may be a conflict with previously installed scanner
drivers. Re-install BERNINA Embroidery Software
and test the scanner. If the selected scanner driver
does not work in BERNINA Embroidery Software,
select another scanner driver from the list. There
are usually two installed for each scanner.
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Calibrating the monitor

Onscreen documentation

Your monitor needs to be correctly calibrated so that
designs at 1:1 scale appear at real size. In most cases
this the software will self-calibrate on later versions of
Windows OS. However, it’s a good idea to check
screen calibration when you first install BERNINA
Embroidery Software or whenever you change
monitors.

Onscreen documentation is provided in two formats –
HTML Help and Adobe Acrobat. Depending on your
product level, documentation components will include
some or all of the following:

To calibrate the monitor

1 Select Settings > Calibrate Screen.
The Calibrate Screen dialog opens.

Release notes
A set of release notes is included with the software
installation. These provide detailed information about
new and improved features as well as direct links to
the relevant sections of the Reference Manual.
Reference manual

Measure
height

Measure width

2 Measure the height and width of the dialog box.
3 Enter the measurement in the Width and Height
fields.

The Reference Manual provides detailed procedures
covering all features of the BERNINA Embroidery
Software ‘Embroidery Canvas’. It contains
step-by-step instructions together with samples and
screen images. The BERNINA Cross Stitch and
BERNINA Quilter applications are documented in
separate supplementary manuals described below.
Note For a full description of the CorelDRAW® tools
available in Artwork Canvas, refer to the electronic
User Guide available via the Windows Start >
Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.
Onscreen help

4 Click OK.

Onscreen help provides quick access to general
information on BERNINA Embroidery Software
features and step-by-step instructions. An F1
keypress accesses context-sensitive help.

Resources & support
BERNINA Embroidery Software provides various ways
to access information about the software and how to
use it. It also provides links to sources of ready-made
embroidery designs.

Access onscreen
documentation

Access BERNINA and
OESD embroidery
design studios

Order and install
upgrades

Supplementary help
With your BERNINA Embroidery Software installation,
you will have also received the following
supplementary help:
 BERNINA Cross Stitch: This covers the capabilities
of the special BERNINA Cross Stitch application.
See also Cross stitching.
 BERNINA Quilter: This covers the capabilities of
the special BERNINA Quilter application. See also
Quilting.

Online resources
There are many other sources of ready-made
embroidery designs which you can purchase and
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adapt as you wish. Your BERNINA Embroidery
Software directs you to two rich sources – BERNINA
and OESD embroidery design studios.

Conventions used in the manual
The following conventions are adopted and used
throughout the manual.
Commands
In this manual, commands on a menu or submenu are
referred to by both the menu and command names.
For example the ‘Show all Colors’ command in the
‘View’ menu is referred to as View > Show all
Colors.
Dialog boxes
Dialog boxes are referred to as ‘dialogs’ and are
shown in the manual only if they provide important
information on using BERNINA® Embroidery
Software. The screen images provided are intended to
be representations, not exact duplicates of the
layouts generated by the software.
Keyboard conventions
Instruction

Symbol

Action

Click

[

Click the left mouse button.

Right-click

]

Click the right mouse button.

Double-click

.

Click the mouse button twice
without moving the mouse.

Click OK

[or j

Click OK with the mouse or press
the Enter key on the keyboard to
complete the action.

Keyboard shortcuts
Shortcut

Action

C+S

While holding down the Control key (Ctrl),
press the S key to save design.

For a complete list of keyboard shortcuts, see Keyboard
Shortcuts.
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PART I
THE BASICS
Designs created in BERNINA Embroidery Software are composed of ‘embroidery
objects’. They are called ‘objects’ because they are discrete entities which can be
manipulated independently of each other. Each object has certain defining
characteristics or ‘properties’ such as color, size, position, and so on. The most
important property of an embroidery object is its stitch type.

Getting started
BERNINA Embroidery Software provides embroiderers with a fast, flexible way of
creating and editing embroidery designs. This section outlines the main uses you will
make of your BERNINA Embroidery Software, together with references to the sections
of the reference manual where you can obtain more in-depth information. See Getting
Started for details.

Basic procedures
This section describes how to start BERNINA Embroidery Software and access the
available commands and tools. It covers basic procedures to do with opening, creating
and saving design files. It explains how to activate hoops and grids and it covers
accessing object properties. See Basic Procedures for details.

Managing designs
This section describes how to open and view designs in Embroidery Library as well as
adjusting viewing settings. It also covers browsing for and accessing designs in folders.
See Managing Designs for details.

Viewing designs
This section explains the design viewing modes available in BERNINA Embroidery
Software as well as the various design viewing settings. It describes zooming and
panning as well as how to view the stitching sequence. It covers displaying design
backdrops and changing backgrounds. It also explains how to obtain information about
your designs. See Viewing Designs for details.

Selecting objects
This section describes how to select objects using the selection tools and keyboard. It
also shows how to select color blocks or individual objects using the Color Film. See
Selecting Objects for details.

Software setup
This section describes how to set up embroidery machines, and scanners and describes
how to calibrate the monitor. It also deals with changing grid spacing and hoop options.
The setting of general options – such as automatic save, pointer position display
options, etc – is also covered. See Software Setup for details.
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CHAPTER 2
GETTING STARTED
If you are new to BERNINA Embroidery
Software or machine embroidery, you
are probably asking yourself ‘where do I
start?!’.
It’s safe to say that you will spend many
hours learning how to get the most out
of your BERNINA embroidery machine
and the design software which supports
it. The two work together hand-in-hand
and it takes practice and patience to
master both the creation and production
of fine embroidery.
The results, however, will speak for
themselves, making the time you invest
all the more valuable. With each project
you complete, you will gain in
experience and confidence and be ready to tackle the next challenge.
This section outlines the main uses you will make of your BERNINA Embroidery
Software, together with references to the sections of the reference manual where
you can obtain more in-depth information.

First things first
You don’t need any experience to start with BERNINA
Embroidery Software. You can simply open a design
and send it to your machine to ‘stitch out’. And this is
the best place to start. As you gain experience, you
will be able to ‘read’ designs and identify which are
good and which may cause problems.

files (ART files) and images (BMP, JPG, and WMF files)
can be found in your Embroidery and Picture libraries.

Embroidery library

Sample designs & artwork
BERNINA Embroidery Software contains hundreds of
ready-to-stitch designs, including many attractive
ornaments, samples and digitizing backdrops. Design

Picture library
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The most valuable thing you can do when starting out
as a new user, is to spend some time exploring these
designs and getting to know what’s available.

Clipart
CorelDRAW® Essentials X6 is packaged with a
selection of clipart which can be accessed via the
program group.
Access CorelDRAW®
clipart folders

Make sure you get familiar with the many clipart
samples. Many can be adapted for use with
embroidery design, either as digitizing backdrops or
direct conversion. See also Browsing clipart.

Note BERNINA Embroidery Software includes its own
Embroidery Library design management
application to view and manage your embroidery
designs. Alternatively, explore design folders using
MS Windows® Explorer.

Other sources
There are many other sources of ready-made
embroidery designs which you can purchase and
adapt as you wish. Your BERNINA Embroidery
Software directs you to two rich sources – BERNINA
and OESD embroidery design studios.
It may be more convenient to take a copy of the entire
CorelDRAW® Essentials X6 Clipart folder and copy it
to My Designs - Embroidery Software 8 folder for
easy reference.

Access BERNINA and
OESD embroidery
design studios

Caution Included artwork (clipart) and embroidery
designs are only available for personal use – i.e. they
cannot be commercially sold in any form.

Rules of good embroidery
Keep the following points in mind when looking at
embroidery designs, both your own and others:
 Stitches are neat, smooth and even
 Design looks good – shapes, colors, balance
 Shapes are filled with correct fill and outline
stitches
 Stitches are angled to match shapes
 Shapes are stitched correctly – no unwanted gaps
 Details are clearly defined
 Lettering is clear and easy to read.
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The stitchout should also have the following
characteristics:

To sew out a design

 The design sews efficiently on the machine

1 Open the design in BERNINA Embroidery

 The fabric does not pucker around stitched areas

Software. See Opening designs for details.

 The design is free of loose ends.
Good embroidery quality starts with good design. You
then need a good quality machine to stitch it out. But
even that is not enough if you do not use the correct
fabric, threads, backings, tension, and so on. Consult
your machine manual for advice and get as much
advice from other embroiderers as you can.

Working with embroidery
Before starting, let’s take a look at the scenarios that
you will find yourself working with. Typically, you will
be involved in one or all of the following:
 Take a ready-made design and sew it out
 Make global changes to a design
 Create a lettering design
 Combine lettering with a design
 Adapt a design by changing parts
 Create new embroidery from artwork using
automated techniques
 Create new embroidery manually
 Use special embroidery features

2 Adjust viewing settings as desired. See Viewing
Designs for details.

3 Check the fabric type and change as necessary.
See Status bar for details.

4 Check thread colors and if necessary, change
charts to suit the one you are using. See Assigning
thread colors for details.

Let’s look at those cases one by one.

5 Preview the stitchout so you understand how the

Sew a ready-made design

6 Choose a hoop and check location within the hoop.

For many embroiderers, it is enough to take an
existing design and stitch it out. This is certainly
where most will start. Once you have found a design
you like, you will want to preview it to see how it will
sew out. A number of steps are involved. We outline
the main ones here with reference to the manual.

design will sew on the machine. See Viewing stitch
sequence for details.
See Selecting hoops for details.

7 Preview the design and print out a design
worksheet before sewing out as desired. See
Printing designs for details.

8 Send the design to machine directly or via data
media (usually memory stick). See Stitching out
designs for details.
Check your BERNINA machine documentation for
steps involved after transferring the design to
machine.

Modify an entire design
Once you are used to the steps involved in sewing out
designs – either clipart or ones you have purchased –
you will soon want to make global design
modifications such as resizing, or changing thread
colors and fabric types. These are all relatively simple
operations.
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To modify an entire design

6 Visualize the design on a garment or article. See
Visualizing finished articles for details.

1 Open the design you want to use. See Opening
designs for details.

7 Print a worksheet and send the design to machine.
2 Check design dimensions, and resize as required.

See Printing designs and Stitching out designs in
the Reference Manual for details.

See Scaling objects for details.
For example, if you are stitching a left chest
design, maximum size will be approximately 4.25"
or 108 mm square.

3 Adjust design thread colors as desired. See
Changing thread colors for details.

Create a simple lettering design
Once you are used to sewing out designs and resizing,
changing colors and fabric types, you will definitely
want to create your own lettering designs. While it
takes practice to obtain a good quality lettering
stitchout, it is as simple as typing letters on-screen to
create attractive lettering in BERNINA Embroidery
Software.
To create a simple lettering design
 Typically you’ll want to add lettering to an existing
design.
 Add embroidery lettering to designs quickly and
easily, either on-screen using current settings or
via ‘object properties’. See Adding lettering to
embroidery designs for details.

4 Check the fabric type and change as necessary.
See also Changing fabrics.

5 Select a hoop of the required size. See Selecting
hoops for details.
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 It’s then a simple matter to adjust baselines,
formatting, spacing settings, and colors. See
Lettering Essentials for details.

borders in your monograms. See Monogramming for
details.

Borders stitched
first – 1, 2, 3, etc
Ornaments
stitched next

Lettering
stitched last

 Try stitching out your lettering design. Study the
stitch quality. Be aware that different fonts sew out
better at different sizes. See also Embroidery
Fonts.

Create more advanced lettering
Once you have tried your hand at creating lettering
designs and sewing them out, you will want to do
more adventurous things, such as monograms, fancy
lettering, flair scripts, raised lettering with trapunto,
as well as special ‘elastic lettering’ effects. The
creative possibilities are endless. Your appetite to try
new things will be stimulated as you gain experience
and confidence. Part of that involves becoming adept
at using your BERNINA machine as well as sampling
and checking design quality.

Monogramming

Fancy fonts
BERNINA Embroidery Software includes a number of
fancy fonts such as Creative Cross and Secret
Garden-Caps. These fonts include multiple colors
and miniature designs. See Adding fancy lettering for
details.

Flair script is a special font which allows you to add
decorative flairs to the end of text objects, mimicking
flamboyant handwriting flourishes. See Adding flair
script lettering for details.

BERNINA Embroidery Software makes the creation of
monogramming designs quite simple with the
‘all-in-one’ Monogramming tool. Optionally include
lettering, ornaments, and/or up to four concentric

Lettering stitch effects
By default, lettering objects are filled with satin
stitching. You can apply other fill stitch types, such as
Step or Fancy, as with any embroidery object. See
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Applying different stitch types & effects to lettering
for details.

types and effects, etc. Here is a sampling of the things
you may want to try.

Combine designs
One technique you will undoubtedly use is combining
design elements. This will in turn teach you a lot
about other editing operations such as resizing,
positioning, rotating, sequencing objects, as well as
removing underlying stitching. See Inserting designs
for details.

Elastic lettering
Apply ‘elastic lettering’ effects to embroidery lettering
to make it bulge or arch, stretch or compress. See
Creating ‘elastic lettering’ effects for details.

Transform design elements
Depending on the type of design work you are doing,
you can make use of BERNINA Embroidery Software
tools for duplicating, rotating, and mirroring design
elements to create wreathes, kaleidoscopes, and
other effects. See Mirroring objects for details.

Tip Remember to study the sample designs included
with your BERNINA Embroidery Software installation.

Adapt a design
Reshape elements
Adapting designs is perhaps the most common
scenario in embroidery. You will sometimes want to
create a new design, usually from artwork, but more
often you will want to take an existing design and
‘re-purpose’ it. We’ve already seen how to make
global changes such as sizing, changing colors and
fabrics. It won’t be long before you want to try more
‘invasive’ changes such as reshaping, removing,
combining, duplicating, resequencing, changing stitch

Reshaping operations may be called on for anything
from minor modifications to object shapes to
reshaping letters for special effects. In all cases, if it
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is selectable, it can be reshaped. See Reshaping &
Editing Objects for details.

Vector artwork conversion
Special conversion tools in BERNINA Embroidery
Software automatically convert vector objects and
text to embroidery or lettering objects. These can be
modified as required. See Converting vector artwork
for details.

Apply artistic stitch effects
It won’t take long before you get bored with simple
fills and outlines and want to try out some of the
many artistic stitch types and effects BERNINA
Embroidery Software provides. See Decorative
Stitching, Stitch Effects and Stitch Patterns.
Tip A good starting point is to use some of the many
clipart samples packaged with CorelDRAW®. Many of
these can be adapted for use in embroidery design.

Bitmap artwork conversion
The Magic Wand tool provides everything necessary
to digitize shapes in bitmap images automatically. An
extension of this technology, Auto-Digitize
recognizes shapes in artwork and makes decisions
about the most suitable stitch types to use. See
Auto-digitizing with Magic Wand and Auto-digitizing
with Auto-Digitize in the Reference Manual for details.

Tip Remember to study the sample designs included
with your BERNINA Embroidery Software installation.

Create ‘automatic embroidery’
If you have graduated this far in your exploration of
your BERNINA machine and BERNINA Embroidery
Software, you are doing well. You can already achieve
a great deal without having to actually do your own
design or digitizing work. However, if you have
graduated this far, that is probably exactly what you
want to do!
One of the quickest ways to get started is to use the
automated techniques BERNINA Embroidery Software
provides. While there are limitations to what can be
done this way, it nevertheless allows you to prototype
design ideas relatively simply and may be sufficient
for your purposes. At least for now!
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Photographic conversion

 internet or CD clipart

Use the powerful Color PhotoStitch tool to create
embroidery from photographs and other images. See
Auto-digitizing with Color PhotoStitch for details.

 children’s art
 your own original artwork.
And remember that a good starting point can be
found with some of the many clipart samples
packaged with CorelDRAW®. Many of these can be
adapted as ‘digitizing backdrops’.

Prepare your artwork
Before digitizing, you need to analyze and plan design
shapes and stitching sequence carefully. Design
shapes need to be clearly defined to make them easy
to embroider. The easiest shapes to embroider have a
relatively constant width, with smooth edges, no
sharp turns and no small, protruding details. See also
Digitizing with Backdrops.

Create new embroidery from scratch
If you have reached this point, you have already
mastered 90% of the techniques that most
embroiderers need. However, coming to grips with the
‘black art’ of manual digitizing is the next step in
becoming an embroidery master. But you don’t have
to dive off the deep end. You can start with quite
simple projects and work your way up to more
complicated designs with more complicated stitch
effects.

Simplify edges in artwork
before or during digitizing

Digitize your design
In BERNINA Embroidery Software, you build designs
from basic shapes or ‘embroidery objects’. The
process of creating embroidery objects on-screen is
called ‘digitizing’.

Start with good artwork
2

To create good quality embroidery, you need to
choose suitable artwork for use as a digitizing
backdrop. Unless you are an experienced digitizer,
don’t use complicated artwork.
1

3

Scanned in 256
color mode

Scanned in RGB color
mode (millions of colors)

Artwork that is not in digital format needs to be
scanned. This can be done via CorelDRAW® which is
included with BERNINA Embroidery Software.
Possible sources include:

As with creating designs in graphics applications,
embroidery digitizing involves the use of different
tools or methods. These are used in conjunction with
stitch types to create embroidery objects. See
Digitizing Methods for details.

Choose stitch types
Decide which stitch types you will use for each design
shape. BERNINA Embroidery Software lets you

 books
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change them at any stage. See also Outline & Fill
Stitching.

regard is choice of fabric type. See Changing fabrics
for details.

Woven Medium Weight

Sequence your design elements

Woven Heavy Weight

Other factors come into play such as choice of
underlay type. See Stabilizing with underlays for
details.

Design sequence is the order in which objects are
created and therefore in which they are stitched out.
You can change the object sequence to improve
sewing – for example, to minimize color changes.
Details should be stitched last. See also Sequencing
embroidery objects.

Zigzag underlay

Edge Walk
underlay

Pull compensation is the other stitch quality setting
which you may have to consider, although default
settings are generally sufficient. See Compensating
for fabric stretch for details.

4 color changes
6 color changes
Pull compensation

Improve stitch quality
Through trial and error you will get a feel for the
issues that affect stitch quality. BERNINA Embroidery
Software automates many of the quality issues such
as stitch bunching, push-pull effect, and embroidery
stability. This single most important setting in this

Digitized outline

Calculated outline

Use special embroidery features
Once you have mastered manual digitizing, you are in
a position to take advantage of the full range of stitch
types and effects that BERNINA Embroidery Software
offers. Many of them you will be familiar with, having
already adapted existing designs for different
purposes.

Freehand embroidery
Some of them, like Freehand Embroidery, cannot
be applied to existing objects but must be digitized
from scratch. This is a technique that lets you create
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designs with a hand-drawn appearance, something
which is difficult to achieve through conventional
digitizing methods. The aim is to mimic designs
formed on an embroidery machine by freehand
motion. The difference is that the fabric secured in an
embroidery hoop, allowing the needle to ‘draw’ on the
fabric surface, exactly as you have drawn on-screen.
See Creating freehand embroidery for details.

suitable for both outlines and fills. See Creating craft
stitches for details.

Appliqué

Patterned stamps, runs & fills

Appliqué is an important craft in home sewing, and
the Appliqué feature provides an easy way to create
quality work. Use it to generate the stitching you
require for closed-object appliqué. See Digitizing for
Appliqué for details.

Patterns are pre-defined design elements, such as
hearts, leaves or border patterns, that can be quickly
inserted into a design. They generally consist of one
or more simple objects, and are stored in a special
pattern set. Use them to create patterned borders or
fills, or use them standalone. See Embroidery
Patterns for details.

Cross stitching
Craft stitch borders & fills
BERNINA Embroidery Software provides a range of
craft stitches which you can use to mimic some
traditional hand-worked embroidery. They include a
large range of blackwork and candlewicking patterns

Cross stitching is a popular technique for filling large
areas with low stitch counts. It can also be used for
outlines and borders. It is suitable for homeware,
tablecloths, children’s clothes and folk designs. Cross
stitch is sometimes combined with appliqué. The
BERNINA Cross Stitch application lets you create
dedicated cross stitch designs or add cross stitching
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to embroidery. See BERNINA Cross Stitch Supplement
for details.

without a central design element. See Quilted
embroidery for details.

Quilting
Patchwork is a popular technique for designing and
sewing patches into blocks. BERNINA Quilter can be
used to design patchwork quilts, either from existing
designs or patterns, or from designs of your own
making. Use BERNINA Quilter to experiment with
patches and colors enabling you to create beautiful,
personalized quilts. See BERNINA Quilter Supplement
for details.

Buttonholing
BERNINA Embroidery Software allows you to insert
preset buttonholes, either singly or in a line. You can
specify their size and merge them into a design. See
Creating buttonholes for details.

Multi-decoration
With the inclusion of CorelDRAW®, BERNINA
Embroidery Software supports multi-medium design.
A popular technique is to combine digital print with
embroidery to create multi-decoration work. This is
intended to be both digitally printed and embroidered.

Embroidery quilting
Quilted embroidery creates dimension by stuffing or
filling areas to produce a raised surface. It employs a
technique known as ‘trapunto’, also referred to as
‘stuffed embroidery’. Using Layout tools, it’s a simple
matter to define quilt blocks of specified size. You can
then arrange elements around the block, with or
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Typically, transfer paper is used together with a
normal color printer. Images are reversed during
printing and the transfer then ironed onto the
garment. Check the available options and use one
that lets you reverse the image.

This will alert you to the key issues to consider when
doing your own work.
All the best. And have fun!

Raised embroidery
Finally, if you have exhausted all the techniques
outlined above, or if you have a particular interest in
fiber-arts crafts, you may be tempted to lift your
embroidery right off the canvas so to speak, and
venture into raised or ‘sculpted’ surfaces. Thankfully
BERNINA Embroidery Software provides some smart
methods to make this easier for you to achieve. See
Raised Embroidery for details.

Happy embroidery!
Do good work with your BERNINA machine and
BERNINA Embroidery Software. With this equipment
you have everything you need to create top quality,
fully professional embroidery. The only thing you lack
is the capacity to mass produce!
Remember that Rome wasn’t built in a day. It takes
practice and patience to master all the techniques and
approaches outlined above. But the results will more
than reward the time you invest in the fascinating art
and craft of embroidery decoration.
Remember to make good use of the packaged designs
and clipart. When in doubt, go back to first principles.
And when you find you want to expand and extend
your repertoire, study the sample designs carefully to
see how it’s done.
As a final word of advice, try stitching out sample
designs before you embark on your own creations.
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CHAPTER 3
BASIC PROCEDURES
To start using BERNINA Embroidery Software,
you need to know the basic procedures, such
as starting up, opening and creating designs,
and saving. Once you start BERNINA
Embroidery Software, you use commands or
icons, and dialogs to complete your tasks. You
select commands in the same way as other
MS Windows® applications – from menus or
toolbars.
BERNINA Embroidery Software opens a range
of native ART files, as well as some other
embroidery file formats, from computer hard
disk, USB stick, or CD-ROM. BERNINA
Embroidery Software gives you a wide range of
standard factory-supplied hoops to select
from. Grid lines help you accurately align or
size embroidery objects. The most important
dialog in BERNINA Embroidery Software is the Object Properties dialog. This and
the Effects dialog are ‘modeless’, meaning that they stay on the design window
as long as you need them.
Note This section describes how to start BERNINA Embroidery Software and
access the available commands and tools. It covers basic procedures to do with
opening, creating and saving design files. It explains how to activate hoops and
grids and it covers accessing object properties.

BERNINA Embroidery Software
interface
BERNINA Embroidery Software integrates with
CorelDRAW® Essentials X6 into a single application,
allowing users to create, not just embroidery, but
true, multi-medium designs. The application has one
workspace or ‘design window’ but you interact with it
in separate operating modes: Artwork Canvas and
Embroidery Canvas. A third mode, Multi-Hooping,
is available for multi-hooping large designs.

Starting the software
Double-click to start BERNINA® Embroidery
Software.
BERNINA Embroidery Software can be opened via the
desktop icon or MS Windows® Start menu. It
defaults to Embroidery Canvas. This allows you to
create and edit embroidery objects using the
embroidery digitizing toolset.
To start BERNINA Embroidery Software
 Double-click the BERNINA Embroidery Software
shortcut icon on the MS Windows® desktop or
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select it via the Windows Start > Programs
group.
BERNINA Embroidery Software opens in
Embroidery Canvas with a new, blank design
(Design1). The screen image below displays an

exploded view of all toolbars in the BERNINA
DesignerPlus product. Depending on your product
level, you will have access to some or all of these
options.

Title bar
Menu bar
Toolboxes
Canvas toolbar

Docker panel

General toolbar
View toolbar
Design window

Zoom toolbar
Transform toolbar

Stitches toolbar

Effects toolbar

Color palette
Status bar

 Customize the design window by showing or hiding
the grid, changing the grid dimensions, as well as
showing and hiding toolbars. See Displaying the
grid for details.

designs, including drag and drop operations.
Optionally, you can tile multiple design tabs.

 Dock or ‘float’ toolbars and dockers in any
configuration that suits.
Toolbars are dockable left, right, top and bottom,
and can be ‘floated’ anywhere in the design
window. The Color Palette and Stitch toolbars
can be docked vertically for convenience. See also
Quick Reference.
 BERNINA Embroidery Software allows you the
choice of large or small button icons with or
without text names. See Setting general options
for details.

Design tabs
BERNINA Embroidery Software makes it easy to see
and switch between open designs with new design
tabs. This also makes it easy to copy/paste between

Docking panes
BERNINA Embroidery Software includes ‘dockers’ for
key functions. Embroidery Canvas has docking
panes for Color Film, Carving Stamps, Morphing
Effects, StumpWork, as well as an Overview
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Window. All panes are dockable at the right side of
the design window.

 File type: indicates grade of ART design –
BERNINA Embroidery Software native ART designs
are classified in four grades depending on how the
file was created. See Embroidery design formats
for details.

Operating modes

Nested dockers

Dockers can be ‘nested’ to increase available
workspace. When nested, tab buttons for each dialog
appear to the side. All dockers can be fixed or
minimized. By hovering the mouse over the tab, a
minimized docker will ‘fly out’, allowing you to access
its functions. It automatically minimizes when not in
use. Dockers may also be ‘floated’ by dragging the
caption bar to the design window or double-clicking it
when ‘pinned’ in place.

Status bar
A Status Bar at the bottom of the Embroidery
Canvas design window provides continuous display
of current cursor position status as well as
instructions for use of selected tools.
Position indicators:
X, Y, L and A

Prompt message
Stitch count

BERNINA Embroidery Software has one workspace or
‘design window’ but you interact with it in different
modes or ‘canvases’. These are accessed via the
Canvas toolbar.

Artwork Canvas
Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
In Artwork Canvas mode, click Canvas > Show
Embroidery to Show or hide any embroidery
components.
Below is a screen image of the Artwork Canvas
workspace which is accessed via the Canvas toolbar.
This mode allows you to create and edit vector
graphics using the CorelDRAW® Essentials X6 toolset

Design width and height
File type

Current fabric

Information displayed includes:
 Prompt message: guides you through use of
selected functions
 Design size – width and height
 Coordinates of current needle position (X/Y), and
length (L) and angle (A) of current stitch. See also
Measuring distances onscreen.
 Stitch count: total number of stitches in design
 Current fabric: fabric settings take into account
the type of fabric you are stitching on. See also
Changing fabrics.
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which offer many sophisticated techniques for
drafting outlines and shapes onscreen.

objects using the embroidery digitizing toolset. See
also BERNINA Embroidery Software interface.

In addition to the CorelDRAW® Essentials X6 toolset,
Artwork Canvas provides capabilities to convert
vectors and vector text directly to embroidery
objects. Vector graphics or text created or imported
into the Artwork Canvas can be converted directly
to embroidery designs. You can use Artwork Canvas
to insert or paste third-party vector graphics such as
clipart for use in embroidery designs. Alternatively,
insert, paste or scan bitmap artwork for use as
digitizing templates or ‘backdrops’. See Loading
vector artwork for details.

Use this mode when you want to create embroidery
from digitizing ‘backdrops’. Various types of image file
can be loaded in BERNINA Embroidery Software. See
also Digitizing with Backdrops.
Embroidery Canvas also offers a graphical
representation of what the final embroidery will look
like. Use Show Artistic View together with a
background fabric to see how your design will look
when stitched out. See also Backdrops &
backgrounds.

Embroidery Library
Note For a full description of the
CorelDRAW® Essentials X6 tools, refer to the
electronic User Guide available via the Windows Start
> Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.

Embroidery Canvas
Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.
Below is a screen image of the Embroidery Canvas
workspace which is accessed via the Canvas toolbar.
This mode allows you to create and edit embroidery

Use Canvas > Embroidery Library to view and
manage all embroidery designs and artwork on your
system.
The built-in Embroidery Library provides an efficient
way to view and manage embroidery designs. It
recognizes all design file formats used by the
software. The library also makes it easy to search,
sort and browse all embroidery designs on your
system. In a nutshell, it lets you:
 Find designs anywhere on your local hard drive or
external device such as USB or ZIP drive.
 Search for designs by various means, including
known design information.
 Create an organizing structure for easy
categorization.
 Batch-convert selected design files to many
machine formats such as JEF, SEW, DST, EXP, and
others.
 Print selected designs or send them to embroidery
machine for stitchout.
 Find embroidery designs anywhere on your hard
drive or external storage device and, optionally,
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add them to your embroidery library. See
Managing Designs for details.

Undoing & redoing commands
Use General > Undo to cancel last command or
series of commands.
Use General > Redo to re-apply cancelled
commands.
You can undo the effects of most commands. If you
change your mind, you can redo them again.
BERNINA Embroidery Software remembers the last
few commands you used.
To undo and redo a command
 To undo a command, click the Undo icon.
When BERNINA Embroidery Software cannot
remember more commands, Undo is dimmed.
 Click the Redo icon to re-apply an ‘undone’
command.

Using commands & tools
Once you start BERNINA Embroidery Software, you
use commands or icons, and dialogs to complete your
tasks. You select commands in BERNINA Embroidery
Software in the same way as other MS Windows®
applications – from menus or toolbars. Keyboard
shortcuts are also available for the most frequently
used commands. See Keyboard Shortcuts for details.

Selecting commands from toolbars
Toolbars provide quick and easy access to BERNINA
Embroidery Software commands. Click a toolbar
button to activate a command or, where applicable,
right-click to set its properties.
To select commands from toolbars
 Rest the pointer over an icon to see its name in a
‘tooltip’.

Toolbox & toolbars
BERNINA Embroidery Software contains a ‘toolbox’
which is permanently docked to the left of the design
window. In addition, toolbars provide quick and easy
access to BERNINA Embroidery Software commands.
Toolbars are ‘dockable’. This means you can move
them around the design window.
To move or dock a toolbar
 To move a toolbar to a more convenient location,
click and drag it:
 Toolbars are dockable left, right, top and
bottom.
 They can be ‘floated’ anywhere in the design
window.
Toolbox ‘digitize’
toolset

 Click the icon to activate the command.
 Right-click to adjust settings or activate the
secondary command.
For many tools, right-click accesses current
command settings. For example, left-click
Lettering selects the input method, while
right-click accesses Object Properties.
Dockable
‘General’ toolbar

Note Object properties can be modified with or
without objects selected. The former affects only
selected objects. The latter affects current
settings. See also Working with object properties.
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 To dock it in its normal position, double-click the
toolbar title.

Popup menu for easy editing
Right-clicking a design or selected object invokes a
popup menu which provides access to useful
commands in context.

attractive ornaments, samples and digitizing
backdrops. Design files (ART files) and images (BMP,
JPG, and WMF files) can be found in your My Designs
- Embroidery Software 8 folder. The most valuable
thing you can do when starting out as a new user, is
to spend some time exploring these designs and
getting to know what’s available. See also Managing
Designs.
To open a design

1 Click the Open Design icon.
The Open Design dialog opens.

Working with design files
Characteristics include:
By default BERNINA Embroidery Software saves
designs to its native ‘ART’ file format. This format
contains all information necessary both for stitching a
design and for later modification. BERNINA
Embroidery Software opens a range of native ART
files, as well as some other embroidery file formats,
from computer hard disk, USB stick, or CD-ROM. You
can save designs in ART as well as other file formats.
See Working with Machine Files for details.

 Large, re-sizeable Open Design dialog with
full folder browsing.
 Windows Explorer search ability within the
dialog.
 More extensive design preview info panel like
Windows Explorer.
 Design thumbnails and preview ranging from
small to extra large.

2 Select a folder from the Look In list.
You can read designs stored on USB stick or
CD-ROM, as well as computer hard disk.

Caution You cannot open ART files created with a
later version of the software to the one you are
running. If you attempt to, you will be prompted to
update your system to the current version.

3 If the design is not in ART format, select a file type

Opening designs

4 Select a design or designs.

Use General > Open Design to open an existing
design.
BERNINA Embroidery Software opens a range of
embroidery files in addition to its own ART format.
Native ART designs are classified in four grades
depending on how the file was created. See also
Starting the software.

from the Files of Type list. See Working with
Machine Files for details.
 To select a range, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you
click.

5 Select the Preview checkbox to preview the
design (for supported file formats) together with
design data. This includes stitch and color
numbers, design height and width, and software
version number.

Note BERNINA Embroidery Software contains
hundreds of ready-to-stitch designs, including many
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6 Click Open.

 To use custom settings, select File > New from
Template.

Choose a
template
Choose a target
fabric

Set background
color and swatch

Note By default, designs are automatically
grouped upon opening or insertion into another
design. See Setting other general options for
details.

7 Check the design size in the Status Bar. See
Status bar for details.

8 Set the zoom factor and other viewing settings as
required. See Viewing Designs for details.
Note You can also read designs from your
embroidery machine memory or BERNINA design
card. See Working with Machine Files for details.

Starting designs
Use General > New Blank Design to create a new
empty design.
When you create a file, template settings are copied
into the new design. Templates contain pre-set styles,
defaults or objects, to make digitizing quicker and
easier. You can choose to base default settings on a
selected template as well as fabric settings.
Optionally, choose a background fabric swatch to
match selected fabric settings. See also Properties,
Fabrics & Templates.
To start a design
 Click the New Blank Design icon.
A blank design opens in the design window based
on the NORMAL template.

 Select a template from the list and click OK. See
also Properties, Fabrics & Templates.
The only template available when the software is
first run is the NORMAL template.
 Optionally, choose a fabric type from the droplist.
Fabric settings are a subset of template settings,
fine-tuned to different fabric types. Selecting a
matching fabric automatically customizes object
properties for the intended fabric. See also
Changing fabrics.
 Optionally, choose a background fabric swatch to
match selected fabric settings.

Saving designs
Use General > Save Design to save the current
design.
BERNINA Embroidery Software designs can be saved
in pure ART format as well as a number of non-native
formats. Saving a design records its file name,
location and format, and updates it with any changes
you make. When you save an existing design under a
new name, to a different location or format, you
create a copy of the original design. See also Working
with Machine Files.

Tip Save your designs early and often. Do not wait
until you finish working. To save changes to an
existing file but preserve the original, use Save As.
Once you have saved a design, every time you click
Save Design on the toolbar the file will be updated.
To save a design

1 Click the Save Design icon.
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If this is the first time you have saved the design,
the Save As dialog opens.

The Options > Machine & Hoop dialog opens.

Folder containing
design

Design name

Format list

 Choose your machine. The hoop list is filtered to
display compatible hoops.

Choose your
machine

2 Select the folder where you want to save the
design from the Save In list.

3 Enter a name for the design in the File name field.
4 Select a file format from the Save as type list.
See Supported machine file formats for details.

 Select a hoop to suit your current design.

5 Click Save.
Choose a
suitable hoop

Note You can also write designs to your
embroidery machine memory or BERNINA design
card. See Writing designs to machine for details.

Hoops, grids & rulers
Fabrics should be hooped before stitching out on the
machine. BERNINA Embroidery Software gives you a
wide range of standard factory-supplied hoops to
select from. Grid lines help you accurately align or
size embroidery objects.

 Click the Show Hoop Template icon to toggle
hoop template display.

Displaying the hoop
Click View > Show Hoop to show or hide hoop.
Right-click for settings.
Click View > Show Hoop Template to show or hide
hoop template.
Whenever you create a new design, a single hoop
representing the one you attach to your embroidery
machine appears by default in the design window. As
you position objects, the hoop position adjusts
automatically so that it is always centered around
objects in the window. See also Selecting hoops.
To display the hoop

Displaying the grid
Click View > Show Grid to show or hide workspace
grid. Right-click for settings.

 Click the Show Hoop icon to toggle hoop display. Use grid lines to help accurately align or size
embroidery objects. You can show or hide the grid.

 Right-click the Show Hoop icon.
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Tip You can change the grid spacing, select a
reference point and turn Snap to Grid on or off in the
Options dialog. See Setting grid options for details.
See also Adjusting display colors.
To display the grid
 Click the Show Grid icon to turn on the grid
display.

To display rulers & guides
 Click the Show Rulers & Guides icon or press
Ctrl+R.
Click-and-drag to
reset ruler zero
point
Click-and-drag to
reposition guides
Click ruler to
create new guide
Drag guide off
ruler to remove

 Reset the ruler zero point by clicking and dragging
the box in the top left-hand corner to the required
point in the design.
 Click the Show Grid icon again to turn off the grid
display.

Displaying rulers & guides
Click View > Show Rulers & Guides to show or hide
workspace rulers and guides. Right-click for settings.

 To create a guide, click on either ruler – horizontal
or vertical – and click-and-drag it into position.
Multiple guides can be created and just as easily
removed.
 For more accurate positioning of guides,
double-click the yellow handle. In the Guide
Position dialog, enter a precise distance from the
zero point, and click OK.

Drag the Ruler Zero Point to reset a new ruler zero
point.
Enter precise
position

The software allows you to turn rulers on and off and
create guides for more accurate digitizing. These
make it possible to accurately position and size
objects and whole designs. The unit of measurement
– mm or inches – defaults to the regional settings in  To remove a guide, drag the yellow guide handle
off the design window.
the MS Windows® Control Panel. These, however, can
be changed from within the software. See also Setting
measurement units. See also Adjusting display colors.
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Specifying measurement units on-the-fly
Tip You can turn Snap to Grid and Snap to
Guide on or off in the Options dialog. See also
Setting grid options.

As an alternative to changing the overall
measurement system used in BERNINA Embroidery
Software, you can specify units of measurement when
typing values into a measurement control. The
software automatically converts the entered value
into the units of the control.
Specify desired unit
of measurement

Select to snap
design points to
grid
Enter grid
spacing

Setting measurement units
The first time you run BERNINA Embroidery Software,
the measurement system will default to whatever the
operating system is using. You can use different
measurement units within BERNINA Embroidery
Software without having to exit and change system
settings.
Accessing the feature
The measurement system may be changed via a
droplist on the General toolbar:

Say, for example, you are using the metric
measurement system so your lettering heights are in
mm. Simply enter ‘3/4in’ or ‘3/4 in’ into the
Lettering Height field and it is automatically
converted to 19.05mm. Supported units include:

 millimeters, mm
 inches, in
 feet, ft
 yards, yd
 centimeters, cm
 meters, m
Tip BERNINA Embroidery Software also allows
entering units in text form, both English and the
language the software is currently running in.

Select desired
measurement unit

Measuring distances onscreen

Note Technically, when you select ‘U.S.’, you will get
the imperial measurement system – inches, feet, and
yards.
Ripple-on effects
Changing the measurement system will change the
units used by most controls – e.g. Transform toolbar
units of measurement.

Measure the distance between two points in the
design window using the Measure command. This
command displays coordinates, distance and angle of
the mouse pointer from a point corresponding to the
center of a hoop in an empty design. View the
measurements in the Status Bar or in a tooltip. See
Interpreting pointer position values for details.

Tip For more accurate results, zoom in before you
measure. The measurement is always the actual size,
and is not affected by the zoom factor.
To measure a distance onscreen

Selected measurement
units displayed

1 Select View > Measure or press M.
2 Click the start point.
3 Move the pointer to the end point and hold the
mouse still.
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The following information displays in the Status
Bar:

 Double-click or right-click any object in the
design window.

 Position coordinates of the end point (X=, Y=).
 Length of the measured line (L=).
 Angle of the line relative to the horizontal
(A=).
Measurements are shown in millimeters or inches,
depending on current selection.

Measurements
appear as tooltip
or in Status bar

Tip If activated, length and angle measurements
will also appear in a tooltip. See Setting other
general options for details.

4 Press Esc to finish.

 Select a tab to access the object property set you
want to adjust.
 Use fields, droplists, radio buttons, checkboxes,
and slider controls to key in or adjust settings.
 Click the Effects button to access a separate set
of more specialized object property settings such
as Underlay, Textured Edge, Gradient Fill, etc.

Accessing object properties
Use General > Object Properties to set current
properties or properties of selected objects.
Use General > Effects to apply stitch effects to
selected embroidery objects or preset with nothing
selected.
Designs created in BERNINA Embroidery Software are
composed of ‘embroidery objects’. They are called
‘objects’ because they are discrete entities which can
be manipulated independently of each other. Each
object has certain characteristics or ‘properties’ such
as color, size, position, and so on. The most important
dialog in BERNINA Embroidery Software is the Object
Properties dialog. See also Working with object
properties.

Note This dialog, in turn, includes a Properties
button which opens the Object Properties
dialog. You can choose to close the Object
Properties dialog automatically whenever the
Effects dialog is opened, and vice versa. See
Setting other general options for details.

To access object properties
 Open the Object Properties dialog by any of the
following means:
 Click the Object Properties icon.

Tip Graphic tips are incorporated into the Object
Properties dialog to give you visual feedback on
particular settings. These are displayed whenever
you hover the mouse over a control. For example,
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with the mouse placed over the Stitch Spacing
control, a graphic tip appears beside it.

dedicated cross stitch designs or add cross stitching
to embroidery. See also Ancillary Applications.

 Apply settings by means of the Apply button at
the bottom of the dialog or by pressing Enter.
 If one or more objects are selected, changes
are applied to all relevant objects.
 If no objects are selected, changes are made to
the current settings – these will affect any
newly created objects.
 If you have modified settings on a number of
tabs, all changes that can be applied will be
applied.
 Click the Save to Template button to save
settings to the current template.
These become the defaults whenever you create
new files based on this template. See Working with
design templates for details.
 Click the Discard button or press the Esc key to
discard any changes.
 Click OK to close the dialog and apply any pending
changes.

Launching ancillary applications
In addition to CorelDRAW®, BERNINA Embroidery
Software includes a number of ancillary applications
which can be launched from the Applications
toolset.

Launching BERNINA Quilter
Use Applications > Quilter to launch BERNINA
Quilter from within BERNINA Embroidery Software.
Patchwork is a popular technique for designing and
sewing patches into blocks. BERNINA Quilter can be
used to design patchwork quilts, either from existing
designs or patterns, or from designs of your own
making. Use BERNINA Quilter to experiment with
patches and colors enabling you create beautiful,
personalized quilts. See also Ancillary Applications.

Launch ancillary
applications

Launching BERNINA Cross Stitch
Use Applications > Cross Stitch to launch BERNINA
Cross Stitch from within BERNINA Embroidery
Software.
Cross stitching is a popular technique for filling large
areas with low stitch counts. It can also be used for
outlines and borders. It is suitable for homeware,
tablecloths, children’s clothes and folk designs. Cross
stitch is sometimes combined with appliqué. The
BERNINA Cross Stitch application lets you create
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CHAPTER 4
MANAGING DESIGNS
The built-in Embroidery Library provides an efficient way to view and manage
embroidery designs. It recognizes all design file formats used by the software.
The library also makes it easy to search, sort and browse all embroidery designs
on your system.

View (Manage
Designs)
Virtual Embroidery
Library folder structure
Manage Designs
toolbox

Design display

Design Info panel

In a nutshell, Embroidery Library lets you:
 Find designs anywhere on your local hard drive or external device such as USB

or ZIP drive.

 Search for designs by various means, including known design information.
 Create an organizing structure for easy categorization.
 Batch-convert selected design files to many machine formats such as DST, EXP,

SEW, and others.

 Print selected designs or send them to embroidery machine for stitchout.

Find embroidery designs anywhere on your hard drive or external storage device
and, optionally, add them to your embroidery library.This section describes how
to open and view designs in Embroidery Library as well as adjusting viewing
settings. It also covers browsing for and accessing designs in folders.
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Accessing the library

Opening embroidery files

The Embroidery Library is accessed from the Canvas
toolbar.

Embroidery files fall into two broad categories –
embroidery or ‘design files’ and machine files. Design
files are generally ones you open and modify in the
software. Machine files are generally ones you send to
machine for production. There is some
inter-convertibility between the two formats.

Embroidery files
You can filter your embroidery library between file
categories – design, machine, or all.

It has five components – two toolbars, a toolbox, a
navigation tree, a design display area, and an info
panel – as summarized here...
Component

Function

Manage
Designs
toolbox

Use the toolbox on the left to open selected
designs, convert them, print them, or output
them to any connected embroidery machine
or data media, or find folders containing the
designs and add/remove folders to/from
embroidery library.

Navigation
tree

• Right-click the navigation tree to access a
popup menu. Use it to cut, copy and delete
without leaving the software.
• Use it also to zip designs and folders.
Note, however, that the navigation tree in the
Embroidery Library is not an exact duplicate
of your Windows Explorer folder structure.
Because the library only deals with
embroidery designs, you will only see folders
which have already been added to the
library.

Design
display

The design display area shows any designs
in selected folders corresponding to the filter
selected and search criteria entered in the
Manage Designs toolbar. Use this toolbar to
filter the design display.

Design info

When a design is selected, summary
information is displayed in the info panel.

Manage
Designs
toolbar

Search or sort the entire embroidery library
or any chosen folders on any criteria
selected. See below.

Standard
toolbar

Create new designs, open existing designs,
open recent designs, and cut, copy and
paste selected designs.

Filter designs by
file category

Design files
Design files, also known as ‘all-in-one’ files, are
high-level formats which contain object outlines,
object properties and stitch data. When you open a
design file in the software, corresponding stitch types,
digitizing methods and effects are applied. Design
files can be scaled, transformed and reshaped without
affecting stitch density or quality. After modification,
you can save to any supported file format.
Machine files
Different embroidery machines speak different
languages. Each has its own commands for the
various machine functions. Machine files, also known
as ‘stitch files’, are low-level formats for direct use by
machines. They contain information about the
position, length and color of each stitch. When they
are read into the software, machine files do not
contain object information such as outlines or stitch
types, but present the design as blocks of stitches.
You can scale machine files but because the stitch
count does not change, the density increases or
decreases with the design size. Thus you should not

Note There are differences in the way the info panel
is displayed in different versions of Windows OS. Your
display may differ slightly from the screen images
shown here.
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scale them by more than ±5% or some areas may be
too thickly or too thinly covered.

outlines and may not handle some fancy stitches. See
also Working with Machine Files.

Original machine file

Browsing designs

Scaled machine file

Open design files
Use Manage Designs > Open Selected to open
design(s) selected in the embroidery library.
Use Manage Designs > New From Selected to
create new designs based on designs selected in the
embroidery library.

The Embroidery Library makes it easy to search, sort
and browse all embroidery designs on your system. If
you are already familiar with Windows Explorer, the
interface will be quite intuitive to you. But there are
some differences. The embroidery library is a ‘virtual
library’ in that any designs on your system can be
located and displayed within the navigation tree. The
design software doesn’t care where they physically
reside on your hard disk or external storage devices.
Any folder containing embroidery designs can be
included in the navigation tree.

Filter & sort designs
The Manage Designs toolbar provides a powerful
means for sorting, filtering, and searching for designs
in your embroidery library. For instance, filter the
library to show only certain file types.

Using the Embroidery Library, you have the option of
opening one or more selected designs in their own
design tabs. Simply select a design or designs by
holding down Ctrl as you click, and then click Open
Selected. This command opens the original file.
Alternatively, click New from Selected. The only
difference for practical purposes is that New From
Selected creates a copy which opens in a new design
tab, thus preserving the original design file.
Caution Be careful not to open too many designs
simultaneously. Potentially you could select all
designs in the library and click Open Selected. This
operation cannot be stopped and may result in the
computer running out of memory.

Filter designs by
file type

Use it also to search for names or keywords or sort
them by name, create date, or other criteria. Use it
also to control display of the navigation tree as well as
thumbnail appearance.

Find designs
Tip If you want to open one design into another, an
Insert Design function is available. Combine designs
or design elements into a single design layout. See
Combining objects for details.

The ‘Find’ field is very powerful. For instance, go to
the Decorative Accents folder and search on tags
such as ‘linework’ or ‘lace’ to bring up the results you
want. In fact, you can search on any criterion
displayed on the Info panel. For example:

Open machine files

‘author:OSED colors:<5 stitches:<3000’

While machine files are generally not suited to
modification, the software can ‘recognize’ object
outlines, stitch types and spacing from stitch data
with some success. By default, machine files are
converted to outlines and objects upon opening in the
software. These ‘recognized’ designs can be scaled
with stitches recalculated for the new outlines.
Processing is effective for most stitch designs but
cannot produce the same level of quality as original
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This will narrow the search to only those designs
By default BERNINA Embroidery Software saves
which have been authored by ‘OESD’, which have less designs to its native ‘ART’ file format. This format
than 5 colors, and which have less than 3000 stitches. contains all information necessary both for stitching a
design and for later modification. However, the
software supports many machine file formats such as
DST, EXP, SEW, and others. You can convert your ART
and other design files to and from other file formats
directly from the Embroidery Library. See also
Working with Machine Files.
 Select the file(s) to be converted and click the
Convert Selected Designs icon. The dialog lists
all machine file formats supports by the software.

Make sure you use correct syntax. Each field name
must include a colon ‘:’ after the name. Use the Clear
button to clear the Find field before conducting
another search.

Select machine file
formats to convert to

Design tags
All packaged designs are tagged for easy search and
find. BERNINA designs use the same tags as OESD.
Use the Summary tab to view, edit, or enter
summary information about a design. The Info panel
displays the same information. See also Viewing
design properties.
 Select the file types you want to convert to.
 Click Browse to locate a destination folder for the
converted designs.
Design tags display
in Info panel

 Click Convert to start the conversion. The
converted designs will be stored in the nominated
folder.

Outputting selected designs
Send designs directly to machine for stitching. Create
hard copy reports of a selected designs using a printer
or plotter. Report types may include design
worksheets, appliqué patterns, color films, hooping
sequence reports, as well as catalogs and lists of
selected designs.

Converting designs
Use Manage Designs > Convert Selected Designs to
convert the design selected in the embroidery library
into different machine file types.

Send designs to machine
Use Manage Designs > Stitch Selected Design to
stitch the design selected in the Embroidery Library.
The software supports various machine models. Some
can be connected by cable directly to your PC via the
USB port. Older-style machines do not support direct
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connection but they do read ATA PC cards and/or USB
memory sticks. See also Working with Machine Files.

Tip When working with designs that are larger than
the available physical hoop, you can split them into
parts, each containing an object or group of objects.
The software automatically calculates which files are
to be sent and shows you how they will look. See
Creating multiple hoopings for details.

 Set worksheet options to show the information you
want in the format you require.
Report

Purpose

Design
worksheet

This provides complete sewing information
for the design. All related information, such
as bobbin length, design size, garment
fabric, etc, is provided.

Appliqué
patterns

This shows appliqué patterns – cutter
information – isolated from the design.
These can be used as a guide to cutting out
fabric pieces. They also show which
appliqué pieces are to be included.

Color film

Provides a list of colors in the design,
together with color and stitch information
for each color layer. This helps the machine
operator to see each stitch color in order of
stitchout.

Hooping
sequence

If there is more than one hooping in the
design, this option displays hoopings in
their correct color sequence.

Print selected designs
Use Manage Designs > Print Selected to print
designs selected in the embroidery library.
You can print worksheets for selected designs, and
include thumbnails of each in the worksheet. Unlike
Print Designs, this option can provide design and
sewing information.
 Sort the designs to be printed using Sort.
 Select a design and click the Print Selected icon.
The Print dialog opens.
 To customize the printout, click Options.

 The Design Worksheet panel provides options for
further customization. See also Printing designs.
 Click OK and ensure correct printer settings in the
Windows Print Setup dialog. The dialog and the
settings available vary from printer to printer. See
your printer manual for details.

Print design catalogs
Use Manage Designs > Print Selected to Catalog to
print selected designs to a catalog.
Printed catalogs of your designs contain thumbnails of
the designs plus limited text details. You can prepare
catalogs of all your designs to suit your needs.
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To print a design catalog

7 Click Preview to view the catalog.

1 Open Embroidery Library and filter designs as
desired. See Filter & sort designs for details.

8 Click Print Now to print the catalog.
2 Select the designs you want to include in the
catalog.

3 Select Manage Designs > Print Selected to
Catalog. The Print Catalog Options dialog
opens.

Tip If the catalog requires more than one page,
you can select which page to print in the
MS Windows® Print Setup dialog.

Export design lists
Use Manage Designs > Export Design List to export
selected files to Tab and CSV (Comma Separated
Value) formats suitable for use by most
spreadsheets.

4 Change Scale (%) to adjust thumbnail size.
5 Select a catalog format – thumbnails with or
without design details.

6 Click Print. The Print Design dialog opens.

The Export Design List option can be used to print
design lists for selected folders. This option allows you
to create a simple design report which can easily be
imported into a spreadsheet. You may want to use
this in order to manage designs by file name.
 Preset the measurement units you want to use –
metric or U.S.

 Open the Embroidery Library and select a design
folder.
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 Sort and filter the designs to be printed.

Find designs to add
Use Manage Designs > Find Embroidery Designs to
locate all compatible designs on your hard disk.
Finding all compatible designs on your hard disk and
any external devices such as USB, zip drive, etc, is
simply a matter of clicking the button. You will be
prompted to select the folders containing designs you
want to add to the embroidery library. Simply select
the folders you want to include in your Embroidery
Library, and click Add to Library.

 Click the Export Design List icon and choose a
location to save the list. Choose whether to save
as a tab-delimited or comma-separated text file.
 Open the text file in a spreadsheet for further
sorting and printing.

Select folder to add
Use Manage Designs > Add Folders to Library to add
an existing folder to the Embroidery Library. This
enables faster searching and filtering of the folder.
Alternatively, simply click the Add Folder to Library
button to locate a folder of your choice. In the dialog,
click Add to Library to add the folder to your
embroidery library.

Tip Designers frequently want to distribute designs
for viewing in real colors, in Artistic View or otherwise,
with or without fabric backgrounds. Screen images
can be captured in PNG format and send as email
attachments.

Managing folders
The Embroidery Library is a ‘virtual library’ in that any
designs on your system can be located and displayed
within the navigation tree. The design software
doesn’t care where they physically reside on your
hard disk or external storage devices. Any folder
containing embroidery designs can be included in the
navigation tree.

Remove folders
Use Manage Designs > Remove Folder from Library
to remove a folder from the Embroidery Library. This
only removes the link to the folder from within the
library. It does not actually delete the files in the
folder from storage.
Remember that the Embroidery Library is a ‘virtual
library’. When you add or remove folders from the
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navigation tree, this only affects the Embroidery
Library. It does not affect the folder structure on your
hard drive. To remove a folder from the Embroidery
Library, select and click the Remove icon. When you
remove a folder, all subordinate folders will also be
removed from the navigation tree.

3 Browse the folders for the clipart you are
interested in.
Note To open the clipart in BERNINA Embroidery
Software, you will need to do so via Artwork
Canvas. See also Loading vector artwork.
Tip It may be more convenient to take a copy of
the entire CorelDRAW® Clipart folder and copy it
to My Designs - Embroidery Software 8 folder
for easy reference.

Browsing clipart
CorelDRAW® Essentials X6 itself is packaged with a
selection of clipart which can be used as digitizing
backdrops or converted directly into embroidery. See
also Converting vectors to embroidery.
To browse clipart

1 Access the CorelDRAW® Essentials X6 folder via
the Windows Start > Programs group.

2 Select the Content folder and choose Clipart.
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CHAPTER 5
VIEWING DESIGNS
BERNINA Embroidery Software provides many viewing features to make it easier
to work with your design. Zoom in on an area to see more detail or view the
design at actual size. Show or hide various design elements with the available
display settings. Preview an existing design in different colors on different fabrics.

When working with embroidery designs, you need to understand the stitching
sequence. You can check a design’s stitching sequence in BERNINA Embroidery
Software by ‘traveling’ through it stitch-by-stitch. You can also check the
sequence by simulating the design stitchout onscreen.
BERNINA Embroidery Software also provides information about designs in a
variety of ways and formats. Before even opening BERNINA Embroidery Software
or your design, you can check some design information for ART files directly from
MS Windows® Explorer. You can view stitching details about a design in the
Design Properties dialog. Also the Print Preview provides essential design
information, including a design preview, the size of the design, color sequence
and any special instructions.
This section explains the design viewing modes available in BERNINA Embroidery
Software as well as the various design viewing settings. It describes zooming and
panning as well as how to view the stitching sequence. It covers displaying design
backdrops and changing backgrounds. It also explains how to obtain information
about your designs.

Embroidery view settings
You can show or hide embroidery elements in
Embroidery Canvas with a variety of display
settings. See a graphical representation of the final
embroidery. Show or hide needle penetration points
and stitches themselves. Or show/hide selected
colors.

Viewing embroidery elements
Click View > Show Artistic View to show or hide
simulation of stitched embroidery.
Click View > Show Stitches to show or hide
embroidery stitching.
Click View > Show Outlines to show or hide object
outlines. Turn off stitches to view outlines only.
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Click View > Show Connectors to show or hide
connecting stitches between embroidery objects.

 To view simulated embroidery (Artistic View),
toggle the Show Artistic View icon on.

Click View > Show Needle Points to show or hide the
needle points in embroidery stitching.
You can show or hide stitches and object outlines as
you work. For instance, hide stitches to see outlines
more clearly when reshaping. See Reshaping &
Editing Objects for details.

Note To make sure your design is being displayed
correctly in Artistic View, calibrate your monitor.
See Calibrating the monitor for details.
To view embroidery elements
 Click Show Stitches to turn stitches on or off.
 Click Show Outlines to turn object outlines on or
off, with or without stitches.

Viewing objects by color
The Hide Colors function helps you isolate individual
design elements for checking or manipulation. This is
particularly useful when you are resequencing objects
by color. See also Sequencing by color.
To view objects by color
 Create or open a design. Ungroup the design
before proceeding.

Stitches ON

Outlines ON

 Click Show Connectors to turn stitches on or off.

 Select View > Hide Colors.

Connectors ON

 Click Needle Points to show or hide needle
points. See also Adjusting display colors.

Needle points ON

 Select the colors you want to hide.
 To select all, click the checkbox at the top of the
column.
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 To select a range, hold down Shift as you click.

The Overview Window opens.

 To select multiple items, hold down Ctrl as you
click.
 Click OK. The design displays with only those
colors left unchecked in view.

 To view all colors in the design, select View >
View all Colors.
Tip The Color Film provides another way to view
design objects. See Viewing & selecting color
blocks for details.

Zooming & panning

Click to activate
zoom box

2 To zoom in or out, click the Zoom button on the
Overview Window and drag a selection marquee
around the area to zoom and drop.

Drag and drop a
selection marquee
around area to
zoom

Use the Overview Window and Zoom functions to
quickly examine your design at different degrees of
magnification.

Tip The Status Bar displays the current ‘zoom
factor’. See Starting the software for details.

Viewing designs in overview
Click General > Overview Window to show or hide
the docker. Use to zoom and pan thumbnail of
current design.
Use the Overview Window to view design
thumbnails. The window updates whenever you make
a change and can be used to zoom into or pan across
the design window.

3 To pan across the design, move the cursor inside
the zoom box – it changes to a four-way arrow
cursor – and drag and drop.

Drag zoom box
to area to pan

To view designs in overview

1 Click Overview Window icon.
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Zooming in & out
Click Zoom > Zoom to left-click to zoom in, right-click
to zoom out, or drag a ‘zoom box’.
Use Zoom > Zoom Factor to select a preset
zoom scale from the droplist or key in your
own zoom scale and press Enter.
Click Zoom > Pan to Drag to pan across the design
at high zoom factors.
Magnify your view of the design by zooming in on
individual stitches or details, or zoom out to display
more of the design in the window. See also Keyboard
Shortcuts.

 To display the design at a particular scale, enter a
scale factor in the Zoom Factor field as a
percentage of the actual size and press Enter.
Alternatively, press F on the keyboard. Enter a
scale as a ratio and click OK.

Enter zoom
factor

 To pan across a design in the design window, use
the scroll bars. Alternatively, select Pan or press P
and use the ‘grabbing hand’ tool. Click to ‘hold’ the
design window and drag it around.

Note To make sure your design is being displayed at
the correct size, calibrate your monitor. See
Calibrating the monitor for details.
To zoom in and out
 Click the Zoom icon or press shortcut key B.
The cursor becomes a magnifying glass.
 Left-click to zoom in, right-click to zoom out.

Click and drag to pan
across the design
window

Right-click

 Alternatively, use the View > Zoom commands to
access more zoom options.

Tip The Zoom Factor field updates accordingly.
 Click-and-drag a selection marquee around the
zoom area and release.

More zoom
options

Click-and-drag

 Select Zoom > Zoom to Fit to display the whole
design. Alternatively, press shortcut key 0 (zero).
 To display the design at actual size, select Zoom
> Zoom 1:1. Alternatively, press shortcut key 1.
See also Calibrating the monitor.
 Press Esc, Enter or Spacebar keys to exit Zoom
mode.
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Tip Use Auto Scroll to scroll the design
automatically while digitizing. This can be more
convenient than using panning or scroll bars. See
also Setting auto scroll options.

Viewing stitch sequence
When working with embroidery designs, you need to
understand the stitching sequence. You can check a
design’s stitching sequence by ‘traveling’ through it
by stitches, colors or objects. You can also check the
sequence by simulating the design stitchout
onscreen. BERNINA Embroidery Software simulates
stitching out by changing stitches from black to their
allocated thread colors as they are ‘stitched’. See also
Viewing & selecting color blocks.

Traveling through designs
Click View > Show Stitches to show or hide
embroidery stitching.
Click View > Show Artistic View to show or hide
simulation of stitched embroidery.

The white cross moves to the first stitch and the
whole design appears black. As you travel through
the design, the needle position marker moves
accordingly.

White cross - current
needle position marker

End point

 To travel by object or color block, select a toggle
and click the Forward/Back buttons. You can also
jump to start or end by this method.
Select toggle and click
Forward/Back buttons

Click Travel > Jump by Object to travel to the
previous or next object in the design. Use in
conjunction with Forward/Back buttons.
Click Travel > Jump by Color to travel to the previous
or next color block in the design. Use in conjunction
with Forward/Back buttons.
Click Travel > Jump to Start/End to travel to the start
or end of the design. Use in conjunction with
Forward/Back buttons.
BERNINA Embroidery Software provides a Travel
toolbar with buttons to ‘travel’ through the stitch
sequence by object and color block. Use in
combination with keyboard arrow keys to travel by
stitches. Keyboard shortcuts also exist to travel
through designs by object or color block. See also
Keyboard Shortcuts.
To travel through the design

 Alternatively, to travel to the next object, press
Ctrl+T. Press Shift+T to go back.
 To travel to the next color, press Page Down.
Press Page Up to go back.

White cross - current
needle position marker

End point

 Ensure that Show Stitches is on and Artistic
View is off. See Viewing embroidery elements for
details.
 Press Esc to ensure that Select Object is
deselected.
The current needle position is indicated by a large
white cross or ‘needle position marker’. Initially,
this is located at the end of the design. The current
stitch number appears in the Status Bar.
 To travel to the start of the design, press the
Home key.
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 Use the arrow keys to travel by 1 or 10 stitch
increments. Use + or - keys on the keypad to
travel 100 stitches at a time.

 Select View > Stitch Player or press Shift+R.

Use arrow keys to
travel by stitches
- 10

-1

+1
+ 10

 To travel to the end of the design, press the End
key. Or use the Travel toolbar.
Tip If you travel outside the visible area, press the
C key to center the current stitch on the screen.

Simulating design stitchouts
Use View > Stitch Player to simulate embroidery
design stitchout onscreen in either stitch or artistic
view.

 To redraw only a section of design, specify the
start and end stitch in the Stitch Range field.
 Use the controls to stitch forwards or backwards
through the design. Typical ‘media player’ buttons
are available for play, pause, rewind operations.
 Use the slider bar to adjust redraw speed.
 Use Auto Scroll when running Stitch Player at high
zoom factors.

Backdrops & backgrounds
You can display a backdrop while you digitize. Hide it
temporarily while you work, or dim it for easier stitch
viewing. You can also change the background of the
design window to match your fabric.

Stitch Player is an important tool in BERNINA
Embroidery Software. It lets you simulate the actual
embroidery design stitchout on screen. Because
Stitch Player emulates the movements of the
embroidery machine, you are able to make decisions
about how to optimize your design in order to lessen
the load on the machine.

Displaying backdrops
Use View > Show Bitmap Artwork to show or hide
any bitmap artwork included in the design.
Use View > Dim Artwork to dim backdrops in order to
show stitches more clearly when digitizing.
Use View > Show Vector Artwork to show or hide any
vector artwork included in the design such as
CorelDRAW® clipart.
Use View > Show Appliqué Fabric to show or hide
background fabric / color of any appliqué objects in
the design.

To simulate the design stitchout
 Choose a design view to visualize your design.
Stitch Player can be run in both Artistic View and
Stitch View.

You can display a backdrop – bitmap or vector – while
you digitize, or hide it temporarily. Hiding backdrops
does not delete them from the design. You can also
dim backdrops to make it easier to view stitches. See
also Digitizing with Backdrops.
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The Background and Display Colors dialog
opens.

To display a backdrop
 To toggle backdrops on/off – both bitmap and
vector graphics – click the corresponding icon. See
also Importing artwork.

Select background
color, fabric, or
article

2 Select the background type you want:
With background ON

With background OFF

 To dim a backdrop, click the Dim Artwork icon.

Option

Purpose

Color

Set background color of design window

Fabric

Select a fabric texture corresponding to your
target fabric.

Article

Select a product image that represents the
article you will be embroidering. This can also
be displayed on the design worksheet.

3 Select the color or fabric you want to use:
Original bitmap image

Dimmed bitmap image

 Click the Show Appliqué Fabric icon to toggle
appliqué fabrics/colors on or off. See also
Digitizing for Appliqué.

 To select a background color, select a color from
the droplist.

Select background
color from droplist

 To select a fabric, select Factory Fabric and
choose a fabric and color from the droplists.
With appliqué fabric ON

With appliqué fabric OFF
Select fabric
from droplist

Setting backgrounds
In BERNINA Embroidery Software, you can change
the background of the design window to match your
fabric. The background is saved with the design.
To set a background

1 Select Design > Background.
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 To select a product image that represents the
article you will be embroidering, select Factory
Article. See also Visualizing finished articles.

The Background and Display Colors dialog
opens.

Set color/s for
selected article

4 Click OK.

 Choose an article from the droplist.
 Select a color or colors. If you have chosen a 2- or
3-color article, more palettes become available.

Color articles
from droplists
Color background

Fabric background

Tip Design worksheets include an option to print
designs with or without backdrops. See also
Printing designs.

Visualizing finished articles
BERNINA Embroidery Software lets you choose an
article as a backdrop upon which to position your
decorations. Use it to visualize location, size and
overall appearance. The software provides a library of
articles to choose from, including multi-color
garments. Alternatively, insert your own photo or
image.

 Scale the article as a percentage.
Scale should be adjusted according to garment
size – XS, S, M, L, XL, or XXL. Rule of thumb: L =
100%. For a small size garment, scale down to
approximately 70%.
Tip Measure the garment using the Measure
command. See also Measuring distances
onscreen.

To visualize finished articles
 Select Design > Background.
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 If you have an electronic image of your own
article, select the Custom option and click
Browse to locate.

Item

Description

Needle
points

Needle points can be activated via the View
toolbar or by pressing ‘.’ (period). See Viewing
embroidery elements for details.

Display colors are saved with the colorway. You can
save the colorway as an EMT template file for use in
future designs.
Black needle points against
white background

Tip Design worksheets include an option to print
designs with or without backdrops. See also
Printing designs.

Adjusting display colors
In addition to background color or fabric, display
colors for needle points, selected stitches, etc, are
part of backgrounds. Change them if they are not
visible against the current background color.
Adjust display
colors of selected
items

Viewing design information
BERNINA Embroidery Software provides information
about designs in a variety of ways and formats.
Before even opening BERNINA Embroidery Software
or your design, you can check some design
information for ART files directly from MS Windows®
Explorer. You can view stitching details in the Design
Properties dialog. The Print Preview tool provides
essential design information, including a design
preview, the size of the design, color sequence and
any special instructions.

Viewing design properties
Adjust colors as required for:
Item

Description

Selected

Selected objects or stitches.

Unsewn

Unsewn stitches as they appear when traveling
through the design.

Shapes

Object outlines as they appear when Show
Stitches is deactivated. See Viewing
embroidery elements for details.

Grid

Guides

Depending on the colorway, you may need to
adjust grid display colors in order to view them
against the background color. See Displaying
the grid for details.

Use Color Palette > Thread Colors to search for and
match threads from different charts, and assign for
use. Right-click to access Design Properties >
Thread Colors summary tab.
You can check software version number and other
design information through the Design Properties
dialog. Stitching details are also provided. Most of the
fields cannot be modified directly.
To view design properties
 Select Design > Design Properties.
The Design Properties > Design dialog opens.
This tab contains information about height and

Depending on the colorway, you may need to
adjust guide display colors in order to view
them against the background color. See
Displaying rulers & guides for details.
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width and stitch count and colors. The data is
 Select the Summary tab to view, edit, or enter
extracted from the design and cannot be modified.
summary information about a design.

Machine runtime
estimate

 Click a field and enter any text which will help you
identify or search for the design at a later date.
See also Browsing designs.

 Information on this tab is included on the Design
Worksheet. Details include:

Note Information from this tab is included on the
Print Preview as well as the Summary tab of the
Windows Properties dialog. See Viewing
designs in Windows Explorer and Previewing
designs for details.

 Stitch count, color changes, trims, as well as
estimated machine runtime. Runtime depends
on the current machine type. See Changing
hoops for details.

Viewing designs in Embroidery Library

 If you are using a design fabric, required
stabilizers are listed. See also Working with
fabrics.

Embroidery Library provides an efficient way for
viewing and managing embroidery designs. The
library is integrated into main application.

 The Design tab also indicates grade of ART
design – BERNINA Embroidery Software native
ART designs are classified in four grades
depending on how the file was created. See
Supported machine file formats for details.
 The Design Properties > Thread Colors tab
provides summary information about threads used
in the design.
Click to print chart
Current thread
chart

This design management tool can access design files
stored on your computer hard disk, CD-ROM, or
floppy disk. Embroidery Library even lets you view
design files in folders which have been archived by
means of the popular WinZip utility. It recognizes all
design file formats used by BERNINA Embroidery
Software. See Managing Designs for details.

 The Print option allows you to print the thread
list in the current thread chart as a shopping
reference when purchasing threads. See
Printing thread charts for details.
 You can use this tab as an alternative means for
managing thread charts. See also Managing
thread charts.
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Viewing designs in Windows Explorer
Before opening ART files, you can view design
thumbnails and details via MS Windows® Explorer.
The Properties dialog displays a design preview
together with design information such as stitch count,
number of stops and color changes. You can also view
general file information, such as file size and
modification dates. Design thumbnails are displayed
in Windows Explorer.

The Print Preview contains a design preview and
essential design information, including the size of the
design, color sequence and any special instructions.
See also Printing designs.
To preview designs

1 Click the Print Preview icon.
The design preview displays in a preview window.
Click to print
design

Note This same dialog can be accessed from within
the Open dialog in BERNINA Embroidery Software.
See also Opening designs.
Right-click a file and select Properties from the
popup menu.

ART design details
available in Windows
Properties dialog

Click to display
Click for print
one or two pages options

2 Adjust the view as required:
 To change the orientation of the paper, click
Landscape or Portrait.
 To adjust information and printing preferences,
click Options. See also Setting worksheet
options.
 Use zoom and page controls to check design
information. Large designs may be displayed
over a number of pages.
 To print the design, click Print.
 To close the print preview, click Close.

The Summary tab provides some of the same
information entered in the Design Properties >
Summary tab in BERNINA Embroidery Software. See
Viewing design properties for details.

Previewing designs
Click General > Print Preview to preview the print
preview onscreen.
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CHAPTER 6
SELECTING OBJECTS
BERNINA Embroidery Software provides
various means for selecting the objects
comprising an embroidery design. These
include techniques such as point and click,
selection marquee, and multiple object
selection. You can select all objects in a design
or individual ones for precise modification.
BERNINA Embroidery Software allows
selection of object outlines or fill stitches.
Note Designs must be ungrouped before
objects can be selected. See Grouping &
ungrouping objects for details.
This section describes how to select objects
using the selection tools and keyboard. It also
shows how to select color blocks or individual
objects using the Color Film.

Selecting objects by point & click

 Click an outline to select the object.

Click Transform > Select Object as necessary
(generally activated by default), and click objects to
select.
The simplest way to select objects is by pointing and
clicking with the mouse with the Select Object tool
activated. Using Shift and Ctrl keys, you can select
multiple objects. Both outlines and/or filled areas can
be selected. Clicking an outline selects an object even
if another is above it. Where you have a mixture of
closed objects, you can select object outlines or fill
stitches.
To select objects by point & click
 Click the Select Object icon.
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 Click the fill behind a outline object to select the
filled object.

Selecting objects by selection marquee
Use Transform > Select Object to select objects or
drag a selection marquee to enclose.
Use Transform > Polygon Select to select irregular
areas or shapes – click reference points to
demarcate.
With the Select Object tool activated, you can select
objects by dragging a selection marquee around
them. Use Polygon Select to select multiple objects.

 Click the fill to select an object even if it lies within
the bounds of a larger object.

To select objects by selection marquee
 Click the Select Object icon.
 Drag a selection marquee around the objects you
want to select.
Objects are selected when you release the mouse
button.

Tip To select an object which is behind another
object, zoom in and click the outline. Alternatively,
position the pointer over the object, hold down the
2 key, and click until the object is selected. Each
click selects the next overlapping object.
 To select multiple items, hold down Ctrl as you
click.

Drag a selection marquee
around the objects

Objects are
selected

Note Unless they have already been grouped,
only objects completely within the selection
marquee will be selected when you release the
mouse button. See also Grouping & ungrouping
objects.
 Alternatively, click the Polygon Select icon.
 Mark reference points around the object/s you
want to select.

Click an object

Hold down Ctrl and
click another object

Ctrl +

 Press Enter to select.

 Select a range of objects by holding down Shift
while you click the first and last objects in the
range.

Mark reference points
around object/s to select

Click first object

Hold down Shift and
click last object

Shift +

Selecting objects by Tab
Click Transform > Select Object and press Tab or
Shift + Tab to tab between objects.
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With the Select Object tool activated, you can select
the first or last object in the design sequence using
the Tab key. If an object is selected, you can select
the object before or after it in the stitching sequence.
See also Reshaping next or previous objects.
To select objects by Tab
 Click the Select Object icon.

Deselecting & deleting objects
Deselecting and deleting objects are basic operations
which rapidly become second-nature. You can cancel
all selections in the design, or remove individual
objects from a group of selected objects. Various
methods are available for deleting objects. See also
Sequencing with Color Film.

 With an object selected, do one of the following:
 Press Tab to select the next object in the
stitching sequence.
 Press Shift+Tab to select the previous object.

To deselect or delete objects
 Cancel a selection using any of the following
methods.
 Press Esc.
 Select another object.

Shift + Tab

Tab

 Click an empty area of the background.
 Select Edit > Deselect All.
 Remove an object from a selection by holding
down Ctrl and clicking the object to deselect.

 With no objects selected, do one of the following:
 Press Tab to select the first object in the
stitching sequence.
 Press Shift+Tab to select the last object.
Tip Hold down the Ctrl key to select multiple
items as you tab between them.

Selecting all objects in a design
Select all objects to apply changes to a whole design.
See also Keyboard Shortcuts.
To select all objects in a design
 Select Edit > Select All or press Ctrl+A.
Sizing handles appear around the entire design.

 Select the object/s to delete, and do one of the
following:
 Press Delete.
 Select Edit > Delete.
 Right-click object/s in the Color Film and select
Delete from the popup menu. See Viewing &
selecting color blocks for details.

Viewing & selecting color blocks
Click General > Color Film to view all color blocks
and objects in a design.
Click Color Film > Show Individual Objects to view
individual objects in order of stitching sequence.
The Color Film tool provides a sequential list of
objects grouped by color. Use it to select and
manipulate ‘color blocks’ – consecutive objects of the
same color. In addition, you can display, select,
modify and sequence individual objects. Color Film is
synchronized with the design window and vice versa.
It dynamically updates whenever you select, modify
or delete objects, or create new ones. See also
Sequencing with Color Film.
To view & select color blocks
 Click the Color Film icon.

No objects selected

All objects selected

 To deselect, select Edit > Deselect All, press X or
Esc.
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The Color Film toolbar opens displaying all color
blocks in the design in order of stitching sequence.

Consecutive objects of
same color form single
color block

All objects comprising
color blocks shown in
their stitching order

right-clicking their icons. See also Combining
objects.

Use popup menu to
cut, copy, paste
objects as required

 Click the Show Individual Objects toggle to
view individual objects.
All objects within a color block are displayed in
stitching order.
 Click an icon to select the color block or object.

Tip To enlarge thumbnail images of color blocks
or objects, click and drag the edge of the dialog.

 To select a range, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you
click.

Select color
block or
object in
Color Film

 Manipulate the color blocks as required. See also
Sequencing with Color Film.
You can quickly access popup menu commands for
manipulating selected color blocks or objects by

Drag edge to enlarge
thumbnails

BERNINA® Embroidery Software : Reference Manual

54

Chapter 7 : Software Setup

CHAPTER 7
SOFTWARE SETUP
BERNINA Embroidery Software lets you
adjust various system settings controlling
the appearance of designs on screen,
display of design information, the behavior
of the design window, and other settings.
You will also need to connect peripheral
devices for use with BERNINA Embroidery
Software. These may include printers,
scanners and embroidery machines. See
Hardware setup for details.
This section describes how to set up
embroidery machines, and scanners and
describes how to calibrate the monitor. It
also deals with changing grid spacing and
hoop options. The setting of general options – such as automatic save, pointer
position display options, etc – is also covered.

Setting grid options
Right-click View > Show Grid to set grid reference
point and spacing.
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.
You can turn the grid on or off, change the grid
spacing, or set a reference point. You can also turn
Snap to Grid on or off in the Options dialog.

design, or a horizontal grid line to sit under a
particular object.
Use Snap to Grid to align objects in your design to
the nearest grid lines. You can align objects to the
horizontal (X) or vertical (Y) axis, or both. New
reference points will ‘snap’ to the nearest grid line as
you digitize. Existing objects will snap to grid when
you select and move them.
To set grid options

1 Right-click the Show Grid icon.
The Options > Grid dialog opens.

Select to display grid
Select snap to grid
Enter horizontal and
vertical spacing

Select to align grid
to a point

Align the grid with a specific point in the design by
setting a reference point – for example, when you
want grid lines to intersect the center point of the

2 Select the Show grid checkbox to display the
grid.
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3 Select the Set reference point checkbox to align
a significant point of the design with a grid line or
grid point.
For example, you can set the grid reference point
to the design center. This is easier and faster than
moving the whole design.

4 Enter Grid spacing values for horizontal and
vertical grid lines.

5 Select the pointer position after scrolling from the
Move pointer to list:
Option

Purpose

Center

Center of the window. Use this setting for
large movements.

Midway

Halfway between the original pointer position
and the center of the window. Use this setting
for smaller movements – e.g. when zooming
into a small area of the design.

Corner

The edge of the screen. Use this setting for
slow scrolling.

5 Select the Snap to grid checkbox.
Tip To temporarily disable Snap to grid as you
digitize, hold down Alt.

6 Click OK.
If you selected Set reference point, mark the
reference point on your design. The grid aligns so
that horizontal and vertical grid lines intersect at
this point.

Setting auto scroll options
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.

6 Click OK.
The effect of this setting only becomes apparent
when you start to digitize. The design window
automatically scrolls to follow the current cursor
position.
Tip Hold down the Shift key to temporarily
deactivate Auto Scroll.

Setting hoop options

Use Auto Scroll to scroll the design automatically
while you are digitizing. This can be more convenient
than using panning or the scroll bars.

Right-click View > Show Hoop to change the hoop
settings.

To set auto scroll options

Use General > Options to access workspace options
such as grid, hoop, and scroll settings.

1 Click Options icon and select the Scrolling tab.

A range of sizes is available to suit the size of your
design as well as a number of embroidery machines.
Select the smallest hoop which fits the design from
the range of hoop sizes available. This will hold the
fabric tight while stitching.

2 Select the Enable auto scrolling checkbox to
apply.

3 Select the Move pointer after scroll checkbox to
move the position of the pointer after each scroll.

4 Adjust the Response time field as required.
Enter smaller values to increase scrolling speed.
To set hoop options

1 Select Settings > Options and select the Hoop
tab or right-click the Show Hoop icon.
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The Options > Machine & Hoop dialog opens.
To set appliqué options

1 Click Options icon and select the Appliqué &
PunchWork tab.
This tab contains two panels – Boundaries and
Frame-out.

2 In the machine and hoop panel, choose from
among the available options:
Option

Purpose

Machine Choose your machine. This filters the hoop
list to display compatible hoops.
Hoop

Select a hoop to suit your current design. See
Selecting hoops for details.

Foot

Select the foot you are currently using. This
will affect the stitchable area within the hoop.

Show...

Use the checkboxes to toggle on/off hoop
display or the hoop template. The hoop
template may be used to help position your
design within the hoop.

3 Select a position to center your hoop. See

2 Select the required Boundaries option:
Option

Purpose

Single

Use when creating a single closed-object
appliqué object.

Multiple

Use when creating multiple closed-object
appliqué objects. See Creating closed-object
appliqué for details.

3 Select the required Frame-out method:

Centering hoops for details.

4 Manage your own hoops with the Custom Hoops
options:
 Click Create to create customized hoops. See
Creating custom hoops for details.

Method

Purpose

Automatic

If selected, the frame-out position is
determined automatically.

Manual

If selected, the frame-out position is
marked as part of the digitizing process.

Place under
If selected, the frame-out position is
cover stitches placed at the location of the last needle
penetration before the frame-out would
occur.

4 Click OK.

 Click Edit to edit existing hoops.
 Click Delete to delete existing hoops.

5 Click OK.

Setting appliqué options
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.
Use Appliqué to produce all the stitching you require
for closed-object appliqué. Options determining
single or multiple boundaries as well as frame-out
position are set in the Options dialog. See also
Creating closed-object appliqué.

Setting overlap removal options
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.
Use Remove Overlaps to remove underlying layers
of stitching. This helps to reduce the stitch count and
prevent a build-up of stitches where they are not
needed. See also Removing underlying stitching.
To set overlap removal options

1 Click Options icon and select the Remove
Overlaps tab.
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The Options > Remove Overlaps dialog opens.
To set automatic save

1 Click Options icon and select the General tab.

2 Tick the Auto-save design checkbox and enter
2 Enter the amount of overlap required in the
Cutting overlap field.

the auto-save frequency.

3 Click OK.

Choosing large or small button icons
BERNINA Embroidery Software allows you the choice
of large or small button icons with or without text
names.

Cutting Overlap: 0.5 mm

Cutting Overlap: 1.5 mm

3 Click OK.

Setting general options
BERNINA Embroidery Software lets you adjust
various general settings controlling the automatic
saving of designs, the position of the pointer
on-screen, as well the display of measurements. The
defaults are generally good enough to get you
started.

Setting automatic save
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.
Save your work automatically at regular intervals
using Auto Save to protect you from losing work in
the event of hardware or software failure. A backup
file is created every time you save a design. The
design will be saved in the BACKUP folder of your
BERNINA Embroidery Software installation. It will
have the same name as the original file with the
extension ‘BAK’.

Choose large or small
button icons with or
without text names

Interpreting pointer position values
The X and Y values show the horizontal and vertical
distance of the pointer from the relative or absolute
point. The L value is the length of the line connecting
the pointer with the start point, while A is the angle
of that line, relative to the horizontal.
Start point

length = 75.4 mm
Y = -42.7 mm

X = 61.4 mm

Caution Backup files remain in the BACKUP folder
until you delete them. To prevent the folder from
using too much hard disk space, delete unwanted files
regularly.

End point

Status
bar

X: horizontal
Y: vertical

A: angle
L: length

A negative X value indicates that the second point
was placed to the left of the first point, while a
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negative Y value displays when the second point is
below the first. Negative angles indicate angles of
more than 180º – for example, an angle of -60º is
equal to 300º.
90º
2

45º

135º

The Options > General tab provides options for
activating the following functions:
 Applying Closest Join while digitizing
 Displaying a measure tooltip when using the
Measure command
 Hiding object properties
 Grouping designs when opening and inserting.

0º

180º

To set other general options

A = 30º
1

-135º

-45º
-90º

Tip You can measure on-screen distances using the
values in the Status Bar. See Measuring distances
onscreen for details.

1 Click Options icon and select the General tab.
Set other
general options

Setting pointer position display options
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.
When you move the mouse, the pointer position is
displayed in the Status Bar at the bottom of the
screen. You can optionally display the pointer position
relative to the last digitized point or stitch point, or as
an absolute value from the first needle point of the
design.
To set pointer position display options

2 Select one or more of these options:
 Apply closest join while digitizing: The
Closest Join method (the default)
automatically calculates the closest join
between objects while digitizing. When
deactivated, all newly digitized objects are
joined by the As digitized method. See
Digitizing closed shapes for details.
 Show measure tooltip: shows length and
angle in a tooltip when measuring distances on
screen. See Measuring distances onscreen for
details.

1 Click Options icon and select the General tab.

Show Measure
Tooltip ON

2 Select a Relative or Absolute setting for the
pointer:
Option

Purpose

Relative

Shows pointer position relative to the last
digitized point or stitch point. Useful while
digitizing or editing stitches.

Absolute Shows pointer position as an absolute value
from the first needle point of the design.
Useful for checking that the design fits a
given area.

3 Click OK.

Setting other general options
Use General > Options to access workspace options
such as grid, hoop, and scroll settings.

 Hide object properties: When selected, the
Object Properties dialog automatically closes
when the Effects dialog is opened, and vice
versa. See Accessing object properties for
details.
 Group designs on open and insert: When
selected, a design is automatically grouped
when first opened or inserted into another
design. This makes it easier to drag into
position without accidentally deselecting it. This
is particularly useful when working with designs
which have been placed right on top of existing
design elements. See Working with design files
for details.

3 Click OK to confirm.
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PART II
DIGITIZING TECHNIQUES
In BERNINA Embroidery Software, you build designs from basic shapes or ‘embroidery
objects’. These are like ordinary drawing objects in that they have certain defining
characteristics or ‘properties’ such as color, size, position, and so on. They also have
properties unique to embroidery such as stitch type and density.

Outline & fill stitches
This section explains how to select basic outline and fill stitch types, as well as change
stitch settings to obtain the best results. Basic outlines dealt with here include Single
and Triple stitch, Satin stitch, and Blanket stitch. Basic fills discussed include Satin fill
and Step fill. See Outline & Fill Stitching for details.

Digitizing methods
This section describes how to digitize shapes with the main digitizing methods. It also
explains how to adjust digitizing settings to obtain the best results. See Digitizing
Methods for details.

Thread colors & charts
This section describes how to select colors from the Color Palette as well as how to
assign threads to the colors in your design. How to modify thread charts is also covered,
as well as creating custom thread charts. See Thread Colors & Charts for details.

Object properties, fabrics & templates
This section explains how to change the object properties in your design, as well as how
to apply fabric settings. It also explains how to create and maintain templates in
BERNINA Embroidery Software. See Properties, Fabrics & Templates for details.

Stitch quality
This section covers adjusting fabric settings, stabilizing with underlays, and
compensating for fabric stretch. It also describes how to preserve long stitches, adjust
tie-in/off settings, and set automatic start and end points. See Stitch Quality for details.
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CHAPTER 8
OUTLINE & FILL STITCHING
All embroidery objects in BERNINA Embroidery Software
have defining settings or ‘properties’, the most important
of which is the stitch type. Whenever you create or
modify an object, stitches are generated according to the
associated stitch type. Stitch settings such as spacing
and length can be adjusted before or after digitizing.
Stitch types divide broadly into two categories – ‘outline’
and ‘fill’. Outlines are used, as the name suggests, for
outlines or borders of shapes and for details. Fill stitches
are used to cover large areas or ‘color blocks’ in a design.
Outline and fill stitches are generated whenever you
create embroidery shapes, but they can be changed at
any time.
BERNINA Embroidery Software provides a variety of
digitizing methods or ‘tools’ for creating embroidery
objects. These tools are used in conjunction with stitch
types to create embroidery ‘objects’.
This section explains how to select basic outline and fill stitch types, as well as
change stitch settings to obtain the best results. Basic outlines dealt with here
include Single and Triple, Satin, and Blanket. Basic fills discussed include Satin
and Step. See also Advanced Digitizing.

Selecting stitch types

these at any time. Simply select an Outline stitch
type from the Stitch toolbar.

BERNINA Embroidery Software provides a number of
basic outline and fill stitch types as well as those of a
more artistic or decorative kind. Different stitch types
suit different shapes. Whenever you create an object,
it always takes the currently selected stitch type.

Outline stitching
BERNINA Embroidery Software provides basic Single,
Triple, Satin and Blanket outline stitches, as well as
more decorative stitch types. You can interchange

Fill stitches
BERNINA Embroidery Software provides basic satin
and step fills, as well as more decorative stitch types.
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You can interchange these at any stage. Simply select
a Fill stitch type from the to Stitch toolbar.

To create a single or triple outline
 Select Single or Triple from the to Stitch toolbar.
 Select a digitizing tool and digitize a shape, open
or closed.
Left and right mouse clicks create reference points
– corner points and curve points respectively. The
outline is created with default settings. See also
Digitizing Methods.

Tip Preset stitch values by changing the current
properties in the Object Properties dialog before
you digitize. See also Properties, Fabrics & Templates.

Creating simple outlines
Use Stitches > Single Outline to create a single row
of stitches along a digitized outline – used for borders
or details.
Use Stitches > Triple Outline to create a thicker
outline by repeating each stitch three times – use for
heavier borders or details.
Use Stitches > Sculpture Outline to create a tick-thin
outline alternating single and triple stitches for a
hand-stitched look.
Use the Single and Triple tools to digitize lines of
single or triple outline stitching. This is the simplest
type of stitching you can digitize. It can be used for
anything from details, object outlines, and simple
borders. Single places a single row of stitches along
a digitized line. Triple repeats each stitch three times
for a thicker line.

 Optionally, double-click or right-click an outline
object. The Object Properties > Outline Stitch
dialog opens.

Select Single
or Triple
Enter stitch
length

 Select Single or Triple from the Stitch Type list
to change stitch types as necessary.
 Adjust stitch length as necessary. If a line has
tight, sharp curves, reduce the length, for example
to 1.8 mm, so that the stitches follow the line.

Run length

Run length

Stitch length
Single Run

Triple Run

1

2

3

3

6

1

4

2

5

4

5

6

For a more hand-stitched appearance, use Sculpture
Outline. This variant stitch type alternates single and
triple stitching for a thick-thin outline.

Too few stitches to
follow tight curve

Stitches follow the
curve more closely

Tip You can mimic handmade embroidery with
Single or Triple stitches by setting the length to
4.0 mm. See also Creating craft stitches.
 Click Apply.

Creating functional outlines
Note You can’t see much difference between these
stitch types on screen. To check, view the stitching
with the Travel tools. See Traveling through designs
for details.

Use Stitches > Blanket Outline for narrow, open
borders with a ‘comb’ effect.
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Use Stitches > Zigzag Outline for narrow, open
borders with a ‘zigzag’ effect.
Blanket and zigzag stitches are used to create narrow,
open borders with a ‘comb’ or ‘zigzag’ effect. They are
generally used for practical applications, such as
borders around appliqué. They can also be used for
decorative effect. See also Decorative Stitching.

 Adjust the spacing field as necessary. This value is
the distance in millimeters between each stitch.

Spacing: 1.0 mm

Spacing: 2.0 mm

Spacing: 3.5 mm

 Adjust the width field as necessary. This value
controls the thickness of the border or outline.

Blanket width: 2.5 mm
Blanket width: 5 mm

 Adjust blanket orientation as necessary.

Adjust blanket
stitch orientation

You can adjust stitch width and spacing.
Stitch width
Blanket
width

To create a blanket or zigzag outline
 Select blanket or zigzag from the Stitch toolbar.
 Select a digitizing tool and digitize a shape, open
or closed. See Digitizing Methods for details.
When an open shape is digitized left-to-right,
blanket stitch is oriented downwards. Otherwise, it
is oriented upwards.

 To adjust spacing and width, double-click or
right-click the object.
The Object Properties > Outline Stitch tab
opens. The spacing and width controls are similar
for both stitch types.

 With blanket, stitches are positioned by default
around the center of a digitized line. You can,
however, offset them to one side, depending on
where you want the border to sit in relation to the
enclosed object/s.

Select Center
or Offset

 Like satin outline, the blanket and zigzag stitch
Calligraphy setting can be used to create
thin-thick effects.

Thin-thick
calligraphy effect

Creating specialty outlines

Adjust spacing
and width

Backstitch and stemstitch are two versatile outline
stitches. Backstitch forms a continuous thin line,
similar to machine stitching, while stemstitch
produces rope-like lines which can vary in thickness
depending on stitch angle. Both can be used to make
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a smooth continuous row of stitching suitable for
outlines and for blackwork.

 Zoom in and activate needle points to study
adjustments better.

Stemstitch outlines
Backstitch outlines
Use Stitches > Backstitch Outline to create
backstitch borders – old, adaptable stitch type used
for delicate outlines.
Backstitch is an old, adaptable stitch which can be
used as a delicate outline. This small, even stitch
follows intricate curves well. Backstitch can be used
for blackwork and redwork designs. You can specify
the exact stitch length, thickness and overlap values
as well as the number of strokes.

Backstitch settings
Backstitch settings can be adjusted in the usual way
via Object Properties.
 Double-click an outline object to open the dialog.

 Hover the cursor over a field and use the graphic
display to interpret the setting.

Use Stitches > Stemstitch Outline to create
stemstitch borders or for details such as stems and
vines.
Stemstitch is a detail stitch that can be used to outline
items or fill in areas. It is used for stems and vines
with other decorative stitches, or as an outline for
stitches such as Satin fill or Pattern Fill. You can
specify various settings including line thickness,
spacing, angle, single or triple, and stitch thickness.

Stemstitch settings
Stemstitch settings can be adjusted in the usual way
via Object Properties.
 Double-click an outline object to open the dialog.

 Hover the cursor over a field and use the graphic
display to interpret the setting.
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 Zoom in and activate needle points to study
adjustments better.

The outline is created with default Satin stitch
settings. Stitch spacing and width can be adjusted
before or after digitizing. See Adjusting satin stitch
spacing for details.

Adjusting satin stitch spacing
Click General > Object Properties to adjust stitch
spacing and width.
Change satin density by adjusting the spacing setting.
The larger the spacing, the lower the density.

Creating satin outlines
Satin width

Satin stitch can be used for outlines or fills. It is
well-suited to thicker borders. Adjust stitch density by
setting a fixed spacing value, or let Auto Spacing
calculate it for you.

Satin spacing

Where a border narrows, stitches need to be less
dense because too many needle penetrations can
damage the fabric. For varying width objects,
automatic spacing adjusts spacing accordingly.
To adjust satin stitch spacing
 Double-click or right-click a satin object.
The Object Properties > Outline Stitch >
Satin dialog opens.

Creating outlines with satin stitch
Use Stitches > Satin Outline to create thicker borders
or columns of even thickness.
Use Stitches > Raised Satin Outline to create raised
satin borders – can be used with trapunto for quilting
effects.
Use Satin outline type to create thicker borders.

Select Manual to
change stitch spacing

 Optionally, select the Manual option. The spacing
field is activated.
 To increase stitch density, enter a smaller
value.
 For more open stitching, enter a larger value.

To create a satin stitch outline
 Select Satin Outline from the to Stitch toolbar.
See also Stitches toolbar.

Stitch Spacing 0.6mm

Stitch Spacing 1.0mm

 For variable satin shapes, use automatic spacing.

 Select a digitizing tool and digitize a shape, open
or closed. See Digitizing Methods for details.

Auto Spacing ON

Auto Spacing OFF
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Tip If a satin border is wide, some stitches may
exceed the maximum stitch the particular
embroidery machine can produce. When Satin
Special is applied, BERNINA Embroidery Software
breaks any long satin stitches into shorter ones.
See also Splitting long stitches in satin fills.

 The satin outline Calligraphy setting can be used
to create thin-thick effects. See also Creating
freehand embroidery.

Adjusting satin width & offset
Click General > Object Properties to set stitch
offsets.
By default, stitches are positioned around the center
of a digitized line. You can, however, offset them to
one side. Width can be controlled interactively or via
object properties. You can also create variable widths
via the calligraphy setting.
To adjust satin width and offset
 Double-click or right-click a satin outline.
The Object Properties > Outline Stitch >
Satin dialog opens.

Thin-thick
calligraphy effect

Creating satin fills
Satin fill is well-suited to stitching narrow borders and
shapes, where the length of each stitch forms the
width of the border. Satin stitches are almost parallel,
with every second stitch slightly slanted. Because
there are generally no needle penetrations breaking
up the fill, Satin Fill creates a glossy, high-quality
effect.

Select center
or offset

 Select an offset option – Center or Offset. This
can be important for controlling overlaps when
applying a satin border to filled objects.

Satin outline
stitches centered

Reference
points

Creating fills with satin stitch
Satin outline
stitches offset

 Adjust column width in the Satin Width field. The
width can also be adjusted via control points in
Reshape mode.
Adjust
column width

Use Stitches > Satin Fill to create stitch fills for
narrow shapes.
Use Stitches > Raised Satin Fill to create raised
surfaces – can be applied to lettering or used with
trapunto for quilting effects.
Use Satin Fill when creating narrow shapes of
varying width. Change the stitch density in satin fills
at any stage.
Satin spacing

Width

Where a shape is narrow, stitches need to be less
dense because too many needle penetrations can
damage the fabric. The larger the spacing, the lower
the density.
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Tip Use Raised Satin Fill to create raised
embroidery designs consisting of multiple layers of
satin stitching. See also Quilted embroidery.

Auto spacing automatically adjusts the stitch
spacing wherever a column changes width.
Automatic stitch spacing

Manual stitch spacing

To create a satin fill
 Select Satin Fill from the Stitch toolbar and
digitize a closed shape. See Digitizing Methods for
details.

Varying spacing depending
on column width

Constant spacing for
whole object

Splitting long stitches in satin fills
If a satin shape is wide, some stitches may exceed the
maximum stitch the particular embroidery machine
can produce. When Satin Special is applied,
BERNINA Embroidery Software breaks any long satin
stitches into shorter ones. It also distributes needle
penetrations in a random pattern so that they do not
form a line down the middle of the shape.

 Double-click or right-click a satin fill object to
adjust settings.
The Object Properties > Fill Stitch > Satin
dialog opens.
While Satin Special is used primarily to prevent long
stitches in wide shapes, it can also be used as an
alternative to Step fill. Satin Special looks more
Satin-like and works well with turning stitches,
creating soft lines and a little more depth. By
contrast, Step fill is flat and can show unwanted
patterns with tight curves.

Select Manual

 Optionally, select the Manual option. The spacing
field is activated.
 To increase stitch density, enter a smaller
value.
 For more open stitching, enter a larger value.

To split long stitches in satin fills
 Double-click or right-click a satin fill object.
The Object Properties > Fill Stitch > Satin
dialog opens.

Select
Satin Special
Stitch Spacing 1.0mm

Stitch Spacing 1.8mm

 To apply automatic spacing, select the
Automatic, checkbox.
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 Select the Satin Special checkbox.

You can also specify step fill stitch length. This varies
slightly to ensure that small stitches are not
generated at the edges.
To create a step fill

Satin Special On

Satin Special Off

Creating step stitch fills

 Select Step Fill from the to Stitch toolbar and
digitize a closed shape. See Digitizing Methods for
details.
 Adjust entry / exit points and stitch angle. These
have a direct bearing on step fill appearance. See
also Reshaping objects.

Different stitch types suit different shapes. BERNINA
Embroidery Software provides normal Satin and Step
fills, as well as Fancy and Craft Stitch fills.

Step fill consists of rows of straight stitches and is
suitable for filling large, irregular shapes. Stitches are
laid in rows going back and forth across the shape.
These can be uniform or patterned. You can choose
from a number of preset patterns. You can also
control stitch spacing and length.

Note With Step fills you can select patterns formed
by needle penetrations. The default Step pattern (No.
1) is designed to create a uniformly flat and smooth
texture similar to a woven mat. See also Applying
step fill patterns.

Creating fills with step stitch
Use Stitches > Step Fill to create stitch fills for larger,
irregular shapes.
Use Step fill for large and/or irregular shapes. Stitch
spacing is the distance between two forward rows.

 To adjust step fill spacing and length, double-click
or right-click a step fill object.
The Object Properties > Fill Stitch > Step
dialog opens.

Adjust stitch
spacing and length

Tip You can preset stitch settings before
digitizing. Click the Object Properties icon to
access the dialog at any time.
 Use the Stitch Spacing field to adjust step fill
spacing:
 To increase density, enter a smaller value.
 To decrease density, enter a larger value.

Stitch spacing

Stitch
length
Forward
Backward
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 In the Stitch Length field, enter the stitch length
you require.

 Select a pattern. A preview of the pattern appears.

 Click Apply.
 Click Apply.

Applying step fill patterns
Click General > Object Properties to set step
patterns.
With Step fills you can select patterns formed by
needle penetrations. The default Step pattern (No. 1)
is designed to create a uniformly flat and smooth
texture similar to a woven mat. See also Decorative
Stitching.

There are other preset patterns to choose from.
Experiment to find the best pattern for your purpose.
See Step Fill Samples for details.
To apply a step fill pattern
 Double-click or right-click a step fill object.
The Object Properties > Fill Stitch > Step
dialog opens.

Select Step
fill pattern
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CHAPTER 9
DIGITIZING METHODS
In BERNINA Embroidery Software, you build
designs from basic shapes or ‘embroidery objects’.
The process of creating embroidery objects
on-screen is called ‘digitizing’. Like creating designs
in graphics applications, this involves the use of
different digitizing tools or methods. These are
used in conjunction with stitch types to create
embroidery objects.
There are also tools for creating designs with a
hand-drawn appearance, something which is
difficult to achieve through conventional digitizing
methods.
This section describes how to digitize shapes with
the main digitizing methods. It also explains how to
adjust digitizing settings to obtain the best results.

Digitizing tools

Use Digitize > Closed Object to digitize closed
embroidery objects.

Different digitizing methods or ‘tools’ are suited to
creating different shapes or design elements.
Digitizing methods divide broadly into two categories
– outline and fill.

Use Digitize > Ellipse to digitize ellipse or circle
embroidery objects.

Like drawing objects, embroidery objects have certain
defining characteristics or ‘properties’ such as color,
size, position, and so on. They also have properties
unique to embroidery such as stitch type and density.
The most important property for an embroidery
object is its stitch type. Different stitch types are
suited to different shapes. See Outline & Fill Stitching
for details.

Use Digitize > Rectangle to digitize rectangle or
square embroidery objects. Press <Ctrl> to
constrain.
Use Digitize > Block to digitize columns with turning
stitches.

Tip Drawing objects themselves can be converted to
embroidery objects using Magic Wand. See
Auto-digitizing with Magic Wand for details.

Digitizing methods divide broadly into two categories
– outline and fill. BERNINA Embroidery Software
provides various tools with which to digitize shapes –
Open Object, Closed Object, Block, Ellipse, and
Rectangle. The Open Object tool is used to create
outline shapes. The Block Digitizing tool is used to
create columns of varying width and stitch angle. The
Closed Object, Ellipse, and Rectangle tools are
used to create filled or outlined shapes.

Selecting digitizing tools

Reference points and reshape nodes

Use Digitize > Open Object to digitize embroidery
objects.

Once you have selected a digitizing tool, you digitize
shapes by marking ‘reference points’ along an outline
using the following conventions:
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 Click to enter corner points.
 Right-click to enter curve points.

to specify entry and exit points when digitizing closed
objects. See Setting general options for details.
Closest
Join on

In general, you mark a reference point where:

Closest
Join off

 a curved outline changes curvature
 the outline has corners
 the outline changes from a straight line to curve.
The reference points you mark when digitizing
become ‘reshape nodes’ during reshaping operations.
Other control points associated with objects allow you
to transform objects (rotate, skew, etc), scale
(resize), adjust letter spacing, and change entry and
exit points.

Reshape nodes are color-coded, corner points
appearing as yellow squares, curve points as
turquoise circles, and stitch angle points as orange
squares. Object entry points are shown as green
diamonds, exit points as red crosses. The start and
end points of an entire design are indicated by a small
green circle and small red cross respectively.

Note Most reshape nodes can be added, deleted,
moved or changed to either corner or curve points.
Some reshape nodes have a specific function and
cannot be deleted – for example, the entry point
marker. See also Reshaping & Editing Objects.
Join methods
The Closest Join setting automatically calculates the
closest join between objects while digitizing saving
you having to think about entry and exit points. When
activated (the default), all newly digitized objects are
joined by this method. When deactivated, all newly
digitized objects are joined by the As Digitized
method. This means they are joined from the exit
point of the last digitized object to the entry point of
the new object. When Closest Join is off, you are able

Object properties
Object properties are defined as you digitize, but they
can be changed at any stage. When you create an
embroidery object, you can accept the default
settings for the particular digitizing method, or apply
new ones. Default settings are stored in the design
template. You can also define ‘current’ properties to
influence all the objects you create in the current
design. See Properties, Fabrics & Templates for
details.

Digitizing regular shapes
Use Digitize > Ellipse to digitize ellipse or circle
embroidery objects.
Use Digitize > Rectangle to digitize rectangle or
square embroidery objects. Press <Ctrl> to
constrain.
BERNINA Embroidery Software provides digitizing
tools for quickly creating regular shapes such as
circles and squares, ovals and rectangles.
To digitize a regular shape
 Select an Outline or Fill stitch type. See Selecting
stitch types for details.
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 Digitize circles and ovals with a few clicks of the
Ellipse tool. Use any fill or outline stitch type.

 Drag the pointer and click to define the
opposite corner.
1

2

Single

Blanket

Satin

Tip To create a square, hold the Ctrl key down
whilst dragging the pointer.

Digitizing complex shapes
Step

Fancy

Pattern Run

 To digitize a circle or oval...

BERNINA Embroidery Software provides input tools
for digitizing irregular shapes, both open and closed.
Closed objects may use outline or fill stitch types.

 Click to mark the center.
 Drag the pointer and click the radius reference
point.
 To create a circle, press Enter. To create an
oval, mark a second radius point, and press
Enter.
3

center 1

1
center
2

Digitizing open shapes
Use Digitize > Open Object to digitize open shapes.
Use the Open Object tool to digitize open shapes of
single/triple run, satin, blanket, patterned or craft
stitching. Open Object places a row of stitches along
a digitized line. This tool is typically used to add
borders to designs.

2

Press Enter

Press Enter

 Digitize squares and rectangles with a few clicks of
the Rectangle tool. Use any fill or outline stitch
type.

To digitize an open shape
Single

Satin

Blanket

1 Select an outline stitch type. See Outline & Fill
Stitching for details.

2 Click the Open Object icon.
3 Digitize the shape, by marking reference points
Step

Pattern Run

Fancy

around its outline.
 Click to enter corner points.

 To digitize a square or rectangle...
 Click to mark a corner.

BERNINA® Embroidery Software : Reference Manual

72

Chapter 9 : Digitizing Methods
 Right-click to enter curve points.
2

2

4

4
3

1

3

1
6

5

5
6

Tip Follow the prompts in the Status Bar to help
you digitize. If you make a mistake, press
Backspace to delete the last reference point, then
continue adding reference points or press Esc to
delete all the points so you can start again.

3 Close the shape.
Tip Follow the prompts in the Status Bar to help
you digitize. If you make a mistake, press
Backspace to delete the last reference point, then
continue adding reference points or press Esc to
delete all the points so you can start again.

 To close the shape with the same type of
reference point as the last you digitized – i.e.
corner or curve – simply press Enter.
 To close the shape using a different type of
reference point, mark the last on top of the first
and press Enter.

4 Press Enter to complete the shape.
Note If you decide to close the object, use the
Edit > Close Curve ... commands with the option
of using straight or curved points.

2

2

4

4

3
1

5

3

1

6

6

5

Objects are closed automatically

4 Repeat as many times as necessary to create more
objects.
Open object

Close Object used

Digitizing closed shapes
Use Digitize > Closed Object to digitize closed
shapes.

Note By default, objects are joined by the
Closest Join method. If deactivated, all newly
digitized objects are joined by the As Digitized
method. This means you need to specify entry and
exit points, following prompts in the Status Bar.
See Setting general options for details. See also
Adjusting entry & exit points.

Digitize complex shapes with the Closed Object tool.
Create objects using left and right clicks to mark
reference points to form the boundary outlines.

As digitized

Closest join

5 Press Esc to deselect the tool.
Outlined closed object

Filled closed object

To digitize closed shapes

Digitizing columns of turning stitches

1 Select an outline or fill stitch type. See Selecting
stitch types for details.

2 Select the Closed Object tool and digitize the
boundary of the shape by marking reference
points around its outline:
 Click to enter corner points.
 Right-click to enter curve points.

Use Digitize > Block to digitize columns with turning
stitches.
Use the Block Digitizing tool to digitize columns of
varying width and stitch angle. Digitized pairs of
reference points define the outline, while lines
connecting the pairs define the stitch angles.
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To digitize a column of turning stitches

other general options for details. See also
Adjusting entry & exit points.

1 Select a Fill stitch type. See Outline & Fill Stitching
for details.

2 Click the Block Digitizing icon.
3 Digitize the column by marking reference points on
alternate sides of the column.
 Click to enter corner points.
 Right-click to enter curve points.
Mark a pair of points wherever the outline
changes, and wherever you want the stitch angle
to change.

Tip If you are using the As Digitized method,
you can choose whether to omit or include the last
stitch. For example, if joining two objects, keep or
omit the last stitch so that the exit point is close to
where you begin the next object.
 Press Enter to keep the last stitch and place
the exit point at the last reference point you
marked.
Start

Start

Finish

 Press Spacebar to omit the last stitch and
place the exit point on the opposite the last
reference point you marked.
Start
Stitches change their
angle gradually

Finish

Start

Stitches remain parallel
between parallel stitch angles

Tip The reshape nodes in a pair do not have to be
the same type. For example, one can be a corner
point, the other a curve.

6 Press Esc to deselect the tool.

Creating freehand embroidery

Mixed curve and corner control
points within the same pair

The Freehand Embroidery feature provides
functionality similar to CorelDRAW® Freehand and
Polyline tools. This is a technique that lets you create
designs with a hand-drawn appearance, something
which is difficult to achieve through conventional
digitizing methods. The aim is to mimic designs
formed on an embroidery machine by freehand
motion. The difference is that the fabric secured in an

Tip If you make a mistake, press Backspace to
delete the last reference point, then continue
digitizing.

4 Press Enter to complete.
5 Repeat as many times as necessary to create more
objects.
By default, objects are joined by the Closest Join
method. If deactivated, all newly digitized objects
are joined by the As Digitized method. This
means you need to specify entry and exit points,
following prompts in the Status Bar. See Setting
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embroidery hoop, allowing the needle to ‘draw’ on the
fabric surface, exactly as you have drawn on-screen.

Creating freehand shapes
Use Digitize > Open Freehand to draw embroidery
outlines onscreen in the current stitch type.
Use Digitize > Closed Freehand to draw closed
embroidery objects onscreen in the current stitch
type – outline or fill.

Other techniques include stitching on top of
photographic images or detailed line drawings. For
example, use the tools to manually trace a color
photo-stitch design. This technique requires accuracy
and control of corners, similar to the CorelDRAW®
Polyline tool.

The Freehand Embroidery feature is deployed in
two forms: ‘Open Object’ and ‘Closed Object’. As with
other digitizing tools, freehand tools can be used in
conjunction with all stitch types currently available.
With these tools, however, you draw objects directly
on screen and, in the case of outline objects, view a
stitch simulation as you draw. It is thus possible to
produce artistic effects similar to free-motion
machine embroidery or ‘thread painting’. Use the
feature to preview designs you have in mind before
attempting to sew them out manually. Alternatively,
once designed on screen, sew them out automatically.

Tip The Freehand Embroidery tools can be
operated with a mouse or WACOM pen.
To create freehand shapes
 To create freehand objects, select a Freehand
tool.
 Select a color from the Color Palette and any of
the available stitch types.
The full range of outline stitches is available for use
and, with the Closed Freehand tool. Most fill
stitch types as well.

Alternatively, designs resembling pencil or charcoal
sketches can be quickly digitized. Use the tools to
create ‘doodle’ type drawing effects without following
detailed artwork – for example, adding to a basic
clipart design or decorative text and so on.

 Choose the preferred cursor style, and pre-set a
smoothing factor to determine how closely to
follow the digitized line. See Adjusting freehand
line smoothness for details.

Set smoothing
preference

Choose cursor
style

 Click and drag to draw. Release to finish.
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BERNINA Embroidery Software displays the
stitches as you drag.

Tip Combined with the Satin stitch Calligraphy
setting, Open Freehand can be used to create
embroidered calligraphy. For best results, a wider
satin width and more layers than the default may
be required. See also Creating satin outlines.

Thick-thin
calligraphy effect

 To create closed objects, select the Closed
Freehand tool.
 If an Outline stitch is selected, a ‘rubber band’
encloses the shape.

Adjusting freehand line smoothness
Use Digitize > Open Freehand to draw embroidery
outlines onscreen in the current stitch type.
Use Digitize > Closed Freehand to draw closed
embroidery objects onscreen in the current stitch
type – outline or fill.
The Freehand Embroidery tools have a special
cursor. This is designed to provide a spacing guide as
you use the tools. The number and spacing of the
concentric circles is controlled by the Freehand
Settings toolbar. This toolbar can be docked or
floating.
To adjust freehand line smoothness

 If a Fill is selected, a wireframe ‘mesh’ is
displayed as you drag.

 Create a freehand design using outline and/or
filled objects. See Creating freehand shapes for
details.

 Adjust the ‘smoothness’ of your freehand lines by
means of the Smoothing controls.
The toolbar contains a Smoothing control which
lets you specify, as a percentage, how closely the
smoothed outline follows the original. By adjusting
the percentage, you increase or decrease the
 Release the mouse button.
BERNINA Embroidery Software closes and
smooths the object outline.

BERNINA® Embroidery Software : Reference Manual

76

Chapter 9 : Digitizing Methods
number of control points BERNINA Embroidery
Software uses to define an embroidery shape.

the Shift key, the edited path is joined with a
straight line to the mouse position.

No smoothing

Hold the Shift key
and drag back
With smoothing

 Toggle display of the freehand cursor guide as
required:
Tool

Note
Use Show Guide to toggle freehand
digitizing guide cursor – provides more
control over ‘freehand’ drawing than the
default pointer.
Use the Guide Inner Circle Radius control
to define the size of the center circle of the
freehand digitizing guide.

 Alternatively, press the Backspace key. The last
point digitized is removed.
 Release the mouse to finish the outline at the last
point digitized. Or press Esc to cancel input of the
object.
Note Objects created using the Freehand
Embroidery tools can be reshaped in the same
way as objects created via conventional methods
by selecting the object and clicking the Reshape
Object tool in the Transform toolbar.

Use the Number of Guide Circles control to
set the number of circles in the freehand
cursor – if the inner circle radius is 2mm,
each additional guide circle is offset by
2mm.
 You can view and edit the control points generated
by Freehand Embroidery tools in Reshape
mode.

No smoothing

With smoothing

 If you want to erase a portion of a line, press and
hold the Shift key while dragging backward over
the line before releasing the mouse. On releasing
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CHAPTER 10
THREAD COLORS & CHARTS
When you digitize, you select thread colors for each object you create from the
Color Palette in the design window. The palette contains a selection of thread
colors tailored to each design. This color scheme represents the actual threads in
which the design will be stitched.

You can select colors from commercial thread charts containing a range of colors
from different manufacturers. To save time when setting up new color schemes,
you can create your own thread chart using your favorite or most frequently used
colors. In BERNINA Embroidery Software you can search for particular threads by
criteria. Even match threads automatically from selected charts to colors in your
design.
This section describes how to select colors from the Color Palette as well as how
to assign threads to the colors in your design. How to modify thread charts is also
covered, as well as creating custom thread charts.

Changing thread colors
BERNINA Embroidery Software provides various
techniques to selecting and changing colors
individually or across entire designs.

Note Due to the differences in computer monitors
and computer video cards, the approximate colors
displayed should be used only as guides. Threads
should always be matched to the appropriate physical
color card.

Selecting thread colors
Use Color Palette > Color Picker to pick up a color
from an existing object and make it current.
Use Color Palette > Apply Current Color to apply the
currently selected palette color to embroidery
objects.
Use Color Palette to set current color.
Use Color Palette > Add Palette Color to add a color
to the end of the color palette.
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Use Color Palette > Remove Palette Color to remove
an unused color from the end of the color palette.

The selected objects change color accordingly.
Used colors are tagged with a blue marker.

Use Color Palette > Hide Unused Colors to show or
hide all unused colors in the color palette.

Changed color

Use Color Palette > Remove Unused Colors to
remove all unused colors from the color palette.
New objects are digitized using the current color on
the Color Palette. You can change colors at any
time. Used colors are tagged with a blue dot.
To select thread colors
 Deselect all objects. The currently selected
(default) color is shown on the toolbar.
 Use the controls to hide or remove unused colors
from palette.
 Use the +/- buttons to add or remove colors.

Changing color schemes
Use Color Palette > Cycle Used Colors to cycle
through combinations of used colors. Right- or
left-click.
Use Color Palette > Color Wheel to access Color
Wheel to test combinations of related colors.

Current color

 Hover the mouse pointer over a color to view its
brand, code and description in a tooltip.
 Click a color in the Color Palette to make it
current. Alternatively, pick colors from existing
objects with the Color Picker tool.
 Select object/s you want to recolor. Alternatively,

The Color Wheel allows you to try out and change
entire color schemes. The main purpose of the tool is
to create a new ‘colorway’ quickly and easily in order
to ‘spice up’ old designs or place them on a different
fabric.
To change color schemes
 Use the Cycle Used Colors tool to try out
different combinations using available threads.

select a color block in the Color Film.

Current selection

 Alternatively, select Color Wheel from the
palette.
 Select a color from the Color Palette.
Alternatively, transfer colors to other objects with
the Apply Current Color tool.

This allows you to cycle through many color
combinations using preset color schemes including
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Analogous, Complementary, Harmonious,
etc.

 Use the Brightness control further adjust
selected colors.

Select color scheme

Adjustable color wheel
for color combinations

 Click and drag the ‘base color’ node to try out
different combinations within the same colorway.

Adjust individual
color node

Control brightness of
selected color

 To adjust the brightness of the entire design,
select the base color node and adjust the
Brightness control.
 Click OK to apply changes.
The design updates to reflect the new color
scheme.

Click and drag base
color node to adjust all

Note The base color nominally relates to the
target fabric.
 Click and drag individual color nodes to adjust.

Note If you have sufficient colors already defined
in the color chart, they will be automatically
matched.
 If you need to match and assign thread colors, you
can do so manually or use the Match & Assign All
function. See Matching threads for details.

Assigning thread colors
Typically you will want to assign actual thread colors
to the Color Palette in these instances...
 When you convert vector graphics in Graphics
mode, colors are appended to the color palette as
RGB values which can be matched to actual
threads.
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 When you auto-digitize a bitmap and want to
match RGB values to actual threads.

3 Click the Thread Colors button to access the
thread chart listing.

 If you read a machine file, color information will be
appended to the Color Palette. Again, you can
match these colors to actual threads.

Click to open
thread charts

 If you receive a design which uses colors from a
thread chart you don’t have, you can match them
to a preferred thread chart.
In BERNINA Embroidery Software you can search for
particular threads manually by various criteria and
assign them. Thread color matching lets you find and
change thread colors in one or several charts, based
on closest match.

Tip The Thread Colors > Print option allows you to
print the thread list in the current thread chart as a
shopping reference when purchasing threads. See
Printing thread charts for details.

Matching threads

4 Choose the chart or charts you want to match and

Use Color Palette > Thread Colors to search for and
match threads from different charts, and assign for
use. Right-click to access Design Properties >
Thread Colors summary tab.

click OK.

5 Click the Match All button in the My Threads
docker.

Use the Match All command to match design colors
to threads in a selected thread chart.
To match threads

1 Open a design.
The design below has been auto-digitized. Color
slots have been assigned default BERNINA colors.

Default colors
assigned

2 Click the Thread Colors icon. The My Threads
docker opens.

BERNINA® Embroidery Software : Reference Manual

81

Chapter 10 : Thread Colors & Charts

6 Check the thread assignments in the Color
Palette by hovering the pointer over the slots.

 Click a color in the Color Palette to make it
current. The My Threads list updates accordingly.

Select a color
Threads assigned from
selected chart

Searching & assigning threads
Use Color Palette > Thread Colors to search for and
match threads from different charts. Right-click to
access Design Properties > Thread Colors summary
tab.
You can search for a thread by code or description and
assign it to a selected design color slot. The supplied
charts represent the brands of threads that BERNINA
Embroidery Software supports. Each chart has a
range of colors associated with it. The code, brand
and description of each color is displayed so that you
can easily find them in a craft or sewing shop. You can
select colors by shade or by number. Select the thread
chart for the brand of thread you have at home or just
select a chart which has colors you like.

Note You can also create your own thread charts,
even charts which include threads from different
makers. See also Creating charts.
To search and assign a thread
 Deselect all objects. The currently selected
(default) color is shown on the toolbar.

 Use the scrollbar to look for a suitable thread.
 Alternatively, in the Search field, enter the first
few characters of the required code or name. The
code is the identification number of a thread color
in a brand. The system searches for the closest
match and displays it in the thread color list.
Enter thread code
if known

Color reassigned

 Once you’ve found a suitable thread, double-click
to assign to the selected color slot.

 Click the Thread Colors icon. The My Threads
docker opens.
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 Continue to assign other threads as desired.
To update an existing chart
Double-click color to
assign to palette

 Select Design > Thread Colors or click the
button in the My Thread Charts dialog.
The Manage Thread Charts dialog opens.

Colors reassigned

Note Selected color settings only apply to the
current design and are part of the ‘design
properties’. As such they are saved with the
design.

Tip You can also access the Manage Thread
Charts dialog via Design Properties > Thread
Colors. See also Viewing design properties.

Managing thread charts
Thread charts in BERNINA Embroidery Software
represent the many different brands and colors of
thread available. They may not always be accurate
because thread manufacturers often change, delete,
and add new colors to their lines. For this reason, you
can update charts as necessary.

Tip The Thread Colors > Print option allows you to
print the thread list in the current thread chart as a
shopping reference when purchasing threads. See
Printing thread charts for details.

Updating existing charts
Use Color Palette > Thread Colors to search for and
match threads from different charts, and assign for
use. Right-click to access Design Properties >
Thread Colors summary tab.

 From the Name list, select the chart to modify.
 In the Threads list, select the thread to modify.
Select thread chart

You may want to remove obsolete threads from a
thread chart, rename a thread chart, or delete
obsolete thread charts altogether.

Note Be careful when deleting thread charts. If you
delete the wrong chart you will need to reinstall
BERNINA Embroidery Software to restore it.

Select thread to modify

Click to edit thread color
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 Click Edit. The Edit Thread dialog opens.

match and replace design colors with your available
threads.

Click to select
or mix color

To create a new chart

Edit code, brand
and description

 Select Design > Thread Colors or click the
button in the My Thread Charts dialog.
The Manage Thread Charts dialog opens.

 Edit the color, code, brand, and description details
for the thread as required. Code is the
identification number of a thread color in a brand.
 Optionally, select the thread (or threads) to
remove. Use Shift and Ctrl keys to select
multiples.

Create a new
thread chart

 Click Create. The Create Thread Chart dialog
opens.

Click to remove selected
threads from chart
My Thread Chart

Enter chart
name

 Enter a name for the chart and click OK.
New thread chart
Click to remove ALL
colors from chart

 Click Remove to remove selected threads from
the chart. Click Clear All to remove everything.
Rename selected
thread chart

 Click Add. The Add Thread dialog opens.
Remove selected
thread chart

 Optionally, click Rename to change the thread
chart name. Use names that will help you
remember or sort frequently used charts to the top
of the list.

My Madeira 40

1234
My Brand
Purple

Click to select
or mix color
Enter code, brand
and description

Rename chart

 Optionally, click Delete to remove a selected
thread chart altogether. Be careful. If you delete
the wrong chart you will need to reinstall BERNINA
Embroidery Software to restore it.

Creating charts
When you create a thread chart, you are creating a
store of colors to use in your designs. For instance,
you may want to create a chart consisting of threads
you already have in your collection. This may include
multiple brands of threads. Having a pre-sorted list in
your own custom thread chart makes it easier to
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 Enter color, code, brand, and description details for
the thread as required. Code is the identification
number of a thread color in a brand.

Click to copy from other chart

 Optionally, click Copy. The Copy Thread Chart
dialog opens.
Select thread chart to copy from

Select threads
to copy

 Select the source chart and select the colors you
want to copy. Use Shift and Ctrl keys to select
multiples.
 Click OK. The colors are copied to the thread
chart, and appear at the bottom of the list.

 Click Close. The new chart is created and ready
for use.
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CHAPTER 11
PROPERTIES, FABRICS & TEMPLATES
The properties of embroidery objects define general
characteristics such as size and position, as well as
embroidery-specific characteristics such as stitch type
and density. The particular stitch settings determine
how stitches will be regenerated when you reshape,
transform or scale an object.
When you create an embroidery object, you can accept
default settings for the particular digitizing method, or
apply new ones.
BERNINA Embroidery Software provides a set of
customized fabric settings so that the software will take
into account the type of fabric you are stitching on.
Templates are special files used to store default settings.
Use templates when digitizing frequently-used design
types so that you do not have to set the current
properties every time.
This section explains how to change the object
properties in your design, as well as how to apply fabric
settings. It also explains how to create and maintain
templates in BERNINA Embroidery Software.

Working with object properties
BERNINA Embroidery Software stores three sets of
object properties: default, current and existing.

they remain the same as the template defaults. You
generally change them to save time when digitizing.
For example, you may preset the Step stitch spacing
setting to use a specific density for all new Step
objects you create.

Note Some object properties can be modified
on-screen; for example, you can change the size
properties by scaling the object with the selection
handles. Other properties, such as stitch spacing or
length, are modified in the Object Properties dialog.

Note The change affects new objects in the design,
not the template itself. To apply changes to all new
designs based on the current template, you need to
change the default – not the current – properties.

Default object properties

Properties of existing objects are the settings stored
with each object in the design.

Default object properties are the properties stored in
a design template and become the starting settings
used when creating a new design based on that
template.
Current object properties

Properties of existing objects

Setting current object properties
Use General > Object Properties to set current
properties.

Current object properties are the settings used to
create new objects. Unless you change these settings,
BERNINA® Embroidery Software : Reference Manual

86

Chapter 11 : Properties, Fabrics & Templates
When you change current object properties, the new
settings automatically apply to any objects
subsequently created in the current design.
To set current object properties

1 Click the Object Properties icon with no object
selected.
The Object Properties dialog opens. Tabs
provide access to all possible object properties.
Select tab

Note Changing the properties of existing objects
does not affect the current or default settings, nor the
properties of any objects not currently selected.
To change properties of selected objects

1 Select the object/s whose properties you want to
change.

2 Double-click or right-click the object/s.
The Object Properties dialog opens.

3 Select the tab you want and change the settings as
required.
Satin spacing
controlled by
current fabric

4 Click Apply.

Changing default object properties
Adjust
statin type

2 Click a tab to view current settings, and update as
required.
Note Not all settings are available for update. Any
defined by the current fabric cannot be overridden,
except for selected objects.

3 Click Apply.

Use General > Object Properties to set current
properties.
You can change default object properties at any time
by saving the properties of the object you are working
with to the current template. Only settings relevant to
that object are saved. Other properties retain their
current settings. For example, if you make the
properties of a selected Satin object the default, the
default Fancy Fill settings will not change. While
saving changes to the template, you can choose
whether settings will relate to lettering objects only,
other types of objects, or both.

Changing properties of selected objects
Use General > Object Properties to set current
properties.
You can change the properties of selected object/s.
For example, if you make a design bigger, you may
want to stitch some objects with Step fill instead of
Satin fill for better coverage. If you select more than
one object, the Object Properties dialog will only
display tabs that include relevant settings for all
selected objects.

Default Satin Spacing
values applied

New Satin Spacing
values applied

Note The change affects all new designs created
using this template. If you only want the changes to
apply to the design you are working in, change the
current – not the default – properties. See Setting
current object properties for details.
To change default object properties

1 Select the object/s on which you want to base the
defaults.
If selected objects have different current values for
the same setting, the field will be blank. If you enter
a new value, it will apply to all objects.

2 Double-click or right-click the object/s.
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The Object Properties dialog opens.

6 Click OK to update the template.
The object properties are saved to the current
template and will apply to any new objects of the
specified type based on this template.
Note You can also create a new template using
modified object properties as defaults. See
Working with design templates for details.

Working with fabrics

Change settings
as required

Click to save to
template

3 Select the tab you want and change the settings as
required.

4 Click Save To Template.

Embroidery stitches pull fabric inward where the
needle penetrates. This can cause fabric to pucker,
and gaps to appear in the embroidery. For an object
to sew out correctly, it must have correct stitch
spacing, sufficient pull compensation together with a
suitable underlay for the combination of cover stitch
type, object type, object shape and fabric. BERNINA
Embroidery Software provides a set of customized
fabric settings so that the software will take into
account the type of fabric you are stitching on.

The Save To Template dialog opens.

5 Select the required option:
 Lettering: only new lettering objects will be
affected by changed settings.
 Other Objects: only new objects other than
lettering will be affected.
 All objects: all new objects will be affected by
changed settings.
A confirmation message appears.

Fabrics are a critical element of designs and are
controlled separately from template values. Fabric
settings are fewer in number than those contained in
templates. Templates set global values for designs
but each design requires its own fabric settings which
are saved with the design.

Stitch settings
Stitch settings for different fabric types are
summarized in the table below.

Fabric

Step

Satin

Length Spacing

Auto spac.

Underlay:

Layer 1
St. len.

St. spac.

Layer 2
St. len.

St. spac.

Pull
comp.

F1 Knit Light Weight
Lettering

92%

Center Walk

2.2

Narrow Satin

90%

Center Walk +
Edge Walk

2.2

0.25
2.0

0.25
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Fabric

Step

Satin

Length Spacing

Auto spac.

Wide Satin
Step

90%
4.0

0.4

Underlay:

Layer 1
St. len.

Edge Walk +
Zigzag

2.0

Step

3.0

St. spac.

Layer 2
St. len.
5.0

Pull

St. spac.

comp.

3.0

0.25

2.0

0.2

F2 Knit Medium Weight
Lettering

92%

Center Walk

2.2

Narrow Satin

90%

Center Walk +
Edge Walk

2.2

2.0

Wide Satin

90%

Edge Walk +
Zigzag

2.0

5.0

Step

4.0

Step

4.0

0.4

0.25
0.25
3.0

2.5

0.25
0.2

F3 Knit Heavy Weight
Lettering

92%

Center Walk

2.2

Narrow Satin

90%

Edge Walk +
Zigzag

2.0

5.0

3.0

0.35

Wide Satin

87%

Edge Walk +
Double Zigzag

2.0

12.7

5.0

0.35

Step

4.0

Step

3.8

0.35

0.35

2.5

0.25

F4 Terry Medium Weight
Lettering

92%

Center Walk

2.2

Narrow Satin

90%

Edge Walk +
Zigzag

2.0

5.0

3.0

0.25

Wide Satin

90%

Edge Walk +
Double Zigzag

2.0

12.7

5.0

0.25

Step + Step

4.0

4.0

3.5

0.25

Step

4.0

0.35

0.25

3.5

F5 Terry Heavy Weight
Lettering

92%

Center Walk

2.2

Narrow Satin

90%

Edge Walk +
Zigzag

2.0

5.0

3.0

0.25

Wide Satin

90%

Edge Walk +
Double Zigzag

2.0

12.7

5.0

0.25

Step + Step

4.0

4.0

3.5

0.25

Center Walk

2.2

Step

4.0

0.35

0.25

3.5

F6 Woven Light Weight
Lettering

117%

Narrow Satin

108%

Edge Walk

2.0

Wide Satin

100%

Edge Walk +
Zigzag

2.0

Step

4.2

Step

4.2

0.5

0.2
0.2
5.0

5.0

5.0

0.25
0.4

F7 Woven Medium Weight
Lettering

90%

Center Walk

2.0

0.2

Narrow Satin

90%

Center Walk

2.0

0.2

Wide Satin

90%

Edge Walk +
Zigzag

2.0

3.6

2.0

0.2

BERNINA® Embroidery Software : Reference Manual

89

Chapter 11 : Properties, Fabrics & Templates

Fabric

Step

Step

Satin

Length Spacing

Auto spac.

4.0

0.4

Underlay:

Layer 1
St. len.

Edge Walk +
Step

2.0

St. spac.

Layer 2
St. len.
3.6

Pull

St. spac.

comp.

2.0

0.2

F8 Woven Heavy Weight
Lettering

98%

Center Walk

2.2

Narrow Satin

96%

Center Walk +
Edge Walk

2.2

2.0

Wide Satin

92%

Edge Walk +
Double Zigzag

2.0

12.7

Step

4.0

Step

4.0

0.4

Changing fabrics
Normally you choose a fabric when you first set up a
design although you can change it at any stage. Fabric
settings affect all object types other than lettering,
pattern fills, appliqué, and outlines.

0.2
0.2
5.0

2.5

0.2
0.17

in the Status Bar at the bottom of the
Embroidery Canvas.
Stitch count

File type

Current fabric

To change fabrics

1 Select Design > Fabric.

Note Changing the current Auto Fabric will
affect all colorways in the design. However, the
converse is not the case. While colorways allow
you to select different fabric swatches, these have
no bearing on Auto Fabric settings.

Managing fabrics

2 From the Fabric type droplist, choose a fabric
type matching or nearest to the fabric you intend
to work with.

In addition to pre-defined fabrics, you can create
custom fabrics to suit particular needs. You may find
through experience that certain settings work better
for certain fabrics. If you find yourself changing the
same settings for each design, you may decide to set
up a custom fabric which you can apply universally.
To define a new fabric
 Select Settings > Manage Fabrics.
The Manage Fabrics dialog opens.

Create new
fabric type
Woven Medium Weight

Woven Heavy Weight

3 Click OK.
The selected fabric settings are applied to all
objects in the design. The current fabric is shown

Note If you already have custom fabrics defined,
you have the option of editing, renaming, or
deleting.
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 Choose a fabric to modify or as a basis for a
custom fabric.

 Set a pull compensation allowance for these
objects. See also Compensating for fabric stretch.

 To modify an existing custom fabric, click
Settings.
 To create a new fabric type, click Create.
The Create Fabric dialog opens.
Fabric: Denim
Pull Comp: Low

Fabric: Silk
Pull Comp: Medium

Fabric: Terry Toweling
Pull Comp: High

My Knit Light Weight

To set satin object values
 Click the tab to access the Wide Satin settings.
 Select a fabric as a base for your own fabric.

These settings will become the defaults for larger
Satin objects.

 Enter a descriptive name.
Tip You can view settings for both locked fabrics
and custom fabrics, but you can’t modify locked
fabrics. If you want to do so, base a custom fabric
based on the locked fabric, and edit as you wish.

Adjust Wide Satin
values for custom
fabric

To set step / fancy fill object values
 Click OK.
The Fabric Settings dialog opens. This dialog
allows you to set the fabric values for four object
groups – Step/Fancy Fill, Wide Satin, Narrow
Satin, and Lettering – as well as enter details of
any recommended stabilizers.

Adjust Tatami/Prog
Split values for
custom fabric

 Adjust the Wide Satin settings as you did for Step
/ Fancy Fill objects. See also Creating satin fills.
 Click the tab to access the Narrow Satin settings
and adjust as you did for Wide Satin objects. See
also Creating satin fills.

Adjust Narrow Satin
values for custom
fabric

 Adjust the Stitch Length and Stitch Spacing
settings as desired:
 Step stitch consists of rows of run stitches and
is suitable for filling large, irregular shapes. See
also Creating step stitch fills.
 Fancy Fill is a decorative stitch type. Use it to
fill wide and large areas with unique artistic
effects while keeping the appearance of a solid
field of stitching. See also Creating fancy fills.
 Set a suitable underlay type for Step / Fancy Fill
objects. See also Stabilizing with underlays.
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compensation or underlay settings set up to suit
different fabrics.

To set lettering object values
 Click the tab to access the Lettering settings.

Adjust Lettering
values for custom
fabric

Frequently used
Background color can be
saved in the template

The NORMAL template is the default template
supplied with BERNINA Embroidery Software. It
contains current object properties. If necessary, you
can revert to the original NORMAL template after
modifying it. See Reverting to the NORMAL template
for details.
 Adjust settings as you did for Satin objects. See
also Applying different stitch types & effects to
lettering.
To set stabilizer settings
 Click the tab to access the Stabilizer settings.

Adjust stabilizer
values for new fabric

 Key in one or more recommended stabilizer(s) in
the Required Stabilizer field, together with a
description or any other relevant information on
the stabilizer for the custom fabric. This
information will be displayed under Fabric
Settings. See also Starting designs.

Creating design templates
You create templates from designs containing the
required objects and object properties. Simply save
the design, or elements of it, as a template.
Templates look the same as design files, but use the
file extension AMT. Make sure that you select a name
for your new template before saving changes.

Note You cannot overwrite templates by accident.
Each time you create a new design from a template,
BERNINA Embroidery Software opens a duplicate.
When you save the design the first time, the Save As
dialog opens so you can save the template under a
new name.
To create a design template

1 Start a new design or open an existing one.
2 Adjust the object properties as required.
3 Add any objects and lettering to be included in the
template.

Working with design templates
Templates are special files used to store default
settings. Use templates when digitizing
frequently-used design types so that you do not have
to set the current properties every time. For example,
a template may include standard objects and sample
lettering. It may simply have preferred stitch settings,
lettering font and size, and colors set as current
properties. Or it may have special density, pull

For instance, you may want to include sample
lettering using different baselines. Simply
overtype the sample text when using the
template. See Applying lettering baselines for
details.

4 Select File > Save as Template.
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The Save as Template dialog opens.

5 Modify object properties, styles and other settings
as required.

Enter template
name

My Template

Select BERNINA
template

Lettering added to
template for display
with every design

6 Select File > Save as Template.
5 Select BERNINA Embroidery Software
Templates from Save as Type droplist.
BERNINA Embroidery Software automatically
opens the ..\Program
Files\BERNINA\Embroidery
Software 8\template folder. Design templates
must be saved here or they will not appear in the
template list when you start a new design.

7 Select the ..\Program
Files\BERNINA\Embroidery
Software 8\template folder.

8 From the Save as Type droplist, select BERNINA
Embroidery Software Templates.

9 Select the template file and click Save.
A confirmation message appears.

6 Enter a name for the template in the File Name
field.

7 Click Save.

Modifying design templates
You can modify templates in the same way as a
normal design. Changes apply only to future uses of
the template. Existing designs based on the template
are not affected.

Note Delete templates in the same way as you would
any other file using MS Windows® Explorer.
Templates are located in the ..\Program
Files\BERNINA\Embroidery
Software 8\template folder.
To modify design templates

1 Select File > Open.
2 Navigate to the ..\Program
Files\BERNINA\Embroidery
Software 8\template folder.

3 Select BERNINA Embroidery Software
Templates from the Files of Type droplist.

4 Select the template you want to modify and click
Open.

Tip To create a new template based on the
modified one, type a new file name and click Save.

10 Click Yes to confirm.
The modified template is ready for use.

Design 1

Design 2

Saving current properties to a template
You can easily save current object properties to the
current template. See also Working with object
properties.
To save current properties to a template

1 Access Object Properties:
 To use the current object properties, deselect
all objects, then click the Object Properties
icon.
 To use the properties for a particular object,
select the object, then double-click or
right-click it.

2 Change object properties settings as required.
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The Object Properties dialog opens.
Note It may take up to 1 or 2 minutes for the
dialog to open.

4 Select the Templates checkbox and click OK.
The original settings for the NORMAL template are
restored.

Change settings
as required

Click to save to
template

3 Click Save to Template.
A confirmation message appears.
Note Only the current object properties – not the
objects or other settings in the design – are saved
to the template.

4 Click OK to update the template.
5 Click Close to return to the design window.
The new settings are saved in the template from
which the design was created and are available for
use.

Reverting to the NORMAL template
If you modify the NORMAL template supplied with
BERNINA Embroidery Software, you can revert to the
original version. A factory copy is always maintained
so that the NORMAL template can be restored.
To revert to the NORMAL template

1 Close BERNINA Embroidery Software.
2 Click the MS Windows® Start button and go to the
BERNINA Embroidery Software programs folder.

3 Select the Tools folder and click the Revert icon.
The Revert to Factory Settings dialog opens.

Select
Templates
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CHAPTER 12
STITCH QUALITY
BERNINA Embroidery Software
provides many settings to help improve
the quality and efficiency of your final
stitchout.
Use automatic underlay to help stabilize
fabric and reduce distortion due to the
pull effect. Adjust the amount of
overstitching you need by varying the
pull compensation setting. This is
handy if you want to stitch a design on
fabrics with varying degrees of stretch.
Reduce the risk of bunched, distorted
embroidery in sharp corners with
Automatic Corners. By applying Auto
Jump, you can preserve long stitches in
objects by turning them into a series of
jumps.
By default, tie-in stitches are
automatically inserted at the start of
objects to prevent stitches from
unraveling. You can control tie-in/offs settings for whole designs or particular
objects.
In addition, there are features which allow you to reinforce outlines as well as join
selected outlines to form a single grouped outline for efficient stitchout.
Use Auto Start & End to set the positions of first and last stitches in a design. All
these features are object properties, and can be applied, removed or modified at
any time.
This section discusses a variety of settings and functions which can improve
overall stitch quality. These include such things as adjusting underlays and
compensating for fabric stretch. Amongst other things, it also describes how to
preserve long stitches, adjust tie-in/off settings, and set automatic start and end
points.

Setting automatic start & end points
Before stitching, some embroidery machines require
you to position the starting needle exactly above the
first needle penetration point. Use Auto Start & End
to set the positions of first and last stitches in a
design.
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To set automatic start & end points

start/end points are maintained during any editing
operations.

1 Select Design > Auto Start & End.

Select a start
needle position
method

Tip Turn off Maintain Automatically if you want
to position the design anywhere in the hoop. You
might do this to set up continuous designs or
special placements such on pockets. Use this
technique with machines which always start in the
center of the hoop. Make sure automatic centering
is set to start needle position. See also Centering
hoops.

Select an end
needle position
method

Start point is at
center of hoop

2 Select a Start Needle Position method:
Method

Notes

First stitch of
design

The start point is set to the first stitch in
the design.

Auto start at

The end point is automatically
maintained at the specified point in the
design. Choose from the available
options,

Digitize start
You are prompted to manually mark the
needle position start point.

3 Select an End Needle Position method. The
same options apply.

4 If you choose to digitize start and end points, you
will be prompted once you close the dialog.

6 Click OK.
Connecting stitches will be inserted as required
before the first and after the last stitches of the
design.

Adjusting stitch spacing
You may need to change stitch density in order to
stitch on a different fabric or with a different thread.
Or you may want to do a test design and reduce the
overall stitch count. The software lets you change the
density of most stitch types across the whole or
selected parts of a design.

Note Use fabric settings so that the machine will take
into account the type of fabric you are stitching on.
See also Working with fabrics.
To adjust stitch spacing
Start Point: First Stitch
End Point: Last Stitch of the
design

Start Point: Auto Start
End Point: Auto End, Center
of the design

1 Select the design or objects you want to adjust.

5 Select the Maintain Automatically checkbox
(the default) to automatically maintain start
and/or end needle positions. This ensures that
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2 Select Edit > Adjust Stitch Spacing.

Applying underlays
Use Effects > Auto Underlay to strengthen and
stabilize objects with underlay stitching.

Enter new stitch spacing
as a percentage

3 Click OK.

Use General > Effects to apply stitch effects to
selected embroidery objects or preset with nothing
selected.
The Auto Underlay tool generates underlay stitching
for objects based on current settings. You can preset
custom underlay settings for all newly created objects
in your design, or apply them to selected objects.
To apply underlays
 Click the Auto Underlay icon to activate the
feature.
Tip To preset underlay settings, click the Effects
icon to access the Effects > Underlay dialog.
 Create a closed-object – circle or square. See
Digitizing Methods for details.
The object is digitized using current settings.

Tip Check any changes via the Object
Properties dialog.

Stabilizing with underlays
To improve the quality of the stitchout, you need to
add underlay. Underlay helps stabilize fabric and
reduce distortion due to the pull effect. It also
provides ‘loft’, raising cover stitches and preventing
them from sinking into soft fabrics. When no underlay
is applied, the embroidery lays flat on the fabric. It
not only looks flat, but the underlying fabric often
shows through. New digitizers might be tempted to
increase stitch density but it is more effective to apply
a proper underlay.

 To change underlay settings, select the object and
right-click the Auto Underlay icon.
The Effects > Underlay dialog opens. This tab
gives you the option of a single underlay or
combined first and second underlays.

Select 1st
underlay and
stitch type

 Select Apply Underlay 1 and select an underlay
type from the droplist.

Note Use fabric settings so that the machine will take
into account the type of fabric you are stitching on.
See also Working with fabrics.
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The type of underlay you choose is determined by
the purpose it is to serve.

Zigzag
underlay

Center Walk underlay places a row of stitches along
the center of a column. It is used to stabilize narrow
columns – e.g. 2-3 mm wide. Edge Walk places
stitches around the edge of an object. Use edge walk
together with zigzag or step underlays when digitizing
large shapes.

Step
underlay

Double Zigzag
underlay

Edge Walk
underlay

Center Walk and Edge Walk
underlays used together

Note Stitch settings for edge walk underlays are
stored separately from, and do not affect, cover stitch
settings.
To set center and edge walk underlays

 Adjust stitch length and margin settings as
required. See below for details.
All underlay types available for Underlay 1 are also
available for Underlay 2.
Select 2nd
underlay and
stitch type

1 Select an object or objects to adjust their
particular settings.

2 Right-click the Auto Underlay icon.
The Effects > Underlay dialog opens.

Select 1st
underlay and
stitch type

 For extra stability, select a second underlay.
Any combination of underlay types can be used.
Zigzag
underlay

3 Select first and second Underlay checkbox (as
required) and select Center Walk and/or Edge
Walk as the underlay types.

4 Adjust stitch length to ensure that underlay
stitches follow the shape of curves and are not
visible in the final embroidery.

Edge Walk
underlay

Edge Walk
underlay
Step underlay

 To keep a permanent record of your custom
settings, click Save to Template. See Saving
current properties to a template for details.

Setting center & edge walk underlays

Edge Walk Stitch Length:
1.5mm

Edge Walk Stitch Length:
3.5mm

5 Adjust underlay margins as required to prevent
underlay stitches from extending outside the cover
stitches. See Setting underlay margins for details.

6 Click Apply.
New or selected objects use the adjusted settings.

Right-click Effects > Auto Underlay to strengthen and
stabilize objects with underlay stitching.

BERNINA® Embroidery Software : Reference Manual

98

Chapter 12 : Stitch Quality

Adjusting zigzag underlay spacing
Use Effects > Auto Underlay to change automatic
underlay settings.
Use zigzag and double-zigzag underlay stitching to
support wide columns. you can set stitch length for
zigzag and double-zigzag underlay. Double-zigzag
underlay only works with satin outline or lettering.
Apply settings before or after digitizing.

Note Zigzag underlay stitch settings are stored
separately from, and do not affect, zigzag cover stitch
settings.

Setting underlay margins
Use Effects > Auto Underlay to change automatic
underlay settings.
The underlay margin is the distance between an
object outline and the edge of the underlay. Increase
this margin to prevent underlay stitches from
extending outside the cover stitches.

Underlay
margin

To adjust zigzag underlay spacing

1 Select an object or objects to adjust their
particular settings.

To set underlay margins

1 Select an object or objects to adjust their

2 Right-click the Auto Underlay icon.
The Effects > Underlay dialog opens.

particular settings.

2 Right-click the Auto Underlay icon.
The Effects > Underlay dialog opens.

Select Zigzag
or Double
Zigzag

Set margin
type

3 Select the Apply Underlay 1 checkbox and select
Zigzag or Double Zigzag as the underlay type.

3 Select a Margin type from the droplist.

4 Enter the required stitch length.
Normal

Medium
Zigzag Stitch Length: 2.5 mm

Zigzag Stitch Length: 5 mm

Wide

Double Zigzag Stitch
Length: 7 mm

Double Zigzag Stitch
Length: 3.5 mm

5 Click Apply.
Selected objects are updated with the adjusted
settings.

4 Click Apply.
New or selected objects use the adjusted settings.

Compensating for fabric stretch
Use General > Object Properties to adjust pull
compensation settings.
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Embroidery stitches pull fabric inwards where the
needle penetrates. This can cause fabric to pucker
and gaps to appear in the embroidery. Shapes are
slightly narrower and longer in the final embroidery
than they look on the screen. Pull compensation
counters this effect by ‘overstitching’ outlines of filled
shapes on the sides where the needle penetrates.
Apply automatic pull compensation to objects in your
design, either before or after digitizing.

Pull compensation
Digitized outline

Tip Pull compensation is automatically set at
0.2 mm. This is suitable for most designs.
However, 0.4 mm is recommended for use with
automatic digitizing.

6 Enter an overstitch allowance (in mm) as required.

Pull Compensation: 0.2 mm

Pull Compensation: 0.5 mm

Calculated outline

The amount pull compensation required depends on
the stitchout fabric. Experiment with the fabrics you
are going to use and see if the set amount is suitable
before changing it. You can also adjust pull
compensation to suit the fabric you are embroidering
on by selecting Settings > Fabric Settings. See
also Changing fabrics.

Tip Applying underlay stitching, and using
appropriate backing and topping when stitching out,
can also reduce pull effect. See also Stabilizing with
underlays.
To apply automatic pull compensation

1 Select an object or objects to adjust their
particular settings.

2 Click the Object Properties icon.

7 Click Apply.
New or selected objects use the adjusted settings.
Tip Click Save to Template before closing this
dialog to save settings permanently. Saved
settings will be applied to all new designs based on
the current template. See Properties, Fabrics &
Templates for details.

Connecting embroidery objects
‘Connectors’ link objects in a design. They take the
form of ‘travel runs’ or ‘jumps’ and are displayed in
Stitch View but hidden in Artistic View. Ideally, you
will plan your embroidery so that connecting stitches
will be covered later by other elements of the design.

The Object Properties dialog opens.

3 Click the Effects button and select the Others
tab.

4 Select the Pull Compensation checkbox.
Select Pull
Compensation

5 Click Apply.
New or selected objects use the new settings.

Pull Compensation ON

Pull Compensation OFF

BERNINA® Embroidery Software : Reference Manual

100

Chapter 12 : Stitch Quality
If a connecting stitch is not covered, it will need to be
trimmed after stitchout.

‘As Digitized’
connectors

Jumps
Jump connectors move the frame from one part of the
design to another without needle penetrations. You
generally need to trim the connecting thread. Jump
connectors are displayed in Stitch View either as a
dotted or solid line – solid lines for short connectors,
dotted lines for long connectors (more than
12.1 mm). Dash-dotted lines indicate color changes.

‘Closest Join’
connectors
Short connector: solid line

Connectors not
displayed in Artistic
View

Connecting stitches are generated automatically but
you can resequence objects in order to minimize
trims. You can even change entry and exit points, but
the Closest Join setting (the default) automatically
calculates the closest join between objects while
digitizing. See Setting other general options for
details.

Long connector: dotted line

Color change: dash-dotted line (no thread to trim)

Long jump connectors have needle jumps of up to
7 mm along their length. This usually causes the
machine to slow down while moving the hoop to the
next needle penetration point.

Travel runs
Travel runs are automatically added when the needle
has to travel between segments within an object.
They are always covered by the overlying stitches but
may sometimes show through.

Note The default connector jump length is the same
as that set for Auto Jump.

Tie-ins and tie-offs
Tie-ins and tie-offs are extra stitches that are added
before and after jumps and color changes so that
threads can be trimmed without stitches unraveling.
Tie-in

Travel run

Travel run visible in Entry point changed
Artistic View
– no travel run

Travel runs are kept to a minimum by adjusting entry
and exit points of consecutive objects. You can
manually adjust entry and exit points using the As
Digitized method, but the Closest Join setting (the
default) automatically calculates the closest join
between objects while digitizing. See Setting other
general options for details.

Tie-off

Tie-in stitches are automatically inserted at the start
of objects after any connector longer than 2 mm or
after a color change. With Satin objects, they are
inserted inside the shape on the second stitch.
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Likewise, tie-offs are automatically added before
connectors or before a color change.

The tab contains two panels – Tie in before
object and Tie off after object – which allow you
to turn the respective option on or off.

Tie-in at the start of
the object

Tip Travel through the design by one stitch to check
for tie-ins and tie-offs. See Traveling through designs
for details.

Adjusting tie-in/off settings
Use General > Object Properties to adjust tie-in/off
settings.
By default, tie-in stitches are inserted at the start of
objects to prevent stitches from unraveling. There are
instances, however, where whole designs may not
include tie-ins, or where selected objects, such as
lettering, may not include them. BERNINA
Embroidery Software gives you control over
tie-in/offs settings. This is necessary for specialized
purposes such as ‘reverse embroidery’ which involves
using thick threads in the bobbin. There can be no
tie-offs for this. You may want to make embroidery
with creative threads where tie-offs can’t be used. In
these cases, you can turn off tie-ins and/or tie-offs
and keep threads from unraveling by cutting them
long and pulling them through. See also Adjusting
entry & exit points.

Note Existing designs created in previous
versions of BERNINA Embroidery Software or
other applications may have a connector length
setting that differs from the 2 mm default setting.
 Optionally, tick the Always Trim checkbox to trim
connectors for the selected objects. When
activated, a tie-in and tie-off is inserted between
selected objects, regardless of connector length.
Select all objects and apply the setting to trim all
connectors in the design. You can also use it to
force trims within lettering objects.
 Adjust the Tie in before object setting as
required:
 When turned off, no tie-ins are inserted for
either external or internal connectors.
 When turned on, tie-ins are inserted if the
connecting stitch before an object is greater
than 2 mm.

Tie-in with two
stitches

To adjust tie-in/off settings
 Access the Tie-in/off controls in one of the
following ways:
 To adjust current design settings, click the
Object Properties icon or select
Settings > Object Properties to access the
Object Properties dialog.
 To adjust a particular object or objects,
double-click or right-click the object(s) to
access the Object Properties dialog.

1 Adjust the Tie off after object setting as
required:
 When turned off, no tie-offs are inserted for
either external or internal connectors.
 When turned on, tie-offs are inserted if the
connecting stitch following an object is greater
than 2 mm.

 Select the Tie-in/off tab.
Select tie-off
method

 Select a tie-off method:
 The first method inserts tie-off stitches along
the last stitch.
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 The second inserts tie-off stitches between the
last two stitches.

the same color as the original and is positioned
after it in the stitching sequence.

The first method is better suited to non-lettering
objects while the second method is better for
lettering objects.
 Click Apply.
Settings are applied to selected objects or, if no
objects are selected, current properties.

Reinforcing outlines
Use the Double Run feature to reinforce outlines.
Use Blackwork Run to join selected outlines to form
a single grouped, reinforced outline, correctly
sequenced for efficient stitchout.

Reinforcing outlines with Double Run
Use Edit > Double Run to reinforce outlines, stitching
it in the opposite direction.
Use the Double Run feature to
reinforce outlines. Double Run
stitches in reverse direction to
the original. It is typically used
to make run stitch outlines
thicker without creating
unwanted connecting stitches.
It can also be applied to filled
objects.
To reinforce outlines with Double Run

1 Select the object/s to reinforce.
2 Click the Double Run icon, or press Ctrl+B.
The object is duplicated with the stitching
reversed, and placed on top of the original. It is

3 Check that the object has been duplicated by using
any of the following methods:
 Check the stitch count in the Status Bar.
 View the objects in the Color Film. See also
Viewing & selecting color blocks.
 Travel through the stitches. See Viewing stitch
sequence for details.
 Use Stitch Player. See Simulating design
stitchouts for details.

Reinforcing outlines with Blackwork Run
Use Edit > Blackwork Run to automatically sequence
selected outlines for efficient stitchout.
Use Blackwork Run to join selected outlines to form
a single grouped, reinforced outline, correctly
sequenced for efficient stitchout. The resulting
Blackwork Run object always follows the color of the
first object in the sequence.

Blackwork Run works with embroidery outlines
consisting of one or a combination of Open Object,
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Closed Object, Ellipse, or Rectangle object types. All
outline stitches can be used except for Pattern Run,
Blackwork Border or Candlewicking Border. See
Outline & Fill Stitching for details.

Sequenced objects can be reshaped as a whole.
There is only one entry and one exit point, but all
component objects have individual reshape points.
See also Reshaping objects using reshape nodes.

Note The Ungroup command is not available when
a Blackwork Run object is selected. If you wish to
access component objects, use the Break Apart tool.
See Splitting into component objects for details.

Note You cannot see a big difference on screen
after applying Blackwork Run as the reinforced
outlines cover each other. To check that a
Blackwork Run object, travel through the stitches.
See Traveling through designs for details.

To reinforce outlines with Blackwork Run

1 Select outline objects.

Controlling corner stitching
Use Effects > Automatic Corners to toggle mitre or
cap corners in line objects with sharp turns. Can be
turned on/off object-by-object.

Long connectors
between separate
objects

Note The function is only available if more than
one object of suitable type is selected. Any which
cannot be automatically sequenced are excluded
from the operation.

2 Click the Blackwork Run icon.
3 Digitize the entry point or press Enter to accept
the default.
Stitches are regenerated. Component objects are
grouped and take the color of the first object.

The quality of corners is important in borders and
appliqué, and satin column sewing in general. Sharp
corners may cause stitch bunching which can create
hard spots in the embroidery and may damage fabric
or needle. Use Automatic Corners to reduce
stitches and the risk of bunched, distorted embroidery
in sharp corners.
To apply automatic corners
 Click Automatic Corners with or without objects
selected.
With no objects selected, corners are
automatically generated for all new objects. The
following approaches can apply to both appliqué
and satin lines.

Objects resequenced,
connectors minimized

Tip Travel through the sequenced object to check
stitching. See Viewing stitch sequence for details.

4 Change the thread color of the entire sequenced
object as required. See Changing thread colors for
details.

5 Reshape the sequenced object as required.
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 Click again to turn off the effect.
Method
Default
corner

Sample

Description
Stitches curve around
corners – default Satin
corner handling.

Auto Jump can also be used, for example, with
manually digitized underlays. It can even be used to
create quilted effects, for example, by applying it to
Satin areas that are over-stitched with Run stitch or
Pattern Fill. Auto Jump is stored as an object property
and is activated by default. You can change its values
at any time for selected or newly created objects.
Auto Jump values can be adjusted for Fill stitch,
Outline Satin and Outline Blanket stitch.
To apply Auto Jump

Mitre
corner

Corners are formed by
two segments that join in
a sharp point.

1 Select an object or objects to adjust their
particular settings.

2 Click the Object Properties icon.
3 Click the Effects button and select the Others
tab.

Cap
corner

Corner is capped by an
extra segment – cap
stitching remains parallel
to the column.

Select Auto
Jump
Adjust max stitch and
jump length values

4 Select Auto Jump if not already selected and click
Apply.
Long jump
stitches

Preserving long stitches
No jumps

Use General > Object Properties to adjust Auto
Jump settings.
Embroidery machines have a maximum possible
stitch length which is determined by the frame
movement limitations of the machine itself. If a stitch
exceeds this, it is broken into smaller stitches. This
can affect the embroidery appearance, especially in
Satin fills. By applying Auto Jump, you can preserve
long stitches in an object by turning them into a series
of jumps. See also Splitting long stitches in satin fills.

5 In the Maximum Stitch field, adjust the
maximum stitch length as required.
Stitches exceeding this value will have Auto Jump
applied.

Maximum stitch
Max stitch length:
10 mm
Long stitch is broken into smaller
needle arm movements or ‘jumps’

To create a narrow column with more ‘loft’ than
normal Satin, apply Auto Jump, in conjunction with a
suitable underlay, with the maximum stitch length set
to a small value, e.g. 6 mm. If the cover stitches are
short, splitting them with a jump makes them looser
and thus more effectively raised off the fabric. See
also Stabilizing with underlays.

Max stitch length:
12.1 mm

Tip Set the maximum stitch larger than the
longest Satin fill stitch you want to allow in the
design, otherwise some Satin stitches will be split
into two or more stitches.
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6 In the Jump Length field, enter the length of each
jump.

Jump Length: 7 mm

Jump Length: 4 mm

Tip Smaller jumps increase the time required to
stitch out but move the frame more smoothly
across the design.

7 Click Apply.
New or selected objects use the adjusted settings.
Tip Click Save To Template before closing this
dialog to save settings permanently. Saved
settings will be applied to all new designs based on
the current template. See Properties, Fabrics &
Templates for details.
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PART III
DIGITIZING

WITH

ARTWORK

There are two broad categories of artwork file, both of which can be imported into
BERNINA Embroidery Software for use as digitizing backdrops – vector and bitmap. To
create good quality embroidery, you need to choose or create suitable artwork of either
format.

Digitizing with backdrops
This section describes how to choose suitable artwork for digitizing purposes as well as
how to scan it into BERNINA Embroidery Software. It also describes how to digitize with
images as backdrops, as well as how to show and hide them as you digitize. See
Digitizing with Backdrops for details.

Processing images for automatic digitizing
This section describes how to prepare images for automatic digitizing. It explains how
to prepare both outlined and non-outlined images. See Image Processing for details.

Automatic digitizing
This section describes how to automatically convert vector graphics as well as bitmap
images to embroidery designs with the available techniques. It also covers how to
create embroidery from photographs. See Automatic Digitizing for details.
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DIGITIZING WITH BACKDROPS
Electronic artwork in both bitmap and
vector formats can be loaded, pasted or
scanned into BERNINA Embroidery
Software for use as digitizing templates
or ‘backdrops’. Textured backgrounds can
also be imported to show what a design
will look like on real fabric. Almost any
artwork can be used – photographs,
magazine pictures, clipart drawings, and
even fabric samples.
From within BERNINA Embroidery
Software you can open images into
MS Paint, Corel
PHOTO-PAINT® Essentials X6, or Paint
Shop Pro™. Images updated in this way
are automatically re-imported into
BERNINA Embroidery Software.
This section describes how to choose suitable artwork for digitizing purposes as
well as how to scan it into BERNINA Embroidery Software. It also describes how
to digitize with images as backdrops, as well as how to show and hide them as
you digitize.

Using design backdrops
Backdrops can be used as a guide to manual
digitizing. Alternatively, BERNINA Embroidery
Software semi-automatic and automatic digitizing can
convert bitmaps to embroidery designs. In summary,
backdrops can help you to:
 Digitize objects manually.
You trace shapes and lines over the artwork using
the appropriate digitizing tools. See Digitizing
Methods for details.
 Digitize shapes automatically with Magic Wand.
You select a shape and Magic Wand
automatically determines the required stitches.
 Digitize complete images automatically with
Auto-Digitize.
You select the image and Auto-Digitize
automatically determines the shapes and stitches

needed to digitize the design. See Auto-digitizing
with Auto-Digitize for details.
 Digitize photographs with PhotoSnap.
Again you select the image and PhotoSnap
automatically determines the shapes and
stitches needed to digitize the design. See
Auto-digitizing with PhotoSnap for details.
Artwork can be imported into BERNINA Embroidery
Software in both vector and bitmap formats:
 Vector graphics: These consist of outlines which
may be colored and may have colored fills. Vector
outlines remain thin and clear even at large zoom
factors, so you can digitize them accurately.
 Bitmap images: These consist of colored dots or
pixels. When you zoom in on a small area, the
outlines become jagged and are displayed as a
series of colored squares or pixels.
To create good quality embroidery, you need to
choose suitable artwork. Once in BERNINA®
Embroidery Software, you can set general properties
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such as size and position. You can also arrange and
transform artwork in the same way as embroidery
designs.
Caution Included artwork (clipart) and embroidery
designs can only be used for personal use – i.e. they
cannot be commercially sold in any form. Changing
the medium – i.e. clipart to embroidery or embroidery
to clipart – does not remove copyright protection.

Tip You can scale and transform bitmap images once
they are loaded into BERNINA® Embroidery Software.
However, if an image needs to be resized or rotated,
it is best to do so during scanning. Scaling afterwards
may distort the image.
Supported graphic formats
BERNINA Embroidery Software supports a wide
variety of vector and bitmap graphic formats:

Vector graphics
Vector graphics can be loaded into BERNINA®
Embroidery Software for use as digitizing backdrops.
They are automatically converted to bitmap images.
Supported
graphic formats

Drawing

Digitized with Magic Wand

Note CorelDRAW® Essentials X6 is packaged with a
selection of clipart which can be used as digitizing
backdrops or converted directly into embroidery. See
also Browsing clipart.

Bitmap images
Bitmap images can be loaded or scanned into
BERNINA® Embroidery Software for use as digitizing
backdrops. For both manual and automatic digitizing
purposes, ‘clean’ images, sometimes referred to as
‘cartoons’, work best. Such images have a limited
number of solid colors which in turn have well-defined
outlines. Ideally, they are:
 well defined, where each shape is made up of
pixels of the same color
 clearly ‘blocked’, where each shape is a stitchable
size, at least 1 sq mm
 saved at a color depth of at least 256 colors (8 bit),
or preferably millions of colors (16 bit). (Images
are automatically reduced to 256 colors or less
when loaded into BERNINA® Embroidery
Software.)

Note For a full discussion of graphics formats, refer
to the CorelDRAW® Essentials X6 User Guide
available via the Windows Start > Programs group.
Alternatively, use the onscreen help available from
the Graphics mode Help menu.
Automatic digitizing
BERNINA® Embroidery Software automatic digitizing
techniques – Auto-Digitize and Magic Wand –
produce best results with images of the type found in
clipart libraries or created from scratch in a graphics
application. See Auto-digitizing with Magic Wand and
Auto-digitizing with Auto-Digitize for details.
Automatic digitizing can work with images from other
sources but they require greater or lesser amounts of
preparation. This is because most commonly available
images are not made up of solid colors. Scanners
introduce noise, while graphics applications perform
‘dithering’ and ‘anti-aliasing’ to improve image print
quality.
Automatic digitizing works least effectively with
photographic images which may contain many
dithered colors and complex forms. With
photographs, however, you can pick out shapes that
you want to embroider, leaving out unnecessary
detail. Alternatively, PhotoSnap is available to create
embroidery designs from scanned photographs.
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Scanned images

Anti-aliased images

Images scanned from hardcopy drawings or existing
embroidery typically contain a lot of introduced
‘noise’. While they can be used as input to automatic
digitizing, once again, best results are achieved with
relatively clean images consisting of solid color
blocks. Typically, logos and simple drawings scanned
from business cards, letterheads, books, magazines,
cards fall into this category.

Anti-aliasing is a software
technique similar to dithering
which is used to soften hard
outlines where color blocks
intersect. It produces
smoother outlines by
‘blurring’ the pixels where
colors join.

Image containing a
lot of scanner
‘noise’

Where anti-aliasing is
deliberately used to blur
Anti-aliased outlines
outlines, these need to be
‘sharpened’ before use with automatic digitizing. See
Image Processing for details.

Scanning artwork

Noisy images typically need to be prepared by
reducing the color count and sharpening the outlines.
See Image Processing for details.
Dithered images

If you have existing artwork, you can scan it with a
TWAIN-compatible scanner using the BERNINA
Embroidery Software scanning function. It is
important to scan your artwork properly if you intend
to use one of the automatic digitizing techniques; the
scanned image quality will affect the quality of the
final embroidered design.

Dithering is a software technique which combines
existing colors in a checkerboard arrangement of
pixels. It is typically used to simulate colors that are
missing from an image palette.

Dithered color
blocks

Like noisy images, dithered images need to be
color-reduced before use. Be aware, however, that
while the software is excellent at processing dithered
colors within a defined outline, it does not work so
well with non-outlined images. See Image Processing
for details.

Good image: good
stitch quality

Poor image: poor stitch
quality

Preparing artwork for scanning
With embroidery design, less is more. You do not
need every detail in an image to create a design. You
use the ‘structure’ of the image rather than the fine
details of texture and color.
To simplify artwork, you can cover it with tracing
paper and draw only the essential shapes and lines
which will be filled with stitches. When scanning, take
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away the original artwork and put white paper behind
the tracing paper.

sufficient. Generally speaking, the smaller the source
image and/or more detail it contains, the higher the
resolution needs to be. Use the following table as a
guide.
Type of artwork

Scanning resolution

Business cards, letter heads

150 - 300 dpi

Hand sketches

150 - 300 dpi

Photos and images

150 - 300 dpi

Commercial art, line drawing

72 - 150 dpi

Color mode
Original artwork

Required parts traced

Shiny surfaces, such as glossy photographs, may not
scan well. Cover them with tracing paper. If the
artwork has very light colors, highlight outlines with a
fine black felt-tip pen.

Scanning resolution
Most scanners require you to enter scanning
resolution information. Resolution determines the
number of dots per inch (dpi) used to create a
drawing. The higher the value, the clearer the image
but larger the file. For digitizing purposes, use a
maximum resolution of 300 dpi (dots per inch). A
resolution of 72dpi (screen resolution) will usually be

Most scanners also require you to enter color mode
information. First decide whether your image is line
art (black and white drawing), sketch, color picture,
or black and white or color photograph, then choose
an appropriate mode. Black and white mode produces
the smallest files. Color photograph and grayscale
modes generate 256 color images and produce similar
sized files. ‘RGB’, ‘True Color’ or ‘millions of colors’
modes generate 16.7 million colors and produce the
biggest files. Use the table below to decide which
mode is suitable for use with your image.

Note Note that scanners may use different terms for
the same mode, some of these terms are included.

Description

Recommended
color mode *

No. of colors in
scanned image

Line art

Two colors – usually black
and white

Black/white drawing
Line art

2
2

Drawing/sketch

Sketch or drawing with
shades of gray

Grayscale
Line art

256
2

Black & white
photograph

Shades of gray

Black/white photo
Grayscale

256
256

Source image

Example

* Different scanning software uses different terms for the same mode.
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Source image

Example

Description

Recommended
color mode *

No. of colors in
scanned image

Color photograph

Many colors

Color RGB
Color photo

16 million
256

Color picture

Two colors or more

Color RGB
Millions of colors
Color drawing

16 million
16 million
2 - 256

* Different scanning software uses different terms for the same mode.

Scanning tips
 Do not scan line art images in grayscale mode;
grayscale scanning produces fuzzy edges.
 Scan color images in RGB mode (millions of colors)
rather than 256 color mode. You may not notice
any difference on screen. In fact the 256 color
image may look better than the RGB image.
However, BERNINA Embroidery Software converts
all images to 256 colors or less upon loading. It
uses the extra information to produce a better
image than if it was originally scanned at 256
colors.

makes the image edges more defined. It does not
increase the image details; it just makes them more
obvious. In general, use sharpening with images that
have well-defined outlines. Do not use it with
non-outlined images.

Scanned with
sharpening

Scanned without
sharpening

Importing artwork

Scanned in 256
color mode

Scanned in RGB color
mode (millions of colors)

Bitmap images and vector graphics of different
formats can be scanned or ‘loaded’ into BERNINA
Embroidery Software for use as digitizing backdrops.
You can scale and transform them after importing but

 Do not scan color images in CMYK mode as this is
only used for images that will be printed and the
colors may be different from RGB colors.
 If the image needs to be resized, scale it when you
scan it. Scaling afterwards may distort the image.

Sharpening
Some scanning software lets you apply what is called
‘sharpening’ as you scan. Sharpening compensates
for the slight blurring in a scanned image by looking
for any differences between colors in the image.
Sharpening accentuates these differences which
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it is generally better to do so during scanning. Scaling
afterwards may distort the image.

5 Choose a scanning mode and resolution. See
Scanning resolution and Color mode for details.
Tip If you are scanning a fabric background, set
the scan to 256 colors, 100% and 72 dpi (dots per
inch). These settings will give a small file which will
display well on your screen without taking up too
much disk space or memory.

6 Preview the image in the scanning program.
7 Select the area to be scanned and scan the image.
8 Save the scanned picture in a compatible format
picture file to your My Designs folder. See also
Digitizing with Backdrops.
Traced image scanned

Auto-digitized

Caution Included artwork (clipart) and embroidery
designs can only be used for personal use – i.e. they
cannot be commercially sold in any form. Changing
the medium – i.e. clipart to embroidery or embroidery
to clipart – does not remove copyright protection.

Scanning artwork
Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
Use Artwork > Scan Bitmap to scan an image into
BERNINA Embroidery Software.
You can scan images directly into BERNINA
Embroidery Software for use as digitizing backdrops.
The scanning feature in BERNINA Embroidery
Software allows you to use most TWAIN-compatible
scanners. You can use any scanning software
provided that it can save the image in one of the
compatible formats.

Note Scanned drawings are bitmaps and must be
saved separately from the design file or they will
be lost when you close the design. See Saving
backdrops as separate files for details.

Inserting bitmap artwork
Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.
Use General > Insert Artwork to import artwork into
current design as a backdrop for manual or
automatic digitizing.
Use View > Show Bitmap Artwork to show and hide
bitmap images.
You can load bitmap images of various formats for use
as digitizing backdrops for manual or automatic
digitizing.
To insert bitmap artwork

1 Switch to Embroidery Canvas and click the
Insert Artwork icon.

Tip You can also scan in your own textured
backgrounds to see what a design will look like on real
fabric. Fabrics can be scanned to provide full,
centered, backgrounds to your design, or as small
samples which can be tiled to fill the screen. See also
Setting backgrounds.
To scan artwork

1 Set up your scanner. See Setting up scanners for
details.

2 Prepare the artwork for scanning. See Preparing
artwork for scanning for details.

3 Switch to Artwork Canvas.
4 Click the Scan Bitmap icon.

Select format

2 Select a folder and select a file type from the Files
of Type list – e.g. BMP.
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3 Select a file and click Open.
4 Choose a digitizing technique:
 Use the artwork as a digitizing backdrop: See
Digitizing Methods for details.
 Convert bitmap to embroidery: See Automatic
Digitizing for details.

Select required
format

Note If you cannot see the image you loaded,
make sure Show Bitmap Artwork icon is toggled
on. See also Displaying backdrops.

Loading vector artwork
Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
Use General > Insert Artwork to import artwork into
current design as a backdrop for manual or
automatic digitizing.
Use View > Show Vector Artwork to show or hide any
vector artwork included in the design such as
CorelDRAW® clipart.
You can load vector artwork of various formats for use
as digitizing backdrops for manual or automatic
digitizing. You can also use this technique to insert
bitmaps via Artwork Canvas.
Note CorelDRAW® Essentials X6 is packaged with a
selection of clipart which can be used as digitizing
backdrops or converted directly into embroidery. See
also Browsing clipart.
To load vector artwork

3 Select a file and click Import.
4 Position the cursor in the design window and press
Enter.

5 Choose a digitizing technique:
 Convert vectors to embroidery: See Converting
vector artwork for details.
 Switch to Embroidery Canvas and use the
artwork as a digitizing backdrop: See Digitizing
Methods for details.
Note If you cannot see the image you loaded,
make sure Show Vector Artwork icon is toggled
on. See also Displaying backdrops.
Tip Locking backdrop images holds them in place
as you digitize, transform or reshape the
embroidery objects near them. Locked objects can
be unlocked for modification at any time. See also
Locking & unlocking objects.

1 Switch to Artwork Canvas and click the Insert
Artwork icon.

Editing imported artwork
For both manual and automatic digitizing purposes,
you may want to crop an image before digitizing. You
can do this within BERNINA Embroidery Software or
using a third-party graphics application. Sometimes,
you may want to save backdrops as separate files
after scanning or cropping.

Select format

2 Select a folder and select a file type from the Files

Tip For both manual and automatic digitizing
purposes, ‘clean’ images, sometimes referred to as
‘cartoons’, work best. Scanners introduce noise, while
graphics applications perform ‘dithering’ and
‘anti-aliasing’ to improve print quality. See also
Preparing images for automatic digitizing.

of Type list – e.g. CDR.
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Cropping bitmaps for digitizing

Reshaping cropped bitmaps

Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
Use Auto-Digitize > Crop Background to crop bitmap
artwork for use with auto-digitizing.
BERNINA Embroidery Software allows you to crop
images prior to use. Before using bitmap images for
design purposes, crop them to remove unnecessary
detail and save processing time.

Click Transform > Reshape Object to crop a free
form image.
After an image has been cropped, you can reshape
and transform the cropping outlines in the same way
as you reshape and transform lettering. You can also
use the tool to reposition cropping outlines. See also
Reshaping letters on screen.
To reshape cropped images

1 Crop an image and select. See Cropping bitmaps

To crop a bitmap for digitizing

for digitizing for details.

 Scan or load the image you want to use. See
Importing artwork for details.

2 Click the Reshape Object icon.

 Select the bitmap and click Crop Background.
The Crop toolbar opens.
Select cropping
option

3 Adjust reshape nodes to change the shape and
press Enter.
The image displays the cropping outline with
reshape nodes.

 Digitize points to create a cropping shape around
the part of the image you require and press Enter.

4 Press Esc to finish.

Touching up artwork

Rectangle

Heart

Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
Use Auto-Digitize > Touch Up Bitmap Artwork to edit
images in a third-party graphics application.

Star 10 points

Curve

From within BERNINA Embroidery Software you can
open images into third-party graphics applications
which can help you improve your scanned images.
Eliminate backgrounds, flood-fill solid areas with
color, or add outlines, close gaps, or reinforce
outlines. Images updated in this way are
automatically re-imported into BERNINA Embroidery
Software.

BERNINA® Embroidery Software : Reference Manual

115

Chapter 13 : Digitizing with Backdrops
Many graphics applications are available. At one end
of the spectrum you have the simple MS Paint
application. This comes free with MS Windows® but
can handle few formats or color conversions. At the
other end there are professional tools such as Corel
PHOTO-PAINT® Essentials X6.

The image displays in BERNINA Embroidery
Software overlaid with stripes. This means that it
is still open in the graphics application.

Image still open in
graphics
application

To touch up artwork

1 Scan or load the image you want to use. See
Importing artwork for details.

2 Still in Artwork Canvas mode, select the image.
6 Select File > Exit & Return <Filename> to exit
the graphics application.
The updated image displays in BERNINA
Embroidery Software and the stripes disappear.
Use a graphics application
to cut out part to be
embroidered

Tip If you want to keep the graphics application
open, select File > Close when finished updating
the image.

Saving backdrops as separate files
3 Click the Touch Up icon. The image opens into
the Corel PHOTO-PAINT® Essentials X6
application.

4 Edit the image as required.

Image cropped

Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.
Use Artwork > Save Artwork to save a backdrop as
a separate file.
All images placed in the design window, whether by
scanning, pasting or inserting from hard disk, are
saved together with the embroidery design in the ART
file. After editing in BERNINA Embroidery Software or
third-party graphics application, you may want to
save the image out as a separate file.
To save a backdrop as a separate file

Background removed

1 Scan or load the image you want to use. See
Importing artwork for details.

2 Still in Artwork Canvas mode, select the image.

Outlines added

5 Select File > Update Design.
3 Click the Save Artwork icon.
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The Export dialog opens.
Select folder

Enter file name

Select required format

4 In the Save In field, select a folder, then select a
format from the Save as type droplist.

5 Enter a new file name and click Export.
When you save the design, the reference is
updated to use the new image file.
Note This file is not referenced by the ART file.
Any further changes to it are not reflected in the
embedded image.
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CHAPTER 14
IMAGE PROCESSING
BERNINA Embroidery Software supports the
automatic and semi-automatic digitizing of
bitmap images. The quality of the resulting
designs greatly depends on the type and
quality of the original artwork. In order to
make bitmap images more suitable for
automatic digitizing, BERNINA Embroidery
Software also provides image processing
capabilities and links to graphics packages.
This section describes how to prepare
images for automatic digitizing. It explains
how to prepare both outlined and
non-outlined images.

Preparing images for automatic
digitizing
Before applying automatic digitizing, you frequently
need to improve or ‘clean up’ artwork. To work
effectively, both Auto-Digitize and Magic Wand
require solid color images as input. You can improve
artwork both with bitmap editing tools in graphics
packages and/or the image processing tools provided
in BERNINA® Embroidery Software. In fact, the
software will not let you apply Auto-Digitize until the
image has been suitably processed.
Outlined vs non-outlined images
Before preparing your image you need to know what
type you are using. For the purposes of automatic
digitizing, there are two categories – outlined and
non-outlined. Outlined images ideally have a solid
black outline around each colored area. Non-outlined
images ideally consist of solid areas of color. Outlined

and non-outlined images require different methods of
preparation.

Image with outlines

Image without outlines

Image clean up
In practice, cleaning up scanned images may involve
any one or a combination of the following techniques:
 reducing the number of colors
 adding or emphasizing outlines
 removing noise, dithering or anti-aliasing
 eliminating unnecessary detail
 cropping sections
 eliminating backgrounds.
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Color reduction
Sometimes an image looks clean but extra colors
have been introduced during scanning or in a graphics
package. Color reduction means reducing the actual
number of image colors in order to eliminate
unnecessary detail and reduce each block to a single
color. Color reduction also cleans the image, removing
noise and anti-aliasing if present. This in turn helps
minimize the number of trims and color changes
required in the resulting embroidery design. Reduce
colors in a non-outlined and outlined images using the
Bitmap Artwork Preparation function.
Color reduction should only be applied if the loss of
detail does not affect the image shapes. Before color
reduction, the colored areas in the image below
include many colors. After reduction, each area is
reduced to a single color. The detail is preserved.

the distinct areas which become embroidery objects
in the resulting design.

Note Outline sharpening only works on images with
black or dark outlines.

Image before outline
sharpening

Image after outline
sharpening

Some images have solid outlines but they may be
indistinct or incomplete. These need to be rectified
with the BERNINA Embroidery Software artwork
preparation tools or a graphics package. See Touching
up artwork for details.
Noise filtering
Image before color
reduction

Image after color
reduction

If you are scanning images, make sure you scan them
correctly for best results. See Scanning artwork for
details.

Scanned in 256
color mode

Noise filtering means restoring the solid color blocks
of the original artwork in scanned images. This is
achieved by merging different shades into one solid
color. Noise filtering is important for automatic
digitizing because it makes it easier for the software
to identify solid color blocks which become
embroidery objects in the resulting design. It also
cleans up blurred or mottled areas of color.

Scanned in RGB color
mode (millions of colors)
Image of mottled colors
before noise removal

Outline sharpening
Outline sharpening means more clearly defining the
outlines bordering distinct color blocks or shapes in
the artwork. These may have been indistinct in the
original or made so by the scanning process. Outline
sharpening is important for automatic digitizing
because it makes it easier for the software to identify

Image single colors
after noise removal

Artwork preparation summary
Even if your artwork looks ready to stitch when
inserted into the software, it will need to be prepared
and image-processed before conversion.

Action

Outlined image

Non-outlined image

Photo

Scan artwork

• Scan in RGB mode
• Use sharpening

• Scan in RGB mode
• No sharpening

Scan in RGB mode
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Action

Outlined image

Non-outlined image

Photo

Scan line drawing

Scan in two-color mode

n/a

n/a

Touch up in external graphics • Crop
program
• Add or edit outlines
• Edit colors
• Remove noise

•
•
•
•

•
•
•
•

Use Bitmap Artwork
Preparation tool

Automatically:
• Reduce each outlined
block to a single color
• Remove anti-aliasing,
noise and dithering
• Sharpen outlines.

Automatically:
• Reduce each block to a
single color
• Remove anti-aliasing,
noise and dithering
• Merge redundant colors.

Color PhotoStitch contains its
own image preparation
methods

Digitize

• Manual
• Magic Wand
• Auto-Digitize

• Manual
• Magic Wand
• Auto-Digitize

• PhotoSnap
• Color PhotoStitch

Preparing non-outlined bitmaps

Crop
Edit image shapes
Edit colors
Remove noise

Crop
Convert to grayscale
Remove background
Adjust contrast

To prepare a non-outlined bitmap

1 Scan or load the image you want to use. See
Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.
Use General > Insert Artwork to import artwork into
current design as a backdrop for manual or
automatic digitizing.

Importing artwork for details.

2 In Artwork Canvas, select the image and crop or
size as required. See Editing imported artwork for
details.

3 Switch to Embroidery Canvas and select the
image.

The Embroidery Canvas provides a Bitmap
Artwork Preparation option to prepare
non-outlined images for automatic digitizing. This
function automatically reduces color blocks in bitmap
images to a single color, removing anti-aliasing and
noise. You can let the software reduce the color count
automatically or specify a precise number. The latter
is useful if you want to match design colors to an
exact number of threads.

4 Select Artwork > Bitmap Artwork
Preparation. The image appears in both ‘before’
and ‘after’ preview panels.

Tip Depending on the quality of the scanned image,
you may need to touch it up manually before
processing in BERNINA Embroidery Software. You
would normally do this in order to eliminate
backgrounds, flood-fill solid areas with color, or add
outlines, close gaps, or reinforce outlines. See
Touching up artwork for details.
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5 Check the number of colors in the bitmap. If there

10 Experiment with settings to obtain the best result.

are a lot, the image probably contains ‘noise’. See
also Preparing images for automatic digitizing.
The software suggests a reduced color count and
shows a preview.

Enter number of
colors/threads
required

6 First try adjusting the color count up or down to
match the number of threads you wish to use.

7 If the image still contains ‘noise’, try adjusting the
filtering options:
Option

Purpose

Min color
area

This defines the smallest area recognized by
the conversion. The default is 0.5 by 0.5
square mm (about eight pixels). Increase
this value if your image has a lot of
‘out-of-color’ pixels. The minimum color area
should not exceed 1/16 of the total area.

Min line
length

This defines the smallest line length
recognized as an object. The default is 2
mm. The minimum line length should not
exceed 25% of the smallest dimension.

8 Use the zoom buttons to view the image more
closely. In addition, you can use the mouse wheel
to zoom in and out. You can also click and drag the
image to pan it within the preview panel.

9 If necessary, manually locate and merge colors.

11 Click OK to apply changes.
The image is ready for automatic digitizing. See
Automatic Digitizing for details.

Preparing outlined images
Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.
Use General > Insert Artwork to import artwork into
current design as a backdrop for manual or
automatic digitizing.
Use the Bitmap Artwork Preparation tool to
prepare outlined images for automatic digitizing.
Outline sharpening makes it easier for the software to
recognize distinct areas in the artwork. These areas
then become the embroidery objects of the finished
design. Use it particularly if the outlines are blurry,
fuzzy or indistinct.

 Holding the Ctrl key, click like-colors in the
color palette to select.
 Click and hold the Locate button to preview.
 Click Merge to merge all like-colors into a
single color.
Tip Depending on the quality of the scanned image,
you may need to touch it up manually before
processing in BERNINA Embroidery Software. You
would normally do this in order to crop an image,
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eliminate backgrounds, flood-fill solid areas with
color, or add borders, close gaps, or reinforce borders.
See Editing imported artwork for details.

8 Use the slider control to set the outline contrast
tolerance. This produces a black and white preview
of the detected outlines.

To prepare an outlined image

1 Scan or load the image you want to use. See
Importing artwork for details.

2 In Artwork Canvas, select the image and crop or
edit it as required. See Editing imported artwork
for details.

3 Switch to Embroidery Canvas and select the
image.

4 Zoom to view the outline.

Tip Move the slider to the right until there is too
much black, then move it slowly back to the left.
Stop when the image shows the outlines clearly.

9 Experiment with settings to obtain the best result.
If necessary, manually locate and merge like
colors as for non-outlined images.

5 Select Artwork > Bitmap Artwork
Preparation. The image appears in both ‘before’
and ‘after’ preview panels.

10 Click OK to apply changes.
The image is ready for automatic digitizing. See
Automatic Digitizing for details.

6 Check the number of colors in the bitmap. If there
are a lot, the image probably contains ‘noise’. See
also Preparing images for automatic digitizing.

7 Select the Cartoon processing option. The
software suggests a reduced color count and
shows a preview.

Select cartoon
processing
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CHAPTER 15
AUTOMATIC DIGITIZING
Through its integration with CorelDRAW®, BERNINA Embroidery Software allows
inter-conversion of vector and embroidery objects. The Convert Vectors to
Embroidery tool can be applied to text as well as vector artwork.

The Auto-Digitize tools automatically convert artwork to entire designs with
little or no intervention. With these tools, novice embroiderers can create simple
designs quite quickly and easily.
BERNINA Embroidery Software also provides a Magic Wand tool for quickly
generating simple embroidery directly from electronic artwork. This in turn frees
you to spend more time on the artistic or more complicated areas of your designs.
With PhotoSnap you can create embroidery from photographs and other
images. While PhotoSnap designs consist of rows of single-color satin stitching,
Color PhotoStitch produces variegated stitching using multiple thread colors.
This section describes how to automatically convert vector artwork as well as
bitmap images to embroidery designs with the available techniques. It also covers
how to create embroidery from photographs.

Converting vector artwork
Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for embroidery
digitizing, manual or automatic.

Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.
Special conversion tools in BERNINA Embroidery
Software automatically convert vector objects and
text to embroidery or lettering objects. In fact, entire
vector drawings can be quickly and easily converted
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to embroidery designs. When creating embroidery
objects, the software determines optimum object and
stitch type for given shapes. These can be modified as
required. You can also convert embroidery designs or
objects to vector objects.

applied to text as well as vector artwork. See also
Converting text to embroidery.

Note Bitmaps cannot be converted to embroidery via
the Convert Artwork to Embroidery tool as images
still need to be processed prior to conversion. See
Image Processing for details.
To convert vectors to embroidery

1 Switch to Artwork Canvas.
2 Scan, load, and size the artwork and/or text you
want to use. See also Importing artwork.

Caution Included artwork (clipart) and embroidery
designs can only be used for personal use – i.e. they
cannot be commercially sold in any form. Changing
the medium – i.e. clipart to embroidery or embroidery
to clipart – does not remove copyright protection.
Conversion limitations
There are some limitations when converting some
CorelDRAW® vectors to embroidery. Vector special
effects, such as drop shadow, contour, and
transparency, do not convert well as there is no
equivalent embroidery effect. Enveloped text and
Fountain or Mesh fills do not always give the
expected result either.

3 Click Convert Artwork to Embroidery.
BERNINA Embroidery Software automatically
switches to Embroidery Canvas.

Drop shadow unable
to be converted

Converting embroidery to vectors
If there is no embroidery equivalent, the object is
converted with solid colors only. Enveloped text is
converted to embroidery objects rather than
embroidery text.

Converting vectors to embroidery

Use Canvas > Convert Embroidery to Artwork
to convert selected embroidery objects to
vector artwork.
The Convert Embroidery to Artwork tool converts
selected embroidery objects to vectors.

Use Canvas > Convert Artwork to Embroidery
to convert selected vector or bitmap artwork to
fill or outline stitches.
The Convert Artwork to Embroidery tool converts
fill or outline properties of selected vector artwork to
fill or outline stitch types respectively. It can be
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To convert embroidery to vectors

1 Switch to Embroidery Canvas.

Digitizing whole images automatically
Use Auto-Digitize > Insert Artwork to import artwork
into current design as a backdrop for manual or
automatic digitizing.
Use View > Show Bitmap Artwork to show and hide
bitmap images.
Use Auto-Digitize > Instant Auto-Digitize to
automatically digitize bitmap artwork instantly.
Use Auto-Digitize > Auto-Digitize to automatically
digitize prepared bitmap artwork.

2 Select embroidery and/or lettering objects and
click Convert Embroidery to Artwork.
BERNINA Embroidery Software automatically
switches to Artwork Canvas mode.

In essence, creating an embroidery design with the
Instant Auto-Digitize tool is simply a matter of
selecting the image you want to convert, and clicking
the tool. The system automatically determines colors
to fill, turn into details, or omit altogether. And it
chooses suitable stitch types using default settings.
Even if an image has not been pre-processed,
Instant Auto-Digitize will automatically process
and convert it.
For more control over object conversion, use the
Auto-Digitize method. This too can recognize
shapes in bitmap artwork and choose suitable stitch
types to use. However, it provides more control over
conversion settings.
Once created, you can always edit the final result
using the available digitizing techniques. Always
remember to apply underlays and you may need to
reshape some objects.
To digitize a whole image automatically
 Scan or insert the image you want to use. See
Importing artwork for details.

Auto-digitizing with Auto-Digitize
An extension of Magic Wand technology,
Auto-Digitize recognizes shapes in artwork and
makes decisions about the most suitable stitch types
to use. It also determines the stitching sequence
based on closest join. Artwork is effectively ‘batch
processed’ to create the many embroidery objects
that make up a design.

Note Even if your artwork looks ready to stitch when
inserted into the software, it will need to be
image-processed before conversion. The software will
not let you apply automatic digitizing techniques
without preliminary image-processing. See Image
Processing for details.

Insert artwork

 If you cannot see the image, turn on Show
Bitmap Artwork. See Displaying backdrops for
details.
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 Size the artwork for its intended purpose.

 Image colors are automatically classified as fills or
details, or omitted altogether.

Set design
size

 Optionally, pre-process the image with the image
preparation tool. See Image Processing for details.
 For an instant sample of your artwork, click
Instant Auto-Digitize. With simple designs, the
results my be sufficient to work with.
Instant
Auto-Digitize

 Select a color in the list and use the Locate button
to preview. Should the color be treated as a fill or
a detail?

Locate color
blocks

 For more control, select the image and click
Auto-Digitize.
The software checks whether the bitmap has been
processed and displays the Bitmap Artwork
Preparation dialog as necessary. See Image
Processing for details.

 Use droplists to tag colors or omit them altogether.
Fills are always stitched first, details, including
borders or small areas, last.

Use droplists to
tag colors

Use Up/Down to
adjust sequence

 Use Up / Down buttons to adjust the stitching
sequence as preferred.
 Select a conversion method for color processing.
By default, image colors are matched to the
nearest thread colors in the current design palette.
Select conversion
method

 Use the ‘Add Bitmap Colors to Palette’ option if you
want to use the exact image colors.
 Adjust stitching options for details as preferred.
See Adjusting automatic stitch settings for details.
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 Click OK to process the image.
Auto-Digitize

Note All editing techniques are available to
further refine the auto-digitized image.

Adjusting automatic stitch settings
Use Auto-Digitize > Auto-Digitize to automatically
digitize prepared bitmap artwork.
Auto-Digitize lets you adjust object recognition
settings for any color you identify as a ‘detail’. A detail
may be a centerline, a border, or a small area of the
design you want stitched last. If an image color is
both a fill and a detail, you can either recolor the fill
color in a graphics package, or omit it for later editing.
Auto-Digitize also allows you to automatically
generate outlines during image conversion.
To adjust automatic stitch settings
 Auto-digitize your artwork using the
Auto-Digitize method. See Digitizing whole
images automatically for details.

 Select a stitching style for details from the
droplist:
Style

Description

Centerline

Most suited for use with thin lines. This
option will trace the center of a color
identified as a detail with a run stitch.

Satin line

Suited for use with thicker lines of constant
width, usually with larger designs. However,
if the width of the shape varies, the software
will automatically apply satin fill even if satin
line is selected.

Satin fill

Most suited for use with thicker lines or
small shapes of varying width.

Note Do not use satin fill for areas where the
stitch length exceeds 7 mm. See Preserving long
stitches for details.
 Optionally, add outlines to all color blocks. Tick
Outlines and select a color. This has the effect of
reinforcing color blocks with a continuous,
branched running stitch.

Include outlines
and/or border

Caution If the image already contains outlines,
the use of Outlines will result in double outlines.
 Similarly, you can add a border to the entire design
by ticking the Border checkbox.
 Click OK to process the image.

Select stitching
style for details
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3 Switch back to Embroidery Canvas and make
Tip You may omit all image colors from the
selection criteria and choose to generate only
outlines.

sure Show Bitmap Artwork is toggled on. See
also Displaying backdrops.

4 Use Matching Method to assign image colors to
the color palette for manual thread matching, or
automatically match them to the current color
palette or current thread chart.

Choose a thread
matching method

5 Select Magic Wand.

Image processed and
ready for auto digitizing

Auto-digitizing with Magic Wand
Use General > Insert Artwork to import artwork into
current design as a backdrop for manual or
automatic digitizing.
Use View > Show Bitmap Artwork to show and hide
bitmap images.
Use Auto-Digitize > Magic Wand to digitize large
artwork shapes with weave fill, preserving any holes
within.
Use Auto-Digitize > Magic Wand Block Digitizing to
digitize narrow column artwork shapes with satin
stitch.
Use Auto-Digitize > Magic Wand Fill without Holes to
digitize large artwork shapes with tatami fill, ignoring
any holes within.
Use Auto-Digitize > Magic Wand Centerline to
digitize centerlines in artwork with run stitching.

6 Click an area of the image as prompted.
The software checks whether it has been
processed and displays the Bitmap Artwork
Preparation dialog as necessary. See Image
Processing for details.

7 Hover the mouse pointer over an area of the
image, and click.

Use Auto-Digitize > Matching Method to assign
image colors to the color palette for manual thread
matching, or automatically match them to the current
color palette or current thread chart.
The Magic Wand tools provide everything necessary
to digitize shapes in bitmap images automatically.
To digitize shapes automatically

1 Scan or load the image you want to use. See
Importing artwork for details.

2 In Artwork Canvas, select the image and crop or
size as required. See Editing imported artwork for
details.
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Stitches are generated according to current stitch
settings. Jumps may appear if stitch length
exceeds the default.

Magic Wand used for
larger shapes

10 Use the Fill without Holes tool to ignore holes in
shapes.

Fill without Holes ignores
holes in shapes

11 If you want to both fill and outline a shape, using
8 Choose Magic Wand tools according to object
shape. Turning Satin, for instance, is suited to
narrow columns.

the Magic Wand tool, left-click for fills and
right-click for outlines.

12 Change thread colors and stitch type as required.
See also Selecting stitch types.

Turning Satin used for
smaller columns and
curved shapes

9 Use the Centerline tool to pick out details.

13 Use the Color Film to place objects in the
optimum stitching sequence. See also Sequencing
embroidery objects.

Centerline used to
pick out details

Caution It is easy with Magic Wand tools to
double-click and inadvertently create
double-layers of stitching. Check everything you
do in the Color Film and delete any unnecessary
objects.

Auto-digitizing with Color PhotoStitch
Use Auto-Digitize > Insert Artwork to import artwork
into current design as a backdrop for manual or
automatic digitizing.
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Use View > Show Bitmap Artwork to show and hide
bitmap images.
Use Auto-Digitize > Adjust Image to adjust image
lightness and contrast.
Use Auto-Digitize > Touch Up Bitmap Artwork to edit
images in a third-party graphics application.
Use Auto-Digitize > Color PhotoStitch to
automatically turn photographs and other bitmap
artwork into multi-colored embroidery.
Use Color PhotoStitch to create embroidery from
photographs and other images. While PhotoSnap
designs consist of rows of single-color satin stitching,
Color PhotoStitch produces variegated stitching
using multiple thread colors. The overall effect is like
multi-colored stippling. For best results, use crisp
images with well-defined subjects and constantly
varying shades.

 Optionally, use Adjust Image to adjust basic
lightness and contrast. These settings are
designed to attune image colors to available
thread colors. For the full range of image
adjustment techniques, use a dedicated graphics
program like PHOTO-PAINT.
 Optionally, touch up using Corel PHOTO-PAINT or
similar program. See Touching up artwork for
details.
 Optionally, crop the image. See Cropping bitmaps
for digitizing for details.
 Size the image for its intended purpose. Optimal
size is 150mm x 150mm or about 6" x 6".
 Choose the machine and hoop that you will use.
See Selecting hoops for details.
To process the image
 With the image selected, click Color PhotoStitch.

Set number
of thread
colors

To prepare the image
 Scan or insert the image you want to use. For best
stitching results, images are better imported via
the Artwork Canvas than Embroidery Canvas.
See also Importing artwork.

 Set the number of thread colors. There will be a
point a diminishing returns where more colors do
not always result in greater design clarity or
stitchability. Usually 7 to 10 colors produce the
best results.
 Use the zoom buttons to examine the previews in
detail. You can also zoom in and out with the
mouse wheel.

 If you cannot see the image, turn on Show
Bitmap Artwork. See Displaying backdrops for
details.
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 Optionally, adjust stitching resolution to high,
medium, or low. High resolution allows greater
detail but with a higher stitch count.

To edit the results
 Check the results with Artistic View on and off.
Turn connector stitching on and off. See also
Embroidery view settings.
If you are unsatisfied with the results, click Undo
and try again. Try different settings and check the
previews. You may need to touch up the image in
PHOTO-PAINT if none of the results is good
enough.
 Edit the results and manually merge thread colors
as desired.

 Click Adjust for further options. Choose between
several image variations:
Effect

Notes

Sepia

In photographic terms, ‘sepia’ refers to the
dark-brown color of old-fashioned prints.
Originally the process involved adding a
pigment made from cuttlefish ink during
development.

Gray

Again in photographic terms, a grayscale or
greyscale images are ones composed
exclusively of shades of gray, varying from
black at the weakest intensity to white at the
strongest.

 Optionally, adjust basic lightness and contrast if
you haven’t already done so.
 Optionally, use Matching Method to assign
image colors to the color palette for manual thread
matching, or automatically match them to the
current color palette or current thread chart.

Choose a thread
matching method

 If you have added RGB colors to the color palette,
open the Color Film and My Threads dockers
side-by-side, and select the thread charts you
have available from the Thread Charts dialog.
Select each color block in turn, check the closest
match in My Threads docker, and manually
choose a thread. Sometimes the closest match
may not be the best or be unavailable. Choosing
the correct thread is key to getting a good result.

Auto-digitizing with PhotoSnap
Use Auto-Digitize > Insert Artwork to import artwork
into current design as a backdrop for manual or
automatic digitizing.
Use View > Show Bitmap Artwork to show and hide
bitmap images.

Use the button to select one or more available
thread charts to match to.
 Click OK to process the image.

Use Auto-Digitize > PhotoSnap to automatically
create rows of Satin and Contour stitches of varying
spacing in current color from photographs and other
bitmap artwork. The effect resembles the output of a
line printer.
Use PhotoSnap to create embroidery from
photographs and other images. Use color or
grayscale. Grayscale images are made up of different
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shades of gray pixels. Color images are automatically
converted to grayscale when you apply PhotoSnap.

The Object Properties > PhotoSnap dialog
opens.

Select resolution

4 In the Resolution panel, select a resolution –
Coarse, Medium, or Fine – and click Apply.
PhotoSnap designs consist of rows of satin stitches
of varying spacing. The effect resembles the output of
a line printer.

With border and
lettering added
Coarse

Fine

5 In the Background Fabric panel, select a
background option – Light or Dark – and click
Apply.
Tip For best results, use images with well-defined
subjects or constantly varying shades.
To create a design with PhotoSnap

1 Scan or load the image you want to use. See
Importing artwork for details.

Light background

Dark background

Tip Usually the option you select depends on
whether the fabric is light or dark.

Tip If you cannot see the image you loaded make
sure Show Bitmap Artwork icon is toggled on.
See Displaying backdrops for details.

2 In Embroidery Canvas mode, click the
PhotoSnap icon and click the image as prompted.
BERNINA Embroidery Software generates stitches.
This process may take some time.

3 Right-click or double-click the resulting
PhotoSnap design.
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6 In the Fill Angle panel, adjust the stitching angle,
if required, and click Apply.

Fill angle 0°

Fill angle 45°

7 Select Fill Stitch tab and adjust PhotoSatin
stitch values as desired.

Adjust PhotoSatin
values

 Stitch Spacing: adjusts stitch density – to
increase stitch density, enter a smaller value.
 Skew Angle: determines the angle of the
stitches themselves (as distinct from the fill
angle).

Fill angle 45°
Skew angle: 0°

Fill angle 45°
Skew angle: 45°

8 Click Apply to apply changes and OK to close.
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PART IV
MODIFYING DESIGNS
After digitizing a design, you can modify it as a whole, edit individual objects or even
individual stitches.

Combining & sequencing objects
This section describes how to combine objects and designs by copying and pasting,
duplicating, and inserting whole designs and design elements. It also covers grouping
and splitting objects, as well as sequencing objects using various techniques including
Color Film. It also discusses auto-sequencing entire designs. See Combining &
Sequencing Objects for details.

Design layouts
This section describes how to position and align objects by both interactive and numeric
methods. It also covers scaling, rotating and skewing objects. A variety of methods for
mirroring objects are also described. Special layout tools are also discussed. See Design
Layouts for details.

Reshaping & editing objects
This section describes how to reshape objects with reshape nodes. It also covers
adjusting stitch angles – including multiple stitch angles – as well as changing entry and
exit points. It also discusses cutting objects and removing underlying stitching, as well
as adding holes to existing objects, filling holes, and generating outlines. See Reshaping
& Editing Objects for details.

Editing stitches
This section deals with selecting and editing stitches. See Editing Stitches for details.
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CHAPTER 16
COMBINING & SEQUENCING OBJECTS
BERNINA Embroidery Software lets
you easily combine designs and design
elements by inserting the contents of
one file into another. You can also add
to designs quickly by copying or
duplicating existing objects. Group
selected objects or entire designs to
keep them together for moving,
scaling or transforming purposes.
The embroidery objects in a design
form a ‘stitching sequence’. Initially,
objects are stitched in the order they
were created. However, you can
change this by a variety of methods.
For example, change the position of a selected object by cutting it, then pasting
it somewhere else in the sequence. There are also techniques available to
sequence objects ‘as selected’ or as ‘color blocks’. You can also resequence
objects using the Color Film.
The Stitch Sequence feature improves the quality and efficiency of the stitchout
by minimizing the number of hoopings, color changes, and trims. All existing
overlaps are preserved by the operation.
This section describes how to combine objects and designs by copying and
pasting, duplicating, and inserting whole designs and design elements. It also
covers grouping and splitting objects, as well as sequencing objects using various
techniques including Color Film. It also discusses auto-sequencing entire designs.

Combining objects
A design or design objects can be copied or cut and
placed on the MS Windows® Clipboard for temporary
storage. It can then be pasted any number of times,
either within the same or another design, until
replaced on the Clipboard. Objects also can be cloned
or duplicated without copying to the Clipboard. See
also Selecting Objects.

Inserting designs
Use General > Insert Embroidery to import
embroidery design files into the current design.

BERNINA Embroidery Software lets you insert one
design into another. The two (or more) designs can
then be saved as a combined design. When you insert
a design in another, the two color palettes are
combined. Colors with the same RGB values are
automatically identified as having the same thread
color. If you want to preserve these as separate
colors, you need to change one or other before
merging.
Caution It’s best, when combining designs, to use
Art Grade A or Grade B file formats. Art Grade C and
D designs may produce poor results if resizing. See
also Supported machine file formats.
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To insert designs

1 Open the base design.
When you first open a design in BERNINA
Embroidery Software, it is grouped by default. See
also Grouping & ungrouping objects.

Note You can also remove objects from a design
using the Cut command and paste them back in
again. Cut and Paste changes the stitching sequence
in the design. See Sequencing by cut-and-paste for
details.

2 Click Insert Embroidery.
The Insert Embroidery dialog opens.

3 Find the design file you want to use and click
Open.
The design is placed at the end of the stitching
sequence. It too is grouped by default.

4 Resequence objects in the combined designs as
necessary, ensuring that details stitch out last. See
Sequencing embroidery objects for details.

5 Size the inserted design as required. See also
Scaling objects.

To copy & paste objects

1 Select the object(s) to copy.
2 Click the Copy icon.
The selected object is copied to the clipboard.

3 Travel to the position in the stitching sequence at
which you want to paste the object. See Traveling
through designs for details.
You can paste between other objects in the
sequence.

4 Click the Paste icon.

Petals copied
and pasted

Note The object will be pasted exactly on top of
the original object. Click and drag it off the object
before deselecting.
The object remains on the clipboard and can be
pasted repeatedly until the next Copy or Cut
command.

6 Move to the required position. See also Arranging
objects.

7 Remove any underlying stitching as necessary.
See also Removing underlying stitching.

8 Save the combined designs under the original or
new name.

Copying & pasting objects
Click General > Copy to copy selected objects to the
clipboard.
Click General > Paste to paste copied objects in the
design.
You can copy objects to create multiple, identical
objects, or to insert objects from other designs. See
also Sequencing with Color Film.

Caution Make sure that there is only one copy of
an object at any one position. If an object is pasted
twice into the same position, it will be stitched
twice.

Duplicating objects
Objects can be duplicated rather than copied. When
an object is duplicated, it is not copied to the
clipboard. This leaves the clipboard free for you to cut
or copy other objects. See also Sequencing with Color
Film.
To duplicate objects
 Travel to the point in the stitching sequence where
you want to place the object(s). See Traveling
through designs for details.
You can place the duplicate(s) between other
objects in the sequence.
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 Select the object(s) to duplicate.
 Select Edit > Duplicate or press Ctrl+D.
The duplicate object is placed directly on top of the
original object, at the current needle position in
the stitching sequence. Be sure to click and drag it
off the object before deselecting.
 Alternatively, select Edit > Duplicate with
Offset or press Ctrl+Shift+D. This function is
best used in conjunction with the Quick Clone
feature.

Tip For precise positioning, hold down the Ctrl key
while dragging – movement is constrained to X or
Y axes.

3 Release the mouse. A duplicate object(s) is
created at the release point.

4 Press Ctrl+Shift+D to repeat. A new object is
created at the same offset as the cloned object.

Press Ctrl+Shift+D to
create duplicate offset

Press Ctrl+Shift+D to
create duplicate offset
Cloned object

Source object
Source object

Cloning objects
Use Transform > Select Object to select and clone
objects.
The Quick Clone feature lets you quickly duplicate
selected objects by right-clicking, dragging and
releasing at a new position.

Tip Clone objects to another window by the same
method. An identical copy of the selection is
created at the same coordinates as the first
window, no matter where the mouse is released.

Grouping & splitting objects
Tip The software lets you create duplicate objects
with an automatic offset. This means you can
step-repeat offsets with duplicate objects.
To clone objects

1 Select the object(s).
2 Holding down the right mouse button, drag to a
new position.

You can group selected objects or an entire design to
keep them together for moving, scaling or
transforming purposes. BERNINA Embroidery
Software makes a distinction between ‘ungrouping’
objects and ‘breaking apart’ objects. Generally
speaking, objects which have been explicitly grouped
by you, the digitizer, need to be ‘ungrouped’ in order
to access their component objects. If you want to
access objects which have been grouped during
system operations – e.g. when generating
open-object appliqué – you need to break them apart.

Right-click object

Drag-and-drop

Note By default, designs are automatically grouped
upon opening or insertion into another design. See
Setting other general options for details.

Grouping & ungrouping objects
Use Arrange > Group to combine multiple objects
into one selectable object grouping.
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Click Arrange > Ungroup to split object grouping into
component objects.
When you group objects, you can apply a change to
all of them at once, saving time, and ensuring that
changes are consistently applied. Group selected
objects or the whole design to keep them together for
moving, scaling or transforming operations. When
you have finished making changes to a group, you can
ungroup it and work with the objects individually.

To lock or unlock objects
 Select the objects to lock and click the Lock icon
or press K.
The selection handles disappear, indicating that
the object can no longer be selected or modified.
 To unlock objects, click the Unlock All icon.

All locked objects in the design are unlocked.

Selecting objects within groups
Note When you first open a design in BERNINA
Embroidery Software, it is grouped by default.
To group & ungroup objects
 Select objects to group and click the Group icon or
press Ctrl+G.

Select, move, resize or
transform grouped
objects as a single
object

Selected objects are combined into a group. This
can be selected, moved, resized and transformed
as a single object. See also Design Layouts and
See also Reshaping & Editing Objects..

Click Transform > Select Object to select individual
objects as well as groups or ranges of objects.
BERNINA® Embroidery Software provides a method
for selecting individual objects within object
groupings. The Alt key ‘suspends’ grouping
temporarily. This is handy if you want to make
changes ‘on-the-fly’ without first having to ungroup
and then regroup objects.
To select objects within groups
 Click the Select Object icon or press 0.

Entire design
grouped

 Select the grouped object and click the Ungroup
icon or press Ctrl+U.
The object is ungrouped and component objects
can be individually selected. See also Selecting
objects within groups.

Ungrouped objects
can be individually
selected

 Use Alt + Click to select a single object within a
group.

Locking & unlocking objects
Click Arrange > Lock to lock selected object/s into
position for protection.
Click Arrange > Unlock All to unlock all locked
object/s to remove protection.
Lock objects to prevent them from being moved or
modified by accident. For example, locking backdrop
images holds them in place as you digitize, transform
or reshape the embroidery objects near them. Locked
objects can be unlocked for modification at any time.

 In combination with the Alt key, use standard
techniques to select multiple objects or a range of
objects within a grouped design, both in the design
window and the Color Film. These include:
 Select a single object/color within a group:
Alt + Click.
 Add/remove a single object/color within a
group: Alt + Ctrl + Click.
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 Select a range of objects/colors within a group:
Alt + Shift + Click.

Individual objects
selected within
group

The Break Apart command is activated.

2 Click Break Apart.
The object is split into its component source
(primary) and any generated (secondary) objects.

Tip You can also use a selection marquee or
Polygon Select in combination with the Alt key.
See also Selecting Objects.
 Once an object (or more) is selected, edit its
properties, stitching and otherwise, as desired.

Splitting into component objects
Use Edit > Break Apart to split monograms, appliqué,
lettering, and blackwork runs into component objects
for editing.
The Break Apart tool allows you to split appliqué
objects into their components. The command can also
be used with monograms, lettering and blackwork
runs. The effect on these objects is similar to the
ungrouping operation.

The operation ungroups open-object appliqué into
its component groups – source (primary) objects,
generated (secondary) objects. It also creates an
auto-appliqué object from each piece of fabric in
the design. These will have no stitching. See also
Digitizing for Appliqué.

Note When saved into earlier versions of the
software, monograms, appliqués, lettering, and
blackwork runs may be subjected to the Break Apart
procedure by default.
To split into component objects

1 Select the object you want to split – open-object
appliqué, auto-appliqué, monogram, or lettering.

The operation ungroups monogram objects into
their component groups – one lettering object,
ornaments (each ornament set remaining as a
group) and borders (also grouped). See also
Monogramming.
Tip To modify individual objects – e.g. to change
the stitching sequence of monogram borders – use
the Color Film to ungroup objects and resequence.

BERNINA® Embroidery Software : Reference Manual

139

Chapter 16 : Combining & Sequencing Objects

Sequencing embroidery objects
The embroidery objects comprising a design form a
‘stitching sequence’. Before digitizing, it is good
practice to analyze and plan design shapes and
stitching sequence in advance. Shapes need to be
clearly defined to make them easy to embroider. The
best shapes have relatively constant width, with
smooth edges, no sharp turns and no small,
protruding details. Details should always be stitched
last. See also Sequencing with Color Film.

3 Travel to the position in the stitching sequence
where you want to paste the object. See Traveling
through designs for details.
You can paste between other objects in the
sequence, or ‘nest’ the cut object within another
object.
If your current needle position marker is at the end
of the design, it will be pasted at the end of the
sequence.

4 Click the Paste icon.

2

Travel to the end of
the design

Paste the object

The object is pasted back in the design.

1
3

Note When working with embroidery designs, you
need to understand the stitching sequence. You can
check this by ‘traveling’ through the design
stitch-by-stitch or by slowly redrawing it on screen.
See Viewing stitch sequence for details.

Sequencing by cut-and-paste
Click General > Cut to cut a selected object or
objects and place them on the clipboard.
Click General > Paste to paste copied objects in the
design.
You can resequence objects by cutting an object from
the design and pasting it back at a different point in
the sequence. This does not change the physical
location of the object.
To sequence objects by cut-and-paste

Note The object remains on the clipboard and can
be pasted repeatedly until the next Copy or Cut
command.

Sequencing with Color Film

o

Click General > Color Film to open the Color Film.
Resequence by dragging and dropping objects in the
list.
Click Color Film > Show Objects to view individual
objects in order of stitching sequence. Drag and drop
object icons to resequence.

Designs are made up of individual embroidery
‘objects’ grouped by ‘color block’. These are listed in
stitch order in the Color Film. Use it to optimize your
design by resequencing selected color or objects.
Generally, you aim to keep objects of the same color
together in order to minimize color changes, trims,
and frame movements. Fills are always stitched first,
details, including borders or small areas, last.

1 Select the object(s) to resequence.
2 Click the Cut icon.
The selected object is removed from the design
and moved to the clipboard.

Note There are instances where colors have to be
split, particularly where the same color is used for fills
and details.
To sequence with Color Film
 Click the Color Film icon on the General toolbar.

Wrong sequence

Select and cut object
to be changed
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The Color Film dialog opens displaying all color
blocks in the design in order of stitching sequence.

View all color blocks
and/or objects in the
design

 Drag and drop color blocks to change their position
in the stitching sequence.
The Color Film is synchronized with the design
window and vice versa. It dynamically updates
whenever you select, modify or delete objects, or
create new ones.

All objects within each color block are displayed in
their stitching order.

Click Show Objects
to toggle individual
objects

 Use the list to drag and drop object icons and
resequence as required.
 To select a range, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you
click.
 Right-click any object in the list to invoke the
popup menu. Use it to cut, copy, paste, or delete
objects as required. See Sequencing by
cut-and-paste for details.

Drag & drop to
change position in
stitching sequence

Right-click to invoke
popup menu
options

 Click the Show Objects toggle to view individual
objects.
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 Use the Sequence command buttons to reposition
selected color blocks or individual objects in the
stitching sequence.

To auto-sequence an entire design

1 Open or create a design.

6 color
changes

Sequence selected
objects via the toolbar
or Arrange menu

2 Select Design > Optimize Color Changes.
Alternatively, click the icon on the Color Film. The
system analyzes all selected objects and calculates
optimal hoopings, color changes and trims.

Auto-sequencing entire designs

o

Click General > Color Film to open the Color Film.
Resequence by dragging and dropping objects in the
list.
Select Color Film > Optimize Color Changes to
resequence objects by color.

The Optimize Color Changes feature improves the
quality and efficiency of the stitchout by minimizing
the number of hoopings, color changes, and trims. All
existing overlaps are preserved by the operation. The
system analyzes the design and calculates:

Note If your design does not fit in the current
hoop, you will be alerted that there are uncovered
objects. You can fix this by selecting a larger hoop
or adding more hoopings. See Creating multiple
hoopings for details.

3 Confirm whether you want to proceed.

 hoopings (if there are more than one)
 color changes (the total number in the current
design window), and
 uncovered objects (if any) – i.e. any stitched
objects not covered within a hooping.

4 color
changes

Grouped objects are not ungrouped by the operation,
but differently colored objects are optimally
sequenced regardless of grouping. Monogramming
and open-object appliqué, however, are treated as
single objects. In other words, they are not internally
resequenced unless you break them up with the
Break Apart command. See also Splitting into
component objects.
Note The Undo command will reverse the effect
of any sequencing changes.
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Sequencing by color

3 Optionally, select a color and click Move Up or Move

You can resequence objects by color in order to
reduce the number of color changes in a design. See
also Sequencing with Color Film.

4 Click OK. Colors are resequenced to stitch out as

Down to change its position in the sequence.
separate color blocks.

To sequence objects by color

1 Select all objects in the design. In the sample
below, each design repeat is color sequenced
separately.

Sequencing objects by selection order
Click General > Color Film to open the Color Film.
Resequence by dragging and dropping objects in the
list.

2 Select Arrange > Sequence by Color.

Use Color Film > Sequence by Selects to
resequence objects in the order selected.
You can resequence objects by selecting them in the
required stitching order.
To sequence objects by selection order

1 Select the first object in the range you want to
resequence.

Sequence objects
by color

The Sequence by Color dialog opens listing the
colors used in the selection.
Select first object
in stitching order
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2 Holding down Ctrl, select each object or color
block in order of stitchout.

Select objects in
order of stitchout

3 With the objects still selected, select Sequence
by Selects from the Color Film toolbar.
Alternatively, select Arrange > Sequence by
Selects.
The objects are resequenced in the order they
were selected right after the first selected object.

Objects
resequenced in
selection order
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CHAPTER 17
DESIGN LAYOUTS
BERNINA Embroidery Software allows you to
arrange and transform objects by a variety of
means, both interactive and numeric. Position
objects by means of click and drag, arrow keys
or object properties. Align objects relative to
each other using the special tools available.
Scale objects directly on-screen or by setting
exact dimensions or scale percentages. Rotate,
skew and mirror objects by similar means.
Special tools allow you to duplicate and
transform selected embroidery objects, as well
as create mirrored and rotated objects around a
central axis. Layout tools allow you to arrange
multiple embroidery designs on an item or fabric
to be sewn.
There are also tools which allow you to quickly and easily create preset quilting
and buttonhole layouts.
This section describes how to position and align objects by both interactive and
numeric methods. It also covers scaling, rotating and skewing objects. A variety
of methods for mirroring objects are also described. Special layout tools are also
discussed.

Arranging objects
Position objects in your design using the mouse to
drag them to a new position, nudging them with the
arrow keys or by specifying the X:Y coordinates in the
Property bar. Alternatively, BERNINA Embroidery
Software provides tools to help you align objects
relative to each other, or distribute them evenly in
your design.

To position objects
 Select the objects to move and click-and-drag to a
new position. See Selecting Objects for details.

Use cross-hair cursor
to center object

Positioning objects
The simplest way to move an object in your design is
to click-and-drag it to a new position. Use the arrow
keys to ‘nudge’ objects into position.

Tip If no objects are selected, using the arrow keys
moves the current needle position.

 For more accurate positioning, use the arrow keys
to ‘nudge’ an object into position.
 For even more accurate positioning, enter X:Y
coordinates in the Transform toolbar.
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The object is centered around the coordinates you
set.

3 Click one of the alignment icons on the Arrange
toolset.

1

3
Check position of
selection

2
Align Centers

Tip Zoom in to make small adjustments. The
distance the object moves depends on the current
zoom factor. The greater the zoom factor, the
smaller the distance moved.

Aligning objects
Use Transform > Select Object to select an object.

Align Bottom

Align Left

Distributing objects

Click Arrange > Align Left to left-align selected
objects.

Click Arrange > Space Evenly Across to evenly
distribute three or more selected objects horizontally.

Click Arrange > Align Centers Vertically to vertically
align centers of selected objects.

Click Arrange > Space Evenly Down to evenly
distribute three or more selected objects vertically.

Click Arrange > Align Right to right-align selected
objects.
Click Arrange > Align Top to align selected objects
along their top sides.
Click Arrange > Align Centers Horizontally to
horizontally align centers of selected objects.
Click Arrange > Align Bottom to align bottoms of
selected objects.
Click Arrange > Align Centers to align centers of
selected objects.

You can automatically distribute selected objects with
even spacing between them, both vertically or
horizontally.
To distribute objects

1 Select the objects you want to space. See
Selecting Objects for details.

2 Click a spacing tool or select Arrange > Space
Evenly > ...

BERNINA Embroidery Software provides tools to
precisely align objects relative to each other. You can
align to the left, right, top, bottom or center of a
‘reference object’.
To align objects

1 Select the objects you want to align.
2 Select the object you want to align with.
Note Objects are aligned with the last object
selected. When we select all the objects in the
design by using Ctrl+A or a selection marquee all
the objects are aligned with the last object in the
sequence.

Scaling objects
You can scale objects directly on-screen or by setting
exact dimensions or scale percentage. As an object is
scaled, the stitch count changes to preserve current
stitch spacing.

Note The scalability and stitching quality of a design
ultimately depends on its original source – ART Grade
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A, ART Grade B, ART Grade C, or ART Grade D. Only
native ART Grade A designs contain the complete set
of design information required for 100% perfect
scaling and transformation. See Supported machine
file formats for details.

 To scale height and width proportionally, use a
corner handle.

Checking dimensions
When doing any sizing work, you need to be aware of
current dimensions. Typically, you will be scaling an
entire design for different applications. For example,
if you are stitching a left chest design, maximum size
will be approximately 4.25" or 108 mm square.
Caution If you scale a machine or ‘stitch’ file by more
than 5%, changes to stitch density will affect the
design quality. See Supported machine file formats
for details.
To check dimensions

Drag

Shift+drag

Scale proportionally

Scale proportionally
about center

Tip Use the tooltip as a guide to object scale.
 To scale freely in vertical and horizontal planes,
hold down Ctrl as you drag.
 To change the height, use the handles at the
center-top or center-bottom.
Drag

1 Turn on the grid and/or ruler as required. See
Displaying rulers & guides for details.

2 Select the design or object/s to scale. See
Selecting objects by point & click for details.

3 Check design dimensions in the Status Bar. See

Scale vertically
Drag

Status bar for details.

4 Check dimensions of the selection in the
Transform toolbar. See also Measuring distances
onscreen.

 To change the width, use the handles at the
center-sides.

Drag
Drag
Check dimensions of
selection

Scale horizontally

 To resize around a center anchor, hold down Shift
while you resize.
Shift+drag

5 Set the required measuring units. See Setting
measurement units for details.

Scaling by click & drag
Change height and width of an object or entire design.
Scale objects individually, or select multiple objects
and scale them together. Scale proportionally using
the selection handles.
To scale by click & drag
 Select the design or object/s to scale. See also
Checking dimensions.
 Click and drag selection handles to resize.

Scale
vertically in
both directions
Shift+drag

Scale horizontally in
both directions

Scaling by properties
Click Transform > Size +20% to increase size of
selected object/s in 20% increments.
Click Transform > Size -20% to reduce size of
selected object/s in 20% increments.
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You can scale the height and width of selected objects
or a whole design using object properties.

When you select an object, selection handles display
at its extremities. When you click the object again,
the handles change to rotation handles.
To rotate objects
 Select the design or object/s to rotate.
Skew handle
Rotation handle
Anchor point

To scale by properties
 Select the design or object/s to scale. See also
Checking dimensions.
 For quick scaling, use the Size +20%/-20%
icons.
 For more precise scaling, adjust dimensions of
selection in the Transform toolbar and press
Enter. See also Measuring distances onscreen.

First click displays
selection handles

Second click displays
rotation handles

 Click the object/s a second time. Rotation handles
appear at the corners and an anchor point at the
center of the object.
 If required, drag the rotation anchor from the
center to a new position.
 Click a rotation handle, and drag it clockwise or
counter-clockwise. An outline and cross-hairs
display as you rotate.

Scale by a
percentage factor

Set width
and/or height

Lock/unlock
aspect ratio

 Optionally, you can specify measurement units
on-the-fly. See also Specifying measurement units
on-the-fly.

Drag a corner to
rotate about the
anchor point

Drag the anchor
point

Drag a corner to
rotate about the
anchor point

 Alternatively, click Rotate Right / Left on the
toolbar.

 Use the Aspect Ratio toggle to decouple width
and height settings.
 Press Apply.

Transforming objects
You can rotate or skew objects directly on-screen or
by setting a precise angle.

Rotating objects
Click Transform > Rotate Right to Rotate selected
objects in 45° increments to right.
Click Transform > Rotate Left to rotate selected
objects in 45° increments to left.
Rotate selected objects by specified amount –
positive or negative – in degrees.

 Alternatively, use the Rotate By field on the
Transform toolbar to enter an exact rotation
angle – plus or minus – and press Enter.

Skewing objects
Skew selected objects by specified amount –
positive or negative – in degrees.
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You can skew objects directly on-screen or by setting
an exact skew angle.

embroidery objects, as well as create mirrored and
rotated objects around a central axis.

To skew objects
 Select the design or object/s to skew.
Skew handle
Rotation handle
Anchor point

First click displays
selection handles

Second click displays
rotation handles

 Click a second time.
Rotation handles appear at the corners and skew
handles at center-top and bottom of the object.
 Drag skew handles left or right.

Mirroring objects
Click Transform > Mirror X to flip selected object/s in
horizontal planes.
Click Transform > Mirror Y to flip selected object/s in
vertical planes.

Drag skew handle
left or right

 Alternatively, use the Skew field on the
Transform toolbar to enter an exact skew angle –
plus or minus – and press Enter.

You can mirror selected objects horizontally or
vertically using Mirror X or Mirror Y.
To mirror horizontally or vertically

1 Select the object/s to mirror.
Original
object

Mirror X

Mirror Y

Mirror X and Y

Mirroring objects
You can mirror objects horizontally or vertically using
the mirroring tools or via object properties. Special
tools allow you to duplicate and transform selected

2 Click the Mirror X icon to flip horizontally or
Mirror Y to flip vertically.

Mirror-merging objects
Use Mirror-Merge > Mirror-Merge Horizontal to
duplicate & mirror horizontally and merge
overlapping objects (optional).
Use Mirror-Merge > Mirror-Merge Vertical to
duplicate & mirror vertically and merge overlapping
objects (optional).
Use Mirror-Merge > Mirror-Merge Horizontal/Vertical
to duplicate & mirror objects around a center point.
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The Mirror-Merge tools allow you to duplicate and
transform selected embroidery objects in vertical and
horizontal planes. Colors can be automatically
resequenced during the mirror-merge operation.
Optionally, overlapping objects can be merged in to a
single object.

 If the selection is ungrouped, mirrored objects
are resequenced into consecutive color blocks.

Objects resequenced
into consecutive color
blocks

To mirror-merge objects

1 Open or create the design you want to mirror.
2 Before mirror-merging a selection, you need to
decide whether color blocks should be merged:
 If you want selected objects to sew out in
separate hoopings, make sure they are
grouped first.
 Alternatively, leave them ungrouped and they
will be color-optimized for a single stitchout –
i.e. color-block by color-block.

3 Select the object/s.

 If the selection is grouped, mirrored objects are
also grouped for separate stitchout.

Each selection
grouped and stitched
separately

4 Select a Mirror-Merge tool – horizontal, vertical,
or both. The technique is essentially the same.

 If a mirrored object overlaps the original in an
ungrouped selection, you are prompted to
merge objects.

5 Move the reference line to position mirrored
objects.

Overlapping objects
merged

6 Click to place the mirror image.
Note Sometimes you may be working with
designs that are too large to accommodate within
a normal hoop. With the Multi-Hooping toolset,
you can place multiple hoopings around an entire
work area. See Creating multiple hoopings for
details.
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Creating design arrays
Use Mirror-Merge > Array to duplicate designs, such
as badges, re-sequencing color blocks for efficient
multiple design stitchouts.

Creating decorative borders
Use Mirror-Merge > Reflect to duplicate and mirror
designs for decorative borders.

Use the Array tool to create multiple copies of
designs, such as badges, spaced in rows and columns
for easier stitchout. Color blocks are resequenced to
minimize color changes.

The Reflect tool is similar to the Array tool. However,
because it also mirrors duplicate selections, it is
particularly useful for decorative borders. As with
other Mirror-Merge tools, color blocks are
resequenced to minimize color changes.

To create design arrays

To create a decorative border

1 Since you will probably be using this tool to create

1 Since you will probably be using this tool to create

multiple copies of the same design, leave the
selection ungrouped. This way, all copies will be
color-optimized for a single stitchout.

2 Select the object/s and click Array.

a decorative border, leave the selection
ungrouped. This way, all copies will be
color-optimized for a single stitchout.

2 Select the object/s to copy and click Reflect.

3 Set the number of rows and columns.
4 Move the reference line to position duplicates.
5 Click to confirm or press Enter.

3 Optionally, set the number of rows and columns.
Or if you are creating a decorative border, leave
the setting at the default 2 x 2.

4 Move the reference line to position duplicates.
5 Click to mark the anchor point or press Enter to
confirm.

Objects resequenced into
consecutive color blocks

Objects resequenced
into consecutive color
blocks

Tip Use Array and Reflect with column and row
repeats to automatically generate continuous
embroidery designs. See also Manual continuous
embroidery.
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6 Use the Color Film to further resequence colors if

2 Select the object/s to copy and click Wreath.

you are combining your border with other
elements.
Tip Use Array and Reflect with column and row
repeats to automatically generate continuous
embroidery designs. See also Manual continuous
embroidery.

Select number of
copies

Creating wreaths
Use Mirror-Merge > Wreath to duplicate objects
around a central axis. Specify duplicates in
Mirror-Merge Settings bar.
Use Mirror-Merge > Mirror Alternate to mirror
alternate pairs. Only enabled when copies are set to
an even number.
The Wreath tool duplicates objects around a central
axis. The Mirror Alternate toggle works with
Wreath to create mirrored pairs.

3 Set the number of copies. Enter an even number
to activate the Mirror Alternate toggle.

4 Move the reference point to the wreath center.
Hold down Ctrl to constrain the line to 45° angles.

Move pointer to set
center point
Mirrored pairs around
a central axis

Tip Use the Wreath tool with fonts and numbers to
create fun designs.
To create a wreath

1 As with all Mirror-Merge functions, decide
whether to group the selection beforehand. Leave
them ungrouped if you want them color-optimized
for a single stitchout.
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5 Click to confirm. Duplicates are generated. Check
the object sequence in the Color Film.

without a central design element. See also Creating
quilt block layouts.

Overall process
The overall process is as follows:

Creating design layouts
The Layout toolset allows you to arrange multiple
embroidery designs or design elements on a fabric,
garment, or item such as tablecloth. Design layouts
are not restricted to the hoop area. Large work areas
– up to 3m x 3m or 10' x 10' – can be defined and
designs arranged within a single layout. There is no
limit to the number of hoopings possible for a large
layout.

 Create or open a design or element that fits within
one hooping.
 Define a work area – rectangular or circular.
 Lay out copies of the design, automatically placed
and orientated, around the work area.
 Define multiple hoopings for the design layout.
 Split the layout into separate machine files.
 Include reference marks for positioning.
You can also print layouts with hoop position markers
for use with a hoop template. Use them to physically
lay out the design on the item you want to embroider.
You can also print the template which can be used to
position each of the hooped portions of the design.
See Printing designs for details.

Note Work area has no bearing on hoop size. With
the Multi-Hooping toolset, you can place multiple
hoopings around an entire work area. See Creating
multiple hoopings for details.

Defining work areas
Use View > Show Work Area to show or hide a work
area defined under Layout.
Use Layout > Define Work Area to define a
rectangular or circular work area of a specified size.
Using Layout tools, it’s also a simple matter to define
a quilt block and display it as a work area. You can
then arrange elements around the block, with or

Before you can create a design layout, you first need
to define a work area corresponding to the item or
fabric you intend to embroider. Work areas may be
rectangular or circular. The software lets you define a
work area up to 3m x 3m (10' x 10').
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tools listed above are the ones you will need for
rectangular layouts.

To define a work area
 Set the measurement system via a droplist on the
General toolbar. See Setting measurement units
for details.
 Select Define Work Area to set a new work area.

Define rectangular or
circular work area

Define work
area color

 Specify a work area shape, size, and color.
 Use the lock to maintain width and height
proportions in rectangular layouts.
 The color is just for on-screen viewing. It has
no effect on design output.
 Click OK to confirm. If the checkbox is activated in
the dialog, the work area will display by default.
Otherwise, use the Show Work Area toggle.

To create a rectangular layout
 Define your work area according to its application
– e.g. as a layout for a tablecloth. See Defining
work areas for details.
 Insert a design and/or select a design/s or object/s
already on-screen. See Inserting designs for
details.
 Resize as necessary. Optionally, use the Auto
Center to Work Area tool to move selected
object/s to the center of the work area. Press
Enter to confirm.
 Insert further objects as needed. Move to the
desired position in the work area. Use arrow keys
to nudge into position.

Creating rectangular layouts
Use General > Insert Embroidery to import
embroidery design files into the current design.
Use Layout > Auto Center to Work Area to
automatically move selected object/s to the center of
the work area.

Objects grouped for
separate stitchout

 Before you copy the design to the work area, you
need to decide whether to merge color blocks:

Use Layout > Layout to Rectangular Work Area to
create copies of selected object/s in each corner of
the work area.

 If you want the selected objects to sew out in
separate hoopings, make sure they are
grouped before proceeding.

Use Context > Work Area Margin to specify a margin
(in mm) between edge of work area and duplicates.

 Alternatively, leave the objects ungrouped, and
they will be color-optimized for a single
stitchout – i.e. color-block by color-block.

Create large embroidery layouts using Layout tools
together with selected design/s and/or object/s. The
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 Click Lay out to Rectangular Work Area.
Wireframe copies are mirrored about vertical and
horizontal axes.

Tip When used in conjunction with the
Multi-Hooping toolset, you can place multiple
hoops around a single design. See Creating
multiple hoopings for details.

Creating circular layouts
Use General > Insert Embroidery to import
embroidery design files into the current design.
Use Layout > Auto Center to Work Area to
automatically move selected object/s to the center of
the work area.
Use Layout > Layout around Circular Work Area to
create copies (specified by number of repeats) of
selected object/s around a circular work area.
 Use the Work Area Margin control on the
Context toolbar to specify a margin (in mm)
between the edge of the work area and the
duplicates.
 Press Esc to cancel or Enter to confirm.

Use Context > Number of Copies to specify the
number of copies, including the selection. Select an
even number to activate Mirror Alternate.
Use Context > Mirror Alternate to mirror alternating
copies to form symmetrical pairs for a kaleidoscope
look. Set Number of Copies to an even number.
Use Context > Work Area Margin to specify a margin
(in mm) between the edge of work area and designs.
Create large embroidery layouts using Layout tools
together with selected design/s and/or object/s. The
tools listed above are the ones you will need for
circular layouts.

 Check the design layout in the Color Film.
Manually resequence colors where necessary. See
Sequencing embroidery objects for details.

To create a circular layout
 Define your work area according to its application
– e.g. as a layout for a tablecloth. See Defining
work areas for details.
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 Insert a design and/or select a design/s or object/s
already on-screen. See Inserting designs for
details.

 Click Lay out to Circular Work Area. Wireframe
copies are mirrored about vertical and horizontal
axes.

 Resize as necessary. Optionally, use the Auto
Center to Work Area tool to move selected
object/s to the center of the work area. Press
Enter to confirm.

 Use the Context toolbar to control the duplicates:

 Insert further objects as needed. Move to the
desired position in the work area. Use arrow keys
to nudge into position.

 Set the number of copies to make.
 If you are creating an even number of
duplicates, use Mirror Alternate to mirror
alternating copies as preferred.
 Use Work Area Margin to specify a margin (in
mm) between the edge of the work area and
the duplicates.
 Press Esc to cancel or Enter to confirm.
 Check the design layout in the Color Film.
Manually resequence colors where necessary. See
Sequencing embroidery objects for details.

Objects grouped for
separate stitchout

 Before you copy the design to the work area, you
need to decide whether to merge color blocks:
 If you want the selected objects to sew out in
separate hoopings, make sure they are
grouped before proceeding.
 Alternatively, leave the objects ungrouped, and
they will be color-optimized for a single
stitchout – i.e. color-block by color-block.

Tip When used in conjunction with the
Multi-Hooping toolset, you can place multiple
hoops around a single design. See Creating
multiple hoopings for details.
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Creating buttonholes
BERNINA Embroidery Software allows you to insert
preset buttonholes. You can specify their size and
merge them into a design. Buttonholes are usually
formed with satin column stitches bordering a slit that
is approximately the length of the button diameter.
The satin stitch border protects the slit from fraying.
The buttonhole consists of a bead of satin stitches
with a bar tack.

The Object Properties > Buttonhole tab opens.

Select
buttonhole
type

Bar tack top

3 Select a buttonhole type and preset stitch values
Bead

Buttonhole

as preferred.
Adjust
buttonhole
values

Bar tack end

 Adjust Slit length according the button size
you intend to use.
Slit length:
20mm

Slit length:
10mm

Adding buttonholes
Slit length:
15mm

Use Digitize > Buttonhole to digitize a single
buttonhole with all necessary stitching.
Use Cutwork > Cut Buttonhole Slit to generate a
cutting line for selected buttonholes.

 Adjust buttonhole density with the Bead stitch
spacing field.

Add buttonholes to a design.

Bead Stitch
Spacing: 0.3mm

To add buttonholes

1 Open or create a design requiring buttonholes.

Bead Stitch
Spacing: 0.4mm

Bead Stitch
Spacing: 1.0mm

4 Select the Buttonhole tool.
A buttonhole outline appears attached to the
mouse pointer.

2 Right-click the Buttonhole tool.

5 Click to place the buttonhole.
6 Repeat to add more buttonholes.
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7 Press Esc to finish.

3 Enter the number of the buttonholes your design

8 Optionally, use the Cut Buttonhole Slit tool
under the Cutwork toolbox to generate a cutting
line for selected buttonholes.

requires and click OK.

4 Click to place the first buttonhole and drag a line –
horizontal or vertical – to the last buttonhole
position.

Cutting line added

Measure tooltip

Tip If a buttonhole has been placed over other
objects, some of the underlying stitches could
unravel after the slit has been cut. To prevent this,
objects under the buttonhole can be reshaped so
that their boundaries line up along buttonhole slit.
See Reshaping & Editing Objects for details.

Creating a line of buttonholes
Use Digitize > Buttonholes to digitize a line of
buttonholes with all necessary stitching.

Drag buttonhole
line

5 Use the measure tooltip as a guide and click to
complete.
Buttonholes are generated according to current
settings in the Object Properties dialog.

6 Optionally, use the Cut Buttonhole Slit tool
under the Cutwork toolbox to generate a cutting
line for selected buttonholes.

Use Cutwork > Cut Buttonhole Slit to generate a
cutting line for selected buttonholes.
Add a line of evenly spaced buttonholes to a design
with the Add Buttonholes command.

Cutting lines
generated

Adjusting buttonholes

To create a line of buttonholes

1 Open or create a design requiring buttonholes.
2 Select the Buttonholes tool.
The Buttonholes Settings dialog opens.

Use General > Object Properties to change
buttonhole types.
Buttonhole types can be changed at any time. They
are simply properties of a buttonhole object. Other
properties include ‘slit length’ as well as stitch
spacings.

Enter number of
buttonholes required
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To adjust buttonholes
 Select the buttonholes to adjust and right-click.

 Select Object tool to rotate one or more
buttonholes together. See also Rotating
objects.

Multiple
buttonholes
rotated

 Reshape Object tool to rotate single
buttonholes. See Reshaping objects for details.

 Select Object Properties. The Buttonhole tab
opens.
 Change buttonhole type as preferred.

Buttonhole
rotated and
resized

 Rotate 45° CCW/CW tool to rotate one or
more buttonholes. See also Rotating objects.
 Mirror Y and Mirror X tools. See also Mirroring
objects.

Select
buttonhole type

 Adjust slit length and bead density as necessary.
Adjust
buttonhole
values

 Adjust orientation with the Angle settings.

 Any of the following techniques will also work:
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CHAPTER 18
RESHAPING & EDITING OBJECTS
BERNINA Embroidery Software lets you modify object
shapes, stitch angles and entry and exit points by
means of reshape nodes. The Reshape Object tool is
one of the most frequently used.
BERNINA Embroidery Software also allows you to cut
filled objects into smaller fragments. This is important
where changes in stitch direction are necessary.
Sometimes, you may need to remove underlying
layers of stitching. This helps to reduce the stitch
count and prevent a build-up of stitches where they
are not needed.
BERNINA Embroidery Software also provides special
tools for cutting holes in objects as well as filling holes
in objects. You can also easily generate new outlines
and offset objects based on existing objects.
This section describes how to reshape objects with reshape nodes. It also covers
adjusting stitch angles – including multiple stitch angles – as well as changing
entry and exit points. It also discusses cutting objects and removing underlying
stitching, as well as adding holes to existing objects, filling holes, and generating
outlines.

Reshaping objects

Reshape nodes can be selected individually or
together, for repositioning or modification.

In BERNINA Embroidery Software you reshape
objects by selecting them with the Reshape Object
tool and moving, adding or deleting reshape nodes on
the outline. With some objects, you can also change
reshape nodes from corner points to curves.
Reshaping operations do not affect stitch angles.

To reshape nodes
 Select an object and click the Reshape Object
icon.
Reshape nodes appear around the object.
Exit point
Curve reshape
node

Tip Before modifying any design, a good practice is
to save a copy under a new name and keep the
original in case you want to discard your changes and
start again.

Selecting reshape nodes
Click Transform > Reshape Object to view the
reshape nodes of a selected object.

Corner reshape
node

Entry point
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 Click to select a single reshape node.

 Right-click to add a curve point.

Right-click

 Holding down Ctrl, click to select multiple reshape
nodes.
Left-click

 Holding down Shift key, click to select a range of
reshape nodes.

4 Select reshape nodes as required. See Selecting
reshape nodes for details.

5 Adjust the position of selected reshape nodes by
Tip Left-clicking or right-clicking in closed shapes
reverses the direction of the selection.

dragging them along the outline as required and
press Enter.

 Click and drag a selection marquee around a group
of reshape nodes to select.
Drag and press
Enter

Reshaping objects using reshape nodes
Click Transform > Reshape Object to reshape
selected objects.
Change object shapes with the Reshape Object tool.
Use it to add, delete, or move reshape nodes on the
object outline. For some objects, you can also change
between corner and curve points.

Tip Use the arrow keys to ‘nudge’ selected
reshape nodes.

6 Press Delete to delete unwanted reshape nodes
and press Enter.

To reshape objects using reshape nodes

1 Select the object to reshape.
2 Click the Reshape Object icon.

Select, delete
and press Enter

Reshape nodes appear around the object.

3 To add extra reshape nodes on the outline:
 Left-click to add a corner point.

7 Press Spacebar to toggle between selected corner
and curve reshape nodes and press Enter.
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Tip If you make a mistake, press Esc to remove
the changes, press Esc again to exit Reshape
Object tool.

For objects created with the Circle tool, you reshape
using the existing reshape nodes only. You cannot
add, change or delete reshape nodes in these objects.
You can change Circle objects from circles to ovals
using the Reshape Object tool. Circle objects have
two reshape nodes (used to change the radius and
orientation of the object), a center point (used to
reposition it), and a stitch entry point.

Select, press
spacebar and
press Enter

Reshape node
Stitch angle
90°
Entry
point

Note You can also adjust stitch angles as
required, as well as change entry and exit points.
See Modifying stitch angles and Adjusting entry &
exit points for details.

Center point
Reshape node

To reshape circle objects

1 Select a Circle object and click the Reshape
Object icon.
Reshape nodes appear around the object.

8 Press Esc to finish.

2 To move a circle, click the reshape node in the

Reshaping next or previous objects

3 Click a reshape node on the circumference of the

circle’s center, and drag it to a new position.

When editing an object in Reshape mode, use the
Tab key to quickly jump between objects. See also
Deselecting & deleting objects.

circle, and drag it to reshape the outline.
 To reshape without changing the orientation,
use the reshape node at the top of the object.

To reshape next or previous objects
 Press the Tab key to accept all changes to an
object and jump to the next object in the stitching
sequence.

Shift + Tab

Tab

 To reshape and spin the object around its
center point, use the reshape node at the side.

 Pressing Shift + Tab causes all changes to the
object to be accepted and the previous object in
the stitching sequence to be selected for
reshaping.

Reshaping circle objects

4 Press Enter to apply the changes, then Esc to
finish.

Click Transform > Reshape Object to reshape circle
objects.
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The Smooth Curves dialog opens.
Tip To scale a circle without changing it to an oval,
select it with the Select Object tool, and use the
corner selection handles to scale it.

Scale using corner
selection handles

4 In the Precision field, enter the smoothing
precision value.
This value controls how closely the smoothed
outline follows the original. The larger the
precision value, the fewer the reshape nodes.

5 Click OK.

Smoothing curves

Minimize reshape nodes
for smoother curves

Click Transform > Reshape Object in combination
with Edit > Smooth Curves to remove unnecessary
reshape nodes from embroidery objects.
Like vector objects, embroidery objects contain
reshape nodes on their outlines. On shapes where the
angle changes constantly, the software may insert
hundreds of reshape nodes, making reshaping
difficult. The Smooth Curves command lets you
apply curve ‘smoothing’ to embroidery objects.
To smooth curves

1 Select the object (or objects) to smooth.
Excessive
reshape nodes

Modifying stitch angles
Stitch angle adjustments depend on the type of object
you are working with. With filled objects you can set
a stitch angle for the entire object. Alternatively, you
can add multiple stitch angles with the Add Stitch
Angles tool. You can also adjust the stitch angle
using the Reshape Object tool.

Note You can change the stitch angle of Circle
objects by moving the stitch entry point.

Setting nominal stitch angles
Note You can only smooth objects that have been
ungrouped and selected. However, you can select
multiple objects.

2 Click the Reshape Object icon.
Reshape nodes display around the outline.

Use Edit > Add Stitch Angles to add stitch angles to
closed objects with or without holes. Right-click for
settings.
Use Edit > Remove Stitch Angles to remove stitch
angles from closed objects with turning stitches.

3 Select Edit > Smooth Curves.
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You can change the nominal stitch angles of filled
objects using object properties.

5 In the Angle field, enter the required stitch angle.

Nominal angle: 0°

Note Whenever Remove Stitch Angles is applied
to selected objects with turning stitch angles, the
resultant object takes a single, nominal stitch angle.
To set the nominal stitch angle

1 Select an closed object with or without turning
stitches.

Nominal angle: 90°

6 Click Apply.

Adding and removing stitch angles
Use Edit > Add Stitch Angles to add stitch angles to
closed objects with or without holes. Right-click for
settings.
Use Edit > Remove Stitch Angles to remove stitch
angles from closed objects with turning stitches.
The stitch angles of filled objects are all modified in
the same way. Multiple stitch angles can be added or
subtracted with the Stitch Angles tools.

Object with
turning stitch
angles

2 If necessary, click the Remove Stitch Angles tool
to return it to the current nominal stitch angle.

Single stitch angle

Multiple stitch angles

In BERNINA Embroidery Software, the Add Stitch
Angles tool can be applied to closed objects with:
 turning stitch angles
 a single stitch angle, with or without hole(s).
Nominal
angle: 45°

3 Right-click the Add Stitch Angles icon.
Alternatively, double-click or right-click the object
itself.
The Object Properties dialog opens.

Tip With the Reshape tool, you can add individual
reshape nodes, modifying the shape without
affecting the stitch angles. See Reshaping objects
using reshape nodes for details.
To add or remove stitch angles

1 Select a closed object with or without turning
stitches.

Enter required stitch angle

4 Select the Stitch Angle tab if not already
selected.
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Note If a Stitch Angles tool is applied to an
object with a Star Fill or Wave Fill effect, the
effect is removed.

Tip Use the Reshape Object tool to adjust
reshape nodes as required. See Adjusting stitch
angles for details.

2 If necessary, click the Remove Stitch Angles tool
to return it to the current nominal stitch angle.

3 Click the Add Stitch Angles icon.
You are prompted to enter stitch angles.

Adjusting stitch angles
Click Transform > Reshape Object to adjust the
multiple stitch angles of a selected object.
Tip If you press Enter without entering stitch
angle lines after the Add Stitch Angles tool is
activated, stitch angle line/s are automatically
created. You either press Enter again to accept
the angle lines or Spacebar to discard them so a
single stitch angle is applied.

You can change stitch angles of filled objects using the
Reshape Object tool.

4 Digitize stitch angles – Points 1 and 2 – so that
they intersect two sides of the object. Make sure
that they do not intersect each other.

To adjust stitch angles

1 Select the filled object.
2 Click the Reshape Object icon.
Reshape nodes appear including stitch angle lines.

Caution New stitch lines should not intersect
existing stitch lines or an error message displays.
Press Backspace to delete.

5 Enter as many stitch angles as required to create
a turning fill effect.

6 Press Enter to apply changes, then Esc to finish.
The object is re-stitched with the new angles.

3 Select stitch angle nodes and press Delete to
remove stitch angles.
Tip When you move the mouse pointer over the
stitch angle point, a tooltip displays the stitch
angle of the selected object.

Turning stitch
angles applied
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4 Click and drag lines as required.

Reshape nodes appear, including entry and exit
points.
Exit point

Entry point

Long
travel runs

5 Press Enter to apply the changes, then Esc to
finish.
The object is re-stitched with the new angles.

Note In Circle objects, only the entry point
appears.

3 Select the entry or exit point as required, and drag
it to a different position on the object outline.

4 Press Enter to apply the changes, then Esc to
finish.

Entry point
Exit point

Tip To set a precise stitch angle, use object
properties. See Setting nominal stitch angles for
details.

Adjusting entry & exit points
Click Transform > Reshape Object to adjust the entry
and exit points of a selected object.
The default Closest Join method automatically
calculates the closest join between objects while
digitizing – no need to think about object entry and
exit points. The Settings > Options > General tab
lets you deactivate the setting if so required. When
deactivated, all newly digitized objects are joined by
the As Digitized method. This means you are
prompted to enter entry and exit points as you
digitize. You can change these at any time with the
Reshape Object tool. See also Setting other general
options.
To adjust entry & exit points

1 Select the object.
2 Click the Reshape Object icon.

Note In Circle objects, the stitch angle is
perpendicular to the line connecting the entry
point to the circle center. Thus, changing the stitch
entry point in a Circle object changes its stitch
angle.

Splitting objects
Click Edit > Knife to cut objects along a digitized line,
preserving stitch settings and colors in resulting
objects.
The Knife tool is used to manually cut filled objects
into smaller fragments. This is important where
changes in stitch direction are necessary. Cut objects
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are generated with stitching – parallel or turning –
appropriate to their shape.

preserves the source object’s entry and exit
points.

Source object
separated into two
adjoining objects

The Knife tool has two modes of operation:
 It will only cut selected objects when there is
something in selection.
 It will cut all objects under the knife when there is
nothing selected.
To split shapes manually

1 Select an object for cutting – e.g. letter, closed
object, or line.

Note The Knife tool cuts object outlines and not
the stitches. The system then regenerates the
stitches inside the new shape that is created.

4 Manually adjust object overlaps using the
Reshape Object tool.

2 Select the Knife tool.
The cursor changes to a knife icon. You are
prompted to enter point 1.

Removing underlying stitching
Use Edit > Remove Overlaps to remove unwanted
stitching underlying objects or lettering.

Object needs cutting at
this point to avoid
awkward stitch angles

Use the Remove Overlaps tool to remove underlying
layers of stitching. This helps to reduce the stitch
count and prevent a build-up of stitches where they
are not needed. A cutting overlap is preserved
between ‘cut’ objects and their ‘cutters’ in order to
prevent gaps forming. This can be adjusted for
different fabric types.

3 Digitize a cutting line – left-click for corner points,
right-click for curve points – and press Enter.
By default BERNINA Embroidery Software reorders
fragments into a closest-join sequence that

Valid cutters
Various embroidery objects can be used as cutters if
not too small and with a stitch spacing of 1.00 mm or
less. Examples include:
 Objects with Satin, Step or Fancy Fill fills
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 Satin outlines
 Auto Appliqué objects with Satin cover stitching
 Lettering objects.
‘Cuttable’ objects

Stitching overlaps are removed according to the
current setting. To change the setting, see Setting
overlap removal options.
Overlaps
removed

‘Cuttable’ objects include:
 Filled objects
 Auto Appliqué objects
 Outline objects.
Lettering and Buttonhole objects cannot be cut in
Remove Overlaps operations although they can
both be used as cutters. See also Creating
buttonholes.
Stitches underlying see-through fills are not removed.
These include fills such as Pattern Fill, Blackwork Fill,
Candlewicking Fill, Lacework Fill, Gradient Fill, or
stitches with more than 1.00 mm stitch spacing. Also
any stitches underlying narrow sections of objects are
not removed.
To remove underlying stitching

1 Select one or more ‘cutters’.
Note Multiple cutters can be simultaneously
selected as part of a single cutting operation.

2 Click the Remove Overlaps icon or select
Arrange > Remove Overlaps.

In the example above, note that:
 The sky object has been broken in two.
 The door and path have caused the removal of
stitches in the house and hill objects.
 The tree stem and sky underlying the leaf
object are preserved since Pattern Fill is not a
valid cutter.
 The section of sky where the orange moon
overlaps remains unchanged since the moon is
not selected at the start of the operation.
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Adding & filling holes

4 Press Enter.

BERNINA Embroidery Software provides special tools
for cutting holes in objects as well as filling holes in
objects.

Note To remove boundaries from a closed object,
select it and click Remove Holes.

Filling holes
Adding & removing holes
Use Edit > Add Holes to cut holes in filled objects.
Use Edit > Remove Holes to remove holes from
selected objects.

Use Edit > Fill Holes to fill holes in selected objects
with current stitch type.
The Fill Holes tool fills holes in single closed objects
containing holes. These can be removed altogether or
new objects created.

With BERNINA Embroidery Software you can cut holes
in selected closed objects with a single stitch angle
using the Add Holes tool. It can only be used with
objects created with the Closed Object tool. The
complementary Remove Holes tool allows you to
remove unwanted holes in closed objects.
To add or remove holes

1 Select the object to modify.

To fill holes in objects

1 Select a source object.

2 Click the Add Holes icon.
Reference points display around the object outline.

3 Digitize additional boundaries for the object. Press
Enter after each boundary.

2 Click the Fill Holes icon.
The Fill Holes dialog opens.

Adjust underlap
value as required
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3 Adjust the Underlap value as desired.

designs in any outline stitch. Any closed shape can be
used.

Underlap: -1.00

 To cover holes exactly, accept the default value
of 0.00.
 To overlap the filled holes and the original
object, enter a positive offset – e.g. 1.00.
Overlapping the objects prevents gaps
appearing.
 To leave a gap between the filled holes and the
original object, enter a negative offset – e.g.
-1.00.

4 Click OK.
All newly created objects are filled with the current
fill stitch settings, stitch angle and thread color.
Each new object is an independent object and is
placed immediately after the source object in the
stitch sequence.

To create outlines

1 Select the embroidery object/s or design to
outline.

2 Select the Outlines & Offsets tool.
The Outlines & Offsets dialog opens.

Select object
outlines

Creating outlines & offsets
Use Edit > Outlines & Offsets to create outlines and
offsets of any type for any filled embroidery object.
BERNINA Embroidery Software provides tools for
quickly generating new outlines and offset objects
based on existing objects. Use the Outlines &
Offsets tool to highlight details – e.g. small satin
objects – or create seamless borders. Auto-outline

3 Tick Object Outlines and choose an outline type.
The Type droplist includes the full range – Single
Run, Triple Run, etc.

4 Choose your outline color. The Color droplist
defaults to the current color in the color palette.
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5 Choose an option for handling overlapping objects: 5 Choose an option for handling multiple objects:
Outline type

Notes

Offset type

Notes

Individual

All generated outlines are full
outlines.

Individual All generated offsets are full outlines.

Common

Intersecting outlines are combined
into a single outline.

Common

Trimmed

Overlapped portions are trimmed by
overlapping objects.

6 Click OK to apply. The software generates an
outline around the source object/s and inserts
them immediately afterwards in the stitching
sequence.

Intersecting offsets are combined into
a single outline.

6 Choose an option for handling sharp corners:
Corner type

Notes

Round

Sharp corners are always rounded.

Sharp

Sharp corners are preserved.

Cut

Any acute angle greater than 89° is cut.

7 Click OK to apply. The software generates offset
objects and adds them to the end of the stitching
sequence.

Note Generated outlines are independent objects
and can be further modified as desired. Change
colors, stitch types, and settings as desired.

8 Optionally, use common outlines for all selected
objects. Combine offsets with outlines as
preferred.
To create offsets

1 Select the source object/s if not already selected.
2 Tick Offset Outlines.
Select offset
outlines

3 Select an outline color and stitch type.
4 In the Offset Count field, enter the number of
offsets required and an offset amount.
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CHAPTER 19
EDITING STITCHES
With BERNINA Embroidery Software
designs, stitches are automatically
generated from design outlines and
properties. This means you can scale,
transform and reshape designs without
affecting stitch density or quality.
However, BERNINA Embroidery
Software also lets you edit individual
stitches. You simply select and
manipulate them like any other object.
For example, you can insert stitches in
an object to fill gaps, or move and
delete individual or clusters of selected stitches. You may need to do this, for
example, when working with ‘machine files’ which do not contain design outline
data. Where possible, however, edit the object properties rather than individual
stitches. See also Embroidery design formats.
This section deals with selecting and editing stitches.

Selecting stitches
The Stitch Edit feature lets you select single stitches,
several stitches, or a range of stitches by selecting
their needle points, or dragging a selection marquee
around them. Selected stitches are highlighted in a
different color.

The needle point and stitch colors change and the
needle position marker moves to the selected
stitch. All stitches after the needle position marker
in the stitching sequence appear in black.
Selected stitch

Hold down Shift to select a
range of stitches

Selecting stitches by needle point
Click Edit > Stitch Edit to place stitch cursor at a
selected insertion point.
You can select individual stitches in Stitch Edit mode
by selecting their needle points.
To select stitches by needle point

 To select a range, hold down Shift as you click.

1 Select Edit > Stitch Edit. Alternatively press E.

 To select multiple items, hold down Ctrl as you
click.

Tip Zoom in and display the needle points for
easier selection. See Zooming in & out and Viewing
embroidery elements.

2 Click a needle point.

Selecting stitches with a selection marquee
Click Edit > Stitch Edit to place stitch cursor at a
selected insertion point.
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You can quickly select all stitches in a group by
dragging a selection marquee around them.

stitch. All stitches after the needle position marker
in the stitching sequence appear in black.

3 Move the mouse pointer where you want to insert
To select stitches with a selection marquee

1 Select Edit > Stitch Edit. Alternatively press E.

the new stitch, and right-click.
Right-click to insert new stitch

Tip Zoom in and display the needle points for
easier selection. See Zooming in & out and Viewing
embroidery elements.

2 Drag a selection marquee around the stitches you

New stitch
inserted and
selected

want to select.
Stitches are selected when you release the mouse
button.

4 Move the mouse to where you want to insert the
next stitch, and right-click.

Right-click to insert new stitch
Selection marquee

Stitches selected

Inserting stitches
Click Edit > Stitch Edit to place stitch cursor at a
selected insertion point.
You can insert stitches in an object to fill gaps.
Inserted stitches are considered part of the object
rather than independent objects. They will, however,
be lost if the object’s stitches are regenerated. Where
possible, edit the object properties rather than
individual stitches. For example, to increase stitch
density, reduce spacing rather than insert stitches.
To insert stitches

1 Select Edit > Stitch Edit. Alternatively press E.
Tip Zoom in and display the needle points for
easier selection. See Zooming in & out and Viewing
embroidery elements.

2 Select a needlepoint.

New stitch
inserted and
selected

5 Continue right-clicking as required.

Moving stitches
Click Edit > Stitch Edit to place stitch cursor at a
selected insertion point.
You can move individual or groups of selected
stitches.
Caution If an object’s stitches are regenerated for
any reason, all stitch editing functions are lost. Where
possible, reshape the object rather than move
individual stitches. See Reshaping & Editing Objects
for details.
To move stitches

1 Select Edit > Stitch Edit. Alternatively press E.
Tip Zoom in and display the needle points for
easier selection. See Zooming in & out and Viewing
embroidery elements.

The needle point and stitch colors change and the
needle position marker moves to the selected

2 Select stitches and drag them to a new position.
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The stitch shadow outline shows the new position.
Drag stitch to
new position
Shadow outline
Selected stitches

3 Press Enter.

Deleting stitches
Click Edit > Stitch Edit to place stitch cursor at a
selected insertion point.
You can delete individual or groups of selected
stitches.
Caution If an object’s stitches are regenerated for
any reason, all stitch editing functions are lost. Where
possible, edit the object properties rather than
individual stitches. See Adjusting satin stitch spacing
and Preserving long stitches for details.
To delete stitches

1 Select Edit > Stitch Edit. Alternatively press E.
Tip Zoom in and display the needle points for
easier selection. See Zooming in & out and Viewing
embroidery elements.

2 Select a stitch or stitches.
3 Press Delete.

Stitches selected

Stitches deleted
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PART V
ADVANCED DIGITIZING
BERNINA Embroidery Software provides specialized productivity features as well as
special effects and digitizing techniques.

Decorative stitching
This section explains how to apply the various decorative types to outlines and fills, as
well as change stitch settings to obtain the best results. See Decorative Stitching for
details.

Stitch effects
This section shows you how to apply artistic stitch effects to embroidery objects, and
how to adjust their settings to get the best results. See Stitch Effects for details.

Stitch patterns
This section describes how to apply stitch patterns to embroidery objects, and how to
adjust their settings to get the best results. See Stitch Patterns for details.

Embroidery patterns
This section describes how to insert patterns into your design, and how to adjust their
settings to get the results you want. It also explains how to create your own patterns
and pattern sets as well as how to create stitch patterns with carving stamps. See
Embroidery Patterns for details.

Digitizing for appliqué
This section covers creating closed-object appliqué as well as partial cover appliqué. It
also discusses creating open-object appliqué. See Digitizing for Appliqué for details.

Cutwork & stumpwork
This section covers tools and techniques for expanding flat embroidery surfaces into
raised or ‘sculpted’ surfaces, specifically by means of cutwork and stumpwork. See
Cutwork & Stumpwork for details.

Raised embroidery
This section covers tools and techniques for expanding flat embroidery surfaces into
raised or ‘sculpted’ surfaces, specifically by means of quilted embroidery, needle felting,
and couching. See Raised Embroidery for details.

Ancillary applications
This section provides an overview of the ancillary BERNINA Cross Stitch and BERNINA
Quilter applications provided with BERNINA Embroidery Software. See Ancillary
Applications for details.
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CHAPTER 20
DECORATIVE STITCHING
BERNINA Embroidery Software provides a
range of decorative stitches which you can
use to mimic some traditional hand-worked
embroidery. These include a large range of
blackwork and candlewicking patterns
suitable for both outlines and fills.
Lacework and stipple are two decorative fill
stitches. Lacework can be used to give a
lacey look to objects such as flowers.
Gradient Fill varies stitch spacing between
dense and open fill, producing shading
effects which are difficult to achieve
manually.
Stippling, also known as vermicelli, is a
free flowing run stitch that can be used for
decorative effects or to produce quilting.
Ripple and Contour fills are related stitch
types which create an open fill which
follows the contours of a shape. Cross
stitching is a popular technique for filling large areas with low stitch counts.
Crosses in separate objects line up precisely when using the same fabric count.
This section explains how to apply the various decorative types to outlines and
fills, as well as change stitch settings to obtain the best results.

Creating craft stitches
Different stitch types suit different styles of
embroidery. When you digitize an object, it uses the
current stitch type for the selected digitizing method.
Of course you can change stitch types at any time.

stemstitch, and candlewicking. Outlines and fills are
generated with default stitch settings. These can be
adjusted before or after digitizing via Object
Properties. See also Digitizing Methods.
Techniques for adjusting layouts are the same as for
pattern fills. Stitch angles have no effect on pattern
layouts. See Creating pattern fills for details.

BERNINA Embroidery Software provides a range of
stitches for more decorative outlines and fills. These
include such stitches as blackwork, backstitch,
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Tip Wave Fill lets you contour fill stitches along a
digitized guideline. Wave Fill can be applied to all
pattern fills. See also Creating wave effects.

Step stitch
used

Wave effect
applied

type of embroidery pattern and has the same
properties. See also Embroidery Patterns.

Decorative stitch
selected

Blackwork
Use Stitches > Blackwork Outline to create craftstitch
borders. Name derives from black silk thread
traditionally used in this form of embroidery.
Use Stitches > Blackwork Fill to create fill for
blackwork designs. Name derives from black silk
thread traditionally used in this form of embroidery.
Blackwork gets its name from the black silk thread
traditionally used in this form of embroidery. Early
designs tend to be angular, whereas later designs use
more diagonal stitches. Blackwork employs just a few
simple stitches to create complex designs. It can be
used to decorate articles of dress or furnishings such
as hankies, table napkins, tablecloths, and doilies.

Candlewicking
Use Stitches > Candlewicking Outline to create
ornamental craftstitch borders. Specify exact pattern
size and spacing.
Use Stitches > Candlewicking Fill to create
candlewicking fills – traditional white-on-white
embroidery usually done with heavy cotton thread on
white linen.
Candlewicking is a traditional white-on-white
embroidery technique, usually done on white linen or
cotton fabric with heavy cotton threads. Stitches used
are mostly knots, both Colonial and French, as well as
stemstitch. Candlewicking Outline can be used for
ornate borders. You can specify the exact size of each
pattern as well as spacing between them.

The most common blackwork fills employ simple
stitches to create complex scrolling or geometric
patterns. By using different blackwork fill patterns,
you can create light and dark tones in a design.
More use of color is becoming popular today. Stitches
used are mostly knots, both Colonial and French, as
well as stemstitch. Candlewicking can be used to
embroider white bedspreads, pillows and clothing.

Blackwork settings
Blackwork settings can be adjusted in the usual way
via Object Properties. In essence, blackwork is a
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Candlewick settings
Candlewick settings can be adjusted in the usual way
via Object Properties. Like blackwork,
candlewicking is a type of embroidery pattern and has
the same properties. See also Embroidery Patterns.

pattern and has the same properties. See also
Embroidery Patterns.

Creating stipple fills
Lacework
Use Stitches > Lacework Fill to create a lacey look
with open trellis-like patterns.
Lacework stitch consists of an open square trellis-like
pattern which gives objects a lacey look. With
Lacework fills you can adjust the layout of the preset
patterns.

Use Stitches > Stipple Run Fill to create fills made up
of run stitches which meander within a border.
Use Stitches > Stipple Stemstitch Fill to create
heavier stipple run fills with stemstitch outlines.
Use Stitches > Stipple Backstitch Fill to create
heavier stipple run fills with backstitch outlines.
Stippling creates a fill made up of run stitches which
meander within a border. There are three types:
Stipple Run, Stipple Backstitch, and Stipple
Stemstitch. Stippling can be applied to the same
objects as Pattern Fill – i.e. closed objects with or
without stitch angles. It can’t be applied to lettering,
auto appliqué or composite objects.

Lacework settings
Lacework settings can be adjusted in the usual way
via Object Properties. Like blackwork, blackwork
and candlewicking, lacework is a type of embroidery

You can control stitch density in stippling objects by
adjusting stitch length and loop spacing. You can
reshape and scale stipple fill object outlines while
preserving settings.
To create a stippling fill

1 Choose a Stipple Fill.
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2 Create or select a closed shape. See Digitizing
Methods for details.

 Adjust Loop spacing for tighter or more open
stitching.

Loop Spacing: 1.5 mm

Note Stitch angle has no effect on the stipple run
pattern.

3 To change settings, double-click or right-click the
object.
The Object Properties > Fill Stitch dialog
opens.

Adjust stitch
values as
required
Adjust stipple
settings

Loop Spacing: 2.5 mm

 Adjust Inset step to offset stippling inwards
from the object outline. To leave a larger gap
between the stippling and the outline, enter a
larger value. Note that the stipple fill cannot
extend beyond the object outline.

6 Change stipple Stitch type as desired. Stipple
Stemstitch and Stipple Backstitch work the
same way as Stipple Run except that they create
a more ornate fill effect.

Stipple Stemstitch

Stipple Backstitch

 Stipple Stemstitch settings are also
controlled via Object Properties. See also
Stemstitch outlines.

4 Adjust run Stitch settings as desired:
 Adjust Stitch length for smoother or sharper
curves.

Stitch length: 1.0 mm

Stitch Length: 3.0 mm

 Adjust Run count defines the number of stitch
repetitions – e.g. 1, 3, 5, 7, 9 – and hence the
stitch bulk.

5 Adjust Stipple settings as desired:
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 Stipple Backstitch settings are also
controlled via Object Properties. See also
Backstitch outlines.

can also be used for special effects and to reduce
overall stitch count.

Creating gradient fills
7 Click Apply to preview the effect or OK to finish

Gradient Fill varies
stitch spacing between
dense and open fill,
Once a stipple fill is generated, you can adjust
producing perspective
object properties of the generated stipple run at
any time. You can also reshape and scale stipple fill and shading effects
which are difficult to
object outlines while preserving settings. See
Reshaping objects using reshape nodes for details. achieve manually. A
number of different
Gradient Fill effects
are available. When you
use Gradient Fill, the
current stitch spacing
settings are ignored.
However, other stitch
effects will still apply.
and close.

Tip The Break Apart command can be applied to
stipple fill objects. As a result, you can edit the
stipple run line directly. Apply Pattern Run, Satin
and other outline stitch types as desired. See
Splitting into component objects for details.

Tip You can use Gradient Fill with Step fill to create
interesting shading effects.
To create a gradient fill

1 Double-click or right-click a filled object. The
Object Properties > Fill Stitch dialog opens.

2 Click the Effects button and select the Gradient
Fill tab.

Select
Gradient Fill
Stipple with Candlewicking

Choose a
profile

Stipple with Blanket

Creating open fills

3 Select the Gradient Fill checkbox and choose a
profile.

BERNINA Embroidery Software offers various
techniques for creating decorative open fills. These
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4 Move the slider to adjust the spacing.

2 Click the Effects button and select the Others
tab.
Select Travel
on Edges

3 Select the Travel on Edges checkbox.
Adjust spacing
values

Travel runs and overlapping rows are removed,
and consistent row spacing is applied.

5 Click Apply to preview the effect.

4 Click Apply to preview the effect or OK to finish
6 To prevent underlay stitching from showing
through, deselect the Effects > Underlay
checkbox. See also Stabilizing with underlays.

7 To prevent travel runs showing through, make
sure Travel on Edges is de-activated. See below.

Hiding travel runs
Apply Travel on Edges effect to force underlying
travel runs to the edges of an object so that they can’t
be seen through open stitching. This is often used for
backgrounds.

Tip Use Travel on Edges effect with the Gradient
Fill or Color Blending effect to eliminate travel
stitches inside graded embroidery objects. See also
Creating gradient fills and Creating color blending.
To hide travel runs in an open fill

1 Double-click or right-click an open-fill object. The
Object Properties > Fill Stitch dialog opens.

and close.
Tip Click Save to Template before closing this
dialog to save settings permanently. Saved
settings will be applied to all new designs based on
the current template. See Properties, Fabrics &
Templates for details.

Creating contoured stitching
Ripple and Contour fills are related stitch types
which create an open fill which follows the contours of
a shape. Ripple provides a similar look to Contour,
with a fixed number of lines and variable spacing, but
spiralling out from the center of a filled object. Both
can be applied to any filled object.

Creating ripple fills
Use Stitches > Ripple Fill to create spiral stitching
from the center of any filled object.
Ripple Fill works best for ‘blobby’ shapes but can be
applied to longer shapes. With longer shapes it may
generate stitches that go outside the perimeter of the
object, but this can provide for some interesting
visual effects. The center of the Ripple stitch can be
moved with the Reshape Object tool.
To create a ripple fill

1 Create or select a closed shape. See Digitizing
Methods for details.
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2 Select Ripple Fill.
Note If the object has a hole, this is ignored when
ripple is applied but still exists when other stitch
types are applied.

Note Stitch angle has no effect on the pattern
layout.

3 To change settings, double-click or right-click the
object. The Object Properties > Fill Stitch
dialog opens.

Tip Some interesting visual effects can be
achieved by reshaping and moving the centre of
the Ripple Fill stitch outside the object outline.

Adjust stitch
settings as desired

4 Adjust ripple Stitch settings as desired:
 Adjust Stitch length for smoother or sharper
curves.

Creating contour fills
Use Stitches > Contour Fill to create stitching which
follows object contours, creating a curved,
light-and-shade effect.

Stitch length: 3.0 mm

Stitch Length: 1.0 mm

 Adjust Stitch spacing for denser or more open
stitching.

Stitch spacing: 3mm

Contour stitch provides back and forth stitching with
a fixed number of lines with variable spacing
depending on the object outline. It can only be
applied to block digitizing objects, including Circle
objects. Closed objects modified with the Add Stitch
Angles tool cannot be used with Contour stitch.

Stitch spacing: 5mm

5 Click Apply to preview the effect or OK to finish
and close.
The selected settings are applied to the object.

To create a contour fill

1 Click the Contour Fill icon.
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The stitch type will be applied to new or selected
objects based on current settings.

 Adjust Stitch spacing for denser or more open
stitching.

2 Create a block digitizing object and select. See
Digitizing Methods for details.
The current Contour settings are applied to the
selected object.

Stitch spacing: smaller

Stitch spacing: larger

5 Click Apply to preview the effect or OK to finish
and close.
The selected settings are applied to the object.
Note Stitch angle has no effect on the pattern
layout.

3 To change settings, double-click or right-click the

Creating cross stitch fills

object.
The Object Properties > Fill Stitch dialog
opens.

Adjust Contour
settings

Use Stitches > Cross Stitch Fill to create open
patterned fills with crosses generated to suit
standard grid for entire design.
Cross stitching is a popular technique for filling large
areas with low stitch counts. Cross stitch is also
sometimes combined with appliqué. It is something
like Pattern Fill but is generated differently.

4 Adjust contour Stitch Values as desired:
 Adjust Stitch length for smoother or sharper
curves.

Stitch length: smaller

Stitch length: larger

Crosses in separate objects line up precisely when
using the same fabric count. This is because cross
stitch fills are generated on a universal grid not
object-by-object. Fractional crosses are generated at
object boundaries in order to avoid gaps. Stitch angle
has no effect on pattern layout. See also Creating
pattern fills.
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4 Adjust cross stitch settings as desired:
Tip Cross Stitch fill is a stitch type in its own right
but does not replace the BERNINA Cross Stitch
application available from the General toolbar. See
also Introduction to cross stitch.

Field

Description

Fabric count

Controls the size of cross specified as a
fabric count rather than cross size.
Crosses in different objects align
precisely if using the same cross
density.

Threads

Number of times – 2, 4 or 6 – thread
passes over the same cross in order to
make it bulkier.

Stitch style

Full cross (X), diagonal, or upright (+).

To create a cross stitch fill

1 Click the Cross Stitch Fill icon.
The stitch type will be applied to new or selected
objects based on current settings.

2 Create closed-object/s and select. See Digitizing
Methods for details.
Current cross-stitch settings are applied to the
selected object. Notice how crosses in different
objects align.

Floss direction Controls which way top leg of the cross
– i.e. full length stitch – is directed –
forward or backward for diagonal full
crosses and horizontal or vertical for
upright full crosses.

5 Click Apply to preview the effect or OK to finish
and close.

Crosses align

Note Stitch angle has no effect on the pattern
layout.

Stitch style: upright cross

Stitch style: full cross

3 To change settings, double-click or right-click the
object/s.
The Object Properties > Fill Stitch dialog
opens.

Tip The cross-stitch grid is not displayed but you
can set the background grid to the cross size to get
a better idea of how the grid is used to generate
the crosses. Use Snap to Grid to ensure that your
object outlines line up with the cross stitch grid.
See Setting grid options for details.

Cross Stitch
settings
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CHAPTER 21
STITCH EFFECTS
BERNINA Embroidery Software
provides many artistic effects to create
textured and curved stitching, color
blending, and warping or ‘morphing’
stitching effects.
Use Textured Edge to add rough edges
to objects, create shading effects, or
imitate fur or other fluffy textures in
your design.
Star Fill generates radial turning
stitching in several stitch types such as
Satin and Tatami stitch.
Wave Fill lets you contour fill stitches
along a digitized guideline. Stitches
follow the line but maintain uniform density and needle penetration patterns.
Pattern fills can be enhanced with 3D Globe Effect. The effect can also be applied
to Candlewicking and Lacework fills.
Use Color Blending to create different shading, perspective, three-dimensional
and color effects by blending two colored layers in an embroidery object. The
Morphing feature allows you to transform object outlines and stitches in a variety
of novel and interesting ways.
This section shows you how to apply artistic stitch effects to embroidery objects,
and how to adjust their settings to get the best results.

Creating textured edges

The effect will be applied to new or selected
objects based on current settings.

2 Create closed-object/s – circle or square – and
Use Effects > Textured Edge to create rough edges
and shading effects, or imitate fluffy textures.
Use Textured Edge to add rough edges to objects,
create shading effects, or imitate fur or other fluffy
textures in your design. Textured Edge is applied
based on current settings in the Effects dialog.
Adjust settings to change the degree of roughness,
the side of the object to which the effect is applied and
the textured edge margin. You can change these
settings before or after digitizing.
To create a textured edge

1 Click the Textured Edge icon.

select. See Digitizing Methods for details.
The current settings are applied to the selected
object.

3 To change settings, right-click the Textured Edge
icon with the object selected.
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The Effects > Textured Edge dialog opens.
Tip To better view the Textured Edge effect,
press the . key to display needle points or use
Artistic View.

Select settings
Adjust values

Creating star fill effects
4 Use the buttons to choose the side of the object
you want to apply the effect to.

Use Effects > Star Fill to create radial turning
stitching with available stitch types.
Click Transform > Reshape Object to view the
reshape nodes of a selected object.
Star Fill generates radial turning stitching in several
stitch types such as Satin and Tatami stitch. Stitches
are generated from the outside edge to the geometric
center. The center can be shifted.

Left side
textured

Both sides
textured

Right side
textured

5 Use the Texture slider to select the degree of
texture – left for a rougher texture and right for a
smoother texture.
More variation in
stitch length gives a
rougher texture

Less variation in
stitch length gives a
smoother texture

6 Use the Span slider to select a stitch range in
which you want the stitches to fall.
Move the slider to the left for a short range and to
the right for a longer range.

Shorter
range

Longer
range

7 Click Apply to preview the effect or OK to finish
and close.
The stitch is regenerated with the adjusted
settings.

Star Fill is applicable to several object shapes –
closed, circle and rectangle – with optional holes. The
effect may be on or off while digitizing. All
transformations, excepting morphing effects,
preserve the Star Fill radial stitching but transform
the hole shape. Shaping operations such as Mirror
Merge or Remove Overlaps preserve Star Fill
effect.
Tips for use
Not all patterns and stitch settings or objects (size
specific) are suitable for Star Fill. In particular, if you
are using it with larger objects, use one or a
combination of the following to avoid bunching at the
center:
 Increase the size of the hole, move the center into
an existing hole in the object, or move it outside
the object altogether.
 Add Textured Edge to the inside.
 Use larger stitch spacing – increase by about 20%.
 Avoid patterns which add needle penetrations
close to the center of the object.
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 Use Edge Walk underlay with smaller objects, to
help reduce the number of stitches at the object
center.
 For fewer problems and a better embroidery
result, use an SUK or H/E embroidery needle.

Tip Star Fill can be applied together with Satin
Fill, Step Fill, and Fancy Fill. See also Creating
fancy fills.

Tip For best effect, use Star Fill with ring shapes.
The size of ring should be about 20% of the outer
diameter.
To create star fill effects

1 Select a closed-object and click the Star Fill icon.

Star Fill with Satin Fill

Star Fill with Fancy Fill

The effect is applied to the selected object.
Tip You are not able to directly edit the stitch
angles automatically generated by Star Fill effect.
However, you can apply Break Apart to an object
with Star Fill effect and edit the resulting turning
angle closed object. See also Splitting into
component objects.

2 To modify the effect, select the object and click the
Reshape Object icon. In Reshape mode, you
can:
 Move the center point of the radial stitching.
 Set the size of the center hole.
 Edit the center hole shape as for a circle/ellipse
object.

Creating wave effects
Use Effects > Wave Fill to contour stitches along a
digitized guideline – stitching maintains uniform
density.
Click Transform > Reshape Object to view the
reshape nodes of a selected object.
Wave Fill lets you contour fill stitches along a
digitized guideline. Stitches follow the line but
maintain uniform density and needle penetration
patterns.

Tip Unlike Ripple stitch, the center of Star Fill
effect can be moved outside the shape or into an
included hole to achieve a different effect, without
loosing the original shape.

3 Press Enter to apply, Esc to finish.

Tip Use smaller stitch lengths – e.g. 4.00 mm or less
– for best results.
To create Wave Fill

1 Select a closed-object and click the Wave Fill
icon.
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The effect is applied to the selected object.

Use Stitches > Lacework Fill to create a lacey look
with open trellis-like patterns.
Use Effects > 3D Globe Effect to create contoured
stitches to produce a 3D appearance. Choose from
pattern library.
Click Transform > Reshape Object to view the
reshape nodes of a selected object.

2 To modify the effect, select the object and click the
Reshape Object icon.

3 Click and drag the curve into the required shape
and press Enter. See Reshaping objects for
details.

4 Press Esc to finish.

Pattern fills can be enhanced with 3D Globe Effect.
The effect can also be applied to Candlewicking and
Lacework fills. It can also be applied to alternating
pattern fills. You can apply the effect to an entire
object, or to a specified part of the fill. The effect,
however, cannot be applied to circle/ellipse objects.

To create a 3D pattern effect
 Select a patterned fill object and click the 3D
Globe Effect icon. The effect is applied.

Tip Wave Fill can be applied together with Fancy
Fill, Pattern Fill and some of the craft stitch
types. See also Creating fancy fills, Creating
pattern fills, and Creating stipple fills.

Object with
Candlewicking
Wave Effect with
Blackwork Fill

Wave Effect with
Candlewicking Fill

3D Globe applied

 To make further adjustments, click Reshape
Object with the object selected. A guide frame
appears with three control points.

Caution Don’t alter stitch angles after applying
Wave Fill as it can displace Fancy Fill patterns.

Click-and-drag
control points

Creating 3D globe effects
Click-and-drag to
reposition frame

Use Stitches > Pattern Fill to create decorative fill
stitching. Choose from pattern library.
Use Stitches > Candlewicking Fill to create
candlewicking fills – traditional white-on-white
embroidery usually done with heavy cotton thread on
white linen.

 Adjust the control points to:
 Change frame height
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 Change frame width
To apply color blending

 Reposition frame.

1 Select a filled object and click the Color Blending
icon.

Creating color blending

The Color Blending dialog opens.

Use the Color Blending effect to create different
shading, perspective, three-dimensional and color
effects by blending two colored layers in an
embroidery object. The effect is created by
duplicating the object, then applying Gradient Fill and
Travel on Edges to both layers, which are then
grouped.

Choose a
profile

Select first
color
Select second
color

2 In the Profiles panel, select a spacing profile for
top and bottom layers.

Bottom Layer: Profile1
Top Layer: Profile1

There are two different Color Blending effects:

Bottom Layer: Profile3
Top Layer: Profile3

3 In the Bottom Layer panel:

 linear stitch spacing

 Select the color of the first layer.

 curved stitch spacing.

 Adjust the maximum spacing value for the first
layer as required.

Color Blending can be applied to objects filled with
Satin, Step, or Fancy Fill stitch, or objects outlined
with Satin or Blanket stitch.

4 In the Top Layer panel:
 Select the color of the second layer.
 Adjust the maximum spacing value for the
second layer as required.

Applying color blending
Use Edit > Color Blending to create blended stitching
in selected objects.

5 Click OK.

Use the Color Blending effect to create color blends,
perspective effects and shading.

Maximum
spacing

Bottom Layer: Red
Top Layer: Yellow

Bottom Layer: Yellow
Top Layer: Red

Minimum
spacing

Tip To prevent underlay stitching from showing
through, deselect the Effects > Underlay
checkbox. See also Stabilizing with underlays.
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Editing blended objects

s

6 Repeat the process for the second object and
re-group the objects.

Click Arrange > Ungroup to ungroup selected
objects.
Click General > Color Film to view all color blocks
and objects in a design.

Editing a Color Blending object is limited. The two
objects must first be ungrouped and the separate
objects edited according to Gradient Fill settings.
See Creating gradient fills for details.

Note If you edit a grouped object the Color Blending
effect will be lost as both layers will have the same
settings.
To edit blended objects

1 Select the blended object and ungroup it. See
Grouping & splitting objects for details.

Creating morphing effects
Use General > Morphing to create transformed
object outlines and stitches.
The Morphing feature allows you to transform object
outlines and stitches in novel and interesting ways.
They are additive in the sense that more than one
effect can be applied to a given selection.

Tip Use the Color Film to view all color blocks and
objects in the design. See Viewing & selecting
color blocks for details.

2 Select one of the objects and change the color as
required.

3 Double-click or right-click it to open the Object
Properties dialog, click the Effects button, and
select the Gradient Fill tab.

Select
Gradient Fill

Adjust spacing

Morphing is a powerful feature but don’t overdo it.
Keep in mind the following points when morphing
objects/designs:
 To avoid poor quality embroidery, don’t use too
much of the effect. Less is more when it comes to
morphing.
 Use larger stitch spacing – increase it by about
20%.
 Avoid morphing Satin stitches – in some objects
they become too long.
 Increase the underlay margin to avoid it projecting
outside the cover stitch.
To create morphing effects

4 Select a profile and adjust spacing as required.

1 Select one or more objects.

See Creating gradient fills for details.

5 Click Apply to preview the effect or OK to finish
and close.
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Any object/s can have morphing effects applied.

Use Wave Horizontal to move the object outlines and
stitches to follow a horizontal wave pattern
Use Wave Vertical to move the object outlines and
stitches to follow a vertical wave pattern.
The selected morphing effect is applied to the
current selection with the morphing center (if any)
defaulting to the center of the current selection.

2 Click the Morphing icon on the General toolbar.
The Morphing Effect docker opens with all
morphing effect buttons enabled.

BERNINA Embroidery Software also does the
following:
Pinch

Ripple

Punch

Twirl

 Groups selected objects if they were not
already grouped.
 Applies the morphing effect to selected objects
as a whole, using the default morphing center
and current parameters.
 Activates the Reshape Object tool for the
resultant objects.
 Displays the available morphing graphical
controls for the selected morphing effect.

Skew
Horizontal

Skew Vertical

Wave
Horizontal

Wave Vertical

4 Optionally, click the Undo button to undo the
morphing transformation, or click and drag the
available morphing controls to adjust the effect.
If you drag one of sliders, the resultant object
outlines display dynamically in black until the
mouse button is released.

3 Choose a morphing effect:
Use Pinch to pinch the object outlines and stitches
together in the morphing center, while pulling outer
stitches away from each other.
Use Punch to punch the object outlines and stitches
away from the morphing center, while stretching the
object outlines and stitches around an imaginary
sphere.
Use Ripple to apply a wave pattern radiating from the
morphing center, like dropping a stone into a pond.
Use Twirl to twist the object outlines and stitches
around the morphing center, creating a swirling effect
like a whirlpool.
Use Skew Horizontal to slant the object outlines and
stitches horizontally to the left or right.
Use Skew Vertical to slant the object outlines and
stitches vertically up or down.

5 Optionally, if available, adjust the morphing center
using the Reshape Object tool. (Not all morphing
effects have a moveable center.)
The Center Morphing button in the Morphing
Effect docker is enabled when the morphing
center is moved away from the center of the
current selection. Clicking it causes the morphing
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center to be moved back to the center of the
current selection.

Center moved to
the left

6 Apply as many effects to the current selection as
desired.

7 Optionally, remove one or more morphing effect/s
by the following means:
 The Remove button is enabled if the current
selection has one or more morphing effects
applying. Clicking it causes the last-applied
morphing effect to be deleted. The previous
morphing effect (if any) becomes immediately
available for reshape or removal.
 Clicking the enabled Remove All button
causes all morphing effects to be removed from
the current selection and the Reshape process
to be stopped.
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CHAPTER 22
STITCH PATTERNS
BERNINA Embroidery Software provides
many artistic effects and stitch types to
create stitch patterns. Based on Step Fill,
pre-defined shapes create regular
patterns of needle points.
Fancy Fill is a decorative fill stitch in
which the needle penetrations form a
tiled pattern. Sculptured Fancy Fill stitch
can be applied to objects with turning
stitches creating three dimensional,
turning pattern effects which can’t be
achieved by Fancy Fill alone.
Elastic Fancy Fill is a decorative effect
where the pattern follows the stitch
angle and may be scaled to fit the width
of the object.
You can also define a pattern of needle penetrations using a ‘carving stamp’ as a
template. A carving stamp can be any vector and/or embroidery shape or shapes.
This section describes how to apply stitch patterns to embroidery objects, and
how to adjust their settings to get the best results.

Creating fancy fills
Use Stitches > Fancy Fill to create artistic fills while
keeping the appearance of solid stitching.
Use Stitches > Sculptured Fancy Fill to create 3D
pattern effects with turning fills.
Fancy Fill is a decorative fill stitch where needle
penetrations form a tiled pattern. Use it to fill wide
and large areas with repeating patterns while keeping
the appearance of a solid field of stitching. See also
Applying step fill patterns.

Sculptured Fancy Fill stitch is a variant of Fancy
Fill which can be applied to objects with turning
stitches. This creates three dimensional, turning
pattern effects which can’t be achieved by Fancy Fill
alone.

Tip The Carving Stamp feature allows you to define
a pattern of needle penetrations using a ‘carving
stamp’ as a template. See Creating patterns with
carving stamps for details.
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 Optionally, change pattern layout by adjusting
settings via the Layout button. By default, Grid is
selected. Techniques for adjusting pattern layout
are the same as for pattern fills. See Laying out
pattern fills on-screen for details.

To create a fancy fill
 Select a closed object or objects.

Pattern
preview

 Click the Fancy Fill icon. The current Fancy Fill
settings are applied to the selected object.
 To change settings, double-click or right-click the
object/s. The Object Properties > Fill Stitch
dialog opens.

Lay out the
pattern on
screen

 While stitch angle has no effect on pattern layout,
it does affect clarity. Adjust stitch angles with the
Reshape tool as necessary.
Select a pattern
from the droplist

 Select a pattern from the droplist. See also Fancy
Fill Samples.

 To create a turning effect, add stitch angles with
the Add Stitch Angles tool or choose an object
with turning angles. See also Modifying stitch
angles.

 Adjust pattern size, orientation, and spacings via
the object properties. The preview panel gives you
immediate visual feedback.

 Next choose Sculpture in the Layout panel. This
has the same effect as choosing Sculptured
Fancy Fill from the Stitch Types toolbar.

Adjust pattern size
and orientation

Adjust pattern
spacings

 Click Apply to preview the effect or OK to finish
and close.
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Tip Wave Fill lets you contour fill stitches along
a digitized guideline. Wave Fill can be applied to
Fancy Fill objects. However, you need to first apply
the effect to a Step fill before converting to a Fancy
Fill. See also Creating wave effects.

To create elastic fancy fills
 Select an object and click the Elastic Fancy Fill
icon.

 Right-click the tool to access settings.
Step stitch used

Wave Effect
applied

Fancy Fill
selected
Select pattern
Pattern preview

Creating elastic fancy fills

Choose
layout option

Use Effects > Elastic Fancy Fill to create fancy fill
patterns that follow stitch angles and are scaled
according to object width. Right-click for settings.
Elastic Fancy Fill is a decorative effect where the
pattern follows the stitch angle and may be scaled to
fit the width of the object. It is intended for use with
objects with turning stitches or varying column width.
You can apply Elastic Fancy Fill to a wide variety of
object and stitch types. Use existing patterns or
create your own.

 Select a pattern from the droplist.
 Select one of four options.

 Optionally, adjust or add stitch angles.
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 Optionally, adjust Elastic Fancy Fill settings to
vary size, shape indent, spacing and pattern
offsets.

 Elastic Fancy Fill effects can also be added to
satin outlines.

Enter dimensions of
largest pattern
Enter distance
between first pattern
and first stitch line
Enter column
spacing and offsets

 In the Size X and Size Y fields, adjust the
dimensions of the largest pattern in the effect.
 In the Indent field, adjust the distance between
the first pattern and the first stitch line.

Default values

Indent: 2 mm

Creating patterns with carving stamps
The Carving Stamp feature allows you to define a
pattern of needle penetrations using a ‘carving stamp’
as a template. A carving stamp can be any vector
and/or embroidery shape or shapes. A needle
penetration is placed wherever a stitch intersects with
the vector or embroidery shape.

Indent: 4 mm

 In the Column panel, enter spacing and offset
settings as required:

Default values

Spacing decreased

Offset adjusted

 If you selected an option that uses more than one
row of patterns, the fields in the Row panel are
available.
With the Carving Stamp feature, you can:
 Apply pre-defined or temporarily-selected or
-digitized carving stamps to applicable objects.
Default values

Spacing decreased

Offset adjusted

 Move/rotate/scale/reshape/delete carving stamps
associated with an applicable object while in
Reshape mode.
 Create and manage your own user-defined carving
stamps in a pattern library for future reference.
Selected carving stamps can be applied to outline
objects with Satin stitch type, and closed objects with
Satin/Step/Fancy stitch type.
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Applying pre-defined patterns

the Carving Stamp dialog opens. The Use
Pattern tab is open by default.

Use General > Carving Stamp to apply preset or
custom patterns to create a pattern of needle
penetrations.
The Carving Stamp docker contains four tabs: Use
Pattern, Use Object, Digitize, and Appearance. The
Use Pattern tab lets you select and apply
pre-defined stamp patterns to selected applicable
objects only or to any applicable objects if nothing is
selected.

Select a pattern
set

To apply pre-defined patterns

Select a stamp
to use

1 Select an embroidery object or not as required.

3 Select a pattern set from the Set list – e.g.
‘Nature’.
Note You can start with or without embroidery
objects selected. If one or more objects is
selected, stamps are only applied to selected
objects. If no object is pre-selected, stamps can be
applied to any objects.

2 Click the Carving Stamp icon.

The Set droplist contains pre-defined pattern sets
as well as user-defined stamp pattern sets. See
Pattern set: Carving Stamps for details.

4 Select a pre-defined stamp pattern.
A thumbnail appears in the preview panel and the
Use Stamp button is enabled.

5 Click the enabled Use Stamp button and move
the mouse pointer to the design window.
The pre-defined stamp is attached to the mouse
pointer. You are prompted in the Status Bar to
enter an anchor point.

6 Move the mouse pointer to the desired position
over the target object/s.
 Right-click to mirror the stamp.
 Press Shift to prevent Auto Scroll.

7 Click the mouse button to fix the anchor point.
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You are prompted to enter the guide point.

rename user-defined stamp patterns. See also
Adding stamps to a library.

Tip Use the Softened Stamp and Raised Stamp
options on the Appearance tab to soften or
accentuate the effect. See Changing carving
stamp appearance for details.

8 Swivel the pattern about the anchor point to the
desired guide point position, optionally with the
Shift key pressed.
BERNINA Embroidery Software resizes the stamp
if the Shift key is pressed while moving the mouse
pointer.

9 Click the mouse button.
 If you have pre-selected an object or objects,
the stamp pattern is only applied to those
objects, whether or not the pattern extends
beyond the object borders.
 If no objects are pre-selected, the stamp
pattern is applied to any applicable underlying
objects.

Using objects as carving stamps
Use General > Carving Stamp to apply preset or
custom patterns to create a pattern of needle
penetrations.
The Carving Stamp docker contains four tabs: Use
Pattern, Use Object, Digitize, and Appearance. The
Use Object tab allows you to select object outlines
from the design window and apply them directly as
stamps or save them to a library for future reference.
To use an object as a carving stamp

1 Select an embroidery object or not as required.
You can start with or without embroidery objects
selected to be used as stamps.

2 Click the Carving Stamp icon and select the Use
Object tab.
Note If there are multiple overlapping objects in
the area in which the stamp is applied, the stamp
is applied to every overlapping applicable object.

10 Repeat as many times as necessary. Press Esc to

Select Use
Object tab

proceed.
Note The Rename and Delete buttons are
enabled whenever a user-defined stamp pattern is
selected. When the Rename button is clicked, the
Rename Pattern Stamp dialog opens. Use it to

3 Click the Start Selecting button.
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Any pre-selected objects remain selected.

4 Hover the mouse over any object in the design

digitized, or apply it to applicable objects in the design
window.

window.
The object outline is highlighted.
 Select object outlines to include in the stamp
using any existing selection methods. The
selected outlines appear in the preview panel.
 Deselect at any time by pressing the Esc key.
Tip Selectable objects can include vectors from
Artwork Canvas. This is the only time vectors
can be selected in the Embroidery Canvas.

5 Click the Use Stamp button to apply the selection
as a carving stamp. See Applying pre-defined
patterns for details.
To digitize carving stamps

1 Select an embroidery object or not as required.
If embroidery objects are pre-selected, digitized
stamps will apply only to these objects.

6 Optionally, click the Add to Library button to add
the selection to the library for future reference.
See Adding stamps to a library for details.
Tip Use the Softened Stamp and Raised Stamp
options on the Appearance tab to soften or
accentuate the effect. See Changing carving
stamp appearance for details.

2 Click the Carving Stamp icon and select the
Digitize tab of the dialog.

Digitizing carving stamps
Use General > Carving Stamp to apply preset or
custom patterns to create a pattern of needle
penetrations.
The Carving Stamp docker contains four tabs: Use
Pattern, Use Object, Digitize, and Appearance. The
Digitize tab allows you to digitize stamp outlines and
either directly apply the digitized stamp where it was

Click to start
digitizing

3 Click the Start Digitizing button.
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You are prompted to enter a starting point for the
stamp outline.

point as with pre-defined patterns. See
Applying pre-defined patterns for details.

6 Optionally, click the Add to Library button to add
4 Digitize stamp outlines:

the selection to the library for future reference.
See Adding stamps to a library for details.

 Press Enter once to complete a boundary.
 Press Enter again to finish stamp digitizing.

5 Click the enabled Stamp button.
 Click the Stamp button to apply the stamp to
selected applicable objects only.

Changing carving stamp appearance
Use General > Carving Stamp to apply preset or
custom patterns to create a pattern of needle
penetrations.
The Carving Stamp docker contains four tabs: Use
Pattern, Use Object, Digitize, and Appearance. The
Softened Stamp and Raised Stamp checkboxes
and Clear All Stamps button in the Appearance tab
are enabled when one or more objects with stamps
are selected.
To change carving stamp appearance

Stamp applied with object/s selected

1 Select an embroidery object with stamps already
applying.

 Alternatively, use Stamp to apply the stamp to
applicable objects with no object/s selected.

Stamp applied with no object/s selected

 Click the Use Stamp button to position the
stamp. You are prompted to enter an anchor
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2 Click the Carving Stamp icon and select the
Appearance tab of the dialog.

penetrations in the underlying object are
automatically updated.
To reshape a carving stamp
 In Reshape mode, select an embroidery object
with carving stamps applied.

Choose an
option

A diamond selection handle is displayed at the
center of each stamp.

3 Choose an option to modify stamp appearance as
desired:
 Checking the Softened Stamp checkbox
causes any existing stamp/s to be softened.

Click a diamond
selection handle

 Select the diamond selection handle.
Another set of sizing, stretching and rotation
handles appears around the stamp as shown.

 Checking the Raised Stamp checkbox cause
any splits within the combined closed
boundaries of a carving stamp to be removed.
Self-intersecting boundaries and overlapping
boundaries are combined.

 Drag the diamond to move the stamp.

Drag diamond

Tip Holding down the Ctrl key will constrain the
movement to the horizontal or vertical axis.
Note Clicking the Clear All Stamps button will
cause all existing stamps to be removed from
selected objects.

Reshaping carving stamps
Carving stamps can be moved, rotated, scaled,
reshaped, and deleted individually in Reshape mode.
As you transform carving stamps, needle
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 Drag one of the corner sizing handles to scale the
stamp.

 Click the curve of the stamp to display control
points. Use these to reshape or delete the stamp
in the same way as for other objects.

Drag corner
sizing handle

 Hold Shift key to scale from the center.
 Hold Ctrl key to scale proportionally.
 Hold Ctrl and Shift keys while dragging a
sizing handle to scale proportionally about the
center.
 Drag one of the stretching handles to stretch the
stamp.
 Top and bottom stretching handles stretch the
object vertically.
 Left and right stretching handles will stretch the
stamp horizontally.
 Holding down the Shift key will stretch the
stamp from the center.

Note When an embroidery object with carving
stamps is itself transformed, carving stamps are
transformed accordingly.

Adding stamps to a library
Use General > Carving Stamp to apply preset or
custom patterns to create a pattern of needle
penetrations.
This procedure starts when you click the enabled Add
to Library button either on the Use Object tab or
Digitize tab in the Carving Stamp docker.
To add a stamp to a library

1 Select an object which you want to add to the
library as a user-defined carving stamp.

Drag stretching
handle

 Define your own carving stamps using the
Carving Stamp > Use Object tab. See Using
objects as carving stamps for details.
 Digitize carving stamps on the spot using the
Carving Stamp > Digitize tab. See Digitizing
carving stamps for details.

 Drag the rotation handle to rotate the stamp.

Drag rotation
handle

 Click the blue diamond handle to change it back
into a green diamond handle with no nodes
displayed.

Click to add
to library

2 On either of these tabs, click the enabled Add to
Library button.
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The Create Stamp Pattern dialog opens.

 Move the mouse pointer to the position you
want to use as the guide point during manual
stamp placement and left-click.

Select library set
from droplist
Enter name for
new stamp

3 Select a set from the droplist or click the New Set

Enter second
reference point

button to create a new library.
If you chose to create a new library set, use the
New Stamp Set dialog to create a new stamp set.
The newly created stamp set is displayed in the
Set list when the Use Pattern tab is selected.

BERNINA Embroidery Software:
 creates the stamp
 registers the reference points either
automatically or manually entered
 replaces any same name stamp with the newly
created stamp

Enter name for
new library set

 displays a confirmation message.

4 Enter a new stamp name and click OK.
You are prompted to digitize the first reference
point in the design window.

7 Click OK.
The newly created stamp is displayed in the stamp
list when the Use Pattern tab is selected.

5 Enter the first reference point:
 Press Enter to have the reference point created
automatically.
 Move the mouse pointer to the position you
want to use as the anchor point during
manual stamp placement, and left-click.

Note The Rename and Delete buttons are
enabled in the Use Patterns tab whenever a
user-defined stamp pattern is selected. When the
Rename button is clicked, the Rename Pattern
Stamp dialog opens. Use it to rename
user-defined stamp patterns. See also Applying
pre-defined patterns.

Enter first
reference point

6 Enter the second reference point:
 Press Enter to have the reference point created
automatically.
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CHAPTER 23
EMBROIDERY PATTERNS
Embroidery patterns are pre-defined
design elements, such as hearts, leaves
or border patterns, that can be inserted
into a design.
Use the patterns provided with the
software or create your own. Patterns can
be scaled, rotated and mirrored in the
same way as other objects. You can
create patterns along a digitized line. Or
you can fill shapes with rows of patterns.
This section describes how to insert
patterns into your design, and how to
adjust their settings to get the results you
want. It also explains how to create your
own patterns and pattern sets as well as
how to create stitch patterns with carving
stamps.

Adding pattern stamps

The Select Pattern dialog opens.
Select viewing mode

Use Digitize > Pattern Stamp to place individual
patterns in the design. Choose from pattern library.
The Pattern Stamp feature allows you to place
single patterns anywhere in the design window. You
can access any pattern in any ‘pattern set’. These
include purpose-made Pattern Fill patterns as well as
craft stitch patterns and monogramming ornaments.

Select
pattern set

Select
pattern

Tip Select a viewing mode – you can list patterns
by picture, name, or both.

2 Select a pattern set from the droplist and select a
pattern from the display panel.
This becomes the current pattern. See also Pattern
Stamp, Run & Fill Samples.
To add a pattern stamp

1 Select Digitize > Pattern Stamp.

3 Click OK.
The dialog closes and the pattern appears
attached to the mouse pointer.

4 Move the pointer to the desired position and click
to mark the guide point.
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This becomes the rotating anchor point. You are
prompted to place the second guide point.

orientation and scale, and vary the space between
patterns.

5 Move the pointer until the pattern is orientated
correctly, then click again for a guide point.

Insert anchor point

Insert guide point
(resized and rotated)

Tip You can resize the pattern on screen by
holding down the Shift key before marking the
second guide point.

6 Press Enter.
Stitches generate.

7 Repeat the step to insert another pattern.
You can rotate and scale patterns as you insert
them.

Applying pattern runs
Use Stitches > Pattern Run Outline to create
ornamental craftstitch borders. Choose from pattern
library.
Select the pattern to use in the pattern run before or
after digitizing.

Tip Right-click to mirror the pattern.

8 Press Esc to finish.
Note Each pattern is treated as a single grouped To apply a pattern run
object. To edit only a section of a pattern, ungroup 1 Click the Pattern Run Outline icon.
it first. See Grouping & splitting objects for details.
The stitch type will be applied to new or selected
objects based on current settings.

Creating pattern runs

2 Digitize an outline for the run to follow. See
Digitizing Methods for details.

Pattern Run Outline is a stitch type that creates
pattern repeats along a digitized line. You can create
decorative outlines using any pattern from the
selection list. You can modify the rotation angle,

3 To change settings, double-click or right-click the
object.
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The Object Properties > Outline Stitch dialog
opens.

Select Pattern
Run Outline
Click to select
pattern

4 If not already selected, select Pattern Run
Outline from the Stitch Type list and click
Select.

Tip If the pattern run does not pick up the color
you have selected in the color palette when first
digitized, select the outline after digitizing, then
select a color.

Adjusting pattern run settings
You can insert a pattern run at its original size and
orientation, and then adjust settings later. You can
also set the exact size and spacing before you insert
the pattern run. Spacing is the distance between each
pattern repetition. See Applying pattern runs for
details.

The Select Pattern dialog opens showing all
available patterns in the current set.
Select viewing mode

Initial spacing

Select
pattern set

Select
pattern

Tip Select a viewing mode – you can list patterns
by picture, name, or both.

5 Select a pattern set from the droplist and select a
pattern from the display panel. See also Pattern
Stamp, Run & Fill Samples.

6 Click OK.

Adjust pattern
run settings

7 Adjust pattern run settings. See Adjusting pattern
run settings for details.

8 Click Apply.
The digitized object is outlined with the selected
pattern run. See also Reshaping pattern runs.

Spacing increased

If they do not fit the baseline exactly, BERNINA
Embroidery Software adjusts the spacing to make
them fit:
 If the space remaining at the end of the baseline is
less than half a pattern, the extra space is spread
evenly between the patterns.
 If the space is larger than half a pattern, BERNINA
Embroidery Software inserts an extra pattern, and
slightly overlaps the patterns to distribute them
evenly along the baseline.
Tip You can reshape the baseline to achieve the exact
spacing you require. See Reshaping pattern runs for
details.
To adjust pattern run settings

1 Select the pattern run object.
2 Double-click or right-click the object.
The Object Properties > Outline Stitch dialog
displays.

Adjust
pattern size
and spacing

BERNINA® Embroidery Software : Reference Manual

206

Chapter 23 : Embroidery Patterns

3 Enter the pattern size in the Size field.

2 Drag the reshape nodes to change the appearance
of the pattern run.
Drag to move
individual patterns

Drag to scale pattern height
Drag to scale patterns
proportionally
Drag to scale patterns
horizontally
Drag to change baseline
length and orientation

Size increased

Default size

Size decreased

3 Press Esc to finish.

4 Adjust the Spacing.
Default patterns

Individual
pattern moved
Spacing decreased

Default spacing

Pattern width
decreased

Baseline length and
orientation changed

Pattern height
increased

Pattern size increased
proportionally

Spacing increased

5 Click Apply.
Tip You can also resize pattern runs using the
selection handles. See Scaling objects for details.

Reshaping pattern runs

Creating pattern fills
Pattern Fill is a decorative stitch used for filling
closed objects. Patterns are repeated in parallel rows
to fill a shape. You can design the pattern layout
on-screen or by adjusting object properties.

Click Transform > Reshape Object to view the
reshape nodes of a selected object.
Reshape pattern runs with the Reshape tool in the
same way as you reshape lettering objects. You can
make pattern runs taller or narrower, rotate pattern
runs, move individual patterns along the baseline or
reshape the baseline. You can rotate, skew and mirror
pattern runs just like other objects.

Note You can also create artistic stitch effects with
craft stitches and fancy fills. See Creating craft
stitches and Creating fancy fills.

Adding pattern fills
To reshape pattern runs

1 Select a pattern run and click the Reshape icon.
Reshape nodes appear around the object.

Use Stitches > Pattern Fill to create decorative fill
stitching. Choose from pattern library.
Use Pattern Fill with filled objects to create
decorative fill stitching. Current values are set in the
Fill Stitch tab of the Object Properties dialog. You
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can select patterns, adjust settings, or change layouts
at any time before or after digitizing.

5 Select a pattern set from the droplist and a pattern
from the display panel. See also Pattern Stamp,
Run & Fill Samples.

6 Click OK.
The selected pattern is displayed in the preview
panel.

Preview
displayed

To add a pattern fill

1 Click the Pattern Fill icon.
The stitch type will be applied to new or selected
objects based on current settings.

2 Create a closed shape and select. See Digitizing
Methods for details.

7 Adjust pattern layout by changing settings or
on-screen. See Adjusting pattern fill settings or
Laying out pattern fills on-screen.
Note Stitch angle has no effect on the pattern
layout.

8 Click Apply.
Tip If the pattern fill does not pick up the color
you have selected in the color palette when first
digitized, select the outline after digitizing, then
select a color.

The digitized object is filled with the selected
Pattern Fill.

3 To change settings, double-click or right-click the
object/s. The Object Properties > Fill Stitch
dialog opens.

Click to select
pattern

Tip Wave Fill lets you contour fill stitches along
a digitized guideline. Wave Fill can be applied to
Pattern Fill objects. However, you need to first
apply the effect to a Step fill before converting to
a Pattern Fill. See also Creating wave effects.

4 Click Select. The Select Pattern dialog opens
showing all available patterns in the current set.
Select viewing mode
Select
pattern set
Step stitch used
Select
pattern

Tip Select a viewing mode – you can list patterns
by picture, name, or both.

Wave Effect
applied

Pattern Fill
selected

Creating alternating pattern fills
Use Stitches > Pattern Fill to create decorative fill
stitching. Choose from pattern library.
Digitize closed fill objects with Pattern Fill or apply it
to existing objects. Select from a wide range of
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patterns in the Object Properties dialog. You can
mix and match different motifs for forward and
backward rows, or use the same motif for each.

Tip As an alternative, you can generate layers of
colored motifs by duplicating an object and
selecting a different color and/or motif.

To create an alternating pattern fill

1 Digitize a closed object and apply a pattern fill.
As soon as entry and exit points are entered,
stitches are generated using current settings.
Stitch angle has no effect on motif layout.

Adjusting pattern fill settings

Fill icon.

You can insert a pattern fill at its original size and
orientation, and then adjust settings later. You can
also set the exact size and spacing as you insert the
pattern fill. Spacing is the distance between each
pattern repetition. See also Adding pattern fills.

The Object Properties > Fill Stitch > Pattern
dialog opens.

To adjust pattern fill settings

2 Double-click the object or right-click the Pattern

1 Double-click or right-click a pattern fill object.
Select pattern for
alternate rows

The Object Properties > Fill Stitch dialog opens
with the current pattern in the preview panel.

Preview
displayed

Combined
pattern displayed

3 For your primary row, click Select and select a
pattern from the Select Pattern dialog. The
selected pattern is displayed in the preview panel.

4 For you alternate row, click the Alternate
Pattern checkbox and choose a complementary
pattern. The combined patterns are displayed in
the preview panel.

2 Change the current fill pattern as required. See
Adding pattern fills for details.

3 Adjust Size X, Size Y, Column Spacing, Row
Spacing settings as required.

X: 12, Col Sp: 12
Y: 12, Rw Sp: 12

X: 9, Col Sp: 12
Y: 9, Rw Sp: 12

X: 9, Col Sp: 9
Y: 9, Rw Sp: 9

BERNINA® Embroidery Software : Reference Manual

209

Chapter 23 : Embroidery Patterns

4 Adjust Row Offset as required (from -99.99mm
to 99.99mm).

Tip Generally you define the layout of the fill before
digitizing the object. If it is important to align the
patterns with the object boundary, digitize the object
using the current settings, and change the layout
afterwards.
To lay out pattern fills on-screen

Row offset: 0.00

Row offset: 2.00

Row offset: 5.00

5 Adjust Rotation Angle as required (from -180° to
+180°).

1 Double-click or right-click a pattern fill object.
The Object Properties > Fill Stitch dialog
opens.

This field sets the current rotation angle of the fill
pattern (default is zero), and defines the
orientation of the entire pattern fill.

Click to adjust pattern layout
Rotation angle: 0°

Rotation angle: 15°

Rotation angle: 45°

6 Click Apply.
The digitized object is filled with the selected
pattern fill, current settings applying.
Note If more than half a pattern is outside the
boundary, it will be clipped along the boundary.

Laying out pattern fills on-screen
You lay out pattern fills on-screen by using
‘guide-patterns’ to scale, space, transform and offset
the entire pattern fill. There are three blue
guide-patterns. Other sample patterns appear in
yellow. Each guide-pattern lets you change different
elements of the layout. When you change a
guide-pattern, all patterns in the fill change
accordingly.

2 Click Layout.
The Object Properties dialog temporarily closes
allowing you to see and edit the layout guides.
Yellow sample and blue guide-patterns appear in
the design window. When you change a
guide-pattern, all patterns in the fill change
accordingly.
Tip Zoom in to select the correct guide-pattern.

3 Adjust the guide-patterns to achieve the effect you
require.
 Move patterns by selecting the middle
guide-pattern and dragging it to a new position.
 Scale patterns by selecting a guide-pattern
and resizing it using the selection handles.
Scale
proportionally
Scale
horizontally

Tip You can also use this method to adjust the layout
of Blackwork Fill, Candlewicking Fill and
Lacework.
Use top guide-pattern to change row spacing,
row offset, and to scale all patterns
Use side guide-pattern to change column
spacing, and to scale all patterns

Scale
vertically

 Rotate patterns by clicking the middle guide
twice to display the rotation handles. Click a
corner handle and drag to rotate.

Use middle guide-pattern to move,
rotate, skew, and scale all patterns
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 Skew patterns by clicking the middle guide
twice, then dragging the skew handles.

To save a pattern

1 Select the embroidery object/s you want to save.

Rotate
Anchor
Skew

Tip To create objects with holes, see Adding &
filling holes for details.
 Change column spacing by selecting the side
guide and dragging it left or right.

2 Select Settings > Create Pattern.
The Create Pattern dialog opens.

Change
column
spacing
Select pattern
set

 Change row spacing by selecting the top
guide and dragging it up or down.
 Change row offset by selecting the top guide
and dragging it left or right. Changing the offset
distorts the rows.
Change
row
spacing
Change
offset

Enter name for
new pattern

My Pattern Set

Smiley

3 Select a pattern set from the droplist.
Note Choose the pattern set carefully so you
remember where you have stored your patterns.
See also Creating your own pattern sets.

4 Enter a name for your new pattern.
5 Click OK.
You are prompted to digitize reference points.

6 Click to mark two reference points for the pattern.
These determine the default pattern orientation.

4 Press Enter to finish.
The Object Properties dialog re-opens allowing
you to apply any other settings. The adjusted size
and layout are applied to the selected object and
become the current Pattern Fill settings.

2

1

1

Managing patterns
2

BERNINA Embroidery Software provides various ways
to manage your patterns including making pattern
sets, saving patterns, and deleting patterns.

1

2

Saving your own patterns
The Create Pattern function lets you save your own
patterns for future use. Store them in your own or an
existing pattern set. They can be used in pattern fills
or runs, or even as pattern stamps.
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Reference points also determine default pattern
spacing.

To delete a pattern

1 Click Object Properties icon.
2 Select Pattern Run Outline from Outline Stitch

2

1

tab or Pattern Fill from the Fill Stitch tab.
Select Pattern
Run Outline
2

1

Click to access
pattern library

7 A confirmation message appears.

3 Click Select.
The Select Pattern dialog opens showing all
available patterns in the current set.

8 Click OK.
Tip Test your new pattern. See Adding pattern
stamps, Creating pattern runs, and Creating
pattern fills.

Creating your own pattern sets

Select
pattern set

My pattern set

Select pattern
to delete

The Create Pattern function lets you create your
own pattern sets to organize and classify your
patterns.
To create your own pattern set

1 Select the object/s you want to save as a pattern.
See Saving your own patterns for details.

Click to delete

2 Select Settings > Create Pattern.
The Create Pattern dialog opens.

Tip Select a viewing mode – you can list patterns
by picture, name, or both.

4 Select the pattern set you saved your pattern/s to.
5 Select the pattern you want to remove and click
Click to create new
pattern set

Delete.
A confirmation message appears.

6 Click OK.
3 Click New Set.
The New Pattern Set dialog opens.

Enter name for
pattern set

My pattern set

4 Enter a name for the new pattern set and click OK.
The Pattern Set is ready for use.

Deleting patterns
Click Object Properties (General toolbar) to delete
patterns.
Delete any patterns you no longer want from a
pattern set. You can only delete your own patterns.
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CHAPTER 24
DIGITIZING FOR APPLIQUÉ
Appliqué is an important craft in home
sewing, and the Appliqué feature
provides an easy way to create quality
work. Use Appliqué to generate the
stitching you require for closed-object
appliqué. Up to four layers of stitching
– placement lines, cutting lines,
tackdown and cover stitches – are
generated. Using the Remove Appliqué
Overlaps tool, you can create appliqué
objects with partial cover stitching to
create overlaps without doubling-up
borders. Sometimes you require added
flexibility to extend the range of
designs that can be sewn. For instance, designs containing open objects cannot
be handled by Appliqué. In such cases, the special Advanced Appliqué tool allows
you to generate ‘open-object appliqué’ from one or more source objects.
This section covers creating closed-object appliqué as well as partial cover
appliqué. It also discusses creating open-object appliqué.

Creating closed-object appliqué
Use Appliqué to produce the stitching you require for
closed-object appliqué. You digitize the border around
an appliqué shape in much the same way as an
closed-object embroidery object. You can control
various settings including cover stitch type – Satin or
Blanket – width, stitch spacing, as well as offset. Up
to three types of ‘secondary object’ can be
automatically generated:
 Placement lines: Optionally, placement lines are
used to position applique fabrics or pre-cut
patches on the background fabric.
 Cutting lines: Optionally, cutting lines form a
guide when trimming the fabric of an appliqué
patch ‘in situ’.

Tip You can also create appliqué objects with partial
cover stitching to create overlaps without doubling-up
borders. See also Creating partial cover appliqué.

Creating appliqué with Appliqué
Use Digitize > Appliqué to digitize closed-object
appliqué with all necessary stitching.
Use Appliqué to generate the stitching you require
for closed-object appliqué. Up to four layers of
stitching – placement line, cutting line, tackdown and
cover stitch – are generated. Options determining
single or multiple boundaries as well as frame-out

 Tackdown: This is a zigzag or run stitch placed
after placement and cutting lines, and used to fix
appliqué patches to the background fabric before
cover stitching is applied.
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position are set in the Options dialog. See Setting
appliqué options for details.

 Automatic: If activated, the frame-out
position is determined automatically.
 Manual: If activated, click the point where the
frame-out position is to be.
Frame out
position

 Place Under Cover Stitches: If activated, the
frame-out position is placed at the location of
the last needle penetration before the
frame-out would occur.

Tip When you stitch out an appliqué object, the
machine stops between layers. Before you begin to
7 Press Enter.
stitch the appliqué, lay the fabric over the design and
The shape is closed and up to four layers of
start the machine. When the guideline has been
stitching generated – placement line, cutting line,
stitched, trim the excess appliqué material and start
tackdown and cover stitch – depending on current
the machine again for the tackdown and cover stitch.
settings. See Adjusting Appliqué settings for
details.
To create appliqué using Appliqué

1 Load a picture. See Loading vector artwork for
details.

2 Click the Appliqué icon in Design or Artistic
View.

3 Digitize the appliqué outline by marking reference
points around the shape.

Placement
line (pink)
Cutting line
(purple)
Zigzag
tackdown
(green)

 Click to create a corner point.
 Right-click to create a curve point.

Satin cover
stitch

Note The Ungroup command is not available
when an Appliqué object is selected. If you wish to
access component objects, use the Break Apart
tool. See Splitting into component objects for
details.

Adjusting Appliqué settings

Tip Follow the prompts in the Status Bar to help
you digitize. If you make a mistake, press
Backspace to delete the last reference point, then
continue digitizing.

4 Press Enter to close the shape.
5 Click the outline to set the stitch entry and exit
points or press Enter to accept the defaults.

6 Depending on the selected frame-out method, you

Use General > Object Properties to set current
properties.
The cover stitch is the border around the appliqué
shape. You can control various settings including
cover stitch type, width, stitch spacing, as well as the
offset in relation to the digitized outline.
To adjust Appliqué settings

1 Double-click or right-click an Appliqué object.

may be prompted to mark the frame-out position.
See Setting appliqué options for details.
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The Object Properties > Appliqué dialog opens.

Tip To adjust settings prior to digitizing, with no
objects selected, access the Object Properties >
Appliqué dialog.

2 In the Cover stitch panel, select the required

and spacing settings. Tackdown width cannot be
greater than the cover stitch width.

Tackdown stitch
width: decreased
spacing: increased

Tackdown stitch
width: default
spacing: default

Tackdown stitch
width: increased
spacing: decreased

cover stitch type – Satin or Blanket.
Note By default cover stitching is activated. This
control allows compatibility between appliqués
created in Explorations which has a ‘No Border’
option, and those created in BERNINA Embroidery
Software.

3 Adjust cover stitch width and spacing as required:
 Width: Enter the width of the Satin or Blanket
column.

Note Tackdown stitching is not available for
Blanket cover stitch.

5 Select required appliqué styles.
Two options are available – Placement Line and
Cutting Line. Use placement lines as a guide to
place pre-cut fabric patches. Use cutting lines to
hold down uncut patches so that they can be cut in
place.

Select placement
and/or cutting lines

6 Use the slider to offset the cover stitch relative to
– inside or outside – the placement line.
Satin Width: 2.5 mm

Satin Width: 1.0 mm

 Spacing: Enter the stitch spacing of the Satin
or Blanket column.

Blanket Spacing: 1.3 mm

Adjust cover
stitch and
tackdown offset

Blanket Spacing: 2.0 mm

4 If using Satin cover stitch, select the Use
Tackdown checkbox as required and adjust width

BERNINA® Embroidery Software : Reference Manual

215

Chapter 24 : Digitizing for Appliqué
Satin defaults to none while Blanket defaults to
100% inside.

between fabrics or plain colors. By default the
Fabrics option is selected.

Select
between
fabrics or
plain colors

Offset: inside

Offset: none

Offset: outside

7 Click Apply.
Current settings are applied to selected objects.

Click node to
view available
range

Placing fabrics in Appliqué designs
Use View > Show Appliqué Fabric to show or hide
background fabric / color of any appliqué objects in
the design.
The Object Properties > Appliqué dialog contains
a Fabric panel which allows you to choose a fabric or
plain color to assign to your appliqué patch.

To place fabric in an Appliqué design

1 Double-click or right-click an appliqué object.

3 Scroll down the display panel to find a suitable
category and click a node on the fabrics tree to
view the available range – e.g. ‘Anniversary
Florals’.

4 Click OK to apply it to the selected appliqué object.

Note The Benartex range is displayed as in Patch
Properties dialog. See Creating open-object
appliqué for details.

5 If you prefer to assign a color to your appliqué
patch, select the Color option.

The Object Properties > Appliqué dialog opens.
Swatch showing current
fabric used for appliqué
Click to choose
fabric or color

2 Click Choose to choose a fabric or plain color in
the Fabric panel to assign to your appliqué patch.
The Appliqué Fabric dialog opens. The
Fabric/Color/None options allow you to select
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The Appliqué Fabric dialog updates to display a
range of colors.

To create partial cover appliqué

1 Create appliqué shapes with Appliqué. See
Creating appliqué with Appliqué for details.

Click to
choose color

2 Select the appliqué objects.

6 Select a tonal range – Light, Mid or Dark – and
choose a color.

3 Click the Remove Appliqué Overlaps icon.
Cover stitches are removed where objects overlap,
leaving only the secondary objects – tackdown,
placement and cutting lines.

7 Click OK to close the dialog and put the fabric into
the Object Properties > Appliqué dialog.

Swatch showing
current fabric or
color

Partial cover

Unstitched part
of boundary

8 Click Apply to apply it to the selected appliqué
object.

Creating open-object appliqué
Tip Use the Show Appliqué Fabric toggle to
turn appliqué fabrics/colors display on/off.

Creating partial cover appliqué

Appliqué is an important craft in home sewing, and
the Appliqué feature provides an easy way to create
high quality work. However, sometimes you require
added flexibility to extend the range of designs that

Click Edit > Remove Appliqué Overlaps to remove
unwanted stitching from underlaying appliqué
objects.
Using the Remove Appliqué Overlaps tool, you can
create overlapping appliqué objects with partial cover
stitching without doubling-up borders. The lower
layers will have partial appliqué applied to them.
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can be sewn. For instance, designs containing open
objects cannot be handled by Appliqué.

Boundaries can be defined by a mixture of objects as
shown here:

Satin outline

Block Digitized
Object (Block)

Blanket stitch
outline

In this design, the stem in the center of the leaf must
be sewn after the placement and cutting lines around
the leaf outline but before the cover stitches. There
may be one or two fabric areas. If there is only one
patch, the stem will not require placement or tacking
stitches. If there are two patches, the stem, as well as
the outline, must have placement and tacking
stitches.
Another problem is illustrated by the rabbit design
below. The entire shape is composed of open curves
whose stitching order is crucial – e.g. the left ear must
be on top. The interior of the rabbit needs to be filled
with fabric, even though none of its component
curves is closed.

Patch

Primary objects
Source or ‘primary’ objects used in the creation of
open-object appliqué must be created and sequenced
before the feature is applied. These objects are not
affected in any way by their incorporation into
open-object appliqué. Several types of source object
can be used:
 Any outline stitch type – Single Run, Satin Outline,
etc,
 Any closed-object filled object, or
 Any block-digitized object.
Some other object types can be used as input in
combination with the above objects. These include
lettering objects, auto-appliqués and even other
open-object appliqués.

Note If BERNINA Embroidery Software detects more
than one area, you have the option of joining them
into one patch. See Merging & unmerging patches for
details.
Secondary objects
Up to three types of ‘secondary object’ can be
automatically generated:

In both cases, you want to be able to enter the curves
in as natural an order as possible and have the
software correctly interpret where the enclosed areas
are to be. To this end the special Advanced Appliqué
tool allows you to generate ‘open-object appliqué’
from one or more source or ‘primary’ objects.

 Placement lines: These are, optionally, the first
appliqué layer to be stitched. Placement lines are
used to position pre-cut appliqué patches on the
background material.
 Cutting lines: Again optionally, cutting lines form
a guide when trimming the fabric of an appliqué
patch ‘in situ’.
 Tackdown: This is a zigzag or run stitch placed
after placement and cutting lines, and used to fix
appliqué patches to the background fabric before
cover stitching is applied.
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Each ‘boundary segment’ will generate a placement
line, cutting line and/or tackdown depending on
current settings.

2 Set the stitching properties and sewing sequence
of these objects.

3 Select all objects to be included in the open-object
appliqué and click the Advanced Appliqué icon.

Note Secondary objects are stitched before primary
objects and are therefore shown beneath. You can
assign thread colors to each secondary object or let
BERNINA Embroidery Software decide.

Creating open-object appliqué design

BERNINA Embroidery Software determines
whether a selection contains at least one allowable
boundary object and whether an area has been
properly enclosed. If these conditions are met, an
open-object appliqué object is created and the
Appliqué Properties dialog opens.

Use Digitize > Advanced Appliqué to generate
open-object appliqué from one or more source
objects.
Several types of ‘primary object’ can be used in the
creation of open-object appliqué, including any
outline stitch type – Single Run, Satin Outline, etc –
any filled object, or any block-digitized object.
Additionally, some other objects can be used as input,
including lettering objects, auto-appliqués or even
other open-object appliqués.

Areas enclosed by
allowable boundary
objects marked with
hashing in white

Note Shapes are ‘corrected’ when an open-object
appliqué is first created. This may have the effect
of removing small detail segments. However,
primary objects are unaffected.

4 Click Place Fabric and Color in Patches option
to add fabric or color. See Placing fabric in patches
and Placing color in patches below for details.
Note By default, designs are automatically grouped
upon opening or insertion into another design. When
you open an appliqué design after saving, you will
need to ungroup it before you can access appliqué
properties. See Setting other general options for
details.
To create an open-object appliqué design

1 Create the objects you want to include in your
cover stitching of the appliqué design. See
Digitizing open shapes for details.

5 Click Back when complete.
6 Click Close to close the dialog.
Tip Open-object appliqué objects can be selected
and manipulated in the same way as a grouped
object – i.e. they can be moved, resized, skewed
or rotated, using the same click and drag method
applying to all objects. Reshaping of open-object
appliqué objects, however, is not possible. Nor is
there any way to select individual objects, primary
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or secondary, within open-object appliqué unless
the object is first ‘broken apart’. See Splitting into
component objects for details.

Placing fabric in patches
Use View > Show Appliqué Fabric to show or hide
background fabric / color of any appliqué objects in
the design.
You can add fabric swatches to open-object appliqué
when it is first created or at any later stage.

3 Select a fabric from the fabrics tree – e.g. ‘Vintage
Shirtings’ – or from the Used Fabrics and Colors
palette.

4 Move the cursor over the design area.
A white outline appears around any closed area
over which the cursor passes.

5 Click an area which is currently hashed or filled.
The area is filled with the chosen fabric and a
swatch added to the Used Fabrics and Colors
palette.

To place fabric in patches

1 If editing an existing open-object appliqué object,
double-click or right-click the object.
The Appliqué Properties dialog opens (or will
already be open if you have just created the
object).

Note For any new patches created, secondary
stitching objects are created using default stitch
types and automatic stitch colors. See Setting
stitch colors and Setting stitch types for details.

6 Select other areas as required to add more
patches.

7 Click Back when complete.
8 Click Close to close the dialog.

2 Click the Place Fabric and Color in Patches
option.
The dialog changes to display the Place Fabric in
Patches panel.

Alternatively, click Place Color in Patches or
Remove Fabric from Patches for more options.
See Placing color in patches and Removing fabric
or color from patches below for details.
Tip Use the Show Appliqué Fabric toggle to
turn appliqué fabrics/colors display on/off.

Placing color in patches
Use View > Show Appliqué Fabric to show or hide
background fabric / color of any appliqué objects in
the design.
You can add color, in place of fabric swatches, to
open-object appliqué when it is first created or at any
later stage.
A white outline appears
around any closed area
where the cursor passes.

To place color in patches

1 If editing an existing open-object appliqué object,
double-click or right-click the object.
Note There may already be pre-selected entries
in the Used Fabrics and Colors palette.
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The Appliqué Properties dialog opens (or will
already be open if you have just created the
object).

2 Click the Place Fabric and Color in Patches
option.
The dialog changes to display the Place Fabric in
Patches panel. There may already be
pre-selected entries in the Used Fabrics and
Colors palette.

The area is filled with the chosen color and a color
sample added to the Used Fabrics and Colors
palette.

Note For any new patches created, secondary
stitching objects are created using the default
stitch types and automatic stitch colors. See
Setting stitch colors and Setting stitch types for
details.

7 Select other areas as required to add more colors.
8 Click Back when complete.
9 Click Close to close the dialog.
Alternatively, click Place Fabric in Patches or
Remove Fabric from Patches for more options.
See Placing fabric in patches and Removing fabric
or color from patches below for details.
Tip Use the Show Appliqué Fabric toggle to
turn appliqué fabrics/colors display on/off.

Removing fabric or color from patches
A white outline appears
around any closed area
where the cursor passes.

You can remove colors or fabrics from open-object
appliqué at any stage.
To remove fabric or color from patches

Note There may already be pre-selected entries
in the Used Fabrics and Colors palette.

3 Select a tonal range – Light, Mid or Dark – using

1 Double-click or right-click the open-object
appliqué object.
The Appliqué Properties dialog opens.

one of the three switches at the top of the palette.

4 Select a color from the palette.
5 Move the cursor over the design area.
A white outline appears around any closed area
over which the cursor passes.

6 Click an outlined area which is currently hashed or
filled.

2 Click the Remove Fabric from Patches option.
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The dialog changes to display the Remove Fabric
from Patches panel.

3 Move the cursor over the design area.
A white outline appears around any closed area
over which the cursor passes.

4 Click an outlined area which is currently filled.

require placement or tacking stitches. In this case,
the two fabric areas need to be merged into one.

To merge and unmerge patches

1 Double-click or right-click the Advanced Appliqué
object.
The Appliqué Properties dialog opens.

The patch fabric or color is replaced with white
hashing and all associated secondary objects
removed.

Note The fabric or color is also removed from the
Used Fabrics and Colors palette if this was the
only instance of that fabric or color.

2 Select the Merge Patches Together option.
The Merge Patches Together panel is displayed.

5 Select other areas as required to remove more
patches.

6 Click Back when complete.
7 Click Close to close the dialog.
Alternatively, click Place Fabric in Patches or
Place Color in Patches for more options. See
Placing fabric in patches and Placing color in
patches below for details.

Merging & unmerging patches
In the sample below, there may be one or two fabric
areas. If there are two patches, the stem, as well as
the outline, must have placement and tacking
stitches. If there is only one patch, the stem will not

3 Select the patch to merge.
A red line appears around its border.

4 Hover the cursor over the second patch.
This patch may or may not be filled with fabric or
color. A white line appears around its border.

5 Click the patch.
The two patches are merged into a single patch
taking the fabric or color of the first one. All
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secondary stitching is removed from the boundary
segments previously shared by the patches.

The Appliqué Properties dialog opens.

Tip To unmerge a merged patch, click the
Unmerge Patches option at any stage and click
a merged patch.

2 Select the Set Colors Automatically option.
The Automatic Stitch Colors dialog opens.

The merged patch is broken into its original
patches, each with their current (not original)
fabric or color. New secondary objects are created
for shared boundaries.

6 Click Back to complete.
7 Click Close to close the dialog.
Tip Use the Show Appliqué Fabric toggle to
turn appliqué fabrics/colors display on/off.

3 Choose an automatic color scheme from the
available options:
 Match color of cover stitching: If selected,
all secondary objects are shown in the color of
their associated primary objects.
 Special colors for each layer: If selected, all
secondary objects are shown and stitched in
the colors displayed here (chosen for visual
clarity on screen).

Setting stitch colors
You can either set colors automatically or manually.
For any newly created open-object appliqué,
secondary objects are created using the automatic
stitch colors. Two options are available: Special
colors for each layer and Match color of cover
stitching. See also Setting stitch types.
To set stitch colors

1 Double-click or right-click the Advanced Appliqué
object.

Note You would not normally use actual threads
in the display colors but a single thread color for all
secondary objects closely matching the fabric on
which the appliqué is to be stitched.

4 Click OK to complete.
5 Click Close to close the dialog.

Setting stitch types
You have two options when it comes to setting stitch
types to use for secondary objects: automatic or
manual. To set stitch types automatically, you simply
click the Set Stitch Types Automatically option in
the Applique Properties dialog. Stitch types for all
tackdowns are set according to the cover stitch type
as follows:
 If the cover stitches are Satin Outline, Satin Fill,
Step fill or Fancy Fill, the tackdown is set to Zigzag.
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 If the cover stitches are anything else, the
tackdown is set to Run stitch.
If you require greater control over stitch types used
for placement lines, cutting lines, and tackdowns, use
the following procedure. When you set colors
manually, any change you make overrides
automatically chosen colors.
To set stitch types

1 Double-click or right-click the Advanced Appliqué
object.
The Appliqué Properties dialog opens.

4 Select the secondary objects you want included in
your open-object appliqué:
 Placement lines: These are, optionally, the
first appliqué layer to be stitched. Placement
lines are used to position pre-cut appliqué
patches on the background material.
 Cutting lines: Again optionally, cutting lines
form a guide when trimming the fabric of an
appliqué patch ‘in situ’.
 Tackdown: This is a zigzag or run stitch placed
after placement and cutting lines, and used to
fix appliqué patches to the background fabric
before cover stitching is applied.

5 Set the display color for each of the secondary
objects – placement lines, cutting lines, and/or
tackdown – you have selected.
Note When you set colors manually, any change
you make overrides automatically chosen colors.
See Setting stitch colors for details.

6 If you have chosen to include tackdown stitches,
select the required type:
Choose tackdown
stitch type

2 Select the Set Stitch Types Manually option.
The Set Properties Manually panel is displayed.
Zigzag: This gives you control over:
 Stitch width: sets the column width for the
Zigzag stitch.
 Spacing: sets the stitch spacing.
 Color: sets the stitch color.
 Offset: sets the cover stitching in relation to
the secondary objects as shown:

3 To make the Set Properties Manually panel
activated, select boundary segments as follows:
 By placing the mouse cursor over an individual
boundary segment, it is highlighted in white. If
you place it over a filled patch, the entire
boundary of the patch is highlighted in white. If
you then click the mouse, the highlighted
section is selected. Selected boundary
segments appear in magenta.
 By holding down the Ctrl key while a boundary
or boundary segment is highlighted, the
highlighted section is added to the selection, if
not already selected, or subtracted from the
selection if already selected.

Tackdown stitch
offset: outside
spacing: decreased

Tackdown stitch
offset: none
spacing: default

Tackdown stitch
offset: inside
spacing: increased

Run Stitch: This gives you control over:
 Stitch length: set the stitch length to suit the
digitized shape – where the object has tight
curves, select a shorter stitch length; to reduce
the stitch count for flatter curves, increase the
stitch length.
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 Color: sets the stitch color.

7 Click Back to return.
8 Click Close to close the dialog.

Recovering the original embroidery objects
Primary objects can be recovered at any time.
BERNINA Embroidery Software will remove all
secondary objects, ungroup the primary objects and
return them as individual objects. See also Splitting
into component objects.
To recover the original embroidery objects

1 Double-click or right-click the Advanced Appliqué
object.
The Appliqué Properties dialog opens.

2 Click the Recover your original embroidery
objects option.
All secondary objects are removed and all primary
objects ungrouped.

3 Click Close to close the dialog.
Note If the whole open-object appliqué had been
resized, moved, or skewed, the primary objects
are returned in this transformed state.
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CHAPTER 25
CUTWORK & STUMPWORK
BERNINA Embroidery Software
provides tools and techniques for
expanding flat embroidery surfaces
into raised or ‘sculpted’ surfaces.
Openwork or ‘cutwork’ embroidery
is a delicate form of needlework
which involves cutting away
portions of the background fabric
and binding the edges with
embroidery stitching. In addition to
reinforcing the edges, resulting
holes may be filled with embroidery
or needle lace.
Stumpwork, on the other hand, is a
raised form of embroidery. It is
created on one backing fabric and
transferred to another, ‘ground
fabric’. BERNINA Embroidery Software allows you to visualize all components of
a stumpwork design in a single design window. At the same time, it lets you edit
each stumpwork piece individually and output to machine.
This section covers tools and techniques for expanding flat embroidery surfaces
into raised or ‘sculpted’ surfaces, specifically by means of cutwork and
stumpwork.

Cutwork / stumpwork borders
BERNINA Embroidery Software allows you to create
cutwork and stumpwork designs for use with the
BERNINA CutWork Tool. Create and edit forms that
can be cut out and used in cutwork and stumpwork
designs. To achieve the desired results, you will need
a BERNINA machine capable of embroidery and the
CutWork tool which you can insert in place of the
needle. You will be amazed at the gorgeous effects
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you can achieve, whether on garments, accessories,
or quilts.

Cutwork components
Cutwork components are generated and sequenced
according to the chosen border type. Like appliqué,
cutwork objects are composite, containing multiple
embroidery and cutting components. They may
include some or all of the following:
Component

Both cutwork and stumpwork designs are created
with a common set of tools. Openwork or ‘cutwork’
involves cutting away portions of a backing fabric and
binding the edges with embroidery stitching.
Stumpwork can be made from cutwork pieces which
are sewn onto the base design, usually with the
addition of a wireline for extra stiffening.

Stabilizing
runs

These are used to reduce deformation
of the material prior to cutting or
stitching. There may be several
stabilizing runs in the one cutwork
object.

Cutting
lines

As a cutting line would be unlikely to
follow one of the standard cutting angles
– 0°, 45°, 90° or 135° – a mix of different
cutting needles is used to approximate
it. The preferred mode of operation is to
complete all cuts one cutting needle at a
time.

Tackdown
runs

These are used to attach the stabilizer
after a hole has been cut. Tackdowns
are implemented as simple runs. They
are not required for cutwork pieces.

Net fills

Net fills are stitched onto the stabilizer
inside a cut hole. They are created after
holes are cut and stabilizers tacked
down. When a fill is stitched out, the
edges are covered, typically, by a satin
or stemstitch line. Other stitch types are
available. The stabilizer is subsequently
dissolved in water so only a net of
stitches is left within the hole.

Border categories
The Cutwork Border contains three categories of
border:
Category

Use

Cut

Open or closed cutting line without any
embroidery. This can be used to create a
simple cut-out piece to be sewn on as
stumpwork.

Stumpwork / The user is interested in the cut-out piece. The
Piece
remainder will probably be discarded. This
consists of some embroidery together with the
cut. Generally pieces are used for stumpwork.
See also Digitizing stumpwork.
Hole

The user is primarily interested in the fabric
that remains after the hole is cut. The resulting
piece usually consists of some embroidery
together with the cut. These border types are
suitable for cutwork.

Use

Embroidery Depending on border type, embroidery
may be used to cover the edge of the
hole. Alternatively, it may run at a certain
distance from the cutting line and stitch
out before or after the material is cut. It
is implemented as either satin, blanket,
wireline, or stemstitch. Satin or wireline
are typically used for stumpwork. See
also Digitizing stumpwork.

Note Unlike appliqué, cutwork objects cannot be
broken into single standalone embroidery objects and
cutting line components.

Border types

The chosen border type determines which
Cutwork generally involves cutting holes within
components are included in the cutwork / stumpwork
fabrics, while stumpwork involves cutting out
stumpwork pieces, similar to badges. For this reason, object. Further modifications are possible. The border
stumpwork borders will be ‘pieces’ rather than ‘holes’.
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type also specifies component stitching order and
spacings.

Hole-2
A variant of Hole-1, this border creates a hole in fabric
with an embroidered edge but no stabilizer.

Hole-3
This border type creates a hole in fabric with a
stabilizer and a net fill. The stabilizer attached after
cutting, fixed by tackdown, then net fill and final
embroidery stitched out.

For example, the simplest border produces only
cutting lines. Alternatively, the digitized outline may
form the centerline of a satin line, while the cutting
line is calculated with a corresponding offset.
Cut
This is the simplest border type. It allows you to
create a cutting line which can be run on the machine
to cut out pieces for stumpwork or stand-alone work.
Or it may be used in conjunction with an existing satin
or other border.

Hole-4
Hole-4 border is one of the simplest types, creating an
embroidered edge followed by a hole. The cut must
not damage embroidery as it is done after. The edges
may look untidy as they are not covered.

Hole-5
Stumpwork/Piece

A variant of Hole-4, this border adds a stabilizing run
at the start.

This border type creates a cutout fabric piece with an
embroidered border. It is recommended for use with
satin cover stitch. It uses two stabilizer run passes for
easier cutting.

Cutwork interface
The cutwork interface has three main components –
a toolbox, a docker, and object properties.
Hole-1
This border type creates a hole in fabric. A stabilizer
is attached after cutting, fixed by tackdown, then final
embroidery stitched out.
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Cutwork toolbox

Object properties

The toolbox contains all tools needed to digitize
cutwork or stumpwork pieces from scratch or create
from existing embroidery.

Each component of a cutwork object has its own
object properties. For example, wireline properties
can be adjusted via a dedicated Wireline tab in the
associated Object Properties.

Cutwork toolset

Object properties for each
cutwork component

 The Digitize tools allows you to create cutwork
objects – holes or pieces – with up to five layers of
embroidery and cutting components, including
stabilizing runs, tackdown runs, cuts, embroidery,
and net fills.
 The Add Cutwork Border tool allows you to
create cutwork pieces from existing objects. This is
generally used for stumpwork.
 The Cut Closed Border tool is generally used for
stumpwork pieces which include a wireline. Use
this tool to cut a closed border and leave an
opening for wire ends. See Creating stumpwork
with a wireline for details.
Cutwork border docker

Output worksheet
In addition to thread information, the design
worksheet contains information about the cutting
needles and the order in which they will be used on
the machine. These are listed as ‘Borer-1’, ‘Borer-2’,
etc.

The Cutwork Border docker allows you to preset
options for both cutwork and stumpwork.

Border type chooser showing
typical cutwork / stumpwork styles
to choose from
Preview current border settings

Stabilizing run 1 not needed with
wireline stumpwork but may be
used to support other types of
cutwork or stumpwork
Stumpwork border embroidery –
usually wireline but may be simple
satin border or any other stitch type
Stabilizing run 2 used to
stabilize fabric for cutting
The cutting line guides the cutting
needles in cutting out the entire
cutwork or stumpwork piece

Digitizing cutwork
Openwork or ‘cutwork’ embroidery is a delicate form
of needlework which involves cutting away portions of
the backing fabric and binding the edges with
embroidery stitching. In addition to reinforcing edges,
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resulting holes may be filled with embroidery or
needle lace.

 Stitch the design onto the fabric.
 Press and stiffen it with starch spray.
 Cut out the fabric between embroidered areas
using sharp-pointed scissors.
 Make sure not to cut the embroidery threads.
 When finished, press the design once again.
Tightly woven fabrics such as linen, which do not fray
easily, are generally preferred for cutwork. Depending
on the stiffness of the fabric, stabilizers may or may
not be used. Dissolving stabilizers can be used to
temporarily stabilize the fabric while stitching, and
then dissolved away after stitching. With the
background cut away, fabric assumes a lacy
appearance.

Digitizing cutwork objects
Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.
With a suitably equipped machine, you can eliminate
most of the manual work associated with traditional
cutwork. While the process is essentially the same,
the design is stitched onto the fabric by machine and,
by attaching cutting needles, holes or pieces are cut
out. Cutting needles generally come as a set of four
(4) with angles of 0°, 45°, 90° and 135°.

General procedure
Because of the number and type of cutwork
components, the Cutwork feature is organized
around ‘border types’. The chosen border type
determines which components are included in the
cutwork object.

Use Cutwork > Digitize Piece to digitize a cutout
piece in hooped fabric, together with supporting
embroidery. Right-click for settings.
Use Cutwork > Digitize Hole to digitize a hole in
hooped fabric, together with supporting embroidery.
Right-click for settings.
Use Cutwork > Digitize Cut to digitize a simple open
or closed cut in hooped fabric. Right-click for
settings.
You digitize cutwork in much the same way as you
digitize appliqué objects. However, you first select a
border type which suits the work you are doing. If you
are planning to do stumpwork, you generally create a
cutwork piece first.
To digitize a cutwork object

1 Import suitable artwork as a digitizing backdrop.

Size the
artwork

Most cutwork follows this production process:
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2 Study the artwork carefully and decide which

9 Digitize cutwork as you would any closed object.

objects comprise cutwork and which will be normal
embroidery.

3 Size the artwork to the correct dimensions for the
intended application – e.g. tablecloth.

Digitize cutwork
border

4 Select a Cutwork tool. If you are digitizing pure
cutwork rather than stumpwork, you will only be
interested in the Digitize Hole or Digitize Cut
tools.

5 Right-click to invoke the Cutwork Border docker.
Select a border
type
Components shown in
preview and listed below

Adjust settings for
each component

10 Press Enter to close the shape.
The border is generated according to chosen
border type and settings. For example:
 A stabilizing run is applied first,
 The cut is made, and
 A satin line is applied to cover edges of the
hole.

11 Digitize the remaining cutwork objects using
suitable border types. See also Border types.

Further adjust
component settings via
object properties

Digitize remaining
cutwork components

6 Select a border type from the droplist.
Components are listed below in order of stitchout.

7 Adjust settings for the chosen border type as
preferred. Alternatively, settings can be adjusted
after digitizing.

8 If you are using embroidery, choose the type from
the Embroidery droplist and adjust settings.

Choose embroidery for
cutwork border
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12 Digitize any additional embroidery.

3 Adjust cutwork component settings – e.g.
embroidery type, net fill spacing, etc. See also
Cutwork / stumpwork borders.

Digitize additional
embroidery components

4 Access further settings via the object properties
button. For instance, to change satin border
thickness, click the icon next to Embroidery.

13 Resequence embroidery and cutwork objects as
necessary. Usually embroidery will be stitched
before cutwork. And ideally, all cutwork should be
stitched together.

Changing cutwork settings
Cutwork objects are composites made up of cutwork
components generated according to a chosen border
type. These can be changed at any time. And,
because components are embroidery objects, their
properties can be accessed and changed as well.
To change cutwork settings

1 Select the cutwork object you want to modify.
Select alternative
border type

Click to access
embroidery settings

Creating cutwork pieces from existing
embroidery
Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.
Use Cutwork > Add Cutwork Border to generate a
cutwork border from selected objects.
Frequently, you want to turn existing embroidery into
a cutwork piece. This may be standalone or, more
commonly, intended as a sub-design in a larger
design. You have two choices – either a stumpwork
border, usually with a wireline, or a simple cut. In the
scenario shown here, we turn an existing border into
a cutwork border. See also Digitizing stumpwork.

2 To change border type, select from the Border
Type droplist. Components are listed below in
stitchout order.

Adjust cutwork
component settings
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To create a cutwork piece from existing
embroidery

1 Open an existing design or digitize required
embroidery objects.

 There are a number of hole types to choose
from as well as a simple cut. See also Border
types.
 The cutwork hole also will, by default, be offset
from the originating hole. Adjust as needed.

5 Click OK. Make any additional modifications using
the Cutwork Border docker.

Change border type and
adjust cutwork settings using
the docker

Select embroidery to
use as source for
cutwork piece

2 Select all objects and click the Add Cutwork
Border icon.
The Add Cutwork Border dialog assumes you
want to create a cutwork piece. However, if your
selected object/s contain holes, you can also turn
them into cutwork.

Select a border
type for the
piece

6 Optionally, turn off Artistic View (T) to view
cutting lines.
Optionally,
include holes in
the cutwork
piece

3 Specify the border type you want to apply:
Setting

Purpose

Border type You have a choice of stumpwork piece or
simple cut.
Offset

By default, the cutwork piece will be offset
from the selected object/s by a small
margin. Adjust as necessary.

Smoothing

Depending on selected shape, adjust
smoothing with the slider bar. This
determines how closely the generated
cutwork piece follows the source.

4 Optionally, tick Include Holes if you want to turn
holes in your piece into cutwork.
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Note The resulting object can be treated as a
standalone cutwork piece or it can be easily turned
into stumpwork and incorporated into a larger
design. See Digitizing stumpwork for details.

stitches it becomes three-dimensional in contrast to
flat embroidery.

Combining cutwork components
There could be dozens of cutwork objects in an entire
design. Components belonging to separate cutwork
objects can be sequenced to minimize cutting needle
changes. When you select more than one cutwork
object, the Combine Selected button becomes
available. Click to combine all cutting lines. Cutting is
optimized so that the four cutting tool positions are
only employed once per design.

The difficulty for anyone trying to create this type of
embroidery is to visualize the complete design.
BERNINA Embroidery Software allows you to visualize
all components of a stumpwork design in a single
design window. At the same time, it lets you edit each
piece and output to machine individually. See also
Outputting stumpwork designs.
Stumpwork scenarios
Stumpwork usually conforms to one of the following
scenarios:
Click to combine
selected components

 Generate stumpwork piece from existing
embroidery.
 Digitize stumpwork pieces from scratch with
wirelines.
 Digitize additional wirelines to lend support and
shape.

Note In complicated designs containing mixed
embroidery and multiple cutwork, it may not be
possible to sequence all cutwork objects together.

Digitizing stumpwork
Stumpwork pieces are generally created on a backing
fabric and transferred to another, ‘ground fabric’. The
cut is always done last, after the embroidery. Through
the use of padding, beads, wire and/or needle lace

 Turn resulting pieces, including any additional
embroidery inside the border, into stumpwork
‘sub-designs’.

Typical stumpwork
Most stumpwork involves the use of wirelines to
provide body and shape to the raised object. The
process involves first sewing a guidetrack within
which to place the wireline. Next a tackdown is used
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to sew the wireline into position within the guidetrack.
Finally cover stitching is added, usually satin.

stumpwork pieces from scratch or create from
existing embroidery.

Use Cutwork toolset to
digitize pieces

Use Stumpwork toolset to
create stumpwork
sub-designs

Stumpwork components
Stumpwork consists of some or all of the following
digitized components. Each is separated in the
stitching sequence by a machine stop.
Components
Stabilizing
run 1

Notes
This is internal to the stumpwork. It is
not needed with wireline embroidery
but may be required with other types.
Stabilizing runs are used to reduce
any deformation in the material prior to
embroidery.

Embroidered Typical stumpwork makes use of a
border
wireline but other borders may be
used.
Stop

If you use wireline, all necessary
stitching and stops are included to
allow you to place and sew the
wireline.

Stabilizing
run 2

This is external to the stumpwork. This
is generally used to stabilize the fabric
for cutting.

Stop

Change to a cutting tool or cut
stumpwork out by hand.

Cutting line

Currently, a cutting line is
automatically generated for cutting
needles to follow.

Stumpwork toolset
In BERNINA Embroidery Software, stumpwork is
considered a form of cutwork. It involves firstly the
creation of cutwork pieces and then their
transformation into stumpwork sub-designs. The two
toolboxes contain all tools needed to digitize

 The Digitize Piece tool allows you to create
cutwork objects with up to five layers of
embroidery and cutting components, including
stabilizing runs, tackdown runs, cuts, embroidery,
and net fills.
 Alternatively, the Add Cutwork Border tool
allows you to create stumpwork pieces from
existing embroidery.
 The Stumpwork toolset allows you to create
cutwork ‘sub-designs’. In effect, these are
embedded designs which are displayed as part of
the ‘base design’ but are not included in the
stitchout. Instead, they are stitched out as
separate components.
Production recommendations
Here are some recommendations for producing
stumpwork on the machine:
 Use the 44C foot. It is transparent and is large
enough to help hold the wire in place as it is tacked
down.
 Use a foot control when tacking down the wire –
it’s easier to stop and start that way.
 Reduce to slow speed with the sliding speed
control.
 After the wire is tacked down, it is ok to stitch at
fast speed.
 When working with a stumpwork piece that has
additional wirelines – such as a leaf with central
veins – make sure the internal wires do not overlap
the border.
 Alternatively, cut the internal wires slightly short.
This means that stitching can continue right up to
the border, thereby avoiding unwanted gaps.

Visualizing stumpwork
Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.
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Use Stumpwork > Open Stumpwork Sub-design to
view and edit the stumpwork sub-design.
Click General > Print Preview to preview the print
preview onscreen.

To print out a worksheet for the stumpwork portions
of a design, open the stumpwork object in its own
window and preview it there.

Use the Show Stumpwork toggle on the View
toolbar to show or hide stumpwork objects within a
design.

Stumpwork design
element printed
separately

Tip Study the Stumpwork_Sample3 design included
in the designs folder. Try stitching it out to practice the
techniques involved. Check your BERNINA machine
documentation.
The worksheet preview shows the entire stumpwork
design in preview but only the base design in the color
film.

Creating stumpwork from existing embroidery
Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.
Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.
Use Cutwork > Add Cutwork Border to generate a
cutwork border from selected objects.

Base design
appears in color
film

Use Cutwork > Cut Closed Border to cut a closed
cutwork border and leave an opening for wire ends.
Use Stumpwork > Create Stumpwork Sub-design to
create stumpwork from a selected cutwork piece.
Use Stumpwork > Open Stumpwork Sub-design to
view and edit the stumpwork sub-design.
Creating stumpwork from existing embroidery is
probably the most common stumpwork scenario. It
usually involves a two-step process:
 Select embroidery shapes and turn them into
cutwork pieces.
 Turn those cutwork pieces into stumpwork
sub-designs within a larger design.
The resulting stumpwork embroidery is usually sewn
out separately with wire and border. It is then cut out
and sewn or attached to the base design. Required
tools are shown above.
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To create stumpwork from existing embroidery

Open Stumpwork Sub-design. See Editing
stumpwork for details.

1 Open an existing design or digitize embroidery
objects as required. Add any stitch effects you
want.

Base embroidery from
which stumpwork will
be created

2 Select all objects and click Add Cutwork Border
to create the stumpwork piece. See Creating
cutwork pieces from existing embroidery for
details.

3 Once the cutwork piece is created, select it and
use the Cut Closed Border tool to leave an
opening for wire ends. You are prompted to mark
a cutting point.

Choose where to
create opening for
wire ends

4 Select the resulting object group and click Create

Stumpwork objects
placed at end of stitching
sequence

Tip Study the Stumpwork_Sample2 design included
in the designs folder. Try stitching it out to practice the
techniques involved. Check your BERNINA machine
documentation.

Stumpwork Sub-design.
Selected objects are bundled into a composite
stumpwork object which effectively resides on a
separate ‘layer’ to the base design. It can be
edited independently by double-clicking or clicking

Creating stumpwork with a wireline
Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.
Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.
Use Cutwork > Digitize Piece to digitize a cutout
piece in hooped fabric, together with supporting
embroidery. Right-click for settings.
Use Cutwork > Cut Closed Border to cut a closed
cutwork border and leave an opening for wire ends.
Use Stumpwork > Digitize Wireline to add a
stumpwork wireline to an existing piece. Right-click
for settings.
Use Stumpwork > Create Stumpwork Sub-design to
create stumpwork from a selected cutwork piece.
Use Stumpwork > Open Stumpwork Sub-design to
view and edit the stumpwork sub-design.
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Use Stumpwork > Save Stumpwork Sub-design As
to save a stumpwork sub-design as a separate
design file.

If you choose Wireline as your embroidery type,
the following properties can be set:
Setting

Digitizing with wire and fabric is probably the
commonest scenario for creating stumpwork. This
involves digitizing a simple cutwork piece and turning
it into a stumpwork sub-design. This is then sewn
onto a separate piece of fabric, often patterned, with
the inclusion of a wire, and then cut out and attached
to the base design. Required tools are listed above.

Notes

Tackdown The gauge of wireline you are using
stitching
determines the width of guidetrack and
tackdown stitching. You can choose to factor
it into your cutwork properties or use the
default value.
Wire
gauge

The wire gauge numbers correspond to the
American Wire Gauge (AWG) codes. This is
a standardized wire gauge system for the
diameters of round, solid, nonferrous,
electrically conducting wire. The larger the
AWG number or wire gauge, the smaller the
physical size of the wire.

Cover
stitch

Satin is the default. Alternatively, Blanket
can be used. Width and spacing can be
adjusted for both.

To digitize stumpwork with a wireline

1 Open the Cutwork Border docker and preset
your preferences. Generally you will use a wireline.
See Cutwork / stumpwork borders for details.

Choose stumpwork
piece

4 Digitize your border as you would any other closed
object.

5 Press Enter to complete. A stumpwork object is
generated based on the Stumpwork Border
presets.

6 Select and use the Cut Closed Border tool to cut
the border and leave an opening for wire ends. You
are prompted to mark a cutting point.
Select wireline
option (default)
Guidetrack for
wireline

Tackdown
stitching

2 Select the Digitize Piece tool and make sure
Wireline is selected as your embroidery type.

3 Open the object properties to adjust your wireline

Cover
stitching

gauge and cover stitch settings.

7 Optionally, use the Digitize Wireline tool to
Edit wireline properties
such as wire gauge, satin
cover width, etc.

insert additional wirelines for extra support. See
Digitizing additional wirelines for details.

8 Select the objects and click Create Stumpwork
Sub-design.
Selected objects are bundled into a composite
object which resides on a separate ‘layer’ to the
base design. The stumpwork layer does not appear
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in the Color Film because it is separate to the
main design.

a wire. They are then cut out and attached to the base
design. Required tools are listed above.

9 Optionally, edit your stumpwork object by
double-clicking or clicking Open Stumpwork
Sub-design.
The stumpwork object opens in a separate window
where you can edit properties such as wire gauge,
satin cover width and offsets, etc. Optionally, add
a background indicative of the fabric you will be
using. See Editing stumpwork for details.

Background fabric added
to stumpwork object

To digitize a closed stumpwork border

1 Use your normal embroidery tools to create a
design, or take an existing design you want to
modify. See also Digitizing Methods.

2 Select the Digitize Piece tool and adjust the
embroidery type as preferred – e.g. Satin border.

Tip Study the Stumpwork_Sample1 design
included in the designs folder. Try stitching it out to
practice the techniques involved. Check your
BERNINA machine documentation.

Creating closed stumpwork borders

Choose embroidery for
the border – e.g. Satin

Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.
Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.
Use Cutwork > Digitize Piece to digitize a cutout
piece in hooped fabric, together with supporting
embroidery. Right-click for settings.
Use Stumpwork > Create Stumpwork Sub-design to
create stumpwork from a selected cutwork piece.
Another simple scenario for the use of stumpwork
involves creating design elements within a closed
border. Like open-border stumpwork, these elements,
or ‘sub-designs’, are sewn onto a separate piece of
fabric, usually patterned, but without the inclusion of
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3 Digitize your border as you would any other closed

You will be prompted to save.

object.

Editing stumpwork
Use General > Cutwork to show or hide the Cutwork
Border docker. Use in conjunction with Cutwork
toolbox.

Stumpwork border
created

Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.

4 Press Enter to complete. A stumpwork object is
generated based on the Cutwork Border presets.
See Cutwork interface for details.

5 Select the resulting border and everything else
you want included in the stumpwork sub-design,
and click Create Stumpwork Sub-design.
Selected objects are bundled into a composite
object which resides on a separate ‘layer’ to the
base design.

6 Optionally, edit your stumpwork object by
double-clicking or clicking Open Stumpwork
Sub-design.
The stumpwork object opens in a separate window
where you can edit its properties. Optionally, add
a background indicative of the fabric you will be
using. See Editing stumpwork for details.

Use Stumpwork > Open Stumpwork Sub-design to
view and edit the stumpwork sub-design.
Use Cutwork > Cut Closed Border to cut a closed
cutwork border and leave an opening for wire ends.
Use Stumpwork > Digitize Wireline to add a
stumpwork wireline to an existing piece. Right-click
for settings.
Use Stumpwork > Save Stumpwork Sub-design As
to save a stumpwork sub-design as a separate
design file.
Once the Create Stumpwork Sub-design function
has been applied, the resulting stumpwork resides on
a separate ‘layer’ to the base design. Stumpwork
pieces can be edited as standalone designs. Required
tools are listed above.
To edit stumpwork

Add fabric as
required

 Select the stumpwork object you want to edit.

7 Close the sub-design to return to the base design.
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 Double-click selection or click Open Stumpwork
Sub-design. The stumpwork opens in a separate
design tab.

 Use the Cut Closed Border tool to leave an
opening for wire ends.

 Edit borders via the Cutwork Border docker –
e.g. add or remove stabilizing runs or cutting lines.
See also Cutwork / stumpwork borders.

 Sequence objects in the Color Film docker as
necessary.
Include or exclude
components via the
checkbox

 Use the Design > Background command to
specify a fabric type if you are creating stumpwork
with fabric and wire.

Click button to access object
properties for each included
stumpwork component
Decide whether an additional
stabilizing run is required

Decide whether to use the
CutWork tool on the
machine, or hand-cut with
scissors

 Click the Object Properties icon to access
additional settings for each included stumpwork
component. Edit properties such as wire gauge,
satin cover width and offsets.

Add a background
fabric as required

 Close the design tab to return to the base design.
You will be prompted as shown.

Edit stumpwork properties
such as wire gauge, satin
cover width, etc.

 Digitize other objects as needed. Use the Digitize
Wireline tool to insert wirelines for extra support
and shape. See Digitizing additional wirelines for
details.

 Alternatively, click Save Stumpwork
Sub-design As if you want to save the stumpwork
piece as a separate design file.

Digitizing additional wirelines
Use Stumpwork > Open Stumpwork Sub-design to
view and edit the stumpwork sub-design.
Use Stumpwork > Digitize Wireline to add a
stumpwork wireline to an existing piece. Right-click
for settings.
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For additional support, you may find that you need to
add wirelines to an existing stumpwork piece.
Additional wirelines provide more shape than a simple
border wire.

The software automatically creates the wire
placement tracks, wire tackdown and cover
stitching.

To digitize additional wirelines
 Create cutwork borders from existing embroidery
or digitize manually as preferred.

Wireline added

Sequence
objects as
desired

Stumpwork
border created

 Sequence objects you want to include in the Color
Film docker.
 If you haven’t already done so, select all objects
and click Create Stumpwork Sub-design.

 Before turning selected objects into a stumpwork
sub-design, select the Digitize Wireline tool and
digitize additional wirelines as you would any open
object.

Selected objects are bundled into a composite
stumpwork object which effectively resides on a
separate ‘layer’ to the base design.

 Alternatively, if you have already created a
stumpwork sub-design, double-click or click Open
Stumpwork Sub-design. Then select the
Digitize Wireline tool and add wirelines to the
sub-design.

Single composite
stumpwork object
placed at end of
stitching sequence

 If you are editing a sub-design, simply close the
tab, save, and return to the base design. See also
Editing stumpwork.
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CHAPTER 26
RAISED EMBROIDERY
BERNINA Embroidery Software
provides tools and techniques for
expanding flat embroidery surfaces
into raised or ‘sculpted’ surfaces.
Quilting creates dimension by
stuffing or filling areas to produce a
raised surface. In BERNINA
Embroidery Software, the quilting
feature consists of two components:
Raised Satin to create ‘puffy
embroidery’, and Trapunto Outlines
to turn puffy embroidery designs
into trapunto designs.
Needle felting, also called ‘dry
felting’, is a popular fiber-arts craft
that creates felt without the use of
water. In BERNINA Embroidery
Software, a dedicated PunchWork
tool allows you to create felting objects and designs for use with the BERNINA
Rotary Hook Punch.
Couching in embroidery refers to the technique of fixing a thick cord or yarn onto
the fabric, usually for decorative purposes. BERNINA Embroidery Software lets
you create couching designs for use with the BERNINA Free Motion Couching Foot
#43.
This section covers tools and techniques for expanding flat embroidery surfaces
into raised or ‘sculpted’ surfaces, specifically by means of quilted embroidery,
needle felting, and couching.

Quilted embroidery
Quilted embroidery creates dimension by stuffing or
filling areas to produce a raised surface. It employs a
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technique known as ‘trapunto’, also referred to as
‘stuffed embroidery’.

of fabric are added before the final outline is stitched
around the design. See also Creating satin fills.

Adjust
amount of
loft required

Quilting techniques

Note Recommended settings for best loft are
0.30mm manual for satin spacing with 4 layers.

There are a number of techniques for creating
trapunto designs.

Quilting in BERNINA Embroidery Software

Note To make sure your design is being displayed
correctly 3D, particularly with Raised Satin in
Artistic View, calibrate your monitor. See Calibrating
the monitor for details.
Trapunto techniques
Traditional hand trapunto involves sewing two layers
of fabric together with a motif outline. The underside
is then slit and stuffed with yarn or cotton.
A modern technique used to create trapunto –
sometimes called machine trapunto or cut-away
trapunto – is to mark the design pattern on top of the
quilt fabric with a water soluble marker. A layer of
batting is then pinned to the underside of the fabric
and two layers are stitched together. The batting is
trimmed close to the stitching to create the embossed
design. The quilt is then constructed by sewing the
quilt top to the quilt back with another layer of batting
in between.
Raised satin
Another technique is to use layers of thread instead of
stuffing or batting to create dimension. The
embroidery design consisting of multiple layers of
satin stitching is first stitched onto Aqua Mesh
water-soluble stabilizer. Then a top and bottom layer

Use Edit > Create Trapunto Outlines in conjunction
with Raised Satin to create quilt stitching for a raised
‘quilted’ look.
Use Stitches > Raised Satin Fill to create raised
embroidery designs consisting of multiple layers of
satin stitching.
Use Stitches > Raised Satin Outline to create raised
satin borders – can be used with trapunto for quilting
effects.
In BERNINA Embroidery Software, the quilting design
work relies on two main tools:
 Raised Satin: This allows you to create ‘puffy
embroidery’. Outlines can be used for lettering and
special calligraphy effects. See also Creating
freehand embroidery.
 Trapunto Outlines: This allows you to turn puffy
embroidery designs into trapunto quilting designs.
The puffy embroidery component allows you to create
raised embroidery consisting of multiple layers of
satin stitches. This is as an alternative to stuffing with
yarn or batting. The trapunto component allows you
to stitch layers of fabric over the raised satin.
The Trapunto Outlines feature is used exclusively
with Raised Satin to create a ‘quilted’ look. When
activated, this feature always defaults to the next
unused color so as to force the machine to stop before
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trapunto outlines are stitched. This allows you to
place the covering fabric.

 Create or open a design or element that fits within
one hooping.
 Define your quilt block shape and size.
 Lay out copies of the design around the work area,
placed and orientated automatically.
 Define multiple hoopings for the design layout.
 Split the layout into separate stitching files.
 Include reference marks for positioning.
Note Work area has no bearing on hoop size. When
used in conjunction with the Multi-Hooping toolset,
you can place multiple hoopings around an entire
work area. See Creating multiple hoopings for details.

Adjust trapunto
offset and outline
thickness

Defining quilt blocks
Use View > Show Quilt Block to show or hide a quilt
block defined under Layout.
Use Layout > Define Quilt Block to define a quilt
block of a specified size.

Tip Study the quilting design included in the designs
folder. Try stitching it out to practice the techniques
involved. Check your BERNINA machine
documentation.

Creating quilt block layouts
Using Layout tools, it’s a simple matter to define quilt
blocks of specified size. You can then arrange
elements around the block, with or without a central
design element. See also Creating quilting
backgrounds.

Before you can create a quilt block layout, you first
need to define a quilt block corresponding to the
patch you intend to embroider. While quilt blocks tend
to be in the range of 8" x 8" to 12" x 12", the software
lets you define an area up 10' x 10'. This allows you
to create a ‘block’ equal to the finished quilt size. You
can then, for instance, create a single continuous
background for the entire quilt.
To define a quilt block
 Set the measurement system via a droplist on the
General toolbar. See Setting measurement units
for details.
 Select Define Quilt Block to set a new quilt block.

Define quilt block
size

Set a work
center

 Specify a quilt block size and color.
 Use the lock to maintain width and height
proportions in rectangular layouts.
 The color is just for on-screen viewing. It has
no effect on design output.
Overall process
The overall process is as follows:
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 Choose a centering option:
Center

Purpose

At 0,0
position

This will place the quilt block at the center
of the design space. You can use the
Layouts tools to locate designs in the quilt
block.

Use design
center

This will place the quilt block at the center
of existing design extents. This ensures
the design is at the center of the quilt
block.

Digitize
center

This allows you to digitize the center point
for the quilt block anywhere in the design
space. This allows the quilt block to be
offset to the actual design.

 Click OK to confirm. If the checkbox is activated in
the dialog, the quilt block will display by default.
Otherwise, use the Show Quilt Block toggle.

 Insert a design and/or select a design/s or object/s
already on-screen. See Inserting designs for
details.

 Resize as necessary. Optionally, use the Auto
Center to Work Area tool to move selected
object/s to the center of the work area. Press
Enter to confirm.
 Insert further objects as needed. Move to the
desired position in the work area. Use arrow keys
to nudge into position.

Objects grouped for
separate stitchout

Creating quilt block layouts
Use General > Insert Embroidery to import
embroidery design files into the current design.
Use Layout > Auto Center to Quilt Block to
automatically move selected object/s to the center of
the quilt block.
Use Layout > Lay out to Quilt Block to create copies
of selected object/s in each corner of the quilt block.
Use Context > Quilt Block Margin to specify a margin
(in mm) between the edge of quilt block and designs.
Use Context > Copy to Center to create a copy of
selected object/s at the center of the quilt block.

 Before you copy the design to the work area, you
need to decide whether to merge color blocks:
 If you want the selected objects to sew out in
separate hoopings, make sure they are
grouped before proceeding.
 Alternatively, leave the objects ungrouped, and
they will be color-optimized for a single
stitchout – i.e. color block by color block.

Create quilt block layouts using Layout tools together
with selected design/s and/or object/s.
To create a quilt block layout
 Define your quilt block according to its application.
See Defining quilt blocks for details.
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 Click Lay out to Quilt Block. Wireframe copies
are mirrored about vertical and horizontal axes.

 Optionally, use the Mirror-Merge or/and
Quilting Background tool to add more objects
and stitching.

 Use the Context toolbar to control the duplicates:
 Use Quilt Block Margin to specify a margin (in
mm) between the edge of the quilt block and
the duplicates.
 Optionally, use Copy to Center to create a
copy of selected object/s at the center of the
quilt block.
 Press Esc to cancel or Enter to confirm.
 Check the design layout in the Color Film.
Manually resequence colors where necessary. See
Sequencing embroidery objects for details.

Automatic re-sizing
Use General > Insert Embroidery to import
embroidery design files into the current design.
Use Layout > Auto Center to Quilt Block to
automatically move selected object/s to the center of
the quilt block.
Use Layout > Auto Fit to Quilt Block to automatically
fit selected object/s to the quilt block.

Automatic re-sizing makes it easy to maximize a
design within a defined quilt block. Simply
import the design and place in the defined quilt
block.

Place design in
quilt block

Tip When used in conjunction with the
Multi-Hooping toolset, you can place multiple
hoops around a single design. See Creating
multiple hoopings for details.

BERNINA® Embroidery Software : Reference Manual

247

Chapter 26 : Raised Embroidery
Then click Auto Fit to Quilt Block to automatically
fit the selected object/s to the defined quilt block.

The Quilting Background feature is activate
when the design window contains one or more
embroidery objects.

2 Click the Quilting Background icon.
The Quilting Background dialog opens. The
dialog is grouped into four functional areas: Block
Size, Design Size, Stitching, and Block Center.
Design
automatically
resized to fit quilt
block

Creating quilting backgrounds
Use Edit > Quilting Background to create ‘echo’ quilting
blocks.

The Outline Design tool is sometimes used to create
‘echo’ quilting designs. However, the Quilting
Background feature provides a better alternative.
Use it, for instance, to create stipple quilting to fill
quilt blocks. Optionally add separate offset outlines
around a design before background quilting.

Note The Design Size panel displays height and
width of the embroidery design as a reference
when defining the block size.

3 Set the size of your quilting in the Block Size
panel.
Height and Width fields define the boundary used
to generate the quilt pattern. There is also a
Proportional Sizing checkbox. When checked,
the software displays a lock symbol – values
change proportionally.

4 Use the Stitching panel to determine stitching
characteristics:
Parameter Description

Note When using the Quilting Background tool,
you are limited to one quilting background per design.
A quilting background cannot be applied to a second
object. When creating mixed quilting, you will need to
create a new design via File > New.

Quilting
type

Choose from a variety of quilt patterns:
• Echo
• Scroll
• Stipple
• Echo clipped
• Scroll clipped

Design
margin

Set gap between echo quilting and the
design.

Block
margin

Set gap between echo quilting and the
block boundary.

Line
spacing

Set distance between each quilting line, or
loop spacing for stipple.

Color

Choose a color for generated quilting
stitches from the current color palette.
Default color is the last color used in the
design.

To create a quilting background

1 Open the design you want to include within the
quilting block.

Tip All spatial controls can switch between
millimeters and inches, depending on the chosen
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measurement system. See Setting measurement
units for details.

5 Use the Block Center panel to center the design
within the quilting block:

Tip Optionally, add separate offset outlines
around a design before background quilting. See
also Creating outlines & offsets.

Parameter Description
Use design Place the design at the center of block
center
outline and generate the quilt pattern
around it.
Digitize
center

Digitize the quilting block center. Choosing
this option attaches an outline of the block
size with cross hairs to the cursor. Left-click
to place the block center where you choose
on the design, and generate the quilt
pattern around it.

6 Click OK to generate stitching.

This section covers tools and techniques for expanding flat embroidery surfaces
into raised or ‘sculpted’ surfaces, specifically by means of quilted embroidery,
needle felting, and couching.

Needle felting
Needle felting, also called ‘dry felting’, is a popular
fiber-arts craft that creates felt without the use of
water. It can be created by industrial felting
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machines, needle felting attachments like BERNINA
needle-punch tool, or even hand-held tools.

under the needles, and includes a guide as part of the
accessories.

Felting with BERNINA Embroidery Software
Use Digitize > PunchWork to create felting objects
and designs for use with the BERNINA Rotary Hook
Punch tool.
In BERNINA Embroidery Software, a dedicated
PunchWork tool allows you to create felting objects
and designs for use with the BERNINA Rotary Hook
Punch.

The needles used in dry felting have small barbs with
soft shoulders. As they penetrate the base fabric, they
pull fiber or ‘roving’ through. Since the barbs face
downwards, fibers are left behind as the needles exit.
Using a single needle or small group of needles, fine
details can be achieved using this technique. It is
popular for 2D and 3D felted work.
PunchWork properties

BERNINA Rotary Hook Punch tool

The object properties for punchwork are similar to
The BERNINA ‘needle-punch’ tool is a cluster of three appliqué. The digitizing technique is essentially the
needles that are used to punch fibers through fabric. same. See also Creating closed-object appliqué.
This process is normally performed as free motion
sewing but can also be done in the embroidery hoop.

Felting
properties
similar to
appliqué

Punchwork consists of the following components, all
of which, apart from the punching itself, are optional.
Each component is separated in the stitching
sequence by a machine stop.

The tool most suitable for hoop work is the Rotary
Hook Punch tool, since the presser foot also allows
yarn, ribbon and so on to be fed through the foot

Component

Notes

Placement
line

Include a guideline to assist placement of
roving.
Stop: Place roving evenly within placement
line.

† Mandatory
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Component

Notes

Cutting line

Include a cutting line to hold down edge of
the roving, and mark out the shape.

stitching has been digitized separately as run stitch
outlines.

Stop: Cut excess roving from around the
edges. Change to punch plate and needle.
Needle
punching

† Punch the felting – consists of loose
tackdown and stipple stitching. Adjust
density as required.
Stop: Remove cutting line as required.
Change back to embroidery plate and
needle.

Border
stitching

Include a border as desired – default is
satin. Blanket stitching is also available.
Set border width and stitch spacing.

Offset

Use the slider to offset borders in relation to
the placement line. By default, Satin is
centered, while Blanket sits inside the
placement line. Adjust as required.

† Mandatory

Tip Check fabric settings before you stitch out. If you
are stitching details over felting, you may need to
select a heavier fabric to compensate. See also
Changing fabrics.
Design technique

Cover stitching
consisting of outlines
sewn over punchwork

Tip Study the punchwork design included in the
designs folder. Try stitching it out to practice the
techniques involved. Check your BERNINA machine
documentation.

Couching
Couching refers to the technique of fixing a thick cord
or yarn onto a fabric, usually for decorative purposes.

Because you have complete control over the
punchwork elements to include in your design,
different approaches may be taken. The sample below
includes only a placement line and felting.

Gap left between
placement line and
punching to allow for
width of needles

Once the roving has been punched into position, the
border stitching can be applied. In this case, border
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Support for free-motion couching foot

Couch stitching

BERNINA Embroidery Software allows you to create
couching designs for the BERNINA Free Motion
Couching Foot #43.

Couching may be combined with existing outline
stitch methods.

Couching designs are typically made up of straight
running stitch outlines:
 These may cross over themselves or other objects
in a continuous fashion.
 It is best to avoid long runs of overlapping cord.
The free-motion couching foot is a specialist needle
attachment for use with cords, yarn and ribbon. The
cords are fed directly to the needle through a hole in
the sole and can be sewn on in any direction. The tool
can be used to embellish table linens, garments and
bags with attractive cord decorations. The main
points to keep in mind are:
 The machine stitches through the cord with
straight stitching – it does not use the zigzag
mechanism.

 It is ok to have couching objects separated by a
trim/jump.
 It is ok to have sharp corners but avoid extremes.
 It is possible to combine normal embroidery and
couching in the same design.
 It is possible to create couching-only designs with
no other embroidery stitching.
 It is possible to use some existing fill stitch
methods for couching if you set object properties
for open density with no underlay.

 The mechanism can be used in combination with
the embroidery module for automatic cording, as
well as manual free-motion cording.
 The foot can be used with cords between 1.5 - 2.0
mm diameter.
 Needle size 80 is recommended by Bernina.
 Cord must be soft enough for the sewing needle to
penetrate and fasten to the fabric.
 Stitching can be done at any angle via the stitch
design data.
 It is possible to stitch over areas of cord already
stitched.
For more about Couching Foot # 43, see the Bernina
Website.

Creating couching designs
Use Stitches > Single Outline to create a single row
of stitches along a digitized outline – used for
borders or details.
Use Effects > Couching to add couching cord for use
with the BERNINA Free Motion Couching Foot #43.
Click View > Show Stitches to show or hide
embroidery stitching.
Click View > Show Needle Points to show or hide the
needle points in embroidery stitching.
To create a couching design in BERNINA Embroidery
Software, follow this process:
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 Open or create the design you want to use.
 Create or designate the Single Outline stitching
which is to form the couching.

These effects are manually created, not automatically
generated, using the following technique:
 Create required couching stitching.
 Copy and paste a duplicate of the couching run
stitching. Use Break Apart if it is a fill.
 Change the stitch type of the duplicate to a
different outline stitch type.

 Select Single Outline objects and apply the
Couching effect. The cord is displayed as a thick
graphic line. It takes the color of the outline
stitching.
 Go to stitch view and turn on needle points. See
Viewing embroidery elements for details.
 Adjust needle point display colors as necessary.
See also Adjusting display colors.

 Ensure stitch properties are set accordingly – no
underlay, correct outline width, pull comp, etc.
 Ensure start/end points don’t generate unwanted
travel stitching.
It is not practical to swap back and forth between
couching and embroidery on an object-by-object
basis. Sequence the design so that:
 Multiple couching objects are stitched all together
first with the couching foot.
 Cover stitching is stitched after, again with the
embroidery foot.

 Avoid or minimize jumps/connectors between
different couching objects in the design. Don’t use
jumps for automatic connectors.
 Avoid or minimize couching crossing over itself.
Add embroidery stitching to couching cord
You can optionally add embroidery stitching over top
of cord which has already been stitched to the fabric,
either for decorative effect, or for technical effects
such as 3D padding under the stitching.

Producing couching on the machine
To perform couching in combination with an
embroidery design...
 Create an embroidery design with stitch data to
define the pattern to sew with couching.
 Stitch data from the design file stops the machine
when required for couching, and tells you what
action to take.
 Manually replace the embroidery foot with the
couching foot when needed, and thread the cord
through the foot in preparation for stitching.
 Choose an embroidery thread to stitch the cord to
the fabric – either a matching color, contrasting
color, or see-through thread.
 The machine stitches the design automatically,
with the cord being fed through the couching foot,
in shapes defined by the stitch data.

For example:
 Satin stitch for a raised 3D effect over top of
couching.
 Blanket stitch or other suitable pattern run stitches
to straddle the cord.
 Stemstitch outline for a light density covering.

 At the end of a section of couching, the machine
stops so you can trim the cord. An instruction is
displayed on the machine as with appliqué.
 Manually switch the foot back to the normal
embroidery foot again when couching is finished.
 Relevant production information is also recorded
on the design worksheet:
 Couching foot is required
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 Cord size and color
 Length of cord required
 The stop sequence shows when to start
couching, trim couching, and end couching.
Tip Be aware of potential registration gaps
between the cord and the cover stitching. You
need to use good stabilizers to minimize fabric
movement.
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CHAPTER 27
ANCILLARY APPLICATIONS
In addition to CorelDRAW®, BERNINA Embroidery Software includes ancillary,
standalone applications which can be launched from within Embroidery Canvas.
The BERNINA Cross Stitch application lets you create dedicated cross stitch
designs or add cross stitching to embroidery. Use BERNINA Quilter to experiment
with patches and colors enabling you create beautiful, personalized quilts.

This section provides an overview of the ancillary BERNINA Cross Stitch and
BERNINA Quilter applications provided with BERNINA Embroidery Software.

Introduction to cross stitch
Cross stitching is a popular technique for filling large
areas with low stitch counts. It can also be used for
outlines and borders. It is suitable for homeware,
tablecloths, children’s clothes and folk designs. Cross
stitch is sometimes combined with appliqué.

the edges to the diagonals. The full range of cross
stitches is listed below.
Full Cross

Upright Cross

Three-Quarter Cross

Double Cross

Unlike machine embroidery where designs are
enhanced with different stitch types, angles, and
effects, in cross stitch you can only add dimension to
the design with shades of colors. For this reason,
most cross stitch designs use many more colors than
machine embroidery.

Half Cross

Elongated Vertical
Cross

Quarter Cross

Elongated Horizontal
Cross

Mini Cross

Single Line

Types of cross stitch

French knot

Cross stitches are created on a matrix of squares or
‘pixels’. Any part of the square can be stitched, from
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Cross stitch fills
When using cross stitch as a fill you can select from
any of the cross stitch fill types.

any corner. Sometimes two half stitches of different
colors are used to make one full cross stitch.

Half cross stitch
pattern

Full cross stitch
Full cross stitches are made up of two equal-length
stitches that cross at the center to form an X. The
overall effect of the fill depends on which stitch in the
X lies underneath or on top. You can also mix and
match for special effects.

Full cross stitch
pattern

Half cross can go in either direction depending on the
effect you want to achieve. For example, half cross
used to represent feathers would slant in the direction
of the feathers themselves.
Quarter cross stitch
Quarter stitches are used to stitch more intricate
patterns.

Three-quarter cross stitch

Quarter cross stitch
pattern

A three-quarter stitch is most often created by
stitching a quarter stitch followed by a half stitch. A
different effect is achieved by stitching the half stitch
first and anchoring it with the quarter stitch.
Three-quarter
cross stitch pattern

Mini cross stitch
Mini cross stitches are two equal-length stitches that
cross at the center to form an X but they only fill
quarter of the square. Use mini cross stitch for details
such as eyes or for a denser look in parts of your
design.
Note The long arm of the three-quarter stitch can go
either / or \ directions.

Mini cross stitch
pattern

Frequently a quarter stitch and a three-quarter stitch
of different colors share a single square. Mix and
match their positions to give different effects.

Upright cross stitch

Mixtures of quarter and a three-quarter stitches

Upright cross stitches are comprised of a vertical and
horizontal stitch.

Half cross stitch
A half stitch is simply a diagonal stitch that looks like
/ or like \. Half stitches are usually used for shadows
and background shading. The stitch can start from
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The stitches can be worked diagonally across the
canvas, or in a horizontal or vertical line.

traditionally used in ‘whitework’ with very exclusive
cotton and fine silk threads.

Upright cross stitch pattern

Double cross stitch
Double cross stitch is two full cross stitches stitched
at 90º on top of each other. A double cross stitch
resembles a star. It is generally used in a scattered
fashion or worked into a row to form a decorative
border.
Double cross stitch
pattern

Typically the top thread of the bottom cross is the
stitch which lies at 135º to the horizontal; and the top
thread of the overlapping cross is the horizontal
stitch.

French knots cross
stitch pattern

French knots can be used in combination with other
cross-stitch types. Use them for eyes, door knobs,
dots for flower pistils, or in place of beads used in
hand-work designs – e.g. ornaments on a Christmas
tree or to dot letters such as ‘i’. Use them as an outline
border. Try them with colorful metallic or variegated
threads. French knots are better sewn in larger grids.

Cross stitch borders
Cross stitch can be used as an embroidery outline or
border. You can also combine cross stitching with
other stitch types to achieve special effects.
You can make outlines with Single Line or Full Cross
stitches or a combination of both for a denser border.
A Single Line outline is treated by the software as a
border while a Full Cross outline is treated as a fill.
This is important if you need to delete a border
because a single line can be deleted as a single object
while a full cross stitch border cannot.
Single line border

Elongated cross stitch

Single Line stitches are only used to create borders or
Elongated cross stitch consists of two equal-length
add details. The single line can be placed on any side
stitches that cross to form an X. There are two types: of the square. Click on the side you want to place the
 elongated horizontal cross stitch
line. You can place a single line border on one side or
all four sides of the square. The single line border can
 elongated vertical cross stitch.
be placed in a square which already has a cross stitch
Elongated horizontal cross stitches are only half the
in it.
height of normal cross stitch and elongated vertical
cross stitches are only half the width of normal cross
stitch.

Elongated cross
stitch pattern

Single line border

Full cross border

French knots

Full crosses can also be used as a decorative outline
stitch. If you use full cross as a border it will be the
same cross stitch type as selected in the Fill stitch

French knots were originally a hand-stitch used to
create a raised look for embellishment. They were
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type list. You can change this by changing the Fill
stitch type.

Mini cross stitches
Use mini cross stitch for details such as eyes or for a
denser look in parts of your design.

Four mini
crosses

Full cross border

Combined to
make four mini
full cross

Cross stitch variations

Elongated cross stitches

The orientation of fractional cross stitches can be
varied to create different patterning effects. You do
this directly pixel-by-pixel, or by setting a fill stitch
orientation. You can also combine fractional cross
stitches in a variety of ways. See also Types of cross
stitch.

Vertical and horizontal elongated cross stitches are
made up of two equal-length stitches that cross to
form an X. They fill either the left, right, top or bottom
of the square.

Three-quarter cross stitches
Quarter and three-quarter cross stitches can be used
to create rounded edges. See also Cross stitch fills.
Elongated cross stitch patterns

Combination stitches
Half cross stitches
Half cross stitches can be used to give objects an ‘airy’
look. You can also use half cross stitches to make a
full cross stitch with two colors. See also Combination
stitches.
Combined to
make two-color
full cross

Two half
crosses

Quarter, half and three-quarter cross stitches can be
combined to make crosses comprised of multiple
colors. You can also combine mini crosses,
elongated vertical or horizontal crosses and outline
stitches.
Combined 1/4, 1/2 and
3/4 crosses
Combined elongated
vertical or horizontal crosses

Quarter cross stitches
Quarter and three-quarter cross stitch can be used to
smooth rounded edges. You can also use quarter
cross stitch to make a full cross stitch with up to four
colors. See also Combination stitches.
Click here to start
in this corner

Combined fractional
and mini crosses
Combined colored outlines
Combined outlines
and crosses

Launching BERNINA Cross Stitch
Full cross stitch made up of
four quarter cross stitches

Use Applications > Cross Stitch to launch BERNINA
Cross Stitch from within BERNINA Embroidery
Software.
Cross stitch design involves a different digitizing
technique to ordinary embroidery design. For this
reason, BERNINA Cross Stitch has its own design
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window which you open from within BERNINA
Embroidery Software.

 Go to the Applications toolset and select Cross
Stitch.

To launch BERNINA Cross Stitch
 Run BERNINA Embroidery Software.

Select Cross Stitch

BERNINA Cross Stitch opens in its own design
window.
Title bar
Menu bar
General toolbar
Mode tabs

Picture/Design toolbar
(changes with selected
mode)
Design Window

Stitch & Color bar
Status line

 For further information, refer to BERNINA Cross
Stitch Help.

Introduction to patchwork & quilting
Patchwork is a popular technique for designing and
sewing patches into blocks. BERNINA Quilter can be
used to design patchwork quilts, either from existing
designs or patterns, or from designs of your own
making. Use BERNINA Quilter to experiment with
patches and colors enabling you create beautiful,
personalized quilts.
Blocks on a quilt can be filled with patches of either
patterned or plain fabric. BERNINA Quilter includes a
large selection of patchwork blocks and fabrics, but
you can also scan your own and store them in a
quilting library.
When a quilt design is complete you can print it out,
showing the blocks, how they are constructed, as well
as yardage, sewing and cutting details.

Patchwork quilt designs
Patchwork and quilting are related and
complementary techniques. BERNINA Quilter is
essentially a design tool to help you put together
quilts combining patchwork, embroidery, and
appliqué. Use BERNINA Quilter to plan and lay out
your patchwork blocks on screen, select your fabrics,
and add embellishments such as appliqué and
embroidery.
Patchwork
A ‘patchwork block’ is a collection of patches sewn
together, usually forming a regular shape such as a
rectangle. A ‘patch’ is a single piece of fabric sewn
with others into a set arrangement to form a
patchwork block. Sewing patches together into blocks
is known as ‘piecing’.

Single patch
or piece

Patchwork block
composed of
patches
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Blocks are then sewn together, either in a straight
square format or as diamonds on-point.

Square

blocks. When working with a single color, select a
wide range of fabrics.

On-point
Creating 3D effects

Although some quilts have patchwork extending out
to the edge, the majority have one or more borders.
Some also have narrow strips of fabric, called
‘sashing’, to separate the blocks. Borders and sashes
can alter the size and appearance of your quilt. They
can be used to frame and soften a busy design.
Borders can also be used to enlarge a quilt so that it
fits a standard bed. More than one border may be
used on each quilt.

With borders
and sash

Using a dominant color

With BERNINA Quilter you can also add appliqué and
embroidered objects to the quilt.
One patch
block with
appliqué
object

12 patch
block

Border with
mitred corners
no sashes

One patch
block with
embroidery
object

Square quilt with four blocks

Many quilts use a combination of fabrics similar in
color and value for the background. Patchwork
patterns are created by the contrast between light,
medium and dark fabrics. Contrast in color depth is
critical to some designs. It is good practice to select
your background color before deciding on your other
design colors.

Plan your quilt by working out the overall
measurements, then calculate how many blocks,
borders and sashes are to be used. Decide which
patchwork blocks are to be used and how you will use
color. Try out various arrangements and colors until
you find one that you like.
Quilting
A quilt is like a sandwich formed of three layers:
 Quilt top: a collection of patches sewn together,
usually forming a regular shape such as a
rectangle and may include borders and sashes.
 Batting: a layer of padded material between the
front and back fabric to add thickness and
substance.
 Backing: a layer of fabric added to the back of a
quilt to encase the batting.
Quilting top

Contrast between light, medium and dark fabrics
Batting material

When fabrics are placed carefully, a three dimensional
illusion can be created. Solid or plain colors are placed
to create bold contrasts between the patchwork

Backing fabric

Quilting involves sewing decorative designs on quilts.
These designs use run stitches to divide the fabric into
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sections giving a pattern of raised areas. Quilting can
be done either by hand, or by free motion using a
sewing machine.

Tip A quilt can be a combination of patchwork and
quilting using patchwork blocks pieced together with
quilting stitches.

Quilt sizing
BERNINA Quilter uses inches (in) for measuring
designs. Use the table to convert between imperial
and metric measurements. You will find it easier to
use the decimal equivalent for imperial
measurements when working out quantities with a
calculator.
Metric (mm)

Imperial (inch)

Decimal (inch)

3

1/8

0.125

6

1/4

0.25

9

3/8

0.375

12

1/2

0.5

16

5/8

0.625

19

3/4

0.75

22

7/8

0.875

25

1

1.0

50

2

2.0

75

3

3.0

100

4

4.0

130

5

5.0

150

6

6.0

225

9

9.0

250

10

10.0

300

12

12.0

450

18

18.0

500

20

20.0

900

36 (1 yard)

36.0

1000 (1 meter)

40

40.0

Quilt

Imperial (inches)

Metric (cm)

King

92-100 x 90-104

234-254 x 228-264

Jumbo

120-124 x 120-124

304-315 x 304-315

Launching BERNINA Quilter
Use Applications > Quilter to launch BERNINA
Quilter from within BERNINA Embroidery Software.
Launch BERNINA Quilter from within BERNINA
Embroidery Software.
To launch BERNINA Quilter
 Run BERNINA Embroidery Software.
 Go to the Applications toolset and select Quilter.

Select Quilter

 Alternatively, you can also launch BERNINA Quilter
by pressing Ctrl+Q.

Use the table below as a rough guide to the most
common quilt sizes. It will vary according to the
blocks you use.
Quilt

Imperial (inches)

Metric (cm)

Baby

36-45 x 45-54

90-115 x 115-137

Cot

42-48 x 54-60

107-122 x 137-152

Single

56-64 x 84-100

142-162 x 213-254

Double

70-80 x 84-100

178-203 x 213-254

Queen

76-84 x 90-104

193-213 x 228-264
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BERNINA Quilter opens in its own design window.
Title bar
Menu bar
Lock toolbar

Edit toolbar

Standard toolbar

Fabric palette

Arrange
toolbar
Design window

Blocks used

Colors used

Fabrics used

 For further information, refer to BERNINA Quilter
Help.
Note If BERNINA Quilter does not open from
BERNINA Embroidery Software, check that Internet
Explorer V6 has been installed on your PC. This is a
minimum requirement.
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PART VI
EMBROIDERY LETTERING
Create top-quality lettering quickly and simply. BERNINA Embroidery Software provides
a large range of scalable closest-join font styles and multi-color and fancy stitching
fonts to choose from.

Lettering essentials
This section describes how to add lettering to embroidery designs. It also covers
applying lettering baselines, formatting lettering and adjusting letter spacing. See
Lettering Essentials for details.

Editing embroidery lettering
This section describes how to edit lettering text. It also covers scaling lettering and
removing underlay from small lettering. It also deals with transforming lettering
objects, adjusting individual letters, as well as reshaping baselines. See Editing
Embroidery Lettering for details.

Special lettering effects
This section describes how to convert TrueType fonts to embroidery fonts. It also
explains how to add special characters as well as fancy and monogram lettering to your
designs. It also covers applying different stitch types to lettering objects as well as
creating special effects with Elastic Lettering. See Special Lettering Features for details.

Monogramming
This section details the creation of monogram lettering with initials or with a name, how
to add ornaments to monograms, and how to create ornament layouts. It also covers
adding and creating your own borders. See Monogramming for details.
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CHAPTER 28
LETTERING ESSENTIALS
Add embroidery lettering to designs quickly
and easily, either on-screen using current
settings or via object properties. Place
lettering on a straight horizontal or vertical
baseline, curve it around a circle or arc, or
digitize your own baselines. You can apply
formatting to lettering objects in the same
way as a word processor, including italics,
bolding, and right/left justification. Letter,
word and line spacings can be determined
before or after creating lettering objects and
placing them in your design. See also
Embroidery Fonts.
This section describes how to add lettering to
embroidery designs. It also covers applying
lettering baselines, formatting lettering and adjusting letter spacing.

Adding lettering to embroidery designs Creating lettering on-screen
You can add lettering to a design by typing it directly
on-screen. Adjust object properties to specify letter
formatting before or after adding it to a design.
BERNINA Embroidery Software provides an font range
suitable for many applications. Select from the
supplied embroidery fonts or convert TrueType or
OpenType fonts.

Tip Combined with the Satin stitch Calligraphy
setting, Open Freehand can be used to create
embroidered calligraphy. For best results, a wider
satin width and more layers than the default may be
required. See also Creating freehand embroidery.

Use Digitize > Lettering to create embroidery
lettering directly on screen.
If it is not essential to fit letters precisely to a certain
area, you can type them directly on-screen. You can
also modify lettering objects directly on-screen to
achieve various artistic effects. Appearance and
layout depend on current settings. You can change
them at any time. See Editing Embroidery Lettering
for details.
To create lettering on-screen

1 Click the Lettering icon.
2 Select a color from the Color Palette. See
Changing thread colors for details.

3 Click where you want to start typing.
An I-beam appears where you clicked.
Thick-thin
calligraphy effect

I-beam

4 Type the letters you want to embroider.
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Tip To start a new line, press Shift+Enter.

5 Press Enter to complete.
Stitches are generated immediately.

Tip You can insert a color change between two
letters by keying a caret (^) symbol. Subsequent
letters default to the next color in the palette.

3 Select a font from the Alphabet list.
 Choose a font type – Embroidery, TrueType, or
both. See also Converting graphic fonts to
embroidery.
 Choose a font group – block, serif, script, or
decorative. These only apply to TrueType fonts.

Note Appearance and layout depend on current
settings in the Object Properties > Lettering
dialog. You can change them at any time. See
Editing Embroidery Lettering for details.

 Type two (or more) characters of the font name
to jump ahead in the font list.

Creating lettering via dialog
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
You can specify letter formatting before adding it to
the design. Select from the supplied embroidery fonts
or convert TrueType or OpenType fonts. If you are
embroidering on a child’s outfit you might use a
simple font like Childs Play. If you are embroidering
on a ladies nightdress you might use an elegant script
font like Anniversary.
To create lettering via dialog

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens.

Select font

Tip Check min/max recommendations for each
font and stay within them for best results. See also
Embroidery Fonts.

4 Adjust formatting and baseline settings as
required. See Formatting lettering for details.

5 Click Apply.
6 Click where you want to place the lettering, or
mark reference points for the baseline you
selected. See Applying lettering baselines for
details.

Enter text

Note Letters are filled with stitches according to
current stitch settings in the Object Properties
dialog. You can change these at any time. See
Applying different stitch types & effects to lettering
for details.

Applying lettering baselines
Adjust settings

2 Enter the text you want to embroider in the text
entry panel.
To start a new line, press Enter.

Baselines determine the shape of lettering objects in
a design. You can place lettering on a straight
horizontal or vertical line, curve lettering around a
circle or arc, or digitize your own baseline. Different
reference points are needed depending on the
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baseline you use. You can digitize baselines
on-screen.

To select baselines

1 Double-click or right-click a lettering object.
The Object Properties > Lettering dialog
opens.

Select
baseline

2 Select a baseline.
The baseline you choose depends on the effect you
want to achieve. You need to digitize different
reference points depending on the type of baseline
you select. Options include:
 Straight Horizontal: See Creating horizontal
baselines for details.
 Circle CW: See Creating circular baselines for
details.
Baselines use default settings to determine their size,
spacing and angles. BERNINA Embroidery Software
gives you both interactive and precise numerical
control over many baseline settings. Techniques are
available to modify baseline type, length, radius and
angle, as well as baseline position.

Note BERNINA Embroidery Software will remember
which baseline you used last and use this one if you
type letters directly on-screen.

 Circle CCW: See Creating circular baselines for
details.
 Any Shape: See Creating custom baselines for
details.
 Vertical: See Creating vertical baselines for
details.
 Multiple: See Creating custom baselines for
details.

3 Click Apply.
The selected baseline is applied to any selected
lettering object or newly created lettering objects.

Selecting baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Free Line (Lettering tab) to create straight
horizontal baselines of no fixed or pre-determined
length.
Use Circle CW (Lettering tab) to create clockwise
baselines.
Use Circle CCW (Lettering tab) to create
counter-clockwise baselines.
Use Any Shape (Lettering tab) to shape lettering
around elements in a design.
Use Free Line Vertical (Lettering tab) to create
straight vertical baselines of no fixed or
pre-determined length.

Tip Create identical baselines by duplicating or
copying them in your design.

Creating horizontal baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Free Line (Lettering tab) to create straight
horizontal baselines of no fixed or pre-determined
length.
Free Line baselines do not have a fixed or
pre-determined length. They extend as long as you
keep adding letters.

Use Predefined (Lettering tab) to create multiple
arching baselines.
Different baselines are available for use with new or
selected lettering objects. Adjust baseline settings
interactively or via properties.
To create horizontal baselines

1 Right-click the Lettering icon.
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The Object Properties > Lettering dialog
counter-clockwise directions. By default, letters are
opens. See Creating lettering via dialog for details. positioned above Circle CW baselines and below
Circle CCW baselines. They are also centered by
2 Enter your text in the text entry panel. See
default.
Creating lettering via dialog for details.

3 Select the Free Line icon.
4 Click Apply.
5 Click where you want to place the letters.

Creating vertical baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Free Line Vertical (Lettering tab) to create
straight vertical baselines of no fixed or
pre-determined length.
Free Line Vertical baselines are straight,
vertical baselines. They do not have a
fixed length, and extend to fit the letters
you enter. Line spacing is calculated
horizontally while letter spacing is
calculated vertically. Letters, by default,
are centered along vertical lines. New
lines are placed by default from left to
right. Vertical baselines are effective for
embroidering on sleeves, as a decorative
effect, and for Asian text.

To create circular baselines

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens. See Creating lettering via dialog for details.

2 Enter your text in the text entry panel. See
Creating lettering via dialog for details.

3 Select the Circle CW or Circle CCW icon and click
Apply.
The Status Bar will prompt you.

4 Mark the center of the circle.
Click to mark
center of circle

Tip Vertical lettering best suited to
uppercase for Western languages because
descenders in lowercase letters are not
accommodated in the letter spacing.

Click to set
radius
2

1

Press Enter to
complete circle

To create vertical baselines

1 Right-click the Lettering icon.

5 Mark a point to define the radius.
The Object Properties > Lettering dialog
6 Press Enter to complete the circle.
opens. See Creating lettering via dialog for details.

2 Enter your text in the text entry panel. See
Creating lettering via dialog for details.

3 Select the Free Line Vertical icon.
4 Click Apply.
5 Click where you want to place the letters.

Creating circular baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Circle CW (Lettering tab) to create clockwise
baselines.
Use Circle CCW (Lettering tab) to create
counter-clockwise baselines.

Circle CW

Circle CCW

7 Alternatively, if you want to create an oval
baseline, mark a third reference point.

1

2
3

Click to set
oval radius

Press Enter to
complete circle

Use Circle CW and Circle CCW baselines to place
letters around a full circle or ellipse in clockwise or
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8 Press Enter to complete the oval.

Oval CW

counterclockwise around the bottom of a circle, all in
one action.

Oval CCW

Tip Make a circle large enough for your lettering.
If it is too small, or the lettering too big, the letters
will be crowded. You can, however, adjust the
baseline radius in the dialog. See also Reshaping
baselines.
Adjust baseline radius

To create a predefined baseline

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens. See Creating lettering via dialog for details.

2 Type the text for the line around the top of the
circle in the text entry panel.

3 Press Enter.
Baseline Radius:
10 mm

Type in texts for
each line

Baseline Radius:
20 mm

Tip Different effects can be achieved by changing
the justification setting – left, right, center, full.
See Setting letter justification for details.

4 On the next line type the text for the line across
the middle of the circle and press Enter.

5 On the third line type the text for the line around
the bottom of the circle.

6 Select the Predefined icon.
Fully justified
CW circle
baseline

Left-justified
CCW oval
baseline

7 Click Apply.
8 Mark the center of the circle. See Creating circular
baselines for details.

Right-justified
CW circle
baseline

9 Mark a point to define the radius.

Creating predefined baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Predefined (Lettering dialog) to create multiple
arching baselines.
Use Predefined baselines to arch lettering clockwise
across the top, straight through the middle, and

10 Press Enter for a perfect circle, or click again to
form an oval and press Enter.

Creating custom baselines
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Use Any Shape (Lettering tab) to shape lettering
around elements in a design.
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Use Any Shape baselines to shape lettering around
elements in your design. Digitize Any Shape baselines
by marking reference points to form the required line.
The number of reference points and length of baseline
are practically unlimited.

To make italic lettering

1 Double-click or right-click a lettering object.
The Object Properties > Lettering dialog
opens.

Enter angle
value

If the baseline has tight curves, or sharp corners, the
letters may overlap. For best results, only mark curve
points, and digitize lines which have shallow, gentle
curves.

2 Enter an angle in the Italic field.

To create custom baselines

3 Click Apply.

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens. See Creating lettering via dialog for details.

You can enter an angle anywhere between 45° and
-45°.
The setting is applied to any selected lettering
object or to newly created lettering objects.

2 Enter your text in the text entry panel. See
Creating lettering via dialog for details.

Italic angle: 0°

3 Select the Any Shape icon and click Apply.
The Status Bar will prompt you.

4 Click to mark the baseline reference points.

Italic angle: -45°

 Right-click for curve points.
 Left-click for corner points.
Italic angle: 45°
1

2

3
4

Making bold lettering
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.

5 Press Enter to complete.

Formatting lettering
You can control the appearance of lettering by
changing object properties before or after adding
lettering, in the same way as other objects.

You can create the effect of bold lettering by
increasing the pull compensation settings for selected
lettering objects.
To make bold lettering

1 Double-click or right-click a lettering object.
The Object Properties > Lettering dialog
opens.

2 Click the Effects button.
The Effects dialog opens.

Making italic lettering
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
You can slant letters to the left or right for an italic
effect. The default italic angle is 0° which is equivalent
to no italics. The largest angle lettering can be
inclined is 45°.

Increase pull comp

3 Select the Others tab.
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increase the setting to 0.4–0.6 mm.

Left Justification, Right Justification, Center
Justification, or Full Justification. See also Setting
letter justification.

Caution Do not use a value of more that 0.6 mm
or letters may distort.

Adjusting overall letter spacing on-screen

4 Select the Pull Compensation checkbox and

5 Click Apply.
The setting is applied to any selected lettering
object or to newly created lettering objects.

Pull comp: 0.2 mm

Pull comp: 0.6 mm

Setting letter justification
Right-click Digitize > Lettering to enter text in the
dialog and adjust settings for embroidery lettering.
Justification is the way that lettering aligns itself on a
baseline. You can justify lettering left or right, center
it, or fully justify it. Full justification spreads the
letters out to fill the length of the baseline.

Click Transform > Reshape Object to adjust letter
spacing.
The spacing between letters is calculated
automatically as a percentage of the letter height. In
most cases the default spacing is adequate.
Sometimes, however, you may want to change the
overall letter spacing.
To adjust overall letter spacing on-screen

1 Select the lettering object and click the Reshape
Object icon.

2 Drag the triangular letter spacing handle left or
right.
Letters are redistributed proportionately along the
baseline.

To set letter justification
Drag letter spacing handle

1 Double-click or right-click a lettering object.
The Object Properties > Lettering dialog
opens.

3 Release the mouse button to complete and press
Esc.

2 Select a justification setting – Left, Right,
Center, or Full Justification.

Tip When a lettering is set to Full Justification, the
letters are evenly distributed along the baseline.
To change the spacing for fully justified lettering,
simply change the length of the baseline.

Adjusting individual letter spacing on-screen
3 Click Apply.
The setting is applied to any selected lettering
object or to newly created lettering objects.

Adjusting spacings
Letter, word and line spacings can be determined
before or after creating lettering objects and placing
them in your design. You can edit spacing directly
on-screen or via object properties. Letter spacing is
calculated automatically according to justification –

Click Transform > Reshape Object to adjust
individual letter spacing.
Spacing between letters is calculated automatically as
a percentage of letter height. In most cases the
default spacing is adequate. Sometimes, however,
spacing between certain letters may appear too large
or too small, depending on the shape of neighboring
letters. To compensate for this visual effect, you can
move one or several selected letters closer or further
apart along the baseline to improve spacing.
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To adjust individual letter spacing on-screen

To adjust line spacing on-screen

1 Select the lettering object and click the Reshape

1 Select the lettering object and click the Reshape

Object icon.

Object icon.

Click and drag
diamond handle

2 Click the diamond handle at the center of a letter.
2 Drag the triangular line spacing handle up or down
Tip To select multiple letters, hold down Ctrl as
you select.

to change line spacing.

3 Drag selected letter/s along the baseline or use
arrow keys to adjust the spacing.

Drag line spacing handle
down to increase spacing

Tip Alternatively, to move multiple letters,
right-click the diamond handle of the first letter
and drag. All letters to the end of the line move as
one.

4 Release the mouse button to complete and press
Esc.

3 Release the mouse button to complete and press
Esc.

Applying auto kerning
BERNINA Embroidery Software provides automatic
kerning for embroidery lettering. Kerning
automatically adjusts spacing between pairs or
triplets of letters. This can improve readability and
appearance. Unlike character spacing, kerning is
defined in the actual font.

Adjusting line spacing on-screen
Click Transform > Reshape Object to adjust line
spacing.

Auto kerning
activated

Change the space between lines in a multiple-line
lettering object using the Reshape tool.
Tip For more information about kerning, see the
Windows Dev Center topic on Justification, Kerning,
and Spacing.
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CHAPTER 29
EDITING EMBROIDERY LETTERING
BERNINA Embroidery Software gives you both
interactive and precise numeric control over
many attributes affecting lettering objects.
You can adjust lettering objects as a whole as
well as individual letters.
Lettering text can be edited directly on-screen
or by means of object properties. When you
first create lettering, it may be too big or
small. Size can be adjusted interactively or
numerically. Small, narrow letters may not
require underlay, depending on their size and
the fabric to be used.
Use the available tools to skew and rotate
lettering objects. Adjust individual letters like
any other embroidery object. Reshape letters, adjust stitch angles, and recolor
letters individually. Baselines can be modified after placement directly on-screen
or via object properties.
This section describes how to edit lettering text. It also covers scaling lettering
and removing underlay from small lettering. It also deals with transforming
lettering objects, adjusting individual letters, as well as reshaping baselines.

Editing lettering text
When you have created a lettering object, you can
select it and make changes to the text directly
on-screen or via object properties.

Editing lettering text on-screen

An I-beam appears.

Click here to edit

2 Edit the text as required.

Use Digitize > Lettering to edit lettering on-screen.
The easiest way to edit lettering is to change it
directly on-screen.
To edit lettering text on-screen

1 Click the Lettering icon and then click inside the

Letter deleted

Tip Press Shift+Enter to start a new line.

3 Press Enter to complete.

lettering object.
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Editing lettering text with the Object
Properties dialog
When you have created a lettering object, you can
select it and make changes to it via object properties.

To scale lettering with Select Object

1 Click Select Object and select the lettering
object.
Resize vertically

To edit lettering with the Object Properties
dialog

Resize
proportionally

1 Double-click or right-click a lettering object.
The Object Properties > Lettering dialog
opens.

Edit text

Resize
horizontally

2 Click and drag a handle to resize the object
horizontally, vertically or proportionally.

Adjust
settings

Drag

3 Release the mouse to complete.
2 Edit the text in the text entry panel as required.
3 Adjust settings as required. See Formatting
lettering for details.

4 Click Apply.

Scaling lettering with Reshape Object
Use Transform > Reshape Object to scale lettering
objects on-screen.
You can scale your lettering objects vertically,
horizontally and proportionally with the Reshape
Object tool. See also Rotating lettering with Reshape
Object.

Note Letters are filled with stitches according to
current stitch settings in the Object Properties >
Fill Stitch dialog. You can change these at any
time. See Applying different stitch types & effects
to lettering for details.

To scale lettering with Reshape Object

1 Select the lettering object and click the Reshape
Object icon.

Scaling lettering
When you first create lettering, it may be too big or
too small. Size can be adjusted interactively or via
object properties.

Scaling lettering with Select Object
Use Transform > Select Object to scale lettering
objects on-screen.
You can scale your lettering objects vertically,
horizontally and proportionally with the Select
Object tool. See also Transforming lettering with
Select Object.
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2 Click and drag a dark triangular handle to scale the
object horizontally, vertically or proportionally.

The Object Properties > Lettering dialog
opens.
Enter height

Drag

Adjust width
percentage
Resize
vertically

Drag

Resize
proportionally

2 Enter the height in the Height field.
Note Letter height can be between 1 mm and
200 mm. See also Embroidery Fonts.

3 Enter the width as a percentage of height in the
Drag
Resize
horizontally

Width field.

4 Click Apply.
The setting is applied to any selected lettering
objects or to newly created lettering objects.

3 Release the mouse button to complete and press

Width 100%

Esc.

Width 140%

Resized
vertically

Resized
proportionally

Resized
horizontally

Width 70%

Tip Optionally, use the width and height controls
on the Transform toolbar to resize selected
lettering objects.

Check position of
selection

Adjusting letter dimensions
Right-click Digitize > Lettering to adjust letter
dimensions.
You can scale your lettering objects vertically,
horizontally and proportionally via object properties.
To adjust letter dimensions

1 Double-click or right-click a lettering object.

Removing underlay from small lettering
Use Effects > Auto Underlay to strengthen and
stabilize objects with underlay stitching.
The quality of most lettering can be improved with an
underlay using the same methods as for other
embroidery objects. Small, narrow letters, however,
may not require underlay, depending on their size and
the fabric to be used. See also Stabilizing with
underlays.
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To remove underlay from small lettering

Another set of selection handles appears – these
let you rotate and skew the object.

1 Select the lettering object.

Skew handle

2 Click the Auto Underlay icon.
The underlay is removed.
Rotation
handles

Rotation point

3 Click and drag one of the diamond-shaped handles
to skew the lettering object horizontally.
Drag

Transforming lettering objects
Use the available tools to skew and rotate lettering
objects. See also Scaling lettering.

4 Click and drag one of the hollow square handles to
rotate the object.

Drag

Transforming lettering with Select Object

Rotation
point

Use Transform > Select Object to scale lettering
objects on-screen.
You can transform lettering objects by manipulating
control points on-screen with the Select Object tool.
See also Scaling lettering with Select Object.

Tip Drag the rotation point itself to a new location
as required.

To transform lettering with Select Object

1 Click Select Object and select the lettering
object.
Selection handles appear – these let you scale the
object. See Scaling lettering with Select Object for
details.

2 Click the lettering object again.

New rotation point

5 Release the mouse to complete.

Rotating lettering with Reshape Object
Use Transform > Reshape Object to rotate lettering
objects on-screen.
You can rotate lettering objects by manipulating
control points on-screen. See also Scaling lettering
with Select Object.
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To rotate lettering with Reshape Object

To reposition letters on screen

1 Select the lettering object and click the Reshape

1 Select the lettering object.

Object icon.
Control points appear around the lettering object.

2 Click Reshape Object.
3 Click the diamond control point in the centre of the
letter.

Rotate baseline selection handle

2 Click and drag a solid square handle to rotate the
Click diamond control points

lettering object.

Tip To select multiple or a range of letters, hold
down Ctrl or Shift as you select.
Drag

4 Click-and-drag the letter to the new position:
 To move the letter horizontally, drag it along
the baseline.

3 Release the mouse button to complete and press
Esc.

 To move the letter vertically, hold down Shift
as you drag.
 To move the letter freely, hold down Ctrl as you
drag.

Adjusting individual letters
As well as scaling and rotating lettering objects, the
Reshape Object tool is used to manipulate individual
letters. You can reposition letters in relation to each
other, scale, rotate and skew them. You can also
reshape individual letters, adjust stitch angles, and
recolor them individually.

5 Release the mouse to complete and press Esc.

Transforming letters on screen
Repositioning letters on screen
Use Transform > Reshape Object to reposition
individual letters on screen.
You can reposition individual letters in a lettering
object using the Reshape Object tool.

Use Transform > Reshape Object to transform
individual letters on screen.
You can transform individual letters by manipulating
control points on screen with the Reshape Object
tool.
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To transform letters on screen

To reshape letters on screen

1 Select the lettering object and click Reshape

1 Select the lettering object and click the Reshape

Object.

Object icon.
Click letter outline

2 Click the diamond control point of a letter.
Another set of reshape nodes appear around the
letter.
Drag to scale
letter height

2 Click the letter outline. Reshape nodes appear
around it.

Drag to scale letter
proportionally

Drag to skew
Drag to scale
letter width
Drag to rotate

3 Click-and-drag a reshape node around the letter to
transform it.

3 Zoom in the letter for precise reshaping. See
Zooming in & out for details.

4 Reshape the letter by adding, deleting, changing
or moving reshape nodes. See Reshaping objects
using reshape nodes for details.

4 Press Esc to finish.

Add, delete, move
reshape nodes

Reshaping letters on screen
Use Transform > Reshape Object to reshape
individual letters.

5 Press Esc and zoom out to view the results.

Create special lettering effects by reshaping letter
outlines with the Reshape Object tool.
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Breaking apart lettering for editing
Use Edit > Break Apart to split monograms,
appliqués, lettering, and blackwork runs into
component objects.
Applying the Break Apart function to a lettering
object breaks it into a logical stitching sequence while
maintaining lettering object characteristics. Object
properties can be edited separately for single lines,
single words, or even single characters. Stitching
sequence is maintained. See also Splitting into
component objects.

To add stitch angles to letters

1 Select a lettering object.
2 Click the Add Stitch Angles icon.
You are prompted to enter angle point 1.

3 Digitize stitch angles so that they intersect two
sides of the object.

Individual letter
broken into
component
‘patches’

Note Make sure that the stitch angles do not
intersect each other.

4 Press Enter.
Stitches are regenerated with the new angles.
Lettering broken apart into
logical stitching sequence

Deleting stitch angles of letters
Use Transform > Reshape Object to delete individual
stitch angles in lettering objects.

Sequence logic is as follows:
 Multi-line lettering can be broken into separate
objects per line
 Individual lines can be broken into separate
objects per word
 Words can be broken into separate objects per
letter.
 Letters can be broken into their individual
embroidery patches. Lettering properties are lost
but properties of each patch can be individually
modified.

Delete individual stitch angles in lettering objects with
the Reshape Object icon.
To delete stitch angles of letters

1 Select the lettering object and click the Reshape
Object icon.

2 Click the diamond handle at the center of a letter.
3 Click the letter outline.
Reshape nodes appear around it.

4 Select and delete reshape nodes as required.

Tip An exception for single-line (multi-word) objects
is the case of the center-out stitching sequence. Such
objects are broken apart directly into single-letter
objects. The stitching sequence is thereby preserved.

Adding stitch angles to letters
Use Edit > Add Stitch Angles to set different stitch
angles for selected letters.

Note Lettering outlines are preserved after any
angle deletion.

Set different stitch angles within letters with the
Stitch Angle icon. Each segment of the letter can
have a different stitch angle.
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Recoloring letters
Use Digitize > Lettering to recolor letters.
BERNINA Embroidery Software lets you change the
color of individual letters within a lettering object.

Tip You can also insert a color change between two
letters by keying a caret (^) symbol. Subsequent
letters default to the next color in the palette. See
Creating lettering via dialog for details.

To reshape a baseline
 Select the lettering object and click the Reshape
Object icon.
Different control points display for different types
of baseline.

Baseline selection
handles

To recolor letters

1 Click the Lettering icon and then click inside the
lettering object. An I-beam appears.

I-beam

2 Select a letter(s) by dragging the cursor over the
letter(s).

Drag the cursor over the letter

Tip The large diamond and cross represent start
and end points. You may need to move them to
access baseline selection handles. They will
reposition themselves automatically based on
changes you make.
 To change the angle of a straight or vertical
baseline, click and drag one of the large solid
squares.

3 Click a color on the color palette.
4 Press Enter to confirm changes.

Drag up or
down

 To adjust the baseline length, click and drag the
open triangle handle.
Letter spacing adjusts accordingly.

Reshaping baselines
Drag triangle

Use Transform > Reshape Object to reshape
lettering baselines.
Baselines can be adjusted on-screen after they have
been placed in your design. Reshape straight
baselines to place them on an angle. For Vertical
baselines, you can also change baseline length and
letter spacing. Reshape Circle and baselines to
change curve depth, justification point and baseline
length. Reshape Any Shape baselines by moving,
changing, adding or deleting reshape nodes along the
baseline. See also Applying lettering baselines.
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 To reshape lettering with a circular baseline, drag
the handle at the circle center to adjust the radius.

like any embroidery object. See Reshaping objects
using reshape nodes for details.

Drag up or down to change
radius of circle

 On a circular baseline, there are actually two
selection handles at the circumference of the
circle, one on top of the other. Drag them apart to
create an arc.

Click baseline to bend, then
drag up or down

Press spacebar to
change between
corners and curves

Drag to change circle baseline to arc

 Press Esc to finish.

 To change letter spacing evenly around a circular
baseline, click and drag the triangle.

Drag triangle to
change spacing evenly

Tip The exact letter positions depend on the
justification – Left Justification, Right Justification,
Center Justification, or Full Justification. If the
baseline becomes too short, letter spacing is
reduced, and letters may overlap. See Setting
letter justification for details.
 To adjust Any Shape baselines, add, delete,
change or move reshape nodes on the base line
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CHAPTER 30
SPECIAL LETTERING FEATURES
All TrueType or OpenType fonts installed on your
computer are also available to you when placing
lettering in your designs. BERNINA Embroidery
Software lets you add special characters to your
lettering which do not appear on the keyboard.
BERNINA Embroidery Software also provides a
number of special fonts for fancy lettering as well
as monogramming. Like all embroidery objects,
each lettering object has its own properties. You
can adjust these before or after creating lettering
objects. BERNINA Embroidery Software also gives
you precise control over the stitch angles of
individual letters. Apply Elastic Lettering effects to
lettering objects to make them bulge or arch, stretch or compress.
This section describes how to convert TrueType fonts to embroidery fonts. It also
explains how to add special characters as well as fancy and monogram lettering
to your designs. It also covers applying different stitch types to lettering objects
as well as creating special effects with Elastic Lettering.

Converting graphic fonts to embroidery Converting text to embroidery
In addition to the professional embroidery fonts
included with the software, BERNINA Embroidery
Software provides various techniques for converting
any installed TrueType and OpenType font on your
system to embroidery.

Use Canvas > Convert Artwork to Embroidery
to convert text to satin embroidery lettering
with turning stitching.
The Convert tool converts selected CorelDRAW® text
objects to:
 Satin embroidery lettering with turning stitching if
the text is not enveloped and does not have an
outline, or
 Non-lettering if the text is enveloped and has an
outline.
To convert text to embroidery

1 Select Artwork Canvas mode.
Note Not all TrueType fonts are suitable for including
in embroidery designs. Experiment with the ones you
like and try different stitch settings.
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2 Select one or more text objects and click the
Convert tool.

To convert a font to embroidery

BERNINA Embroidery Software automatically
switches to Embroidery Canvas. Source objects
are removed from the design.

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens.

Once converted to an embroidery font, you can
apply whatever font you prefer.
Select
TrueType font

2 Select a font from the Alphabet list.
Any TrueType or OpenType fonts installed on your
computer are listed.

3 Enter the text you want to embroider in the text
entry panel.

4 Click Apply.
5 Click on-screen where you want to place the
Tip You can also use the Convert tool with
ordinary vector objects. See also Converting
vector artwork.
Note If the selection contains both text fitted to a
path and a drawing object, only the text will be
converted to embroidery. The solution is to convert
everything to curves before conversion.

Converting fonts to embroidery
Right-click Digitize > Lettering to convert TrueType
fonts to embroidery fonts via the dialog.
MS Windows® comes with a collection of TrueType
and OpenType fonts installed and there are others
available from various sources, including
CorelDRAW® Essentials X6. All these fonts are
available to you when placing lettering in your
designs.

letters.
The text is stitched using the selected font.

Tip Not all TrueType fonts are suitable for
including in embroidery designs. Experiment with
the ones you like and try different stitch settings.

Adding special characters
In BERNINA Embroidery Software, you can add
special characters and symbols directly through the
Select Symbols dialog or by means of the
MS Windows® Character Map.

Selecting special characters
Tip Install new fonts using My Computer > Control
Panel. Double-click the Fonts folder then select File
> Install New Font. Before you can use the new
fonts, you need to restart your computer and then
BERNINA Embroidery Software will display the new
fonts in the Alphabet list.

Right-click Digitize > Lettering to select special
characters via the dialog.
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You can quickly add special
characters and symbols to
your lettering designs. If you
know the keyboard shortcut
for a symbol, add it to your
lettering by entering the
combination on-screen or in
the Object Properties >
Lettering dialog.

Tip When you select a character, a keystroke
appears in the Selection field. This indicates the
key combination required to type the character
directly on-screen. For example, ‘m’ means press
the m key while ‘M’ means press Shift+M.

5 Click OK.
The selected characters are displayed in the text
entry panel.

To select special
characters

6 Click Apply.

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens.

Using the Character Map
Use the MS Windows® Character Map to provide
quick access to common symbols and letters. The
Character Map is usually installed as part of the
MS Windows® setup. See your MS Windows®
documentation for more details.
Click to select
special characters

Tip If you know the Alt key code for the special
character you require, you can key it directly into
the text entry field. The Character Map gives you
codes for all characters. See Using the Character
Map for details.

2 Click Select Character.
The Select Character dialog opens.
Select viewing mode
Select font

Tip You can create special characters in each font by
holding down the Alt key on your keyboard and
typing 0 (zero), its code, using the numbers on the
keypad. For example, to type è with the code 232,
type Alt+0232. The character will appear when you
release the Alt key. The Character Map gives you
codes for all characters.
To use the Character Map

1 Open the MS Windows® Character Map.
By default, you will find it under Start >
Programs > Accessories > System Tools >
Character Map.

Select
character

Corresponding
keystrokes

Tip Select a viewing mode – you can list fonts by
picture, character, or both.

3 Select a font from the Font list.
4 Select the character(s) you want to use.

Alt key combination

2 Double-click a character, or select it and press
Select.
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The character appears in the Characters to copy
box.

The Object Properties > Lettering dialog
opens.
Select Creative Cross or
Secret Garden-Caps

Note The equivalent Alt key combination is
shown at the bottom of the dialog. This can be
used to key the character directly on screen.

3 Click Copy to copy the character to the clipboard.
4 Paste it into the text entry panel by pressing
Ctrl+V.

5 Click Apply.
Continue creating the lettering object in the
normal way.

Using special fonts
BERNINA Embroidery Software provides a number of
special fonts for fancy lettering as well as
monogramming. See also Embroidery Fonts.

Click to select fancy
lettering characters

2 Select one of the included special fonts from the
Alphabet list – e.g. ‘Creative Cross’ or ‘Secret
Garden-Caps’.

3 Optionally, use the Select Character button to
preview and select special characters.
Select viewing mode

Adding fancy lettering
Right-click Digitize > Lettering to add fancy lettering
via the dialog.

Select
character

Use Edit > Break Apart to split monograms,
appliqués, lettering, and blackwork runs into
component objects.
BERNINA Embroidery Software includes a number of
fancy fonts such as Creative Cross and Secret
Garden-Caps. These fonts include multiple colors
and miniature designs. In effect, each letter is a
self-contained design. This presents a few challenges
when it comes to coloring and sequencing.

Corresponding
keystrokes

Tip When you select a character, a corresponding
keystroke appears in the Selection field. You can
use this to type the character directly on-screen
once the font is selected.

4 Click Apply and click a starting point on-screen.
Colors will default to the initial colors in the Color
Palette. The letters will appear as a single
lettering object in the Color Film.

To add fancy lettering

1 Right-click the Lettering icon.

5 Place and size the lettering object as desired.
Don’t worry about colors for the moment.

6 Optionally, in order to change colors, assign them
via the Design Properties > Thread Colors
dialog. See Matching threads for details.
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Notice in the Color Film object list, each letter is
sewn out separately. This involves many color
changes.

Each letter sewn out
separately

Flair script is a special font which allows you to add
decorative flairs to the end of text objects, mimicking
flamboyant handwriting flourishes.

To add flair script lettering

1 Right-click the Lettering icon.
The Object Details > Lettering dialog opens.

7 Optionally, use the Break Apart tool to split the
lettering object into its components. See Breaking
apart lettering for editing for details.
These can then be recolored and resequenced as
desired. However, note that lettering properties
are lost.

Enter text

Select Flair
Script font

Click for
special
characters
Colors resequenced,
lettering properties
lost

2 Select Flair Script from the Font list.
3 Enter the text you want to embroider in the text
entry panel.

4 Click Select Character.
The Select Character dialog opens.

Adding flair script lettering
Right-click Digitize > Lettering to add flair script
lettering via the dialog.

Select flare

Corresponding
keystrokes

5 Select the flare character(s) you want to use.
Scroll down for more options. See also Selecting
special characters.
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6 Click OK to close the dialog.
The selected characters are displayed in the text
entry panel.

7 Adjust lettering as required. See Adding lettering
to embroidery designs for details.

8 Click OK.
9 Click where you want to place the lettering, or
mark reference points for the selected baseline.

10 Press Enter.

positions, plus a border and flourish for
two-letter designs. See also Embroidery Fonts.
 Use Diamond3 for a three-letter monogram:
Diamond3 is a special font which includes three
versions of each letter for left, center and right
positions, plus a border and flourish for 3-letter
designs.

3 Click Select Character.
The Select Character dialog opens.
Tip Select a viewing mode – you can list fonts by
picture, character, or both.
Select viewing mode

Select
character

Tip Experiment with different flare characters to
obtain the look you want.

Adding monogram lettering
In addition to the dedicated Monogramming
feature, BERNINA Embroidery Software allows you to
create monogramming designs using special
monogram fonts. Use Diamond2 for 2-letter
monograms and Diamond3 for 3-letter monograms.
See also Monogramming.
To add monogram lettering

1 Right-click the Lettering icon.
The Object Properties > Lettering dialog
opens.
Select Diamond2
or Diamond3

Corresponding
keystrokes

Tip When you select a character, a keystroke
appears in the Selection field. This indicates the
key combination required to type the character
directly on-screen. For example, ‘m’ means press
the m key while ‘M’ means press Shift+M.

4 Select a left letter.
Note When selecting letters, make sure the letter
orientation is correct. For example, Diamond3 has
three sets of each letter, one for the left side, one
for the middle and one for the right side.

5 Select the middle letter, if using Diamond3.
6 Select the right letter.

7 Select a border if required.
Click to select fancy
lettering characters

Select
border

2 Select the desired monogram font:
 Diamond2 for a two-letter monogram:
Diamond2 is a special font which includes two
versions of each letter for left and right

8 Click OK.
The selected characters are displayed in the text
entry panel.
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9 Click Apply.
Diamond2
monogram

Diamond3
monogram

Where a letter is narrow, stitches are tight, thus
requiring fewer stitches to cover the fabric. Where a
column is very narrow, stitches need to be less dense
because too many needle penetrations can damage
the fabric. See also Adjusting satin stitch spacing.

Automatic Spacing

Tip If you want the letters in your monogram to
be different styles, create each letter separately.
Manual Spacing

Applying different stitch types & effects
to lettering
By default, lettering objects are filled with satin
stitching. You can apply other fill stitch types, such as
Step or Fancy, as with any other embroidery object.

Note For larger lettering objects, various techniques
are available for controlling long stitches. See
Preserving long stitches for details. See also Splitting
long stitches in satin fills.

Applying Raised Satin to lettering
Raised Satin can be applied to lettering with or
without trapunto outlines to create raised lettering.
See also Quilted embroidery.

Raised Satin
Lettering

Adjusting Satin stitch settings for lettering
By default, lettering objects are filled with satin stitch.
You can fill lettering shapes with Special Satin
stitching as well as the regular satin stitch. It is
particularly suitable for filling large, irregular lettering
shapes that are too large for satin stitch. See Creating
satin fills for details.

Raised Lettering with
trapunto outlines

Applying Step stitch settings to lettering
You can fill lettering shapes with Step stitch. It is
particularly suitable for filling large, irregular lettering
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shapes. Adjust stitch density and pattern as desired.
See Creating step stitch fills for details.

with curved elastic lettering. Elastic Lettering can be
used with any baseline.

Applying Fancy stitch settings to lettering
You can fill lettering shapes with Fancy stitching as
well as the regular satin stitch. It is particularly
suitable for filling large, irregular lettering shapes that
are too large for satin stitch. The density is
determined by the stitch spacing setting. See also
Creating fancy fills.

Caution If you get an ‘Out of Memory’ error on your
A200 or A730 embroidery machine, there are two
possible workarounds:
 Select the lettering object and click the Break
Apart tool before sending the design. This will
turn lettering into embroidery patches – i.e. no
longer a lettering object. See Splitting into
component objects for details.
 Save as EXP and send to the machine as an EXP
file.

Distorting lettering objects

Creating ‘elastic lettering’ effects
Apply Elastic Lettering effects to lettering objects to
make them bulge or arch, stretch or compress. You
can create slant or pennant lettering with straight
Elastic Lettering. You can create bulges and arches

Four types of Elastic Lettering effect are available –
Straight, Curved, Perspective and Diamond.
To distort lettering objects

1 Select the lettering object you want to distort.
2 Select Edit > Elastic Lettering.
3 Select an elastic type from among the following
alternatives:

Straight

Curved

Perspective

Diamond
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Different handles display around the object outline
depending on the Elastic Lettering type.

2 Click inside the duplicate lettering object and edit
text as required.

Curved
reshape
handles

4 Drag a handle to reshape the object:
 To move two handles in opposite directions,
hold the Shift key down while dragging a
handle.
Shift+drag

3 Press Enter to complete.
The lettering in the Elastic Lettering is updated.

Removing Elastic Lettering
 To move the handles in the same direction, hold
down the Ctrl key while dragging a handle.
Ctrl+drag

Return an object to its original shape by removing the
Elastic Lettering.
To remove Elastic Lettering
 Select the lettering object.
 Select Edit > Elastic Lettering > None.
The Elastic Lettering is removed and the letters
return to their original shape.

5 Press Enter to complete.

Editing lettering in Elastic Lettering

o

Click Digitize > Lettering to edit letters in envelopes
on-screen.

You can edit lettering in Elastic Lettering on-screen in
the same way as normal lettering. When you click
inside the lettering, a duplicate displays below the
envelope.
To edit lettering in Elastic Lettering

1 Click the Lettering icon then click inside the
lettering object.
Duplicate letters appear below the selected shape
in their original form. The cursor changes to an
I-beam and appears after the last letter.
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CHAPTER 31
MONOGRAMMING
A monogram is a design composed of one
or more letters, typically the initials of a
name, used as an identifying mark. The
Monogramming feature offers a simple way
to create personalized monograms using a
selection of pre-defined monogramming
styles, border shapes and ornaments,
together with a set of tools to help you
place these elements in creative and
decorative ways.
This section details the creation of
monogram lettering with initials or with a
name, how to add ornaments to
monograms, and how to create ornament
layouts. It also covers adding and creating
your own borders.

Monogram designs
Use Digitize > Monogramming to create
personalized monograms using a selection of
pre-defined monogramming styles, border shapes
and ornaments.

one as a starting point and then modify by means of
the other tabs.

Select monogram type and
choose a design template

You build monograms using the Monogramming
docker. The simplest way to get started is to select a
base design from the new Designs tab. This tab gives
you a selection of design templates ranging from
lettering only, with borders, or with ornaments. Select

Note that the monogramming design is grouped in the
Color Film docker. It is treated as a single, composite
object. It can only be edited via the Monogramming
docker. It cannot be ungrouped but it can be broken
BERNINA® Embroidery Software : Reference Manual

290

Chapter 31 : Monogramming
apart into its components. See also Breaking apart
lettering for editing.

can be entered into your monogramming design,
including special characters and symbols.

Monogram grouped as
composite object

However, if all you want to do is recolor monogram
elements, you can select them individually without
breaking apart the monogram. Simply hold down Alt
and click the object.

The Letters tab provides similar options to the
Lettering tab of the Object Properties docker. If
you are using one of the template designs, the easiest
way to adapt it is to apply a different style. Change
initials as required and choose from any number of
native embroidery fonts or any TrueType font installed
on your system. In addition, this tab also provides a
selection of styles to choose from.

Use Alt key to
select and recolor
Choose lettering
style
Choose lettering
font

Monogram lettering
Use Digitize > Monogramming to create
personalized monograms using a selection of
pre-defined monogramming styles, border shapes
and ornaments.
The Letters tab of the Monogramming docker
allows you to create personalized monograms with
initials, including special characters and symbols, or
unlimited lines of characters. Any number of initials
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In place of single letters, the same tab allows you to
enter multiple lines.

lettering. All settings can, however, be controlled via
the Object Properties dialog.

Enter multiple
lines of text

Access complete set of
object properties

Monogram ornaments
If a selected style doesn’t quite give you what you are
looking for, open the Advanced panel to access more
settings. Use these to adjust letter width, spacing,
etc. Adjust letter rotation and baseline angle. These
allow you rotate individual letters or the entire
baseline.
Access advanced
settings

Use Digitize > Monogramming to create
personalized monograms using a selection of
pre-defined monogramming styles, border shapes
and ornaments.
Ornaments can be added to a monogram either from
motif patterns or from any design file. You have a
choice of:
 Adding ornament motif patterns or designs
 Creating single ornament layouts
 Creating multi-ornament layouts.

Access full set of
object properties

Click Properties to make any further adjustments –
e.g. stitch type. The default values for monogram
lettering are different from those for conventional

Modifying ornaments
If you are using a template design or adapting
another monogram, it is a simple matter to change
the ornament to a different type or configuration. Use
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the buttons at the top of the Ornaments tab to add,
delete, or change ornaments.

These settings give you precise control over ornament
placement, size, rotation, orientation, and margin.

Adding ornaments

Choose from a range of preset placement patterns,
including Mirrors, Duplicates, and Cycle. Note that
the pyramid icon indicates not only the placement but
also the orientation of the pattern in both horizontal
and vertical planes.

If the preset pattern gallery doesn’t quite give you
what you are looking for, open the Advanced panel.

You can add up to ten ornament sets to a monogram
design and change them at any time. Any available
pattern set can be used. A set of ornamental designs
is also available. These are stored in their own
Decorative Accents folder.

Use the checkboxes to add up to eight instances of a
selected ornament. These are arranged according to
ornament placements relative to the lettering.
Excluding position #5, any combination of
checkboxes can be used.
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The first selected serves as the ‘anchor’ position
(highlighted in red). All other ornaments are sized,
rotated and mirrored in relation to it. Use the Width
and Height fields to change ornament dimensions.
The Lock Aspect Ratio toggle forces width and
height to maintain their proportions. Use the Margin
setting to offset ornaments from the lettering.

Monogram borders

Creating single ornament layouts

You can add up to four borders of the same shape to
a monogram design.

Use Position #5 to insert an ornament as a
standalone element within a set. All other checkboxes
are unchecked automatically. Width, Height, and
Rotate By fields and Mirror checkboxes remain
available, and Offset controls replace the Margin
control.

Position ornament relative
to lettering object

Use the X and Y fields in the Offset panel to position
the ornament horizontally or vertically relative to the
lettering object. These settings specify the position of
the ornament center relative to the center of the
lettering object.

Use Digitize > Monogramming to create
personalized monograms using a selection of
pre-defined monogramming styles, border shapes
and ornaments.

Changing borders
If you are using one of the template designs, it is a
simple matter to change borders. Use the Change
button on the Borders tab to select from one of the
many available.

Multi-ornament layouts
You can add up to eight instances of a selected
ornament to your monogram. Any combination of
ornaments and ornament positions can be used. Add
the ornament sets you want and assign placements to
each one.

Remember, if you want to recolor monogram
elements, you can select them individually without
breaking apart the monogram. Simply hold down Alt
and click the object.
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Adjusting border shape & offset
Use the Aspect Ratio settings to adjust height and
width proportions.

Adjust aspect ratio to
change border
proportions

Use the Rotate field to re-orientate the border as
desired.

Adding multiple borders

Add up to four borders to the selected monogram. Use
the Offset field to adjust margins between multiple
Use the Offset field to fine-tune margins between
borders. The software lets you enter a negative offset.
lettering and border, and between border and border. This allows you to create multiple overlapping
borders.

Use the Stitch Type buttons to change to line or fill
stitch type for selected borders. Satin Line is the
default stitch type. All line and fill stitch types
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The Create Border dialog opens.

available in the software can be used as borders. Click
the Properties button to make further adjustments.

Select border set
Enter name for
new border

Cloud

3 Select a border set from the list.
Optionally, click Create to define a new border set.
Enter a name and click OK.

Remember, if you want to recolor monogram
elements, you can select them individually without
breaking apart the monogram. Simply hold down Alt
and click the object.

Custom borders
The Add Border dialog offers a list of pre-defined
border shapes. You can also create your own to add
to the library. These can be saved to the default
‘Borders’ set or one of your own creation. Borders
must be closed and, by default, Satin is always used
as the default border stitch type. This can be changed
once the border is selected in the Monogramming
dialog.

Tip Like borders, you can create your own ornament
patterns for use in monograms using the Create
Pattern tool. See Managing patterns for details.

My Borders

4 Enter a name for your new border and click OK.
You are prompted to digitize the start and end
points of the border.

5 Click to mark two reference points on the border.
Reference points set the standard orientation of
the border.

Mark reference
points

2

1

6 Click OK.
The new border is saved to the border set and a
confirmation message displayed.

To create your own border

1 Select the closed embroidery object you want to
save as a border.

2 Select Settings > Create Border.
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PART VII
DESIGN PROCESSING & OUTPUT
At some stage you will actually want to output your designs to printer, machine, or
storage device. For this, you will need an understanding of the different print options,
embroidery file types and the storage media available.

Hooping designs
This section describes how to choose and display hoops in BERNINA Embroidery
Software. It covers creating and modifying custom hoops. It also deals with hooping
large designs. See Hooping Designs for details.

Outputting designs
This section describes how to print worksheets, appliqué patterns, color films, and
thread charts. It also covers stitching out designs, both singly and as multi-hooped
designs. See Outputting Designs for details.

Machine files
This section describes how to select conversion options for opening and saving different
stitch and outline design formats. It also deals with storing designs to design card. See
Working with Machine Files for details.
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CHAPTER 32
HOOPING DESIGNS
Fabrics must be hooped before stitching out on the machine. BERNINA
Embroidery Software allows you to select from a wide range of standard
factory-supplied hoops. If your project contains a large design or a number of
smaller designs, you may need to use multiple hoopings. If you have a hoop
which does not appear in the list, you can define a custom hoop from scratch or
based on a standard hoop. See also Displaying the hoop.

This section describes how to choose and display hoops in BERNINA Embroidery
Software. It covers creating and modifying custom hoops. It also deals with
hooping large designs.

Hooping concepts
There are four main cases when hooping designs in
BERNINA Embroidery Software:
 A single design that fits within a single hoop.
 A single design that fits within a single hoop, but
which is repeated continuously.
 Large work-piece layouts involving multiple
designs each requiring its own hooping.

 Large single designs that will not fit within a single
hoop and require multiple hoopings.
With each hooping, there is generally only one
important reference point – the center of the hoop.
This is particularly so where machines automatically
center the design. When designs are located on a
large work piece, like a table cloth, design extents and
geometric center become important for positioning.
Single designs in single hoopings
As a beginner, you will generally use designs that fit
entirely within the available hoops for your particular
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machine. You will mostly use default settings both in
the software and the machine. The hoop center
becomes the reference point for all designs you do in
this manner. This technique provides the basis for all
other techniques you will use. See Stitching out single
designs for details.

Single hoop work-piece layouts
As an intermediate user, you may want to create
design layouts on large work pieces. Each design will
still fit in a single hoop but there may be multiple
designs in the layout. Each hooping has its own
reference point that is used with the hoop template to
accurately place the design at the correct orientation.
As there is only one design per hooping, there is no
need for secondary placement points. The main
benefit of this technique is that the complete layout
can be accommodated within a single design file with
the work piece as reference and all components
included. See Stitching out work-piece layouts for
details.

Continuous embroidery
Continuous embroidery consists of a single design,
repeated continuously, that fits within a single hoop.

Multi-hooped designs
If your design is too large or involves a large work
area, you have the option of splitting it into multiple
hoopings. The Multi-Hooping toolset lets you
strategically position hoops until you obtain the least

In BERNINA Embroidery Software, continuous
embroidery can be achieved in one of two ways:
 Automatic continuous embroidery consists of
multiple design repeats combined with
multi-hooping to create output files with automatic
registration marks. See Automatic continuous
embroidery for details.
 Manual continuous embroidery consists of a single
design with manually inserted basting stitch
markers or graphic markers at start and end of
design for alignment. See Manual continuous
embroidery for details.
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number of hoopings necessary to accommodate the
whole design layout.

Each hooping contains an object or group of objects
that can be stitched out on their own. Hoopings are
stitched consecutively to form the whole design. They
can be sent directly to machine or saved to file. See
Creating multiple hoopings for details.

centering marks on the frames. These help with
aligning both the fabric and the design.

Bernina hoops also come with a clear plastic template
overlay. These include alignment lines, with tiny holes
which allow you to create positioning marks.
Positioning templates for all Bernina hoops are
included in BERNINA Embroidery Software. Hoop
templates can be toggled on or off independently of
the hoop itself.

Selecting hoops
Whenever you create a new design, a single hoop
representing the embroidery hoop you connect to
your embroidery machine appears by default in the
design window. A range of hoop sizes is available for
supported machine types. You can change hoop
orientation on screen for ease of digitizing.

Hoops & templates
When it comes to stitching out, it is important to align
the fabric squarely in the hoop, with even pressure on
all sides, and fabric patterns and weaves running
perpendicular to the hoop. Otherwise, fabric bias
allows stretch. This can distort stitching and result in
puckering. Each hoop contains vertical and horizontal

The software also lets you specify which foot you are
using with your selected hoop. It then adapts the
allowable sewing area accordingly.

Embroidery
foot # 15

Embroidery
foot # 26

Uses...
 Templates are displayed with alignment and
registration guide markings. This allows you to
align the design in the hoop on screen, relative to
the markings.
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 Templates are printed with alignment and
registration markings. This allows you to cut out
the printed design and align it in the hoop with the
physical template.

 Select the foot you are currently using. This will
affect the stitchable area within the hoop.

Choose your
current foot

Changing hoops
Click View > Show Hoop to show or hide hoop.
Right-click for settings.
Click View > Show Hoop Template to show or hide
hoop template.

 Use the checkboxes to toggle on/off hoop display
or the hoop template. The template may be used
to help position your design within the hoop.

From the range of hoop sizes available, select the
smallest hoop which will accommodate your design.
This will hold the fabric tight while stitching. When
you choose a new hoop, it becomes the ‘current’ hoop
until changed in the present or a future session.
To change hoops
 Right-click the Show Hoop icon.
The Options > Machine & Hoop dialog opens.

 Alternatively, use the View toolbar toggles to turn
on/off hoop and/or hoop template.

 Choose your machine. The hoop list is filtered to
display compatible hoops.

Choose your
machine

Tip You can include the hoop template in the
design worksheet, together with alignment and
registration guide markings. This allows you to cut
out the printed design and align it within the hoop.
Use the template markings to align it to physical
hoop template. See Printing multi-hooped designs
for details.

Centering hoops
Click View > Show Hoop to show or hide hoop.
Right-click to change hoop settings.

 Select a hoop to suit your current design.

Choose a
suitable hoop

By default, BERNINA Embroidery Software ensures
that your design is always centered in the hoop.
However, you can use the manual option to lock the
hoop position. This means it won’t automatically
center while you are digitizing. If you are creating a
single hooping, however, always turn on
auto-centering to check that the design will fit within
the selected hoop.

Note Some embroidery machines will always center
the design. You can set your software to match the
exact behavior of the machine.
Note In the hoop droplist, factory hoops are
shown with a green, rounded-rectangle icon, while
custom hoops are shown with a grey, circular icon.

BERNINA® Embroidery Software : Reference Manual

301

Chapter 32 : Hooping Designs
you to maintain start and end connectors. See also
Stitching out embroidery on garments.

To set the hoop center
 Select Settings > Options and select the Hoop
tab or right-click the Show Hoop icon.
The Options > Machine & Hoop dialog opens.

 With machines that always start in the center of
the hoop, make sure automatic centering is set to
the start needle position. See also Setting
automatic start & end points.

Choose centering
method

 In the Position panel, specify how you want the
hoop centered:
Option

Purpose

Automatic
centering

The hoop always centers itself around
the design center.

At start needle
position

The hoop centers itself around the start
needle point. If using this option, you
should turn off the ‘Maintain
Automatically’ option in Auto Start &
End. See also Setting automatic start &
end points.

Manual

Allows manual placement of the design
anywhere in the hoop. Only suitable for
machines which allow off-centering of
designs within the hoop.

Set hoop
center

Allows an arbitrary hoop center to be
created by digitizing a point in the
design window.

Machine settings
Start point is at
center of hoop

Creating multiple hoopings
BERNINA Embroidery Software allows you to specify
multiple hoopings manually or automatically. Manual
hooping is generally better than automatic, except for
simple designs. However, it does require greater
understanding of both design and production
processes.

 Click OK.
 If you have selected Set Hoop Center, click a
point in the design window where you want to
center the hoop.

Automatic centering

Manual

 If you want to off-center the design, turn off
Maintain Automatically. You might do this to set
up continuous designs or for special placements
such as pockets. Use this with machines that allow

Note When a large design requires multiple
hoopings, it is important to establish the stitching
order so that objects in the foreground are sewn after
those in the background. This is normal practice for
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any design. See Combining & Sequencing Objects for
details.

 Designs can be saved with all hoops as a single
‘master’ multi-hooping design.

Multi-hooping concepts

 Registration marks can be turned off if you want to
digitize your own.

The goal of multi-hooping is to:
 Accommodate a design within a minimum number
of hoopings.
 Maximize overlaps between successive hoopings.
 Hoop the design within the maximum registration
mark margin.
 Set splitting lines, in overlapping areas, where an
object cannot be accommodated within a single
hooping.
Note ‘Hooping’ is not the same thing as ‘hoop
position’ – you can have more hoopings than hoop
positions but you can never have less. In other words,
a single hoop position may involve more than one
hooping in order to preserve the design sequence.
Multi-hooping rules
When BERNINA Embroidery Software calculates
multiple hoopings, it attempts to include whole
objects within sequential hoopings. Where one object
overlaps another, the overlapped object must be
stitched before the overlapping object. Thus:
 Hoopings should be placed as near as possible to
the order of the actual design object sequence.
 Each successive hooping overlaps a previously
stitched hooping.

Calculation time
The time to calculate design hoopings depends more
on the number of objects and hoop positions than
stitch count. Designs converted from EXP, PES, HUS,
etc, will in general result in a larger number of objects
than a native BERNINA Embroidery Software design.
Hence, these designs will take longer to calculate.
However, even with pure ART files, if the design is
complex, large, and contains many hoop positions,
calculation can take time.

Creating automatic multi-hoopings
Click View > Show Hoop to show or hide hoop.
Right-click to change hoop settings.
Use Multi-Hooping > Automatically Add Hoops to
add hoop positions automatically.
Use Multi-Hooping > Multi-Hooping Options to check
your hooping settings.
Use Multi-Hooping > Preview Hoopings to preview
hoop positions in the Hooping Sequence docker.
The easiest way to work out hoop positions is with the
Automatically Add Hoops tool. Bear in mind that

this method uses a purely rule-based software
algorithm. It works best with simple designs.
To create automatic multiple hoopings

Note For any design that requires multi-hooping, use
the largest hoop available for the specific machine
model.

 Choose the hoop you want to use. Since a given
stitchout can use only one size of hoop, you need
to choose a hoop that will cover the largest object
in the design. See Changing hoops for details.

Multi-hooping characteristics
Multi-hooping in BERNINA Embroidery Software
includes the following characteristics:
 Designs are automatically split on objects. This
provides better stitching results.
 Registration marks are created.
 No need to manually digitize marks.

Select preferred
hoop

 Automatically recalculated if hoop positions
change.
 Automatic registration marks are not a
permanent part of the design.
 Objects that are too large for any individual hoop
can be manually split. Splitting is done without
additional needle penetrations, thus maintaining
object appearance.
 Underlay is automatically recalculated for split
objects in order to provide better stabilization.
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 Switch to Multi-Hooping mode. When you click
Multi-Hooping on the toolbox, covered objects –
those that fit wholly within a hoop – display as
green stitches. Uncovered objects – those that do
not fit – display as black stitches.

 Use the Automatically Add Hoops tools to add
hoop positions automatically. These are calculated
according to the object sequence.

Wholly covered
objects appear in
green

Note No embroidery object can be selected or
manipulated in Multi-Hooping mode.
 Check hoop settings via the Options command.
Change hoops if you need to. Make sure the Foot
setting reflects the foot you are using. This will
affect the available sewing area within the hoop.

 Use the Preview Hoopings tool to preview hoop
positions in the Hooping Sequence docker. Click
and hold to isolate the hooping in the design
window.

 The software always attempts to include whole
objects within sequential hoopings. Where this is
not possible, it will split objects between hoopings.
Although split lines are only visible in
Multi-Hooping, they are maintained when

BERNINA® Embroidery Software : Reference Manual

304

Chapter 32 : Hooping Designs
switching to other modes. They do not affect
object integrity. See also Splitting objects between
hoopings.
 If the same hoop position is repeated in the
hooping sequence, the hooping label will indicate
this. Moving a hoop slightly to include objects
shown can reduce repeat hoopings.

To output registration marks
 Open or create the large design or design layout
you want to sew out. See also Creating design
layouts.

 Each hooping contains an object or group of
objects that can be stitched out in a single
hooping. These are stitched consecutively to form
the whole design.
 You are now ready to save the design to one or
more files or send it to machine. See Outputting
multi-hooped designs for details.
Tip Print a copy of the design showing the hoop
positions to help you stitch it in the correct hooping
order. See Printing multi-hooped designs for
details.

Outputting registration marks

 Click the Options icon and select the
Multi-Hooping tab.

Use Multi-Hooping > Multi-Hooping Options to check
your hooping settings.
Use Multi-Hooping > Preview Hoopings to preview
hoop positions in the Hooping Sequence docker.
In order to correctly align consecutive hoopings
during stitchout, you can include registration marks
for each hooping. Two sets of marks are generated in
overlapping areas of each consecutive hooping. One
set appears as the final stitches of the preceding
hooping. The next set is included as the first of the
subsequent hooping. These stitches do not form part
of the design and are not saved with the design file.
However, they are added during output and are
viewable in the hooping preview and worksheet.

Tip Correct alignment of multi-hooped designs
requires some practice. Third-party training programs
are available on the internet which demonstrate
correct technique. Most recommend using a
sticky-back tear-away stabilizer, heavy enough so
that the registration marks do not tear the stabilizer.
Use pins through the registration marks of one
hooping to align the corresponding marks of the next
hooping.

Choose to add
registration marks

 Choose the Add registration marks on output
option.
 Adjust the margin settings as required.
The larger the margin, the greater the distance
between the registration mark and the maximum
embroidery area of the hoop. This makes it easier
to align but there may be some trade-off in
precision.
 Use the Preview Hoopings tool to check that
registration marks have been added. Click and
hold to isolate the hooping in the design window.
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Red marks indicate the end of a hooping, green,
the start of the next.

how best to position hoops to make it easier to place
fabric and reduce registration errors.

Tip Manual hooping is also better when working with
‘recognized’ machine files. See also Machine files.

Checking object sequence
Knowing the object sequence helps you place hoops
in the best hooping sequence. Use the Color Film
tool to study the object sequence. See also Viewing &
selecting color blocks.

 Registration marks are also shown in the hooping
list in Print Preview. See Outputting
multi-hooped designs for details.

Study the object
sequence

Registration marks included

 As registration marks are not a permanent part of
the design, they cannot be moved. By adjusting
hoop positions and using Calculate Hoopings,
you can vary where registration marks are placed
in overlapping hoop positions.
 During production, align the last-stitched
registration marks with the marks on the stabilizer,
and smooth the fabric onto the sticky back. To
assist, stick sewing pins through the center of the
registration marks.
 Always try to place hoopings as near as possible to
the actual object sequence.

Manual multi-hooping
Manual hooping is generally better than automatic,
but it does require greater understanding of both
design and production processes.
An experienced embroiderer will generally be better
able to weigh up alternatives than a purely rule-based
software algorithm. This is especially so when it
comes to splitting objects between different
hoopings. Also, you may have definite ideas about

Another useful tool is Stitch Player. When you run it,
you are aiming to make sure that any split objects are
split between adjacent hoops – both in terms of
position and hoop placement – and that the object
starts stitching in the earlier hooping. See also
Simulating design stitchouts.
Adjusting object sequence
While correct hoop placements reduce the number of
calculated hoopings, sometimes the object sequence
may not be ideal. You may find that the only way to
reduce the number of hoopings is to re-sequence the
design itself. Bear in mind the following:
 Stock designs which have been created for a single
hoop are generally sequenced to minimize the
number of color changes.
 Enlarging a stock design to the point where it
requires multiple hoopings may require
adjustments to the object sequence.
 Since a given stitchout can use only one size of
hoop, choose a hoop that will cover the largest
object in the design.
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Creating manual multi-hoopings

green stitches. Uncovered objects – those that do
not fit – display as black stitches.

Use Multi-Hooping > Add Hoop to add a new
hooping to a multi-hooping layout.
Use Multi-Hooping > Delete Hoop to remove
selected hoop from hooping layout.
Use Multi-Hooping > Add Hoop Left/Right to place a
new hooping to left or right of the selected hoop. A
10mm overlap is allowed between sewing fields.
Use Multi-Hooping > Add N Hoops Around to
generate 4/8 hoopings around a selected hoop. A
10mm overlap is allowed between sewing fields.
Select preferred
hoop

Use Multi-Hooping > Add Splitting Line to digitize
one or more guides in a multi-hoop layout to split
objects between hoopings.
Use Multi-Hooping > Calculate Hoopings to calculate
hoopings resulting from current layout.
BERNINA Embroidery Software provides a dedicated
set of tools which for creating multiple hoopings
manually. Use these if you cannot achieve the result
you want with the automatic method.
To create manual multiple hoopings

 Select the hoop outline, and drag it till it covers the
first object in the design.

 Choose the hoop you want to use. Select the foot
you are currently using. This will affect the
stitchable area within the hoop. See Changing
hoops for details.
Drag handles to
rotate hoop

Tip Since a given stitchout can use only one size
of hoop, you need to choose a hoop that will cover
the largest object in the design.
 Switch to Multi-Hooping mode. When you click
Multi-Hooping on the toolbox, covered objects –
those that fit wholly within a hoop – display as
Cover first object
in design

 Click the hoop again and use the rotation handles
to orientate it as necessary. Alternatively, use the
rotation controls on the Transform toolbar to
rotate the hoop by increments.
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 Use the Add Hoop tools to add one or more hoop
positions. Aim to reflect the stitching sequence.

Add more hoops and
position as needed

Note As soon as a hoop is moved or joined by
others, automatic centering is deactivated,
meaning that it no longer centers itself
automatically around objects in the design. If you
remove all hoops in a design and create a new one,
automatic centering is re-activated.
 Re-position and rotate additional hoops until they
completely cover all objects in the design.

 Nudge selected hoops into position using the arrow
keys.
Add as many hoops
as needed to cover
all objects

 Finally, click the Calculate Hoopings icon to
evaluate the hoopings that will result from the
current hoop layout.
While a design may be entirely covered by
separate hoop positions, some objects may remain
uncovered. The confirmation message will tell you
and uncovered objects will appear in black.
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 Use the Add Splitting Line tool to split objects
that would not otherwise fit within a hooping. See
Splitting objects between hoopings for details.

The Add Splitting Line tool allows you to split
objects that would not otherwise fit within a hooping.
In effect, it allows you to digitize one or more split
lines in a multi-hooped design prior to outputting to
file, machine or memory card. Although split lines are
only visible in Multi-Hooping, they are maintained
when switching to other modes. Split lines do not
affect object integrity and you can still reshape and
transform split objects as before.

Mark splitting guides
to split uncovered
objects between
hoopings

To split objects between hoopings
 Optionally, add registration marks via the Options
> Multi-Hooping tab. See Creating automatic
multi-hoopings for details.
 Use the Preview Hoopings tool to check that
registration marks have been added. If they
haven’t been added, it means there’s insufficient
overlap between hoopings. You can either increase
the overlap by repositioning. Or reduce the margin
for registration marks.

 Manually create your multiple hoopings. See
Creating manual multi-hoopings for details.
While a design may be entirely covered by
separate hoop positions, some objects may remain
uncovered. Uncovered stitching appears in black.

Reduce margin
as needed

 You are now ready to save the design to one or
more files or send it to machine. See Outputting
multi-hooped designs for details.
Tip Print a copy of the design showing the hoop
positions to help you stitch it in the correct hooping
order. See Printing multi-hooped designs for
details.

Splitting objects between hoopings
Use Multi-Hooping > Add Splitting Line to split
objects between hoopings in multi-hoop layouts.
Digitize guides over uncovered parts of a design.
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 Select the Add Splitting Line tool. You are
prompted to enter a split line.

 Repeat as necessary or press Enter to complete.

Digitize split lines
as open curves

 Digitize split lines just as you would open curve
objects, using right-clicks for curves and left-clicks
for corner points.

 Split lines can be reshaped using the Reshape
tool.
Corner point
Selected point
Curve point

Adding manual reference markers
Use Digitize > Basting Stitch Marker to insert a
reference marker at any angle and position.

 As long as splits occur within the sewing field of
overlapping hoopings, the resultant ‘split objects’
become covered and are displayed in green.
 Objects integrity is maintained but they will be
split on output. The resulting objects will preserve
their original object type, stitch angle, parameters
and color.

Use Digitize > Insert Graphic Marker to insert a
graphic marker representing adhesive stickers
attached to the fabric to indicate location and
orientation.
Reference markers are sometimes needed for
continuous embroidery and possibly work-piece
layouts. BERNINA Embroidery Software includes two
types of reference marker:
 Graphic reference markers representing the
different styles of positioning stickers available in
the market.
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 Basting stitch markers of various shapes and sizes. 9 Start stitching the basting stitch marker to confirm
the location and orientation. Adjust as needed.

10 Stitch the design.
Tip If you want to manually create a multi-hoop
design or continuous embroidery design with a
single design, optionally insert basting stitch
markers or bitmap markers at the end of the
design.
Note that for multi-hooped designs, registration
marks are automatically generated when turned on.
To add graphic reference markers

You can select and manually place reference markers
in a design at any angle and position. The process for
using each in a single hoop design is outlined below.

 Group the embroidery design if not already
grouped.
 Use the Insert Graphic Marker tool to insert
markers.

Tips...
 Stitch reference marks first to help align a fabric in
the hoop.
 Sequence them to the start of the design.
 Attach physical adhesive stickers to the fabric to
indicate hoop location and orientation.
 Use basting stitch reference markers to match
these stickers.
To add basting stitch markers

1 Use the Basting Stitch Marker tool to insert the
basting stitch marker and place it before the
embroidery design so it stitches first. Various sizes
and shapes are available.

 Select both and use align centers.
 Group the graphic and the embroidery.
 Position and rotate as needed in the design.
 Print the graphic with the design in Print Options.
 Print the design layout template and use a physical
position marker sticker at the same location and
orientation as the position marker graphic.
 Send the design to machine.
 Move the start needle position to the center of the
physical sticker.

2 Insert the design. Group if not already grouped.

 Stitch the design.

3 Select it together with the basting stitch and align
the centers.

4 Group the basting stitch with the embroidery.
5 Position and rotate as needed in the design.
6 Print the design layout template and use a physical
position marker sticker at the same location and
orientation as the basting stitch marker

7 Send the design to machine. The basting stitch
marker will stitch first.

8 Move the start needle position to the center of the

Creating custom hoops
If you are using a hoop size that is not in the hoop list,
you can define your own and save it for later use.

Custom hoop types
Click View > Show Hoop to show or hide hoop.
Right-click to change hoop settings.

sticker on the work piece.
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You can create or edit four basic types of hoop –
rectangular, oval, sliding and 3-position.

height and width of the hoop as well as the sewing
field within.

Rectangular hoops
Set height and width according to the dimensions of
the hoop you are using.

Sewing
Field

Total
Height

Height

Width
Width

Oval hoops
Set heights and width of the oval according to the
dimensions of the hoop you are using.

Total
Height

Rectangle
Height

3-position hoops
3-position hoops allow large designs to be split
manually and stitched without the usual registration
problems. Unlike sliding hoops, the sewing fields are
in fixed positions with known dimensions, making it
easy to register objects stitched in each position. In
the software, they are displayed as three dotted
rectangles. The top rectangle is green, the middle,
blue and the bottom, red. Define your own 3-position
hoop according to the dimensions of the hoop you are
using.
Position 1
Height

Width

Sliding hoops
Sliding hoops are special hoops with adjustable
frames to accommodate unusual size designs. Set

Position 2
Height
Total
Height

Position 3
Height

Width

Creating custom hoops
The method for defining your own hoops –
rectangular, oval, sliding or 3-position – is essentially
the same. The only thing that changes is the number
of dimensions needed for each hoop type.
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The custom hoop is now available for use in the
Options > Hoop tab.

To create a custom hoop

1 Right-click the Show Hoop icon or select
View > Hoop. The Options > Machine & Hoop
dialog opens.
Select the
machine

Editing hoops
Click View > Show Hoop to show or hide hoop.
Right-click to change hoop settings.
You can edit and delete custom hoops as necessary.
To edit a hoop

Click to create
new hoop

 Right-click the Show Hoop icon or select
View > Hoop. The Options > Hoop dialog
opens.

2 Select the machine you are working with.
Alternatively, use machine Others if you want
general availability.

3 Click Create.
Enter a name
for the hoop

Click to edit
hoop
My Custom Hoop

Choose a
hoop type

 In the Hoop list, select the custom hoop. Only
custom hoops can be modified.
 Click Edit. The Create dialog opens.

4 Enter a name for your custom hoop.
5 Choose the type of hoop you want to work with.
6 Define the dimensions of the selected hoop type:
 Rectangular: enter Height and Width.
 Oval: enter Rectangle Height, Total Height
and Width.
 Sliding: enter Sewing Field, Total Height
and Width.
 3-position hoop: enter Total Height, heights
for Position 1, 2 and 3, followed by hoop
Width.

 Enter new dimensions.
 Alternatively, click Delete Hoop. The hoop is
removed permanently.
 Click Save Hoop to save any changes.

Tip It is best to enter the total height of the hoop
first. If the sewing field is larger than the default
total height, the size will default to a smaller size.

7 Click the Save Hoop button.
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Positioning & production techniques

aligns with the hoop template grid as the hoop
centers around the design.

To facilitate the accurate positioning of designs in
more complex cases, BERNINA Embroidery Software
uses a combination of:
 Design layout templates
 Design worksheets with printed location markers
 Positioning markers – either stickers or basting
stitches
 Hoop templates.
Where the final output requires multiple hoopings,
positioning and alignment of multiple hoopings at
sewing time, or repeats of the same design, can be
tricky. It takes practice to obtain accurate alignment
where a design requires re-hooping.
As an advanced user, you may want to produce
designs larger than any available hoop. This could be
a single large design or a continuous embroidery
design with repeating patterns. Continuous
embroidery is similar to the ‘endless embroidery’
function available on some machines.

Stitching out single designs
As a beginner, you will generally use designs that fit
entirely within the available hoops for your particular
machine. You will mostly use default settings both in
the software and the machine. The hoop center
becomes the reference point for all designs you do in
this manner. This technique provides the basis for all
other techniques you will use.

2 Optionally, adjust the design size or change hoops
to suit the design. See Changing hoops for details.

3 Print a design worksheet. The worksheet can
include the hoop position marker. See Printing
designs for details.

4 Send the design to machine. The design is
automatically centered on the BERNINA machine.
See Stitching out designs for details.

5 Fix the design worksheet to the fabric.
6 Hoop the fabric. Align the worksheet hoop position
marker with the hoop template centerlines.
Align worksheet hoop position marker
with hoop template centerlines

To stitch out a single design

1 Insert or open a design.
 The hoop automatically centers around design
extents, as it does on BERNINA machines.

7 Start the machine. The needle will move to the
hoop center. See also Centering hoops.

8 Stitch out the design.

Stitching out work-piece layouts

 Using the hoop template instead of the grid,
you can ensure that the hoop center always

As an intermediate user, you may want to create
design layouts on large work pieces. Each design will
still fit in a single hoop but there may be multiple
designs in the layout. Each hooping has its own
reference point that is used with the hoop template to
accurately place the design at the correct orientation.
As there is only one design per hooping, there is no
need for secondary placement points. The main
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benefit of this technique is that the complete layout
can be accommodated within a single design file with
the work piece as reference and all components
included.

relationship. See also Printing multi-hooped
designs.

6 Piece together the design worksheet to show the
entire layout. The worksheet shows the hoop
position marker. Each hoop position marker has a
number indicating the hooping sequence.

7 Send the design to machine. The design is
To stitch out a work-piece layout

1 Insert or open a design. The hoop automatically
centers around design extents, as it does on
BERNINA machines.

2 Optionally, adjust design size or change the hoop
to suit the design. See also Scaling objects.

3 Create a design layout by combining designs and
design elements.
 There are various features within the software
for creating geometric design layouts quickly
and easily – Mirror-Merge, Layouts, etc. See
also Design Layouts.
 Alternatively, place designs manually.
 Optionally, include a background for a garment
or large work piece. See also Visualizing
finished articles.

4 Use multi-hooping in order to automatically place
hoops for each design location. You can use the
automatic feature to generate hoopings even in
large layouts. See Creating multiple hoopings for
details.

automatically centered in the BERNINA machine.
See also Sending multi-hooped designs to
machine.

8 Fix the layout template to the work piece.
Optionally, remove the non-stitched sections of
the design worksheet to make the work piece
easier to work with.

9 Hoop the work piece using the printed design
layout template and hoop template.
Align the worksheet hoop position marker with the
hoop template centerlines.

10 Once hooped, remove the layout template and
stitch the design component for that hooping.
 The hoop location number is included on the
hoop position marker.
 When sent to machine, designs have the hoop
location number added to the design layout file
name.

11 Stitch out the design.
12 Locate the next hoop in the sequence and repeat.

Stitching out embroidery on garments
Note With work-piece layouts, you don’t need to
include registration marks, but you do need the
hoop position markers for each hoop location. This
will show the position and orientation of each
design in the layout.

5 Print out the layout template with the design
worksheet. Large layouts can be printed on small
format printers and then pieced together. This
establishes all hoops in the correct spatial

Sometimes, you want to stitch out at specific
locations for garments, caps and other wearables. For
example, take the case where you want to stitch a
monogram design at the top of a shirt pocket. Use this
with machines that allow you to maintain start and
end connectors.
To stitch out embroidery on a garment

1 Open a blank design.
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2 Set the start and end points to center-top. This
helps when placing a monogram on a shirt pocket.
See also Setting automatic start & end points.

8 Hoop the garment using the hoop template vertical
centerline to locate the center of the pocket and
place the horizontal centerline 10mm down from
the top of the pocket.

9 Stitch out the design. The machine will start the
design at the hoop center.
Start at
center-top

Automatic continuous embroidery

Turn off Maintain
Automatically

 Multiple design repeats in a single file using
automatic layout features.

Automatic continuous embroidery consists of the
following elements:

 Multi-hooping to create the output files with
automatic registration marks.
End at
center-top

To create automatic continuous embroidery

1 Insert or open your source design.
Turn off Maintain
Automatically

3 Turn off Maintain Automatically so start and end
is always fixed to this point in the hoop.

4 Using the Lettering toolbox, create a lettering or
monogram design. Notice that the hoop center
moves to the top center of the lettering. See also
Monogramming.

2 Create your design repeats.
Tip Use the Array and Reflect tools to
automatically generate continuous embroidery
designs. See Mirroring objects for details.

3 Set the number of columns and rows required for
the finished item.

Design centered at
center-top position

4 Open the Multi-Hooping toolbox and use

5 Optionally, include a background for the garment
you are using. See Visualizing finished articles for
details.

6 Optionally print the design worksheet. The
worksheet shows the hoop position marker on the
design at the location on-screen. See also
Previewing & printing worksheets.

7 Send the design to machine. The design is
positioned in the same location as shown on
screen as uses the start and end connectors to
locate the design from the center of the hoop.

automatic hooping to cover all objects in the
design. See Creating automatic multi-hoopings for
details.
Hoops should be placed with at least a 3cm overlap
for good registration mark generation.

5 Send the multi-hoop design to machine. See
Sending multi-hooped designs to machine for
details.

Manual continuous embroidery
Manual continuous embroidery consists of the
following elements:
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 Single design in file.
 Manually inserted basting stitch markers or
graphic markers at start and end of design for
alignment.
 Manually repeated design on the machine using
manual reference markers to align each hooping.
To create manual continuous embroidery

1 Insert or open your source design.
2 Move the design into the required position in the
hoop. Start and end connectors are fixed to the
center of the hoop.

3 Optionally, adjust design size or change the hoop
to suit the design.

4 Use the Basting Stitch Marker command to
insert basting stitch markers – two near the top at
either side of the design, and two near the bottom
at either side of the design. See Adding manual
reference markers for details.

sequence. See also Previewing & printing
worksheets.

9 Send the design to machine. The design is
positioned at the same location as shown on
screen. It uses start and end connectors to locate
the design from the center of the hoop. The
machine will start stitching at the hoop center. See
Stitching out designs for details.

10 Fix the design worksheet to the fabric in the
required position for the first part of the endless
embroidery.

11 Hoop the fabric. Align the worksheet hoop position
marker with the hoop template centerlines.

12 Step past the first two basting stitch markers as
these are only needed for second and subsequent
designs. Stitch out the design.

13 Hoop a piece of sticky-back stabilizer for the
second hooping.

14 Stitch the first two basting stitch markers on the
stabilizer.

15 Place the fabric on the sticky stabilizer lining up

Add basting
stitch markers

the basting stitch markers on the fabric with those
stitched on the stabilizer. Press the fabric into
place.

16 Stitch the next repeat of the design.
17 Repeat the process until all repeats are complete.
Tip Inserting graphics for the physical reference
markers could be substituted for the basting stitch
markers. These can be aligned to the center of the
design and the design and reference marker
rotated as needed.

Stitching out multi-hoop designs
5 Align the associated basting stitch marker with the
bottom left-hand corner of the design extents:
 Select the bottom left-hand basting stitch
marker.

If your design is too large or involves a large work
area, you have the option of splitting it into multiple
hoopings. The Multi-Hooping toolset lets you
strategically position hoops until you obtain the least

 Using the Ctrl key, select the design.
 Click Arrange > Align > Bottom followed by
Arrange > Align > Left.

6 Repeat for each of the other basting stitch markers
and place then in each corner.

7 Select the two basting stitch markers at the top.
Using the Color Film, move them to the start of
the design. Make sure the two bottom-most
basting stitch markers are sequenced at the end of
the design.

8 Print a design worksheet. The worksheet shows
the hoop position marker. Each hoop position
marker has a number indicating the hooping
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number of hoopings necessary to accommodate the
whole design layout.

the sticky back. To assist, stick sewing pins
through the center of the registration marks.

11 Stitch the next hooping.
12 Repeat until the design is complete.

Each hooping contains an object or group of objects
that can be stitched out on their own. Hoopings are
stitched consecutively to form the whole design. They
can be sent directly to machine or saved to file.
To stitch out a multi-hoop design

1 Create a large design combining many design
elements.

2 Add hoops via Multi-Hooping to cover each
design element in the layout. You can use the
automatic feature to generate hoopings even in
large layouts. See Creating multiple hoopings for
details.

3 Optionally, include a background for the garment
you are using. See Visualizing finished articles for
details.

4 Print out the layout template from the software.
Large layouts can be printed on small format
printers and then pieced together. This establishes
all hoops in the correct spatial relationship.

5 Fix the template to the garment. Remove the
unnecessary pieces of the layout to isolate the
individual hoopings.

6 Hoop the fabric (or garment) and stitch out the
first hooping. Registration marks are stitched last.
Use the hoop position marker to locate and rotate
the garment using the physical hoop template.

7 Un-hoop the fabric.
8 Hoop a piece of sticky backed stabilizer and
remove the protective paper.

9 Stitch the registration marks at the start of the
next hooping onto the stabilizer.

10 Align the last-stitched registration marks with the
marks on the stabilizer, and smooth the fabric onto
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CHAPTER 33
WORKING WITH MACHINE FILES
By default BERNINA Embroidery Software
saves designs to its native ‘ART’ file format.
This format contains all information
necessary both for stitching a design and for
later modification.
However, BERNINA Embroidery Software
can also open and save designs in native as
well as non-native machine file formats as
well. When opening machine files, BERNINA
Embroidery Software converts stitch data to
outlines so you can modify them using the
editing features.
When you send designs directly to machine,
they will be lost when the machine is turned
off. Apart from saving to hard disk, floppy
disk or archiving to CD, you can also preserve designs by writing them to
embroidery machine memory, design card, or USB memory stick.
Note If you intend to stitch a design immediately, send it directly to the machine.
See Stitching out designs for details.
This section describes how to select conversion options for opening and saving
different stitch and outline design formats. It also deals with storing designs to
design card.

Embroidery design formats
BERNINA Embroidery Software opens and saves pure
ART format designs as well as a number of non-native
formats. Other format designs which can be read into
BERNINA Embroidery Software are generally
‘stitch-based’. This means they were not created
object-by-object but stitch-by-stitch. When you open
other formats into BERNINA Embroidery Software,
the software reads the data and, depending on your
settings, attempts to determine object outlines and
properties so that you can modify the designs like
native ones.

object outlines and properties, actual stitches, thread
colors, a picture icon and comments. There are three
other grades of ART file, depending on how the ART
file was created – Grade B is more reliable than Grade
C, but not as good as Grade A format, and Grade D is
the least reliable. It goes without saying that only ART
Grade A files provide 100% perfect scaling and
transformation.
File source

Description

Art Grade A

Pure ART file created in BERNINA
Embroidery Software-based software.
These files contain pure ART objects,
outlines and stitches.

ART files
Native ART designs, called ‘ART Grade A’, contain a
complete set of design information in a single file –
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File source

Description

Art Grade B

Designs read from outline format such as
GNC and saved in ART format. Such
designs cannot be read directly in
BERNINA Embroidery Software but once
converted to ART in other software,
BERNINA Embroidery Software reads
them as Grade B designs.

Art Grade C

Designs read from machine files – SEW,
PCS, PES, etc – where stitches have been
converted to objects. See Opening
machine files for details.

Art Grade D

Designs read from machine files – SEW,
PCS, PES, etc – where stitches have NOT
been converted to objects. See Opening
machine files for details.

All files saved in ART format are automatically
compressed when saved, and decompressed when
re-opened. This reduces the storage space required,
and makes it possible to save large files to floppy disk,
or send them as email attachments.

Tip For information about the source of a design file,
refer to the Open dialog or the Design Properties
dialog. See Viewing design information for details.
See also Opening designs.

You will be warned if the design you are opening
should not be scaled.

Tip You can make this warning display when opening
designs by selecting Help > Show Design Warning.

Comparison of embroidery and machine files
BERNINA Embroidery Software uses the native ART
embroidery file format which combines the
advantages of both outlines and calculated stitches.
The table below shows the type of data found in ART
files compared with machine files.
Included in file

Machine files ART files

Object properties

No

Yes

Stitch data

No

Yes

Stitch types

No

Yes

Includes stitch coordinates

Yes

Yes

Thread colors

Some

Yes

Machine files

Comments

No

Yes

Different embroidery machines understand different
languages. Each has its own control commands for
the various machine functions. Before you can stitch
a design, it must be in a format which can be
interpreted by the machine. Stitch or ‘expanded’
designs are low-level formats for direct use by
embroidery machines. They contain only stitch
coordinates and machine functions. They are
generally created ‘on the fly’ when sending designs to
machine. They can also be output to embroidery disk
or design card.

Pull compensation settings

No

Yes

Auto spacing settings

No

Yes

When read into BERNINA Embroidery Software,
machine files do not contain object information such
as outlines or stitch types, but present the design as
a collection of ‘stitch blocks’. Stitch blocks are created
wherever colors change or trims are detected in the
design. Machine files are generally not suited to
modification because stitches are not regenerated.

Converting machine files
When you scale a pure ART design, you change the
number of stitches needed to fill the shape. BERNINA
Embroidery Software recalculates and redraws all
stitches automatically. This is called ‘stitch
processing’ and it ensures that the design you see
on-screen appears as it will be stitched. While stitch
designs are generally not suited to modification,
BERNINA Embroidery Software can interpret object
outlines, stitch types and spacing from stitch data
with some success. When you open a machine file, it
is converted by default to a Grade C ART file.
Converted designs can be scaled and stitches
recalculated.
Opening without conversion
You can choose to open machine files without
conversion. Designs opened in this way can be output
for stitching in other formats. Or you can edit stitches
and add new elements. There is nothing to stop you
scaling machine format designs which have been
opened without object conversion. However, because
the stitch count does not change, the density
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increases or decreases with the design size. Thus you
should not scale stitch designs by more than ±10% or
some areas may be too thickly or too thinly covered.

Supported embroidery file formats
BERNINA Embroidery Software supports the following
embroidery file formats:

Original stitch design

Scaled stitch design

Note With or without object conversion, machine
files can be still saved in ART format once they are
opened in BERNINA Embroidery Software.

Format

File

BERNINA All-in-One Vx

ARTx0

BERNINA All-in-One
V4/V3

ART

BERNINA A730/A200

ART

OESD All-in-One

Grade Read Write
A

z

z

^

A

z

z

*

A

z

z

ART42

A

z

z

Janome/Elna All-in-One

JAN

A

z

Wilcom All-in-One
Designs

EMB

A

z

z

Wilcom All-in-One
Designs e3

EMB

†

A

z

z

artista Cross Stitch

ARX

‡

D

z

BERNINA Template V8.0 AMT80 ¥

A

z

z

Recalculating converted machine files

BERNINA Template V7.0 AMT70

A

z

z

When an ART design is created by opening a machine
file with stitch processing, the original stitches are
maintained until you change them. You can guarantee
that the design will stitch as originally made.
However, if you scale the design or do anything which
forces stitches to be recalculated from new estimated
outlines, there may be significant differences from the
original stitches.

^ V1 and V2 ART no longer supported for write
* A730/A200 files can be read directly by some BERNINA
machines
‡ While not an embroidery file format, ARX is native to
BERNINA and can be read by BERNINA Embroidery
Software
† Use this format if opening into Wilcom e3 software.
¥ AMT50 and AMT60 no longer supported for write.

Grade Source

Open method Contains

Supported machine file formats
BERNINA Embroidery Software supports the following
machine file formats:

A

ART

Open normally

Outlines and
stitches

B

non-native
outline file
saved as ART

Open normally

Converted
outlines and
stitches

C

EXP or DST file Open with
saved as ART object
conversion on

Estimated
outlines and
converted
stitches

EXP or DST file Open with
saved as ART object
conversion off

No outlines and
individual
stitches

D

Format

File

Grade Read Write

BERNINA A730/A200

ART

BERNINA USB stick

EXP

Janome / Elna /
Kenmore

SEW

C

z

z

Elna Xpressive

EMD

C

z

z

Deco, Brother, Babylock PEC

C

z

z

Deco, Brother, Babylock PES

C

z

z

Husqvarna Viking / Pfaff VP3

C

z

z

Husqvarna Viking / Pfaff VIP

C

z

z

C

z

z

*

A

z

z
z

Husqvarna / Viking

SHV

^

Husqvarna / Viking

HUS

C

z

z

Pfaff

PCS

C

z

z

Pfaff

PCD

C

z

z

Pfaff

PCQ

C

z

z

* A730/A200 files can be read directly by some BERNINA
machines
^ Save back as SHV but not convert to SHV
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Format

File

Grade Read Write

Pfaff

PCM

C

z

z

Singer

XXX

C

z

z

Poem, Huskygram,
Singer EU

CSD

C

z

z

Melco

EXP

C

z

z

Tajima

DST

C

z

z

Great Notions

GNC

C

z

* A730/A200 files can be read directly by some BERNINA
machines
^ Save back as SHV but not convert to SHV

Other formats
BERNINA Embroidery Software supports the following
artista file formats:
Format

File

Grade Read Write

artista Cross Stitch

ARX

‡

D

z

z

artista Quilter

ARQ

†

D

z

z

‡ Cross Stitch application only † Quilter application only

Note BERNINA Embroidery Software will convert
designs to non-native home formats which are
current at the time of development. Later releases of
other-brand software may not produce compatible
formats of the same file types.

Device selection
Whether outputting designs or reading designs, you
interact with devices via the Device Selection
dialog.

are enabled once you connect to machine. The dialog
is the interface to the following functions.
Device

Description
Use this to:
• Write designs in EXP format to USB stick
• Read designs EXP designs from USB stick.
Use this to load the design to machine ready for
stitching.

Use this to:
• Write design to machine, or USB stick plugged
into machine
• Read designs from machine, or USB stick
plugged into machine.
Use this to:
• Write EXP design to memory card for deco
330/bernette 340 deco, or USB stick for
bernette 340 deco
• Read EXP design from memory card for deco
330/bernette 340 deco, or USB stick for
bernette 340 deco.
Use this to:
• Write EXP design to artista 165 to artista 185 or
serial Reader/Writer Box
• Read EXP from artista 165 to artista 185 or
serial Reader/Writer Box.
Use this to:
• Write design in artista 200/730(ART V4) format
to USB stick
• Read artista 200/730(ART V4) design from
USB stick.

Exporting & opening machine files
BERNINA Embroidery Software can open supported
machine files stored on your PC from a variety of
sources – hard disk, floppy disk, USB memory stick,
or CD ROM. Once opened, they can be checked or
edited before sending to machine for stitchout or
storage. Similarly, the software can export to any
supported machine file format for transfer to
embroidery machine. See also Supported machine file
formats.

Exporting machine files
BERNINA Embroidery Software designs can be
exported to native EXP machine format as well as a
number of non-native formats.
If you plug a USB stick into your PC, you will see four
enabled icons shown above. The other two buttons

Note The Save As dialog saves only original file
formats such as ART to the My Designs library folder.
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The Export Machine File dialog saves machine
(EXP) and all other file formats (PES, etc) to the My
Machine Files library folder.

and stitches recalculated. While processing is
effective for most stitch designs, it cannot produce
the same level of quality as original outlines and may
not handle some fancy stitches.

To export a machine file

Occasionally you may want to turn off stitch
processing. By opening a machine file without object
conversion, you can output the design without
change, edit individual stitches, and perform minor
scaling and transforming actions without losing the
original stitch information. When you open machine
files without object conversion, the design is
converted to a Grade D ART file.

1 Open the design you want to export to machine.
2 Select File > Export Machine File.

To open a machine file

1 Click the Open icon to open from your hard disk or
USB stick.

Choose required
machine file format

Select file type

3 Choose a machine file format. Typically you will be
using BERNINA All-in-One V4 ART files or BERNINA
USB Stick EXP files.

4 Change file name as required, choose a
destination folder, and click Save.
If the system detects that not all objects are
covered by hoop positions, you are prompted. See
Hooping Designs for details.

2 Select a folder and select a machine format from
the Files of type list and select a file to open. See
Supported machine file formats for details.

3 Click Options. The Open Options dialog opens.

Choose a
conversion option

4 Select a conversion option and click OK.
5 Click Open. Depending on the conversion option:
Note You can also write designs directly to your
embroidery machine memory or BERNINA design
card. See Stitching out designs for details.

 The design is processed and converted to
objects with fill or outline stitch properties as
well as general properties. If an object is not
recognized, it has general properties only.

Opening machine files
Use General > Open to open an existing design.
Machine files are converted to outlines and objects by
default upon opening. The design is converted to a
Grade C ART file. Converted designs can be scaled
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 The design opens as a collection of stitches with
only general properties.

Stitches processed
(ART Grade C)

 USB memory stick: Designs can also be read
from a USB memory stick attached to your
machine. See also Writing designs to machine.

Note USB memory sticks can also be attached
directly to your PC and designs read into BERNINA
Embroidery Software. See Exporting & opening
machine files for details.
To read designs from machine

Tip To ensure object outlines, stitch types, stitch
density and colors are correct, it is always a good
idea to check and edit designs after conversion.

Reading designs from machine
You can read designs into BERNINA Embroidery
Software from a variety of sources, both on your
computer and embroidery machine. Once opened,
they can be checked or edited before saving to hard
disk, or sending to machine for stitchout or storage.
When reading designs from machine, three options
are available:

1 Open a new, blank file.
2 If you intend to read designs from card or USB
stick, insert the storage device in the machine (or
Embroidery Card Reader/Writer Box).
Note For connection details, see the instructions
which came with your Embroidery Card
Reader/Writer Box.

3 Select File > Card/Machine Read.
If this is the first time you have downloaded a
design after turning on the machine or reader box,
the Device Selection dialog opens.

 Embroidery machine: Most machines allow
designs to be stored to and read from machine
memory. This is like having a built-in design card.
 Design card: Designs can also be stored on a
design card attached to your embroidery machine
(or Embroidery Card Reader/Writer Box).

4 Select an embroidery machine or reader box, as
well as COM port if prompted to do so. See also
Device selection.

5 Click OK.
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If the machine connection is working, the Write to
Embroidery System dialog opens. The name and
thumbnail image are displayed.

 Delete the design.
 Access design properties.

The Read from Embroidery System and
Design Manager dialog opens.

Select storage
device
Select
design

10 Select a destination folder on the hard disk where

Select hard drive
destination

the design is to be stored.

Click to
download

Select
destination
folder

6 Select the required storage source by clicking the

Use folder buttons to
navigate folders and
create new ones

corresponding button – embroidery machine,
design card, or USB memory stick.
When you select a button, all folders and designs
currently stored on the device are displayed.

11 Click the Download arrow button to read the
design and save to hard disk.

Select folder
tab
Right-click to
access popup
menu

Create new
folders

Tip Right-click the design icon to access a popup
menu – use it to rename, delete, or view design
properties.

Note You can write designs of the appropriate
format from hard disk to the storage device using
the Upload arrow button.
Use Upload arrow button
to write selected designs
from hard disk to storage
device

7 Click a folder tab (if more than one) and/or folder
to locate the design.
Tip Use the icons on the right of the display panel
to create new folders or navigate the folder
structure.

Writing designs to machine

8 Select the design.
A preview image is displayed in the Selected
Design panel.
Click to open design in
BERNINA Embroidery Software
Click to access
design properties

9 Use the display panel buttons as required to:
 Open the design directly into BERNINA
Embroidery Software for editing.
 Rename the design.

Use General > Write to Card/Machine to write (save)
design to BERNINA design card or BERNINA
embroidery machine.
Click View > Show Stitches to toggle stitch view
on/off.
If you intend to stitch designs only when the machine
is connected to your computer, store them on your PC
hard disk. However, you can also use the Write to
Card/Machine command to save designs for later
use, independent of your PC. Designs from any
storage device – embroidery machine, design card, or
USB memory stick – can then be stitched out as many
times as you like. This eliminates the need for the PC
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to be connected to the machine during stitchout. See
your BERNINA embroidery machine documentation
for details.
To write designs to machine

If the machine connection is working, the Write to
Embroidery System dialog opens. The name and
thumbnail image are displayed.
Write to memory
module

Write to
design card

Write to
USB stick

1 Open the design and turn off Artistic View. See
Opening designs for details.
Select
folder tab
Indicates
current
storage
device usage
Click to download
selected design

Design to be
stored

6 Select the required storage device by clicking the
corresponding button – embroidery machine,
design card, or USB memory stick.
Note The machine (or external Embroidery Card
Reader/Writer Box) must be switched on before
you insert the card, otherwise designs will not
display or be loaded to the machine.

2 If you intend to write the design to card or to USB
stick, insert the storage device in the machine (or
Embroidery Card Reader/Writer Box).
For connection details, see the instructions which
came with your Embroidery Card Reader/Writer
Box.

3 Click the Write to Card/Machine icon.
If this is the first time you have downloaded a
design after turning on the machine or reader box,
the Device Selection dialog opens.

When you select a button, all folders and designs
currently stored on the device are displayed.

Select folder
tab
Select folder
Right-click to access
popup menu

Create new folders

7 Click a folder tab (if more than one) and/or folder
to select where the design is to be saved.
Tip Use the icons on the right of the display panel
to create new folders or navigate the folder
structure. Right-click the design icon to access a
popup menu – use it to rename, delete, or view
design properties.

Caution Make sure the needle arm on your
machine is up before downloading designs.

4 Select an embroidery machine or reader box, as
well as COM port if prompted to do so. See also
Device selection.

5 Click OK.

8 Click the Download arrow button to write the
design.
The machine touch screen goes blank while the
download takes place. Once the design is saved to
the selected device, you can stitch it at any time
without a PC connected to your machine. See your
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BERNINA embroidery machine documentation for
details.

the Device Selection dialog opens. See also
Device selection.

Writing designs directly to USB stick
Use General > Write to Card/Machine to write (save)
design to BERNINA design card or BERNINA
embroidery machine.
Click View > Show Stitches to toggle stitch view
on/off.
Designs can be saved to a dedicated BERNINA or
OESD USB memory stick attached directly to your PC.
While you can copy designs directly from your hard
disk to memory stick via MS Windows® Explorer, you
should do so via BERNINA Embroidery Software.
While saving the design, BERNINA Embroidery
Software automatically converts it to the correct
format for stitchout.

Tip If you are already connected to a embroidery
system, click the Connected Device button in the
Write to Embroidery System dialog in order to
access the Device Selection dialog. See also
Writing designs to machine.

Note Other types of memory stick can be used but
they are not recognized automatically by the
software.

Click to access the
Bernina Device
Selection dialog

To write a design directly to USB stick

1 Open the design and turn off Artistic View. See
Opening designs for details.

4 Select the appropriate BERNINA USB Stick
option for the embroidery system that will be used
to stitch out the design and click OK.
If you have inserted a memory stick other than
BERNINA or OESD, the Enter Drive Letter and
Path dialog opens prompting you for the device
location.

Click to browse
for the USB
device

2 Insert a BERNINA or OESD USB memory stick
directly into a USB port on your PC.

3 Click the Write to Card/Machine icon.
If this is the first time you have downloaded a
design after turning on the machine or reader box,

5 Browse for the device location on your PC as
required.
If the machine connection is working, the Write to
Embroidery System dialog opens. The name and
the preview of your design are displayed. Folders
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and designs currently saved on the device are also
displayed.

2 Select File > Export Machine File.

Select folder

Click to download
selected design

Design to be
stored

6 Select the location the design is to be stored.
Tip Use the icons on the right of the display panel
to create new folders or move up a level in the
folder structure. Right-click design files already
stored to access a popup menu – use it to rename,
delete, or view design properties.

Select PES

7 Click the Download arrow button to write the
design to the memory stick.
While saving the design, BERNINA Embroidery
Software automatically converts it to the correct
format for stitchout. See the relevant BERNINA
Embroidery Software documentation for details of
how to stitch out from a USB memory stick.

3 Choose PES as the file type.
The PES Save Options dialog opens.

Saving designs in PES format
PES is a Brother machine file format which involves
different combinations of hoop size and file version.
Use the following procedure when saving PES
designs.
To save a design in PES format

1 Open the file you want to export and select a
suitable Brother hoop. See Selecting hoops for
details.

Select PES version
from droplist

4 Select the PES version you require from the
droplist and click Save.
The Export Machine File dialog saves machine
(EXP) and all other file formats (PES, etc) to the
My Machine Files library folder.

Note You will be warned if the design does not fit
the hoop.
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CHAPTER 34
OUTPUTTING DESIGNS
You can output embroidery designs in a
variety of ways – by printing as worksheets,
as appliqué patterns, color films, or as
thread charts. BERNINA Embroidery
Software also allows you to save your
designs as images for use with fabric and
garment applications. You can also send
them directly to machine for stitching. When
working with designs that are larger than the
available physical hoop, you can split them
into parts, each containing an object or
group of objects. The software automatically
calculates which files are to be sent and shows you how they will look.
This section describes how to print worksheets, appliqué patterns, color films, and
thread charts. It also covers stitching out designs, both singly and as
multi-hooped designs.

Printing designs

Your design displays as it will be printed. Large
designs may be displayed over a number of pages
if printed at actual size.

You can create a hard copy of your designs using
default or custom printer options. Preview designs
before printing. Set print options to display the
information you require. If you are using a color
printer, you can print in Artistic View. Even print
thread charts as a shopping reference when
purchasing threads.

Previewing & printing worksheets
Use General > Print Preview to preview a design
before printing.
Use Print Preview to view stitching information. Use
it to check the sewing sequence before you stitch out
your design. You can create a hard copy of your
designs using default or custom printer options.
To preview and print a worksheet
 Click the Print Preview icon.
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 Use the Preview buttons as required:
Field

The default worksheet type is the ‘design
worksheet’.

Description

Next Page

View the next page.

Prev Page

View the previous page.

Two Page

Display two pages in the Preview
Window.

Portrait /
Landscape

Toggle design display between
landscape and portrait views.

Select worksheet
type

Zoom In / Out Use to examine portions of the design or
to read production information.
 Click Options to set any Print Options. See
Setting worksheet options for details.
 Click Print Now to proceed with printing. The
MS Windows® Print dialog opens allowing you to
choose a printer and adjust any other print
settings you require. See also Setting worksheet
options.

Select a preset
configuration
Print whole or
part of design
Set zoom factor
for design display

Setting worksheet options
Use General > Print to print active design using
current settings.
Use General > Print Preview to preview a design
before printing.
Print options give you precise control over your design
printout. Different worksheet configurations are
available for different purposes – design worksheet,
color sequence, appliqué pattern, as well as hooping
sequence. Each configuration can be further
customized.
To set worksheet options
 Optionally, print the whole design or selected
objects only. If the latter, select the objects before
accessing the Print Options dialog.
 Select File > Print.
 Click the Print icon or the Print Preview icon.
Both dialogs provide an Options button.

 Select a worksheet type:
Type

Purpose

Design
worksheet

Print all production-related information,
such as bobbin length, design size,
garment fabric, etc, is provided.

Appliqué
patterns

Print appliqué patterns – cutter information
– isolated from the design. These can be
used as a guide to cutting out fabric pieces.
See also Digitizing for Appliqué.

Color film

Print a list of colors and objects used in the
design, together with stitch information for
each color layer. See also Sequencing
embroidery objects.

Hooping
sequence

If there is more than one hooping in the
design, this option displays hoopings in
their correct sequence. See also Creating
multiple hoopings.

Click for print
options

 Click Options to further configure print options.
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 Select checkbox if you want to print the design as
a design worksheet.

Option

Purpose

Start & end
crosshairs

The start/end needle position is included
in the printout. See also Setting
automatic start & end points.

Background

Include design background if set – for
instance, to indicate fabric appearance or
position on garment. See also Setting
backgrounds.

Design
boundary

Display design bounding rectangle and
reference marks similar to the machine
display. This means start and end point
positions can be easily identified. When
designs are located on a large work
piece, like a table cloth, design extents
and geometric center become important
for positioning.

 If you have selected ‘design worksheet’, three
presets are available:
Quilt block
Preset

Purpose

Standard

Reset worksheet options to default values.

Current
view

Display the design as it appears in the
design window.

Layout
template

Show the design at actual size (1:1) with
object outlines only (no stitches).

Hoop

It may be important to include the hoop in
the printout for positioning purposes.
Alternatively, use the hoop position
marker to align the needle and orientate
the hoop.

Hoop
template

Printing the hoop template allows you to
cut out the printed design and align it
within the hoop. Use the template
markings to align it to physical hoop
template.

Hoop
position
marker

This indicates the hoop center and
orientation for more accurate hoopings.

Work area

This lets you arrange multi-hoopings on
an item or fabric to be sewn. It should be
printed together with hoop position
markers. See also Creating design
layouts.

 Click Options to further configure print options.
The default worksheet type is the ‘design
worksheet’.

Further configure
embroidery
elements to print

Grid / guides These may be used to help align the
hoop template lines. See also Setting
grid options.
 Optionally, tick Design Information to include
production information in the printout:
 Further configure design worksheet options as
necessary:
Option

Purpose

Stitches

Display design as stitches with or without
Artistic View. In stitch view, connectors
may also be shown. Use them as a guide
when you save to multiple files for
multi-hooped positioning.

Outlines

In stitch view, outlines helps delineate
shapes. Alternatively, turn off stitches
and print outlines alone.

Artwork

Choose to include bitmap or vector
artwork in the printout.

Information

Purpose

Thread
usage

Helps you determine length of threads
required and assemble prior to
production. Thread usage appears below
the color sequence list.

Machine
runtime

Estimated machine runtime based on
current machine type. See also Changing
hoops.

Print on
separate
page

Print all design information on a separate
page for easy reference. For instance, a
multi-hooped design may include many
color changes, requiring a dedicated
page to display.
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 Optionally, print the whole design or selected
objects only. Only enabled if there is already a
selection in the design window.
Print selected
objects only

To print an appliqué pattern

1 Click the Print Preview icon.
2 Click Options. The Print Options dialog opens.
Select to print
appliqué patterns

 Select a sizing option to view the design on the
worksheet:
Type

Purpose

Zoom 1:1

Choose this (the default) if you want to see
the design in real size.

Zoom to fit

Use this if you want to see the design using
all the available space on the worksheet.

% of actual Use this if you want a larger printout at a
size
known relative size – e.g. twice the original
(200%).
Zoom to
article

Use this if you want to visualize design
placement on an actual article or garment.

3 Select the Appliqué Patterns checkbox.
4 Click OK.
Each appliqué pattern piece is numbered
according to the stitching sequence.

 Optionally, click the Font button to adjust
worksheet display font.
Appliqué
Assembly
page

Adjust worksheet
display font

Appliqué
Patterns page

Tip While the cloth setting marking is supported
in JEF and SEW files, outlines are not. Since JEF
and SEW are machine file formats, they only
contain stitch data, no outlines. The workaround is
to display JEF and SEW files with stitches and cloth
setter marking turned on.

Printing appliqué patterns
Use General > Print Preview to preview a design
before printing.
Print a copy of the appliqué pattern to use to cut out
the fabric pieces. Each appliqué pattern piece is
numbered according to the stitching sequence.

Note If the Zoom 1:1 option is selected, both an
assembled appliqué layout and individual patterns
in the actual size are created on separate pages. If
the Zoom to fit or % of Actual options are
selected, the assembled appliqué layout is created
in the selected size, but individual patterns are still
printed in the actual size on separate pages.

5 Click Print.

Printing color sequence
Use General > Print Preview to preview a design
before printing.
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The Color Film option lets you include a list of color
layers in the current design, together with color and
stitch information for each layer.

To print a multi-hooped design

1 Click the Print Preview icon.
2 Click Options. The Print Options dialog opens.

To print the color sequence

1 Click the Print Preview icon.
2 Click Options. The Print Options dialog opens.

Select color film
worksheet

3 Select Color Film with or without the design

Select hooping
sequence worksheet

3 Select Hooping Sequence with or without the
design worksheet.

4 Click OK.

worksheet.

4 Click OK.

Stop #: 3
Code: 0941
Name: Cornucopia Outlines
Chart: Isacord 40
Stitches: 1371
Thread Used: 19.82ft

The following information is included showing the
objects in each hooping.

The following information is included:
Field

Description

Stop

Number in the stitching sequence.

Code

Thread code for ease of ordering.

Name

Color name listed in the associated thread
chart.

Chart

Thread brand – e.g. Isacord 40.

Stitches

Total stitch count for individual color layer.

Thread
used

Total stitch length of the individual color
layer in the measurement unit currently set
for the system – e.g. ‘meters’.

5 Click Print.

Printing multi-hooped designs
If there is more than one hooping in the design, you
have the option of printing hoops in multi-hooping
view in their correct color sequence. See also Creating
multiple hoopings.

Note The information displayed here is the same
as the information displayed in the Hooping
Sequence docker. See Creating automatic
multi-hoopings for details.
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5 Click Print.

Saving designs as bitmap

Printing thread charts

The Save Design as Image command allows you to
save design images for use with your fabric and
garment application. The resulting image is exactly as
it appears on screen, including connectors, stitch
cursor, grid, as well as any backdrop. The hoop,
however, does not appear in the image file even if it
intersects objects within the design.

Use Color Palette > Thread Colors to search for and
match threads from different charts, and assign for
use. Right-click to access Design Properties >
Thread Colors summary tab.
The Thread Colors > Print option allows you to print
the thread list in the current thread chart as a
shopping reference when purchasing threads.
To print a thread chart

1 Right-click the Thread Colors icon.

To save a design as an image
 Switch to Embroidery Canvas.
 With the design still open in the design window,
select File > Save Design as Bitmap.
The Save Design as Bitmap dialog opens. By
default, PNG is the selected file type.

The Design Properties > Thread Colors dialog
opens.
Click to print chart
Select thread
chart to print

2 Select a thread chart from the Thread Chart list.
3 Click the Print button.
A Print Preview page opens displaying a printed
form of the selected thread chart in the current
sorting order.

 Optionally, deselect the Make Background
Transparent option as required.
This option is only available with PNG. When
checked, the grid and background are excluded
from the saved image and only design objects
appear.
 Click Save. The design is saved as an image file.

This printable thread chart includes the thread
chart name, code, brand, and description.

4 Click Print Now to proceed with printing.
The MS Windows® Print dialog opens allowing
you to choose a printer and adjust any other print
settings you require.

Stitch View with grid

Artistic View with fabric

5 Use the tick boxes in the printed document to
mark off any threads you want to purchase. There
is also a Memo field for notes.

Note Zoom factor has no bearing on the image
file which is always saved at 1:1 (real size).

6 Click Print.
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Stitching out designs

If this is the first time you have downloaded a
design after turning on the machine or Reader box,
the Bernina Device Selection dialog opens.

Use General > Write to Card/Machine to write (save)
design to BERNINA design card or BERNINA
embroidery machine.
Use Write to Card/Machine to send a design
directly to your BERNINA embroidery machine. See
also Writing designs to machine.

4 Select an embroidery machine type and COM port
if prompted to do so. See also Device selection.

5 Click OK.

Tip Check the color sequence before you stitch a
design. Use Print Preview to view stitching
information. See Previewing & printing worksheets for
details.

If the machine connection is working, the Write to
Embroidery System dialog opens. The name and
the thumbnail of your design are displayed.

To stitch out a design

1 Switch to Embroidery Canvas.

Click to stitch out
selected design

6 Click Stitch out Selected Design.
The Writing file(s) to device dialog displays,
followed by a confirmation message. The design is
sent to your embroidery machine ready for
stitching.

2 Check that the design fits the hoop. Use the
smallest hoop possible. See Changing hoops for
details.

3 Click the Write to Card/Machine icon.

Note When you send designs directly to machine,
they will be lost when the machine is turned off.
Apart from saving to hard disk, floppy disk or
archiving to CD, you can also preserve designs by
writing them to a variety of storage devices. Saved
designs can then be retrieved for editing. See also
Working with Machine Files.

Outputting multi-hooped designs
When working with designs that are larger than the
available physical hoop, you can split them into parts
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in Multi-Hooping, each containing an object or
group of objects. When a multi-hooped design is
output, each part is stitched separately after the
fabric has been re-hooped. See also Creating multiple
hoopings.

2 Ensure that the embroidery machine or reader box
have been correctly attached.

The following commands are all available in
Multi-Hooping:
 Save As
 Write to Card/Machine
 Card/Machine Write
When any of these commands is invoked,
multi-hoopings and split lines are applied. Hooping
Sequence mode is activated, showing the separate
hoopings. In the case of the Save As command,
however, Hooping Sequence mode is only activated
if you choose to export split files. See also Printing
multi-hooped designs.

3 Click the Write to Card/Machine icon.
The system checks whether there is only one hoop
in the design and if all objects are covered.
 If some objects are uncovered, you are asked
whether you want to continue or otherwise.

Sending multi-hooped designs to machine
Use General > Write to Card/Machine to write (save)
design to BERNINA design card or BERNINA
embroidery machine.

 If there is more than one hoop, the system
checks that all objects are covered. All
hoopings needed to stitch the design are
displayed in Hooping Sequence mode. This

With a multi-hooped design, you can send one or
more machine files to sewing machine or memory
card. The software automatically calculates which
files are to be sent and shows you how they will look.
To send a multi-hooped design to machine

1 Switch to Multi-Hooping and create your
multi-hooped design. See also Creating multiple
hoopings.
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displays a list of all hoopings required to stitch
the design.

List of hoopings in
current design

Registration marks
appear in red

Objects already sewn
shown as dark grey
outlines

Objects to be sewn
shown in actual stitch
colors

Objects to be sewn
after this hooping
shown as light grey
outlines

Note Fabric in covered appliqué is hidden, leaving
stitchable items only. Registration marks are
shown if activated. See Outputting registration
marks for details.

one. You will need to do this when exporting machine
files.

4 Select any hooping in the list. Objects within the
selected hooping are shown in their actual stitch
colors.

5 Click the Send Now button. The system outputs a
file containing everything to be stitched within the
current hooping.

6 Repeat this process as many times as necessary to
send all hoopings.

7 Click Close to end.

Exporting multi-hooped designs
If more than one hooping is needed to cover your
design, you may split it into separate files for each

Note The Save As dialog saves only original file
formats such as ART to the My Designs library folder.
The Export Machine File dialog saves machine
(EXP) and all other file formats (PES, etc) to the My
Machine Files library folder.
To export a multi-hooped design

1 Switch to Multi-Hooping and create your
multi-hooped design. See Creating multiple
hoopings for details.

2 Select File > Export Machine File.
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Sequence dialog. See also Splitting objects
between hoopings.

Save All or
one-by-one

List of
hoopings in
current design

Choose required
machine file format

3 Choose a machine file format. Typically you will be
using BERNINA All-in-One V4 ART files or BERNINA
USB Stick EXP files.

4 Change file name as required, choose a

6 Select a hooping and click Save or click Save All.
Hoopings are named consecutively and saved to
the chosen file format.

destination folder, and click Save.
 If more than one hoop position is detected, you
are prompted to split the design into multiple
files, or export everything to a single file.

 If the system detects that not all objects are
covered by hoop positions, you are prompted.

Outputting stumpwork designs
5 Click Yes to export a file for every hooping.
All hoopings needed to stitch the design are
calculated. Any split lines are applied and
calculated hoopings shown in the Hooping

Stumpwork designs, like any other design in your
embroidery software, are saved to native ART file
format. The ART format contains a complete set of
design information in a single ‘all-in-one’ file – object
outlines and properties, actual stitches and machine
functions, thread colors, a picture icon and
comments. It also includes all stumpwork elements in
addition to the base design. When it comes time to
output the design, however, it is necessary to create
separate machine files for the machine.
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Exporting base design

everything you need to know about exporting
stumpwork.

Use View > Show Stumpwork to show or hide any
stumpwork sub-designs included in a design.
It doesn’t really matter which order you export the
design elements, but it’s logical to start with the base
design.
To export the base design

1 Open the stumpwork design file you want to
output.

5 If you then open the exported machine file, you
will only see the base design without
accompanying stumpwork pieces.

2 Use the Show Stumpwork option to selectively
view stumpwork elements together with the base
design.

3 Select File > Export Machine File.

Exporting stumpwork pieces
If a design such as the one shown here, includes
repeating stumpwork elements, there is no need to
output each one to machine file.
To export the stumpwork pieces

1 Choose a single instance of the stumpwork
element and open it as a sub-design.

2 Again use the Export Design function to output
the stumpwork piece as a machine file.

4 Choose the machine file you want and save it out.
The warning message you receive will tell you
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3 Repeat the same action for each unique
stumpwork piece making up the design.

4 Each piece can be output as many times to
machine as necessary to assemble the final
design.
Tip For maximum efficiency, you may want to
copy all stumpwork sub-designs into a single
design and stitch them out together in one
hooping.

Print a worksheet
Use General > Print Preview to preview a design
before printing.
Finally, it’s a good idea to output a design worksheet
to accompany your machine files. You will refer to this
when assembling the final stumpwork design. See
Printing designs for details.
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QUICK REFERENCE
BERNINA Embroidery Software integrates with
CorelDRAW® Essentials X6 into a single application.
This Quick Reference details commands and tools
available in the Embroidery Canvas and
Multi-Hooping.

Embroidery Canvas

Operating modes

The Embroidery Canvas allows you to create, edit,
and output embroidery designs using the embroidery
digitizing toolset. The screen image below displays an
exploded view of all toolbars in the BERNINA
DesignerPlus Embroidery Canvas.

BERNINA Embroidery Software has one workspace or
‘design window’ but you interact with it in different
modes or ‘canvases’: Artwork Canvas, Embroidery
Canvas. These are accessed via the Canvas toolbar.

Use Canvas > Embroidery Canvas to digitize and
edit embroidery designs. Display embroidery as well
as artwork. View designs realistically in 3D
simulation.

Title bar
Menu bar
Toolboxes
Canvas toolbar

Docker panel

General toolbar
View toolbar
Zoom toolbar

Design window

Transform toolbar

Stitches toolbar

Effects toolbar

Color palette
Status bar
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Artwork Canvas
Use Canvas > Artwork Canvas to import, edit or
create vector artwork as a backdrop for
embroidery digitizing, manual or automatic.

The Artwork Canvas allows you to create and edit
bitmap and vector artwork using the
CorelDRAW® Essentials X6 toolset. Below is a screen
image of the Artwork Canvas workspace. This
includes the entire suite of CorelDRAW® drawing tools
which offer many techniques for drafting outlines and
shapes onscreen.

File menu
New

Open new blank design.

New from
Template

Create new design from template.

Open Design

Open an existing design.

Open Recent
Design

Select file from most recently used.

Close

Close current design.

Save

Save current design.

Save As

Save current design with a different name,
location or format.

Save as
Template

Save current design as a design template
for future use.

Export Machine
File
Print

Print active design using current settings.

Print Preview

View design worksheet. Print worksheet
from this window.

Read from
Read (open) design from BERNINA
Card / Machine Embroidery Software Design Card or
BERNINA embroidery machine.

In addition, Artwork Canvas provides capabilities to
convert vectors and vector text directly to
embroidery. You can use Artwork Canvas to insert
or paste third-party vector graphics such as clipart for
use in embroidery designs. Alternatively, insert, paste
or scan bitmap artwork for use as digitizing templates
or ‘backdrops’.
Note For a full description of the CorelDRAW® tools
available in Artwork Canvas, refer to the electronic
User Guide available via the Windows Start >
Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.

Write to Card /
Machine

Write (save) design to BERNINA design
card or BERNINA embroidery machine.

Insert
Embroidery

Import embroidery design files into the
current design.

Insert Artwork

Import vector or bitmap artwork into
current design as a backdrop for manual
or automatic digitizing.

Scan Artwork

Scan images directly into BERNINA
Embroidery Software.

Save Design
As Bitmap

Save design images in Stitch View or
Artistic View. The resulting image is
exactly as it appears in the design window.

Exit

Close all open designs and exit BERNINA
Embroidery Software.

Edit menu
Undo / Redo

Cancel last command or series of
commands, or re-apply.

Cut / Copy

Cut or copy selection and place on
Clipboard.

Paste

Paste contents of Clipboard into design
window.

Duplicate

Duplicate selection without placing it on
clipboard.

Duplicate with
Offset

Duplicate a cloned object at the same
offset from its source object.

Delete

Delete selection without placing it on
clipboard.

Embroidery Canvas menu bar
The Embroidery Canvas menu bar contains the
pulldown menus described below.
Note Standard MS Windows® Alt key shortcuts
apply. Use the Alt key with the letter underlined in the
menu. To cancel an operation, press Esc twice.
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Select All

Select all objects in design.

Deselect All
Close Curve
with ... Line

View entire product in design window.

Deselect all selected objects in design.

Zoom > Zoom
to Article

Close an open outline with a straight or
curved line.

Zoom > Zoom
to Hoop

Display entire hoop in design window.

Smooth Curves Apply curve ‘smoothing’ to selected
objects.

Pan

Drag to pan across the design at high
zoom factors. Shortcut <P> also available.

Elastic
Lettering

Previous View

Return to previous view. Shortcuts <V>
and <F5> also available.

Apply special effects to lettering objects to
make them bulge or arch, stretch or
compress.

Adjust Stitch
Spacing

Center Current Center currently selected stitch in design
Stitch
window. Shortcuts <C> and <F6> also
available.
Measure

Measure distances on screen. Shortcut
<M> also available.

Stitch Player

Redraw design slowly to check stitching
sequence. Shortcut <Shift> + <R> also
available.

Hide Colors

Show only selected colors in design.

View all Colors

Show all colors after activating View by Color.

Refresh Screen

Refresh screen display. Shortcut <R> also
available.

View menu
Artistic View

Show / hide artistic view.

Dim Artwork

Dim backdrops to show stitches more
clearly when digitizing.

Show >

Access same design viewing commands
as available on View toolbar.

Show Hoop

Show / hide hoop display. Right-click for
settings.

Design menu

Show Hoop
Template
Show Grid

Show / hide workspace grid.

Show Rulers & Show / hide workspace rulers and guides.
Guides
Show Work
Area

Show / hide work area defined under
Layout.

Show Quilt
Block

Show / hide quilt block defined under
Layout.

Zoom > Zoom

Zoom in/out of workspace and zoom in on
bounded areas to full window size.
Shortcut <B> also available.

Zoom >
Zoom 1:1

Show design at actual size. Shortcut <1>
also available.

Zoom > Zoom
Factor

Display design as percentage of actual
size. Shortcuts <F> and <F3> also
available.

Design
Properties

Show design information such as size or
number of stitches, and add comments to
print on worksheet.

Thread Colors

Search for and match threads from different
charts, and assign for use.

Auto Start &
End

Set start and end points in design.

Fabric

Adjust fabric types and settings.

Background

Select background fabrics and colors.

Stitch
Sequence

Automatically arrange stitch sequence to
minimize hoopings, color changes and
trims.

Arrange menu
Group

Combine multiple objects into one selectable
object grouping. Shortcut <Ctrl+G> also
available.

Ungroup

Split object grouping into component
objects. Shortcut <Ctrl+U> also available.

Lock / Unlock
All

Lock and unlock objects to protect them
during digitizing or editing. Shortcut keys
<K> and <Shift+K> also available.

Sequence >

Access same object sequencing
commands as available on Color Film
toolbar. See Color Film toolbar for details.

Align >

Access same object alignment commands
as available on Arrange toolset. See
Arrange toolset for details.

Space Evenly

Same functions as the Arrange toolset.

Zoom > Zoom
In 1.25x
Zoom > Zoom
Out 1.25x
Zoom > Zoom
In 2X

Display design at 200% current view.
Shortcut <Z> also available.

Zoom > Zoom
Out 2X

Display design at 50% current view.
Shortcuts <Shift+Z> and <F10> also
available.

Zoom > Zoom
to Fit

Display whole design in design window.
Shortcut <0> also available.

Zoom > Zoom
to Selected

Zoom into selected object. Shortcut
<Shift+0> also available.
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Artwork menu

Bernina
International
Home Page

Open BERNINA® International web site.

Insert Artwork

Same as File > Insert Artwork.

Adjust

Adjust image lightness and contrast.

Touch Up

Open a third-party paint program to edit
selected bitmap artwork.

Bernina of
Open BERNINA® of America web site.
America Home
Page

Crop

Crop bitmap artwork for use with
auto-digitizing.

Embroidery
Design Studio

Bitmap Artwork Reduce number of colors, remove image
Preparation
‘noise’, and sharpen outlines in scanned
artwork.
Settings menu
Object
Properties

Same functions as the General toolbar.

Effects

Same functions as the General toolbar.

Options

Adjust settings for display window.

Embroidery
Online

Open Embroidery Online web site.

Embroidery Canvas toolbars

Manage
Fabrics
Calibrate
Screen

BERNINA
Embroidery
Design Studio

Calibrate screen for accurate display.

Scanner Setup Set scanner options.
Create Pattern

Save your own patterns for future use in
pattern fills or runs, or even as pattern
stamps.

Create Border

Save your own borders for future use with
monogram designs.

The Embroidery Canvas workspace contains the
toolbars described below. Not all tools are relevant to
all levels of product.
Canvas toolbar
There are three operating modes in BERNINA
Embroidery Software accessible via the Canvas
toolbar.
Artwork
Canvas

Import, edit or create vector artwork as a
backdrop for embroidery digitizing,
manual or automatic.

Embroidery
Canvas

Digitize and edit embroidery designs.
Display embroidery as well as artwork.
View designs realistically in 3D simulation.

Tile Horizontal / Split open design tab in a horizontally or
Vertical
vertically ‘tiled’ (non-overlapping) fashion.

Embroidery
Library

Open the Embroidery Library window.

Remove Tiling

Show
Embroidery

Show / hide any embroidery components.

Window menu

Dockers

Show / hide dockers to optimize working
area. See also General toolbar.

Toolbars

Show/hide toolbars to optimize working
area.

Convert Embroidery to Artwork: Convert
selected embroidery objects to vector
artwork.

(Title of Open
Window)

Choose from a list of open windows titles
in the order in which they are stacked.

Convert Artwork to Embroidery: Convert
selected vector or bitmap artwork to fill or
outline stitches.

Help menu
Help Topics

List onscreen help topics.

Reference
Manual

Onscreen documentation in Adobe Acrobat
PDF format. Note: depending on your
product level, documentation components
may vary.

Release Notes
About

Show BERNINA Embroidery Software
version information.

Show Design
Warning

Displays a warning when opening a design
that should not be scaled.

Note For a full description of the
CorelDRAW® Essentials X6 tools, refer to the
electronic User Guide available via the Windows Start
> Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.
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General toolbar
This toolbar includes tools for opening and outputting
designs, accessing design properties, and opening
and closing docker windows.
New Blank
Design

Open new blank design.

Open
Design

Open an existing design.

CutWork
Border

Show / hide the CutWork Border docker.
Use in conjunction with CutWork and
StumpWork toolboxes.

This toolbar brings together tools for design
visualization. See also Viewing Designs.
Show
Show / hide simulation of stitched
Artistic View embroidery.

Print active design using current settings.

Print
Preview

View design worksheet. Print worksheet
from this window.

Write to
Card /
Machine

Write (save) design to BERNINA design
card or BERNINA embroidery machine.

Cut

Same as Edit > Cut.

Copy

Same as Edit > Copy.

Paste

Same as Edit > Paste.

Undo

Show / hide Morphing Effect docker.
Create transformed object outlines and
stitches.

View toolbar

Save Design Save current design.
Print

Morphing
Effect

Same as Edit > Undo.

Dim Artwork

Dim backdrops to show stitches more
clearly when digitizing.

Show
Stitches

Show / hide embroidery stitching.

Show
Outlines

Show / hide object outlines. Turn off
stitches to view outlines only.

Show
Needle
Points

Show / hide the needle points in
embroidery stitching.

Show
Connectors

Show / hide connecting stitches between
embroidery objects.

Show
Bitmap
Artwork

Show / hide any bitmap artwork included
in the design.

Show Vector Show / hide any vector artwork included in
Artwork
the design such as CorelDRAW® clipart.
Redo

Same as Edit > Redo.

Insert
Embroidery

Same as File > Insert Embroidery.

Insert
Artwork

Same as File > Insert Artwork.

Object
Properties

Access properties of selected embroidery
objects or preset with nothing selected.

Effects

Apply stitch effects to selected embroidery
objects or preset with nothing selected.

Options

Access workspace options such as grid,
hoop, and scroll settings.
Change measurement units within
software without changing operating
system settings.

Show
StumpWork

Show / hide any stumpwork sub-designs
included in the design.

Show
Appliqué
Fabric

Show / hide background fabric / color of
any appliqué objects in the design.

Show Hoop

Show / hide hoop. Right-click for settings.

Show Hoop
Template

Show / hide hoop template. Right-click for
settings.

Show Grid

Show / hide workspace grid. Right-click
for settings.

Show Rulers Show / hide workspace rulers and guides.
& Guides
Right-click for settings.
Show Work
Area

Same as View > Show Work Area

Overview
Window

Show / hide Overview Window docker.
Use to zoom and pan thumbnail of current
design.

Show Quilt
Block

Same as View > Show Quilt Block.

Color Film

Show / hide Color Film docker. Use it to
resequence objects and color blocks in
the design.

Stitch Player

Simulate embroidery design stitchout
onscreen in either stitch or artistic view.

Carving
Stamp

Show / hide Carving Stamp docker. Use
preset or custom patterns to create a
pattern of needle penetrations.
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Color palette
This toolbar displays a palette of thread colors
together with tools for selecting, applying, and cycling
through colors. See also Thread Colors & Charts.

Raised Satin
Outline

Create raised satin borders – can be
used with trapunto for quilting effects.

Zigzag Outline

Create narrow, open borders with a
‘zigzag’ effect.

Blanket Outline

Create narrow, open borders with a
‘comb’ effect.

Blackwork
Outline

Create ornamental craftstitch borders.
Name derives from black silk thread
traditionally used in this form of
embroidery.

Candlewicking
Outline

Create ornamental craftstitch borders.
Specify exact pattern size and spacing.

Pattern Run
Outline

Create ornamental craftstitch borders.
Choose from pattern library.

Color Picker

Pick up a color from an existing object
and make it current.

Apply Current
Color

Apply the currently selected palette
color to embroidery objects.

Current Color

Shows the currently selected palette
color.

Add Palette
Color

Add a color slot to the end of the
palette.

Remove
Palette Color

Removed an unused color slot from the
end of the palette.

Hide Unused
Colors

Show / hide all unused colors in the
palette.

Step Fill

Create stitch fills for larger, irregular
shapes.

Remove
Unused Colors

Remove all unused colors from the
palette.

Satin Fill

Create stitch fills for narrow shapes.

Cycle Used
Colors

Cycle through combinations of used
colors. Right- or left-click.

Raised Satin
Fill

Color Wheel

Access Color Wheel to test
combinations of related colors.

Create raised surfaces – can be
applied to lettering or used with
trapunto for quilting effects.

Fancy Fill

Create artistic fills while keeping the
appearance of solid stitching.

Sculptured
Fancy Fill

Create 3D pattern effects with turning
fills.

Ripple Fill

Create spiral stitching from the center
of any filled object.

Contour Fill

Create stitching which follows object
contours, creating a curved,
light-and-shade effect.

Blackwork Fill

Create fill for blackwork designs. Name
derives from black silk thread
traditionally used in this form of
embroidery.

Candlewicking
Fill

Create candlewicking fills – traditional
white-on-white embroidery usually
done with heavy cotton thread on white
linen.

Lacework Fill

Create a lacey look with open
trellis-like patterns.
Create decorative fill stitching. Choose
from pattern library.

Fills

Change Design Search for and match threads from
Color
different charts, and assign for use.

Stitches toolbar
This toolbar provides a range of basic outline and fill
stitch types as well as those of a more artistic or
decorative kind. It also includes stitch effects which
can be additionally applied. Left-click icons to select
stitch type. Right-click to access properties. See also
Outline & Fill Stitching.
Outlines
Single Outline

Create a single row of stitches along a
digitized outline – used for borders or
details.

Triple Outline

Create a thicker outline by repeating
each stitch three times – use for
heavier borders or details.

Sculpture
Outline

Create a tick-thin outline alternating
single and triple stitches for a
hand-stitched look.

Pattern Fill

Backstitch
Outline

Create traditional backstitch borders –
old, adaptable stitch type used for
delicate outlines.

Create open patterned fills with
Cross Stitch Fill crosses generated to suit standard grid
for entire design.

Stemstitch
Outline

Create traditional stemstitch borders or
details such as stems and vines.

Stipple Run Fill

Satin Outline

Create thicker borders or columns of
even thickness.

Create fills made up of run stitches
which meander within a border.
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Stipple
Stemstitch Fill

Create heavier stipple run fills with
stemstitch outlines.

Mirror X

Stipple
Backstitch Fill

Create heavier stipple run fills with
backstitch outlines.

Mirror Y

Flip selected object/s in horizontal or
vertical planes.

Rotate Left
45°

Effects toolbar
This toolbar contains tools used to create many
artistic effects to create textured and curved
stitching, color blending, and warping or ‘morphing’
stitching effects. See also Stitch Quality and Stitch
Effects.

Rotate
Right 45°

Rotate selected objects in 45° increments
to right or left.

Rotate selected objects by specified
amount – positive or negative – in degrees.

Underlay

Strengthen and stabilize objects with
underlay stitching.

Skew selected objects by specified amount
– positive or negative – in degrees.

Textured
Edge

Create rough edges and shading effects, or
imitate fluffy textures.

Automatic
Corners

Toggle mitre or cap corners in line objects
with sharp turns. Can be turned on/off
object-by-object.

Enter specific settings for precise
positioning of selected objects. Use in
conjunction with Rulers & Guides.

Couching

Add couching cord for use with the
BERNINA Free Motion Couching Foot #43.

Star Fill

Create radial turning stitching with available
stitch types. Stitches are generated from
outside to geometric center. Center can be
shifted.

Wave Fill

Create contoured stitches along a digitized
guideline – stitching maintains uniform
density.

Elastic
Fancy Fill

Create fancy fill patterns that follow stitch
angles and are scaled according to object
width. Right-click for settings.

3D Globe
Effect

Create contoured stitches to produce a 3D
appearance. Choose from pattern library.

Transform toolbar
This toolbar contains all the tools you need to select,
reshape, scale, and mirror embroidery designs in
Embroidery Canvas mode. See also Design
Layouts.
Select
Object

Click to select objects or drag a selection
marquee to enclose.

Polygon
Select

Select irregular areas or shapes – click
reference points to demarcate.

Reshape
Object

Reshape selected embroidery and
lettering objects.

Size +20%
Size -20%

Scale objects or whole designs by a
precise width or height, or a percentage
factor. Use Aspect Ratio lock to maintain
proportions.
Travel toolbar
This toolbar contains tools for checking a design’s
stitching sequence by ‘traveling’ through it by
stitches, colors or objects. See also Viewing stitch
sequence.
Select
While
Traveling

Toggle on to select stitches, objects, or
colors while traveling through a design.

Travel
Backward

Travel backwards through a design.

Travel
Forward

Travel forwards through a design.

Jump by
Object

Travel to the previous or next object in the
design. Use in conjunction with
Forward/Back buttons.

Jump by
Color

Travel to the previous or next color block in
the design. Use in conjunction with
Forward/Back buttons.

Jump to
Start/End

Travel to the start or end of the design. Use
in conjunction with Forward/Back buttons.

Increase/reduce size of selected object/s
in 20% increments. Stitches are
automatically recalculated.
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Zoom toolbar
This toolbar includes tools for zooming and panning
designs. Other zoom presets are available via the
View menu. See also Zooming & panning.

Zoom

Left-click to zoom in, right-click to zoom out,
or drag a ‘zoom box’. Shortcut <B> also
available.

Zoom Factor: select a preset zoom scale from
the droplist or key in your own zoom scale and
press Enter.

Pan

Drag to pan across the design at high zoom
factors. Shortcut <P> also available.

Embroidery Canvas toolboxes
The Embroidery Canvas workspace contains a
Toolbox permanently docked on the left of the
workspace. The Toolbox contains a series of
‘toolsets’ organized as follows.
Manage Design toolset
The built-in Embroidery Library provides an
efficient way to view and manage embroidery
designs. It recognizes all design file formats used by
the software. The library also makes it easy to search,
sort and browse all embroidery designs on your
system. See also Managing Designs.
New from
Selected

Create new design(s) based on the
design(s) selected in the embroidery
library.

Open
Selected

Open design(s) selected in the
embroidery library.

Convert
Selected
Designs

Convert the design selected in the
embroidery library into different machine
file types.

Stitch
Selected
Design

Stitch the design selected in the
Embroidery Library

Print designs selected in the embroidery
Print Selected
library.
Print Selected
Print selected designs to a catalog.
to catalog
Export
Designs List

Export a text or CSV file containing a list
of the visible design files and their
properties.

Find
Embroidery
Designs

Search the computer for folders
containing embroidery to add to the
library.

Add Folder to
Library

Add an existing folder to the Embroidery
Library. This enables faster searching
and filtering of the folder.

Remove
Folder from
Library

Remove a folder from the Embroidery
Library. This only removes the link to the
folder from within the library. It does not
actually delete the files in the folder from
storage.

Edit toolset
This toolset contains all tools you need to edit
embroidery designs in Embroidery Canvas mode.
Add Holes

Cut holes in filled objects.

Remove
Holes

Remove holes from selected objects.

Add Stitch
Angles

Add stitch angles to closed objects with
or without holes. Right-click for settings.

Remove
Stitch Angles

Remove stitch angles from closed
objects with turning stitches.

Double Run

Reinforce outlines, stitching it in the
opposite direction.

Blackwork
Run

Automatically sequence selected
outlines for efficient stitchout.

Color
Blending

Create blended stitching in selected
objects.

Fill Holes

Fill holes in selected objects with current
stitch type.

Outlines &
Offsets

Create outlines and offsets of any type
for any filled embroidery object.

Quilting
Background

Create ‘echo’ quilting blocks.

Create
Trapunto
Outlines

Use in conjunction with raised satin to
create stitching for a raised ‘quilted’ look.

Break Apart

Split monograms, appliqué, lettering,
and blackwork runs into component
objects for editing.

Remove
Overlaps

Remove unwanted stitching underlying
objects or lettering.

Remove
Appliqué
Overlaps

Remove unwanted stitching from
underlying appliqué objects.

Knife

Cut objects along a digitized line,
preserving stitch settings and colors in
resulting objects.

Stitch Edit

Place the stitch cursor at a selected
insertion point.
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Auto-Digitize toolset
This toolset contains all tools required for
auto-digitizing artwork in Embroidery Canvas
mode. See also Automatic Digitizing.
Insert Artwork Same as File > Insert Artwork.

Closed
Freehand

Draw closed embroidery objects
onscreen in the current stitch type –
outline or fill.

Block

Digitize columns with turning stitches.

Ellipse

Digitize ellipse or circle embroidery
objects.

Adjust

Same as Artwork > Adjust.

Rectangle

Digitize rectangle or square embroidery
objects. Press <Ctrl> to constrain.

Crop
Background

Open Crop toolbar to crop bitmap
artwork for use with auto-digitizing.

Lettering

Create embroidery lettering directly on
screen.

Touch Up

Edit images in a third-party graphics
application.

Monogramming

Color
PhotoStitch

Automatically turn photographs and
other bitmap artwork into multi-colored
embroidery.

Create personalized monograms using
a selection of pre-defined styles, border
shapes and ornaments.

Appliqué

Digitize closed-object appliqué with all
necessary stitching.

PhotoSnap

Automatically create rows of Satin and
Contour stitches of varying spacing in
current color from photographs and
other bitmap artwork. The effect
resembles the output of a line printer.

Advanced
Appliqué

Generate open-object appliqué from
one or more source objects.

Buttonhole

Digitize a single buttonhole with all
necessary stitching.

Auto-Digitize

Automatically digitize prepared bitmap
artwork.

Buttonholes

Digitize a line of buttonholes with all
necessary stitching.

Instant
Auto-Digitize

Automatically digitize bitmap artwork
instantly.

PunchWork

Magic Wand

Automatically digitize filled areas in
vector or bitmap artwork.

Digitize PunchWork designs for use
with the BERNINA Rotary Hook Punch
tool.

Pattern Stamp

Place individual patterns in the design.
Choose from pattern library.

Basting Stitch
Maker

Insert a reference marker at any angle
and position.

Insert Graphic
Marker

Insert a graphic marker representing
adhesive stickers attached to the fabric
to indicate location and orientation.

Magic Wand
Block
Digitizing

Digitize narrow column artwork shapes
with satin stitch.

Magic Wand
Fill without
Holes

Digitize large artwork shapes with Step,
ignoring any holes within.

Magic Wand
Centerline

Digitize centerlines in arwork with
Outline stitches.

Set Matching
Method

Use to assign image colors to the color
palette for manual thread matching, or
automatically match them to the current
color palette or current thread chart.

Digitize toolset
This toolset contains all tools required for manually
digitizing embroidery designs in Embroidery
Canvas mode. Right-click to access properties. See
also Digitizing Methods.
Open Object

Digitize open embroidery objects.

Closed Object

Digitize closed embroidery objects.

Open
Freehand

Draw embroidery outlines onscreen in
the current stitch type.

Freehand settings
When Freehand tools are activated, the Freehand
Settings toolbar appears.
Use the Smoothing control to specify, as a
percentage, how closely the smoothed
outline follows the original.
Use Show Guide to toggle freehand digitizing
guide cursor – provides more control over
‘freehand’ drawing than the default pointer.
Use the Guide Inner Circle Radius control to
define size of center circle of freehand
digitizing guide.
Use the Number of Guide Circles control to set
number of circles in the freehand cursor – if
the inner circle radius is 2mm, each additional
guide circle is offset by 2mm.
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CutWork toolset
The CutWork toolset is available from the Toolbox.
It contains all the tools necessary to digitize cutwork
holes and pieces from scratch. See also Digitizing
cutwork.
Add Cutwork
Border

Generate a cutwork border from
selected objects.

Digitize Cut

Digitize a simple open or closed cut in
hooped fabric. Right-click for settings.

Digitize Piece

Digitize a cutout piece in hooped fabric,
together with supporting embroidery.
Right-click for settings.

Digitize Hole

Digitize a hole in hooped fabric,
together with supporting embroidery.
Right-click for settings.

Cut Closed
Border

Cut a closed cutwork border and leave
an opening for wire ends.

Cut Buttonhole Generate a cutting line for selected
Slit
buttonholes.

StumpWork toolset
The StumpWork toolset is available from the
Toolbox. It contains all the tools necessary to digitize
stumpwork from scratch or create stumpwork from
existing objects. See also Digitizing stumpwork.
Create
Stumpwork
Sub-design

Create stumpwork sub-design from
selected objects which include
embroidery within a stumpwork
border.

Open StumpWork View and edit selected stumpwork
Sub-design
sub-design.
Save Stumpwork
Sub-design As

Save stumpwork sub-design as a
separate design file.

Digitize Wireline

Create a wireline using a digitized
outline and current settings.

Reflect

Duplicate and mirror objects or designs.
Use to create decorative borders.

Wreath

Duplicate selected objects around a
central axis. Specify duplicates in
Mirror-Merge Settings toolbar.
Enter number of wreath points. Enter
even number to activate Kaleidoscope.

Layout toolset
The Layout toolset allows you to arrange multiple
embroidery designs or design elements on a fabric,
garment, or item such as tablecloth. See also
Creating design layouts.
Layout to
Rectanglar
Work Area
Corners

Automatically create copies of any
selected object/s in each corner of the
layout work area.

Layout Around
Circular Work
Area

Automatically create copies of
selected object/s (specified by number
of repeats) around the center of the
work area.

Auto Center to
Work Area

Automatically move selected object/s
to center of the work area.

Define Work
Area

Open the Layout Work Area dialog to
define either a rectangular or round
work area of a specified size.

Layout to
Rectanglar
Quilt Block
Corners

Automatically create copies of any
selected object/s in each corner of the
layout quilt block.

Auto Center to
Quilt Block

Automatically move selected object/s
to center of the quilt block.

Auto Fit to Quilt Automatically fit selected object/s to
Block
the quilt block.
Define Quilt
Block

Open the Layout Quilt Block dialog to
define quilt block of a specified size
and a specified center.

Mirror-Merge toolset

Arrange toolset

This toolset contains all tools required to duplicate
and transform selected embroidery objects in vertical
and horizontal planes. See also Mirroring objects.

This toolset contains all tools you need to precisely
align, distribute and mirror objects in Embroidery
Canvas mode. See also Arranging objects.

Mirror-Merge
Horizontal

Duplicate & mirror horizontally and
merge overlapping objects (optional).

Group

Combine multiple objects into one
selectable object grouping.

Mirror-Merge
Vertical

Duplicate & mirror vertically and merge
overlapping objects (optional).

Ungroup

Split object grouping into component
objects.

Mirror-Merge
Horizontal /
Vertical

Duplicate & mirror selected objects
around a center point.

Lock

Lock selected object/s into position for
protection.

Unlock All

Unlock all locked object/s to remove
protection.

Array

Duplicate designs, such as badges,
automatically re-sequencing color
blocks for efficient multiple design
stitchouts.

Align Left

Left-align selected objects.
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Align
Centers
Vertically

Vertically align centers of selected objects.

Add 4 Hoops
Around

Align Right

Right-align selected objects.

Add 8 Hoops
Around

Align Top

Align tops of selected objects.

Align
Centers
Horizontally

Horizontally align centers of selected
objects.

Applications toolset
In addition to CorelDRAW®, BERNINA Embroidery
Software includes a number of ancillary applications
which can be launched from the Applications
toolset.

Align Bottom Align bottoms of selected objects.
Align
Centers

Align centers of selected objects.

Space
Evenly
Across

Evenly distribute three or more selected
objects horizontally.

Space
Evenly
Down

Evenly distribute three or more selected
objects vertically.

Multi-Hooping toolset
This toolset is available under the Multi-Hooping
toolbox. See Creating multiple hoopings for details.
Select a Hoop

Show hoop properties.

Automatically
Add Hoops

Add hoops automatically to cover the
entire design.

Add Splitting
Line

Digitize one or more guides in a
multi-hoop layout to split objects
between hoopings.

Preview
Hoopings

Preview hoopings.

Calculate
Hoopings

Calculate hoopings resulting from
current layout.

Multi Hooping
Options

Access workspace options for
multi-hooping.

Add Hoop

Add a new hooping to a multi-hooping
layout.

Delete Hoop

Remove selected hoop from hooping
layout.

Add Hoop
Right

Place a new hooping to right of selected
hoop. Allows a 10mm overlap between
sewing fields.

Generate 4/8 hoopings around a
selected hoop’s perimeter. Allow a
10mm overlap between sewing field.

Cross Stitch

Launch BERNINA Cross Stitch from
within BERNINA Embroidery Software.

Quilter

Launch BERNINA Quilter from within
BERNINA Embroidery Software.

Color Film toolbar
This toolbar is available in Embroidery Canvas
mode.
Show
Objects

View individual objects in order of stitching
sequence. Drag and drop object icons to
resequence.

Back /
Forward 1
Object

Move selection back / forward one object in
the stitching sequence.

Back /
Forward 1
Color

Move selection back / forward one color in
the stitching sequence.

Move to
Start / End

Move selection to start / end of stitching
sequence.

Sequence
by Selects

Resequence objects in order of selection.

Sequence
by Color

Resequence all blocks of like color. (To
maintain separate color blocks, use Color
Film.)

Place a new hooping to left of selected
Add Hoop Left hoop. Allows a 10mm overlap between
sewing fields.
Add Hoop
Down

Place a new hooping to below the
selected hoop. Allows a 10mm overlap
between sewing fields.

Add Hoop Up

Place a new hooping above selected
hoop. Allows a 10mm overlap between
sewing fields.
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KEYBOARD SHORTCUTS
You select commands in BERNINA Embroidery
Software as other MS Windows® applications – from
menus or toolbars. Keyboard shortcuts are available
for frequently used commands.
Key combinations
To use a keyboard shortcut, or key combination, you
press a modifier key together with a character key.
For example, pressing the Ctrl (Control) key with the
‘c’ key copies whatever is currently selected – text,
graphics, etc – to the Clipboard. This is also known as
the Ctrl+C key combination, or keyboard shortcut.
Windows to Mac conversion
Key combinations are slightly different from Mac to
PC. If you know and use keyboard shortcuts regularly
in Windows, you will need to retrain your fingers
slightly. For the most part, a Control + Key in
Windows translates to a Command + Key in Mac OS.
Most favorites should work by just making this switch.
Here is a basic breakdown of keyboard equivalence:
Windows

Mac

Control (Ctrl)

Command (most of the time); Control

Alt

Option

Windows / Start

Command / Apple

Backspace

Backspace

Delete

Delete

Shift

Shift

Enter

Enter

Return

Return

Note Standard MS Windows® Alt key shortcuts
apply. Use the Alt key with the letter underlined in the
menu. To cancel an operation, press Esc twice.
General functions
To

Press

Cancel command

E

Exit the program

A+4

Open existing design

C+o

Print design

C+p

To

Press

Save design

C+s

Start new design

C+n

View designs
To

Press

Or

Center current stitch

c

6

Measure

M

Refresh screen

r

Show needle points

. (period or full
stop)

Show previous view

V

Show selected objects only

V+S

Zoom to fit

0 (zero) 2

Show/hide connectors

V+C

Show/hide picture

d

Show/hide vectors

V+d

Pan

P

Turn on/off Artistic View

T

Zoom (box)

b then [ 8

Zoom factor

f

3

Zoom in 2x

z

[ wheel

Zoom out 2x

V+z

0

4

5

Zoom to 1:1 scale (100%)

1

Vertical scroll

A+[ wheel

Horizontal scroll

C+[ wheel

Select objects
To

Press

Activate Select Object tool

o

Add next object to selection

C+T

Add previous object to selection

C+V+T

Deselect all objects

E or x

Select a range of objects

V+[

Select all objects

C+a

Select multiple objects

C+[

Select next object

T
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Digitizing & lettering

To

Press

Select object underneath

2+[

To

Press

Select previous object

V+T

Activate Double Run

C+b

Edit designs
To

Press

Delete the last input point

* B

Finish digitizing an object

* R or s

Turn underlay on/off

u
a

Delete the last input point

* B

Display the lettering dialog

Finish digitizing an object

* R or s

* BERNINA DesignerPlus only

Turn underlay on/off

u

Display the lettering dialog

a

Redo command

C+y

Undo command

C+z

Cut selection

C+x

Copy selection

C+c

Paste selection

C+v

Duplicate selection

C+d

Maintain an object’s proportions
while resizing

Clone selection

]+:

Reshape selected object

h

Reinforce outline (Double Run)

C+b

Change reshape node type

Delete selection

D

[+M
Select reshape node
and press spacebar

Group selected objects

C+g

Manipulate objects and stitches

* BERNINA DesignerPlus only

To

Press or click

Nudge selected designs

tblr

Move an object horizontally or
vertically

:+C
Drag the object

Regroup ungrouped objects
Press
To travel
Keyb’rd

1 segment forward

C+u

Ungroup selected objects

View stitching sequence

1 segment backward

† VL+:
Drag corner handle

Keypad*

C+l
C+r

1 stitch backward

†l

4

1 stitch forward

†r

6

10 stitches backward

†t

8

10 stitches forward

†b

2

100 stitches backward

-

100 stitches forward

+

* C+R

Lock selected objects

K

Unlock selected objects

V+K

Bring object to front

* V+u

Bring object forward

* u

Send object to back

* V+d

Send object backward

* d
e

Activate Stitch edit

† Use Alt+Drag with BERNINA Quilter * BERNINA Quilter only
System shortcuts
Here is a list of commonly-used Windows keyboard
shortcuts and their Mac equivalents.

Activate Stitch Player

V+r

To next color

d

To next object

C+t

Action

Windows

Mac

To next selected object

T

Backwards delete

Backspace

Delete

To previous color

u

Print Screen

To previous object

V+t

Capture entire screen
to Clipboard

To previous selected object

V+T

Command +
Control + Shift +
3

To the end of a design

e

1

Capture frontmost
window

Alt + Print
Screen

Command +
Shift + 3

To the start of a design

h

7

Close current window

Control + W

Command + W

Copy a file/folder

Control + drag
icon

Option + drag
icon

* Num Lock OFF † Select Object tool OFF

9

3
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Action

Windows

Mac

Action

Windows

Mac

Copy to Clipboard

Control + C

Command + C

Undo

Control-Z

Command-

Create an alias or
shortcut

Right mouse
Command + L
click and select
Create Shortcut

Cut to Clipboard

Control + X

Command + X

Exit a dialog box
without changes

Escape

Escape

Find/Search

Control + F

Command + F

Force quit a frozen
application

Control + Alt +
Delete

Command +
Option + Escape

Forward delete

Delete

Delete (For Mac
notebooks,
press the
Function (fn)
and Delete key)

Get item info or
properties

Alt + Enter

Command + I

 Disable the checkbox in Parallels preferences. This
is the easy way, but you lose all system keys at
once within the VM); or

Logout current user

Windows + L

Command +
Shift + Q

Maximize window

Control + F10

None

 Remove the assignment of those two shortcuts in
Mac OS X system preferences / keyboard /
keyboard shortcuts.

Minimize windows

Windows + M

Command + M

New folder

Control + N

Command +
Shift + N

Open file

Control + O

Command + O

Paste Clipboard

Control + V

Command + V

Print

Control + P

Command + P

Quit / close a program

Alt + F4

Command + Q

Rename a file / folder

Select item + F2 Select item +
Enter

Save file

Control + S

Command + S

Select all items

Control + A

Command + A

Select more than one
item in a list (non
contiguous)

Control + click
on each item

Command +
click on each
item

Send items to trash /
recycle bin

Delete

Command +
Delete

Send / receive email

Control + K

Command + K

Shut down

Windows + U +
U

Command +
Option + Control
+ Eject

Switch to next window

Control + F6

Command + ~
(tilde)

Switch to previous
window

Control + Shift + Command +
F6
Shift + ~ (tilde)

Toggle through open
applications

Alt + Tab

Command + Tab

Type special
characters

Alt + key

Option + key

Mac environment on virtual machines
If you are running BERNINA Embroidery Software in a
Mac environment on a virtual machine (VM), you may
find that shortcuts don’t work as expected.
Lion uses more shortcuts than Snow Leopard,
especially for LaunchPad and Mission Control. The
latter has Ctrl arrow left and Ctrl arrow right
assigned by default. With Parallels preferences /
keyboard / Enable Mac OS X system shortcuts
checked, the above combinations trigger Mission
Control functions even from inside the VM. That’s
what the preference item is for. To avoid this, you can
go two ways:

Just chose Mission Control on the left side, then you
can see the two items on the right side. Uncheck
them, and you are fine inside the Windows VM.
There’s no sacrifice unless you want to use the
shortcuts for Mission Control.
Since Mission Control only makes real fun with
gestures enabled, most people with gesture-capable
machines won’t need the shortcuts. You could even
assign other shortcuts to Mission Control if you liked.
There may also be an issue with the Shift key in
Parallels. Try the following: Click on ‘Virtual Machine’.
Configure and enable the option ‘Optimize Modifier
key for games’.
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APPENDIX A
TROUBLESHOOTING
This appendix provides help for solving problems in
BERNINA Embroidery Software. It includes
procedures for checking your system’s requirements
and settings, reverting to original values, and testing
disks and connections. It also describes how to log
errors, and lists causes for common error messages
and problems.

Solving problems in BERNINA
Embroidery Software
If you encounter a problem, refer to the following
sources for help:

Issue reporting
BERNINA Embroidery Software provides a built-in
mechanism to report an issue following a system
crash.

 BERNINA Embroidery Software Reference Manual
– select Help > Reference Manual (or printed
version)
 BERNINA Embroidery Software Online Help –
select Help > Help Topics
 MS Windows® Online Help – select Start > Help
 MS Windows® manual
 Documentation supplied with your hardware.
Getting help
If you are unable to solve a problem, you should
contact your dealer. Before seeking help, check that
your PC meets the system requirements and General
problems section in this chapter.

Report an issue in the
event of a system
crash

Use the issue reporter to request assistance for
specific issues. The reporter can also be run
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independently from the BERNINA Embroidery
Software program group.

few basic system checks. These include your PC
specifications, your CPU/RAM specifications, as well
as your available hard disk space.

System requirements
Report an issue in the
event of a system crash

System checks

In order to run your software, you need to ensure that
the following pre-requisite system requirements are
met.
PC specifications

If you are having problems with your BERNINA
Embroidery Software, it’s a good idea to carry out a
Check that your PC meets the system requirements. Check CPU/RAM as well as hard disk space. The table
below provides minimum system requirements.
Component

Minimum

Recommended

CPU

Intel® Core 2 Duo or AMD Athlon™ 64

3GHz + Latest 64-bit (x64) multi core processor

Operating system

‡ Windows® 7 (32-bit or 64-bit Editions) with latest Windows® 10 (64-bit Edition) or Windows®
service packs installed.
8.1 (64-bit Edition), with latest service packs.

Browser

I.E. 9.0 or Later

I.E. 11.0 or Later

Memory

4 GB

8 GB or more

Hard disk size
Free disk space
Graphics card

Monitor

80 GB

256 GB or More (Solid State Drive)

† 40 GB

60 GB or More

Support for Highest Color (32bit) and resolution
(1366 X 768)

¥ 1366 X 768 screen resolution

Support for DirectX 9 graphics with:
WDDM Driver
1GB of graphics memory (non-integrated)
Pixel Shader 2.0 in hardware bits per pixel
Dual Monitor Capable
Dual monitors capable of displaying 1920 X 1080
screen resolution

Mouse

USB mouse

USB mouse

USB port

Required for software installation.

Sound card

Required for online video help.

Internet
connection

Required for product activation and registration. Internet connection may also be required during
installation in order to download Windows features such as .Net Framework 3.5.

Supported operating systems ‡

Screen resolution ¥

Although Windows® 7 (32-bit or 64-bit edition) is
supported, we recommend updating to Windows® 10
(64-bit edition) or Windows® 8.1 (64-bit edition) with
latest service packs installed. You will, however, need
to uninstall any versions of CorelDRAW earlier than
X6.

Some controls may be hidden on the user interface if
you run your monitor at low resolutions. The physical
size of your monitor will have a bearing on the
optimum screen resolution. Larger fonts will
exacerbate the problem. If you experience visibility
issues, try adjusting both screen resolution and font
size. For example, a resolution of 1366 X 768 with a
font size of 100% or 125% should be acceptable.

Free hard disk space †
BERNINA Embroidery Software occupies up to 5GB of
hard disk space, depending on options installed.
CorelDRAW Essentials also takes up an additional
3GB.
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System security
The software is shipped with a product key which can
be found inside the software kit. Each product key
allows your system to be uniquely identified. You will
be prompted to enter the product key to register and
activate the product when the software is launched
the first time following installation. Please keep the
product key in a secure place.

Note Each licensed copy of the software is for a
single user. It entitles you to three (3) activations:
two (2) on different computers, and one (1) in case of
hardware failure or replacement.

To check CPU/RAM specifications

1 On the MS Windows® desktop, right-click the My
Computer icon and select Properties.
The System Properties > General dialog opens.

2 Check the MS Windows® version, the CPU and the
amount of RAM.

Checking your hard disk space
Check that your hard disk has enough space to run
BERNINA Embroidery Software effectively. See PC
specifications for details.
To check your hard disk space

1 Double-click the My Computer icon on your

Integration with CorelDRAW®

MS Windows® Desktop.
The My Computer window opens.

CorelDRAW® Graphics Suite is the most popular
vector-based drawing package for the decorated
goods industry. It features ‘best-of-breed’
bitmap-to-vector tracing, enhanced illustration
capabilities, photo-editing together with a library of
professional clipart images.
BERNINA Embroidery Software comes together with
an installation of CorelDRAW® Essentials X6. The
built-in CorelDRAW Graphics window includes
CorelDRAW drawing tools which offer many
techniques for drafting outlines and shapes on screen.
Vector objects can be converted to embroidery
designs. CorelDRAW® Essentials X6 and its sister
product, Corel PHOTO-PAINT® Essentials X6 can also
be run as standalone applications.
For a full description of the tools, refer to the
electronic User Guide available via the Windows Start
> Programs group. Alternatively, use the onscreen
help available from the Graphics mode Help menu.

Note CorelDRAW is installed together with Windows
.NET Framework. To ensure that CorelDRAW is
correctly installed with your embroidery software with
the correct version of .NET, make sure you install it
when prompted to do so. It can take up to 20 minutes
or more to install the .NET Framework on some
computers.

2 Right-click the hard-disk drive icon (usually C:)
and select Properties.
The Properties > General dialog opens.
This tab shows the hard-disk capacity as well as
any free space. This must be greater than 40 Mb
or 10% of your total hard drive space, whichever
is the greater amount.

Recovering from hardware or software
failure
If your software crashes due to a hardware or
software failure, recovery files are usually created.
When you restart BERNINA Embroidery Software
after such a failure, the design you were last working
on is opened automatically or, if Auto Save was on,
the backup file is retrieved.
To recover from hardware or software failure
 Open BERNINA Embroidery Software.
The Auto Recovery dialog will appear.

Checking CPU/RAM specifications
Check your CPU and RAM specifications, and the
version of MS Windows® you are running to ensure
they meet the BERNINA Embroidery Software
requirements. See PC specifications for details.
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 Normally, you will want to load recovery files for
the designs you were last working on.
 If a recovery file is opened, save the file to a new
name with the ART extension. Once your recovery
file has been saved and re-named with the ART
extension, the recovery files will be automatically
deleted when you close the software.
 If the design file itself has become corrupted and
is causing problems, you may need to delete
recovery files without opening.
 If problems persist, use the reporting function to
seek assistance.

3 Select Delete Backup Files if you want to delete
back up files.

4 Click OK.
If some files cannot be deleted, a message will
display. Delete these files from the C:..\Program
Files\BERNINA\Embroidery Software 8\Recover
and C:..\Program Files\BERNINA\Embroidery
Software 8\Backup folders manually, from
MS Windows® Explorer.

Unrecoverable errors
Problem

The system fails and displays ‘unrecoverable’
error.

Cause

The design you tried to open is corrupt.

Suggestion

You will be prompted next time you run the
software if you want to recover. Choose to
delete your files.

Deleting files with Delete Recovery
You can delete corrupt files using the Delete
Recovery utility. Delete Recovery deletes files in
the C:..\Program Files\BERNINA\Embroidery
Software 8\Recover and C:..\Program
Files\BERNINA\Embroidery Software 8\Backup
folders. You should also periodically delete the backup
files created by Auto Save.

Note Some files such as MLG and DMP files can build
up over time and take up disk space. You can delete
them manually from MS Windows® Explorer.

Tip If the errors persist, try reverting to factory
settings. See Reverting to factory settings for
details.

Security driver problems
When attempting to run your software, you may
encounter the following error message:
A valid license to run BERNINA Embroidery
Software could not be found...
This may happen after your Windows OS has
automatically updated. The solution is to reinstall the
HASP driver which controls the software licensing.
To reinstall the HASP security driver

1 Exit BERNINA Embroidery Software.
2 Select the Reinstall HASP Drivers utility from
the BERNINA Embroidery Software program
group.

To delete files with Delete Recovery

1 Exit BERNINA Embroidery Software.
BERNINA Embroidery Software must be closed
before deleting recovery or backup files or it will
NOT delete these files.

2 Select the Purge Recovery utility from the

Reinstall HASP drivers

The following message will appear.

BERNINA Embroidery Software program group.

Run Purge Recovery
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3 Let the installation procedure complete. You will
see a confirmation message.

driver and/or the display adapter itself. Try each of
the following solutions in sequence.
Exception access violation at startup

At this point, the HASP driver has been reinstalled.
If the HASP error occurs again in future, repeat the
process to reinstall.

General problems
The following section refers to general problems you
may experience with your designs.

Inconsistent output results
Problem

Problems when sending designs to
embroidery machines for stitching.
Inconsistent reading and writing.

Cause

Serial or USB communications problems.
Inconsistent reading and writing may be
caused by wrong port settings in the
operating system.
Other possible causes are that machine and
software versions may not be compatible. In
this case, contact your dealer.

Suggestion

Change the port settings.

Missing toolbar buttons
Problem

Buttons missing from toolbars or bottom of
toolbars.

Cause

Screen resolution is set too low. Virus in
computer. Or, the toolbar itself may be turned
off.

Suggestion

Make sure the toolbar is turned on. Go to the
Window > Toolbars menu and ensure the
toolbar has a tick beside it. If necessary,
change the screen resolution to 1366 x 768
or higher. Run your virus checker.

Problem

An ‘Exception Access Violation’ error
message appears when starting BERNINA
Embroidery Software.

Cause

A corrupt design file in the RECOVER folder
or a corrupt ..\Program
Files\BERNINA\Embroidery
Software 8\RES\defaults.dfl file.

Suggestion • Run the Revert utility via the BERNINA
Embroidery Software program group.
• Only if that doesn’t work, delete any files in
the ...\Program Files\BERNINA\Embroidery
Software 8\RECOVER folder.
• If BERNINA Embroidery Software still will
not start, use MS Windows® Explorer to
copy the default ...\BIN\defaults.dfl file to the
...\RES folder, overriding the corrupt
defaults.dfl file. This will reset BERNINA
Embroidery Software to ‘new installation’.
Other exception setting violations
Problem

An ‘Exception Access Violation’ error
message appears when zooming, using
lettering, printing or scanning, saving designs,
or viewing the Color Film.

Cause

This problem generally relates to the display
adapter driver and/or the display adapter itself.

Suggestion Make sure you have the latest display drivers
for your display adaptor. Go the
manufacturer’s website.

Reverting to factory settings
If you have made changes to the default settings in
your software and you want to revert to factory
settings, use the Revert utility.
To revert to factory settings

1 Exit BERNINA Embroidery Software.
2 Select the Revert utility from the BERNINA

Resolving Exception Access Violation
errors
The error message ‘Exception Access Violation’ can
appear when zooming, using lettering, printing or
scanning, saving designs, or viewing the Color Film.
This problem generally relates to the display adapter

Embroidery Software program group.

Run Revert
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The Revert to Factory Settings dialog opens.

3 Select the items you want restored to factory
defaults.
Note Reverting to the original settings removes
any changes you have made to styles, templates
and hardware settings.

4 Click OK.
The selected items are restored to factory settings.
Note There is no confirmation message.

BERNINA® Embroidery Software : Reference Manual

362

APPENDIX B
EMBROIDERY FONTS
The table below includes all fonts that are standard with your BERNINA
Embroidery Software. Categories include:
 3D fonts
 Appliqué fonts
 Block fonts
 Cyrillic fonts
 Fancy fonts
 Hebrew fonts
 Japanese fonts
 Monogram fonts
 Outline fonts
 Run stitch fonts
 Script fonts
 Serif fonts
 Small fonts
 Special fonts

Minimum and maximum sizes
For the best results when stitching, do not exceed the maximum or minimum
recommended sizes. Note, however, that recommended heights refer to UPPER
CASE letters. Most embroidery alphabets are digitized from an original
TrueType Font (TTF), some of which have lower-case letters – e.g. a and c –
which are about 70% the height of a capital letter. As a result, these letters
may be too small to embroider neatly at minimum sizes. You may need to
increase the size of the lower-case characters to suit the embroidery. See also
Adding lettering to embroidery designs.

TrueType Font
Embroidery Letters
Special characters
You can create special characters in each font by holding down the Alt key on
your keyboard and typing 0 (zero), its code, using the numbers on the keypad.

BERNINA® Embroidery Software : Reference Manual

363

For example, to type ê with the code 234, type Alt+0234. The accented letter
will appear when you release the Alt key. See also Adding special characters.
Note Not all characters are available in all fonts.
Join method
The lettering stitch method is preset to give the best results for each alphabet.
Options include:
Join

Purpose

Bottom join

BJ

Letters are joined along the baseline. Use it when stitching on towelling – joins
are hidden in the pile.

Closest join

CJ

Letters are joined at the closest point. Use it to minimize trims.

As digitized

AD Letters are joined the same way they were originally digitized. Use it with
alphabets combining different fill stitch types or special effects.

Font table
Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

3D Brush Script

0.8

20

2.4

60

AD

3D Comica

0.8

20

2.0

50

AD

3D Commonwealth

0.8

20

2.0

50

AD

3D Drummon

0.8

20

2.4

60

AD

3D Emphatic

0.8

20

3.2

80

AD

3D Futurism

0.8

20

1.2

30

AD

3D fonts
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

3D Futuro

0.8

20

2.0

50

AD

Impact 3D

0.8

20

2.4

60

AD

3D London

0.8

20

2.4

60

AD

3D Monoglyceride

0.8

20

2.4

60

AD

3D Sofachrome

5.5

14

0.8

20

AD

Varsity
Appliqué-CAPS

1.0

25

3.2

80

AD

Easy Appliqué

1.2

30

4.0

100

AD

Fortress

0.25

6

1.6

40

BJ

Lazer

0.24

6

2.0

50

CJ

Appliqué fonts

Block fonts
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

London

0.3

8

2.0

50

BJ

Microgramma

0.25

6

2.4

60

CJ

Monoglyceride

0.4

10

2.4

60

CJ

Monoglyceride Bold

0.4

10

2.4

60

CJ

Prestige

0.2

6

2.3

60

CJ

Rounded Block

0.8

20

1.4

35

CJ

Scanner

0.3

7

1.6

40

BJ

Sofachrome

0.6

15

1.2

30

CJ

Swiss Block

0.25

6

2.4

60

BJ

Technical Block

0.3

8

2.0

50

BJ
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Varsity Block-CAPS

0.2

6

1.3

35

BJ

Veranda

0.25

6

2.4

60

CJ

Greek

0.3

8

2.0

50

CJ

Greek Ionic

0.4

10

2.4

60

CJ

Jikharev

0.3

8

2.0

50

CJ

Russian Textbook

0.3

8

1.8

45

CJ

Alice

0.3

8

2.0

50

CJ

Bamboo

0.3

8

1.6

40

BJ

Castle

0.25

6

2.0

50

CJ

Cyrillic fonts

Fancy fonts
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Childs Play

0.5

13

1.2

30

BJ

Christopher

0.3

8

1.2

30

BJ

Croissant

0.25

6

2.0

50

CJ

Craft

0.4

10

2.0

50

BJ

Drifter

0.25

6

1.6

40

BJ

Erica

0.6

15

2.2

55

CJ

Felt Tip

0.4

10

2.0

50

CJ

Flourish Light

0.6

15

2.0

50

AD

Guinevere

0.5

13

2.0

50

BJ
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Ketchikan

0.3

8

1.2

30

CJ

Kindergarten Block

0.4

10

3.6

90

CJ

Mandarin

0.3

8

2.0

50

CJ

Olde English

0.4

10

2.0

50

CJ

Tiffany

0.3

7

1.4

35

BJ

Victoria

0.3

7

1.0

25

CJ

HEBREW2

0.3

8

1.5

40

CJ

Hebrew David

0.3

7

1.5

40

BJ

0.5

13

2.0

50

BJ

Hebrew fonts

Japanese fonts

Hiragana
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Katakana

0.5

13

2.0

50

BJ

Heisei Kaisho

0.32

8

2.7

70

CJ

Heisei Gyosho

0.32

8

2.7

70

CJ

Diamond2

0.7

18

4.0

100

BJ

Diamond3

0.7

18

4.0

100

BJ

Broadsheet

1.2

30

3.0

75

BJ

Dexter Normal

0.4

9

2.0

50

CJ

Neon-CAPS

0.7

18

3.0

75

BJ

Monogram fonts

Outline fonts
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Tabloid

1.2

30

3.0

75

BJ

Turncoat

0.7

20

3.1

80

BJ

Quilting Text

0.2

5

1.0

25

AD

Run Cardigan

0.2

5

0.5

12

CJ

Run Freehand

0.2

5

0.5

12

CJ

Run Liberty

0.2

5

0.5

12

CJ

Run Murray Hill

0.2

5

0.5

12

CJ

0.4

10

2.0

50

CJ

Run stitch fonts

Script fonts

Abby Script
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Anniversary

0.5

12

4.0

100

CJ

Cursive

0.3

7

2.4

60

CJ

Eliza

0.7

20

3.1

80

CJ

Empress

0.5

13

2.4

60

CJ

Energy

0.3

8

2.4

60

CJ

Hand of Sean

0.3

8

2.0

50

CJ

Island

0.3

8

2.0

50

CJ

Lisa

0.5

12

2.0

75

CJ

Meegan

0.6

15

2.1

55

CJ

Nightowl

0.25

6

2.0

50

CJ
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Racer

0.3

8

1.4

35

CJ

Speedy

0.3

8

1.2

30

CJ

Zurich

0.3

8

2.3

60

BJ

Blackboard

0.3

8

2.0

50

BJ

Bodoni

0.3

7

2.0

50

CJ

Centurion

0.5

13

2.4

60

CJ

Chicago

0.25

6

3.0

75

CJ

King Charles

0.3

8

2.0

50

BJ

Medley

0.3

7

1.6

40

BJ

Times Small

0.3

7

2.0

50

CJ

Serif fonts
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Recommended sizes
Font

Sample

Min

Max

Join
method

in.

mm

in.

mm

Helvetica Small

0.2

4

0.3

7

CJ

Micro Block

0.2

4

0.3

8

CJ

Roman-Small

0.2

4

0.25

6

AD

Sm HighTower

0.2

4

0.25

6

CJ

Border-CAPS

0.5

13

1.5

38

AD

Creative Cross

1.2

30

4.0

100

AD

Flair Script

0.75

10

3.2

80

CJ

Secret Garden CAPS

1.5

38

3.5

90

AD

Small fonts

Special fonts

BERNINA® Embroidery Software : Reference Manual

374

Recommended sizes
Font

Phoebe Curls

Sample

Min

Max

in.

mm

in.

mm

0.6

15

1.4

35

Join
method

AD
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Appendix C : Fancy Fill Samples

APPENDIX C
FANCY FILL SAMPLES
The Fancy fill patterns shown in this appendix are a sample of those included with
your BERNINA Embroidery Software program. For actual Fancy fill patterns and
instructions on how to use them, see Creating fancy fills.
ID & Angle
001 Diamond
(90)

002 Emerald
(90)

003 Ruby (90)

Fancy Fill

ID & Angle

Fancy Fill

012 Brick3 (45)

013 BabyBlock
(120)

014 3DBlock (0)

004 Sapphire
(90)

015 Roman (90)

005 Topaz (90)

016 Capri (45)

006 Jewel (90)

017 Frame (45)

007 Brilliant
(90)

018 Quilt1 (45)

008 Square (45)

019 Quilt2 (45)

009 Squarecut
(45)

020 Quilt3 (45)

010 Brick1 (45)

021 Circle (90)

011 Brick2 (45)

022 Wattle (90)
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ID & Angle

Fancy Fill

ID & Angle

023 Oval (90)

038 Honeycomb (90)

024 Whirlpool
(90)

039 Beeswax
(30)

025 Dance (90)

040 Wave (90)

026 Heart (90)

041 Dunes (0)

027 Heart2 (90)

042 Chevron
(90)

028 Valentine
(90)

043 Chevron2
(90)

029 Scallop
(90)

044 Chevron3
(90)

030 Shell (90)

045 Wedge (90)

031 Smile (90)

046 Crazy (90)

032 Flower (90)

047 Arrow (20)

033 Ribbon (30)

048 Weave (48)

034 Sunny (90)

049 Weave2
(90)

035 Shine (90)

050 Stream (90)

036 Star (90)

051 Bowtie (0)

037 Stardust
(90)

052 Chain (90)

Fancy Fill
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ID & Angle

Fancy Fill

ID & Angle

053 Glitter (90)

068 Letter H
(45)

054 Cross (45)

069 Letter I (45)

055 Doublecross (90)

070 Letter J
(45)

056 Galaxy (90)

071 Letter K
(30)

057 Ring (90)

072 Letter L
(45)

058 Ramble
(90)

073 Letter M
(45)

059 Florastar
(90)

074 Letter N
(45)

060 Stripes (90)

075 Letter O
(30)

061 Letter A
(90)

076 Letter P
(45)

062 Letter B
(45)

077 Letter Q
(30)

063 Letter C
(90)

078 Letter R
(45)

064 Letter D
(45)

079 Letter S
(45)

065 Letter E
(45)

066 Letter F
(45)

067 Letter G
(45)

Fancy Fill

080 Letter T
(45)
081 Letter U
(45)
082 Letter V
(45)
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Appendix C : Fancy Fill Samples

ID & Angle

Fancy Fill

ID & Angle

083 Letter W
(45)

098 Knuckled
frame (45)

084 Letter X
(90)

099 Tile (0)

085 Letter Y
(30)

100 Alarm Tile
(83)

086 Letter Z
(30)

101 Turtle-back
(79)

087 Paver (90)

102 Stepped
Wave (45)

088 Picasso
(135)

103 Crayon (0)

089 Ziggy (0)

104 Diamond
Inlay (0)

090 Spirali (90)

105 Corduroy
(0)

091 Manchu
(45)

106 Diamond
Punch (0)

092 Grilles (45)

107 Inlay Print
(0)

093 Wooden
Lattice (82)

094 Han Line
(45)

095 Dart (10)

096 T-frame
(45)

097 Double-arm (87)

Fancy Fill

108 Snowflake
(0)

109 Inlay Maze
(45)

110 Quilt Diamond 1 (0)

111 Quilt Diamond 2 (0)

112 Quilt Diamond 3 (0)
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ID & Angle

Fancy Fill

ID & Angle

113 Zig-Zag
Inlay (0)

128 Star (18)

114 Shell Inlay
(0)

129 Web (0)

115 Music 1 (0)

130 Tear Drop
(0)

116 Music 2 (0)

131 2-way
zig-zag (87)

117 Four
Square (45)

132 Quilt
Square 1 (45)

118 Symbol 1
(45)

133 Quilt
Square 2 (0)

119 Symbol 2
(50)

134 Quilt
Square 3 (0)

120 Symbol 3
(82)

135 Quilt
Square 4 (0)

121 Wave 2 (0)

136 Quilt
Square 5 (45)

122 Wave 3 (0)

137 Quilt
Square 6 (18)

123 Honeycomb 2 (45)

138 Cloud Band
1 (25)

124 Rope (0)

139 Cloud
Bands 2 (0)

125 Tree (142)

140 Cloud
Bands 3 (0)

126 Wings
(135)

141 Arrow 2 (0)

127 Leaf (0)

142 Rusty Ice
(0)

Fancy Fill
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Appendix C : Fancy Fill Samples

ID & Angle

Fancy Fill

ID & Angle

143 Ice Rays
(0)

159 Ellipse (0)

144 Dynasty (0)

160 Flame (90)

145 Windwheel
(0)

161 Jem (90)

146 Tea Tray
(0)

162 Leaf (0)

147 Cash Bars
(45)

163 Melody (0)

148 Chengtu (0)

164 Metal (0)

149 Chihli (86)

165 Passage
(0)

150 Ming (135)

166 Piccolo (0)

151 Arrowhead
(89)

167 Roma (0)

152 Basket2
(40)

168 Rope (10)

153 Bird (90)

169 Seville (0)

154 Blocks2 (0)

170 Star5 (10)

155 Chain (90)

172 Tick (0)

157 Circle (0)

173 Tile1 (135)

158 Cube (48)

174 Tile3 (0)

Fancy Fill
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ID & Angle

Fancy Fill

175 Vine (0)

176 Wave2 (90)

177 Wave3 (90)

178 Whirl (90)

179 Wild (48)

180 Xmastree
(48)
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Appendix D : Step Fill Samples

APPENDIX D
STEP FILL SAMPLES
The Step fill patterns shown in this appendix are a sample of those included with
your BERNINA® Embroidery Software program. For actual Step fills and
instructions on how to use them, see Creating step stitch fills.
Note Make sure you apply the correct stitch angle to each Step fill. The following
samples have been digitized with a stitch angle of 0°. Experiment with different
stitch angles to get new effects.
No.

Stitch sample

Preview

No.

1

8

2

9

3

10

4

11

5

12

6

13

7

14

Stitch sample

Preview
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No.

Stitch sample

Preview

No.

15

26

16

27

17

28

18

29

19

30

Stitch sample

Preview

20

21

22

23

24

25
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Appendix E : Pattern Stamp, Run & Fill Samples

APPENDIX E
PATTERN STAMP, RUN & FILL SAMPLES
Below are samples of the Pattern Stamps, Runs and Fills included with your
BERNINA Embroidery Software. See also Embroidery Patterns.

Pattern set: BerninaV5
Name

Pattern

Name

Pattern

NP005-11

NP005-01
NP005-02

NP005-12

NP005-03
NP005-13
NP005-04

NP005-05

NP005-14

NP005-06

NP005-15

NP005-07

NP005-16

NP005-08

NP005-17

NP005-09

NP005-10

NP005-18

NP005-19
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Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

Name

Pattern

NP005-20
NP005-35
NP005-21
NP005-36
NP005-22

NP005-23

NP005-37

NP005-24
NP005-38

NP005-25
NP005-39
NP005-26

NP005-27

NP005-40

NP005-28
NP005-41
NP005-29

NP005-42
NP005-30

NP005-43
NP005-31

NP005-32

NP005-44

NP005-33

NP005-45

NP005-34
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Name

Pattern

Name

Pattern

929
NP005-46

Pattern set: Corners
NP005-47

Name

Pattern

Cnr001
NP005-48

Cnr002

NP005-49

Cnr003

NP005-50

Pattern set: Children
Name

Pattern

Cnr004

901

905

Cnr005

907
Cnr006
909

910
Cnr007
911

914

BERNINA® Embroidery Software : Reference Manual

387

Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

Name

Cnr008

Cnr018

Cnr009

Cnr019

Cnr010

Pattern

Cnr020

Cnr011

Pattern set: Cross
Name

Pattern

Cnr012
301

302
Cnr013
303

Cnr014

305

309
Cnr015
311

313
Cnr016
b301

Cnr017

b302

BERNINA® Embroidery Software : Reference Manual

388

Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

b303

Name

Pattern

614

618
b304
623
b305

629

b306

637

641
b307
644
b308
648
b309
653
b310

Pattern set: Heirloom
Pattern set: Embellishment
Name
Name

Pattern

Pattern
705

601

706
605
709
608

610

710

711

717
612
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Appendix E : Pattern Stamp, Run & Fill Samples

Name
718

719

Pattern

Pattern set: Home Dec
Name

401

724

402

726

403

728

732

Pattern

405

406

733
407
738

409

411
a701
412
a702
413
a703
414
a704
415
a705
416
a706
417

422
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Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

Name

Pattern

424
a408
425
a409
426

Pattern set: Misc
427
Name

Pattern

429
10
430
11
431
12
a401
13

a402

21

29
a403
Star
a404
3wave

a405
Heart

a406
Wedge
a407
Blanket
Feather
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Name

Pattern

Name

Pattern

Pinstit

Pattern set: Monogram Ornaments
Name

M006a

Pattern
M006b

M006a pattern oriented horizontally

M001a
M007a

M001b

M001a pattern oriented horizontally
and mirrored
M008a
M008b

M002a

M002b

M02a pattern oriented horizontally

M009a

M009b

M003a

M008a pattern oriented vertically

M009a pattern oriented horizontally

M010a

M004a
M010b

M004b

M004a pattern oriented horizontally

M005a

M005b

M011a

M011b

M005a pattern oriented horizontally
and mirrored

M010a pattern oriented horizontally

M011a pattern oriented horizontally

M012a

M012b

M012a pattern oriented horizontally
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Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

M013a pattern oriented horizontally

M014a

M014b

M014a pattern oriented vertically and
mirrored

M020a pattern oriented horizontally

M021b

M021a pattern oriented horizontally

M022a

M015a pattern oriented horizontally

M022b

M022a pattern oriented diagonally

M023a

M016a

M016b

M020b

M021a

M015a

M015b

Pattern

M020a

M013a

M013b

Name

M016a pattern oriented horizontally

M023b

M023a pattern oriented horizontally

M017a
M024a

M018a

M018b

M018a pattern oriented vertically

M024a pattern oriented diagonally

M024c

M024a pattern oriented horizontally

M025a

M019a

M019b

M024b

M019a pattern oriented horizontally

M025b

M025a pattern oriented horizontally
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Name

Pattern

Pattern

M033a

M026a

M026b

Name

M026a pattern oriented horizontally

M033b

M033a pattern oriented horizontally

M034a
M027a

M027b

M034b

M034a pattern oriented vertically

M027a pattern oriented vertically
M035a

M028a

M028b

M028a pattern oriented diagonally

M035b

M035a pattern oriented horizontally

M029a
M036a
M029b

M029a pattern oriented horizontally
M036b

M036a pattern oriented horizontally

M030a
M037a
M030b

M030a pattern oriented horizontally
M037b

M037a pattern oriented horizontally

M031a
M038a
M031b

M031a pattern oriented horizontally
M038b

M038a pattern oriented horizontally

M032a

M032b

M032a pattern oriented horizontally

BERNINA® Embroidery Software : Reference Manual

394

Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

M039a pattern oriented horizontally

M040a pattern oriented horizontally

M045a pattern oriented horizontally

M046b

M046a pattern oriented horizontally

M047a

M041a

M041b

M045b

M046a

M040a

M040b

Pattern

M045a

M039a

M039b

Name

M041a pattern oriented horizontally

M047b

M047a pattern oriented horizontally

M042a
M048a
M042b

M042a pattern oriented vertically

M042c

M042a pattern oriented diagonally
M048b

M048a pattern oriented horizontally

M043a
M049a

M043b
M049b
M043c

M049a pattern oriented horizontally

M043a pattern oriented horizontally
M050a

M044a

M044b

M044a pattern oriented vertically

M050b

M050a pattern oriented horizontally

M051a
M051b

M051a pattern oriented diagonally
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Name

Pattern

M052a

Name

Pattern

M063a

M053a
M064a
M054a

M064b

M064a pattern oriented horizontally

M055a
M065a
M055b

M055a pattern oriented vertically
M066a

M056a
M066b
M067a

M057a

M067b
M057b

M066a pattern oriented horizontally

M067a pattern oriented vertically

M057a pattern oriented diagonally
and mirrored
M068a

M058a

M069a
M059a
M069b
M059b

M069a pattern oriented vertically

M059a pattern oriented horizontally
M070a

M060a

M071a
M061a
M071b
M061b

M071a pattern oriented vertically

M061a pattern oriented horizontally

M062a
M062b

M062a pattern oriented horizontally
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Name

Pattern

Name

Pattern

M074g

M075a
M072a
M075b

M072b

M072a pattern oriented horizontally

M072c

M072a pattern oriented diagonally

M073a

M075c

M075b pattern mirrored

M075d

M075b pattern oriented vertically

M076a
M076b

M073b

M073a pattern oriented vertically

M073c

M073a pattern bigger sized

M076a pattern oriented vertically

M077a
M077b

M077a pattern oriented vertically

M073d
M073e

M073d pattern oriented vertically

M073f

M073g

M073f pattern oriented horizontally

M073h

M073i

M078a

M078b

M078a pattern smaller sized

M078c

M078b pattern oriented vertically

M079a

M079b

M079a pattern smaller sized

M079c

M079b pattern oriented vertically

M073h pattern oriented horizontally
M080a

M073j
M073k

M073j pattern oriented diagonally

M073l

M073j pattern oriented vertically

M080b

M080a pattern smaller sized

M080c

M080b pattern oriented vertically

M074a
M081a
M074b

M074a pattern oriented horizontally

M081b

M081a pattern smaller sized

M081c

M081b pattern oriented vertically

M082a

M074a

M074a pattern oriented vertically

M082b

M082a pattern oriented vertically
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Name

Pattern

M083a

M083b

Name

Pattern

M090a
M083a pattern oriented vertically
M090b

M090a pattern oriented horizontally

M090c

M090a pattern oriented diagonally

M084a
M090d

M084b

M084a pattern oriented vertically

M090e

M090d pattern oriented vertically

M091a
M085a

M085b

M085a pattern smaller sized

M085c

M085b pattern oriented vertically

M091a pattern oriented vertically

M091c

M091a pattern oriented diagonally

M092a

M092b

M086a
M086b

M091b

M092a pattern oriented vertically

M086a pattern oriented vertically
M092c

M087a
M087b

M087a pattern smaller sized

M092d

M092e pattern mirrored vertically and
horizontally

M087c

M087b pattern oriented vertically

M092e

M092e pattern mirrored horizontally

M093a
M088a
M093b
M088b

M088a pattern oriented horizontally

M088c

M088a pattern oriented diagonally

M093a pattern oriented vertically

M093c
M093d

M093c pattern oriented diagonally

M093e

M093c pattern oriented vertically

M089a
M093f
M089b

M088a pattern oriented vertically
M094a

M089c
M094b

M094a pattern oriented vertically

M094c

M094a pattern oriented diagonally
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Name

Pattern

Name

Pattern

M095a
M0100a

M095b
M0100b
M096a
M096b

M0100a pattern bigger sized

Pattern set: NP004a
M096a pattern oriented vertically
Name

Pattern

M096c
K0001a

M096d

K0002a

M097a

K0003a
M097b

M097a pattern oriented vertically

K0004a

M097c

M097d

M097c pattern oriented horizontally

M097e

M097c pattern oriented diagonally

M098a

M098b

K0006a

M098a pattern oriented vertically

K0007a

K0008a

M098c

M098d

K0005a

M098c pattern oriented vertically
K0009a

M099a

M099b

M099a pattern oriented right

M099c

M099a pattern oriented downwards

M099d

M099a pattern oriented left

M099e

M099a pattern oriented diagonally

K0010a

K0011a

K0012a
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Name
K0013a

K0014a

K0015a
K0016a

K0017a

Pattern

Name

Pattern

A200606

A200609

A200615

A200749

Pattern set: NP005a

K0018a

Name

K0019a

151a

Pattern

K0020a
151b
K0021a
K0022a

152a

K0023a

437a

K0024a

660a

663a
K0025a
K0026a

701a

K0027a
1023a
A200026

A200150

1024a

A200446
1026a
A200602

BERNINA® Embroidery Software : Reference Manual

400

Appendix E : Pattern Stamp, Run & Fill Samples

Name

Pattern

Name

Pattern

129

1027a

135

Pattern set: Nature
Name
101

102

Pattern

136

Pattern set: Quilting
Name

Pattern

327
103
328
106

111

112

113

114

330

332

333

334

336

115
337

117
338
118
339
119
340
124

342
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Name
343

Pattern

Pattern set: Satin-Quilt
Name

Pattern

501
a301

503
a302

a303

506

a304
507
a305
a306
508
a307

509
a308

a309

511

a310
512

a311
a312

513

a313

a314

514

a315
515
a316
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Pattern set: Carving Stamps
Name

Name

Pattern

Pattern
A

0

B
1

C
2

D
3

E
4

F
5

G
6

H
7

I
8

J
9

K
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Name

Pattern

Name

L

V

M

W

N

X

O

Y

P

Z

Pattern

Cylinder
Q

Triangle
R

Ring_Half
S

Trapezoid
T

Arrow_3_Way
U

Arrow_4_Way
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Name

Pattern

Name

Arrow_Block

Flame

Ring_Ellipse

Heart

Parallelogram

Banned

Page

Smiley

Tear

Arrow_Double
_Right_Angle

Arrow_4_Way_
Block

Polygon

Pattern

Arrow_Right_
Angle

Arrow_Double
_Block

Arrow

Cross

Flash
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APPENDIX F
CRAFT STITCH PATTERN SAMPLES
The Craft Stitch patterns shown in this appendix are a sample of those included
with your BERNINA Embroidery Software program. For actual Craft Stitches and
instructions on how to use them, see Creating craft stitches.

Blackwork patterns
Blackwork gets its name from the black silk thread
traditionally used in this form of embroidery.
Blackwork patterns can be used either as borders, as
fills, or even pattern stamps. The most common
blackwork fills employ simple stitches to create
complex scrolling or geometric patterns. See
Blackwork for details.

ID

Sample

B0005b

B0006a
ID

Sample

B0001a
B0007a

B0002a
B0008a

B0003a
B0009a

B0004a

B0010a
B0005a
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ID

Sample

ID

Sample

B0011a

B0022a

B0012a

B0023a

B0013a
B0024a
B0013b
B0025a
B0014a

B0026a
B0015a

B0027a
B0016a

B0017a

B0028a

B0018a
B0029a

B0019a

B0030a
B0020a

B0021a
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ID

Sample

ID

Sample

B0041a
B0031a

B0042a
B0032a
B0043a

B0033a
B0044a

B0034a
B0045a

B0035a
B0046a

B0036a
B0047a

B0037a
B0048a

B0038a
B0048b

B0039a

B0049a

B0040a
B0050a
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ID

Sample

ID

Sample

B0051a

B0062a

B0052a

B0063a

B0053a

B0054a

B0055a

B0056a

B0064a

B0065a

B0066a

B0067a

B0057a

B0068a
B0058a

B0069a
B0059a

B0070a
B0060a

B0061a

B0071a
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ID

B0072a

Sample

ID

Sample

B0075a

Candlewicking patterns
B0073a
Candlewicking is a traditional white-on-white
embroidery technique, usually done on white linen or
cotton fabric with heavy cotton threads.
Candlewicking patterns can be used either as borders,
as fills, or even pattern stamps. See Candlewicking
for details.
B0074a
ID

Pattern

Knot-3mm
B0075a

Colonial4mm
B0075a

Colonial4.5mm
B0075a

Half Knot

B0075a

Lacework patterns

B0075a

Lacework stitch consists of an open square trellis-like
pattern which gives objects a lacey look. Lacework
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can only be applied to filled objects with a single stitch
angle. See Lacework for details.
ID

Pattern

L0001a

L0002a

L0003a

L0004a

L0005a
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Active window: The active
window is one to which the next
command or action will apply. If a
window is ‘active’, its title bar
changes color to differentiate it
visually from other open windows.
Anchor point: A fixed point used
when rotating, scaling, skewing or
mirroring a design.
Anti-aliasing: A software
technique similar to dithering
which is used to soften hard
outlines where color blocks
intersect. It produces smoother
outlines by ‘blurring’ the pixels
where colors join.
Appliqué: Decoration or
trimming cut from one piece of
fabric and stitched to another to
add dimension and texture.
Designs with appliqué can be more
economical than embroidery alone,
if appliqué occupies a significant
amount of the design, thereby
lowering stitch count.
Appliqué cutter: A device that
can cut fabric along a line,
somewhat like old pen plotters. It
requires a vector file as input. In
MS Windows they can be set up as
a type of printer device.
ARQ: BERNINA Quilter format.
ART: BERNINA Embroidery
Software format.
Artistic View: A realistic, ‘three
dimensional’ preview of a stitched
embroidery design.
Artwork: Bitmap or vector
graphic used as a backdrop for
digitizing. See also Bitmap image
and Vector graphic.
Image Preparation: See Image
preparation.
ARX: BERNINA Embroidery
Software Cross Stitch format.
Auto Appliqué: Auto Appliqué is
an embroidery object associated
with an appliqué which provides

automatic stitching to place it, tack
it down, and cover its edges.

front fabric will be cut away to
reveal the fabric beneath it.

Auto Center: Auto Center
automatically centers the start and
end points of a design.

Backdrop: An electronic image
used as a guide for digitizing
designs on-screen. Two types are
used – vector or bitmap. Insert
them from various file sources, or
copy and paste them via the
Windows clipboard.

Automatic digitizing: Digitize
complete images automatically.
Auto-Digitize automatically
converts artwork to embroidery
objects and generates stitches.
Auto Jump: Preserves long
stitches in an object by splitting
them into a series of jumps. This
prevents the machine from
inserting unwanted needle
penetrations when the maximum
frame movement is exceeded.

Background: BERNINA
Embroidery Software lets you
change the background color of the
design window to match the color
of your fabric. Or you can select a
background fabric for more
realistic previews and
presentations. The background is
saved with the colorway.

Auto Scroll: The Auto Scroll
feature automatically scrolls the
screen while you are digitizing.

Backing: Also known as
‘stabilizers’, backings are woven or
non-woven materials placed
beneath the item or fabric being
Auto-sequencing: The
embroidered for stability and
Auto-sequencing feature lets you
support. The more stitches a
digitize like objects – e.g. the
design
has, the heavier the backing
fingers of a hand – without having
required. Backings are available in
to think about the most efficient
various weights and types such as
stitching sequence and joins.
cut-away, tear-away and
Auto Spacing: Auto Spacing only wash-away (soluble). Professional
affects Satin stitch. It adjusts stitch embroiderers use tear-away
spacing according to column width. stabilizers for woven fabrics and
Automatic color change: Ability cut-away stabilizers for knits. See
Topping.
of multi-needle embroidery
machine to follow a command to
Backstitch: Backstitch is an input
change to a specified needle with a method which can be used for
different thread color.
delicate outlines. This stitch follows
Automatic pull compensation:
Embroidery stitches pull the fabric
inwards where the needle
penetrates. This can cause the
fabric to pucker, and gaps to
appear in the embroidery.
Automatic pull compensation
counters this effect by
‘overstitching’ outlines of filled
shapes on the sides where the
needle penetrates. This means the
design can be optimized for
different fabrics. See Pull
compensation.
Back appliqué: A fabric piece
used behind a design where the

intricate curves well. It is also is
the term used for every second row
of stitches in a Tatami fill. See also
Standard backstitch, Borderline
backstitch, and Diagonal
backstitch.
Backup: The copying of files onto
floppy disk or other storage media
in order to duplicate and secure
data. Usually two copies are made
and kept separately.
Baseline: The notional line on
which the letters of an font sit.
Only descenders extend below it.
Baselines determine the shape of
lettering objects in a design. Place
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it on straight horizontal or vertical Most effective for simple designs
lines, curve it around a circle or
such as leaves and vines, or special
arc, or digitize your own baselines. effects with threads too heavy to
be threaded through the needle.
Baseline Angle: The baseline
angle determines the absolute
Bonding: Permanently joining
angle of the baseline relative to the two fabrics together with a bonding
horizontal axis. You use it to align agent. Heat sealing.
letters to a significant part of the
Border: Single closed-curve
design.
object which can be optionally
Basting stitch: A long even
added to a monogram. Also, a strip
stitch (generally between 6 and 12 of fabric that is joined to an inner
mm in length), that is meant to be quilt to enhance it.
removed after use. It can be used
Bounding box: The dotted
to fix the fabric to the stabilizer,
rectangle that appears when you
identify the extents of the design,
select a range of items.
or be used as registration marks.
Candlewicking: A traditional
Batting: A layer of padded
white-on-white embroidery
material between the front and
technique, usually done on white
back fabric to add thickness and
linen or cotton fabric with heavy
substance.
cotton threads.
Bitmap: An electronic image
Cascade: A way of arranging
made up of dots or ‘pixels’, in
open windows on the desktop so
contrast to vector ‘outlines’.
that they overlap each other, with
Typically created in paint
the title bar of each window
programs, bitmaps have file
remaining visible.
extensions such as BMP, JPG, GIF,
TIF and PCX. When enlarged or
Checkbox: A small square box
scaled down, vector graphics
that appears in a dialog box and
preserve image quality while
that can be selected or cleared.
bitmap images generally cause
When selected, a tick or a cross
problems of pixilation and image
appears. A checkbox represents an
degradation. See also Pixel.
option that you can set.
Blackwork: Blackwork gets its
name from the black silk thread
traditionally used in this form of
embroidery. It can be used to
decorate articles such as hankies,
table napkins, table clothes, and
doilies.
Blanket stitch: Widely used for
tacking down appliqués as a
decorative border. The stitches
form a comb pattern.
Block: The basic unit of a quilt
top.
BMP: Windows bitmap image
format. See also Bitmap.
Bobbin: Spool or reel that holds
the bobbin thread, which helps
form stitches on the underside of
the fabric.
Bobbin embroidery: Designs
worked with the fabric hooped
facedown and the specialty thread
or ribbon wound onto the bobbin.

created are known as Closed
Object objects.
Color depth: Color depth, also
called ‘pixel depth’, refers to the
amount of color information
available to each pixel in an image.
An image with a color depth of
1-bit can display only two colors.
As the color depth increases, more
colors are available – 16 Colors (4
bit), 256 Colors (8 bit), High Color
(16 bit), True Color (24 bit).
Color palette: The color palette
contains a selection of thread
colors tailored for each design. This
color scheme, or ‘colorway’,
represents the actual thread colors
in which a design will be stitched.
See also Thread chart.
Color Reduction: See Image
preparation for details.
Colorways: Colorways are
multiple color schemes for the
same design. They are made up of
colors defined in ‘color books’
which may be created in Wilcom
BERNINA Embroidery Software or
similar design program, or may be
selected from a patent color
system such as Chromatone or
Pantone.

Column: Narrow, long, curving
shape.
Click: Press and release the left
mouse button. See also Right-click.
COM port: A standard serial port
used as a connection point for
Click-and-drag: Click to select,
peripherals. Other ports may be
hold down the left mouse button,
present if the appropriate internal
move the cursor and release.
option cards have been installed.
Clipboard: A temporary storage
The computer must be informed
area in PC memory for what was
which port is being used by which
last cut or copied. Images on the
peripheral – e.g. COM1, COM2, etc.
clipboard can be pasted into
Command: An instruction issued
designs any number of times.
to the software in order to carry
Close button: Used to close a
out an action. It may be as simple
window or an application. In MS
as ‘paste an object’ or as complex
Windows, it appears as a small box as ‘regenerate stitches’. It is
with an ‘X’ in it at the top-right of
usually activated via a menu item,
the title bar.
toolbar icon, or command button in
a dialog.
Closed Object: Input method,
used to digitize large and complex Command button: A button in a
shapes. Allows holes to be
dialog which executes or cancels
designated at the same time the
the selected action. Two common
object outline is digitized. The
command buttons are Cancel and
object is thus digitized as one fill
OK.
area, instead of being broken down
into multiple sections. Objects so

BERNINA® Embroidery Software : Reference Manual

413

Glossary
Condensed file: See Outline file
for details.
Configuration: The size and type
of computer hardware. Can also be
used to mean the options provided
with your software.
Confirmation message: A
message displayed by the software
asking you if you are sure you want
to proceed – e.g. when you want to
delete a design.
Connector stitches: Connector
stitches link objects in a design.
They can be run stitches or jumps.
You can use automatic settings to
generate connectors, trims and
tie-offs, or add them manually.
Connectors: Hardware devices to
connect cables to ports. If the
connection is male, the port is
female, and vice versa. The wiring
configuration of each device is
determined by its function.
Copy: To place a copy of a
selection onto the clipboard. See
also Duplicate.
Continuous embroidery: The
repeating of a single design in
order to create a large work piece
that is bigger than a single hoop.
The design may be repeated in X,
Y, or both axes.
Control points: Control points
are used to modify object shapes,
stitch angles and entry and exit
points. You can change the shape
of an object by moving, adding or
deleting control points on the
outline. For most objects, you can
also change control points from
corner points to curves.
Contour stitch: Contour is a
curved fill stitch type – stitches
follow the contours of a shape,
creating a curved, light and shade
effect. It only works on columnar
shapes. There are two types –
Standard and Spiral – both of
which can be applied to Input A,
Input B, Input C or Ring objects.
Standard Contour can also be
applied to Circle objects.
Copyright: A right granted by the
government or by international
agreement giving the owner the

exclusive privilege to publish and
sell artistic work during the life of
the creator plus 50 years.

an entire outline, and includes
corner detection to better
approximate the intended curve.

Corner points: In standard
digitizing, corner points indicate
where a curve changes direction.
The user digitizes a line segment
with two consecutive corner points.
The run and turning fill stitch
generation algorithms interpret
corner points as subdividing the
curve, and so always generate a
stitch penetration at corner points.

Custom designs: Designs
created by digitizing artwork or
manipulating existing patterns.

Cover stitch: Cover stitch is the
border around an appliqué shape.
You can control various settings
including cover stitch type – Satin
or Blanket – width, stitch spacing,
as well as the offset.
Conversion software: Programs
that read information, other than
from a card, and translate it from
one sewing machine format to
another.
Converter box: A converter box
acts like a translator from one
memory card format to another,
via computer. They translate
designs from memory cards in
other formats or from a hard drive,
disk, or CD and write the design to
a blank card.
CPU: Central Processing Unit.
Cross stitch: Two stitches that
cross at the center to form an X.
Laid in rows or within a box shape
to form geometric designs. Creates
a handmade appearance.
Current property settings:
Current property settings override
the template defaults. Unless you
deliberately change them, these
take the default values. You
generally change them to save
time when digitizing. For example,
you may preset Tatami stitch
spacing to use a specific density for
all new Tatami objects you create.
See also Object properties.
Curve smoothing: Curve
smoothing is used to filter out
‘mouse jaggies’ generated by
freehand techniques and to
convert the generated path into a
relatively smooth curve. Advanced
curve smoothing typically works on

Cut: An editing function. To
remove a selection from a design.
The cut selection is stored in
memory (on the ‘clipboard’) and
can be pasted into the same or
different design.
Cutting line: A second line of run
stitches that forms a guide when
trimming the fabric of an appliqué
patch.
Default object properties: See
Default values for details.
Default values: Pre-defined
settings which determine object
properties such as stitch spacing,
as well as certain system settings.
These are stored in the design
template. They are automatically
applied to any newly created
objects. They remain ‘current’
unless you override them with new
settings. See also Current property
settings.
Defects: See Stitching defects for
details.
Density: See Stitch density or
Thread density.
Design: A ‘design’ is a file in the
native embroidery format – e.g.
ART, JAN, ART – of embroidery
digitizing software. The design
source may be a machine format
design. The design contains
stitching information such as fabric
type in addition to stitched shapes.
Design card: Disk containing
computerized embroidery designs
read by the embroidery machine’s
computer.
Design elements: The
decorative design components that
make up a monogram (including
ornaments and borders).
Design file: See File for details.
Design layout template: The
design printed as outlines with
optional positioning markers,
grids, guides and design extents
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printed at 1:1 scale. When printed
for large work pieces indicates the
location and orientation of each
individual hoop.
Design object: See Object for
details.
Design properties: Designs
themselves have properties, some
of which can be modified, others
not. The most important design
property is its source – Native
Design, Imported Outlines,
Processed Stitches, or Imported
Stitches. Other properties include
the software version number, stitch
count, and so on. Colorways too
are properties of the whole design.
Design sequence: See Stitching
sequence for details.
Design source: While
embroidery files are broadly
classified as ‘outline’ (condensed)
or ‘stitch’ (expanded), BERNINA
Embroidery Software internally
tags files as belonging to one of
four types–Native Design,
Imported Outlines, Processed
Stitches, or Imported Stitches. See
also Design properties.
Design template: See Template
for details.
Design window: The design
window is where designs are
displayed for viewing and
modification.
Design worksheet: See
Worksheet for details.
Desktop: MS Windows
terminology for the screen
background on which program
icons are displayed.

why a command cannot be
completed.
Digitizing: Process of encoding a
design. Artwork is converted into a
series of ‘embroidery objects’ to be
read and manipulated by a
specialist CAD/CAM application.
Before outputting to embroidery
machine, it is converted into ‘stitch
data’.
Digitizing tool: Digitizing tools,
sometimes referred to as ‘input
methods’, are similar to drawing
tools except that the end result is
an embroidery object rather than a
vector object. Different digitizing
tools are suited to creating
different shapes or design
elements.

Download: The process of
transferring a copy of a file from a
remote computer or the internet to
a computer or other device such as
an embroidery machine.
Drag: An operation of the mouse.
Holding the (left) mouse button
while moving the mouse. Typically
used for moving something on the
screen.
Dropdown list : A single-line
dialog box control that opens to
display a list of choices.
Duplicate: When an object is
duplicated, it is not copied to the
clipboard. This leaves the clipboard
free for you to cut or copy other
objects.

Disk drive: Computers usually
have three types of disk drive: a
hard disk (or fixed disk) which
usually supports the mass storage
of information and applications, a
floppy disk drive, and a CD ROM
drive.

Editing: Changing aspects of a
design via a computerized editing
program. Most programs allow you
to scale designs up or down, edit
stitch-by-stitch or block-by-block,
merge lettering with the design,
move aspects of the design
around, combine designs and
insert or edit machine commands.

Display: A screen used to display
the output of a computer. Also
known as the monitor.

Elastic Lettering: Special effects
applied to lettering objects to make
them bulge, stretch or compress.

Dithering: A software technique
which combines existing colors in a
checkerboard arrangement of
pixels. It is typically used to
simulate colors that are missing
from an image palette. A type of
optical illusion created by placing
two pixels of different color next to
each other. The human eye
automatically resolves the two
colors into a third color.

Emblem: Embroidered design
with a finished edge, applied to a
garment after stitching, commonly
an insignia of identification. Also
known as a ‘crest’ or ‘patch’.

Disk: See Floppy disk for details.

Destination folder: The folder
(directory) where you intend to
copy or move one or more files.

Dongle: A security hardware
device required to run protected
software. Some are attached to a
parallel port, others to a USB port.

Detail: An outline, a border, a
pickout run, or a small area of the
design you want to be stitched out
last when using Auto-Digitize.

Dots Per Inch (DPI): A
measurement of screen or printer
resolution; the number of dots in a
line of 1".

Dialog: An on-screen box that
either requests or provides
information. Many dialogs present
options to choose among before a
command is carried out. Some
dialogs present warnings or explain

Double-click: Click the left
mouse button twice without
moving the mouse. Double-clicking
carries out actions such as opening
a program from an icon.

Embroidery: Decorative stitching
on fabric. Generally involves
non-lettering designs, but can also
include lettering and/or
monograms. Evidence of
embroidery exists during the reign
on Egyptian pharaohs, in the
writings of Homer and from the
Crusaders of the 12th century. Has
evolved from hand-work to manual
sewing machines and from
hand-looms and Schiffli machines
with hundreds of needles to
high-speed, computerized
multihead machines.
Embroidery object: See Object
for details.
Embroidery thread: See Thread
for details.
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Endless embroidery: See
Continuous embroidery for details.
EMF: Enhanced Metafile vector
graphic format.
Entry point: The entry point is
the point where the thread enters
the embroidery object. This should
coincide with the exit point of the
preceding object.
Exit: To leave a current window or
application.
Exit point: The exit point is the
point where thread leaves the
embroidery object. This should
coincide with the entry point of the
next object.
EXP: Stitch or ‘expanded’ file
format native to Melco machines.
Extension: See File extension for
details.
Fabric: Fabrics have many
properties, the main one being
elasticity or ‘fabric stretch’. Surface
texture, if present, is another
property that requires different
underlay types. The system can
automatically compensate for the
pull-push effect of different fabrics.
Push, warping, and shearing are
reduced by suitable underlay for
the stitch type and fabric.
Fabric stretch: Embroidery
stitches pull the fabric inwards
where the needle penetrates. This
can cause the fabric to pucker, and
gaps to appear in the embroidery.
Use automatic pull compensation
to counter this effect by
‘overstitching’ outlines of filled
shapes.
Facing: See Topping for details.
Factory settings: These are the
initial system settings as installed.
They are a standard known setting
that you can return to. Some
customers want to create custom
settings tailored to the exact fabric
they are using most frequently.
The ‘My Fabric’ settings are those
retained in the design and can be
saved to the template file.
Fancy Fill: A decorative fill stitch
which can be applied to various
object types where needle

penetrations form a tiled pattern.
Different preset patterns are
available for use.
File: A named collection of
specifically related information
stored on a disk. Designs that have
been saved are stored as files.
File extension: The dot and
three letters at the end of a
filename such as ‘.BMP’. The
extension identifies the file as a
certain type, readable by certain
applications.
Filename: The name of a file,
including the extension, e.g.
Cat.BMP.
Fill stitch: Series of running
stitches commonly used to cover
large areas. Different fill patterns
can be created by altering the
angle, length and repeat sequence
of the stitches. Also known as
Geflect stitch.
Finishing: Processes done after
embroidery is completed. Includes
trimming loose threads, cutting or
tearing away excess backing,
removing facing or topping,
cleaning any stains, pressing or
steaming to remove wrinkles or
hoop marks and packaging for sale
or shipment.
Flagging: Up and down motion of
fabric under action of the needle,
so named because of its
resemblance to a waving flag.
Often caused by improper framing
of goods. Flagging may result in
poor registration, unsatisfactory
stitch formation and birdnesting.
Floppy disk: A flexible disk
permanently sealed in a square
plastic jacket – e.g. HD/DD 3.5"
floppy disk. Used for information
storage ‘off-line’ for security
and/or infrequently used data. Also
used for transferring punched
embroidery design (machine file)
data from computer to embroidery
machine.
Folder: A collection of files and
subfolders that are stored together
on a disk. Part of structure for
organizing files on a disk.

Font: A set of characters of the
same design or style including
letters, numbers and typographical
symbols. Also called ‘alphabet’
even if it includes non-letter
characters. See also Lettering.
Free motion machine
embroidery: See Thread painting
for details.
French knot: A stitch featuring a
raised knotted center.
Fringe: Threads that are cut and
hang loosely from the edge of a
design.
Gradient Fill: artistic stitch effect
that gradually varies stitch spacing
between dense and open fill along
an embroidery object, producing
shading and color effects which are
difficult to achieve manually.
Graphics application: Software
application that creates or allows
you to edit bitmap images and/or
vector graphics. Vector graphics
can be scaled with no loss of
sharpness. Examples of vector
editing programs are Adobe
Illustrator, MacroMedia Freehand
and CorelDRAW®. See also Paint
package and Drawing package.
Grayscale: A grayscale picture is
made up of 254 different shades of
gray, plus solid black and solid
white for a total of 256 different
tones. Black and white
photographs are grayscale.
Grid: Grid lines provide visual
cues to help you accurately place a
design. When you start the
software for the first time, grid
lines appear by default.
Guide run: Series of stitches
used to align embroideries in
multi-hooping situations or to
assist in fabric placement for
appliqué. It is the first appliqué
layer stitched and is used to
position the appliqué fabric on the
background material. See also
Appliqué.
Handle: See Selection Handle.
Hard disk: A device for mass
information storage. Usually the
disk is fixed inside the system unit,
and a second hard disk can be
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added. When you store information
on the hard disk it will remain there
until you delete it. As it has a finite
capacity, file management is
required.
Hardware: Computer
componentry, including monitor,
keyboard, digitizing tablet, printer,
scanner, sewing machine, etc.
Heirloom embroidery:
Embroidered goods designed to be
passed down from generation to
generation.
Hoop position marker: This
indicates the hoop center and
orientation. For multi-hooping, it
also includes the hooping sequence
number.
Hoop template: The physical
clear plastic insert for the
embroidery hoop. These generally
have a 1 cm grid with highlighted
crosshairs for the embroidery
center as well as some additional
alignment lines at 45° through the
center point.
I-beam: One shape taken by the
PC pointer, it indicates that text can
be input at the point selected. The
shape is like the capital letter ‘I’.
Icon: Miniature picture used in
the screen display instead of, or as
well as, text. The file list can be
displayed as icons with the
filenames underneath; the
toolboxes which appear in the left
of the screen are composed of
icons.
Image preparation: Cleaning up
scanned images as input to
embroidery digitizing. This may
involve any one or a combination of
the following techniques: reducing
the number of colors, adding or
emphasizing outlines, removing
noise, dithering or anti-aliasing,
eliminating unnecessary detail,
cropping sections or eliminating
backgrounds.
Input method: See Digitizing
tool for details.
JPG: JPEG file interchange bitmap
image format.
Jump: A frame or hoop
movement without a needle

penetration, commonly used to get
from one point in a design to
another.
Justification: The position of
lettering on the embroidery
baseline.
Lacework: Lacework involves the
use of threads to produce overall
embroidery of full-length fabrics.
Most often used to embellish
women's apparel and home
fashions. It is the most widely used
application for Schiffli machines.
Letters: Initials or name making
up a monogram. Letters of an
alphabet or font.
Lettering: Embroidery using
letters or words. Lettering
commonly called ‘keyboard
lettering’ may be created from
pre-defined font styles or fonts,
allowing variance of size, height,
spacing, density and other
characteristics.
Line art: A drawing with only two
colors – usually black and white.
List box: A single-line dialog that
opens to display a list of choices.
Lockstitch: Commonly referred
to as a lock-down or tack-down
stitch, a lockstitch is formed by
three or four consecutive stitches
of at least a 10-point movement. It
should be used at the end of all
columns, fills and at the end of any
element in your design where jump
stitches will follow, such as color
changes or the end of a design.
May be stitched in a triangle, star
or in a straight line. Lock stitch is
also the name of the type of stitch
formed by the hook and needle of
home sewing machines, as well as
computerized embroidery
machines.
Logo: Name, symbol or
trademark of a company or
organization. Short for logotype.
Looping: Loops on the surface of
embroidery generally caused by
poor top tension or tension
problems. Typically occurs when
polyester top thread has been
improperly tensioned.

Machine file: Machine or ‘stitch’
files are low-level formats for direct
use by embroidery machines. They
contain only stitch coordinates and
machine functions. Machine files
are generally not suited to scaling
because stitches are not
regenerated during rescaling. See
also Outline file.
Magic Wand: Technique for
creating embroidery designs by
automatically digitizing color
blocks in electronic images.
Max/Min stitch length: The
minimum and maximum stitch
lengths allowable in a design
determine the outside limits as
measured between needle
penetration points. They are
governed by the minimum and
maximum frame movements that
the machine can make.
Maximize button: For Windows,
the small box in the center of the
group of three at the right of the
title bar. Click the Maximize button
to enlarge a window to its
maximum size.
Memory: The place in the
computer’s system unit that stores
information while you are working
with it. If you exit without saving
information in memory, it will be
lost.
Menu bar: The menu bar
contains dropdown menus of
commands. Some of the same
commands are available on the
toolbar.
Menu chart: The menu chart
provided with the software lets you
select commands directly from the
digitizing tablet using the puck.
You need to ‘register’ it before use.
Minimize button: For Windows,
the small box to the left of the
group of three at the right of the
title bar. Click the Minimize button
to reduce a window to its minimum
size.
Modal dialog: A dialog which,
while open, prevents the user from
selecting any control or object
outside it. Changes made to
settings inside the dialog are not
effective until it is closed.
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Modeless dialog: A dialog which,
while open, allows the user to
select objects freely. Controls in
the dialog change to conform to
the values of selected objects, or
show relevant system information
when no object is selected.
Changes made to settings in the
dialog may be applied while it
remains open. Other dialogs and
commands may be opened and
used while the modeless dialog
remains open.
Modem: Unit to telegraphically
send computer information from
one computer to another.
Monogram: Embroidered design
composed of one or more letters,
usually the initials of a name. Can
also consist of borders or designs
to mark ownership of items such as
clothing, caps, handkerchiefs, etc.
Multi-appliqué: A type of
appliqué object composed of more
than one piece of fabric and
bordered by various types of
embroidery objects.
Native file format: A design
saved in the original format of the
application you are working with is
said to be the ‘native’ file format. It
can also refer to the machine file
format required by a specific
embroidery machine. When saved
to another format, it is known as a
non-native format.
Needle: Small, slender piece of
steel with a hole for thread and a
point for piercing fabric. A machine
needle differs from a handwork
needle; the machine needle’s eye
is found at its pointed end. Machine
embroidery needles come with
sharp points for piercing heavy,
tightly woven fabric; ball points
which glide between fibers of knit;
and variety of specialty points,
such as wedge points, which are
used for leather.
Needle points: You can view
needle points in a design to check
density or, for instance, to select
stitches for editing.
Needle felting: Needle felting,
also called ‘dry felting’, is a popular
fiber-arts craft that creates felt
without the use of water. The

needles which are used in
industrial felting machines, or
needle felting attachments like
BERNINA needle-punch tool, or
even hand-held tools, have little
barbs with soft shoulders. As these
needles penetrate the layers of
fabric and yarn, they pull fiber
through. Since the barbs face
downwards, they do not pull the
fibres out as the needles exit.
Using a single needle or a small
group of needles, fine details can
be achieved using this technique.
It is popular for 2D and 3D felted
work.
Noise filtering: Noise filtering
means restoring the solid color
blocks of original artwork in
scanned images. This is achieved
by merging different shades into
one solid color. Noise filtering is
important for automatic digitizing
because it makes it easier for the
software to identify solid color
blocks which become embroidery
objects in the resulting design. It
also cleans up blurred or mottled
areas of color.
NORMAL template: Default
template. See also Template.
Object: In embroidery design
terms, an object is an individual
‘element’ of a design. An object has
many properties, such as its size,
color, sequence in the design,
stitch type and values, including
the rules for stitching. See also
Vector object.
Object outline: See Outline file
for details.
Object properties: All
embroidery objects in BERNINA
Embroidery Software contain
defining settings or ‘values’. The
values stored with an object
become its ‘properties’. All objects
have certain properties in common
such as size and position. There
are other, more specific properties
of objects which depend on the
object type.
Object type: An object has a
type, shape, thread type and color,
stitching settings and a position in
the stitching order. The object type
may or may not determine the

intended final appearance of the
stitching.
Ornament: A grouped
embroidery design which may
consist of one or more objects of
any type and one or more colors.
Ornaments may be placed in up to
eight positions around letters, or
centered behind letters.
Outline file: Outline or
‘condensed’ files are high-level
formats which contain object
outlines, object properties and
stitch data. When you open an
outline file in BERNINA Embroidery
Software, corresponding stitch
types, input methods and effects
are applied. Outline files can be
scaled, transformed and reshaped
without affecting stitch density or
quality. See also Machine file.
Outline stitch: Stitch such as
Run or Satin used to outline an
embroidery object.
Overview window: Use the
Overview window to view a
thumbnail of the design. The
window is updated whenever you
make a change, and can be used to
zoom in or pan across the design
window.
Paint package: Software
application that creates or allows
you to edit image files. You can
create lines and filled areas as well
as edit the image pixel-by-pixel
using paintbrushes, erasers and
spraypaint tools. Examples of
image editing programs are Adobe
Photoshop, Jasc PaintShop Pro and
Corel
PHOTO-PAINT® Essentials X6. See
also Graphics application.
Pan: Use Pan to view parts of a
design which are not currently
visible in the design window.
Parallel port: A connection on a
computer, usually LPT1, where you
plug in the cable for a parallel
printer and/or a dongle. Parallel
ports are used to connect some
embroidery machines. They are
named LPT1, LPT2, etc. When you
set up a parallel machine
connection, select the parallel port
and the required protocol, and

BERNINA® Embroidery Software : Reference Manual

418

Glossary
complete the machine setup
procedure.
Paste: To insert an object, which
has previously been placed on the
clipboard by cutting or copying
selected objects, into a design. You
can paste from the clipboard as
many times as you like.
Patch: The fabric piece use in
appliqué.
Patchwork: The composite of
pieces sewn together to form a
large piece, such as a quilt.
Patchwork block: A collection of
patches sewn together, usually
forming a regular shape such as a
rectangle. These are then sewn
together to make a quilt.
Pattern Fill: Pattern Fill is a
decorative fill stitch with which you
can fill Closed Object objects. You
can also create special or three
dimensional effects.
Pattern Run Outline: Patterns
which are linked together along a
digitized line. You can create
decorative outlines using any
pattern from the list.
PCX: PC Paintbrush bitmap image
format.
PDF: Portable Document Format.
Used to view the Online Manual in
Acrobat Reader.

Pixel: A dot. For example, dots of
light that make up the picture on a
computer screen. The more pixels
there are in a given area – that is,
the smaller and closer together
they are – the higher the
resolution.
Pixilation: An effect which occurs
when a bitmap image is enlarged
so that the individual pixels are
obvious to the eye.
Placement line: The first
appliqué layer stitched –
placement lines are used to
position appliqué fabric on
background material. See also
Appliqué.
PNG: Portable Network Graphics
vector graphic format.
Pointer: A part of the screen
display, the pointer can take
various shapes. It is moved by
moving the mouse and can be used
to point to anything on the screen
to make selections and indicate
points for input. It also indicates
when the computer is working and
no input is possible.
Point: Unit of measurement, with
10 points equal to 1 mm.
Port: A connection on a computer
where you plug in the cable that
carries data to another device.
Ports which are used to attach
peripherals have names like COM1
or LPT1 so that you can specify
where the peripherals are
attached.

Program: A computer program or
‘application’ is generally used for a
particular kind of work, such as
word processing or database
management.
Properties: See Object
properties for details.
Protocol: The communications
protocol depends on the
connection type between the
computer and the embroidery
machine. This will be one of:
standard serial, parallel, serial to
parallel converted (DCi), or
interface card.
Puckering: Result of the fabric
being gathered by the stitches.
Many possible causes include
incorrect density, loose hooping,
lack of backing, incorrect tension
or dull needle.
Pull compensation: Digitizing
technique that takes into account
the distortion of a design that will
occur because of the interaction of
thread with fabric. ‘Push and pull’
will cause a circle digitized
perfectly round to sew with the
sides pushed out, resulting in an
egg shape. Generally, it is
necessary to extend horizontal
elements and reduce vertical
elements. See also Automatic pull
compensation.

Peripheral: Any device
connected to a computer which is
to some degree controlled by the
computer – e.g. an embroidery
machine or printer.

Print Preview: Use to preview
design and design information
before printing a Production
Worksheet. The design is displayed
as it will be printed.

Push-Pull: When any stitch is
sewn into fabric, the tension in the
thread between needle
penetrations can build up and
result in a ‘push-pull’ effect. This
can cause distortions in your sewn
designs, poor stitch registration
and even the bunching of the
fabric. The degree of distortion can
be affected by the following
factors: stitch density, fabric type,
underlay, backing type, thread
type and garment orientation. See
also Stitch-Pull.

PhotoSnap: Technique for
creating embroidery designs
directly from photographs and
other grayscale bitmap images.
PhotoSnap designs consist of rows
of Satin or Contour stitches of
varying spacing. The effect
resembles the output of a line
printer.

Production worksheet: The
production worksheet is the link
between the designer and the
embroidery machine operator. It
contains a design preview as well
as essential production
information, including the design
size, the color sequence and any
special instructions.

Quilting: In general, the process
of making a quilt; in specific, the
stitching of patterns into the quilt
layers to add strength and
decoration to the quilt - top,
batting and backing -- to form
decorative patterns on the surface
of the quilt and to hold the layers
together.

Pencil rub: Low-cost way of
producing an embroidery design
sample. Consists literally of a piece
of tracing paper placed over a
stitchout and rubbed lightly with a
pencil to produce an impression of
the embroidery.

Position: The Position indicator
shows position of the design (X, Y)
in the design window.
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RAM: Random Access Memory,
computer chip maintaining
memory.
Read: To open a design which has
been written on a design card or to
an embroidery machine.
Redraw: The screen display is
refreshed. This is useful when
parts of the display have become
obscured in the course of editing.
See also Slow Redraw.
Refresh: See Redraw for details.
Resequence: You can change the
position of a selected object by
cutting it, then pasting it
somewhere else in the stitching
sequence, or by using the
Resequence command. You can
also resequence objects by color or
using the Color Film.
Resizing: See Scaling for details.
Resolution: Resolution
determines the number of dots per
inch (dpi) used to create an image.
The higher the value, the clearer
the image, but the more storage
space required. A resolution of 75
dpi generally produces good
results.
RGB: RGB stands for red, green,
and blue. It is the system used by
computer monitors to create color.
Right-click: To press and release
the right mouse button. See also
Click.
Rotation handles: When you
select an object, selection handles
display at its extremities. If you
click the object again, rotation and
skew handles appear around the
object. Rotation handles appear at
the corners of the object and an
anchor point displays at the
object’s center. Skew handles are
diamond-shaped and appear at the
center-top and bottom of the
object. See also Selection handles.
Roving: Fibers that have been
carded and combed, but not spun.
The term is most commonly heard
in the phrase ‘wool roving’, but
roving can be made out of any kind
of fiber or a mix of fibers.

Run stitch: Run stitch (also
called Walk stitch) places a single
row of stitches along a digitized
line. The needle penetrations are
placed in consecutive order. Run is
generally used for stitching
outlines and connector stitches.
Run stitch length can be set to
automatically vary in order to
follow tight curves.
Satin Special: Satin Special only
affects Satin stitch. When applied,
it breaks any long Satin stitches
into shorter ones. It also
distributes needle penetrations in a
random pattern so that they do not
form a line in the middle of the
shape. Used primarily to prevent
long stitches in wide columns, it
can also be used as an alternative
to Tatami fill.Satin Special looks
more Satin-like and works well
with turning stitches, creating soft
lines and a little more depth.
Satin stitch: Type of fill stitch.
Formed by closely arranged zigzag
stitches, it can be stitched at any
angle and with varying lengths.
The thread is laid across a shape
with a zigzag sewing action where
two stitches form a column. Hence
it is only suitable for small or
narrow shapes. As the stitches are
almost parallel, Satin provides
good coverage. It is often used for
lettering, outlining, and details.
Because there are generally no
needle penetrations breaking up
the fill, Satin stitch creates a glossy
effect.
Save: To store (design)
information in a file. Each time you
save a design, you replace the
previous version using the
filename. You should save your
design frequently.
Scalability: Ability to enlarge or
reduce a design. In expanded
format, most scaling is limited to
10 to 20%, because the stitch
count remains constant despite
final design size. In condensed
formats, on the other hand, scale
changes may be more dramatic,
because stitch count and density
may be varied.
Scaling: Ability to enlarge or
reduce a design in size. In stitch or

‘expanded’ format, most scaling is
limited to ±10% because the stitch
count remains constant despite
final design size. In outline or
‘condensed’ formats, scale
changes may be more dramatic
because stitch count and density
are recalculated.
Scanner: A device that converts
physical images into digital form so
that they can be stored and
manipulated by computer.
Scanning allows you to take
scanned images as a basis for
embroidery design.
Screen calibration: You need to
calibrate your monitor so that
designs at 1:1 scale appear at real
size. Do this when you first install
BERNINA Embroidery Software,
whenever you change your
monitor, or adjust your monitor’s
horizontal or vertical controls.
Screen resolution: See Pixel for
details.
Scroll bar: The bar at the bottom
and right edge of a window whose
contents are not entirely visible.
Each scroll bar contains a small
box, called a scroll box, and two
scroll arrows to allow different
types of scrolling.
Security code: Options in
BERNINA Embroidery Software are
controlled by a security device
installed on the computer. Security
access codes entered into the
software are sent to this security
device. Each security device has a
unique serial number and identity
code.
Security Device: See Dongle for
details.
Select: To highlight an object or
group of objects for the purpose of
editing. Only selected items can be
edited.
Selection handles: Eight small
squares that appear symmetrically
at the corners and edges of a
selected object. Use them to
position and resize objects. See
also Rotation handles.
Selection marquee: The dotted
rectangle that appears when you
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select a range of items. See also
Bounding box.
Sequence: See Stitching
sequence for details.
Serial port: A connection point
on a computer where you plug a
serial communications device such
as a modem. PC serial COM ports
are male connectors, and can be
either 9-pin or 25-pin. They are
named COM1, COM2, COM3, etc.
The number of available ports
limits the number of devices you
can connect. If additional ports are
required, you can add them.
Multi-port serial cards can also be
used.
Serial Port Setup: Here you can
adjust Baud, Data Bits, Stop Bits,
Parity values. These settings must
be identical to those of the
embroidery machine. The type of
handshaking must match the type
of cable you are using.
Short stitch: Digitizing technique
that places shorter stitches in
curves and corners to avoid an
unnecessarily bulky build-up or
stitches.
Shortcut key: A key stroke or a
series of keystrokes you can use to
perform a task instead of using the
mouse. For example, Ctrl+C
actions the Copy command.
Sizing handles: See Selection
handles for details.
Skew handles: See Rotation
handles for details.
Slow Redraw: Use to redraw
your design slowly. Slow Redraw
lets you view the stitching and
color sequence of a design in slow
motion.
Software: Programs, such as MS
Windows and BERNINA Embroidery
Software, which run your
computer.
Specialty fill: A fill stitch
capability that produces a fill with a
‘relief’ or ornament within the
fill-stitch area – e.g. Pattern Fill.
Specialty threads: Threads
designed for effects such as shine,
glitter, iridescence or thickness.

The threads often are made from
synthetic materials including
rayon, mercerized cotton, metallics
and textured nylon.
Status bar: Provides information
about the whole design: number of
stitches, position of the design (X,
Y), number of colors (C), number
of stops (S), etc.
Stemstitch: A detail stitch that
can be used to outline items or fill
in areas. It is used for stems and
vines with other decorative
stitches, or as an outline for Satin
or Stipple fills.
Step stitch: Series of parallel
stitches commonly used to cover
large areas. Different step patterns
can be created by altering the
angle, the length and repeat
sequence of the stitches.
Stippling: A method of creating a
fill made of run stitches which
meander around within a border.
Often used in quilting.
Stitch: A stitch is one needle
penetration; also used to refer to
the thread laid down from one
needle penetration to the next.
Stitch angle: The stitch angle is
the angle the overall stitching
follows within a shape. The shape
may have a fixed stitch angle – e.g.
45° to the horizontal – or multiple
stitch angles.
Stitch bunching: Standard stitch
spacing is calculated at the outside
edge of a shape. With sharp
curves, spacing which provides
adequate coverage on the outside
edge may cause bunching along
the inside edge. This may cause
thread breakage when stitching
out.
Stitch count: Stitch count refers
to the number of stitches in a
design. In BERNINA Embroidery
Software one stitch is considered
one machine revolution. See also
Design properties.
Stitch density: The number of
stitches per given area (or stitch
lines per distance in a fill).

Stitch editing: Digitizing feature
that allows one or more stitches in
a pattern to be deleted or altered.
Stitch length: The distance
between two needle penetration
points. For maximum stitch length,
the length is measured according
to the X and Y co-ordinates,
whichever is greater. Run stitch
length can be set to automatically
vary in order to follow tight curves.
See also Max/Min stitch length.
Stitch-Pull: When any stitch is
sewn into fabric the tension in the
thread between needle
penetrations can build up and
result in Stitch-Pull. Stitch-Pull can
cause distortions in your sewn
designs, poor stitch registration
and even the bunching up of fabric.
The amount of Stitch-Pull that
results in your design can be
affected by the following factors:
Stitch Density, Fabric Type,
Underlay, Backing Type, Thread
Type and Garment Orientation. See
also Push-Pull.
Stitch type: Three basic stitch
types are available with lockstitch
machines – Run, Satin and Tatami
(Weave). BERNINA Embroidery
Software provides many variants
of these.
Stitch spacing: Spacing between
two consecutive needle
penetrations on the same side of a
column. The smaller the value, the
greater the stitch density. For more
open stitching, use larger values.
Stitching defects: Stitching
defects may appear in the form of
gaps between filled areas, fabric
show-through and thread breaks.
These are often caused by
incorrect stitching settings – e.g.
setting pull compensation too small
for the fabric stretchiness.
Stitching sequence: The
embroidery objects in a design
form a stitching sequence. Initially,
objects are stitched in the order in
which they were created. You can
change the position of a selected
object by cutting it, then pasting it
somewhere else in the sequence,
or by using the Resequence
command. You can also
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resequence objects by color or with
the Color Film.
Stock designs: Embroidery
designs readily available on disk or
proprietary embroidery card.
Digitized embroidery designs that
are commercially available for
general use by embroiderers.
System requirements: What
your computer’s hardware and
software, operating together, can
support. System requirements are
printed on software packages,
design disk cards and packs, CDs
and other computer accessories.
You need to know what your
system can and cannot support, as
sometimes a system is not capable
of handling new software without
adding memory or disk space.
Tackdown: Zigzag stitch, placed
after placement and cutting lines,
and used to fix appliqué patches to
the background fabric before cover
stitching is applied.
Tatami stitch: Series of run
stitches, commonly used to cover
large, irregular shapes. Stitches
are laid in rows traversing back and
forth across the shape. These can
be parallel or slightly turning.
Different fill patterns can be
created by varying the stitch
length, angle or sequence. Also
known as Weave stitch.
Template: Special files used to
store styles and default property
settings. Use templates when
digitizing frequently-used design
types to save time re-adjusting the
current property settings.
Tension: Tautness of thread
when forming stitches. Top thread
tension, as well as bobbin thread
tension, need to be correctly set.
Proper thread tension is achieved
when about one third of the thread
showing on the underside of the
fabric on a column stitch is bobbin
thread.
Textured Edge: Use Textured
Edge to create rough edges, to
create shading effects, or to
imitate fur or other fluffy textures
in your design.

Thread: Fine cord or natural or
synthetic material made from two
or more filaments twisted together
and used for stitching. Machine
embroidery threads come in rayon
(high sheen), cotton (duller finish),
polyester (strong and colorfast),
metallics (synthetic core wrapped
with metal foil or thin slivers of
metal foil) and acrylic (sheen
similar to rayon).
Thread chart: Thread charts are
lists of pre-defined thread colors.
They may be based on
commercially available thread
charts, or charts you define
yourself. You can copy colors
between different thread charts to
create your own charts from
existing colors. See also Color
palette.
Thread code: Code is the
identification number of a thread
color in a brand.
Thread painting: The technique
of forming designs on an
embroidery machine by
simultaneously running the
machine and using a freehand
motion with the fabric secured in
an embroidery hoop, allowing the
needle to ‘draw’ on the fabric
surface.
Thread density: Different thread
density systems are used by
different thread manufacturers.
Density A is normal embroidery
thread (density 120/2, or 40).
Density B is thicker, Density C is
finer, and Density D is very fine.
Thread thickness: See Thread
density for details.
Thread type: Embroidery thread
varies in thickness. Types are A, B,
C and D. Stitch density should be
set according to the thread type.
See also Thread thickness.
Tie-ins: Tie-in stitches are
inserted at the start of objects to
prevent stitches from unraveling.
They are inserted inside the shape
on the second stitch. You generally
use them when the previous
connector is trimmed.
Tie-offs: Tie-offs are generally
placed before trims to prevent

stitches from unraveling. You can
adjust connector settings to
automatically add tie-offs under
certain conditions, or add them
manually. You can also include trim
functions so machines with
trimmers cut the thread
automatically.
Title bar: The horizontal bar
located at the top of a window and
containing the title of the window.
On many windows, the title bar
also contains the Control menu box
and Maximize and Minimize
buttons.
Toolbar: Toolbars provide quick
and easy access to BERNINA
Embroidery Software commands.
Click a toolbar button to activate a
command or, where applicable,
right-click to view and adjust its
settings.
Topping: Material hooped or
placed on top of fabrics that have
definable nap or surface texture,
such as corduroy and terry cloth,
prior to embroidery. The topping
compacts the wale or nap and
holds the stitches above it. It
includes a variety of substances,
such as plastic wrap, water-soluble
plastic ‘foil’ and open-weave fabric
that has been chemically treated to
disintegrate with the application of
heat. Also known as ‘facing’.
Travel on Edges: In BERNINA
Embroidery Software, Travel on
Edges effect forces travel runs to
the edges of objects so they do not
show through open or loose
stitching.
Travel run: Travel runs are
typically used to connect segments
of complex shapes. They can also
connect adjacent objects. Because
runs are not trimmed, they may be
visible in the final embroidery. For
this reason, they are less
commonly used as connectors
between objects than jumps. If
objects are adjacent and
connectors will be hidden, they can
be used.
Traveling: You generally check a
design’s stitching sequence by
‘traveling’ through it by stitches,
segments, functions or objects.
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Trims functions: If you are using
a machine with an automatic
trimmer, the trim code causes the
thread to be cut after a tie-off. In
the software, trims are
represented by a triangle with a
small circle at the point where
stitching starts again. The trimmed
connector appears as a dotted line.
You can adjust connector settings
to automatically add trims, or add
them yourself.
Trimmers: Devices built into an
embroidery machine to
automatically trim or cut remaining
thread when the design jumps
from one area to another or
performs a color change.
Trimming: Action of cutting loose
thread, removing backing, etc,
from the final embroidered
product.
TrueType Font: Digital font
technology designed by Apple
Computer and now used by both
Apple and Microsoft in their
operating systems.
Turning stitches: Embroidery
objects can be filled with parallel or
turning stitching. Turning stitches
are columns of stitches which turn
to follow the path defined by the
object outline. By contrast, parallel
stitching traverses the shape in
one direction only – e.g. at 90° to
the horizontal, 45°, or whatever is
set. Objects can be created with
turning stitching already applying,
or multiple stitch angles can be
added later. Turning stitches are
best used with designs containing
complicated, turning shapes such
as trees, animals, or large filled
areas. Turns generally occur at
points where a shape changes
significantly in direction or width.

action that will attach the backing
to the fabric being embroidered. It
also supports the top embroidery
for a more lofty, dimensional look.
Underlay stitches are made up of a
series of single run stitches,
usually with a very short stitch
length, and are digitized manually
or placed automatically under the
column (satin) or fill stitch areas of
your embroidery design.
Underlay margin: The distance
between an object outline and the
edge of the underlay. Increase this
margin to prevent underlay
stitches from extending outside the
cover stitches.
USB port: Universal Serial Bus
Connector, a connection on a
computer where you plug in the
dongle.
Values: The actual settings –
letters and numbers – that you
enter into dialogs. See also Object
properties.
Variable sizing: Ability to scale a
design to different sizes.
Vector graphic: Any image
displayed and stored
mathematically as lines. Vector
‘objects’ include rectangles,
ellipses, curves, polygon stars,
complex stars and perfect-shape
objects created in graphics
applications such as CorelDRAW®.
Unlike raster images, vector
graphics contain geometric shapes
and lines that combine to form the
image. Vector graphics are scalable
without distortion, and usually
form small files. See also Bitmap
image.

TWAIN: Industry standard which
allows devices (such as scanners)
to communicate directly with
design and layout programs. Both
device and program must be
TWAIN-compliant. This lets you
use any TWAIN-compliant scanner
with your software.

Vector object: Vector objects are
derived from vector graphics and
can be created in BERNINA
Embroidery Software or imported.
In BERNINA Embroidery Software
they can be converted to and from
embroidery objects. You can set
general properties such as size and
position, and arrange and
transform them in the same way as
other objects. See also Bitmap.

Underlay: Stitches sewn before
other design elements to help
stabilize fabrics. The stitching

Wave Effect: With Wave Effect
you can curve Closed Fill stitches
along a digitized line to create

flowing stitch effects. The stitches
follow the digitized line but
maintain uniform density and
needle penetration patterns.
Weave stitch: See Tatami stitch
for details.
Weight: When referring to
T-shirts, the three standard weight
divisions are mid-weight/value,
heavyweight/premium, and super
heavyweight.
WMF: Windows Metafile vector
format.
Work piece: A rectangular or
circular reference piece displayed
in the software that can represent
a table cloth, pillow case, table
runner and so on.
Worksheet: The design
worksheet containing information
about the whole design, including
thread colors, amount of thread
used, design size, hoop used and
so on.
Write: To send design information
to an embroidery disk, design card
or embroidery machine for
immediate stitchout or storage.
X/Y coordinates: The horizontal
(X) and vertical (Y) distances on a
graph or computer screen. Use X
values to measure width, and Y
values to measure height.
Zigzag stitch: Zigzag stitch is
similar to Satin but is generally
used where fewer stitches are
required. The needle penetrates
each side of the column, laying the
thread across in an open zigzag
pattern. The density is determined
by the stitch spacing setting. The
settings for Zigzag fill stitches are
stored separately from Zigzag and
Double Zigzag underlay settings.
Zigzag underlay: Zigzag and
Double Zigzag underlay stitching is
used to support wide columns.
Zoom factor: The scale at which
the design is currently displayed.
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INDEX

Numerics
3D effects, creating 259
3D Globe Effect tool 188

A
Absolute 59
Add Folders to Library tool 38
Add Holes tool 169
Add Hoop
Add N Hoops Around tool 307
Right tool 307
tool 307
Add Palette Color tool 78
Add Splitting Line tool 307, 309
Add Stitch Angles tool 163, 164
Add Thread dialog 84
Adjust Image tool 130
Adjust Stitch Spacing dialog 96
Advanced Appliqué tool 219
Align
Bottom tool 146
Centers Horizontally tool 146
Centers tool 146
Centers Vertically tool 146
Left tool 146
Right tool 146
Top tool 146
fonts
See also lettering
AMT templates 92
anchor points, rotation 148
angles, see stitch angles
anti-aliasing 110
Any Shape option 266, 268
Applications
Cross Stitch 31, 258
Quilter 31, 261
appliqué 17
adding to quilts 259
adjusting cover stitch settings 214,
332
Appliqué
tool 213
Appliqué Fabric dialog 216
closed-objects 213
cover stitch values 214, 332
offsetting cover stitches 214
open-object 217
partial cover 217

setting options 57
splitting 139
Appliqué & PunchWork tab 57
appliqué fabric, show 45
Appliqué Properties dialog
Merge Patches Together 222
Place Fabric and Color in
Patches 220
Place Fabric in Patches 220
Recover your original embroidery
objects 225
Remove Fabric from Patches 221
Set Colors Automatically 223
Set Stitch Types Manually 224
Apply closest join while digitizing 59
Apply Current Color tool 78
Arrange toolset
Align Bottom 146
Align Centers 146
Align Centers Horizontally 146
Align Centers Vertically 146
Align Left 146
Align Right 146
Align Top 146
Group 137
Lock 138
Ungroup 138, 190
Unlock All 138
Array tool 151
articles, visualize 10, 47
artistic stitch effects, create 14
artistic view 40
artwork
anti-aliased images 110
automatic conversion 14
bitmap images 109
browse 39
dim 45
dithered images 110
loading 113, 114
prepare 15
preparing for automatic
digitizing 118, 120, 121
scanned images 110
scanning 110
show 45
sources 15
vector drawings 109
Artwork Canvas
mode 22, 113–116
tool 343
Artwork Preparation tool 244

Artwork toolbar
Save Artwork 116
Scan Bitmap 113
As Digitized method 71, 74
Auto Center
to Quilt Block tool 246, 247
to Work Area tool 154, 155
Auto Fit to Quilt Block tool 247
Auto Jump, applying 105
auto kerning 271
auto scroll options 56
Auto Underlay tool 97–99, 274
Auto-Digitize Embroidery dialog 125
Auto-Digitize tool 125, 127
Auto-Digitize toolset
Adjust Image 130
Auto-Digitize 125, 127
Color PhotoStitch 130
Crop Background 115
Insert Artwork 129
Instant Auto-Digitize 125
Magic Wand 128
Magic Wand Block Digitizing 128
Magic Wand Centerline 128
Magic Wand Fill without Holes 128
Matching Method 128
PhotoSnap 131
Touch Up 115, 130
automatic
backup 58
pull compensation 99
save 58
sequencing 142
start and end 95
stitch splitting 67
underlay 97
Automatic Corners tool 104
automatic digitizing 14, 125, 128
adjusting fill stitch settings 127
cleaning up images 118
color reduction 119
creating embroidery designs 125,
127
cropping images 115
image preparation tools 119
noise filtering 119
outline sharpening 119
preparing images 118
preparing non-outlined images 120
preparing outlined images 121
Automatic Stitch Colors dialog 223
Automatically Add Hoops tool 303
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B
backdrops 45
inserting bitmap images 113, 114
loading 113, 114
saving as separate files 116
scanning 113
using as template 108
Background and Display Colors
dialog 46, 47
backgrounds 45
scanning 113
select 46
backing 260
Backstitch
Outline tool 64
outlines 64
settings 64
stitch length 64
backup files 359
baselines
circular lettering 267
custom baseline lettering 268
horizontal lettering 266
lettering 11, 266
multiple baseline lettering 268
reshaping 279
selecting 266
vertical lettering 267
basics
saving designs 26
starting 20
using commands 49, 50
batting 260
Bernina Device Selection
dialog 324–327, 335
Bitmap Artwork Preparation
dialog 120, 122, 125
bitmap images
anti-aliasing 110
automatic digitizing 109
dithered 110
file types 113, 114
inserting 113, 114
saving separately 116
scanned 110
scanning 113
show 45
supported file formats 109
Blackwork
changing patterns 177
Fill tool 177
Outline tool 177
Blackwork Run
break apart 139
tool 103
Blanket Outline tool 62
block digitizing 73
with Block Digitizing tool 73
with multiple angles 73
Block tool 70, 73

block, patchwork 259
bold lettering, making 269
borders
craft stitches 17
creating 170
patchwork 259
boring, display color 48
Break Apart tool 139, 278, 284
buttonhole
add 157
types 158
Buttonholes 18
Buttonhole tool 157
creating a line 158
Settings dialog 158
tool 158

C
Calculate Hoopings
dialog 303, 307
tool 307
Calibrate Screen dialog 5
Calligraphy setting 63, 66, 76
Candlewicking
Fill tool 177, 188
Outline tool 177
Canvas toolbar
Artwork Canvas 22, 113–116, 123,
343
Convert Artwork to
Embroidery 124, 281
Convert Embroidery to Artwork 124
Embroidery Canvas 23, 113, 120,
121, 123, 342
Embroidery Library 23
Show Embroidery 22
Cap corner 105
Carving Stamp docker
Appearance 200
Digitize 199, 202
Use Object 198
Use Pattern 197
Carving Stamp tool 197–202
carving stamps
adding to library 202
changing appearance 200
creating stitch patterns 196
digitizing 199
pre-defined 197
reshaping 201
using objects 198
centering object, with cross-hair
cursor 145
Character Map dialog 283
Circle
CCW option 266, 267
CW option 266, 267
circle baselines 267
circle objects, reshaping 162

clipart, browse 39
cloning objects 137
Closed Freehand tool 75, 76
Closed Object tool 70, 73
closed-object appliqué 213
Closest Join 74
Closest Join method 71
color
place in patches 220
reduction 119
remove from patches 221
Color Blending
applying 189
dialog 189
selecting types 190
setting values 190
spacing values 190
tool 189
Color Film
docker 53, 140
printing 332
resequencing objects 140
selecting color blocks 53
tool 53, 140–??, 190
Color Film toolbar
Optimize Color Changes 142
Sequence by Selects 143
Show Individual Objects 53
Show Objects 140
Color Palette toolbar
Add Palette Color 78
Apply Current Color 78
Color Picker 78
Color Wheel 79
Cycle Used Colors 79
Thread Colors 81, 82
Color PhotoStitch dialog 130
Color PhotoStitch tool 130
Color Picker tool 78
color printer 18
Color Wheel
dialog 79
tool 79
colors
changing 79
changing borer display 48
changing grid display 48
changing object outlines 48
changing stitch display 48
changing thread colors 78
display colors 48
modifying thread values 84
removing from thread charts 83
resequencing by 143
selecting for an object 78
traveling by 44
columns, turning stitching 73
combining
designs 13, 140
objects 135
commands
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selecting 49, 50
toolbars 24
composite objects, splitting 139
connectors
Auto Jump 105
jumps 101
show 40
stitches used to move between
objects 100
tie-ins 101
travel runs 101
Context
Copy to Center 246
Mirror Alternate 155
Number of Copies 155
Quilt Block Margin 246
Work Area Margin 154, 155
Contour Fill tool 182
control points 70
selecting 160
using to reshape objects 161
conversion
bitmap artwork 14
photographs 15
photos to designs 131
tools 124
vector artwork 14
Convert
Artwork to Embroidery tool 124,
281
Embroidery to Artwork tool 124
Convert Selected Designs tool 35
coordinates, setting 145
Copy to Center tool 246
Copy tool 136
copying
cloning objects 137
duplicating objects 136
objects 136
corner stitching, control 104
Couching tool 252
cover stitches
offsetting 214
setting values 214, 332
craft stitches
borders & fills 17
ripple fills 181
Create
Border dialog 296
Fabric dialog 90
Hoop dialog 313
Pattern dialog 212
Stamp Pattern dialog 202
Thread Chart dialog 84
Create Border Set dialog 296
Create Pattern dialog 211
Create Stumpwork Sub-design
tool 236, 237, 239
creating
lettering on-screen 264
monograms 286

textured edges 185
textures with Fancy fill 193
Crop Background tool 115
Cross Stitch
application 31, 258
Fill tool 183
cross stitch 17
borders 257
combination stitches 258
double cross 257
elongated cross 257
fills 183, 256
French knot 257
full cross 256
half cross 256
mini-cross 256
quarter cross 256
three-quarter 256
types 255
upright cross 256
variations 258
cross-hair cursor 145
current
object properties 86
object properties, changing 86
curved lines, making 70
curves, smoothing 163
custom
baselines, creating 268
templates
selecting 26
custom hoops
creating 311
editing 313
cut and paste
objects 136
resequencing 140
Cut Buttonhole Slit tool 157, 158
Cut Closed Border tool 236, 237, 240
cut holes in objects 169
Cut tool 140
cutters, remove overlaps 167
cutting lines
appliqué 213
open-object appliqué 218
Cutwork toolbox
Cut Buttonhole Slit 157, 158
Cut Closed Border 236–240
Digitize Piece 230, 232, 236, 237,
239
Cycle Used Colors tool 79

D
decorative flairs, lettering 12
default object properties 86
Define
Quilt Block tool 245
Work Area dialog 154
Work Area tool 153

Define Quilt Block dialog 245
Delete Hoop tool 307
delete recovery 360
deleting
colors from thread charts 83
objects 136
patterns 212
templates 94
densities, adjusting 96
design colors, changing 79
design dimensions, check 10
design elements
combine 13
reshape 13
sequence 16
transform 13
design information
viewing 48
viewing in Windows Explorer 49, 50
design information, view 48
Design Properties dialog 48
Thread Color 47
Thread Colors 82–84, 334
designs
adding lettering 264
combining 140
creating new 25
opening 25
opening multiple 25
previewing 50, 329
print preview 329
printing 329
resequencing 140
saving 26
saving as images 334
saving multi-hooped 337
sending to machine 334
stabilizing with underlay 97
starting 25
stitching 334
writing to design cards 325
device selection 322
dialogs
Add Thread 84
Adjust Stitch Spacing 96
Applique Fabric 216
Appliqué Properties > Merge
Patches Together 222
Appliqué Properties > Place Fabric
and Color in Patches 220
Appliqué Properties > Recover your
original embroidery objects 225
Appliqué Properties > Remove
Fabric from Patches 221
Appliqué Properties > Set Colors
Automatically 223
Appliqué Properties > Set Stitch
Types Manually 224
Auto-Digitize Embroidery 125
Automatic Stitch Colors 223
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Background and Display Colors 46,
47
Bernina Device Selection 324, 326,
327, 335
Bitmap Artwork Preparation 120,
122, 125
Buttonholes Settings 158
Calculate Hoopings 303, 307
Calibrate Screen 5
Charactor Map 283
Color 47
Color Blending 189
Color PhotoStitch 130
Color Wheel 79
Create Border 296
Create Border Set 296
Create Fabric 90
Create Hoop 313
Create Pattern 211, 212
Create Stamp Pattern 202
Create Thread Chart 84
Define Quilt Block 245
Define Work Area 154
Design Properties 47, 48
Design Properties > Thread
Colors 334
Edit Thread 83
Effects 30
Effects > Gradient Fill 180, 190
Effects > Others 105, 181, 269
Effects > Star & Wave Fill 187
Effects > Underlay 99
Effects >Textured Edge 185
Enter Drive Letter and Path 327
Export 116
Fabric 90
Fabric Settings 91–92
Fill Holes 169
Guide Position 28
Hide Colors 41
Import 114
Manage Fabrics 90
Manage Thread Charts 83
Matching Method 128, 130
Multiple Hoopings 337
New from Template 26
New Pattern Set 212
New Stamp Set 202
Object Not Covered 336, 337
Object Properites > Fill Stitch >
Pattern Fill 208, 209
Object Properites > Outline Stitch >
Pattern Run 205, 206
Object Properties 30, 87
Object Properties > Appliqué 214,
216
Object Properties > Buttonhole 157
Object Properties > Fill Stitch >
Blackwork 177
Object Properties > Fill Stitch >
Candlewicking Fill 178

Object Properties > Fill Stitch >
Contour 182
Object Properties > Fill Stitch >
Cross Stitch 184
Object Properties > Fill Stitch >
Fancy 194
Object Properties > Fill Stitch >
Lacework 178
Object Properties > Fill Stitch >
Pattern Fill 208–210, 212
Object Properties > Fill Stitch >
PhotoSatin 130, 132
Object Properties > Fill Stitch >
Raised Satin 244
Object Properties > Fill Stitch >
Ripple 181
Object Properties > Fill Stitch >
Satin 67
Object Properties > Fill Stitch >
Sculptured Fancy 194
Object Properties > Fill Stitch >
Step 68, 69
Object Properties > Fill Stitch >
Stipple Backstitch 178
Object Properties > Fill Stitch >
Stipple Run 178
Object Properties > Fill Stitch >
Stipple Stemstitch 178
Object Properties >
Lettering 265–270, 273, 274,
282–286
Object Properties > Outline Stitch >
Blacket 63
Object Properties > Outline Stitch >
Blackwork 177
Object Properties > Outline Stitch >
Candlewicking 178
Object Properties > Outline Stitch >
Pattern Run 205–206, 212
Object Properties > Outline Stitch >
Raised Satin 67, 244
Object Properties > Outline Stitch >
Satin 65
Object Properties > Outline Stitch >
Sculpture Run 62
Object Properties > Outline Stitch >
Single 62
Object Properties > Outline Stitch >
Stemstitch 64
Object Properties > Outline Stitch >
Stipple Backstitch 64
Object Properties > Outline Stitch >
Triple 62
Object Properties > Outline Stitch >
Zigzag 63
Object Properties >
PhotoSnap 130, 132
Object Properties >
PunchWork 250
Object Properties > Stitch
Angle 164
Object Properties > Tie-In/Off 102

Open Design 25
Open Options 323
Optimize Color Changes 142
Options 55–59, 301–313
Outlines & Offsets 170, 171
PES Save Options 328
Print Catalog Options 37
Print Design 37, 330
Print Options 330–333
Print Preview 329
Quilting Background 248
Rename Thread Chart 83
Revert to Factory Settings 94
Save As 26
Save as Template 92
Save Design as Bitmap 334
Save Hoop As 313
Save To Template 87
Select Character 283–286
Select Pattern 204–208, 212
Select Source 4
Sequence By Color 143
Smooth Curves 163
Start and End 96
Stitch Player 45
Thread Charts 81
Write to Embroidery
System 324–327, 335
Zoom Factor 43
diamonds, on-point 259
Digitize Piece tool 230–239
Digitize toolset
Advanced Appliqué 219
Auto Applique 213
Block 70, 73
Buttonhole 157
Buttonholes 158
Closed Freehand tool 75, 76
Closed Object 70, 73
Ellipse 70, 71
Freehand Draw Embroidery - Open
Object 75, 76
Lettering 264–270, 272–279,
282–289
Monogramming 290–294
Open Freehand tool 75, 76
Open Object 70, 72
Partial Applique 217
Pattern Stamp 204
PunchWork 250
Rectangle 70, 71
Digitize Wireline tool 237, 240, 241
digitizing
automatic 125
closed shapes using Closed Object
tool 73
columns 73
essentials 60
lines with Open Object 72
manually 60
methods, Open Object tool 72
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selecting a digitizing tool 70
tools 70
Dim Artwork tool 45
display
adapters, checking 361
changing display colors 48
Display dialog 47
distorting lettering, using Elastic
Lettering 288
dithering 110
dockers
Carving Stamp > Appearance 200
Carving Stamp > Digitize 199, 202
Carving Stamp > Use Object 198
Carving Stamp > Use Pattern 197
Color Film 53, 140
Hooping Sequence 333
Monogramming > Borders 294
Monogramming > Designs 290
Monogramming > Letters 291
Monogramming > Ornaments 292
Morphing Effect 190
My Threads 81
Overview Window 42
Rename Pattern Stamp 197
StumpWork Border 240
Double cross stitch 257
Double Run tool 103
Double Zigzag, setting values 99
downloading, designs to cards 325
drawings, see also backdrops
duplicate objects 13, 136

E
Edit Thread dialog 83
Edit toolset
Add Holes 169
Add Stitch Angles 163, 164
Artwork Preparation 244
Blackwork Run 103
Break Apart 139, 278, 284
Color Blending 189
Double Run 103
Fill Holes 169
Outlines & Offsets 170
Quilting Background 248
Remove Holes 169
Remove Overlaps 167
Remove Stitch Angles 163, 164
Stitch Angles 278
Stitch Edit 172–174
editing stitches 173
deleting stitches 174
inserting stitches 173
moving stitches 173
effects
Auto Jump 105
automatic corners 104
Color Blending 189

Effects tool 30, 97
star fill 186
Textured Edge 185
Travel on Edges 180
Effects dialog 30
Gradient Fill 180, 190
Others 105, 181, 269
Star & Wave Fill 187
Textured Edge 185
Underlay 97–99
Effects toolbar
3D Globe Effect 188
Auto Underlay 97–99, 274
Automatic Corners 104
Couching 252
Elastic Fancy Fill 195
Star Fill 186
Textured Edge 185
Wave Fill 187
Elastic Fancy Fill tool 195
Elastic Lettering
distorting lettering 288
editing lettering 289
removing 289
Ellipse tool 70, 71
Elongated cross stitch 257
embroidery
adding to quilts 259
converting to vectors 124
create 15
objects 15
objects, conversion to vectors 123
Embroidery Canvas mode 23, 113,
120, 121, 342
embroidery design formats 319
embroidery elements, view 40
embroidery lettering
converting font 282
converting text 281
Embroidery Library mode 23
embroidery machines
connections 4
setting up 4
End Needle Position 96
end point, setting automatically 95
Enter Drive Letter and Path
dialog 327
entry point, changing 166
errors, unrecoverable 360
Exception Access Violation, resolving
errors 361
excess stitching, remove 13
exit point, changing 166
EXP format 322
Export Design List tool 37, 349
Export dialog 116

dialog 90
Fabric Settings
Lettering 92
Satin 91
Stabilizer 92
Step/Fancy Fill 91
fabrics
change 10
light, medium and dark 259
managing 90
placing in Auto Appliqué 216
placing in patches 220
removing from patches 221
stretch compensation 99
Fancy Fill tool 193
fancy fonts 12
files
backup 359
combining designs 140
PES files 328
Fill Holes
dialog 169
tool 169
fill stitches
adjusting settings 127
block digitizing 73
types 68
fills
adding stitch angles 164
contour 182
craft stitch 17
cross stitch 183, 256
ripple 181
star fill 186
stippling 178
stitch types 68
Find Embroidery Designs tool 38
find threads 82
flair script 12, 285
folk design 17
fonts
convert to embroidery 282
flair script 285
formats, embroidery design 319
frame movement, Auto Jump 105
Free Line
option 266
Vertical option 266–268
Free Line option 266
freehand embroidery 74
freehand lines
creating 75
smoothing 76
Freehand Settings toolbar 75, 76
French knot cross stitch 257
Full cross stitch 256

F

G

Fabric

gaps, offsetting filled holes 169
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garment, visualize design 10
garments, visualize 47
general options, setting 58
General toolbar
Carving Stamp 197–202
Color Film 53, 140–??, 190
Copy 136
Cut 140
Effects 30, 97
Insert Artwork 113, 114, 120, 121,
125, 128, 131
Insert Embroidery 135, 154, 155,
246, 247
Morphing 190
New Blank Design 26
Object Properties 30, 69, 86, 87,
99–102, 158, 212, 214
Open 323
Open Design 25
Options 55–59
Overview Window 42
Paste 136, 140
Print 330
Print Preview 50, 236, 329, 330,
332, 340
Redo 24
Save Design 26
StumpWork Border 230–240
Undo 24
Write to Machine 325–327, 334,
336
generating stitches 25
global changes 10
good
artwork 15
embroidery, rules 9
gradient fills
adjusting settings 180
applying 180
setting values 180
spacing values 180
graphics
digitizing with vectors 123
packages, linking to 115
grid
changing display color 48
displaying 27
setting options 55
Group designs on open and insert 59
Group tool 137
guide patterns, Pattern Fill 210
Guide Position dialog 28

H
Half cross stitch 256
handles, see selection handles
hard disk space, checking 359
hardware
recovering from failure 359

setting up display monitor 5
setting up scanner 4
Hide Colors dialog 41
Hide object properties 59
holes
add holes 169
fill holes 169
hoop centers, setting 301
hooped designs
outputting 335
sending to machine 336
Hooping Sequence docker 333
hoops
changing 301
changing display 27
choosing 10
creating custom hoops 311
displaying 27
editing custom hoops 313
hiding on screen 27
options, setting 56
print hooping sequence 333
selecting 300
showing on screen 27
horizontal baselines, creating 266

I
image preparation
cropping 115
preparing non-outlined images 120
images
cleaning up 118
color reduction 119
cropping 115
editing 115
inserting bitmaps 113, 114
loading 113, 114
noise filtering 119
non-outlined 120
outline sharpening 119
outlined vs non-outlined 118
preparation tools 119
preparing for automatic
digitizing 120, 121
saving bitmaps separately 116
saving designs as 334
scanning bitmaps 113
sharpening/scanning 112
Import dialog 114
individual letters, adjusting 276
information, design 48
Insert Artwork tool 113, 114, 120,
121, 125–131
Insert Embroidery tool 135, 154,
155, 246, 247
inserting
bitmap images 113, 114
one design into another 140
installing, printers 4

Instant Auto-Digitize tool 125
italic lettering
making 269

J
Jump
by Color tool 44
by Object tool 44
to Start/End tool 44
jumps
as connectors 101
Auto Jump 105
setting Jump Length 105
justification, setting lettering 270

K
kaleidoscope effects, create 13
keyboard shortcuts 353

L
Lacework Fill tool 178, 188
Lay out
around Circular Work Area tool 155
to Quilt Block tool 246
to Rectangular Work Area tool 154
layers, remove stitching layers 167
Layout
Auto Center to Quilt Block 246, 247
Auto Center to Work Area 154, 155
Auto Fit to Quilt Block 247
Lay out around Circular Work
Area 155
Lay out to Quilt Block 246
Lay out to Rectangular Work
Area 154
Layout toolset
Define Quilt Block 245
Define Work Area 153
layouts
creating 154, 155, 246
Pattern Fills 210
length
Backstitch 64
jumps 105
preserving long stitches 105
Zigzag and Double Zigzag
stitches 99
lettering
adding to designs 264
adjusting individual letter
spacing 270
adjusting on-screen 270
adjusting overall spacing 270
adjusting Satin stitch settings 287
adjusting spacing 270
adjusting spacing on-screen 270
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advanced 12
applying baselines 265
As Digitized join method 364
auto kerning 271
Bottom Join method 364
changing line spacing 271
Character Map 283
circle baselines 267
Closest Join method 364
converting font to embroidery 282
converting text to embroidery 281
creating monograms 286
creating on-screen 264
creating with the Lettering
dialog 265
custom baselines 268
deleting stitch angles 278
elastic effect 13
entering on-screen 264
entering via dialog 265
fancy fonts 12
fancy lettering 284
horizontal baselines 266
letter justification 270
making bold 269
making italic 269
monograms 12
moving letters along baseline 271
multiple baselines 268
reshaping baseline 279
resizing 273
rotating with Reshape Object 275
scaling 273
scaling with Reshape Object 273
scaling with Select Object 273
selecting symbols 282
size 11
special characters 282
special characters and symbols 282
splitting 139
switching off underlay 274
symbols 282
transforming 275
transforming with Reshape Object
tool 276
transforming with Select
Object 275
vertical baselines 267
See also baselines
See also fonts
lettering designs
create 11
output 11
transforming 275
Lettering tool 264–270, 272–279,
282–289
letters
adjusting 276
adjusting individually 276
adjusting spacing 270
changing colors 279

height, adjusting 274
reshaping 277
spacing, adjusting 270
width, adjusting 274
line spacing, adjusting lettering 271
lines, digitizing with Open Object 72
Lock tool 138

M
Machine & Hoop tab 27, 56
machines
selecting 27
send design 10
send multi-hooped designs 336
stitch out designs 334
Magic Wand
Block Digitizing tool 128
Centerline tool 128
Fill without Holes tool 128
tool 128
Manage Designs toolset
Add Folders to Library 38
Convert Selected Designs 35
Export Design List 37, 349
Find Embroidery Designs 38
New From Selected 34
Open Selected 34
Print Selected 36
Print Selected to Catalog 36
Remove Folder from Library 38
Stitch Selected Design 35
Manage Fabrics dialog 90
Manage Thread Charts dialog 83
manipulating designs, using Color
Film 53
margins, setting for underlays 99
Match All 81
Matching Method dialog 128, 130
Matching Method tool 128
measure distance on-screen 29
Mini cross stitch 256
Mirror
X tool 149
Y tool 149
Mirror Alternate tool 152, 155
mirror objects 13
Mirror-Merge
Array 151
creating wreaths 152
Horizontal tool 149
Horizontal/Vertical tool 149
Mirror Alternate 152
mirroring objects 149
Reflect 151
Vertical tool 149
Wreath 152
Mitre corner 105
modifying objects
changing entry point 162

changing exit point 162
changing radius of Circle 162
grouping 137
mirroring 149
reshape 13
reshaping 160
reshaping circles 162
reshaping circles to ovals 162
rotating 148
scaling 146
skewing
spacing evenly 146
viewing by color 41
monitor
calibrate 5
setting up 5
Monogramming docker
Borders 294
Designs 290
Letters 291
Ornaments 292
Monogramming tools 290–294
monograms 12
creating 286
splitting 139
Morphing Effect docker 190
Morphing tool 190
motif fill
applying 208
filling shapes with 208
moving objects
nudging 145
positioning with X:Y
coordinates 145
with click-and-drag 145
Multi Hooping tab 305
multi-decoration 18
multi-hooped designs
alignment marks 305
creating 303, 307
outputting 335
printing 333
saving as 337
sending to machine 336
Multi-Hooping toolset
Add Hoop 307
Add Hoop Right 307
Add N Hoops Around 307
Add Splitting Line 307, 309
Automatically Add Hoops 303
Calculate Hoopings 307
Delete Hoop 307
Multi-Hooping Options 303, 305
Preview Hoopings 303, 305
Multiple Hoopings dialog 337
multiple stitch angles
adjusting 165
setting 164
with block digitizing 73
My Threads docker 81
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N
needle points
patterns 69
show 40
New Blank Design tool 26
new designs, creating 25
New From Selected tool 34
New from Template dialog 26
New Pattern Set dialog 212
New Stamp Set dialog 202
nodes, reshaping 161
noise filtering, automatic
digitizing 119
nominal stitch angles 163
non-outlined images 120
NORMAL template
reverting 94
using 26
nudging objects into position 145
Number of Copies tool 155

O
object connectors
stitches used to move between
objects 100
Object Not Covered dialog 336, 337
object outlines, change display
color 48
object properties
applying 86
changing defaults 87
changing for an object 87
current 86
default 86
defaults 86
lettering 11
managing 86
saving current 86
saving to a template 93
templates 92
Object Properties dialog 30, 87
Appliqué 214, 216
Buttonhole 157
Fill Stitch > Blackwork 177
Fill Stitch > Candlewicking Fill 178
Fill Stitch > Contour 182
Fill Stitch > Cross Stitch 184
Fill Stitch > Fancy 194
Fill Stitch > Lacework 178
Fill Stitch > Pattern Fill 208–210,
212
Fill Stitch > PhotoSatin 130, 132
Fill Stitch > Raised Satin 244
Fill Stitch > Ripple dialog 181
Fill Stitch > Satin 67
Fill Stitch > Sculptured Fancy 194
Fill Stitch > Step 68, 69
Fill Stitch > Stipple Backstitch 178

Fill Stitch > Stipple Run 178
Fill Stitch > Stipple Stemstitch 178
Lettering 265–270, 273, 274,
282–286
Outline Stitch > Blackwork 177
Outline Stitch > Blanket 63
Outline Stitch > Candlewicking 178
Outline Stitch > Pattern
Run 205–206, 212
Outline Stitch > Raised Satin 67,
244
Outline Stitch > Satin 65
Outline Stitch > Sculpture Run 62
Outline Stitch > Single 62
Outline Stitch > Stipple
Backstitch 64
Outline Stitch > Triple 62
Outline Stitch > Zigzag 63
Outline Stitch tab 62
PhotoSnap 130, 132
PunchWork 250
Stitch Angle 164
Object Properties tool 30, 69, 86, 87,
99–102, 158, 212, 214
object splitting 139
objects
aligning 145
applying underlay 97
changing entry and exit points 166
changing the object properties 87
cloning 137
combining 135
copying and pasting 136
digitizing for appliqué 213
duplicating 136
locking and unlocking 138
mirror merging 149
mirroring 149
reshape 13
reshaping 160
reshaping using control points 161
rotating 148
scaling 147
selecting colors 78
sequence 16
skewing 148
strengthening with underlay 97
traveling by 44
See also modifying objects
offsetting
appliqué cover stitches 214
filled holes (Complex Fill) 169
patterns on-screen 211
Satin outline 66
on-point, diamonds 259
Open
Design dialog 25
Design tool 25
tool 323
open fills
creating 180

See also color blending
Open Freehand tool 75, 76
Open Object tool 70, 72
Open Options dialog 323
Open Selected tool 34
Open StumpWork Sub-design
tool 236–241
open-ended shapes, digitizing 72
opening designs 25
open-object appliqué, creating 217
Optimize Color Changes dialog 142
Optimize Color Changes tool 142
Options dialog
Appliqué & PunchWork 57
Genaral 58–59
Grid tab 55
Hoop 301, 302, 313
Machine & Hoop tab 27, 56
Multi Hooping 305
Remove Overlaps tab 57
Scrolling tab 56
Options tool 55–59
options, setting pointer display 59
outline sharpening, automatic
digitizing 119
Outline Stitch tab 62
outlined images
sharpening 121
vs non-outlined 118
outlines
backstitch 64
Candlewicking Border 177
changing display color 48
creating blanket stitch 62
reinforce (Blackwork Run) 103
Satin 65
selecting objects with 52
single 62
stemstitch 64
Triple 62
Outlines & Offsets
dialog 170, 171
tool 170
outlines, reinforcing 103
outlines, show 40
ovals, reshaping circles 162
overlap stitching, remove 167
overlapping
Backstitch 64
color blending 189
overstitching, compensate for fabric
stretch 99
Overview Window 42

P
Pan tool 43
Partial Applique tool 217
Paste tool 136, 140
patches

BERNINA® Embroidery Software : Reference Manual

431

Index
merging/unmerging 222
placing color 220
placing fabric 220
patchwork 18
blocks 259
quilt designs 259
Pattern Fill
applying 207
filling shapes with 207
layout patterns 210
modifying layouts on-screen 210
settings 209
tool 188, 207, 208
Pattern Outline tool 205
pattern runs
creating 205, 211
reshaping 207
scaling 206
Pattern Stamp tool 204
patterns
adjusting spacing on-screen 211
Blackwork Border 177
Candlewicking Border 177
deleting 212
inserting 205
laying out on-screen (Pattern
Fill) 210
making sets 211, 212
offsetting patterns on-screen 211
outline values 206
patchwork 259
pre-defined 197
scaling patterns on-screen 210
selecting 205
skewing patterns on-screen 211
using objects 198
perspective effects
Color Blending 189
gradient fills 180
PES Save Options dialog 328
photographs, converting to
embroidery 131
PhotoSatin stitch type 131
PhotoSnap tool 131
pictures
editing 115
loading 113, 114
piecing 259
placement lines
appliqué 213
open-object appliqué 218
pointer
interpreting position 58
setting options 59
Polygon Select tool 52
position designs 13
preserve long stitches 105
preset object properties 86
Preview Hoopings tool 303, 305
previewing
designs 50, 329

printed design 329
primary objects, open-object
appliqué 218
Print Catalog Options dialog 37
Print Design dialog 37, 330
Print Options dialog 330–333
Print Preview
dialog 329
tool 50, 236, 329, 330, 332, 340
Print Selected to Catalog tool 36
Print Selected tool 36
Print tool 330
printers 4
installing 4
parallel port 4
setting up 4
printing
combine with embroidery 18
designs 329
problems, solving 357
properties
existing properties 86
lettering 11
of objects 30
pull compensation, apply 99
PunchWork tool 250

Q
Quarter cross stitch 256
Quilt Block Margin tool 246
quilt designs 18
construction 260
opening 31, 258, 261
patchwork 259
sizes 261
Quilter application 31, 261
Quilting Background tool 248

Remove Holes tool 169
Remove Overlaps
options 57
tool 167
Remove Overlaps tab 57
Remove Stitch Angles tool 163, 164
Rename Pattern Stamp dialog 197
Rename Thread Chart dialog 83
resequencing
by color 143
by color using Color Film 140
by selection 143
using Color Film 140
using cut and paste 140
Reshape Object tool 115, 160–166,
186–188, 270–271, 273–279
reshaping
circles 162
letters 277
Pattern Run 207
selecting control points 160
resize
design 10, 13
lettering 273
Revert to Factory Settings dialog 94
revert to original NORMAL
template 94
Ripple Fill tool 181
Rotate
Left tool 148
Right tool 148
rotating objects 13, 148
by click and drag 148
lettering 275
on-screen 148
patterns on-screen 210
runs, create pattern runs 205

S
R
raised embroidery 19
Raised Satin
Fill tool 66, 244
Outline tool 65, 244
read designs from machine 324
recolor lettering 279
recover from software/hardware
failure 359
Rectangle tool 70, 71
Redo tool 24
reference points 70
Reflect tool 151
registration marks,
multihooping 305
reinforce outlines 103
reinforce outlines (Blackwork
Run) 103
Relative 59
Remove Folder from Library tool 38

sample patterns, Pattern Fill 210
sashes, patchwork 259
Satin
appliqué cover stitch 214, 332
fill 66
Fill tool 66
outline 65
Outline tool 65
outline, offsets 66
outline, stitch length 65
Special 67
splitting long stitches 67
Save
Artwork tool 116
Design as Bitmap dialog 334
Design tool 26
Hoop As dialog 313
Stumpwork Sub-design As
tool 238, 240
to Template dialog 87
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Save As dialog 26
Save as Template dialog 92
saving
automatic 58
bitmap images as separate
files 116
designs 26
object properties to a template 93
scaling
lettering 273
lettering with Reshape Object 273
pattern runs 206
patterns on-screen 210
See also scaling objects
scaling objects 146, 147
by click and drag 147
on-screen 147
Scan Bitmap tool 113
scanning
artwork 110, 113
color mode 111
resolution 111
setting up scanners 4
sharpening 112
Scrolling tab 56
scrolling, automatically 56
Sculpture Outline tool 62
Sculptured Fancy Fill tool 193
searching, for threads 82
secondary objects, open-object
appliqué 218
Select Character dialog 283–286
Select Object tool 51–52, 137, 138,
146, 273, 275
Select Pattern dialog 204–208, 212
Select Source dialog 4
selecting
and inserting Pattern Runs 205
fill stitches 68
selecting objects
by color blocks 53
grouping 137
resequencing by selection 143
reshape control points 160
selecting first and last 51
selecting multiple objects 51
selecting the next or previous
object 51
selection marquee 52
using Color Film 53
using point and click 51
using to transform lettering 275
within groups 138
selecting stitches 61, 172
range of stitches 172
several stitches 172
single stitch 172
using outline 173
selection handles
rotating 148
scaling 145

selection marquee, selecting
objects 52
send design to machine 10
sequence
automatic 142
checking 140
resequencing 140
traveling 140
Sequence by Color
dialog 143
Sequence by Selects tool 143
sequence objects 13, 16
sequence of hoops, printing 333
sequence, view stitching 44
sewing, stitch out designs 334
shading effects
Color Blending 189
gradient fills 180
shapes
block digitizing 73
digitizing 73
digitizing using block digitizing 73
shortcut keys 353
Show Appliqué Fabric tool 45, 216,
220
Show Artistic View tool 40, 44
Show Bitmap Artwork tool 45, 113,
128–131
Show Connectors tool 41
Show Embroidery tool 22
Show Grid tool 27, 55
Show Hoop Template tool 27, 301
Show Hoop tool 27, 56, 301–311
Show Individual Objects tool 53
Show measure tooltip 59
Show Needle Points tool 41, 252
Show Objects tool 140
Show Quilt Block tool 245
Show Rulers and Guides tool 28
Show Stitches tool 40, 44, 252, 325,
327
Show StumpWork tool 235–240, 339
Show Vector Artwork tool 45, 114
Show Work Area tool 153
Single Outline tool 62, 252
Single stitch
adjusting length 62
spacing 62
Size +20% tool 147
skewing objects 148
by click and drag 149
patterns on-screen 211
with rotation handles 149
Smooth Curves dialog 163
smoothing freehand lines 76
software failure, recovering 359
Space
Horizontally tool 146
Vertically tool 146
space, checking hard disk 359
spacing

adjusting lettering on-screen 270
adjusting lines 271
adjusting stitch 96
Candlewicking Border 177
objects evenly 146
open spacing (color blending) 189
Satin outline 65
Stemstitch 64
Zigzag and Double Zigzag
stitches 99
special characters
selecting 282
selecting for lettering 282
special effects
with Elastic Lettering 288
splitting
using Satin Special 67
square format 259
stabilizing designs, with underlay 97
star fill effects 186
Star Fill tool 186
Start and End dialog 96
Start Needle Position 96
Stemstitch
Outline tool 64
outlines 64
settings 64
stitch thickness 64
Step
applying patterns 69
Fill tool 68
Stipple
Backstitch Fill tool 178
Fill tool 178
Stemstitch Fill tool 178
stitch angles
adding to fill objects 164
adjusting for individual letters 278
adjusting multiple angles 165
changing in circle objects 163
lettering, deleting 278
setting 163
Stitch Angles tool 278
stitch densities, adjusting 96
Stitch Edit tool 172–174
stitch effects
artistic 14
lettering 12
stitch length
adjusting 62
Satin outline 65
Stemstitch 64
stitch patterns, with carving
stamps 196
Stitch Player dialog 45
Stitch Player tool 45
stitch quality 9, 16
Stitch Selected Design tool 35
stitch sequence, view 44
stitch spacing
adjusting 96
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Candlewicking Border 177
Satin outline 65
Stemstitch 64
stitch thickness
Backstitch 64
stitch types 15
cross stitch 183
fill 68
Pattern Run 207
PhotoSatin 131
Satin 65
Satin fill 66
Satin outline 65
Single 62
Triple 62
stitch values
cover applique 214, 332
stitch type 68
stitches
adjusting Auto Jump length 105
appliqué cover stitches 214, 332
changing 61
changing display color 48
digitizing run stitches 72
editing 173
generating 25
selecting 61, 172
stitch types 68
Zigzag and Double Zigzag
length 99
See also inserting stitches
See also selecting stitches
Stitches toolbar
Backstitch Outline 64
Blackwork Fill 177
Blackwork Outline 177
Blanket Outline 62
Candlewicking Fill 177, 188
Candlewicking Outline 177
Contour Fill 182
Cross Stitch Fill 183
Fancy Fill 193
Lacework Fill 178, 188
Pattern Fill 188, 207, 208
Pattern Run Outline 205
Raised Satin Fill 66, 244
Raised Satin Outline 65, 244
Ripple Fill 181
Satin Fill 66
Satin Outline 65
Sculpture Outline 62
Sculptured Fancy Fill 193
Single Outline 62, 252
Stemstitch Outline 64
Step Fill 68
Stipple Backstitch Fill 178
Stipple Run Fill 178
Stipple Stemstitch Fill 178
Triple Outline 62
Zigzag Outline 63
stitches, show 40

stitching
designs 334
removing overlaps 167
sequence checking 140
stitchouts, simulation 45
strengthening design with
underlay 97
stumpwork 19
StumpWork Border
docker 240
tool 230–240
StumpWork toolset
Create Stumpwork
Sub-design 236–239
Digitize Wireline 237–241
Open StumpWork
Sub-design 236–241
Save Stumpwork Sub-design
As 238, 240
symbols
Character Map 283
selecting 282
selecting for lettering 282
system preferences
automatic backup 58
automatic save 58

T
tablecloths 17
tackdown
appliqué 213
open-object appliqué 218
templates
AMT 92
creating 92
deleting 94
managing 92
modifying 93
overview 92
reverting to original 94
saving object properties 93
using 26
text
adjusting line spacing 271
converting to embroidery 281
Textured Edge tool 185
textured fills, creating 195
thread charts
modifying thread values 84
printing 334
removing thread colors 83
Thread Charts dialog 81
thread charts, manage 83
thread colors
adjust 10
assigning 80
modifying thread values 84
removing from thread charts 83
Thread Colors tool 81, 82
threads

finding 82
searching for 82
threads, matching 81
Three-quarter cross stitch 256
tie-ins as connectors 101
To 37
Touch Up tool 115, 130
transfer paper 18
transform lettering objects 275
Transform toolbar
Mirror X 149
Mirror Y 149
Polygon Select 52
Reshape Object 115, 160–166,
186–188, 270–271, 273–279
Rotate Left 148
Rotate Right 148
Select Object 51–52, 137, 138, 146,
273, 275
Size +20% 147
Size -20% 147
Travel on Edges effect 180
travel runs 101
Travel toolbar
Jump by Color 44
Jump by Object 44
Jump to Start/End 44
traveling
by color 44
overview 140
to end of design 44
to start of design 44
Triple Outline
adjusting length 62
Triple Outline tool 62
Triple stitch, spacing 62
troubleshooting 357
delete recovery 360
exception access violations 361
general problems 361
hardware failure 359
inconsistent output results 361
missing toolbar buttons 361
reverting to factory settings 361
software failure 359
TWAIN scanners 4

U
underlay
Double Zigzag 99
Edge Walk margins 99
margins 99
setting automatic underlay
margins 99
setting margins 99
Step margins 99
switching off for small lettering 274
using to strengthen design 97
Zigzag and Double Zigzag 99
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Zigzag margins 99
underlying stitching, remove 13
Undo tool 24
Ungroup tool 138, 190
Unlock All tool 138
unrecoverable errors 360
Upright cross stitch 256
USB
embroidery machine connection 4
users, first-time and experienced 1

V
values
pull compensation 99
selecting stitch types 68
vector graphics
automatic digitizing 109
converting to embroidery 124
digitizing 123
supported file formats 109
vectors, show 45
vertical baselines, creating 267
view objects by color 41
View toolbar
Dim Artwork 45
Show Appliqué Fabric 45, 216, 220
Show Artistic View 40, 44
Show Bitmap Artwork 45, 113,
128–131
Show Connectors 41
Show Grid 27, 55
Show Hoop 27, 56, 301–311
Show Hoop Template 27, 301
Show Needle Points 41, 252
Show Quilt Block 245
Show Rulers and Guides 28
Show Stitches 40, 44, 252, 325, 327
Show StumpWork 235–240, 339
Show Vector Artwork 45, 114
Show Work Area 153
Stitch Player 45

X
X and Y coordinates, setting 145

Z
Zigzag Outline tool 63
Zigzag underlay, settings 99
Zoom Factor
dialog 43
tool 43
Zoom toolbar
Zoom 1:1 43
Zoom Factor 43

W
Wave Fill tool 187
Windows Explorer, view design
information 49
Work Area Margin tool 154, 155
worksheet, print 10
wreaths
create 13
kaleidoscope effect 152
objects as wreaths 152
Wreath tool 152
write designs to design cards 325
Write to Embroidery System
dialog 324–327, 335
Write to Machine tool 325–327, 334,
336
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